What is the OINA AZtec Extender SDK?

A Developer's Guide to the OINA AZtec Extender SDK
General Overview

The OINA AZtec Extender is an API used by third-party applications that require Ed, EBSD and FSD data from OINA AZtec. More accurately, the OINA AZtec Extender is a facade on top of Mustang that encapsulates aspects of common functionality contained in the Mustang Core, and simplifies it.

Using OINA AZtec Extender, developers can build applications that allow the acquisition of data using Oxford Instruments hardware.

Principal Architecture
What is the Mustang Core?
Contained in an Assembley (.dll) the Mustang Core handles all AZtec data structures, relationships between functions, etc, used in the implementation of the overall software model.
What are Controls?
Contained in an Assembly (.dll) Controls handle all aspects of the AZtec User Interface. For example, the Spectrum Viewer, Image Viewer, etc.
What are Services?

  • Acquisition Service (OINA.Acquisition): Used to process all hardware data associated with Spectrum's Image Maps, etc.

  • Device Manager Service (OINA.Devices): Used to control hardware devices: X- Stream and MICS, X-Max Detector, EBSD Camera, FSD, etc.

  • Extender Service (OINA.Extender): Used with Extender, allowing it to be used remotely.

  • Microscope Control Service (OINA.Mircoscope): Used to hold the latest state of the Microscope.The state is expressed by parameters such as Magnification, Working Distance, Accelerating Voltage and Stage values.

  • Notification Service (OINA.Notification): Enables messages, originating in the Notification Server, to be displayed about AZtec and the state of the hardware.

Working with Simulators

Given that software development using Mustang (including the OINA Extender) must include the use of hardware, then developers are faced with the choice of either using physical devices provided by Oxford Instruments, or specially developed Simulators that mimic the behaviour of the Microscope, Detector, etc. For obvious convenience it is often advisable to use one or more Simulators; allowing software to be created and tested without the need for hardware.

What is being simulated?

In general terms, the interfaces between hardware components used by AZtec are simulated to mimic the interaction between them. Simulators exist separately for Ed, EBSD, FSD, etc, and are used mainly for Scanning, Image Acquisition and Detector Control. Simulators also exist for:

  • The Microscope Image Capture System (MICS), which has interfaces with both AZtec and the Microscope.

  • X-Ray Stream Capture (X-Stream), which has interfaces with both AZtec and the Detector.

The following diagram illustrates a very general configuration. The green "ticks" indicate the interfaces between hardware components that it is possible to simulate.

All available Simulators are delivered by the AZtec installer. Once AZtec has been installed they MUST be enabled (configured) to run in your environment and then switched on (selected).

Making Simulators visible

For AZtec Services to be aware of Simulators they MUST first be enabled (configured) using the OinaApp.config file. This can be found here:

C:\ProgramData\Oxford Instruments NanoAnalysis\Services\OinaApp.config

The OinaApp.config file looks something like this and can be edited using Notepad, or similar:

In the above example, OinaApp.config has been edited and the setting name, "CreateSimulators" has been set to "True". Doing this makes ALL Simulators available for subsequent selection.

Note: Once the OinaApp.config file has been changed then all Services MUST be stopped and re-started using the Task Manager.

Finding Simulators

When all Simulators have been made available for selection, using OinaApp.config, they can be viewed in the AZtec Hardware Configuration App. This lists all devices known to AZtec Services; including Simulators. The AZtec Hardware Configuration App can be found here:

C:\Program Files\Oxford Instruments NanoAnalysis\AZtec\HardwareConfigureApp.exe

When running, the AZtec Hardware Configuration App will display information similar to this:

Selecting Simulators

Using the AZtec Hardware Configuration App click the Use Simulators Button:

Clicking Use Simulators switches on (selects) ALL Simulators. They are now ready to use.

Calibration

When Simulators is selected a calibration XML file is automatically created and placed here: C:\ProgramData\Oxford Instruments NanoAnalysis\Calibration

Limitations

Please note that simulators have been developed by Oxford Instruments to be as accurate as possible. However, given the complexity and constant progression of the equipment involved it may not be possible to mimic the behaviour of hardware exactly in all cases.

Copyright © 2010-2014 Oxford Instruments Nanotechnology Tools Ltd. All rights reserved.


The Extender Assembley

Where is the OINA Extender Assembley?

The Extender Dynamic Link Library (DLL), or Assembley, and all its dependents, are delivered by the AZtec installer. Once installed, the folder containing Extender.dll can be found at:

C:\Program Files (x86)\Oxford Instruments NanoAnalysis\Extender

Adapters and the OINA Extender Assembley

A DLL file each Adapter is, likewise, delivered by the AZtec installer and can be found in the same folder location.

What's in the OINA Extender Assembley?

See: OINA.Extender.dll Developer Reference

Development with the OINA Extender Assembley

The following steps should be observed when developing with the OINA Extender Assembley:

  1. Once delivered, the folder containing the OINA Extender DLL, relevant Adapter DLLs, and dependent DLLs, should be copied to an appropriate location on the development PC.

  2. Create your application, guided by the: OINA.Extender.dll Developer Reference.

  3. Ensure that the folder containing the OINA Extender DLL, relevant Adapter DLLs, and dependent DLLs, is distributed with your application once completed.

Logs and Profiles

The following locations contain Extender log files and shared user profiles exported from AZtec:

  • C:\ProgramData\Oxford Instruments NanoAnalysis\Extender\Logs

  • C:\ProgramData\Oxford Instruments NanoAnalysis\Extender\Profiles

Licensing

  • Note that using the OINI Extender DLL requires a license from Oxford Instruments. A License is also required, per Adapter.


.NET & Visual Studio

Using .NET?

As a developer you must be using .NET 4.5 (4.0) as a minimum to work with the OINA AZtec Extender SDK.

Visual Studio and the OINA Extender Assembley

If using Visual Studio then to use the OINA Extender Assembly you must use Visual Studio to reference Extender.dll. Using the Visual Studio Solution Explorer, click on References, drill down to where the Extender.dll is located and click on it. For example:

Not using Visual Studio?

If you are not using .NET and/or Visual Studio then please refer to the following:

Walkthrough: Creating and Using a Dynamic Link Library


OINA.Extender.dll Developer Reference

Glossary

The OINA Extender DLL, or Assembley, contains the following Namespaces:

  • OINA.Extender: The top-level Namespace. Contains all Extender Classes, Interfaces, Controls and definitions used by the API.
  • OINA.Extender.Acquisition: Top level Class (for Ed, Image, Quant and Xsync) used to control the acquisition of data from a Detector.
  • OINA.Extender.Acquisition.Ed: Defines all Classes and Interfaces used to control the acquisition of data from an Ed Detector.
  • OINA.Extender.Acquisition.Image: Defines all Classes and Interfaces used to control the acquisition of electron images.
  • OINA.Extender.Acquisition.Quant: Defines all Classes and Interfaces used to control the acquisition of Ed data for quant calibration.
  • OINA.Extender.Acquisition.XSync: Defines all Classes and Interfaces used to control the acquisition of Ed data using External Scan Synchronisation.
  • OINA.Extender.Controls: Defines all Classes and Interfaces used for the visual User Controls used by the API.
  • OINA.Extender.Controls.Common: Defines a set of Classes, Interfaces and definitions that are common across all Extender Visual Controls.
  • OINA.Extender.Controls.Image: Defines a set of Classes, Interfaces and definitions used by the Image Viewer Control.
  • OINA.Extender.Controls.Spectrum: Defines a set of Classes, Interfaces and definitions that apply only to Extender Visual Controls that display, or manipulate, Spectrum information.
  • OINA.Extender.Controls.Styles: Defines Classes used to modify the visual style of Extender Controls. Each control available within the Extender Library has its own default visual theme. A Static Class exists for each Control for which the visual style can be modified.
  • OINA.Extender.Data: Top level Class (for Ed, Image and Region) used to describe Data Types available within Extender.
  • OINA.Extender.Data.Image: Defines Classes and Interfaces that describe image Data Types available within Extender.
  • OINA.Extender.Data.Region: Defines Classes and Interfaces that describe acquisition regions.
  • OINA.Extender.DetectorControl: Defines Classes used to interact with Detectors making up a system; and a Detector's associated functionality. An array of Detector Control Objects can be obtained using OINA.Extender.AcquireFactory.CreateEdDetectorControl. Each function for a Detector can be controlled using a Control Interface Object, obtained from the Detector's IEdDetectorControl Interface Object, such as Thermal Control, Shutter Control, Slide Control, and Overload Control.
  • OINA.Extender.MicroscopeControl: Defines Classes and Interfaces that allow for the control of the microscope.
  • OINA.Extender.MonitorControl: Defines Classes and Interfaces that allow the monitoring of hardware.
  • OINA.Extender.Processing: Top level Class (for Ed and Quant) used to process data.
  • OINA.Extender.Processing.Ed: Defines Classes and Interfaces used to process Ed data.
  • OINA.Extender.Processing.Quant: Defines Classes and Interfaces used to process Ed data for quantification.
Limitations

Please note: The OINA AZtec Extender does not facilitate the management of application settings or data.

C# Terms (and definitions) you may find in this document

Assembly

An entity that physically stores data types, including DLL files where code is compiled. A reusable, versionable, and self-describing building block of a run-time application.

Base Class

A class that is inherited by another 'derived' class.

Class

A data type that describes an object. Classes contain both data, and the methods for acting on the data.

Constructor

A special method on a class or struct that initializes the objects of that type.

Derived Class

A class that uses inheritance to gain, augment, or modify the behaviour and data of another 'base' class.

Enumerator

Used to indicate, or change, the state of an object.

Event

A member of a class or struct that sends notifications of a change.

EventArgs Class

The base class for classes that contain event data, and provides a value to use for events that do not include event data.

Exception Class

The base class for all exceptions.

Factory

A type of Class. In Extender, factory classes are used to supply objects used for detector control. Extender uses three Factories:
  • Acquisition: Creates Acquisition Objects.
  • Data: Creates Data Objects.
  • Processing: Creates Processing Objects.
Each factory creates an instance of its type that can be used to perform its specified task without the need to know all the settings required for setting up the instance; or where global settings are applied to every instance of the type.

Field

A data member of a class or struct that is accessed directly.

Inheritance

C# supports inheritance, so a class that derives from another class, known as the base class, inherits the same methods and properties. Inheritance involves base classes and derived classes.

Interface

A type that contains only the signatures of public methods, events, and delegates. An object that inherits the interface must implement all of the methods and events defined in the interface. Classes or structs may inherit any number of interfaces.

Member

A field, property, method, or event declared on a class or struct.

Method

A named code block that provides behavior for a class or struct.

Namespace

A unique identifier for the logical organisation of Data Types.

Object

An instance of a class. An object exists in memory, and has data and methods that act on the data. For more information, see Objects, Classes, and Structs.

Property

A data member accessed by means of an accessor.

Static

A class or method declared as static exists without first being instantiated using the keyword new. Main() is a static method.

Struct

A compound data type that is typically used to contain a few variables that have some logical relationship. Structs can also contain methods and events. Structs do not support inheritance but they do support interfaces. A struct is a value type, while a class is a reference type.
See Also
Glossary


OINA.Extender Namespace

The top-level Namespace (root). Contains all Extender Classes, Interfaces, Controls and definitions used by the API.

OINA Extender Namespace

Classes
 | Class | Description
Public class | AcquireFactory | A Class that supports acquisition, detector control and microscope control.
Public class | DataFactory | A Class used to de-serialise data from a file, or byte array.
Public class | DoNotCaptureAttribute | When added to any type (class, enum, interface, or struct), prevents that type's fields from being included in error reports.
Public class | DoNotCaptureVariablesAttribute | Prevent variables from being included in error reports.
Public class | DoNotEncodeStringsAttribute | Exclude the member from Strings Encoding.
Public class | DoNotMoveAttribute | Prevent the method from being moved to another type if Method Parent Obfuscation is turned on. Note that a method with any attribute is automatically excluded from moving.
Public class | DoNotMoveMethodsAttribute | Prevent all methods in the class from being moved to another type if Method Parent Obfuscation is turned on.
Public class | DoNotObfuscateAttribute | Exclude the member from obfuscation.
Public class | DoNotObfuscateControlFlowAttribute | Do not apply Control Flow Obfuscation.
Public class | DoNotObfuscateTypeAttribute | Exclude the type definition, as well as all the type's members from obfuscation.
Public class | DoNotPruneAttribute | Exclude the type definition from pruning.
Public class | DoNotPruneTypeAttribute | Exclude the type definition, as well as all type's members, from pruning.
Public class | DoNotSealTypeAttribute | Do not seal the type. This overrides the option to automatically seal all possible classes.
Public class | EncodeStringsAttribute | If Strings Encoding is turned on in options, revert the effect of DoNotEncodeStringsAttribute set on a parent member.
Public class | EventArgsT | Generic Event Args with T value.
Public class | EventArgsTKey, TValue | Generic Event Args with TKey, TValue (key-value pair).
Public class | ExcludeFromMemberRefsProxyAttribute | Turn off References Dynamic Proxy for this member.
Public class | ForceObfuscateAttribute | Force element to be obfuscated, even if it was excluded by safety mechanisms. Takes precedence over DoNotObfuscateAttribute!
Public class | ForwardWhenMergedAttribute | When a member must be visible to external assemblies (like plugins) after merging, SmartAssembly creates an embedded assembly forwarding calls to the members marked with this attribute from the original to the merged location.
Public class | InvalidSettingsException | A Class that generates an exception when settings are invalid.
Public class | LicenseCheckException | A Class that defines an exception that is created when there is a problem with the product license.
Public class | ObfuscateControlFlowAttribute | Turn on control flow obfuscation. This overrides the control flow obfuscation level set in the SmartAssembly project.
Public class | ObfuscateNamespaceToAttribute | Force the type to be in a chosen namespace.
Public class | ObfuscateToAttribute | Force the type or field to be renamed to a chosen name. Only rename methods if Advanced Renaming Algorithm is used.
Public class | ProcessingFactory | Class used to process acquired data.
Public class | ReportExceptionAttribute | Report any unhandled exception, which occurs in this method. This is useful for DLLs because it saves you catching exceptions yourself and passing the exceptions to SmartAssembly.
Public class | ReportUsageAttribute | Increment feature usage counter each time the method is ran. By default, the method's name is used for the feature name.
Public class | StayPublicAttribute | Ensure the member remains public after obfuscation. When SmartAssembly obfuscates some members, they may become internal. This can stop other applications from post-processing the obfuscated code.
Interfaces
 | Interface | Description
Public interface | IProductInfo | Gets product versions for the current Extender SDK and related products.
Public interface | IValidationResults | An Interface that defines validation results.


AcquireFactory Class

A Class that supports acquisition, detector control and microscope control.
Inheritance Hierarchy
SystemObject
OINA.ExtenderAcquireFactory

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class AcquireFactory
Public NotInheritable Class AcquireFactory
public ref class AcquireFactory abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AcquireFactory =  class end

The AcquireFactory type exposes the following members.

Methods
Name | Description
CreateEdChordListServer | Creates a server for acquiring ED chordlists.
CreateEdChordListSettings | Creates settings for acquiring ED chordlists.
CreateEdDetectorControl | Creates a controller for controlling Ed detectors.
CreateEdSpectrumServer | Creates a server for acquiring Ed spectra.
CreateEdSpectrumSettings | Creates settings for acquiring Ed spectra.
CreateImageServer | Creates a server for acquiring electron images.
CreateImageSettings | Creates settings for acquiring electron images.
CreateMicroscopeControl | Creates a microscope controller.
CreateMonitorControl | Creates a controller for monitoring hardware.
CreateProductInfo | Creates an instance of the product info class.
CreateQuantCalibrationController | Creates a controller for performing quant calibration.
CreateQuantCalibrationSettings | Creates settings for quant calibration.
CreateXSyncEdMapServer | Creates a server for acquiring Ed Maps using external scan synchronisation.
CreateXSyncEdMapSettings | Creates settings for acquiring Ed Maps using external scan synchronisation.
Top
See Also

Reference

OINA.Extender Namespace


AcquireFactory Methods

The AcquireFactory type exposes the following members.

Methods
Name | Description
CreateEdChordListServer | Creates a server for acquiring ED chordlists.
CreateEdChordListSettings | Creates settings for acquiring ED chordlists.
CreateEdDetectorControl | Creates a controller for controlling Ed detectors.
CreateEdSpectrumServer | Creates a server for acquiring Ed spectra.
CreateEdSpectrumSettings | Creates settings for acquiring Ed spectra.
CreateImageServer | Creates a server for acquiring electron images.
CreateImageSettings | Creates settings for acquiring electron images.
CreateMicroscopeControl | Creates a microscope controller.
CreateMonitorControl | Creates a controller for monitoring hardware.
CreateProductInfo | Creates an instance of the product info class.
CreateQuantCalibrationController | Creates a controller for performing quant calibration.
CreateQuantCalibrationSettings | Creates settings for quant calibration.
CreateXSyncEdMapServer | Creates a server for acquiring Ed Maps using external scan synchronisation.
CreateXSyncEdMapSettings | Creates settings for acquiring Ed Maps using external scan synchronisation.
Top
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateEdChordListServer Method

Creates a server for acquiring ED chordlists.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IEdChordListAcquisitionController CreateEdChordListServer()
Public Shared Function CreateEdChordListServer As IEdChordListAcquisitionController
public:
static IEdChordListAcquisitionController^ CreateEdChordListServer()
static member CreateEdChordListServer : unit -> IEdChordListAcquisitionController

Return Value

Type: IEdChordListAcquisitionController
The ED chordlist acquisition server
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateEdChordListSettings Method

Creates settings for acquiring ED chordlists.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IEdChordListSettings CreateEdChordListSettings()
Public Shared Function CreateEdChordListSettings As IEdChordListSettings
public:
static IEdChordListSettings^ CreateEdChordListSettings()
static member CreateEdChordListSettings : unit -> IEdChordListSettings

Return Value

Type: IEdChordListSettings
The ED chordlist acquisition settings
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateEdDetectorControl Method

Creates a controller for controlling Ed detectors.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IEdDetectorControl[] CreateEdDetectorControl()
Public Shared Function CreateEdDetectorControl As IEdDetectorControl()
public:
static array<IEdDetectorControl^>^ CreateEdDetectorControl()
static member CreateEdDetectorControl : unit -> IEdDetectorControl[]

Return Value

Type: IEdDetectorControl
Detector control for each Ed detector
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateEdSpectrumServer Method

Creates a server for acquiring Ed spectra.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IEdSpectrumAcquisitionController CreateEdSpectrumServer()
Public Shared Function CreateEdSpectrumServer As IEdSpectrumAcquisitionController
public:
static IEdSpectrumAcquisitionController^ CreateEdSpectrumServer()
static member CreateEdSpectrumServer : unit -> IEdSpectrumAcquisitionController

Return Value

Type: IEdSpectrumAcquisitionController
The acquisition server
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateEdSpectrumSettings Method

Creates settings for acquiring Ed spectra.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IEdSpectrumSettings CreateEdSpectrumSettings()
Public Shared Function CreateEdSpectrumSettings As IEdSpectrumSettings
public:
static IEdSpectrumSettings^ CreateEdSpectrumSettings()
static member CreateEdSpectrumSettings : unit -> IEdSpectrumSettings

Return Value

Type: IEdSpectrumSettings
The acquisition settings
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateImageServer Method

Creates a server for acquiring electron images.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IImageAcquisitionController CreateImageServer()
Public Shared Function CreateImageServer As IImageAcquisitionController
public:
static IImageAcquisitionController^ CreateImageServer()
static member CreateImageServer : unit -> IImageAcquisitionController

Return Value

Type: IImageAcquisitionController
The iamge acquisition server
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateImageSettings Method

Creates settings for acquiring electron images.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IImageAcquisitionSettings CreateImageSettings()
Public Shared Function CreateImageSettings As IImageAcquisitionSettings
public:
static IImageAcquisitionSettings^ CreateImageSettings()
static member CreateImageSettings : unit -> IImageAcquisitionSettings

Return Value

Type: IImageAcquisitionSettings
The acquisition settings
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateMicroscopeControl Method

Creates a microscope controller.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IMicroscopeController CreateMicroscopeControl()
Public Shared Function CreateMicroscopeControl As IMicroscopeController
public:
static IMicroscopeController^ CreateMicroscopeControl()
static member CreateMicroscopeControl : unit -> IMicroscopeController

Return Value

Type: IMicroscopeController
MicroscopeControl
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateMonitorControl Method

Creates a controller for monitoring hardware.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IMonitoringController CreateMonitorControl()
Public Shared Function CreateMonitorControl As IMonitoringController
public:
static IMonitoringController^ CreateMonitorControl()
static member CreateMonitorControl : unit -> IMonitoringController

Return Value

Type: IMonitoringController
The MonitorController
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateProductInfo Method

Creates an instance of the product info class.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IProductInfo CreateProductInfo()
Public Shared Function CreateProductInfo As IProductInfo
public:
static IProductInfo^ CreateProductInfo()
static member CreateProductInfo : unit -> IProductInfo

Return Value

Type: IProductInfo
The product info class.
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateQuantCalibrationController Method

Creates a controller for performing quant calibration.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IQuantCalibrationController CreateQuantCalibrationController()
Public Shared Function CreateQuantCalibrationController As IQuantCalibrationController
public:
static IQuantCalibrationController^ CreateQuantCalibrationController()
static member CreateQuantCalibrationController : unit -> IQuantCalibrationController

Return Value

Type: IQuantCalibrationController
The quant calibration controller
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateQuantCalibrationSettings Method

Creates settings for quant calibration.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IQuantCalibrationSettings CreateQuantCalibrationSettings()
Public Shared Function CreateQuantCalibrationSettings As IQuantCalibrationSettings
public:
static IQuantCalibrationSettings^ CreateQuantCalibrationSettings()
static member CreateQuantCalibrationSettings : unit -> IQuantCalibrationSettings

Return Value

Type: IQuantCalibrationSettings
The quant calibration settings
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateXSyncEdMapServer Method

Creates a server for acquiring Ed Maps using external scan synchronisation.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IXSyncEdMapAcquisitionController CreateXSyncEdMapServer()
Public Shared Function CreateXSyncEdMapServer As IXSyncEdMapAcquisitionController
public:
static IXSyncEdMapAcquisitionController^ CreateXSyncEdMapServer()
static member CreateXSyncEdMapServer : unit -> IXSyncEdMapAcquisitionController

Return Value

Type: IXSyncEdMapAcquisitionController
The acquisition server
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


AcquireFactory.CreateXSyncEdMapSettings Method

Creates settings for acquiring Ed Maps using external scan synchronisation.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IXSyncEdMapSettings CreateXSyncEdMapSettings()
Public Shared Function CreateXSyncEdMapSettings As IXSyncEdMapSettings
public:
static IXSyncEdMapSettings^ CreateXSyncEdMapSettings()
static member CreateXSyncEdMapSettings : unit -> IXSyncEdMapSettings

Return Value

Type: IXSyncEdMapSettings
The acquisition settings
See Also

Reference

AcquireFactory Class
OINA.Extender Namespace


DataFactory Class

A Class used to de-serialise data from a file, or byte array.
Inheritance Hierarchy
SystemObject
OINA.ExtenderDataFactory

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class DataFactory
Public NotInheritable Class DataFactory
public ref class DataFactory abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataFactory =  class end

The DataFactory type exposes the following members.

Methods
Name | Description
LoadEdSpectrum | Loads an Ed spectrum from a byte array.
LoadEdSpectrumFromIex | Loads an Ed spectrum from an Inca format (.iex) file.
LoadElectronImage | Loads an electron image from a byte array.
LoadFLSMapImage | Loads a FLS map image from a byte array.
LoadWindowIntegralMapImage | Loads a window integral map image from a byte array.
Top
See Also

Reference

OINA.Extender Namespace


DataFactory Methods

The DataFactory type exposes the following members.

Methods
Name | Description
LoadEdSpectrum | Loads an Ed spectrum from a byte array.
LoadEdSpectrumFromIex | Loads an Ed spectrum from an Inca format (.iex) file.
LoadElectronImage | Loads an electron image from a byte array.
LoadFLSMapImage | Loads a FLS map image from a byte array.
LoadWindowIntegralMapImage | Loads a window integral map image from a byte array.
Top
See Also

Reference

DataFactory Class
OINA.Extender Namespace


DataFactory.LoadEdSpectrum Method

Loads an Ed spectrum from a byte array.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IEdSpectrum LoadEdSpectrum(
    byte[] serializedObject
)
Public Shared Function LoadEdSpectrum (
    serializedObject As Byte()
) As IEdSpectrum
public:
static IEdSpectrum^ LoadEdSpectrum(
    array<unsigned char>^ serializedObject
)
static member LoadEdSpectrum :
        serializedObject : byte[] -> IEdSpectrum

Parameters

serializedObject
Type: SystemByte
The serialized data for Ed spectrum.

Return Value

Type: IEdSpectrum
The spectrum
See Also

Reference

DataFactory Class
OINA.Extender Namespace


DataFactory.LoadEdSpectrumFromIex Method

Loads an Ed spectrum from an Inca format (.iex) file.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IEdSpectrum LoadEdSpectrumFromIex(
    string fileName
)
Public Shared Function LoadEdSpectrumFromIex (
    fileName As String
) As IEdSpectrum
public:
static IEdSpectrum^ LoadEdSpectrumFromIex(
    String^ fileName
)
static member LoadEdSpectrumFromIex :
        fileName : string -> IEdSpectrum

Parameters

fileName
Type: SystemString
The path and filename of the .iex file

Return Value

Type: IEdSpectrum
IEdSpectrum
See Also

Reference

DataFactory Class
OINA.Extender Namespace


DataFactory.LoadElectronImage Method

Loads an electron image from a byte array.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IElectronImage LoadElectronImage(
    byte[] serializedObject
)
Public Shared Function LoadElectronImage (
    serializedObject As Byte()
) As IElectronImage
public:
static IElectronImage^ LoadElectronImage(
    array<unsigned char>^ serializedObject
)
static member LoadElectronImage :
        serializedObject : byte[] -> IElectronImage

Parameters

serializedObject
Type: SystemByte
The serialized data for electron image.

Return Value

Type: IElectronImage
The electron image
See Also

Reference

DataFactory Class
OINA.Extender Namespace


DataFactory.LoadFLSMapImage Method

Loads a FLS map image from a byte array.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IFLSMapImage LoadFLSMapImage(
    byte[] serializedObject
)
Public Shared Function LoadFLSMapImage (
    serializedObject As Byte()
) As IFLSMapImage
public:
static IFLSMapImage^ LoadFLSMapImage(
    array<unsigned char>^ serializedObject
)
static member LoadFLSMapImage :
        serializedObject : byte[] -> IFLSMapImage

Parameters

serializedObject
Type: SystemByte
The serialized data for the FLS map image.

Return Value

Type: IFLSMapImage
The FLS map image
See Also

Reference

DataFactory Class
OINA.Extender Namespace


DataFactory.LoadWindowIntegralMapImage Method

Loads a window integral map image from a byte array.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IWindowIntegralMapImage LoadWindowIntegralMapImage(
    byte[] serializedObject
)
Public Shared Function LoadWindowIntegralMapImage (
    serializedObject As Byte()
) As IWindowIntegralMapImage
public:
static IWindowIntegralMapImage^ LoadWindowIntegralMapImage(
    array<unsigned char>^ serializedObject
)
static member LoadWindowIntegralMapImage :
        serializedObject : byte[] -> IWindowIntegralMapImage

Parameters

serializedObject
Type: SystemByte
The serialized data for the window integral map image.

Return Value

Type: IWindowIntegralMapImage
The window integral map image
See Also

Reference

DataFactory Class
OINA.Extender Namespace


DoNotCaptureAttribute Class

When added to any type (class, enum, interface, or struct), prevents that type's fields from being included in error reports.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderDoNotCaptureAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class DoNotCaptureAttribute : Attribute
Public NotInheritable Class DoNotCaptureAttribute
    Inherits Attribute
public ref class DoNotCaptureAttribute sealed : public Attribute
[<SealedAttribute>]
type DoNotCaptureAttribute =
    class
        inherit Attribute
    end

The DoNotCaptureAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DoNotCaptureAttribute | Initializes a new instance of the DoNotCaptureAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


DoNotCaptureAttribute Constructor

Initializes a new instance of the DoNotCaptureAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DoNotCaptureAttribute()
Public Sub New
public:
DoNotCaptureAttribute()
new : unit -> DoNotCaptureAttribute
See Also

Reference

DoNotCaptureAttribute Class
OINA.Extender Namespace


DoNotCaptureAttribute Properties

The DoNotCaptureAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

DoNotCaptureAttribute Class
OINA.Extender Namespace


DoNotCaptureAttribute Methods

The DoNotCaptureAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoNotCaptureAttribute Class
OINA.Extender Namespace


DoNotCaptureVariablesAttribute Class

Prevent variables from being included in error reports.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderDoNotCaptureVariablesAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class DoNotCaptureVariablesAttribute : Attribute
Public NotInheritable Class DoNotCaptureVariablesAttribute
    Inherits Attribute
public ref class DoNotCaptureVariablesAttribute sealed : public Attribute
[<SealedAttribute>]
type DoNotCaptureVariablesAttribute =
    class
        inherit Attribute
    end

The DoNotCaptureVariablesAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DoNotCaptureVariablesAttribute | Initializes a new instance of the DoNotCaptureVariablesAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


DoNotCaptureVariablesAttribute Constructor

Initializes a new instance of the DoNotCaptureVariablesAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DoNotCaptureVariablesAttribute()
Public Sub New
public:
DoNotCaptureVariablesAttribute()
new : unit -> DoNotCaptureVariablesAttribute
See Also

Reference

DoNotCaptureVariablesAttribute Class
OINA.Extender Namespace


DoNotCaptureVariablesAttribute Properties

The DoNotCaptureVariablesAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

DoNotCaptureVariablesAttribute Class
OINA.Extender Namespace


DoNotCaptureVariablesAttribute Methods

The DoNotCaptureVariablesAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoNotCaptureVariablesAttribute Class
OINA.Extender Namespace


DoNotEncodeStringsAttribute Class

Exclude the member from Strings Encoding.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderDoNotEncodeStringsAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class DoNotEncodeStringsAttribute : Attribute
Public NotInheritable Class DoNotEncodeStringsAttribute
    Inherits Attribute
public ref class DoNotEncodeStringsAttribute sealed : public Attribute
[<SealedAttribute>]
type DoNotEncodeStringsAttribute =
    class
        inherit Attribute
    end

The DoNotEncodeStringsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DoNotEncodeStringsAttribute | Initializes a new instance of the DoNotEncodeStringsAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


DoNotEncodeStringsAttribute Constructor

Initializes a new instance of the DoNotEncodeStringsAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DoNotEncodeStringsAttribute()
Public Sub New
public:
DoNotEncodeStringsAttribute()
new : unit -> DoNotEncodeStringsAttribute
See Also

Reference

DoNotEncodeStringsAttribute Class
OINA.Extender Namespace


DoNotEncodeStringsAttribute Properties

The DoNotEncodeStringsAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

DoNotEncodeStringsAttribute Class
OINA.Extender Namespace


DoNotEncodeStringsAttribute Methods

The DoNotEncodeStringsAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoNotEncodeStringsAttribute Class
OINA.Extender Namespace


DoNotMoveAttribute Class

Prevent the method from being moved to another type if Method Parent Obfuscation is turned on. Note that a method with any attribute is automatically excluded from moving.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderDoNotMoveAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class DoNotMoveAttribute : Attribute
Public NotInheritable Class DoNotMoveAttribute
    Inherits Attribute
public ref class DoNotMoveAttribute sealed : public Attribute
[<SealedAttribute>]
type DoNotMoveAttribute =
    class
        inherit Attribute
    end

The DoNotMoveAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DoNotMoveAttribute | Initializes a new instance of the DoNotMoveAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


DoNotMoveAttribute Constructor

Initializes a new instance of the DoNotMoveAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DoNotMoveAttribute()
Public Sub New
public:
DoNotMoveAttribute()
new : unit -> DoNotMoveAttribute
See Also

Reference

DoNotMoveAttribute Class
OINA.Extender Namespace


DoNotMoveAttribute Properties

The DoNotMoveAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

DoNotMoveAttribute Class
OINA.Extender Namespace


DoNotMoveAttribute Methods

The DoNotMoveAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoNotMoveAttribute Class
OINA.Extender Namespace


DoNotMoveMethodsAttribute Class

Prevent all methods in the class from being moved to another type if Method Parent Obfuscation is turned on.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderDoNotMoveMethodsAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class DoNotMoveMethodsAttribute : Attribute
Public NotInheritable Class DoNotMoveMethodsAttribute
    Inherits Attribute
public ref class DoNotMoveMethodsAttribute sealed : public Attribute
[<SealedAttribute>]
type DoNotMoveMethodsAttribute =
    class
        inherit Attribute
    end

The DoNotMoveMethodsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DoNotMoveMethodsAttribute | Initializes a new instance of the DoNotMoveMethodsAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


DoNotMoveMethodsAttribute Constructor

Initializes a new instance of the DoNotMoveMethodsAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DoNotMoveMethodsAttribute()
Public Sub New
public:
DoNotMoveMethodsAttribute()
new : unit -> DoNotMoveMethodsAttribute
See Also

Reference

DoNotMoveMethodsAttribute Class
OINA.Extender Namespace


DoNotMoveMethodsAttribute Properties

The DoNotMoveMethodsAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

DoNotMoveMethodsAttribute Class
OINA.Extender Namespace


DoNotMoveMethodsAttribute Methods

The DoNotMoveMethodsAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoNotMoveMethodsAttribute Class
OINA.Extender Namespace


DoNotObfuscateAttribute Class

Exclude the member from obfuscation.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderDoNotObfuscateAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class DoNotObfuscateAttribute : Attribute
Public NotInheritable Class DoNotObfuscateAttribute
    Inherits Attribute
public ref class DoNotObfuscateAttribute sealed : public Attribute
[<SealedAttribute>]
type DoNotObfuscateAttribute =
    class
        inherit Attribute
    end

The DoNotObfuscateAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DoNotObfuscateAttribute | Initializes a new instance of the DoNotObfuscateAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


DoNotObfuscateAttribute Constructor

Initializes a new instance of the DoNotObfuscateAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DoNotObfuscateAttribute()
Public Sub New
public:
DoNotObfuscateAttribute()
new : unit -> DoNotObfuscateAttribute
See Also

Reference

DoNotObfuscateAttribute Class
OINA.Extender Namespace


DoNotObfuscateAttribute Properties

The DoNotObfuscateAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

DoNotObfuscateAttribute Class
OINA.Extender Namespace


DoNotObfuscateAttribute Methods

The DoNotObfuscateAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoNotObfuscateAttribute Class
OINA.Extender Namespace


DoNotObfuscateControlFlowAttribute Class

Do not apply Control Flow Obfuscation.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderDoNotObfuscateControlFlowAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class DoNotObfuscateControlFlowAttribute : Attribute
Public NotInheritable Class DoNotObfuscateControlFlowAttribute
    Inherits Attribute
public ref class DoNotObfuscateControlFlowAttribute sealed : public Attribute
[<SealedAttribute>]
type DoNotObfuscateControlFlowAttribute =
    class
        inherit Attribute
    end

The DoNotObfuscateControlFlowAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DoNotObfuscateControlFlowAttribute | Initializes a new instance of the DoNotObfuscateControlFlowAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


DoNotObfuscateControlFlowAttribute Constructor

Initializes a new instance of the DoNotObfuscateControlFlowAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DoNotObfuscateControlFlowAttribute()
Public Sub New
public:
DoNotObfuscateControlFlowAttribute()
new : unit -> DoNotObfuscateControlFlowAttribute
See Also

Reference

DoNotObfuscateControlFlowAttribute Class
OINA.Extender Namespace


DoNotObfuscateControlFlowAttribute Properties

The DoNotObfuscateControlFlowAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

DoNotObfuscateControlFlowAttribute Class
OINA.Extender Namespace


DoNotObfuscateControlFlowAttribute Methods

The DoNotObfuscateControlFlowAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoNotObfuscateControlFlowAttribute Class
OINA.Extender Namespace


DoNotObfuscateTypeAttribute Class

Exclude the type definition, as well as all the type's members from obfuscation.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderDoNotObfuscateTypeAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class DoNotObfuscateTypeAttribute : Attribute
Public NotInheritable Class DoNotObfuscateTypeAttribute
    Inherits Attribute
public ref class DoNotObfuscateTypeAttribute sealed : public Attribute
[<SealedAttribute>]
type DoNotObfuscateTypeAttribute =
    class
        inherit Attribute
    end

The DoNotObfuscateTypeAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DoNotObfuscateTypeAttribute | Initializes a new instance of the DoNotObfuscateTypeAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


DoNotObfuscateTypeAttribute Constructor

Initializes a new instance of the DoNotObfuscateTypeAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DoNotObfuscateTypeAttribute()
Public Sub New
public:
DoNotObfuscateTypeAttribute()
new : unit -> DoNotObfuscateTypeAttribute
See Also

Reference

DoNotObfuscateTypeAttribute Class
OINA.Extender Namespace


DoNotObfuscateTypeAttribute Properties

The DoNotObfuscateTypeAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

DoNotObfuscateTypeAttribute Class
OINA.Extender Namespace


DoNotObfuscateTypeAttribute Methods

The DoNotObfuscateTypeAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoNotObfuscateTypeAttribute Class
OINA.Extender Namespace


DoNotPruneAttribute Class

Exclude the type definition from pruning.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderDoNotPruneAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class DoNotPruneAttribute : Attribute
Public NotInheritable Class DoNotPruneAttribute
    Inherits Attribute
public ref class DoNotPruneAttribute sealed : public Attribute
[<SealedAttribute>]
type DoNotPruneAttribute =
    class
        inherit Attribute
    end

The DoNotPruneAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DoNotPruneAttribute | Initializes a new instance of the DoNotPruneAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


DoNotPruneAttribute Constructor

Initializes a new instance of the DoNotPruneAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DoNotPruneAttribute()
Public Sub New
public:
DoNotPruneAttribute()
new : unit -> DoNotPruneAttribute
See Also

Reference

DoNotPruneAttribute Class
OINA.Extender Namespace


DoNotPruneAttribute Properties

The DoNotPruneAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

DoNotPruneAttribute Class
OINA.Extender Namespace


DoNotPruneAttribute Methods

The DoNotPruneAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoNotPruneAttribute Class
OINA.Extender Namespace


DoNotPruneTypeAttribute Class

Exclude the type definition, as well as all type's members, from pruning.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderDoNotPruneTypeAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class DoNotPruneTypeAttribute : Attribute
Public NotInheritable Class DoNotPruneTypeAttribute
    Inherits Attribute
public ref class DoNotPruneTypeAttribute sealed : public Attribute
[<SealedAttribute>]
type DoNotPruneTypeAttribute =
    class
        inherit Attribute
    end

The DoNotPruneTypeAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DoNotPruneTypeAttribute | Initializes a new instance of the DoNotPruneTypeAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


DoNotPruneTypeAttribute Constructor

Initializes a new instance of the DoNotPruneTypeAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DoNotPruneTypeAttribute()
Public Sub New
public:
DoNotPruneTypeAttribute()
new : unit -> DoNotPruneTypeAttribute
See Also

Reference

DoNotPruneTypeAttribute Class
OINA.Extender Namespace


DoNotPruneTypeAttribute Properties

The DoNotPruneTypeAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

DoNotPruneTypeAttribute Class
OINA.Extender Namespace


DoNotPruneTypeAttribute Methods

The DoNotPruneTypeAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoNotPruneTypeAttribute Class
OINA.Extender Namespace


DoNotSealTypeAttribute Class

Do not seal the type. This overrides the option to automatically seal all possible classes.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderDoNotSealTypeAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class DoNotSealTypeAttribute : Attribute
Public NotInheritable Class DoNotSealTypeAttribute
    Inherits Attribute
public ref class DoNotSealTypeAttribute sealed : public Attribute
[<SealedAttribute>]
type DoNotSealTypeAttribute =
    class
        inherit Attribute
    end

The DoNotSealTypeAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DoNotSealTypeAttribute | Initializes a new instance of the DoNotSealTypeAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


DoNotSealTypeAttribute Constructor

Initializes a new instance of the DoNotSealTypeAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DoNotSealTypeAttribute()
Public Sub New
public:
DoNotSealTypeAttribute()
new : unit -> DoNotSealTypeAttribute
See Also

Reference

DoNotSealTypeAttribute Class
OINA.Extender Namespace


DoNotSealTypeAttribute Properties

The DoNotSealTypeAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

DoNotSealTypeAttribute Class
OINA.Extender Namespace


DoNotSealTypeAttribute Methods

The DoNotSealTypeAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoNotSealTypeAttribute Class
OINA.Extender Namespace


EncodeStringsAttribute Class

If Strings Encoding is turned on in options, revert the effect of DoNotEncodeStringsAttribute set on a parent member.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderEncodeStringsAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class EncodeStringsAttribute : Attribute
Public NotInheritable Class EncodeStringsAttribute
    Inherits Attribute
public ref class EncodeStringsAttribute sealed : public Attribute
[<SealedAttribute>]
type EncodeStringsAttribute =
    class
        inherit Attribute
    end

The EncodeStringsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | EncodeStringsAttribute | Initializes a new instance of the EncodeStringsAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


EncodeStringsAttribute Constructor

Initializes a new instance of the EncodeStringsAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public EncodeStringsAttribute()
Public Sub New
public:
EncodeStringsAttribute()
new : unit -> EncodeStringsAttribute
See Also

Reference

EncodeStringsAttribute Class
OINA.Extender Namespace


EncodeStringsAttribute Properties

The EncodeStringsAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

EncodeStringsAttribute Class
OINA.Extender Namespace


EncodeStringsAttribute Methods

The EncodeStringsAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EncodeStringsAttribute Class
OINA.Extender Namespace


EventArgs(T) Class

Generic Event Args with T value.
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.ExtenderEventArgsT
OINA.Extender.AcquisitionAcquisitionFinishedEventArgsT
OINA.Extender.AcquisitionAcquisitionStartedEventArgsT
OINA.Extender.AcquisitionAcquisitionStartingEventArgsT

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class EventArgs<T> : EventArgs

Public Class EventArgs(Of T)
    Inherits EventArgs
generic<typename T>
public ref class EventArgs : public EventArgs
type EventArgs<'T> =
    class
        inherit EventArgs
    end

Type Parameters

T
The type

The EventArgsT type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


EventArgs(T) Properties

The EventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the value
Top
See Also

Reference

EventArgsT Class
OINA.Extender Namespace


EventArgs(T).Value Property

Gets the value

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public T Value { get; }
Public ReadOnly Property Value As T
    Get
public:
property T Value {
    T get ();
}
member Value : 'T with get

Property Value

Type: T
See Also

Reference

EventArgsT Class
OINA.Extender Namespace


EventArgs(T) Methods

The EventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventArgsT Class
OINA.Extender Namespace


EventArgs(TKey, TValue) Class

Generic Event Args with TKey, TValue (key-value pair).
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.ExtenderEventArgsTKey, TValue
OINA.Extender.MicroscopeControlColumnEventArgs
OINA.Extender.MicroscopeControlStageEventArgs

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class EventArgs<TKey, TValue> : EventArgs

Public Class EventArgs(Of TKey, TValue)
    Inherits EventArgs
generic<typename TKey, typename TValue>
public ref class EventArgs : public EventArgs
type EventArgs<'TKey, 'TValue> =
    class
        inherit EventArgs
    end

Type Parameters

TKey
The key type
TValue
The value type

The EventArgsTKey, TValue type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the key
Public property | Value | Gets the value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


EventArgs(TKey, TValue) Properties

The EventArgsTKey, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the key
Public property | Value | Gets the value
Top
See Also

Reference

EventArgsTKey, TValue Class
OINA.Extender Namespace


EventArgs(TKey, TValue).Key Property

Gets the key

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public TKey Key { get; }
Public ReadOnly Property Key As TKey
    Get
public:
property TKey Key {
    TKey get ();
}
member Key : 'TKey with get

Property Value

Type: TKey
See Also

Reference

EventArgsTKey, TValue Class
OINA.Extender Namespace


EventArgs(TKey, TValue).Value Property

Gets the value

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public TValue Value { get; }
Public ReadOnly Property Value As TValue
    Get
public:
property TValue Value {
    TValue get ();
}
member Value : 'TValue with get

Property Value

Type: TValue
See Also

Reference

EventArgsTKey, TValue Class
OINA.Extender Namespace


EventArgs(TKey, TValue) Methods

The EventArgsTKey, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventArgsTKey, TValue Class
OINA.Extender Namespace


ExcludeFromMemberRefsProxyAttribute Class

Turn off References Dynamic Proxy for this member.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderExcludeFromMemberRefsProxyAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class ExcludeFromMemberRefsProxyAttribute : Attribute
Public NotInheritable Class ExcludeFromMemberRefsProxyAttribute
    Inherits Attribute
public ref class ExcludeFromMemberRefsProxyAttribute sealed : public Attribute
[<SealedAttribute>]
type ExcludeFromMemberRefsProxyAttribute =
    class
        inherit Attribute
    end

The ExcludeFromMemberRefsProxyAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ExcludeFromMemberRefsProxyAttribute | Initializes a new instance of the ExcludeFromMemberRefsProxyAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


ExcludeFromMemberRefsProxyAttribute Constructor

Initializes a new instance of the ExcludeFromMemberRefsProxyAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ExcludeFromMemberRefsProxyAttribute()
Public Sub New
public:
ExcludeFromMemberRefsProxyAttribute()
new : unit -> ExcludeFromMemberRefsProxyAttribute
See Also

Reference

ExcludeFromMemberRefsProxyAttribute Class
OINA.Extender Namespace


ExcludeFromMemberRefsProxyAttribute Properties

The ExcludeFromMemberRefsProxyAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ExcludeFromMemberRefsProxyAttribute Class
OINA.Extender Namespace


ExcludeFromMemberRefsProxyAttribute Methods

The ExcludeFromMemberRefsProxyAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExcludeFromMemberRefsProxyAttribute Class
OINA.Extender Namespace


ForceObfuscateAttribute Class

Force element to be obfuscated, even if it was excluded by safety mechanisms. Takes precedence over DoNotObfuscateAttribute!
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderForceObfuscateAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class ForceObfuscateAttribute : Attribute
Public NotInheritable Class ForceObfuscateAttribute
    Inherits Attribute
public ref class ForceObfuscateAttribute sealed : public Attribute
[<SealedAttribute>]
type ForceObfuscateAttribute =
    class
        inherit Attribute
    end

The ForceObfuscateAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ForceObfuscateAttribute | Force element to be obfuscated, even if it was excluded by safety mechanisms. Takes precedence over DoNotObfuscateAttribute!
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


ForceObfuscateAttribute Constructor

Force element to be obfuscated, even if it was excluded by safety mechanisms. Takes precedence over DoNotObfuscateAttribute!

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ForceObfuscateAttribute(
    bool useHashAsName = false
)
Public Sub New (
    Optional useHashAsName As Boolean = false
)
public:
ForceObfuscateAttribute(
    bool useHashAsName = false
)
new :
        ?useHashAsName : bool
(* Defaults:
        let _useHashAsName = defaultArg useHashAsName false
*)
-> ForceObfuscateAttribute

Parameters

useHashAsName (Optional)
Type: SystemBoolean
If true, uses MD5 hash of a method name prefixed with "_". Otherwise, uses default Name Mangling setting.
See Also

Reference

ForceObfuscateAttribute Class
OINA.Extender Namespace


ForceObfuscateAttribute Properties

The ForceObfuscateAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ForceObfuscateAttribute Class
OINA.Extender Namespace


ForceObfuscateAttribute Methods

The ForceObfuscateAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ForceObfuscateAttribute Class
OINA.Extender Namespace


ForwardWhenMergedAttribute Class

When a member must be visible to external assemblies (like plugins) after merging, SmartAssembly creates an embedded assembly forwarding calls to the members marked with this attribute from the original to the merged location.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderForwardWhenMergedAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class ForwardWhenMergedAttribute : Attribute
Public NotInheritable Class ForwardWhenMergedAttribute
    Inherits Attribute
public ref class ForwardWhenMergedAttribute sealed : public Attribute
[<SealedAttribute>]
type ForwardWhenMergedAttribute =
    class
        inherit Attribute
    end

The ForwardWhenMergedAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ForwardWhenMergedAttribute | Initializes a new instance of the ForwardWhenMergedAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


ForwardWhenMergedAttribute Constructor

Initializes a new instance of the ForwardWhenMergedAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ForwardWhenMergedAttribute()
Public Sub New
public:
ForwardWhenMergedAttribute()
new : unit -> ForwardWhenMergedAttribute
See Also

Reference

ForwardWhenMergedAttribute Class
OINA.Extender Namespace


ForwardWhenMergedAttribute Properties

The ForwardWhenMergedAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ForwardWhenMergedAttribute Class
OINA.Extender Namespace


ForwardWhenMergedAttribute Methods

The ForwardWhenMergedAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ForwardWhenMergedAttribute Class
OINA.Extender Namespace


InvalidSettingsException Class

A Class that generates an exception when settings are invalid.
Inheritance Hierarchy
SystemObject
SystemException
OINA.ExtenderInvalidSettingsException

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InvalidSettingsException : Exception,
    ISerializable
<SerializableAttribute>
Public Class InvalidSettingsException
    Inherits Exception
    Implements ISerializable
[SerializableAttribute]
public ref class InvalidSettingsException : public Exception,
    ISerializable
[<SerializableAttribute>]
type InvalidSettingsException =
    class
        inherit Exception
        interface ISerializable
    end

The InvalidSettingsException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidSettingsException | Initializes a new instance of the InvalidSettingsException class
Public method | InvalidSettingsException(String) | Initializes a new instance of the InvalidSettingsException class
Protected method | InvalidSettingsException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidSettingsException class
Public method | InvalidSettingsException(String, IValidationResults) | Initializes a new instance of the InvalidSettingsException class Constructor that includes the ValidationResults returned from a validation check.
Public method | InvalidSettingsException(String, Exception) | Initializes a new instance of the InvalidSettingsException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValidationResults | Gets or sets the validation results returned from a validation check.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Get object data. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Class information (Overrides ExceptionToString.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OINA.Extender Namespace


InvalidSettingsException Constructor

Overload List
 | Name | Description
Public method | InvalidSettingsException | Initializes a new instance of the InvalidSettingsException class
Public method | InvalidSettingsException(String) | Initializes a new instance of the InvalidSettingsException class
Protected method | InvalidSettingsException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidSettingsException class
Public method | InvalidSettingsException(String, IValidationResults) | Initializes a new instance of the InvalidSettingsException class Constructor that includes the ValidationResults returned from a validation check.
Public method | InvalidSettingsException(String, Exception) | Initializes a new instance of the InvalidSettingsException class
Top
See Also

Reference

InvalidSettingsException Class
OINA.Extender Namespace


InvalidSettingsException Constructor

Initializes a new instance of the InvalidSettingsException class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public InvalidSettingsException()
Public Sub New
public:
InvalidSettingsException()
new : unit -> InvalidSettingsException
See Also

Reference

InvalidSettingsException Class
InvalidSettingsException Overload
OINA.Extender Namespace


InvalidSettingsException Constructor (String)

Initializes a new instance of the InvalidSettingsException class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public InvalidSettingsException(
    string message
)
Public Sub New (
    message As String
)
public:
InvalidSettingsException(
    String^ message
)
new :
        message : string -> InvalidSettingsException

Parameters

message
Type: SystemString
error message
See Also

Reference

InvalidSettingsException Class
InvalidSettingsException Overload
OINA.Extender Namespace


InvalidSettingsException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the InvalidSettingsException class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
protected InvalidSettingsException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
InvalidSettingsException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> InvalidSettingsException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
serialization information
context
Type: System.Runtime.SerializationStreamingContext
streaming context
See Also

Reference

InvalidSettingsException Class
InvalidSettingsException Overload
OINA.Extender Namespace


InvalidSettingsException Constructor (String, IValidationResults)

Initializes a new instance of the InvalidSettingsException class Constructor that includes the ValidationResults returned from a validation check.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public InvalidSettingsException(
    string message,
    IValidationResults validationResults
)
Public Sub New (
    message As String,
    validationResults As IValidationResults
)
public:
InvalidSettingsException(
    String^ message,
    IValidationResults^ validationResults
)
new :
        message : string *
        validationResults : IValidationResults -> InvalidSettingsException

Parameters

message
Type: SystemString
error message
validationResults
Type: OINA.ExtenderIValidationResults
validation results
See Also

Reference

InvalidSettingsException Class
InvalidSettingsException Overload
OINA.Extender Namespace


InvalidSettingsException Constructor (String, Exception)

Initializes a new instance of the InvalidSettingsException class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public InvalidSettingsException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
InvalidSettingsException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> InvalidSettingsException

Parameters

message
Type: SystemString
error message
inner
Type: SystemException
inner exception
See Also

Reference

InvalidSettingsException Class
InvalidSettingsException Overload
OINA.Extender Namespace


InvalidSettingsException Properties

The InvalidSettingsException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValidationResults | Gets or sets the validation results returned from a validation check.
Top
See Also

Reference

InvalidSettingsException Class
OINA.Extender Namespace


InvalidSettingsException.ValidationResults Property

Gets or sets the validation results returned from a validation check.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public IValidationResults ValidationResults { get; set; }
Public Property ValidationResults As IValidationResults
    Get
    Set
public:
property IValidationResults^ ValidationResults {
    IValidationResults^ get ();
    void set (IValidationResults^ value);
}
member ValidationResults : IValidationResults with get, set

Property Value

Type: IValidationResults
See Also

Reference

InvalidSettingsException Class
OINA.Extender Namespace


InvalidSettingsException Methods

The InvalidSettingsException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Get object data. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Class information (Overrides ExceptionToString.)
Top
See Also

Reference

InvalidSettingsException Class
OINA.Extender Namespace


InvalidSettingsException.GetObjectData Method

Get object data.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
serialization information
context
Type: System.Runtime.SerializationStreamingContext
streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

InvalidSettingsException Class
OINA.Extender Namespace


InvalidSettingsException.ToString Method

Class information

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
Type information

Implements

_ExceptionToString
See Also

Reference

InvalidSettingsException Class
OINA.Extender Namespace


InvalidSettingsException Events

The InvalidSettingsException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidSettingsException Class
OINA.Extender Namespace


IProductInfo Interface

Gets product versions for the current Extender SDK and related products.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IProductInfo
Public Interface IProductInfo
public interface class IProductInfo
type IProductInfo =  interface end

The IProductInfo type exposes the following members.

Properties
 | Name | Description
Public property | AztecVersion | Gets the AZtec version.
Public property | ExtenderVersion | Gets the extender version.
Public property | IsAztecInstalled | Gets a value indicating whether AZtec is installed.
Top
See Also

Reference

OINA.Extender Namespace


IProductInfo Properties

The IProductInfo type exposes the following members.

Properties
 | Name | Description
Public property | AztecVersion | Gets the AZtec version.
Public property | ExtenderVersion | Gets the extender version.
Public property | IsAztecInstalled | Gets a value indicating whether AZtec is installed.
Top
See Also

Reference

IProductInfo Interface
OINA.Extender Namespace


IProductInfo.AztecVersion Property

Gets the AZtec version.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Version AztecVersion { get; }
ReadOnly Property AztecVersion As Version
    Get
property Version^ AztecVersion {
    Version^ get ();
}
abstract AztecVersion : Version with get

Property Value

Type: Version
See Also

Reference

IProductInfo Interface
OINA.Extender Namespace


IProductInfo.ExtenderVersion Property

Gets the extender version.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Version ExtenderVersion { get; }
ReadOnly Property ExtenderVersion As Version
    Get
property Version^ ExtenderVersion {
    Version^ get ();
}
abstract ExtenderVersion : Version with get

Property Value

Type: Version
See Also

Reference

IProductInfo Interface
OINA.Extender Namespace


IProductInfo.IsAztecInstalled Property

Gets a value indicating whether AZtec is installed.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsAztecInstalled { get; }
ReadOnly Property IsAztecInstalled As Boolean
    Get
property bool IsAztecInstalled {
    bool get ();
}
abstract IsAztecInstalled : bool with get

Property Value

Type: Boolean
See Also

Reference

IProductInfo Interface
OINA.Extender Namespace


IValidationResults Interface

An Interface that defines validation results.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IValidationResults
Public Interface IValidationResults
public interface class IValidationResults
type IValidationResults =  interface end

The IValidationResults type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | Gets a value indicating whether or not the result is valid.
Public property | ValidationErrors | Gets a list of reasons stating why result is not valid.
Top
See Also

Reference

OINA.Extender Namespace


IValidationResults Properties

The IValidationResults type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | Gets a value indicating whether or not the result is valid.
Public property | ValidationErrors | Gets a list of reasons stating why result is not valid.
Top
See Also

Reference

IValidationResults Interface
OINA.Extender Namespace


IValidationResults.IsValid Property

Gets a value indicating whether or not the result is valid.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsValid { get; }
ReadOnly Property IsValid As Boolean
    Get
property bool IsValid {
    bool get ();
}
abstract IsValid : bool with get

Property Value

Type: Boolean
See Also

Reference

IValidationResults Interface
OINA.Extender Namespace


IValidationResults.ValidationErrors Property

Gets a list of reasons stating why result is not valid.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEnumerable<string> ValidationErrors { get; }
ReadOnly Property ValidationErrors As IEnumerable(Of String)
    Get
property IEnumerable<String^>^ ValidationErrors {
    IEnumerable<String^>^ get ();
}
abstract ValidationErrors : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

IValidationResults Interface
OINA.Extender Namespace


LicenseCheckException Class

A Class that defines an exception that is created when there is a problem with the product license.
Inheritance Hierarchy
SystemObject
SystemException
OINA.ExtenderLicenseCheckException

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class LicenseCheckException : Exception,
    ISerializable
<SerializableAttribute>
Public Class LicenseCheckException
    Inherits Exception
    Implements ISerializable
[SerializableAttribute]
public ref class LicenseCheckException : public Exception,
    ISerializable
[<SerializableAttribute>]
type LicenseCheckException =
    class
        inherit Exception
        interface ISerializable
    end

The LicenseCheckException type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseCheckException | Initializes a new instance of the LicenseCheckException class
Public method | LicenseCheckException(String) | Initializes a new instance of the LicenseCheckException class
Protected method | LicenseCheckException(SerializationInfo, StreamingContext) | Initializes a new instance of the LicenseCheckException class
Public method | LicenseCheckException(String, Exception) | Initializes a new instance of the LicenseCheckException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Get object data (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OINA.Extender Namespace


LicenseCheckException Constructor

Overload List
 | Name | Description
Public method | LicenseCheckException | Initializes a new instance of the LicenseCheckException class
Public method | LicenseCheckException(String) | Initializes a new instance of the LicenseCheckException class
Protected method | LicenseCheckException(SerializationInfo, StreamingContext) | Initializes a new instance of the LicenseCheckException class
Public method | LicenseCheckException(String, Exception) | Initializes a new instance of the LicenseCheckException class
Top
See Also

Reference

LicenseCheckException Class
OINA.Extender Namespace


LicenseCheckException Constructor

Initializes a new instance of the LicenseCheckException class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public LicenseCheckException()
Public Sub New
public:
LicenseCheckException()
new : unit -> LicenseCheckException
See Also

Reference

LicenseCheckException Class
LicenseCheckException Overload
OINA.Extender Namespace


LicenseCheckException Constructor (String)

Initializes a new instance of the LicenseCheckException class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public LicenseCheckException(
    string message
)
Public Sub New (
    message As String
)
public:
LicenseCheckException(
    String^ message
)
new :
        message : string -> LicenseCheckException

Parameters

message
Type: SystemString
error message
See Also

Reference

LicenseCheckException Class
LicenseCheckException Overload
OINA.Extender Namespace


LicenseCheckException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the LicenseCheckException class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
protected LicenseCheckException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
LicenseCheckException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> LicenseCheckException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
serialization information
context
Type: System.Runtime.SerializationStreamingContext
streaming context
See Also

Reference

LicenseCheckException Class
LicenseCheckException Overload
OINA.Extender Namespace


LicenseCheckException Constructor (String, Exception)

Initializes a new instance of the LicenseCheckException class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public LicenseCheckException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
LicenseCheckException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> LicenseCheckException

Parameters

message
Type: SystemString
error message
inner
Type: SystemException
inner exception
See Also

Reference

LicenseCheckException Class
LicenseCheckException Overload
OINA.Extender Namespace


LicenseCheckException Properties

The LicenseCheckException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

LicenseCheckException Class
OINA.Extender Namespace


LicenseCheckException Methods

The LicenseCheckException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Get object data (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

LicenseCheckException Class
OINA.Extender Namespace


LicenseCheckException.GetObjectData Method

Get object data

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
serialization information
context
Type: System.Runtime.SerializationStreamingContext
streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

LicenseCheckException Class
OINA.Extender Namespace


LicenseCheckException Events

The LicenseCheckException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

LicenseCheckException Class
OINA.Extender Namespace


ObfuscateControlFlowAttribute Class

Turn on control flow obfuscation. This overrides the control flow obfuscation level set in the SmartAssembly project.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderObfuscateControlFlowAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class ObfuscateControlFlowAttribute : Attribute
Public NotInheritable Class ObfuscateControlFlowAttribute
    Inherits Attribute
public ref class ObfuscateControlFlowAttribute sealed : public Attribute
[<SealedAttribute>]
type ObfuscateControlFlowAttribute =
    class
        inherit Attribute
    end

The ObfuscateControlFlowAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ObfuscateControlFlowAttribute | Initializes a new instance of the ObfuscateControlFlowAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


ObfuscateControlFlowAttribute Constructor

Initializes a new instance of the ObfuscateControlFlowAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ObfuscateControlFlowAttribute()
Public Sub New
public:
ObfuscateControlFlowAttribute()
new : unit -> ObfuscateControlFlowAttribute
See Also

Reference

ObfuscateControlFlowAttribute Class
OINA.Extender Namespace


ObfuscateControlFlowAttribute Properties

The ObfuscateControlFlowAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ObfuscateControlFlowAttribute Class
OINA.Extender Namespace


ObfuscateControlFlowAttribute Methods

The ObfuscateControlFlowAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ObfuscateControlFlowAttribute Class
OINA.Extender Namespace


ObfuscateNamespaceToAttribute Class

Force the type to be in a chosen namespace.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderObfuscateNamespaceToAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class ObfuscateNamespaceToAttribute : Attribute
Public NotInheritable Class ObfuscateNamespaceToAttribute
    Inherits Attribute
public ref class ObfuscateNamespaceToAttribute sealed : public Attribute
[<SealedAttribute>]
type ObfuscateNamespaceToAttribute =
    class
        inherit Attribute
    end

The ObfuscateNamespaceToAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ObfuscateNamespaceToAttribute | Force the type to be in a chosen namespace.
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


ObfuscateNamespaceToAttribute Constructor

Force the type to be in a chosen namespace.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ObfuscateNamespaceToAttribute(
    string newName
)
Public Sub New (
    newName As String
)
public:
ObfuscateNamespaceToAttribute(
    String^ newName
)
new :
        newName : string -> ObfuscateNamespaceToAttribute

Parameters

newName
Type: SystemString
Name of the namespace the type should be in.
See Also

Reference

ObfuscateNamespaceToAttribute Class
OINA.Extender Namespace


ObfuscateNamespaceToAttribute Properties

The ObfuscateNamespaceToAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ObfuscateNamespaceToAttribute Class
OINA.Extender Namespace


ObfuscateNamespaceToAttribute Methods

The ObfuscateNamespaceToAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ObfuscateNamespaceToAttribute Class
OINA.Extender Namespace


ObfuscateToAttribute Class

Force the type or field to be renamed to a chosen name. Only rename methods if Advanced Renaming Algorithm is used.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderObfuscateToAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class ObfuscateToAttribute : Attribute
Public NotInheritable Class ObfuscateToAttribute
    Inherits Attribute
public ref class ObfuscateToAttribute sealed : public Attribute
[<SealedAttribute>]
type ObfuscateToAttribute =
    class
        inherit Attribute
    end

The ObfuscateToAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ObfuscateToAttribute | Force the type or field to be renamed to a chosen name. Only rename methods if Advanced Renaming Algorithm is used.
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


ObfuscateToAttribute Constructor

Force the type or field to be renamed to a chosen name. Only rename methods if Advanced Renaming Algorithm is used.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ObfuscateToAttribute(
    string newName
)
Public Sub New (
    newName As String
)
public:
ObfuscateToAttribute(
    String^ newName
)
new :
        newName : string -> ObfuscateToAttribute

Parameters

newName
Type: SystemString
Name to rename the type or field to.
See Also

Reference

ObfuscateToAttribute Class
OINA.Extender Namespace


ObfuscateToAttribute Properties

The ObfuscateToAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ObfuscateToAttribute Class
OINA.Extender Namespace


ObfuscateToAttribute Methods

The ObfuscateToAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ObfuscateToAttribute Class
OINA.Extender Namespace


ProcessingFactory Class

Class used to process acquired data.
Inheritance Hierarchy
SystemObject
OINA.ExtenderProcessingFactory

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class ProcessingFactory
Public NotInheritable Class ProcessingFactory
public ref class ProcessingFactory abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ProcessingFactory =  class end

The ProcessingFactory type exposes the following members.

Methods
Name | Description
CreateAutoIdSettings | Creates AutoId settings
CreateEdMapFLSProcessor | Creates an Ed Map FLS processor
CreateEdMapFLSSettings | Creates settings for the FLS processing of Ed maps
CreateSEMQuantSettings | Creates Quant settings for detectors on SEMs
CreateSpectrumProcessing | Creates instance of class that can be used for spectrum processing.
Top
See Also

Reference

OINA.Extender Namespace


ProcessingFactory Methods

The ProcessingFactory type exposes the following members.

Methods
Name | Description
CreateAutoIdSettings | Creates AutoId settings
CreateEdMapFLSProcessor | Creates an Ed Map FLS processor
CreateEdMapFLSSettings | Creates settings for the FLS processing of Ed maps
CreateSEMQuantSettings | Creates Quant settings for detectors on SEMs
CreateSpectrumProcessing | Creates instance of class that can be used for spectrum processing.
Top
See Also

Reference

ProcessingFactory Class
OINA.Extender Namespace


ProcessingFactory.CreateAutoIdSettings Method

Creates AutoId settings

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IAutoIdSettings CreateAutoIdSettings()
Public Shared Function CreateAutoIdSettings As IAutoIdSettings
public:
static IAutoIdSettings^ CreateAutoIdSettings()
static member CreateAutoIdSettings : unit -> IAutoIdSettings

Return Value

Type: IAutoIdSettings
The AutoId settings
See Also

Reference

ProcessingFactory Class
OINA.Extender Namespace


ProcessingFactory.CreateEdMapFLSProcessor Method

Creates an Ed Map FLS processor

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IEdMapFLSProcessor CreateEdMapFLSProcessor()
Public Shared Function CreateEdMapFLSProcessor As IEdMapFLSProcessor
public:
static IEdMapFLSProcessor^ CreateEdMapFLSProcessor()
static member CreateEdMapFLSProcessor : unit -> IEdMapFLSProcessor

Return Value

Type: IEdMapFLSProcessor
The map processor
See Also

Reference

ProcessingFactory Class
OINA.Extender Namespace


ProcessingFactory.CreateEdMapFLSSettings Method

Creates settings for the FLS processing of Ed maps

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IEdMapFLSSettings CreateEdMapFLSSettings()
Public Shared Function CreateEdMapFLSSettings As IEdMapFLSSettings
public:
static IEdMapFLSSettings^ CreateEdMapFLSSettings()
static member CreateEdMapFLSSettings : unit -> IEdMapFLSSettings

Return Value

Type: IEdMapFLSSettings
The settings
See Also

Reference

ProcessingFactory Class
OINA.Extender Namespace


ProcessingFactory.CreateSEMQuantSettings Method

Creates Quant settings for detectors on SEMs

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static ISEMQuantSettings CreateSEMQuantSettings()
Public Shared Function CreateSEMQuantSettings As ISEMQuantSettings
public:
static ISEMQuantSettings^ CreateSEMQuantSettings()
static member CreateSEMQuantSettings : unit -> ISEMQuantSettings

Return Value

Type: ISEMQuantSettings
The SEM Quant settings
See Also

Reference

ProcessingFactory Class
OINA.Extender Namespace


ProcessingFactory.CreateSpectrumProcessing Method

Creates instance of class that can be used for spectrum processing.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static IEdSpectrumProcessing CreateSpectrumProcessing()
Public Shared Function CreateSpectrumProcessing As IEdSpectrumProcessing
public:
static IEdSpectrumProcessing^ CreateSpectrumProcessing()
static member CreateSpectrumProcessing : unit -> IEdSpectrumProcessing

Return Value

Type: IEdSpectrumProcessing
The spectrum processing instance
See Also

Reference

ProcessingFactory Class
OINA.Extender Namespace


ReportExceptionAttribute Class

Report any unhandled exception, which occurs in this method. This is useful for DLLs because it saves you catching exceptions yourself and passing the exceptions to SmartAssembly.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderReportExceptionAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class ReportExceptionAttribute : Attribute
Public NotInheritable Class ReportExceptionAttribute
    Inherits Attribute
public ref class ReportExceptionAttribute sealed : public Attribute
[<SealedAttribute>]
type ReportExceptionAttribute =
    class
        inherit Attribute
    end

The ReportExceptionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ReportExceptionAttribute | Initializes a new instance of the ReportExceptionAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


ReportExceptionAttribute Constructor

Initializes a new instance of the ReportExceptionAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ReportExceptionAttribute()
Public Sub New
public:
ReportExceptionAttribute()
new : unit -> ReportExceptionAttribute
See Also

Reference

ReportExceptionAttribute Class
OINA.Extender Namespace


ReportExceptionAttribute Properties

The ReportExceptionAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ReportExceptionAttribute Class
OINA.Extender Namespace


ReportExceptionAttribute Methods

The ReportExceptionAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReportExceptionAttribute Class
OINA.Extender Namespace


ReportUsageAttribute Class

Increment feature usage counter each time the method is ran. By default, the method's name is used for the feature name.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderReportUsageAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class ReportUsageAttribute : Attribute
Public NotInheritable Class ReportUsageAttribute
    Inherits Attribute
public ref class ReportUsageAttribute sealed : public Attribute
[<SealedAttribute>]
type ReportUsageAttribute =
    class
        inherit Attribute
    end

The ReportUsageAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ReportUsageAttribute | Increment feature usage counter each time the method is ran. By default, the method's name is used for the feature name.
Public method | ReportUsageAttribute(String) | Increment feature usage counter each time the method is ran. By default, the method's name is used for the feature name.
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


ReportUsageAttribute Constructor

Overload List
 | Name | Description
Public method | ReportUsageAttribute | Increment feature usage counter each time the method is ran. By default, the method's name is used for the feature name.
Public method | ReportUsageAttribute(String) | Increment feature usage counter each time the method is ran. By default, the method's name is used for the feature name.
Top
See Also

Reference

ReportUsageAttribute Class
OINA.Extender Namespace


ReportUsageAttribute Constructor

Increment feature usage counter each time the method is ran. By default, the method's name is used for the feature name.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ReportUsageAttribute()
Public Sub New
public:
ReportUsageAttribute()
new : unit -> ReportUsageAttribute
See Also

Reference

ReportUsageAttribute Class
ReportUsageAttribute Overload
OINA.Extender Namespace


ReportUsageAttribute Constructor (String)

Increment feature usage counter each time the method is ran. By default, the method's name is used for the feature name.

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ReportUsageAttribute(
    string featureName
)
Public Sub New (
    featureName As String
)
public:
ReportUsageAttribute(
    String^ featureName
)
new :
        featureName : string -> ReportUsageAttribute

Parameters

featureName
Type: SystemString
The supplied string is used for the feature name.
See Also

Reference

ReportUsageAttribute Class
ReportUsageAttribute Overload
OINA.Extender Namespace


ReportUsageAttribute Properties

The ReportUsageAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ReportUsageAttribute Class
OINA.Extender Namespace


ReportUsageAttribute Methods

The ReportUsageAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReportUsageAttribute Class
OINA.Extender Namespace


StayPublicAttribute Class

Ensure the member remains public after obfuscation. When SmartAssembly obfuscates some members, they may become internal. This can stop other applications from post-processing the obfuscated code.
Inheritance Hierarchy
SystemObject
SystemAttribute
OINA.ExtenderStayPublicAttribute

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class StayPublicAttribute : Attribute
Public NotInheritable Class StayPublicAttribute
    Inherits Attribute
public ref class StayPublicAttribute sealed : public Attribute
[<SealedAttribute>]
type StayPublicAttribute =
    class
        inherit Attribute
    end

The StayPublicAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | StayPublicAttribute | Initializes a new instance of the StayPublicAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender Namespace


StayPublicAttribute Constructor

Initializes a new instance of the StayPublicAttribute class

Namespace: OINA.Extender
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public StayPublicAttribute()
Public Sub New
public:
StayPublicAttribute()
new : unit -> StayPublicAttribute
See Also

Reference

StayPublicAttribute Class
OINA.Extender Namespace


StayPublicAttribute Properties

The StayPublicAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

StayPublicAttribute Class
OINA.Extender Namespace


StayPublicAttribute Methods

The StayPublicAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StayPublicAttribute Class
OINA.Extender Namespace


OINA.Extender.Acquisition Namespace

Top level Class (for Ed, Image, Quant and XSync) used to control the acquisition of data from an Ed Detector.

OINA Extender Acquisition Namespace

Classes
 | Class | Description
Public class | AcquisitionFinishedEventArgs | Non-generic acquisition finished event args
Public class | AcquisitionFinishedEventArgsT | Generic acquisition finished event args
Public class | AcquisitionStartedEventArgsT | Generic acquisition started event args
Public class | AcquisitionStartException | A Class that defines an exception that is created when an error occurs starting acquisition.
Public class | AcquisitionStartingEventArgsT | Generic acquisition starting event args
Public class | AcquisitionStopException | A Class that defines an exception created when acquisition is unable to stop.
Interfaces
 | Interface | Description
Public interface | IAcquisitionRegion | An Interface that defines the scanned region being acquired.
Public interface | IScannedAcquisitionRegion | An Interface that defines the scanned region being acquired.


AcquisitionFinishedEventArgs Class

Non-generic acquisition finished event args
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.Extender.AcquisitionAcquisitionFinishedEventArgs

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionFinishedEventArgs : EventArgs
Public Class AcquisitionFinishedEventArgs
    Inherits EventArgs
public ref class AcquisitionFinishedEventArgs : public EventArgs
type AcquisitionFinishedEventArgs =
    class
        inherit EventArgs
    end

The AcquisitionFinishedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Error | Gets a value indicating whether exception information
Public property | Success | Gets a value indicating whether the acquisition was successful
Public property | TerminationReasons | Gets a value indicating whether reasons of Termination Conditions
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs Properties

The AcquisitionFinishedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Error | Gets a value indicating whether exception information
Public property | Success | Gets a value indicating whether the acquisition was successful
Public property | TerminationReasons | Gets a value indicating whether reasons of Termination Conditions
Top
See Also

Reference

AcquisitionFinishedEventArgs Class
OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs.Error Property

Gets a value indicating whether exception information

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Exception Error { get; }
Public ReadOnly Property Error As Exception
    Get
public:
property Exception^ Error {
    Exception^ get ();
}
member Error : Exception with get

Property Value

Type: Exception
See Also

Reference

AcquisitionFinishedEventArgs Class
OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs.Success Property

Gets a value indicating whether the acquisition was successful

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool Success { get; }
Public ReadOnly Property Success As Boolean
    Get
public:
property bool Success {
    bool get ();
}
member Success : bool with get

Property Value

Type: Boolean
See Also

Reference

AcquisitionFinishedEventArgs Class
OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs.TerminationReasons Property

Gets a value indicating whether reasons of Termination Conditions

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> TerminationReasons { get; }
Public ReadOnly Property TerminationReasons As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ TerminationReasons {
    IEnumerable<String^>^ get ();
}
member TerminationReasons : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

AcquisitionFinishedEventArgs Class
OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs Methods

The AcquisitionFinishedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AcquisitionFinishedEventArgs Class
OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs(T) Class

Generic acquisition finished event args
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.ExtenderEventArgs T
OINA.Extender.AcquisitionAcquisitionFinishedEventArgsT

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionFinishedEventArgs<T> : EventArgs<T>
where T : class

Public Class AcquisitionFinishedEventArgs(Of T As Class)
    Inherits EventArgs(Of T)
generic<typename T>
where T : ref class
public ref class AcquisitionFinishedEventArgs : public EventArgs<T>
type AcquisitionFinishedEventArgs<'T when 'T : not struct> =
    class
        inherit EventArgs<'T>
    end

Type Parameters

T
The type of data acquired

The AcquisitionFinishedEventArgsT type exposes the following members.

Properties
 | Name | Description
Public property | Error | Gets a value indicating whether exception information
Public property | Success | Gets a value indicating whether the acquisition was successful
Public property | TerminationReasons | Gets a value indicating whether reasons of Termination Conditions
Public property | Value | Gets the value (Inherited from EventArgsT.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs(T) Properties

The AcquisitionFinishedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Error | Gets a value indicating whether exception information
Public property | Success | Gets a value indicating whether the acquisition was successful
Public property | TerminationReasons | Gets a value indicating whether reasons of Termination Conditions
Public property | Value | Gets the value (Inherited from EventArgsT.)
Top
See Also

Reference

AcquisitionFinishedEventArgsT Class
OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs(T).Error Property

Gets a value indicating whether exception information

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Exception Error { get; }
Public ReadOnly Property Error As Exception
    Get
public:
property Exception^ Error {
    Exception^ get ();
}
member Error : Exception with get

Property Value

Type: Exception
See Also

Reference

AcquisitionFinishedEventArgsT Class
OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs(T).Success Property

Gets a value indicating whether the acquisition was successful

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool Success { get; }
Public ReadOnly Property Success As Boolean
    Get
public:
property bool Success {
    bool get ();
}
member Success : bool with get

Property Value

Type: Boolean
See Also

Reference

AcquisitionFinishedEventArgsT Class
OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs(T).TerminationReasons Property

Gets a value indicating whether reasons of Termination Conditions

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> TerminationReasons { get; }
Public ReadOnly Property TerminationReasons As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ TerminationReasons {
    IEnumerable<String^>^ get ();
}
member TerminationReasons : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

AcquisitionFinishedEventArgsT Class
OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs(T) Methods

The AcquisitionFinishedEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

AcquisitionFinishedEventArgsT Class
OINA.Extender.Acquisition Namespace


AcquisitionFinishedEventArgs(T).ToString Method

[Missing <summary> documentation for "M:OINA.Extender.Acquisition.AcquisitionFinishedEventArgs`1.ToString"]

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:OINA.Extender.Acquisition.AcquisitionFinishedEventArgs`1.ToString"]

See Also

Reference

AcquisitionFinishedEventArgsT Class
OINA.Extender.Acquisition Namespace


AcquisitionStartedEventArgs(T) Class

Generic acquisition started event args
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.ExtenderEventArgs T
OINA.Extender.AcquisitionAcquisitionStartedEventArgsT

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionStartedEventArgs<T> : EventArgs<T>
where T : class

Public Class AcquisitionStartedEventArgs(Of T As Class)
    Inherits EventArgs(Of T)
generic<typename T>
where T : ref class
public ref class AcquisitionStartedEventArgs : public EventArgs<T>
type AcquisitionStartedEventArgs<'T when 'T : not struct> =
    class
        inherit EventArgs<'T>
    end

Type Parameters

T
The type of data acquired

The AcquisitionStartedEventArgsT type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the value (Inherited from EventArgsT.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Acquisition Namespace


AcquisitionStartedEventArgs(T) Properties

The AcquisitionStartedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the value (Inherited from EventArgsT.)
Top
See Also

Reference

AcquisitionStartedEventArgsT Class
OINA.Extender.Acquisition Namespace


AcquisitionStartedEventArgs(T) Methods

The AcquisitionStartedEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AcquisitionStartedEventArgsT Class
OINA.Extender.Acquisition Namespace


AcquisitionStartException Class

A Class that defines an exception that is created when an error occurs starting acquisition.
Inheritance Hierarchy
SystemObject
SystemException
OINA.Extender.AcquisitionAcquisitionStartException

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class AcquisitionStartException : Exception,
    ISerializable
<SerializableAttribute>
Public Class AcquisitionStartException
    Inherits Exception
    Implements ISerializable
[SerializableAttribute]
public ref class AcquisitionStartException : public Exception,
    ISerializable
[<SerializableAttribute>]
type AcquisitionStartException =
    class
        inherit Exception
        interface ISerializable
    end

The AcquisitionStartException type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionStartException | Initializes a new instance of the AcquisitionStartException class
Public method | AcquisitionStartException(String) | Initializes a new instance of the AcquisitionStartException class
Protected method | AcquisitionStartException(SerializationInfo, StreamingContext) | Initializes a new instance of the AcquisitionStartException class
Public method | AcquisitionStartException(String, Exception) | Initializes a new instance of the AcquisitionStartException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Get object data. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Class information (Overrides ExceptionToString.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OINA.Extender.Acquisition Namespace


AcquisitionStartException Constructor

Overload List
 | Name | Description
Public method | AcquisitionStartException | Initializes a new instance of the AcquisitionStartException class
Public method | AcquisitionStartException(String) | Initializes a new instance of the AcquisitionStartException class
Protected method | AcquisitionStartException(SerializationInfo, StreamingContext) | Initializes a new instance of the AcquisitionStartException class
Public method | AcquisitionStartException(String, Exception) | Initializes a new instance of the AcquisitionStartException class
Top
See Also

Reference

AcquisitionStartException Class
OINA.Extender.Acquisition Namespace


AcquisitionStartException Constructor

Initializes a new instance of the AcquisitionStartException class

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public AcquisitionStartException()
Public Sub New
public:
AcquisitionStartException()
new : unit -> AcquisitionStartException
See Also

Reference

AcquisitionStartException Class
AcquisitionStartException Overload
OINA.Extender.Acquisition Namespace


AcquisitionStartException Constructor (String)

Initializes a new instance of the AcquisitionStartException class

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public AcquisitionStartException(
    string message
)
Public Sub New (
    message As String
)
public:
AcquisitionStartException(
    String^ message
)
new :
        message : string -> AcquisitionStartException

Parameters

message
Type: SystemString
error message
See Also

Reference

AcquisitionStartException Class
AcquisitionStartException Overload
OINA.Extender.Acquisition Namespace


AcquisitionStartException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AcquisitionStartException class

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
protected AcquisitionStartException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
AcquisitionStartException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AcquisitionStartException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
serialization information
context
Type: System.Runtime.SerializationStreamingContext
streaming context
See Also

Reference

AcquisitionStartException Class
AcquisitionStartException Overload
OINA.Extender.Acquisition Namespace


AcquisitionStartException Constructor (String, Exception)

Initializes a new instance of the AcquisitionStartException class

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public AcquisitionStartException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
AcquisitionStartException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> AcquisitionStartException

Parameters

message
Type: SystemString
error message
inner
Type: SystemException
inner exception
See Also

Reference

AcquisitionStartException Class
AcquisitionStartException Overload
OINA.Extender.Acquisition Namespace


AcquisitionStartException Properties

The AcquisitionStartException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

AcquisitionStartException Class
OINA.Extender.Acquisition Namespace


AcquisitionStartException Methods

The AcquisitionStartException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Get object data. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Class information (Overrides ExceptionToString.)
Top
See Also

Reference

AcquisitionStartException Class
OINA.Extender.Acquisition Namespace


AcquisitionStartException.GetObjectData Method

Get object data.

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
serialization information
context
Type: System.Runtime.SerializationStreamingContext
streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AcquisitionStartException Class
OINA.Extender.Acquisition Namespace


AcquisitionStartException.ToString Method

Class information

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
Type information

Implements

_ExceptionToString
See Also

Reference

AcquisitionStartException Class
OINA.Extender.Acquisition Namespace


AcquisitionStartException Events

The AcquisitionStartException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

AcquisitionStartException Class
OINA.Extender.Acquisition Namespace


AcquisitionStartingEventArgs(T) Class

Generic acquisition starting event args
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.ExtenderEventArgs T
OINA.Extender.AcquisitionAcquisitionStartingEventArgsT

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class AcquisitionStartingEventArgs<T> : EventArgs<T>
where T : class

Public Class AcquisitionStartingEventArgs(Of T As Class)
    Inherits EventArgs(Of T)
generic<typename T>
where T : ref class
public ref class AcquisitionStartingEventArgs : public EventArgs<T>
type AcquisitionStartingEventArgs<'T when 'T : not struct> =
    class
        inherit EventArgs<'T>
    end

Type Parameters

T
The type of data acquired

The AcquisitionStartingEventArgsT type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the value (Inherited from EventArgsT.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Acquisition Namespace


AcquisitionStartingEventArgs(T) Properties

The AcquisitionStartingEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the value (Inherited from EventArgsT.)
Top
See Also

Reference

AcquisitionStartingEventArgsT Class
OINA.Extender.Acquisition Namespace


AcquisitionStartingEventArgs(T) Methods

The AcquisitionStartingEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AcquisitionStartingEventArgsT Class
OINA.Extender.Acquisition Namespace


AcquisitionStopException Class

A Class that defines an exception created when acquisition is unable to stop.
Inheritance Hierarchy
SystemObject
SystemException
OINA.Extender.AcquisitionAcquisitionStopException

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class AcquisitionStopException : Exception,
    ISerializable
<SerializableAttribute>
Public Class AcquisitionStopException
    Inherits Exception
    Implements ISerializable
[SerializableAttribute]
public ref class AcquisitionStopException : public Exception,
    ISerializable
[<SerializableAttribute>]
type AcquisitionStopException =
    class
        inherit Exception
        interface ISerializable
    end

The AcquisitionStopException type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionStopException | Initializes a new instance of the AcquisitionStopException class
Public method | AcquisitionStopException(String) | Initializes a new instance of the AcquisitionStopException class
Protected method | AcquisitionStopException(SerializationInfo, StreamingContext) | Initializes a new instance of the AcquisitionStopException class
Public method | AcquisitionStopException(String, Exception) | Initializes a new instance of the AcquisitionStopException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Get object data. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Class information (Overrides ExceptionToString.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OINA.Extender.Acquisition Namespace


AcquisitionStopException Constructor

Overload List
 | Name | Description
Public method | AcquisitionStopException | Initializes a new instance of the AcquisitionStopException class
Public method | AcquisitionStopException(String) | Initializes a new instance of the AcquisitionStopException class
Protected method | AcquisitionStopException(SerializationInfo, StreamingContext) | Initializes a new instance of the AcquisitionStopException class
Public method | AcquisitionStopException(String, Exception) | Initializes a new instance of the AcquisitionStopException class
Top
See Also

Reference

AcquisitionStopException Class
OINA.Extender.Acquisition Namespace


AcquisitionStopException Constructor

Initializes a new instance of the AcquisitionStopException class

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public AcquisitionStopException()
Public Sub New
public:
AcquisitionStopException()
new : unit -> AcquisitionStopException
See Also

Reference

AcquisitionStopException Class
AcquisitionStopException Overload
OINA.Extender.Acquisition Namespace


AcquisitionStopException Constructor (String)

Initializes a new instance of the AcquisitionStopException class

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public AcquisitionStopException(
    string message
)
Public Sub New (
    message As String
)
public:
AcquisitionStopException(
    String^ message
)
new :
        message : string -> AcquisitionStopException

Parameters

message
Type: SystemString
error message
See Also

Reference

AcquisitionStopException Class
AcquisitionStopException Overload
OINA.Extender.Acquisition Namespace


AcquisitionStopException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AcquisitionStopException class

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
protected AcquisitionStopException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
AcquisitionStopException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AcquisitionStopException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
serialization information
context
Type: System.Runtime.SerializationStreamingContext
streaming context
See Also

Reference

AcquisitionStopException Class
AcquisitionStopException Overload
OINA.Extender.Acquisition Namespace


AcquisitionStopException Constructor (String, Exception)

Initializes a new instance of the AcquisitionStopException class

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public AcquisitionStopException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
AcquisitionStopException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> AcquisitionStopException

Parameters

message
Type: SystemString
error message
inner
Type: SystemException
inner exception
See Also

Reference

AcquisitionStopException Class
AcquisitionStopException Overload
OINA.Extender.Acquisition Namespace


AcquisitionStopException Properties

The AcquisitionStopException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

AcquisitionStopException Class
OINA.Extender.Acquisition Namespace


AcquisitionStopException Methods

The AcquisitionStopException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Get object data. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Class information (Overrides ExceptionToString.)
Top
See Also

Reference

AcquisitionStopException Class
OINA.Extender.Acquisition Namespace


AcquisitionStopException.GetObjectData Method

Get object data.

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
serialization information
context
Type: System.Runtime.SerializationStreamingContext
streaming context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AcquisitionStopException Class
OINA.Extender.Acquisition Namespace


AcquisitionStopException.ToString Method

Class information

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
Type information

Implements

_ExceptionToString
See Also

Reference

AcquisitionStopException Class
OINA.Extender.Acquisition Namespace


AcquisitionStopException Events

The AcquisitionStopException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

AcquisitionStopException Class
OINA.Extender.Acquisition Namespace


IAcquisitionRegion Interface

An Interface that defines the scanned region being acquired.

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IAcquisitionRegion : INotifyPropertyChanged,
    IScannedAcquisitionRegion
Public Interface IAcquisitionRegion
    Inherits INotifyPropertyChanged, IScannedAcquisitionRegion
public interface class IAcquisitionRegion : INotifyPropertyChanged,
    IScannedAcquisitionRegion
type IAcquisitionRegion =
    interface
        interface INotifyPropertyChanged
        interface IScannedAcquisitionRegion
    end

The IAcquisitionRegion type exposes the following members.

Properties
 | Name | Description
Public property | CurrentAcquisitionRegion | Gets the current region. This is updated when a create region method is called. (Inherited from IScannedAcquisitionRegion.)
Public property | PixelSize | Gets the size of a pixel (= 1 / resolution in pixels). This is updated when a create region method is called. (Inherited from IScannedAcquisitionRegion.)
Top
Methods
 | Name | Description
Public method | CreateChordListRegion | Creates a chord list region. (Inherited from IScannedAcquisitionRegion.)
Public method | CreateFullFieldRegion | Creates a full field region. (Inherited from IScannedAcquisitionRegion.)
Public method | CreateMicroscopeRegion | Creates a microscope region. Scan controlled by microscope.
Public method | CreatePointRegion | Creates a point region.
Public method | CreateRectangleRegion | Creates a rectangle region. (Inherited from IScannedAcquisitionRegion.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition Namespace


IAcquisitionRegion Properties

The IAcquisitionRegion type exposes the following members.

Properties
 | Name | Description
Public property | CurrentAcquisitionRegion | Gets the current region. This is updated when a create region method is called. (Inherited from IScannedAcquisitionRegion.)
Public property | PixelSize | Gets the size of a pixel (= 1 / resolution in pixels). This is updated when a create region method is called. (Inherited from IScannedAcquisitionRegion.)
Top
See Also

Reference

IAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IAcquisitionRegion Methods

The IAcquisitionRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateChordListRegion | Creates a chord list region. (Inherited from IScannedAcquisitionRegion.)
Public method | CreateFullFieldRegion | Creates a full field region. (Inherited from IScannedAcquisitionRegion.)
Public method | CreateMicroscopeRegion | Creates a microscope region. Scan controlled by microscope.
Public method | CreatePointRegion | Creates a point region.
Public method | CreateRectangleRegion | Creates a rectangle region. (Inherited from IScannedAcquisitionRegion.)
Top
See Also

Reference

IAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IAcquisitionRegion.CreateMicroscopeRegion Method

Creates a microscope region. Scan controlled by microscope.

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeRegion CreateMicroscopeRegion()
Function CreateMicroscopeRegion As IMicroscopeRegion
IMicroscopeRegion^ CreateMicroscopeRegion()
abstract CreateMicroscopeRegion : unit -> IMicroscopeRegion

Return Value

Type: IMicroscopeRegion
The microscope region
See Also

Reference

IAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IAcquisitionRegion.CreatePointRegion Method

Creates a point region.

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IPointRegion CreatePointRegion(
    Point point
)
Function CreatePointRegion (
    point As Point
) As IPointRegion
IPointRegion^ CreatePointRegion(
    Point point
)
abstract CreatePointRegion :
        point : Point -> IPointRegion

Parameters

point
Type: System.WindowsPoint
The point in normalised co-ordinates

Return Value

Type: IPointRegion
The point region
See Also

Reference

IAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IAcquisitionRegion Events

The IAcquisitionRegion type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IScannedAcquisitionRegion Interface

An Interface that defines the scanned region being acquired.

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IScannedAcquisitionRegion : INotifyPropertyChanged
Public Interface IScannedAcquisitionRegion
    Inherits INotifyPropertyChanged
public interface class IScannedAcquisitionRegion : INotifyPropertyChanged
type IScannedAcquisitionRegion =
    interface
        interface INotifyPropertyChanged
    end

The IScannedAcquisitionRegion type exposes the following members.

Properties
 | Name | Description
Public property | CurrentAcquisitionRegion | Gets the current region. This is updated when a create region method is called.
Public property | PixelSize | Gets the size of a pixel (= 1 / resolution in pixels). This is updated when a create region method is called.
Top
Methods
 | Name | Description
Public method | CreateChordListRegion | Creates a chord list region.
Public method | CreateFullFieldRegion | Creates a full field region.
Public method | CreateRectangleRegion | Creates a rectangle region.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition Namespace


IScannedAcquisitionRegion Properties

The IScannedAcquisitionRegion type exposes the following members.

Properties
 | Name | Description
Public property | CurrentAcquisitionRegion | Gets the current region. This is updated when a create region method is called.
Public property | PixelSize | Gets the size of a pixel (= 1 / resolution in pixels). This is updated when a create region method is called.
Top
See Also

Reference

IScannedAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IScannedAcquisitionRegion.CurrentAcquisitionRegion Property

Gets the current region. This is updated when a create region method is called.

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IRegion CurrentAcquisitionRegion { get; }
ReadOnly Property CurrentAcquisitionRegion As IRegion
    Get
property IRegion^ CurrentAcquisitionRegion {
    IRegion^ get ();
}
abstract CurrentAcquisitionRegion : IRegion with get

Property Value

Type: IRegion
See Also

Reference

IScannedAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IScannedAcquisitionRegion.PixelSize Property

Gets the size of a pixel (= 1 / resolution in pixels). This is updated when a create region method is called.

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double PixelSize { get; }
ReadOnly Property PixelSize As Double
    Get
property double PixelSize {
    double get ();
}
abstract PixelSize : float with get

Property Value

Type: Double
See Also

Reference

IScannedAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IScannedAcquisitionRegion Methods

The IScannedAcquisitionRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateChordListRegion | Creates a chord list region.
Public method | CreateFullFieldRegion | Creates a full field region.
Public method | CreateRectangleRegion | Creates a rectangle region.
Top
See Also

Reference

IScannedAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IScannedAcquisitionRegion.CreateChordListRegion Method

Creates a chord list region.

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IChordListRegion CreateChordListRegion(
    ChordList chordList
)
Function CreateChordListRegion (
    chordList As ChordList
) As IChordListRegion
IChordListRegion^ CreateChordListRegion(
    ChordList^ chordList
)
abstract CreateChordListRegion :
        chordList : ChordList -> IChordListRegion

Parameters

chordList
Type: OINA.Extender.DataChordList
The chord list in pixel co-ordinates

Return Value

Type: IChordListRegion
The chord list region
See Also

Reference

IScannedAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IScannedAcquisitionRegion.CreateFullFieldRegion Method

Creates a full field region.

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IFullFieldRegion CreateFullFieldRegion(
    double pixelSize
)
Function CreateFullFieldRegion (
    pixelSize As Double
) As IFullFieldRegion
IFullFieldRegion^ CreateFullFieldRegion(
    double pixelSize
)
abstract CreateFullFieldRegion :
        pixelSize : float -> IFullFieldRegion

Parameters

pixelSize
Type: SystemDouble
The size of a pixel (= 1 / resolution in pixels).

Return Value

Type: IFullFieldRegion
The full field region
See Also

Reference

IScannedAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IScannedAcquisitionRegion.CreateRectangleRegion Method

Creates a rectangle region.

Namespace: OINA.Extender.Acquisition
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IRectangleRegion CreateRectangleRegion(
    Rect rect,
    double pixelSize
)
Function CreateRectangleRegion (
    rect As Rect,
    pixelSize As Double
) As IRectangleRegion
IRectangleRegion^ CreateRectangleRegion(
    Rect rect,
    double pixelSize
)
abstract CreateRectangleRegion :
        rect : Rect *
        pixelSize : float -> IRectangleRegion

Parameters

rect
Type: System.WindowsRect
The rectangle in normalised co-ordinates.
pixelSize
Type: SystemDouble
The pixel size

Return Value

Type: IRectangleRegion
The rectangle region
See Also

Reference

IScannedAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


IScannedAcquisitionRegion Events

The IScannedAcquisitionRegion type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IScannedAcquisitionRegion Interface
OINA.Extender.Acquisition Namespace


OINA.Extender.Acquisition.Ed Namespace

Defines all Classes and Interfaces used to control the acquisition of data from an Ed Detector.

Interfaces
 | Interface | Description
 | IEdCapabilities | An Interface that defines capabilities for Ed acquisition.
Public interface | IEdChordListAcquisitionController | An Interface for acquiring spectra at pixel positions defined by chordlists.
Public interface | IEdChordListScanCapabilities | An Interface that defines scan capabilities for Ed chordlist acquisition.
Public interface | IEdChordListSettings | An Interface that defines settings and capabilities for Ed chordlist acquisition.
 | IEdSettings | An Interface that defines settings for Ed acquisition.
 | IEdSpectrumAcquisitionController | An Interface for acquiring a spectrum.
Public interface | IEdSpectrumScanCapabilities | An Interface that defines scan capabilities for Ed spectrum acquisition.
Public interface | IEdSpectrumScanSettings | An interface that defines scan settings for Ed spectrum acquisition.
Public interface | IEdSpectrumSettings | An Interface that defines settings and capabilities for Ed spectrum acquisition.
Enumerations
 | Enumeration | Description
Public enumeration | EdAcquireMode | The Ed acquisition termination mode.
Public enumeration | EdTimeMode |


EdAcquireMode Enumeration

The Ed acquisition termination mode.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum EdAcquireMode
Public Enumeration EdAcquireMode
public enum class EdAcquireMode
type EdAcquireMode
Members
Member name | Value | Description
Unknown | 0 | Has not been set.
RealTime | 1 | Acquire Ed data for a period of real time.
LiveTime | 2 | Acquire Ed data for a period of live time.
See Also

Reference

OINA.Extender.Acquisition.Ed Namespace


EdTimeMode Enumeration

[Missing <summary> documentation for "T:OINA.Extender.Acquisition.Ed.EdTimeMode"]

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum EdTimeMode
Public Enumeration EdTimeMode
public enum class EdTimeMode
type EdTimeMode
Members
Member name | Value | Description
Pixel | 0 | AcquisitionTime specifies the per-pixel dwell time.
Frame | 1 | AcquisitionTime specifies the time to acquire a single frame.
See Also

Reference

OINA.Extender.Acquisition.Ed Namespace


IEdCapabilities Interface

An Interface that defines capabilities for Ed acquisition.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdCapabilities : INotifyPropertyChanged
Public Interface IEdCapabilities
    Inherits INotifyPropertyChanged
public interface class IEdCapabilities : INotifyPropertyChanged
type IEdCapabilities =
    interface
        interface INotifyPropertyChanged
    end

The IEdCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AllowedEnergyRanges | Gets the allowed energy ranges. The energy range defines the upper limit of the spectrum.
Public property | AllowedNumberOfChannels | Gets the allowed number of channels for binning the spectrum.
Public property | AllowedProcessTimes | Gets the allowed process times.
Public property | HasHardwareConnection | Gets a value indicating whether or not the Ed hardware is connected.
Public property | MaximumAcquisitionTime | Gets the maximum acquisition time.
Public property | MinimumAcquisitionTime | Gets the minimum acquisition time.
Top
Methods
 | Name | Description
Public method | GetMaximumOutputRateAtProcessTime | Gets the maximum output count rate at a given process time.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Examples
Copy
public void Run()
{
    Console.WriteLine();
    Console.WriteLine(@"Spectrum Acquisition Example.");
    Console.WriteLine();

    Console.WriteLine();
    Console.WriteLine(@"Quantification Processing Option:");

    // Get choice of processing option from user
    var processingOptions = new Dictionary<int, string>
    {
        { 1, "All Elements" },
        { 2, "Element by Difference" },
        { 3, "Element by Stoichiometry" }
    };

    this.userProcessingOption = Program.MakeChoice(processingOptions);

    IEdSpectrumSettings edSpectrumSettings = AcquireFactory.CreateEdSpectrumSettings();

    edSpectrumSettings.EdSettings.AcquisitionMode = EdAcquireMode.LiveTime; // RealTime or LiveTime
    edSpectrumSettings.EdSettings.AcquisitionTime = TimeSpan.FromSeconds(2);

    Console.WriteLine(@"Allowed Process Times: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedProcessTimes));
    Console.WriteLine(@"Allowed Energy Ranges: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedEnergyRanges));
    Console.WriteLine(@"Allowed Number of Channels: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedNumberOfChannels));

    edSpectrumSettings.EdSettings.ProcessTime = 1;
    edSpectrumSettings.EdSettings.EnergyRange = 10;
    edSpectrumSettings.EdSettings.NumberOfChannels = 1024;

    edSpectrumSettings.ScanSettings.AcquisitionRegion.CreateFullFieldRegion(1.0 / 1024.0);

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = AcquireFactory.CreateEdSpectrumServer();

    // Event handlers for spectrum acquisition controller events
    edSpectrumAcquisitionController.ExperimentStarting += this.OnEdSpectrumExperimentStarting;
    edSpectrumAcquisitionController.ExperimentFinished += this.OnEdSpectrumExperimentFinished;

    // IEdSpectrumSettings.EdCapabilities will validate settings and hardware availability.
    if (edSpectrumAcquisitionController.IsEdHardwareReady(edSpectrumSettings))
    {
        // This only used for multiple acquisition:
        //      if this is the first acquisition, call BeginMultipleAcquisition
        //      on the IEdSpectrumAcquisitionController to suppress external scan switching
        edSpectrumAcquisitionController.BeginMultipleAcquisition();

        // Start spectrum acquisition
        try
        {
            IEdSpectrum edSpectrum = edSpectrumAcquisitionController.StartAcquisition(edSpectrumSettings);

            edSpectrum.Label = @"Code Example Spectrum";
        }
        catch (InvalidSettingsException invalidSettingsException)
        {
            Console.WriteLine(@"Invalid Settings Exception:");
            Console.WriteLine(
                @"{0} {1}",
                invalidSettingsException.Message,
                string.Join(",", invalidSettingsException.ValidationResults.ValidationErrors));
        }
        catch (AcquisitionStartException acquisitionStartException)
        {
            Console.WriteLine(@"Acquisition Start Exception:");
            Console.WriteLine(acquisitionStartException.Message);
        }
    }
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Starting.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The <see cref="AcquisitionFinishedEventArgs{IEdSpectrum}"/> instance containing the event data.</param>
private void OnEdSpectrumExperimentStarting(object sender, AcquisitionStartingEventArgs<IEdSpectrum> e)
{
    IEdSpectrum edSpectrum = e.Value;

    Console.WriteLine(@"Spectrum Acquisition starting: {0}", edSpectrum.Label);
    Console.WriteLine();

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        edSpectrumAcquisitionController.ExperimentStarting -= this.OnEdSpectrumExperimentStarting;
        edSpectrumAcquisitionController.ExperimentStarted += this.OnEdSpectrumExperimentStarted;
    }

    edSpectrum.PropertyChanged += this.OnPropertyChanged;
    edSpectrum.DataChanged += this.OnDataChanged;
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Started.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The <see cref="AcquisitionFinishedEventArgs{IEdSpectrum}"/> instance containing the event data.</param>
private void OnEdSpectrumExperimentStarted(object sender, AcquisitionStartedEventArgs<IEdSpectrum> e)
{
    IEdSpectrum edSpectrum = e.Value;

    Console.WriteLine(@"Spectrum Acquisition started: {0}", edSpectrum.Label);
    Console.WriteLine();

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        edSpectrumAcquisitionController.ExperimentStarted -= this.OnEdSpectrumExperimentStarted;
    }
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Finished
/// </summary>
/// <param name="sender">sender object</param>
/// <param name="e">The instance containing the event data.</param>
private void OnEdSpectrumExperimentFinished(object sender, AcquisitionFinishedEventArgs<IEdSpectrum> e)
{
    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        // This only used for multiple acquisition:
        //      If this is the last experiment, call EndMultipleAcquisition on the Acquisition
        //      controller, to re-enable external scan switching
        edSpectrumAcquisitionController.EndMultipleAcquisition();

        edSpectrumAcquisitionController.ExperimentFinished -= this.OnEdSpectrumExperimentFinished;
    }

    IEdSpectrum edSpectrum = e.Value;

    edSpectrum.PropertyChanged -= this.OnPropertyChanged;
    edSpectrum.DataChanged -= this.OnDataChanged;

    Console.WriteLine();
    Console.WriteLine(@"Spectrum Acquisition finished: {0}", edSpectrum.Label);
    Console.WriteLine(@"    AcquisitionDate: {0}", edSpectrum.AcquisitionDate);
    Console.WriteLine(@"    LiveTime: {0:0.00}, RealTime: {1:0.00}", edSpectrum.LiveTimeSeconds, edSpectrum.RealTimeSeconds);
    Console.WriteLine();

    this.edSpectrum = edSpectrum;

    this.DoAutoID();
    this.DoQuant();

    Console.WriteLine();
    Console.WriteLine();
    Console.WriteLine(@"Code Example finished.");
}

/// <summary>
/// Called when IEdSpectrum PropertyChanged
/// </summary>
/// <param name="sender">Event source</param>
/// <param name="e">Event arguments</param>
private void OnPropertyChanged(object sender, PropertyChangedEventArgs e)
{
    var edSpectrum = (IEdSpectrum)sender;

    var output = string.Empty;

    switch (e.PropertyName)
    {
        case "ColumnConditions":
            output = string.Format(CultureInfo.InvariantCulture, @"     Column Conditions: eg WorkingDistance - {0:0.00}", edSpectrum.ColumnConditions.WorkingDistance);
            break;
        case "StageConditions":
            output = string.Format(CultureInfo.InvariantCulture, @"     Stage Conditions: eg StageR - {0:0.00}", edSpectrum.StageConditions.StageR);
            break;
        case "AcquisitionDate":
            output = string.Format(CultureInfo.InvariantCulture, @"     Acquisition Date: {0:dd-MMM-yy HH:mm:ss}", edSpectrum.AcquisitionDate);
            break;
        case "HardwareIds":
            output = string.Format(CultureInfo.InvariantCulture, @"     HardwareIds: eg DetectorDeviceId - {0}", string.Join(",", edSpectrum.HardwareIds.Select(h => h.DetectorDeviceId).ToArray()));
            break;
        case "PrimaryHardwareId":
            output = string.Format(CultureInfo.InvariantCulture, @"     PrimaryHardwareId: eg DetectorDeviceId - {0}", string.Join(",", edSpectrum.PrimaryHardwareId.DetectorDeviceId));
            break;
        case "RealTimeSeconds":
            output = string.Format(CultureInfo.InvariantCulture, @"     Real Time - {0:0.00}", edSpectrum.RealTimeSeconds);
            break;
        case "LiveTimeSeconds":
            output = string.Format(CultureInfo.InvariantCulture, @"     Live Time - {0:0.00}", edSpectrum.LiveTimeSeconds);
            break;
        default:
            output = string.Format(CultureInfo.InvariantCulture, @"     {0}", e.PropertyName);
            break;
    }

    Console.WriteLine(@"Property Changed:{0}{1}", Environment.NewLine, output);
    Console.WriteLine();
}

/// <summary>
/// Called when IEdSpectrum DataChanged
/// </summary>
/// <param name="sender">Event source</param>
/// <param name="e">Event arguments</param>
private void OnDataChanged(object sender, EventArgs e)
{
    var edSpectrum = (IEdSpectrum)sender;

    var buffer = new int[edSpectrum.NumberOfChannels];

    edSpectrum.GetChannelData(buffer);

    Console.WriteLine(@"Data Changed - ChannelData: {0}{1}", Environment.NewLine, string.Join(",", buffer));
    Console.WriteLine();
}
See Also

Reference

OINA.Extender.Acquisition.Ed Namespace


IEdCapabilities Properties

The IEdCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AllowedEnergyRanges | Gets the allowed energy ranges. The energy range defines the upper limit of the spectrum.
Public property | AllowedNumberOfChannels | Gets the allowed number of channels for binning the spectrum.
Public property | AllowedProcessTimes | Gets the allowed process times.
Public property | HasHardwareConnection | Gets a value indicating whether or not the Ed hardware is connected.
Public property | MaximumAcquisitionTime | Gets the maximum acquisition time.
Public property | MinimumAcquisitionTime | Gets the minimum acquisition time.
Top
See Also

Reference

IEdCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdCapabilities.AllowedEnergyRanges Property

Gets the allowed energy ranges. The energy range defines the upper limit of the spectrum.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<int> AllowedEnergyRanges { get; }
ReadOnly Property AllowedEnergyRanges As ReadOnlyCollection(Of Integer)
    Get
property ReadOnlyCollection<int>^ AllowedEnergyRanges {
    ReadOnlyCollection<int>^ get ();
}
abstract AllowedEnergyRanges : ReadOnlyCollection<int> with get

Property Value

Type: ReadOnlyCollection Int32
See Also

Reference

IEdCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdCapabilities.AllowedNumberOfChannels Property

Gets the allowed number of channels for binning the spectrum.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<int> AllowedNumberOfChannels { get; }
ReadOnly Property AllowedNumberOfChannels As ReadOnlyCollection(Of Integer)
    Get
property ReadOnlyCollection<int>^ AllowedNumberOfChannels {
    ReadOnlyCollection<int>^ get ();
}
abstract AllowedNumberOfChannels : ReadOnlyCollection<int> with get

Property Value

Type: ReadOnlyCollection Int32
See Also

Reference

IEdCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdCapabilities.AllowedProcessTimes Property

Gets the allowed process times.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<int> AllowedProcessTimes { get; }
ReadOnly Property AllowedProcessTimes As ReadOnlyCollection(Of Integer)
    Get
property ReadOnlyCollection<int>^ AllowedProcessTimes {
    ReadOnlyCollection<int>^ get ();
}
abstract AllowedProcessTimes : ReadOnlyCollection<int> with get

Property Value

Type: ReadOnlyCollection Int32
See Also

Reference

IEdCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdCapabilities.HasHardwareConnection Property

Gets a value indicating whether or not the Ed hardware is connected.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasHardwareConnection { get; }
ReadOnly Property HasHardwareConnection As Boolean
    Get
property bool HasHardwareConnection {
    bool get ();
}
abstract HasHardwareConnection : bool with get

Property Value

Type: Boolean
See Also

Reference

IEdCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdCapabilities.MaximumAcquisitionTime Property

Gets the maximum acquisition time.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
TimeSpan MaximumAcquisitionTime { get; }
ReadOnly Property MaximumAcquisitionTime As TimeSpan
    Get
property TimeSpan MaximumAcquisitionTime {
    TimeSpan get ();
}
abstract MaximumAcquisitionTime : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

IEdCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdCapabilities.MinimumAcquisitionTime Property

Gets the minimum acquisition time.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
TimeSpan MinimumAcquisitionTime { get; }
ReadOnly Property MinimumAcquisitionTime As TimeSpan
    Get
property TimeSpan MinimumAcquisitionTime {
    TimeSpan get ();
}
abstract MinimumAcquisitionTime : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

IEdCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdCapabilities Methods

The IEdCapabilities type exposes the following members.

Methods
 | Name | Description
Public method | GetMaximumOutputRateAtProcessTime | Gets the maximum output count rate at a given process time.
Top
See Also

Reference

IEdCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdCapabilities.GetMaximumOutputRateAtProcessTime Method

Gets the maximum output count rate at a given process time.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int GetMaximumOutputRateAtProcessTime(
    int processTime
)
Function GetMaximumOutputRateAtProcessTime (
    processTime As Integer
) As Integer
int GetMaximumOutputRateAtProcessTime(
    int processTime
)
abstract GetMaximumOutputRateAtProcessTime :
        processTime : int -> int

Parameters

processTime
Type: SystemInt32
The process time

Return Value

Type: Int32
The maximum output count rate
See Also

Reference

IEdCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdCapabilities Events

The IEdCapabilities type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IEdCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController Interface

An Interface for acquiring spectra at pixel positions defined by chordlists.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdChordListAcquisitionController
Public Interface IEdChordListAcquisitionController
public interface class IEdChordListAcquisitionController
type IEdChordListAcquisitionController =  interface end

The IEdChordListAcquisitionController type exposes the following members.

Properties
 | Name | Description
Public property | IsAcquiring | Gets a value indicating whether the acquisition controller is acquiring or not.
Top
Methods
 | Name | Description
Public method | BeginMultipleAcquisition | Request that external scan control will not be released after acquisition has finished.
Public method | EndMultipleAcquisition | Release external scan control.
Public method | IsEdHardwareReady | Gets a value indicating whether the ED hardware is ready or not.
Public method | StartAcquisition | Start ED chordlist acquisition.
Public method | StopAcquisition | Stop acquisition immediately.
Top
Events
 | Name | Description
Public event | ExperimentFinished | Occurs when ED chordlist acquisition is finished.
Public event | ExperimentStarted | Occurs when ED chordlist acquisition has started.
Public event | ExperimentStarting | Occurs before ED chordlist acquisition starts.
Public event | PixelProcessed | Occurs when a pixel has been acquired and processed.
Top
See Also

Reference

OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController Properties

The IEdChordListAcquisitionController type exposes the following members.

Properties
 | Name | Description
Public property | IsAcquiring | Gets a value indicating whether the acquisition controller is acquiring or not.
Top
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController.IsAcquiring Property

Gets a value indicating whether the acquisition controller is acquiring or not.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsAcquiring { get; }
ReadOnly Property IsAcquiring As Boolean
    Get
property bool IsAcquiring {
    bool get ();
}
abstract IsAcquiring : bool with get

Property Value

Type: Boolean
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController Methods

The IEdChordListAcquisitionController type exposes the following members.

Methods
 | Name | Description
Public method | BeginMultipleAcquisition | Request that external scan control will not be released after acquisition has finished.
Public method | EndMultipleAcquisition | Release external scan control.
Public method | IsEdHardwareReady | Gets a value indicating whether the ED hardware is ready or not.
Public method | StartAcquisition | Start ED chordlist acquisition.
Public method | StopAcquisition | Stop acquisition immediately.
Top
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController.BeginMultipleAcquisition Method

Request that external scan control will not be released after acquisition has finished.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void BeginMultipleAcquisition()
Sub BeginMultipleAcquisition
void BeginMultipleAcquisition()
abstract BeginMultipleAcquisition : unit -> unit
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController.EndMultipleAcquisition Method

Release external scan control.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void EndMultipleAcquisition()
Sub EndMultipleAcquisition
void EndMultipleAcquisition()
abstract EndMultipleAcquisition : unit -> unit
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController.IsEdHardwareReady Method

Gets a value indicating whether the ED hardware is ready or not.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsEdHardwareReady(
    IEdChordListSettings settings
)
Function IsEdHardwareReady (
    settings As IEdChordListSettings
) As Boolean
bool IsEdHardwareReady(
    IEdChordListSettings^ settings
)
abstract IsEdHardwareReady :
        settings : IEdChordListSettings -> bool

Parameters

settings
Type: OINA.Extender.Acquisition.EdIEdChordListSettings
The ED chordlist settings

Return Value

Type: Boolean
true if the hardware is ready
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController.StartAcquisition Method

Start ED chordlist acquisition.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void StartAcquisition(
    IEdChordListSettings settings
)
Sub StartAcquisition (
    settings As IEdChordListSettings
)
void StartAcquisition(
    IEdChordListSettings^ settings
)
abstract StartAcquisition :
        settings : IEdChordListSettings -> unit

Parameters

settings
Type: OINA.Extender.Acquisition.EdIEdChordListSettings
The ED chordlist settings.
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController.StopAcquisition Method

Stop acquisition immediately.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void StopAcquisition()
Sub StopAcquisition
void StopAcquisition()
abstract StopAcquisition : unit -> unit
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController Events

The IEdChordListAcquisitionController type exposes the following members.

Events
 | Name | Description
Public event | ExperimentFinished | Occurs when ED chordlist acquisition is finished.
Public event | ExperimentStarted | Occurs when ED chordlist acquisition has started.
Public event | ExperimentStarting | Occurs before ED chordlist acquisition starts.
Public event | PixelProcessed | Occurs when a pixel has been acquired and processed.
Top
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController.ExperimentFinished Event

Occurs when ED chordlist acquisition is finished.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AcquisitionFinishedEventArgs> ExperimentFinished
Event ExperimentFinished As EventHandler(Of AcquisitionFinishedEventArgs)
 event EventHandler<AcquisitionFinishedEventArgs^>^ ExperimentFinished {
    void add (EventHandler<AcquisitionFinishedEventArgs^>^ value);
    void remove (EventHandler<AcquisitionFinishedEventArgs^>^ value);
}
abstract ExperimentFinished : IEvent<EventHandler<AcquisitionFinishedEventArgs>,
    AcquisitionFinishedEventArgs>

Value

Type: SystemEventHandler AcquisitionFinishedEventArgs
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController.ExperimentStarted Event

Occurs when ED chordlist acquisition has started.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler ExperimentStarted
Event ExperimentStarted As EventHandler
 event EventHandler^ ExperimentStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ExperimentStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController.ExperimentStarting Event

Occurs before ED chordlist acquisition starts.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler ExperimentStarting
Event ExperimentStarting As EventHandler
 event EventHandler^ ExperimentStarting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract ExperimentStarting : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListAcquisitionController.PixelProcessed Event

Occurs when a pixel has been acquired and processed.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<IPixelSEMQuantStatus>> PixelProcessed
Event PixelProcessed As EventHandler(Of EventArgs(Of IPixelSEMQuantStatus))
 event EventHandler<EventArgs<IPixelSEMQuantStatus^>^>^ PixelProcessed {
    void add (EventHandler<EventArgs<IPixelSEMQuantStatus^>^>^ value);
    void remove (EventHandler<EventArgs<IPixelSEMQuantStatus^>^>^ value);
}
abstract PixelProcessed : IEvent<EventHandler<EventArgs<IPixelSEMQuantStatus>>,
    EventArgs<IPixelSEMQuantStatus>>

Value

Type: SystemEventHandler EventArgs IPixelSEMQuantStatus
See Also

Reference

IEdChordListAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListScanCapabilities Interface

An Interface that defines scan capabilities for Ed chordlist acquisition.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdChordListScanCapabilities : INotifyPropertyChanged
Public Interface IEdChordListScanCapabilities
    Inherits INotifyPropertyChanged
public interface class IEdChordListScanCapabilities : INotifyPropertyChanged
type IEdChordListScanCapabilities =
    interface
        interface INotifyPropertyChanged
    end

The IEdChordListScanCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AspectRatio | Gets the aspect ratio.
Public property | HasHardwareConnection | Gets a value indicating whether or not the hardware is connected.
Public property | MaximumNumberOfChords | Gets maximum number of chords.
Public property | MaximumPixelSize | Gets maximum pixel size (smallest resolution). For example, 1/32 pixels.
Public property | MinimumNumberOfChords | Gets minimum number of chords.
Public property | MinimumPixelSize | Gets minimum pixel size (largest resolution). For example, 1/8k pixels.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition.Ed Namespace


IEdChordListScanCapabilities Properties

The IEdChordListScanCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AspectRatio | Gets the aspect ratio.
Public property | HasHardwareConnection | Gets a value indicating whether or not the hardware is connected.
Public property | MaximumNumberOfChords | Gets maximum number of chords.
Public property | MaximumPixelSize | Gets maximum pixel size (smallest resolution). For example, 1/32 pixels.
Public property | MinimumNumberOfChords | Gets minimum number of chords.
Public property | MinimumPixelSize | Gets minimum pixel size (largest resolution). For example, 1/8k pixels.
Top
See Also

Reference

IEdChordListScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListScanCapabilities.AspectRatio Property

Gets the aspect ratio.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double AspectRatio { get; }
ReadOnly Property AspectRatio As Double
    Get
property double AspectRatio {
    double get ();
}
abstract AspectRatio : float with get

Property Value

Type: Double
See Also

Reference

IEdChordListScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListScanCapabilities.HasHardwareConnection Property

Gets a value indicating whether or not the hardware is connected.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasHardwareConnection { get; }
ReadOnly Property HasHardwareConnection As Boolean
    Get
property bool HasHardwareConnection {
    bool get ();
}
abstract HasHardwareConnection : bool with get

Property Value

Type: Boolean
See Also

Reference

IEdChordListScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListScanCapabilities.MaximumNumberOfChords Property

Gets maximum number of chords.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MaximumNumberOfChords { get; }
ReadOnly Property MaximumNumberOfChords As Integer
    Get
property int MaximumNumberOfChords {
    int get ();
}
abstract MaximumNumberOfChords : int with get

Property Value

Type: Int32
See Also

Reference

IEdChordListScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListScanCapabilities.MaximumPixelSize Property

Gets maximum pixel size (smallest resolution). For example, 1/32 pixels.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MaximumPixelSize { get; }
ReadOnly Property MaximumPixelSize As Double
    Get
property double MaximumPixelSize {
    double get ();
}
abstract MaximumPixelSize : float with get

Property Value

Type: Double
See Also

Reference

IEdChordListScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListScanCapabilities.MinimumNumberOfChords Property

Gets minimum number of chords.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MinimumNumberOfChords { get; }
ReadOnly Property MinimumNumberOfChords As Integer
    Get
property int MinimumNumberOfChords {
    int get ();
}
abstract MinimumNumberOfChords : int with get

Property Value

Type: Int32
See Also

Reference

IEdChordListScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListScanCapabilities.MinimumPixelSize Property

Gets minimum pixel size (largest resolution). For example, 1/8k pixels.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MinimumPixelSize { get; }
ReadOnly Property MinimumPixelSize As Double
    Get
property double MinimumPixelSize {
    double get ();
}
abstract MinimumPixelSize : float with get

Property Value

Type: Double
See Also

Reference

IEdChordListScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListScanCapabilities Events

The IEdChordListScanCapabilities type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IEdChordListScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings Interface

An Interface that defines settings and capabilities for Ed chordlist acquisition.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdChordListSettings : INotifyPropertyChanged
Public Interface IEdChordListSettings
    Inherits INotifyPropertyChanged
public interface class IEdChordListSettings : INotifyPropertyChanged
type IEdChordListSettings =
    interface
        interface INotifyPropertyChanged
    end

The IEdChordListSettings type exposes the following members.

Properties
 | Name | Description
Public property | AutoIdSettings | Gets the AutoID settings.
Public property | ChordLists | Gets or sets the chordlists to acquire.
Public property | EdCapabilities | Gets the Ed Capabilities.
Public property | EdSettings | Gets the Ed Settings.
Public property | EnablePulsePileupCorrection | Gets or sets a value indicating whether to enable pulse pile-up correction.
Public property | NumberOfProcessingThreads | Gets or sets the number of processing threads.
Public property | QuantSettings | Gets the SEM quant settings.
Public property | ScanCapabilities | Gets the Scan Capabilities.
Top
Methods
 | Name | Description
Public method | CopyFrom | Copies the settings from specified source.
Public method | Validate | Validates all the settings.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings Properties

The IEdChordListSettings type exposes the following members.

Properties
 | Name | Description
Public property | AutoIdSettings | Gets the AutoID settings.
Public property | ChordLists | Gets or sets the chordlists to acquire.
Public property | EdCapabilities | Gets the Ed Capabilities.
Public property | EdSettings | Gets the Ed Settings.
Public property | EnablePulsePileupCorrection | Gets or sets a value indicating whether to enable pulse pile-up correction.
Public property | NumberOfProcessingThreads | Gets or sets the number of processing threads.
Public property | QuantSettings | Gets the SEM quant settings.
Public property | ScanCapabilities | Gets the Scan Capabilities.
Top
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings.AutoIdSettings Property

Gets the AutoID settings.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IAutoIdSettings AutoIdSettings { get; }
ReadOnly Property AutoIdSettings As IAutoIdSettings
    Get
property IAutoIdSettings^ AutoIdSettings {
    IAutoIdSettings^ get ();
}
abstract AutoIdSettings : IAutoIdSettings with get

Property Value

Type: IAutoIdSettings
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings.ChordLists Property

Gets or sets the chordlists to acquire.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IReadOnlyList<ChordList> ChordLists { get; set; }
Property ChordLists As IReadOnlyList(Of ChordList)
    Get
    Set
property IReadOnlyList<ChordList^>^ ChordLists {
    IReadOnlyList<ChordList^>^ get ();
    void set (IReadOnlyList<ChordList^>^ value);
}
abstract ChordLists : IReadOnlyList<ChordList> with get, set

Property Value

Type: IReadOnlyList ChordList
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings.EdCapabilities Property

Gets the Ed Capabilities.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdCapabilities EdCapabilities { get; }
ReadOnly Property EdCapabilities As IEdCapabilities
    Get
property IEdCapabilities^ EdCapabilities {
    IEdCapabilities^ get ();
}
abstract EdCapabilities : IEdCapabilities with get

Property Value

Type: IEdCapabilities
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings.EdSettings Property

Gets the Ed Settings.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSettings EdSettings { get; }
ReadOnly Property EdSettings As IEdSettings
    Get
property IEdSettings^ EdSettings {
    IEdSettings^ get ();
}
abstract EdSettings : IEdSettings with get

Property Value

Type: IEdSettings
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings.EnablePulsePileupCorrection Property

Gets or sets a value indicating whether to enable pulse pile-up correction.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool EnablePulsePileupCorrection { get; set; }
Property EnablePulsePileupCorrection As Boolean
    Get
    Set
property bool EnablePulsePileupCorrection {
    bool get ();
    void set (bool value);
}
abstract EnablePulsePileupCorrection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings.NumberOfProcessingThreads Property

Gets or sets the number of processing threads.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int NumberOfProcessingThreads { get; set; }
Property NumberOfProcessingThreads As Integer
    Get
    Set
property int NumberOfProcessingThreads {
    int get ();
    void set (int value);
}
abstract NumberOfProcessingThreads : int with get, set

Property Value

Type: Int32
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings.QuantSettings Property

Gets the SEM quant settings.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ISEMQuantSettings QuantSettings { get; }
ReadOnly Property QuantSettings As ISEMQuantSettings
    Get
property ISEMQuantSettings^ QuantSettings {
    ISEMQuantSettings^ get ();
}
abstract QuantSettings : ISEMQuantSettings with get

Property Value

Type: ISEMQuantSettings
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings.ScanCapabilities Property

Gets the Scan Capabilities.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdChordListScanCapabilities ScanCapabilities { get; }
ReadOnly Property ScanCapabilities As IEdChordListScanCapabilities
    Get
property IEdChordListScanCapabilities^ ScanCapabilities {
    IEdChordListScanCapabilities^ get ();
}
abstract ScanCapabilities : IEdChordListScanCapabilities with get

Property Value

Type: IEdChordListScanCapabilities
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings Methods

The IEdChordListSettings type exposes the following members.

Methods
 | Name | Description
Public method | CopyFrom | Copies the settings from specified source.
Public method | Validate | Validates all the settings.
Top
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings.CopyFrom Method

Copies the settings from specified source.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void CopyFrom(
    IEdChordListSettings source
)
Sub CopyFrom (
    source As IEdChordListSettings
)
void CopyFrom(
    IEdChordListSettings^ source
)
abstract CopyFrom :
        source : IEdChordListSettings -> unit

Parameters

source
Type: OINA.Extender.Acquisition.EdIEdChordListSettings
The source settings.
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings.Validate Method

Validates all the settings.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IValidationResults Validate()
Function Validate As IValidationResults
IValidationResults^ Validate()
abstract Validate : unit -> IValidationResults

Return Value

Type: IValidationResults
The validation results
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdChordListSettings Events

The IEdChordListSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IEdChordListSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings Interface

An Interface that defines settings for Ed acquisition.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdSettings : INotifyPropertyChanged
Public Interface IEdSettings
    Inherits INotifyPropertyChanged
public interface class IEdSettings : INotifyPropertyChanged
type IEdSettings =
    interface
        interface INotifyPropertyChanged
    end

The IEdSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionMode | Gets or sets the acquisition mode.
Public property | AcquisitionTime | Gets or sets the acquisition time.
Public property | EnergyRange | Gets or sets the energy range (keV).
Public property | IsHardwareEnabled | Gets a value to determine whether detectors are enabled/disabled. For use in multiple Ed detector systems to identify which detectors are in use.
Public property | NumberOfChannels | Gets or sets the number of channels
Public property | PrimaryHardwareId | Gets or sets the id of the primary device. For use in multiple Ed detector systems to identify the primary detector.
Public property | ProcessTime | Gets or sets the process time.
Public property | TimeMode | Gets or sets the time mode.
Top
Methods
 | Name | Description
Public method | CopyFrom | Synchronizes the settings from a source
Public method | EnableDevice | Enable/disable an Ed device. For use with multiple Ed detector systems.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Examples
Copy
public void Run()
{
    Console.WriteLine();
    Console.WriteLine(@"Spectrum Acquisition Example.");
    Console.WriteLine();

    Console.WriteLine();
    Console.WriteLine(@"Quantification Processing Option:");

    // Get choice of processing option from user
    var processingOptions = new Dictionary<int, string>
    {
        { 1, "All Elements" },
        { 2, "Element by Difference" },
        { 3, "Element by Stoichiometry" }
    };

    this.userProcessingOption = Program.MakeChoice(processingOptions);

    IEdSpectrumSettings edSpectrumSettings = AcquireFactory.CreateEdSpectrumSettings();

    edSpectrumSettings.EdSettings.AcquisitionMode = EdAcquireMode.LiveTime; // RealTime or LiveTime
    edSpectrumSettings.EdSettings.AcquisitionTime = TimeSpan.FromSeconds(2);

    Console.WriteLine(@"Allowed Process Times: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedProcessTimes));
    Console.WriteLine(@"Allowed Energy Ranges: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedEnergyRanges));
    Console.WriteLine(@"Allowed Number of Channels: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedNumberOfChannels));

    edSpectrumSettings.EdSettings.ProcessTime = 1;
    edSpectrumSettings.EdSettings.EnergyRange = 10;
    edSpectrumSettings.EdSettings.NumberOfChannels = 1024;

    edSpectrumSettings.ScanSettings.AcquisitionRegion.CreateFullFieldRegion(1.0 / 1024.0);

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = AcquireFactory.CreateEdSpectrumServer();

    // Event handlers for spectrum acquisition controller events
    edSpectrumAcquisitionController.ExperimentStarting += this.OnEdSpectrumExperimentStarting;
    edSpectrumAcquisitionController.ExperimentFinished += this.OnEdSpectrumExperimentFinished;

    // IEdSpectrumSettings.EdCapabilities will validate settings and hardware availability.
    if (edSpectrumAcquisitionController.IsEdHardwareReady(edSpectrumSettings))
    {
        // This only used for multiple acquisition:
        //      if this is the first acquisition, call BeginMultipleAcquisition
        //      on the IEdSpectrumAcquisitionController to suppress external scan switching
        edSpectrumAcquisitionController.BeginMultipleAcquisition();

        // Start spectrum acquisition
        try
        {
            IEdSpectrum edSpectrum = edSpectrumAcquisitionController.StartAcquisition(edSpectrumSettings);

            edSpectrum.Label = @"Code Example Spectrum";
        }
        catch (InvalidSettingsException invalidSettingsException)
        {
            Console.WriteLine(@"Invalid Settings Exception:");
            Console.WriteLine(
                @"{0} {1}",
                invalidSettingsException.Message,
                string.Join(",", invalidSettingsException.ValidationResults.ValidationErrors));
        }
        catch (AcquisitionStartException acquisitionStartException)
        {
            Console.WriteLine(@"Acquisition Start Exception:");
            Console.WriteLine(acquisitionStartException.Message);
        }
    }
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Starting.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The <see cref="AcquisitionFinishedEventArgs{IEdSpectrum}"/> instance containing the event data.</param>
private void OnEdSpectrumExperimentStarting(object sender, AcquisitionStartingEventArgs<IEdSpectrum> e)
{
    IEdSpectrum edSpectrum = e.Value;

    Console.WriteLine(@"Spectrum Acquisition starting: {0}", edSpectrum.Label);
    Console.WriteLine();

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        edSpectrumAcquisitionController.ExperimentStarting -= this.OnEdSpectrumExperimentStarting;
        edSpectrumAcquisitionController.ExperimentStarted += this.OnEdSpectrumExperimentStarted;
    }

    edSpectrum.PropertyChanged += this.OnPropertyChanged;
    edSpectrum.DataChanged += this.OnDataChanged;
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Started.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The <see cref="AcquisitionFinishedEventArgs{IEdSpectrum}"/> instance containing the event data.</param>
private void OnEdSpectrumExperimentStarted(object sender, AcquisitionStartedEventArgs<IEdSpectrum> e)
{
    IEdSpectrum edSpectrum = e.Value;

    Console.WriteLine(@"Spectrum Acquisition started: {0}", edSpectrum.Label);
    Console.WriteLine();

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        edSpectrumAcquisitionController.ExperimentStarted -= this.OnEdSpectrumExperimentStarted;
    }
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Finished
/// </summary>
/// <param name="sender">sender object</param>
/// <param name="e">The instance containing the event data.</param>
private void OnEdSpectrumExperimentFinished(object sender, AcquisitionFinishedEventArgs<IEdSpectrum> e)
{
    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        // This only used for multiple acquisition:
        //      If this is the last experiment, call EndMultipleAcquisition on the Acquisition
        //      controller, to re-enable external scan switching
        edSpectrumAcquisitionController.EndMultipleAcquisition();

        edSpectrumAcquisitionController.ExperimentFinished -= this.OnEdSpectrumExperimentFinished;
    }

    IEdSpectrum edSpectrum = e.Value;

    edSpectrum.PropertyChanged -= this.OnPropertyChanged;
    edSpectrum.DataChanged -= this.OnDataChanged;

    Console.WriteLine();
    Console.WriteLine(@"Spectrum Acquisition finished: {0}", edSpectrum.Label);
    Console.WriteLine(@"    AcquisitionDate: {0}", edSpectrum.AcquisitionDate);
    Console.WriteLine(@"    LiveTime: {0:0.00}, RealTime: {1:0.00}", edSpectrum.LiveTimeSeconds, edSpectrum.RealTimeSeconds);
    Console.WriteLine();

    this.edSpectrum = edSpectrum;

    this.DoAutoID();
    this.DoQuant();

    Console.WriteLine();
    Console.WriteLine();
    Console.WriteLine(@"Code Example finished.");
}

/// <summary>
/// Called when IEdSpectrum PropertyChanged
/// </summary>
/// <param name="sender">Event source</param>
/// <param name="e">Event arguments</param>
private void OnPropertyChanged(object sender, PropertyChangedEventArgs e)
{
    var edSpectrum = (IEdSpectrum)sender;

    var output = string.Empty;

    switch (e.PropertyName)
    {
        case "ColumnConditions":
            output = string.Format(CultureInfo.InvariantCulture, @"     Column Conditions: eg WorkingDistance - {0:0.00}", edSpectrum.ColumnConditions.WorkingDistance);
            break;
        case "StageConditions":
            output = string.Format(CultureInfo.InvariantCulture, @"     Stage Conditions: eg StageR - {0:0.00}", edSpectrum.StageConditions.StageR);
            break;
        case "AcquisitionDate":
            output = string.Format(CultureInfo.InvariantCulture, @"     Acquisition Date: {0:dd-MMM-yy HH:mm:ss}", edSpectrum.AcquisitionDate);
            break;
        case "HardwareIds":
            output = string.Format(CultureInfo.InvariantCulture, @"     HardwareIds: eg DetectorDeviceId - {0}", string.Join(",", edSpectrum.HardwareIds.Select(h => h.DetectorDeviceId).ToArray()));
            break;
        case "PrimaryHardwareId":
            output = string.Format(CultureInfo.InvariantCulture, @"     PrimaryHardwareId: eg DetectorDeviceId - {0}", string.Join(",", edSpectrum.PrimaryHardwareId.DetectorDeviceId));
            break;
        case "RealTimeSeconds":
            output = string.Format(CultureInfo.InvariantCulture, @"     Real Time - {0:0.00}", edSpectrum.RealTimeSeconds);
            break;
        case "LiveTimeSeconds":
            output = string.Format(CultureInfo.InvariantCulture, @"     Live Time - {0:0.00}", edSpectrum.LiveTimeSeconds);
            break;
        default:
            output = string.Format(CultureInfo.InvariantCulture, @"     {0}", e.PropertyName);
            break;
    }

    Console.WriteLine(@"Property Changed:{0}{1}", Environment.NewLine, output);
    Console.WriteLine();
}

/// <summary>
/// Called when IEdSpectrum DataChanged
/// </summary>
/// <param name="sender">Event source</param>
/// <param name="e">Event arguments</param>
private void OnDataChanged(object sender, EventArgs e)
{
    var edSpectrum = (IEdSpectrum)sender;

    var buffer = new int[edSpectrum.NumberOfChannels];

    edSpectrum.GetChannelData(buffer);

    Console.WriteLine(@"Data Changed - ChannelData: {0}{1}", Environment.NewLine, string.Join(",", buffer));
    Console.WriteLine();
}
See Also

Reference

OINA.Extender.Acquisition.Ed Namespace


IEdSettings Properties

The IEdSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionMode | Gets or sets the acquisition mode.
Public property | AcquisitionTime | Gets or sets the acquisition time.
Public property | EnergyRange | Gets or sets the energy range (keV).
Public property | IsHardwareEnabled | Gets a value to determine whether detectors are enabled/disabled. For use in multiple Ed detector systems to identify which detectors are in use.
Public property | NumberOfChannels | Gets or sets the number of channels
Public property | PrimaryHardwareId | Gets or sets the id of the primary device. For use in multiple Ed detector systems to identify the primary detector.
Public property | ProcessTime | Gets or sets the process time.
Public property | TimeMode | Gets or sets the time mode.
Top
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings.AcquisitionMode Property

Gets or sets the acquisition mode.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
EdAcquireMode AcquisitionMode { get; set; }
Property AcquisitionMode As EdAcquireMode
    Get
    Set
property EdAcquireMode AcquisitionMode {
    EdAcquireMode get ();
    void set (EdAcquireMode value);
}
abstract AcquisitionMode : EdAcquireMode with get, set

Property Value

Type: EdAcquireMode
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings.AcquisitionTime Property

Gets or sets the acquisition time.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
TimeSpan AcquisitionTime { get; set; }
Property AcquisitionTime As TimeSpan
    Get
    Set
property TimeSpan AcquisitionTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
abstract AcquisitionTime : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings.EnergyRange Property

Gets or sets the energy range (keV).

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int EnergyRange { get; set; }
Property EnergyRange As Integer
    Get
    Set
property int EnergyRange {
    int get ();
    void set (int value);
}
abstract EnergyRange : int with get, set

Property Value

Type: Int32
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings.IsHardwareEnabled Property

Gets a value to determine whether detectors are enabled/disabled. For use in multiple Ed detector systems to identify which detectors are in use.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ReadOnlyDictionary<EdHardwareId, bool> IsHardwareEnabled { get; }
ReadOnly Property IsHardwareEnabled As ReadOnlyDictionary(Of EdHardwareId, Boolean)
    Get
property ReadOnlyDictionary<EdHardwareId^, bool>^ IsHardwareEnabled {
    ReadOnlyDictionary<EdHardwareId^, bool>^ get ();
}
abstract IsHardwareEnabled : ReadOnlyDictionary<EdHardwareId, bool> with get

Property Value

Type: ReadOnlyDictionary EdHardwareId, Boolean
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings.NumberOfChannels Property

Gets or sets the number of channels

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int NumberOfChannels { get; set; }
Property NumberOfChannels As Integer
    Get
    Set
property int NumberOfChannels {
    int get ();
    void set (int value);
}
abstract NumberOfChannels : int with get, set

Property Value

Type: Int32
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings.PrimaryHardwareId Property

Gets or sets the id of the primary device. For use in multiple Ed detector systems to identify the primary detector.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
EdHardwareId PrimaryHardwareId { get; set; }
Property PrimaryHardwareId As EdHardwareId
    Get
    Set
property EdHardwareId^ PrimaryHardwareId {
    EdHardwareId^ get ();
    void set (EdHardwareId^ value);
}
abstract PrimaryHardwareId : EdHardwareId with get, set

Property Value

Type: EdHardwareId
The primary hardware identifier.
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings.ProcessTime Property

Gets or sets the process time.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int ProcessTime { get; set; }
Property ProcessTime As Integer
    Get
    Set
property int ProcessTime {
    int get ();
    void set (int value);
}
abstract ProcessTime : int with get, set

Property Value

Type: Int32
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings.TimeMode Property

Gets or sets the time mode.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
EdTimeMode TimeMode { get; set; }
Property TimeMode As EdTimeMode
    Get
    Set
property EdTimeMode TimeMode {
    EdTimeMode get ();
    void set (EdTimeMode value);
}
abstract TimeMode : EdTimeMode with get, set

Property Value

Type: EdTimeMode
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings Methods

The IEdSettings type exposes the following members.

Methods
 | Name | Description
Public method | CopyFrom | Synchronizes the settings from a source
Public method | EnableDevice | Enable/disable an Ed device. For use with multiple Ed detector systems.
Top
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings.CopyFrom Method

Synchronizes the settings from a source

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void CopyFrom(
    IEdSettings sourceSettings
)
Sub CopyFrom (
    sourceSettings As IEdSettings
)
void CopyFrom(
    IEdSettings^ sourceSettings
)
abstract CopyFrom :
        sourceSettings : IEdSettings -> unit

Parameters

sourceSettings
Type: OINA.Extender.Acquisition.EdIEdSettings
The source settings
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings.EnableDevice Method

Enable/disable an Ed device. For use with multiple Ed detector systems.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void EnableDevice(
    EdHardwareId hardwareId,
    bool isEnabled
)
Sub EnableDevice (
    hardwareId As EdHardwareId,
    isEnabled As Boolean
)
void EnableDevice(
    EdHardwareId^ hardwareId,
    bool isEnabled
)
abstract EnableDevice :
        hardwareId : EdHardwareId *
        isEnabled : bool -> unit

Parameters

hardwareId
Type: OINA.Extender.Data.EdEdHardwareId
The ed device Id
isEnabled
Type: SystemBoolean
true to enable the device for acquisition
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSettings Events

The IEdSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IEdSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController Interface

An Interface for acquiring a spectrum.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdSpectrumAcquisitionController
Public Interface IEdSpectrumAcquisitionController
public interface class IEdSpectrumAcquisitionController
type IEdSpectrumAcquisitionController =  interface end

The IEdSpectrumAcquisitionController type exposes the following members.

Properties
 | Name | Description
Public property | CurrentSpectrum | Gets the current spectrum.
Public property | IsAcquiring | Gets a value indicating whether there is an acquisition in progress.
Top
Methods
 | Name | Description
Public method | BeginMultipleAcquisition | Requests that external scan control will not be released after acquisition has finished.
Public method | EndMultipleAcquisition | Releases external scan control. Any acquisition controller can be used to release external scan control.
Public method | IsEdHardwareReady | Gets a value indicating whether or not the Ed hardware is ready.
Public method | ResumeAcquisition | Resumes acquisition of a previously acquired spectrum.
Public method | StartAcquisition | Start spectrum acquisition.
Public method | StopAcquisition | Stop acquisition immediately.
Top
Events
 | Name | Description
Public event | ExperimentFinished | Occurs when Spectrum acquisition is finished.
Public event | ExperimentStarted | Occurs when Spectrum acquisition has started.
Public event | ExperimentStarting | Occurs before Spectrum acquisition starts.
Top
Examples
Copy
public void Run()
{
    Console.WriteLine();
    Console.WriteLine(@"Spectrum Acquisition Example.");
    Console.WriteLine();

    Console.WriteLine();
    Console.WriteLine(@"Quantification Processing Option:");

    // Get choice of processing option from user
    var processingOptions = new Dictionary<int, string>
    {
        { 1, "All Elements" },
        { 2, "Element by Difference" },
        { 3, "Element by Stoichiometry" }
    };

    this.userProcessingOption = Program.MakeChoice(processingOptions);

    IEdSpectrumSettings edSpectrumSettings = AcquireFactory.CreateEdSpectrumSettings();

    edSpectrumSettings.EdSettings.AcquisitionMode = EdAcquireMode.LiveTime; // RealTime or LiveTime
    edSpectrumSettings.EdSettings.AcquisitionTime = TimeSpan.FromSeconds(2);

    Console.WriteLine(@"Allowed Process Times: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedProcessTimes));
    Console.WriteLine(@"Allowed Energy Ranges: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedEnergyRanges));
    Console.WriteLine(@"Allowed Number of Channels: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedNumberOfChannels));

    edSpectrumSettings.EdSettings.ProcessTime = 1;
    edSpectrumSettings.EdSettings.EnergyRange = 10;
    edSpectrumSettings.EdSettings.NumberOfChannels = 1024;

    edSpectrumSettings.ScanSettings.AcquisitionRegion.CreateFullFieldRegion(1.0 / 1024.0);

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = AcquireFactory.CreateEdSpectrumServer();

    // Event handlers for spectrum acquisition controller events
    edSpectrumAcquisitionController.ExperimentStarting += this.OnEdSpectrumExperimentStarting;
    edSpectrumAcquisitionController.ExperimentFinished += this.OnEdSpectrumExperimentFinished;

    // IEdSpectrumSettings.EdCapabilities will validate settings and hardware availability.
    if (edSpectrumAcquisitionController.IsEdHardwareReady(edSpectrumSettings))
    {
        // This only used for multiple acquisition:
        //      if this is the first acquisition, call BeginMultipleAcquisition
        //      on the IEdSpectrumAcquisitionController to suppress external scan switching
        edSpectrumAcquisitionController.BeginMultipleAcquisition();

        // Start spectrum acquisition
        try
        {
            IEdSpectrum edSpectrum = edSpectrumAcquisitionController.StartAcquisition(edSpectrumSettings);

            edSpectrum.Label = @"Code Example Spectrum";
        }
        catch (InvalidSettingsException invalidSettingsException)
        {
            Console.WriteLine(@"Invalid Settings Exception:");
            Console.WriteLine(
                @"{0} {1}",
                invalidSettingsException.Message,
                string.Join(",", invalidSettingsException.ValidationResults.ValidationErrors));
        }
        catch (AcquisitionStartException acquisitionStartException)
        {
            Console.WriteLine(@"Acquisition Start Exception:");
            Console.WriteLine(acquisitionStartException.Message);
        }
    }
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Starting.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The <see cref="AcquisitionFinishedEventArgs{IEdSpectrum}"/> instance containing the event data.</param>
private void OnEdSpectrumExperimentStarting(object sender, AcquisitionStartingEventArgs<IEdSpectrum> e)
{
    IEdSpectrum edSpectrum = e.Value;

    Console.WriteLine(@"Spectrum Acquisition starting: {0}", edSpectrum.Label);
    Console.WriteLine();

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        edSpectrumAcquisitionController.ExperimentStarting -= this.OnEdSpectrumExperimentStarting;
        edSpectrumAcquisitionController.ExperimentStarted += this.OnEdSpectrumExperimentStarted;
    }

    edSpectrum.PropertyChanged += this.OnPropertyChanged;
    edSpectrum.DataChanged += this.OnDataChanged;
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Started.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The <see cref="AcquisitionFinishedEventArgs{IEdSpectrum}"/> instance containing the event data.</param>
private void OnEdSpectrumExperimentStarted(object sender, AcquisitionStartedEventArgs<IEdSpectrum> e)
{
    IEdSpectrum edSpectrum = e.Value;

    Console.WriteLine(@"Spectrum Acquisition started: {0}", edSpectrum.Label);
    Console.WriteLine();

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        edSpectrumAcquisitionController.ExperimentStarted -= this.OnEdSpectrumExperimentStarted;
    }
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Finished
/// </summary>
/// <param name="sender">sender object</param>
/// <param name="e">The instance containing the event data.</param>
private void OnEdSpectrumExperimentFinished(object sender, AcquisitionFinishedEventArgs<IEdSpectrum> e)
{
    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        // This only used for multiple acquisition:
        //      If this is the last experiment, call EndMultipleAcquisition on the Acquisition
        //      controller, to re-enable external scan switching
        edSpectrumAcquisitionController.EndMultipleAcquisition();

        edSpectrumAcquisitionController.ExperimentFinished -= this.OnEdSpectrumExperimentFinished;
    }

    IEdSpectrum edSpectrum = e.Value;

    edSpectrum.PropertyChanged -= this.OnPropertyChanged;
    edSpectrum.DataChanged -= this.OnDataChanged;

    Console.WriteLine();
    Console.WriteLine(@"Spectrum Acquisition finished: {0}", edSpectrum.Label);
    Console.WriteLine(@"    AcquisitionDate: {0}", edSpectrum.AcquisitionDate);
    Console.WriteLine(@"    LiveTime: {0:0.00}, RealTime: {1:0.00}", edSpectrum.LiveTimeSeconds, edSpectrum.RealTimeSeconds);
    Console.WriteLine();

    this.edSpectrum = edSpectrum;

    this.DoAutoID();
    this.DoQuant();

    Console.WriteLine();
    Console.WriteLine();
    Console.WriteLine(@"Code Example finished.");
}

/// <summary>
/// Called when IEdSpectrum PropertyChanged
/// </summary>
/// <param name="sender">Event source</param>
/// <param name="e">Event arguments</param>
private void OnPropertyChanged(object sender, PropertyChangedEventArgs e)
{
    var edSpectrum = (IEdSpectrum)sender;

    var output = string.Empty;

    switch (e.PropertyName)
    {
        case "ColumnConditions":
            output = string.Format(CultureInfo.InvariantCulture, @"     Column Conditions: eg WorkingDistance - {0:0.00}", edSpectrum.ColumnConditions.WorkingDistance);
            break;
        case "StageConditions":
            output = string.Format(CultureInfo.InvariantCulture, @"     Stage Conditions: eg StageR - {0:0.00}", edSpectrum.StageConditions.StageR);
            break;
        case "AcquisitionDate":
            output = string.Format(CultureInfo.InvariantCulture, @"     Acquisition Date: {0:dd-MMM-yy HH:mm:ss}", edSpectrum.AcquisitionDate);
            break;
        case "HardwareIds":
            output = string.Format(CultureInfo.InvariantCulture, @"     HardwareIds: eg DetectorDeviceId - {0}", string.Join(",", edSpectrum.HardwareIds.Select(h => h.DetectorDeviceId).ToArray()));
            break;
        case "PrimaryHardwareId":
            output = string.Format(CultureInfo.InvariantCulture, @"     PrimaryHardwareId: eg DetectorDeviceId - {0}", string.Join(",", edSpectrum.PrimaryHardwareId.DetectorDeviceId));
            break;
        case "RealTimeSeconds":
            output = string.Format(CultureInfo.InvariantCulture, @"     Real Time - {0:0.00}", edSpectrum.RealTimeSeconds);
            break;
        case "LiveTimeSeconds":
            output = string.Format(CultureInfo.InvariantCulture, @"     Live Time - {0:0.00}", edSpectrum.LiveTimeSeconds);
            break;
        default:
            output = string.Format(CultureInfo.InvariantCulture, @"     {0}", e.PropertyName);
            break;
    }

    Console.WriteLine(@"Property Changed:{0}{1}", Environment.NewLine, output);
    Console.WriteLine();
}

/// <summary>
/// Called when IEdSpectrum DataChanged
/// </summary>
/// <param name="sender">Event source</param>
/// <param name="e">Event arguments</param>
private void OnDataChanged(object sender, EventArgs e)
{
    var edSpectrum = (IEdSpectrum)sender;

    var buffer = new int[edSpectrum.NumberOfChannels];

    edSpectrum.GetChannelData(buffer);

    Console.WriteLine(@"Data Changed - ChannelData: {0}{1}", Environment.NewLine, string.Join(",", buffer));
    Console.WriteLine();
}
See Also

Reference

OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController Properties

The IEdSpectrumAcquisitionController type exposes the following members.

Properties
 | Name | Description
Public property | CurrentSpectrum | Gets the current spectrum.
Public property | IsAcquiring | Gets a value indicating whether there is an acquisition in progress.
Top
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController.CurrentSpectrum Property

Gets the current spectrum.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSpectrum CurrentSpectrum { get; }
ReadOnly Property CurrentSpectrum As IEdSpectrum
    Get
property IEdSpectrum^ CurrentSpectrum {
    IEdSpectrum^ get ();
}
abstract CurrentSpectrum : IEdSpectrum with get

Property Value

Type: IEdSpectrum
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController.IsAcquiring Property

Gets a value indicating whether there is an acquisition in progress.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsAcquiring { get; }
ReadOnly Property IsAcquiring As Boolean
    Get
property bool IsAcquiring {
    bool get ();
}
abstract IsAcquiring : bool with get

Property Value

Type: Boolean
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController Methods

The IEdSpectrumAcquisitionController type exposes the following members.

Methods
 | Name | Description
Public method | BeginMultipleAcquisition | Requests that external scan control will not be released after acquisition has finished.
Public method | EndMultipleAcquisition | Releases external scan control. Any acquisition controller can be used to release external scan control.
Public method | IsEdHardwareReady | Gets a value indicating whether or not the Ed hardware is ready.
Public method | ResumeAcquisition | Resumes acquisition of a previously acquired spectrum.
Public method | StartAcquisition | Start spectrum acquisition.
Public method | StopAcquisition | Stop acquisition immediately.
Top
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController.BeginMultipleAcquisition Method

Requests that external scan control will not be released after acquisition has finished.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void BeginMultipleAcquisition()
Sub BeginMultipleAcquisition
void BeginMultipleAcquisition()
abstract BeginMultipleAcquisition : unit -> unit
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController.EndMultipleAcquisition Method

Releases external scan control. Any acquisition controller can be used to release external scan control.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void EndMultipleAcquisition()
Sub EndMultipleAcquisition
void EndMultipleAcquisition()
abstract EndMultipleAcquisition : unit -> unit
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController.IsEdHardwareReady Method

Gets a value indicating whether or not the Ed hardware is ready.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsEdHardwareReady(
    IEdSpectrumSettings settings
)
Function IsEdHardwareReady (
    settings As IEdSpectrumSettings
) As Boolean
bool IsEdHardwareReady(
    IEdSpectrumSettings^ settings
)
abstract IsEdHardwareReady :
        settings : IEdSpectrumSettings -> bool

Parameters

settings
Type: OINA.Extender.Acquisition.EdIEdSpectrumSettings
The Ed Spectrum settings

Return Value

Type: Boolean
true if the hardware can be used
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController.ResumeAcquisition Method

Resumes acquisition of a previously acquired spectrum.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void ResumeAcquisition(
    IEdSpectrumSettings settings,
    IEdSpectrum spectrum
)
Sub ResumeAcquisition (
    settings As IEdSpectrumSettings,
    spectrum As IEdSpectrum
)
void ResumeAcquisition(
    IEdSpectrumSettings^ settings,
    IEdSpectrum^ spectrum
)
abstract ResumeAcquisition :
        settings : IEdSpectrumSettings *
        spectrum : IEdSpectrum -> unit

Parameters

settings
Type: OINA.Extender.Acquisition.EdIEdSpectrumSettings
The Ed Spectrum settings
spectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The Ed Spectrum
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController.StartAcquisition Method

Start spectrum acquisition.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSpectrum StartAcquisition(
    IEdSpectrumSettings settings
)
Function StartAcquisition (
    settings As IEdSpectrumSettings
) As IEdSpectrum
IEdSpectrum^ StartAcquisition(
    IEdSpectrumSettings^ settings
)
abstract StartAcquisition :
        settings : IEdSpectrumSettings -> IEdSpectrum

Parameters

settings
Type: OINA.Extender.Acquisition.EdIEdSpectrumSettings
The Ed Spectrum settings

Return Value

Type: IEdSpectrum
The Ed Spectrum
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController.StopAcquisition Method

Stop acquisition immediately.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void StopAcquisition()
Sub StopAcquisition
void StopAcquisition()
abstract StopAcquisition : unit -> unit
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController Events

The IEdSpectrumAcquisitionController type exposes the following members.

Events
 | Name | Description
Public event | ExperimentFinished | Occurs when Spectrum acquisition is finished.
Public event | ExperimentStarted | Occurs when Spectrum acquisition has started.
Public event | ExperimentStarting | Occurs before Spectrum acquisition starts.
Top
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController.ExperimentFinished Event

Occurs when Spectrum acquisition is finished.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AcquisitionFinishedEventArgs<IEdSpectrum>> ExperimentFinished
Event ExperimentFinished As EventHandler(Of AcquisitionFinishedEventArgs(Of IEdSpectrum))
 event EventHandler<AcquisitionFinishedEventArgs<IEdSpectrum^>^>^ ExperimentFinished {
    void add (EventHandler<AcquisitionFinishedEventArgs<IEdSpectrum^>^>^ value);
    void remove (EventHandler<AcquisitionFinishedEventArgs<IEdSpectrum^>^>^ value);
}
abstract ExperimentFinished : IEvent<EventHandler<AcquisitionFinishedEventArgs<IEdSpectrum>>,
    AcquisitionFinishedEventArgs<IEdSpectrum>>

Value

Type: SystemEventHandler AcquisitionFinishedEventArgs IEdSpectrum
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController.ExperimentStarted Event

Occurs when Spectrum acquisition has started.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AcquisitionStartedEventArgs<IEdSpectrum>> ExperimentStarted
Event ExperimentStarted As EventHandler(Of AcquisitionStartedEventArgs(Of IEdSpectrum))
 event EventHandler<AcquisitionStartedEventArgs<IEdSpectrum^>^>^ ExperimentStarted {
    void add (EventHandler<AcquisitionStartedEventArgs<IEdSpectrum^>^>^ value);
    void remove (EventHandler<AcquisitionStartedEventArgs<IEdSpectrum^>^>^ value);
}
abstract ExperimentStarted : IEvent<EventHandler<AcquisitionStartedEventArgs<IEdSpectrum>>,
    AcquisitionStartedEventArgs<IEdSpectrum>>

Value

Type: SystemEventHandler AcquisitionStartedEventArgs IEdSpectrum
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumAcquisitionController.ExperimentStarting Event

Occurs before Spectrum acquisition starts.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AcquisitionStartingEventArgs<IEdSpectrum>> ExperimentStarting
Event ExperimentStarting As EventHandler(Of AcquisitionStartingEventArgs(Of IEdSpectrum))
 event EventHandler<AcquisitionStartingEventArgs<IEdSpectrum^>^>^ ExperimentStarting {
    void add (EventHandler<AcquisitionStartingEventArgs<IEdSpectrum^>^>^ value);
    void remove (EventHandler<AcquisitionStartingEventArgs<IEdSpectrum^>^>^ value);
}
abstract ExperimentStarting : IEvent<EventHandler<AcquisitionStartingEventArgs<IEdSpectrum>>,
    AcquisitionStartingEventArgs<IEdSpectrum>>

Value

Type: SystemEventHandler AcquisitionStartingEventArgs IEdSpectrum
See Also

Reference

IEdSpectrumAcquisitionController Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumScanCapabilities Interface

An Interface that defines scan capabilities for Ed spectrum acquisition.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdSpectrumScanCapabilities : INotifyPropertyChanged
Public Interface IEdSpectrumScanCapabilities
    Inherits INotifyPropertyChanged
public interface class IEdSpectrumScanCapabilities : INotifyPropertyChanged
type IEdSpectrumScanCapabilities =
    interface
        interface INotifyPropertyChanged
    end

The IEdSpectrumScanCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AspectRatio | Gets the aspect ratio.
Public property | HasHardwareConnection | Gets a value indicating whether or not the hardware is connected.
Public property | MaximumPixelSize | Gets maximum pixel size (smallest resolution). For example, 1/32 pixels.
Public property | MinimumPixelSize | Gets minimum pixel size (largest resolution). For example, 1/8k pixels.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumScanCapabilities Properties

The IEdSpectrumScanCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AspectRatio | Gets the aspect ratio.
Public property | HasHardwareConnection | Gets a value indicating whether or not the hardware is connected.
Public property | MaximumPixelSize | Gets maximum pixel size (smallest resolution). For example, 1/32 pixels.
Public property | MinimumPixelSize | Gets minimum pixel size (largest resolution). For example, 1/8k pixels.
Top
See Also

Reference

IEdSpectrumScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumScanCapabilities.AspectRatio Property

Gets the aspect ratio.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double AspectRatio { get; }
ReadOnly Property AspectRatio As Double
    Get
property double AspectRatio {
    double get ();
}
abstract AspectRatio : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrumScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumScanCapabilities.HasHardwareConnection Property

Gets a value indicating whether or not the hardware is connected.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasHardwareConnection { get; }
ReadOnly Property HasHardwareConnection As Boolean
    Get
property bool HasHardwareConnection {
    bool get ();
}
abstract HasHardwareConnection : bool with get

Property Value

Type: Boolean
See Also

Reference

IEdSpectrumScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumScanCapabilities.MaximumPixelSize Property

Gets maximum pixel size (smallest resolution). For example, 1/32 pixels.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MaximumPixelSize { get; }
ReadOnly Property MaximumPixelSize As Double
    Get
property double MaximumPixelSize {
    double get ();
}
abstract MaximumPixelSize : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrumScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumScanCapabilities.MinimumPixelSize Property

Gets minimum pixel size (largest resolution). For example, 1/8k pixels.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MinimumPixelSize { get; }
ReadOnly Property MinimumPixelSize As Double
    Get
property double MinimumPixelSize {
    double get ();
}
abstract MinimumPixelSize : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrumScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumScanCapabilities Events

The IEdSpectrumScanCapabilities type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IEdSpectrumScanCapabilities Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumScanSettings Interface

An interface that defines scan settings for Ed spectrum acquisition.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdSpectrumScanSettings : INotifyPropertyChanged
Public Interface IEdSpectrumScanSettings
    Inherits INotifyPropertyChanged
public interface class IEdSpectrumScanSettings : INotifyPropertyChanged
type IEdSpectrumScanSettings =
    interface
        interface INotifyPropertyChanged
    end

The IEdSpectrumScanSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionRegion | Gets the acquisition region.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumScanSettings Properties

The IEdSpectrumScanSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionRegion | Gets the acquisition region.
Top
See Also

Reference

IEdSpectrumScanSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumScanSettings.AcquisitionRegion Property

Gets the acquisition region.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IAcquisitionRegion AcquisitionRegion { get; }
ReadOnly Property AcquisitionRegion As IAcquisitionRegion
    Get
property IAcquisitionRegion^ AcquisitionRegion {
    IAcquisitionRegion^ get ();
}
abstract AcquisitionRegion : IAcquisitionRegion with get

Property Value

Type: IAcquisitionRegion
See Also

Reference

IEdSpectrumScanSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumScanSettings Events

The IEdSpectrumScanSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IEdSpectrumScanSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumSettings Interface

An Interface that defines settings and capabilities for Ed spectrum acquisition.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdSpectrumSettings
Public Interface IEdSpectrumSettings
public interface class IEdSpectrumSettings
type IEdSpectrumSettings =  interface end

The IEdSpectrumSettings type exposes the following members.

Properties
 | Name | Description
Public property | EdCapabilities | Gets the Ed Capabilities.
Public property | EdSettings | Gets the Ed Settings.
Public property | ScanCapabilities | Gets the Scan Capabilities.
Public property | ScanSettings | Gets the Scan Settings.
Top
Methods
 | Name | Description
Public method | Validate | Validates all the settings.
Top
See Also

Reference

OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumSettings Properties

The IEdSpectrumSettings type exposes the following members.

Properties
 | Name | Description
Public property | EdCapabilities | Gets the Ed Capabilities.
Public property | EdSettings | Gets the Ed Settings.
Public property | ScanCapabilities | Gets the Scan Capabilities.
Public property | ScanSettings | Gets the Scan Settings.
Top
See Also

Reference

IEdSpectrumSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumSettings.EdCapabilities Property

Gets the Ed Capabilities.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdCapabilities EdCapabilities { get; }
ReadOnly Property EdCapabilities As IEdCapabilities
    Get
property IEdCapabilities^ EdCapabilities {
    IEdCapabilities^ get ();
}
abstract EdCapabilities : IEdCapabilities with get

Property Value

Type: IEdCapabilities
See Also

Reference

IEdSpectrumSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumSettings.EdSettings Property

Gets the Ed Settings.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSettings EdSettings { get; }
ReadOnly Property EdSettings As IEdSettings
    Get
property IEdSettings^ EdSettings {
    IEdSettings^ get ();
}
abstract EdSettings : IEdSettings with get

Property Value

Type: IEdSettings
See Also

Reference

IEdSpectrumSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumSettings.ScanCapabilities Property

Gets the Scan Capabilities.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSpectrumScanCapabilities ScanCapabilities { get; }
ReadOnly Property ScanCapabilities As IEdSpectrumScanCapabilities
    Get
property IEdSpectrumScanCapabilities^ ScanCapabilities {
    IEdSpectrumScanCapabilities^ get ();
}
abstract ScanCapabilities : IEdSpectrumScanCapabilities with get

Property Value

Type: IEdSpectrumScanCapabilities
See Also

Reference

IEdSpectrumSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumSettings.ScanSettings Property

Gets the Scan Settings.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSpectrumScanSettings ScanSettings { get; }
ReadOnly Property ScanSettings As IEdSpectrumScanSettings
    Get
property IEdSpectrumScanSettings^ ScanSettings {
    IEdSpectrumScanSettings^ get ();
}
abstract ScanSettings : IEdSpectrumScanSettings with get

Property Value

Type: IEdSpectrumScanSettings
See Also

Reference

IEdSpectrumSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumSettings Methods

The IEdSpectrumSettings type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Validates all the settings.
Top
See Also

Reference

IEdSpectrumSettings Interface
OINA.Extender.Acquisition.Ed Namespace


IEdSpectrumSettings.Validate Method

Validates all the settings.

Namespace: OINA.Extender.Acquisition.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IValidationResults Validate()
Function Validate As IValidationResults
IValidationResults^ Validate()
abstract Validate : unit -> IValidationResults

Return Value

Type: IValidationResults
The validation results
See Also

Reference

IEdSpectrumSettings Interface
OINA.Extender.Acquisition.Ed Namespace


OINA.Extender.Acquisition.Image Namespace

Defines all Classes and Interfaces used to control the acquisition of electron images.

Interfaces
 | Interface | Description
 | IImageAcquisitionController | An Interface that defines electron image acquisition.
 | IImageAcquisitionSettings | An Interface that defines settings and capabilities for image acquisition.
 | IImageCapabilities | An Interface that defines capabilities for images.
Public interface | IImageScanCapabilities | An Interface that defines the scan capabilities for image acquisition.
 | IImageScanSettings | An Interface that defines the scan settings for image acquisition.
 | IImageSettings | An Interface that defines the settings for image acquisition.


IImageAcquisitionController Interface

An Interface that defines electron image acquisition.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IImageAcquisitionController
Public Interface IImageAcquisitionController
public interface class IImageAcquisitionController
type IImageAcquisitionController =  interface end

The IImageAcquisitionController type exposes the following members.

Properties
 | Name | Description
Public property | CurrentImages | Gets the current electron image data.
Public property | IsAcquiring | Gets a value indicating whether there is an acquisition in progress.
Top
Methods
 | Name | Description
Public method | BeginMultipleAcquisition | Requests that external scan control will not be released after acquisition has finished.
Public method | EndMultipleAcquisition | Releases external scan control. Any acquisition controller can be used to release external scan control.
Public method | IsImageHardwareReady | Gets a value indicating whether the hardware is ready.
Public method | StartAcquisition | Start image acquisition.
Public method | StopAcquisition | Stop acquisition immediately.
Top
Events
 | Name | Description
Public event | ExperimentFinished | Occurs when image acquisition has finished.
Public event | ExperimentStarted | Occurs when image acquisition has started.
Public event | ExperimentStarting | Occurs before image acquisition starts.
Top
Examples
Copy
namespace Extender.CodeExamples.AcquisitionExamples
{
    using System;
    using System.Collections.Generic;
    using System.ComponentModel;
    using System.Linq;
    using System.Text;
    using OINA.Extender;
    using OINA.Extender.Acquisition;
    using OINA.Extender.Acquisition.Image;
    using OINA.Extender.Data;
    using OINA.Extender.Data.Image;

    /// <summary>
    /// AcquireImageExample
    /// </summary>
    public class AcquireImageExample
    {
        /// <summary>
        /// Run
        /// </summary>
        public void Run()
        {
            Console.WriteLine();
            Console.WriteLine(@"Image Acquisition Example.");
            Console.WriteLine();

            IImageAcquisitionSettings acquisitionSettings = AcquireFactory.CreateImageSettings();

            IImageSettings imageSettings = acquisitionSettings.ImageSettings;
            IImageCapabilities imageCapabilities = acquisitionSettings.ImageCapabilities;
            IImageScanSettings scanSettings = acquisitionSettings.ScanSettings;

            IImageAcquisitionController imageAcquisitionController = AcquireFactory.CreateImageServer();

            imageAcquisitionController.ExperimentStarting += this.OnImageExperimentStarting;
            imageAcquisitionController.ExperimentStarted += this.OnImageExperimentStarted;
            imageAcquisitionController.ExperimentFinished += this.OnImageExperimentFinished;

            imageSettings.DwellTimeMicroSeconds = 40;

            // Multiple input sources can be used.
            imageSettings.InputSources.ToList().ForEach(i => imageSettings.EnableInputSource(i.Key, true));

            scanSettings.FrameCount = 1;

            // Pixel size is 1/Resolution
            var pixelSize = 1d / 1024;

            scanSettings.AcquisitionRegion.CreateFullFieldRegion(pixelSize);

            // Check valid Dwell Time
            if (imageSettings.DwellTimeMicroSeconds > imageCapabilities.MaximumImageDwellMicroseconds ||
                imageSettings.DwellTimeMicroSeconds < imageCapabilities.MinimumImageDwellMicroseconds)
            {
                Console.WriteLine(
                    @"Invalid Dwell Time setting ({0}): Value must be between {1} and {2}",
                    imageSettings.DwellTimeMicroSeconds,
                    imageCapabilities.MinimumImageDwellMicroseconds,
                    imageCapabilities.MaximumImageDwellMicroseconds);
            }

            try
            {
                IEnumerable<IElectronImage> images = imageAcquisitionController.StartAcquisition(acquisitionSettings);
                images.ToList().ForEach(i =>
                {
                    i.Label = string.Format(@"Code example image - {0:HH:mm:ss} - {1}", DateTime.Now, i.InputSource.ToString());
                });
            }
            catch (InvalidSettingsException settingsException)
            {
                var sb = new StringBuilder(@"Invalid settings have been supplied: ");
                sb.AppendLine();
                settingsException.ValidationResults.ValidationErrors.ToList().ForEach(ve => sb.AppendFormat("{0}{1}", Environment.NewLine, ve));

                Console.WriteLine(sb.ToString());
            }
            catch (AcquisitionStartException startException)
            {
                Console.WriteLine(@"AcquisitionStartException: {0}", startException.Message);
            }
        }

        /// <summary>
        /// OnImageExperimentStarting
        /// </summary>
        private void OnImageExperimentStarting(object sender, AcquisitionStartingEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarting:");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                image.PropertyChanged += this.OnImagePropertyChanged;
                image.DataChanged += this.OnImageDataChanged;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentStarted
        /// </summary>
        private void OnImageExperimentStarted(object sender, AcquisitionStartedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarted");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarting -= this.OnImageExperimentStarting;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentFinished
        /// </summary>
        private void OnImageExperimentFinished(object sender, AcquisitionFinishedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentFinished");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                Console.WriteLine(@"    AcquisitionDate: {0:dd-MMM-yy HH:mm:ss}", image.AcquisitionDate);
                Console.WriteLine(@"    FramesAveraged: {0}", image.FramesAveraged);

                image.PropertyChanged -= this.OnImagePropertyChanged;
                image.DataChanged -= this.OnImageDataChanged;
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarted -= this.OnImageExperimentStarted;
                imageAcquisitionController.ExperimentFinished -= this.OnImageExperimentFinished;
            }

            Console.WriteLine();
            Console.WriteLine();
            Console.WriteLine(@"Code Example finished.");
        }

        /// <summary>
        /// OnImagePropertyChanged
        /// </summary>
        private void OnImagePropertyChanged(object sender, PropertyChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image != null)
            {
                Console.WriteLine(@"IElectronImage.PropertyChanged:{0}      ""{1}"" - {2}", Environment.NewLine, image.Label, e.PropertyName);
                Console.WriteLine();
            }
        }

        /// <summary>
        /// OnImageDataChanged
        /// </summary>
        private void OnImageDataChanged(object sender, SpatialDataChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image == null)
            {
                return;
            }

            Console.WriteLine(@"IElectronImage.DataChanged: {0}", image.Label);
            Console.WriteLine(@"        ChangedPixels Height/Width: {0}/{1}", e.ChangedPixels.Height, e.ChangedPixels.Width);

            var chordArray = new[] { new Chord(e.ChangedPixels.X, e.ChangedPixels.Y, e.ChangedPixels.Width) };

            var buffer = new byte[chordArray[0].Length * image.BytesPerPixel];

            // Get the data for the changed pixels
            image.GetData(chordArray, buffer);

            Console.WriteLine(@"        Image Height/Width: {0}/{1}", image.Height, image.Width);
            Console.WriteLine(@"        Image BytesPerPixel: {0}", image.BytesPerPixel);
            Console.WriteLine(@"        Data Buffer length: {0:0,000}", buffer.Length);
            Console.WriteLine();
        }
    }
}
See Also

Reference

OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController Properties

The IImageAcquisitionController type exposes the following members.

Properties
 | Name | Description
Public property | CurrentImages | Gets the current electron image data.
Public property | IsAcquiring | Gets a value indicating whether there is an acquisition in progress.
Top
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController.CurrentImages Property

Gets the current electron image data.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEnumerable<IElectronImage> CurrentImages { get; }
ReadOnly Property CurrentImages As IEnumerable(Of IElectronImage)
    Get
property IEnumerable<IElectronImage^>^ CurrentImages {
    IEnumerable<IElectronImage^>^ get ();
}
abstract CurrentImages : IEnumerable<IElectronImage> with get

Property Value

Type: IEnumerable IElectronImage
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController.IsAcquiring Property

Gets a value indicating whether there is an acquisition in progress.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsAcquiring { get; }
ReadOnly Property IsAcquiring As Boolean
    Get
property bool IsAcquiring {
    bool get ();
}
abstract IsAcquiring : bool with get

Property Value

Type: Boolean
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController Methods

The IImageAcquisitionController type exposes the following members.

Methods
 | Name | Description
Public method | BeginMultipleAcquisition | Requests that external scan control will not be released after acquisition has finished.
Public method | EndMultipleAcquisition | Releases external scan control. Any acquisition controller can be used to release external scan control.
Public method | IsImageHardwareReady | Gets a value indicating whether the hardware is ready.
Public method | StartAcquisition | Start image acquisition.
Public method | StopAcquisition | Stop acquisition immediately.
Top
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController.BeginMultipleAcquisition Method

Requests that external scan control will not be released after acquisition has finished.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void BeginMultipleAcquisition()
Sub BeginMultipleAcquisition
void BeginMultipleAcquisition()
abstract BeginMultipleAcquisition : unit -> unit
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController.EndMultipleAcquisition Method

Releases external scan control. Any acquisition controller can be used to release external scan control.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void EndMultipleAcquisition()
Sub EndMultipleAcquisition
void EndMultipleAcquisition()
abstract EndMultipleAcquisition : unit -> unit
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController.IsImageHardwareReady Method

Gets a value indicating whether the hardware is ready.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsImageHardwareReady(
    IImageAcquisitionSettings settings
)
Function IsImageHardwareReady (
    settings As IImageAcquisitionSettings
) As Boolean
bool IsImageHardwareReady(
    IImageAcquisitionSettings^ settings
)
abstract IsImageHardwareReady :
        settings : IImageAcquisitionSettings -> bool

Parameters

settings
Type: OINA.Extender.Acquisition.ImageIImageAcquisitionSettings
The image acquisition settings

Return Value

Type: Boolean
True if the hardware can be used
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController.StartAcquisition Method

Start image acquisition.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEnumerable<IElectronImage> StartAcquisition(
    IImageAcquisitionSettings settings
)
Function StartAcquisition (
    settings As IImageAcquisitionSettings
) As IEnumerable(Of IElectronImage)
IEnumerable<IElectronImage^>^ StartAcquisition(
    IImageAcquisitionSettings^ settings
)
abstract StartAcquisition :
        settings : IImageAcquisitionSettings -> IEnumerable<IElectronImage>

Parameters

settings
Type: OINA.Extender.Acquisition.ImageIImageAcquisitionSettings
The image acquisition settings

Return Value

Type: IEnumerable IElectronImage
The electron image data
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController.StopAcquisition Method

Stop acquisition immediately.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void StopAcquisition()
Sub StopAcquisition
void StopAcquisition()
abstract StopAcquisition : unit -> unit
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController Events

The IImageAcquisitionController type exposes the following members.

Events
 | Name | Description
Public event | ExperimentFinished | Occurs when image acquisition has finished.
Public event | ExperimentStarted | Occurs when image acquisition has started.
Public event | ExperimentStarting | Occurs before image acquisition starts.
Top
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController.ExperimentFinished Event

Occurs when image acquisition has finished.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AcquisitionFinishedEventArgs<IElectronImage[]>> ExperimentFinished
Event ExperimentFinished As EventHandler(Of AcquisitionFinishedEventArgs(Of IElectronImage()))
 event EventHandler<AcquisitionFinishedEventArgs<array<IElectronImage^>^>^>^ ExperimentFinished {
    void add (EventHandler<AcquisitionFinishedEventArgs<array<IElectronImage^>^>^>^ value);
    void remove (EventHandler<AcquisitionFinishedEventArgs<array<IElectronImage^>^>^>^ value);
}
abstract ExperimentFinished : IEvent<EventHandler<AcquisitionFinishedEventArgs<IElectronImage[]>>,
    AcquisitionFinishedEventArgs<IElectronImage[]>>

Value

Type: SystemEventHandler AcquisitionFinishedEventArgs IElectronImage
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController.ExperimentStarted Event

Occurs when image acquisition has started.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AcquisitionStartedEventArgs<IElectronImage[]>> ExperimentStarted
Event ExperimentStarted As EventHandler(Of AcquisitionStartedEventArgs(Of IElectronImage()))
 event EventHandler<AcquisitionStartedEventArgs<array<IElectronImage^>^>^>^ ExperimentStarted {
    void add (EventHandler<AcquisitionStartedEventArgs<array<IElectronImage^>^>^>^ value);
    void remove (EventHandler<AcquisitionStartedEventArgs<array<IElectronImage^>^>^>^ value);
}
abstract ExperimentStarted : IEvent<EventHandler<AcquisitionStartedEventArgs<IElectronImage[]>>,
    AcquisitionStartedEventArgs<IElectronImage[]>>

Value

Type: SystemEventHandler AcquisitionStartedEventArgs IElectronImage
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionController.ExperimentStarting Event

Occurs before image acquisition starts.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AcquisitionStartingEventArgs<IElectronImage[]>> ExperimentStarting
Event ExperimentStarting As EventHandler(Of AcquisitionStartingEventArgs(Of IElectronImage()))
 event EventHandler<AcquisitionStartingEventArgs<array<IElectronImage^>^>^>^ ExperimentStarting {
    void add (EventHandler<AcquisitionStartingEventArgs<array<IElectronImage^>^>^>^ value);
    void remove (EventHandler<AcquisitionStartingEventArgs<array<IElectronImage^>^>^>^ value);
}
abstract ExperimentStarting : IEvent<EventHandler<AcquisitionStartingEventArgs<IElectronImage[]>>,
    AcquisitionStartingEventArgs<IElectronImage[]>>

Value

Type: SystemEventHandler AcquisitionStartingEventArgs IElectronImage
See Also

Reference

IImageAcquisitionController Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionSettings Interface

An Interface that defines settings and capabilities for image acquisition.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IImageAcquisitionSettings
Public Interface IImageAcquisitionSettings
public interface class IImageAcquisitionSettings
type IImageAcquisitionSettings =  interface end

The IImageAcquisitionSettings type exposes the following members.

Properties
 | Name | Description
Public property | ImageCapabilities | Gets the image capabilities.
Public property | ImageSettings | Gets the image acquisition settings.
Public property | ScanCapabilities | Gets the scan capabilities.
Public property | ScanSettings | Gets the scan settings.
Top
Methods
 | Name | Description
Public method | Validate | Validates all the settings.
Top
Examples
Copy
namespace Extender.CodeExamples.AcquisitionExamples
{
    using System;
    using System.Collections.Generic;
    using System.ComponentModel;
    using System.Linq;
    using System.Text;
    using OINA.Extender;
    using OINA.Extender.Acquisition;
    using OINA.Extender.Acquisition.Image;
    using OINA.Extender.Data;
    using OINA.Extender.Data.Image;

    /// <summary>
    /// AcquireImageExample
    /// </summary>
    public class AcquireImageExample
    {
        /// <summary>
        /// Run
        /// </summary>
        public void Run()
        {
            Console.WriteLine();
            Console.WriteLine(@"Image Acquisition Example.");
            Console.WriteLine();

            IImageAcquisitionSettings acquisitionSettings = AcquireFactory.CreateImageSettings();

            IImageSettings imageSettings = acquisitionSettings.ImageSettings;
            IImageCapabilities imageCapabilities = acquisitionSettings.ImageCapabilities;
            IImageScanSettings scanSettings = acquisitionSettings.ScanSettings;

            IImageAcquisitionController imageAcquisitionController = AcquireFactory.CreateImageServer();

            imageAcquisitionController.ExperimentStarting += this.OnImageExperimentStarting;
            imageAcquisitionController.ExperimentStarted += this.OnImageExperimentStarted;
            imageAcquisitionController.ExperimentFinished += this.OnImageExperimentFinished;

            imageSettings.DwellTimeMicroSeconds = 40;

            // Multiple input sources can be used.
            imageSettings.InputSources.ToList().ForEach(i => imageSettings.EnableInputSource(i.Key, true));

            scanSettings.FrameCount = 1;

            // Pixel size is 1/Resolution
            var pixelSize = 1d / 1024;

            scanSettings.AcquisitionRegion.CreateFullFieldRegion(pixelSize);

            // Check valid Dwell Time
            if (imageSettings.DwellTimeMicroSeconds > imageCapabilities.MaximumImageDwellMicroseconds ||
                imageSettings.DwellTimeMicroSeconds < imageCapabilities.MinimumImageDwellMicroseconds)
            {
                Console.WriteLine(
                    @"Invalid Dwell Time setting ({0}): Value must be between {1} and {2}",
                    imageSettings.DwellTimeMicroSeconds,
                    imageCapabilities.MinimumImageDwellMicroseconds,
                    imageCapabilities.MaximumImageDwellMicroseconds);
            }

            try
            {
                IEnumerable<IElectronImage> images = imageAcquisitionController.StartAcquisition(acquisitionSettings);
                images.ToList().ForEach(i =>
                {
                    i.Label = string.Format(@"Code example image - {0:HH:mm:ss} - {1}", DateTime.Now, i.InputSource.ToString());
                });
            }
            catch (InvalidSettingsException settingsException)
            {
                var sb = new StringBuilder(@"Invalid settings have been supplied: ");
                sb.AppendLine();
                settingsException.ValidationResults.ValidationErrors.ToList().ForEach(ve => sb.AppendFormat("{0}{1}", Environment.NewLine, ve));

                Console.WriteLine(sb.ToString());
            }
            catch (AcquisitionStartException startException)
            {
                Console.WriteLine(@"AcquisitionStartException: {0}", startException.Message);
            }
        }

        /// <summary>
        /// OnImageExperimentStarting
        /// </summary>
        private void OnImageExperimentStarting(object sender, AcquisitionStartingEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarting:");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                image.PropertyChanged += this.OnImagePropertyChanged;
                image.DataChanged += this.OnImageDataChanged;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentStarted
        /// </summary>
        private void OnImageExperimentStarted(object sender, AcquisitionStartedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarted");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarting -= this.OnImageExperimentStarting;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentFinished
        /// </summary>
        private void OnImageExperimentFinished(object sender, AcquisitionFinishedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentFinished");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                Console.WriteLine(@"    AcquisitionDate: {0:dd-MMM-yy HH:mm:ss}", image.AcquisitionDate);
                Console.WriteLine(@"    FramesAveraged: {0}", image.FramesAveraged);

                image.PropertyChanged -= this.OnImagePropertyChanged;
                image.DataChanged -= this.OnImageDataChanged;
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarted -= this.OnImageExperimentStarted;
                imageAcquisitionController.ExperimentFinished -= this.OnImageExperimentFinished;
            }

            Console.WriteLine();
            Console.WriteLine();
            Console.WriteLine(@"Code Example finished.");
        }

        /// <summary>
        /// OnImagePropertyChanged
        /// </summary>
        private void OnImagePropertyChanged(object sender, PropertyChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image != null)
            {
                Console.WriteLine(@"IElectronImage.PropertyChanged:{0}      ""{1}"" - {2}", Environment.NewLine, image.Label, e.PropertyName);
                Console.WriteLine();
            }
        }

        /// <summary>
        /// OnImageDataChanged
        /// </summary>
        private void OnImageDataChanged(object sender, SpatialDataChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image == null)
            {
                return;
            }

            Console.WriteLine(@"IElectronImage.DataChanged: {0}", image.Label);
            Console.WriteLine(@"        ChangedPixels Height/Width: {0}/{1}", e.ChangedPixels.Height, e.ChangedPixels.Width);

            var chordArray = new[] { new Chord(e.ChangedPixels.X, e.ChangedPixels.Y, e.ChangedPixels.Width) };

            var buffer = new byte[chordArray[0].Length * image.BytesPerPixel];

            // Get the data for the changed pixels
            image.GetData(chordArray, buffer);

            Console.WriteLine(@"        Image Height/Width: {0}/{1}", image.Height, image.Width);
            Console.WriteLine(@"        Image BytesPerPixel: {0}", image.BytesPerPixel);
            Console.WriteLine(@"        Data Buffer length: {0:0,000}", buffer.Length);
            Console.WriteLine();
        }
    }
}
See Also

Reference

OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionSettings Properties

The IImageAcquisitionSettings type exposes the following members.

Properties
 | Name | Description
Public property | ImageCapabilities | Gets the image capabilities.
Public property | ImageSettings | Gets the image acquisition settings.
Public property | ScanCapabilities | Gets the scan capabilities.
Public property | ScanSettings | Gets the scan settings.
Top
See Also

Reference

IImageAcquisitionSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionSettings.ImageCapabilities Property

Gets the image capabilities.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IImageCapabilities ImageCapabilities { get; }
ReadOnly Property ImageCapabilities As IImageCapabilities
    Get
property IImageCapabilities^ ImageCapabilities {
    IImageCapabilities^ get ();
}
abstract ImageCapabilities : IImageCapabilities with get

Property Value

Type: IImageCapabilities
See Also

Reference

IImageAcquisitionSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionSettings.ImageSettings Property

Gets the image acquisition settings.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IImageSettings ImageSettings { get; }
ReadOnly Property ImageSettings As IImageSettings
    Get
property IImageSettings^ ImageSettings {
    IImageSettings^ get ();
}
abstract ImageSettings : IImageSettings with get

Property Value

Type: IImageSettings
See Also

Reference

IImageAcquisitionSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionSettings.ScanCapabilities Property

Gets the scan capabilities.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IImageScanCapabilities ScanCapabilities { get; }
ReadOnly Property ScanCapabilities As IImageScanCapabilities
    Get
property IImageScanCapabilities^ ScanCapabilities {
    IImageScanCapabilities^ get ();
}
abstract ScanCapabilities : IImageScanCapabilities with get

Property Value

Type: IImageScanCapabilities
See Also

Reference

IImageAcquisitionSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionSettings.ScanSettings Property

Gets the scan settings.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IImageScanSettings ScanSettings { get; }
ReadOnly Property ScanSettings As IImageScanSettings
    Get
property IImageScanSettings^ ScanSettings {
    IImageScanSettings^ get ();
}
abstract ScanSettings : IImageScanSettings with get

Property Value

Type: IImageScanSettings
See Also

Reference

IImageAcquisitionSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionSettings Methods

The IImageAcquisitionSettings type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Validates all the settings.
Top
See Also

Reference

IImageAcquisitionSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageAcquisitionSettings.Validate Method

Validates all the settings.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IValidationResults Validate()
Function Validate As IValidationResults
IValidationResults^ Validate()
abstract Validate : unit -> IValidationResults

Return Value

Type: IValidationResults
The validation results
See Also

Reference

IImageAcquisitionSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageCapabilities Interface

An Interface that defines capabilities for images.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IImageCapabilities : INotifyPropertyChanged
Public Interface IImageCapabilities
    Inherits INotifyPropertyChanged
public interface class IImageCapabilities : INotifyPropertyChanged
type IImageCapabilities =
    interface
        interface INotifyPropertyChanged
    end

The IImageCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AllowedInputSources | Gets the allowed input sources for the image. For example, BSE.
Public property | HasHardwareConnection | Gets a value indicating whether the hardware is connected.
Public property | MaximumImageDwellMicroseconds | Gets the maximum dwell time per pixel, in microseconds.
Public property | MinimumImageDwellMicroseconds | Gets the minimum dwell time per pixel, in microseconds.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Examples
Copy
namespace Extender.CodeExamples.AcquisitionExamples
{
    using System;
    using System.Collections.Generic;
    using System.ComponentModel;
    using System.Linq;
    using System.Text;
    using OINA.Extender;
    using OINA.Extender.Acquisition;
    using OINA.Extender.Acquisition.Image;
    using OINA.Extender.Data;
    using OINA.Extender.Data.Image;

    /// <summary>
    /// AcquireImageExample
    /// </summary>
    public class AcquireImageExample
    {
        /// <summary>
        /// Run
        /// </summary>
        public void Run()
        {
            Console.WriteLine();
            Console.WriteLine(@"Image Acquisition Example.");
            Console.WriteLine();

            IImageAcquisitionSettings acquisitionSettings = AcquireFactory.CreateImageSettings();

            IImageSettings imageSettings = acquisitionSettings.ImageSettings;
            IImageCapabilities imageCapabilities = acquisitionSettings.ImageCapabilities;
            IImageScanSettings scanSettings = acquisitionSettings.ScanSettings;

            IImageAcquisitionController imageAcquisitionController = AcquireFactory.CreateImageServer();

            imageAcquisitionController.ExperimentStarting += this.OnImageExperimentStarting;
            imageAcquisitionController.ExperimentStarted += this.OnImageExperimentStarted;
            imageAcquisitionController.ExperimentFinished += this.OnImageExperimentFinished;

            imageSettings.DwellTimeMicroSeconds = 40;

            // Multiple input sources can be used.
            imageSettings.InputSources.ToList().ForEach(i => imageSettings.EnableInputSource(i.Key, true));

            scanSettings.FrameCount = 1;

            // Pixel size is 1/Resolution
            var pixelSize = 1d / 1024;

            scanSettings.AcquisitionRegion.CreateFullFieldRegion(pixelSize);

            // Check valid Dwell Time
            if (imageSettings.DwellTimeMicroSeconds > imageCapabilities.MaximumImageDwellMicroseconds ||
                imageSettings.DwellTimeMicroSeconds < imageCapabilities.MinimumImageDwellMicroseconds)
            {
                Console.WriteLine(
                    @"Invalid Dwell Time setting ({0}): Value must be between {1} and {2}",
                    imageSettings.DwellTimeMicroSeconds,
                    imageCapabilities.MinimumImageDwellMicroseconds,
                    imageCapabilities.MaximumImageDwellMicroseconds);
            }

            try
            {
                IEnumerable<IElectronImage> images = imageAcquisitionController.StartAcquisition(acquisitionSettings);
                images.ToList().ForEach(i =>
                {
                    i.Label = string.Format(@"Code example image - {0:HH:mm:ss} - {1}", DateTime.Now, i.InputSource.ToString());
                });
            }
            catch (InvalidSettingsException settingsException)
            {
                var sb = new StringBuilder(@"Invalid settings have been supplied: ");
                sb.AppendLine();
                settingsException.ValidationResults.ValidationErrors.ToList().ForEach(ve => sb.AppendFormat("{0}{1}", Environment.NewLine, ve));

                Console.WriteLine(sb.ToString());
            }
            catch (AcquisitionStartException startException)
            {
                Console.WriteLine(@"AcquisitionStartException: {0}", startException.Message);
            }
        }

        /// <summary>
        /// OnImageExperimentStarting
        /// </summary>
        private void OnImageExperimentStarting(object sender, AcquisitionStartingEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarting:");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                image.PropertyChanged += this.OnImagePropertyChanged;
                image.DataChanged += this.OnImageDataChanged;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentStarted
        /// </summary>
        private void OnImageExperimentStarted(object sender, AcquisitionStartedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarted");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarting -= this.OnImageExperimentStarting;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentFinished
        /// </summary>
        private void OnImageExperimentFinished(object sender, AcquisitionFinishedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentFinished");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                Console.WriteLine(@"    AcquisitionDate: {0:dd-MMM-yy HH:mm:ss}", image.AcquisitionDate);
                Console.WriteLine(@"    FramesAveraged: {0}", image.FramesAveraged);

                image.PropertyChanged -= this.OnImagePropertyChanged;
                image.DataChanged -= this.OnImageDataChanged;
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarted -= this.OnImageExperimentStarted;
                imageAcquisitionController.ExperimentFinished -= this.OnImageExperimentFinished;
            }

            Console.WriteLine();
            Console.WriteLine();
            Console.WriteLine(@"Code Example finished.");
        }

        /// <summary>
        /// OnImagePropertyChanged
        /// </summary>
        private void OnImagePropertyChanged(object sender, PropertyChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image != null)
            {
                Console.WriteLine(@"IElectronImage.PropertyChanged:{0}      ""{1}"" - {2}", Environment.NewLine, image.Label, e.PropertyName);
                Console.WriteLine();
            }
        }

        /// <summary>
        /// OnImageDataChanged
        /// </summary>
        private void OnImageDataChanged(object sender, SpatialDataChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image == null)
            {
                return;
            }

            Console.WriteLine(@"IElectronImage.DataChanged: {0}", image.Label);
            Console.WriteLine(@"        ChangedPixels Height/Width: {0}/{1}", e.ChangedPixels.Height, e.ChangedPixels.Width);

            var chordArray = new[] { new Chord(e.ChangedPixels.X, e.ChangedPixels.Y, e.ChangedPixels.Width) };

            var buffer = new byte[chordArray[0].Length * image.BytesPerPixel];

            // Get the data for the changed pixels
            image.GetData(chordArray, buffer);

            Console.WriteLine(@"        Image Height/Width: {0}/{1}", image.Height, image.Width);
            Console.WriteLine(@"        Image BytesPerPixel: {0}", image.BytesPerPixel);
            Console.WriteLine(@"        Data Buffer length: {0:0,000}", buffer.Length);
            Console.WriteLine();
        }
    }
}
See Also

Reference

OINA.Extender.Acquisition.Image Namespace


IImageCapabilities Properties

The IImageCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AllowedInputSources | Gets the allowed input sources for the image. For example, BSE.
Public property | HasHardwareConnection | Gets a value indicating whether the hardware is connected.
Public property | MaximumImageDwellMicroseconds | Gets the maximum dwell time per pixel, in microseconds.
Public property | MinimumImageDwellMicroseconds | Gets the minimum dwell time per pixel, in microseconds.
Top
See Also

Reference

IImageCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageCapabilities.AllowedInputSources Property

Gets the allowed input sources for the image. For example, BSE.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<ImageInputSources> AllowedInputSources { get; }
ReadOnly Property AllowedInputSources As ReadOnlyCollection(Of ImageInputSources)
    Get
property ReadOnlyCollection<ImageInputSources>^ AllowedInputSources {
    ReadOnlyCollection<ImageInputSources>^ get ();
}
abstract AllowedInputSources : ReadOnlyCollection<ImageInputSources> with get

Property Value

Type: ReadOnlyCollection ImageInputSources
See Also

Reference

IImageCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageCapabilities.HasHardwareConnection Property

Gets a value indicating whether the hardware is connected.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasHardwareConnection { get; }
ReadOnly Property HasHardwareConnection As Boolean
    Get
property bool HasHardwareConnection {
    bool get ();
}
abstract HasHardwareConnection : bool with get

Property Value

Type: Boolean
See Also

Reference

IImageCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageCapabilities.MaximumImageDwellMicroseconds Property

Gets the maximum dwell time per pixel, in microseconds.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MaximumImageDwellMicroseconds { get; }
ReadOnly Property MaximumImageDwellMicroseconds As Double
    Get
property double MaximumImageDwellMicroseconds {
    double get ();
}
abstract MaximumImageDwellMicroseconds : float with get

Property Value

Type: Double
See Also

Reference

IImageCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageCapabilities.MinimumImageDwellMicroseconds Property

Gets the minimum dwell time per pixel, in microseconds.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MinimumImageDwellMicroseconds { get; }
ReadOnly Property MinimumImageDwellMicroseconds As Double
    Get
property double MinimumImageDwellMicroseconds {
    double get ();
}
abstract MinimumImageDwellMicroseconds : float with get

Property Value

Type: Double
See Also

Reference

IImageCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageCapabilities Events

The IImageCapabilities type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IImageCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanCapabilities Interface

An Interface that defines the scan capabilities for image acquisition.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IImageScanCapabilities : INotifyPropertyChanged
Public Interface IImageScanCapabilities
    Inherits INotifyPropertyChanged
public interface class IImageScanCapabilities : INotifyPropertyChanged
type IImageScanCapabilities =
    interface
        interface INotifyPropertyChanged
    end

The IImageScanCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AspectRatio | Gets the aspect ratio of the image.
Public property | HasHardwareConnection | Gets a value indicating whether the hardware is connected.
Public property | MaximumNumberOfFrames | Gets the maximum number of frames.
Public property | MaximumPixelSize | Gets the maximum pixel size (smallest resolution). For example, 1/32 pixels.
Public property | MinimumNumberOfFrames | Gets the minimum number of frames.
Public property | MinimumPixelSize | Gets the minimum pixel size (largest resolution). For example, 1/8k pixels.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition.Image Namespace


IImageScanCapabilities Properties

The IImageScanCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AspectRatio | Gets the aspect ratio of the image.
Public property | HasHardwareConnection | Gets a value indicating whether the hardware is connected.
Public property | MaximumNumberOfFrames | Gets the maximum number of frames.
Public property | MaximumPixelSize | Gets the maximum pixel size (smallest resolution). For example, 1/32 pixels.
Public property | MinimumNumberOfFrames | Gets the minimum number of frames.
Public property | MinimumPixelSize | Gets the minimum pixel size (largest resolution). For example, 1/8k pixels.
Top
See Also

Reference

IImageScanCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanCapabilities.AspectRatio Property

Gets the aspect ratio of the image.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double AspectRatio { get; }
ReadOnly Property AspectRatio As Double
    Get
property double AspectRatio {
    double get ();
}
abstract AspectRatio : float with get

Property Value

Type: Double
See Also

Reference

IImageScanCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanCapabilities.HasHardwareConnection Property

Gets a value indicating whether the hardware is connected.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasHardwareConnection { get; }
ReadOnly Property HasHardwareConnection As Boolean
    Get
property bool HasHardwareConnection {
    bool get ();
}
abstract HasHardwareConnection : bool with get

Property Value

Type: Boolean
See Also

Reference

IImageScanCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanCapabilities.MaximumNumberOfFrames Property

Gets the maximum number of frames.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MaximumNumberOfFrames { get; }
ReadOnly Property MaximumNumberOfFrames As Integer
    Get
property int MaximumNumberOfFrames {
    int get ();
}
abstract MaximumNumberOfFrames : int with get

Property Value

Type: Int32
See Also

Reference

IImageScanCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanCapabilities.MaximumPixelSize Property

Gets the maximum pixel size (smallest resolution). For example, 1/32 pixels.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MaximumPixelSize { get; }
ReadOnly Property MaximumPixelSize As Double
    Get
property double MaximumPixelSize {
    double get ();
}
abstract MaximumPixelSize : float with get

Property Value

Type: Double
See Also

Reference

IImageScanCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanCapabilities.MinimumNumberOfFrames Property

Gets the minimum number of frames.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MinimumNumberOfFrames { get; }
ReadOnly Property MinimumNumberOfFrames As Integer
    Get
property int MinimumNumberOfFrames {
    int get ();
}
abstract MinimumNumberOfFrames : int with get

Property Value

Type: Int32
See Also

Reference

IImageScanCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanCapabilities.MinimumPixelSize Property

Gets the minimum pixel size (largest resolution). For example, 1/8k pixels.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MinimumPixelSize { get; }
ReadOnly Property MinimumPixelSize As Double
    Get
property double MinimumPixelSize {
    double get ();
}
abstract MinimumPixelSize : float with get

Property Value

Type: Double
See Also

Reference

IImageScanCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanCapabilities Events

The IImageScanCapabilities type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IImageScanCapabilities Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanSettings Interface

An Interface that defines the scan settings for image acquisition.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IImageScanSettings : INotifyPropertyChanged
Public Interface IImageScanSettings
    Inherits INotifyPropertyChanged
public interface class IImageScanSettings : INotifyPropertyChanged
type IImageScanSettings =
    interface
        interface INotifyPropertyChanged
    end

The IImageScanSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionRegion | Gets the acquisition region.
Public property | FrameCount | Gets or sets the number of frames to scan.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Examples
Copy
namespace Extender.CodeExamples.AcquisitionExamples
{
    using System;
    using System.Collections.Generic;
    using System.ComponentModel;
    using System.Linq;
    using System.Text;
    using OINA.Extender;
    using OINA.Extender.Acquisition;
    using OINA.Extender.Acquisition.Image;
    using OINA.Extender.Data;
    using OINA.Extender.Data.Image;

    /// <summary>
    /// AcquireImageExample
    /// </summary>
    public class AcquireImageExample
    {
        /// <summary>
        /// Run
        /// </summary>
        public void Run()
        {
            Console.WriteLine();
            Console.WriteLine(@"Image Acquisition Example.");
            Console.WriteLine();

            IImageAcquisitionSettings acquisitionSettings = AcquireFactory.CreateImageSettings();

            IImageSettings imageSettings = acquisitionSettings.ImageSettings;
            IImageCapabilities imageCapabilities = acquisitionSettings.ImageCapabilities;
            IImageScanSettings scanSettings = acquisitionSettings.ScanSettings;

            IImageAcquisitionController imageAcquisitionController = AcquireFactory.CreateImageServer();

            imageAcquisitionController.ExperimentStarting += this.OnImageExperimentStarting;
            imageAcquisitionController.ExperimentStarted += this.OnImageExperimentStarted;
            imageAcquisitionController.ExperimentFinished += this.OnImageExperimentFinished;

            imageSettings.DwellTimeMicroSeconds = 40;

            // Multiple input sources can be used.
            imageSettings.InputSources.ToList().ForEach(i => imageSettings.EnableInputSource(i.Key, true));

            scanSettings.FrameCount = 1;

            // Pixel size is 1/Resolution
            var pixelSize = 1d / 1024;

            scanSettings.AcquisitionRegion.CreateFullFieldRegion(pixelSize);

            // Check valid Dwell Time
            if (imageSettings.DwellTimeMicroSeconds > imageCapabilities.MaximumImageDwellMicroseconds ||
                imageSettings.DwellTimeMicroSeconds < imageCapabilities.MinimumImageDwellMicroseconds)
            {
                Console.WriteLine(
                    @"Invalid Dwell Time setting ({0}): Value must be between {1} and {2}",
                    imageSettings.DwellTimeMicroSeconds,
                    imageCapabilities.MinimumImageDwellMicroseconds,
                    imageCapabilities.MaximumImageDwellMicroseconds);
            }

            try
            {
                IEnumerable<IElectronImage> images = imageAcquisitionController.StartAcquisition(acquisitionSettings);
                images.ToList().ForEach(i =>
                {
                    i.Label = string.Format(@"Code example image - {0:HH:mm:ss} - {1}", DateTime.Now, i.InputSource.ToString());
                });
            }
            catch (InvalidSettingsException settingsException)
            {
                var sb = new StringBuilder(@"Invalid settings have been supplied: ");
                sb.AppendLine();
                settingsException.ValidationResults.ValidationErrors.ToList().ForEach(ve => sb.AppendFormat("{0}{1}", Environment.NewLine, ve));

                Console.WriteLine(sb.ToString());
            }
            catch (AcquisitionStartException startException)
            {
                Console.WriteLine(@"AcquisitionStartException: {0}", startException.Message);
            }
        }

        /// <summary>
        /// OnImageExperimentStarting
        /// </summary>
        private void OnImageExperimentStarting(object sender, AcquisitionStartingEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarting:");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                image.PropertyChanged += this.OnImagePropertyChanged;
                image.DataChanged += this.OnImageDataChanged;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentStarted
        /// </summary>
        private void OnImageExperimentStarted(object sender, AcquisitionStartedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarted");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarting -= this.OnImageExperimentStarting;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentFinished
        /// </summary>
        private void OnImageExperimentFinished(object sender, AcquisitionFinishedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentFinished");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                Console.WriteLine(@"    AcquisitionDate: {0:dd-MMM-yy HH:mm:ss}", image.AcquisitionDate);
                Console.WriteLine(@"    FramesAveraged: {0}", image.FramesAveraged);

                image.PropertyChanged -= this.OnImagePropertyChanged;
                image.DataChanged -= this.OnImageDataChanged;
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarted -= this.OnImageExperimentStarted;
                imageAcquisitionController.ExperimentFinished -= this.OnImageExperimentFinished;
            }

            Console.WriteLine();
            Console.WriteLine();
            Console.WriteLine(@"Code Example finished.");
        }

        /// <summary>
        /// OnImagePropertyChanged
        /// </summary>
        private void OnImagePropertyChanged(object sender, PropertyChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image != null)
            {
                Console.WriteLine(@"IElectronImage.PropertyChanged:{0}      ""{1}"" - {2}", Environment.NewLine, image.Label, e.PropertyName);
                Console.WriteLine();
            }
        }

        /// <summary>
        /// OnImageDataChanged
        /// </summary>
        private void OnImageDataChanged(object sender, SpatialDataChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image == null)
            {
                return;
            }

            Console.WriteLine(@"IElectronImage.DataChanged: {0}", image.Label);
            Console.WriteLine(@"        ChangedPixels Height/Width: {0}/{1}", e.ChangedPixels.Height, e.ChangedPixels.Width);

            var chordArray = new[] { new Chord(e.ChangedPixels.X, e.ChangedPixels.Y, e.ChangedPixels.Width) };

            var buffer = new byte[chordArray[0].Length * image.BytesPerPixel];

            // Get the data for the changed pixels
            image.GetData(chordArray, buffer);

            Console.WriteLine(@"        Image Height/Width: {0}/{1}", image.Height, image.Width);
            Console.WriteLine(@"        Image BytesPerPixel: {0}", image.BytesPerPixel);
            Console.WriteLine(@"        Data Buffer length: {0:0,000}", buffer.Length);
            Console.WriteLine();
        }
    }
}
See Also

Reference

OINA.Extender.Acquisition.Image Namespace


IImageScanSettings Properties

The IImageScanSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionRegion | Gets the acquisition region.
Public property | FrameCount | Gets or sets the number of frames to scan.
Top
See Also

Reference

IImageScanSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanSettings.AcquisitionRegion Property

Gets the acquisition region.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IScannedAcquisitionRegion AcquisitionRegion { get; }
ReadOnly Property AcquisitionRegion As IScannedAcquisitionRegion
    Get
property IScannedAcquisitionRegion^ AcquisitionRegion {
    IScannedAcquisitionRegion^ get ();
}
abstract AcquisitionRegion : IScannedAcquisitionRegion with get

Property Value

Type: IScannedAcquisitionRegion
See Also

Reference

IImageScanSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanSettings.FrameCount Property

Gets or sets the number of frames to scan.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int FrameCount { get; set; }
Property FrameCount As Integer
    Get
    Set
property int FrameCount {
    int get ();
    void set (int value);
}
abstract FrameCount : int with get, set

Property Value

Type: Int32
See Also

Reference

IImageScanSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageScanSettings Events

The IImageScanSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IImageScanSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageSettings Interface

An Interface that defines the settings for image acquisition.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IImageSettings : INotifyPropertyChanged
Public Interface IImageSettings
    Inherits INotifyPropertyChanged
public interface class IImageSettings : INotifyPropertyChanged
type IImageSettings =
    interface
        interface INotifyPropertyChanged
    end

The IImageSettings type exposes the following members.

Properties
 | Name | Description
Public property | DwellTimeMicroSeconds | Gets or sets the dwell time per pixel in microseconds.
Public property | InputSources | Gets the image input sources. For example, BSE.
Top
Methods
 | Name | Description
Public method | EnableInputSource | Used to select image input sources for acquisition. Electron Images from different sources can be acquired simultaneously.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Examples
Copy
namespace Extender.CodeExamples.AcquisitionExamples
{
    using System;
    using System.Collections.Generic;
    using System.ComponentModel;
    using System.Linq;
    using System.Text;
    using OINA.Extender;
    using OINA.Extender.Acquisition;
    using OINA.Extender.Acquisition.Image;
    using OINA.Extender.Data;
    using OINA.Extender.Data.Image;

    /// <summary>
    /// AcquireImageExample
    /// </summary>
    public class AcquireImageExample
    {
        /// <summary>
        /// Run
        /// </summary>
        public void Run()
        {
            Console.WriteLine();
            Console.WriteLine(@"Image Acquisition Example.");
            Console.WriteLine();

            IImageAcquisitionSettings acquisitionSettings = AcquireFactory.CreateImageSettings();

            IImageSettings imageSettings = acquisitionSettings.ImageSettings;
            IImageCapabilities imageCapabilities = acquisitionSettings.ImageCapabilities;
            IImageScanSettings scanSettings = acquisitionSettings.ScanSettings;

            IImageAcquisitionController imageAcquisitionController = AcquireFactory.CreateImageServer();

            imageAcquisitionController.ExperimentStarting += this.OnImageExperimentStarting;
            imageAcquisitionController.ExperimentStarted += this.OnImageExperimentStarted;
            imageAcquisitionController.ExperimentFinished += this.OnImageExperimentFinished;

            imageSettings.DwellTimeMicroSeconds = 40;

            // Multiple input sources can be used.
            imageSettings.InputSources.ToList().ForEach(i => imageSettings.EnableInputSource(i.Key, true));

            scanSettings.FrameCount = 1;

            // Pixel size is 1/Resolution
            var pixelSize = 1d / 1024;

            scanSettings.AcquisitionRegion.CreateFullFieldRegion(pixelSize);

            // Check valid Dwell Time
            if (imageSettings.DwellTimeMicroSeconds > imageCapabilities.MaximumImageDwellMicroseconds ||
                imageSettings.DwellTimeMicroSeconds < imageCapabilities.MinimumImageDwellMicroseconds)
            {
                Console.WriteLine(
                    @"Invalid Dwell Time setting ({0}): Value must be between {1} and {2}",
                    imageSettings.DwellTimeMicroSeconds,
                    imageCapabilities.MinimumImageDwellMicroseconds,
                    imageCapabilities.MaximumImageDwellMicroseconds);
            }

            try
            {
                IEnumerable<IElectronImage> images = imageAcquisitionController.StartAcquisition(acquisitionSettings);
                images.ToList().ForEach(i =>
                {
                    i.Label = string.Format(@"Code example image - {0:HH:mm:ss} - {1}", DateTime.Now, i.InputSource.ToString());
                });
            }
            catch (InvalidSettingsException settingsException)
            {
                var sb = new StringBuilder(@"Invalid settings have been supplied: ");
                sb.AppendLine();
                settingsException.ValidationResults.ValidationErrors.ToList().ForEach(ve => sb.AppendFormat("{0}{1}", Environment.NewLine, ve));

                Console.WriteLine(sb.ToString());
            }
            catch (AcquisitionStartException startException)
            {
                Console.WriteLine(@"AcquisitionStartException: {0}", startException.Message);
            }
        }

        /// <summary>
        /// OnImageExperimentStarting
        /// </summary>
        private void OnImageExperimentStarting(object sender, AcquisitionStartingEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarting:");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                image.PropertyChanged += this.OnImagePropertyChanged;
                image.DataChanged += this.OnImageDataChanged;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentStarted
        /// </summary>
        private void OnImageExperimentStarted(object sender, AcquisitionStartedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarted");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarting -= this.OnImageExperimentStarting;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentFinished
        /// </summary>
        private void OnImageExperimentFinished(object sender, AcquisitionFinishedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentFinished");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                Console.WriteLine(@"    AcquisitionDate: {0:dd-MMM-yy HH:mm:ss}", image.AcquisitionDate);
                Console.WriteLine(@"    FramesAveraged: {0}", image.FramesAveraged);

                image.PropertyChanged -= this.OnImagePropertyChanged;
                image.DataChanged -= this.OnImageDataChanged;
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarted -= this.OnImageExperimentStarted;
                imageAcquisitionController.ExperimentFinished -= this.OnImageExperimentFinished;
            }

            Console.WriteLine();
            Console.WriteLine();
            Console.WriteLine(@"Code Example finished.");
        }

        /// <summary>
        /// OnImagePropertyChanged
        /// </summary>
        private void OnImagePropertyChanged(object sender, PropertyChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image != null)
            {
                Console.WriteLine(@"IElectronImage.PropertyChanged:{0}      ""{1}"" - {2}", Environment.NewLine, image.Label, e.PropertyName);
                Console.WriteLine();
            }
        }

        /// <summary>
        /// OnImageDataChanged
        /// </summary>
        private void OnImageDataChanged(object sender, SpatialDataChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image == null)
            {
                return;
            }

            Console.WriteLine(@"IElectronImage.DataChanged: {0}", image.Label);
            Console.WriteLine(@"        ChangedPixels Height/Width: {0}/{1}", e.ChangedPixels.Height, e.ChangedPixels.Width);

            var chordArray = new[] { new Chord(e.ChangedPixels.X, e.ChangedPixels.Y, e.ChangedPixels.Width) };

            var buffer = new byte[chordArray[0].Length * image.BytesPerPixel];

            // Get the data for the changed pixels
            image.GetData(chordArray, buffer);

            Console.WriteLine(@"        Image Height/Width: {0}/{1}", image.Height, image.Width);
            Console.WriteLine(@"        Image BytesPerPixel: {0}", image.BytesPerPixel);
            Console.WriteLine(@"        Data Buffer length: {0:0,000}", buffer.Length);
            Console.WriteLine();
        }
    }
}
See Also

Reference

OINA.Extender.Acquisition.Image Namespace


IImageSettings Properties

The IImageSettings type exposes the following members.

Properties
 | Name | Description
Public property | DwellTimeMicroSeconds | Gets or sets the dwell time per pixel in microseconds.
Public property | InputSources | Gets the image input sources. For example, BSE.
Top
See Also

Reference

IImageSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageSettings.DwellTimeMicroSeconds Property

Gets or sets the dwell time per pixel in microseconds.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double DwellTimeMicroSeconds { get; set; }
Property DwellTimeMicroSeconds As Double
    Get
    Set
property double DwellTimeMicroSeconds {
    double get ();
    void set (double value);
}
abstract DwellTimeMicroSeconds : float with get, set

Property Value

Type: Double
See Also

Reference

IImageSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageSettings.InputSources Property

Gets the image input sources. For example, BSE.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ReadOnlyDictionary<ImageInputSources, bool> InputSources { get; }
ReadOnly Property InputSources As ReadOnlyDictionary(Of ImageInputSources, Boolean)
    Get
property ReadOnlyDictionary<ImageInputSources, bool>^ InputSources {
    ReadOnlyDictionary<ImageInputSources, bool>^ get ();
}
abstract InputSources : ReadOnlyDictionary<ImageInputSources, bool> with get

Property Value

Type: ReadOnlyDictionary ImageInputSources, Boolean
See Also

Reference

IImageSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageSettings Methods

The IImageSettings type exposes the following members.

Methods
 | Name | Description
Public method | EnableInputSource | Used to select image input sources for acquisition. Electron Images from different sources can be acquired simultaneously.
Top
See Also

Reference

IImageSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageSettings.EnableInputSource Method

Used to select image input sources for acquisition. Electron Images from different sources can be acquired simultaneously.

Namespace: OINA.Extender.Acquisition.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void EnableInputSource(
    ImageInputSources inputSource,
    bool isSelected
)
Sub EnableInputSource (
    inputSource As ImageInputSources,
    isSelected As Boolean
)
void EnableInputSource(
    ImageInputSources inputSource,
    bool isSelected
)
abstract EnableInputSource :
        inputSource : ImageInputSources *
        isSelected : bool -> unit

Parameters

inputSource
Type: OINA.Extender.Data.ImageImageInputSources
The ImageInputSources Enum value
isSelected
Type: SystemBoolean
Whether the source is selected
See Also

Reference

IImageSettings Interface
OINA.Extender.Acquisition.Image Namespace


IImageSettings Events

The IImageSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IImageSettings Interface
OINA.Extender.Acquisition.Image Namespace


OINA.Extender.Acquisition.Quant Namespace

Defines all Classes and Interfaces used to control the acquisition of Ed data for quant calibration.

Classes
 | Class | Description
Public class | BeamMeasurementResultEventArgs | A Class that provides information about the beam measurement result.
Public class | CalibrationAcquisitionFinishedEventArgs | A Class that provides information about the completed beam measurement, or energy calibration acquisition.
Public class | CalibrationFinishedEventArgs | A Class that provides information about a completed beam measurement, or energy calibration.
Public class | CalibrationPeakInsignificantEventArgs | A Class that provides information about the calibration peak during beam measurement, or energy calibration.
Public class | EnergyWindowRange | A Class that defines the scope of an energy window.
Public class | QuantCalibrationException | A Class that defines an exception created when an error occurs during beam measurement, or energy calibration.
Interfaces
 | Interface | Description
Public interface | IQuantCalibrationCapabilities | An Interface that defines the capabilities for quant calibration.
 | IQuantCalibrationController | An Interface that can be used to perform a quant calibration.
 | IQuantCalibrationSettings | An Interface that defines the settings for quant calibration.
Enumerations
 | Enumeration | Description
Public enumeration | BeamMeasurementResultStatus | The result of a beam measurement.
Public enumeration | QuantCalibrationMode | The type of calibration to perform.


BeamMeasurementResultEventArgs Class

A Class that provides information about the beam measurement result.
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.Extender.Acquisition.QuantBeamMeasurementResultEventArgs

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class BeamMeasurementResultEventArgs : EventArgs
Public Class BeamMeasurementResultEventArgs
    Inherits EventArgs
public ref class BeamMeasurementResultEventArgs : public EventArgs
type BeamMeasurementResultEventArgs =
    class
        inherit EventArgs
    end

The BeamMeasurementResultEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether to cancel the beam measurement process.
Public property | Percent | Gets the percentage of the current beam measurement, relative to the previous beam measurement.
Public property | Status | Gets the status of the beam measurement result.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Acquisition.Quant Namespace


BeamMeasurementResultEventArgs Properties

The BeamMeasurementResultEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether to cancel the beam measurement process.
Public property | Percent | Gets the percentage of the current beam measurement, relative to the previous beam measurement.
Public property | Status | Gets the status of the beam measurement result.
Top
See Also

Reference

BeamMeasurementResultEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


BeamMeasurementResultEventArgs.Cancel Property

Gets or sets a value indicating whether to cancel the beam measurement process.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BeamMeasurementResultEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


BeamMeasurementResultEventArgs.Percent Property

Gets the percentage of the current beam measurement, relative to the previous beam measurement.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double Percent { get; }
Public ReadOnly Property Percent As Double
    Get
public:
property double Percent {
    double get ();
}
member Percent : float with get

Property Value

Type: Double
See Also

Reference

BeamMeasurementResultEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


BeamMeasurementResultEventArgs.Status Property

Gets the status of the beam measurement result.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public BeamMeasurementResultStatus Status { get; }
Public ReadOnly Property Status As BeamMeasurementResultStatus
    Get
public:
property BeamMeasurementResultStatus Status {
    BeamMeasurementResultStatus get ();
}
member Status : BeamMeasurementResultStatus with get

Property Value

Type: BeamMeasurementResultStatus
See Also

Reference

BeamMeasurementResultEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


BeamMeasurementResultEventArgs Methods

The BeamMeasurementResultEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeamMeasurementResultEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


BeamMeasurementResultStatus Enumeration

The result of a beam measurement.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum BeamMeasurementResultStatus
Public Enumeration BeamMeasurementResultStatus
public enum class BeamMeasurementResultStatus
type BeamMeasurementResultStatus
Members
Member name | Value | Description
None | 0 | Beam measurement has not been done.
MeasurementOK | 1 | Beam measurement was OK.
MeasurementDifference | 2 | Beam measurement was different to previous measurement.
See Also

Reference

OINA.Extender.Acquisition.Quant Namespace


CalibrationAcquisitionFinishedEventArgs Class

A Class that provides information about the completed beam measurement, or energy calibration acquisition.
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.Extender.Acquisition.QuantCalibrationAcquisitionFinishedEventArgs

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class CalibrationAcquisitionFinishedEventArgs : EventArgs
Public Class CalibrationAcquisitionFinishedEventArgs
    Inherits EventArgs
public ref class CalibrationAcquisitionFinishedEventArgs : public EventArgs
type CalibrationAcquisitionFinishedEventArgs =
    class
        inherit EventArgs
    end

The CalibrationAcquisitionFinishedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether to cancel calibration or not. If Success is false, setting Cancel to false has no effect
Public property | Error | Gets a value indicating whether an exception occurred during acquisition.
Public property | Success | Gets a value indicating whether the acquisition was successful.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Acquisition.Quant Namespace


CalibrationAcquisitionFinishedEventArgs Properties

The CalibrationAcquisitionFinishedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether to cancel calibration or not. If Success is false, setting Cancel to false has no effect
Public property | Error | Gets a value indicating whether an exception occurred during acquisition.
Public property | Success | Gets a value indicating whether the acquisition was successful.
Top
See Also

Reference

CalibrationAcquisitionFinishedEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationAcquisitionFinishedEventArgs.Cancel Property

Gets or sets a value indicating whether to cancel calibration or not.

If Success is false, setting Cancel to false has no effect

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CalibrationAcquisitionFinishedEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationAcquisitionFinishedEventArgs.Error Property

Gets a value indicating whether an exception occurred during acquisition.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Exception Error { get; }
Public ReadOnly Property Error As Exception
    Get
public:
property Exception^ Error {
    Exception^ get ();
}
member Error : Exception with get

Property Value

Type: Exception
See Also

Reference

CalibrationAcquisitionFinishedEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationAcquisitionFinishedEventArgs.Success Property

Gets a value indicating whether the acquisition was successful.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool Success { get; }
Public ReadOnly Property Success As Boolean
    Get
public:
property bool Success {
    bool get ();
}
member Success : bool with get

Property Value

Type: Boolean
See Also

Reference

CalibrationAcquisitionFinishedEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationAcquisitionFinishedEventArgs Methods

The CalibrationAcquisitionFinishedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CalibrationAcquisitionFinishedEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationFinishedEventArgs Class

A Class that provides information about a completed beam measurement, or energy calibration.
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.Extender.Acquisition.QuantCalibrationFinishedEventArgs

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class CalibrationFinishedEventArgs : EventArgs
Public Class CalibrationFinishedEventArgs
    Inherits EventArgs
public ref class CalibrationFinishedEventArgs : public EventArgs
type CalibrationFinishedEventArgs =
    class
        inherit EventArgs
    end

The CalibrationFinishedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Error | Gets a value indicating whether an error occured during calibration.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Acquisition.Quant Namespace


CalibrationFinishedEventArgs Properties

The CalibrationFinishedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Error | Gets a value indicating whether an error occured during calibration.
Top
See Also

Reference

CalibrationFinishedEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationFinishedEventArgs.Error Property

Gets a value indicating whether an error occured during calibration.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Exception Error { get; }
Public ReadOnly Property Error As Exception
    Get
public:
property Exception^ Error {
    Exception^ get ();
}
member Error : Exception with get

Property Value

Type: Exception
See Also

Reference

CalibrationFinishedEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationFinishedEventArgs Methods

The CalibrationFinishedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CalibrationFinishedEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationPeakInsignificantEventArgs Class

A Class that provides information about the calibration peak during beam measurement, or energy calibration.
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.Extender.Acquisition.QuantCalibrationPeakInsignificantEventArgs

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class CalibrationPeakInsignificantEventArgs : EventArgs
Public Class CalibrationPeakInsignificantEventArgs
    Inherits EventArgs
public ref class CalibrationPeakInsignificantEventArgs : public EventArgs
type CalibrationPeakInsignificantEventArgs =
    class
        inherit EventArgs
    end

The CalibrationPeakInsignificantEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ElapsedTime | Gets the elapsed time.
Public property | EstimatedTimeToCompletion | Gets the estimated time remaining to complete the calibration.
Public property | HighEnergyBackgroundCounts | Gets the background counts on the high energy side of the calibration peak.
Public property | LowEnergyBackgroundCounts | Gets the background counts on the low energy side of the calibration peak.
Public property | PeakCounts | Gets the counts in the selected calibration peak.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Acquisition.Quant Namespace


CalibrationPeakInsignificantEventArgs Properties

The CalibrationPeakInsignificantEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ElapsedTime | Gets the elapsed time.
Public property | EstimatedTimeToCompletion | Gets the estimated time remaining to complete the calibration.
Public property | HighEnergyBackgroundCounts | Gets the background counts on the high energy side of the calibration peak.
Public property | LowEnergyBackgroundCounts | Gets the background counts on the low energy side of the calibration peak.
Public property | PeakCounts | Gets the counts in the selected calibration peak.
Top
See Also

Reference

CalibrationPeakInsignificantEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationPeakInsignificantEventArgs.ElapsedTime Property

Gets the elapsed time.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public TimeSpan ElapsedTime { get; }
Public ReadOnly Property ElapsedTime As TimeSpan
    Get
public:
property TimeSpan ElapsedTime {
    TimeSpan get ();
}
member ElapsedTime : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

CalibrationPeakInsignificantEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationPeakInsignificantEventArgs.EstimatedTimeToCompletion Property

Gets the estimated time remaining to complete the calibration.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public TimeSpan EstimatedTimeToCompletion { get; }
Public ReadOnly Property EstimatedTimeToCompletion As TimeSpan
    Get
public:
property TimeSpan EstimatedTimeToCompletion {
    TimeSpan get ();
}
member EstimatedTimeToCompletion : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

CalibrationPeakInsignificantEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationPeakInsignificantEventArgs.HighEnergyBackgroundCounts Property

Gets the background counts on the high energy side of the calibration peak.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public int HighEnergyBackgroundCounts { get; }
Public ReadOnly Property HighEnergyBackgroundCounts As Integer
    Get
public:
property int HighEnergyBackgroundCounts {
    int get ();
}
member HighEnergyBackgroundCounts : int with get

Property Value

Type: Int32
See Also

Reference

CalibrationPeakInsignificantEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationPeakInsignificantEventArgs.LowEnergyBackgroundCounts Property

Gets the background counts on the low energy side of the calibration peak.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public int LowEnergyBackgroundCounts { get; }
Public ReadOnly Property LowEnergyBackgroundCounts As Integer
    Get
public:
property int LowEnergyBackgroundCounts {
    int get ();
}
member LowEnergyBackgroundCounts : int with get

Property Value

Type: Int32
See Also

Reference

CalibrationPeakInsignificantEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationPeakInsignificantEventArgs.PeakCounts Property

Gets the counts in the selected calibration peak.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public int PeakCounts { get; }
Public ReadOnly Property PeakCounts As Integer
    Get
public:
property int PeakCounts {
    int get ();
}
member PeakCounts : int with get

Property Value

Type: Int32
See Also

Reference

CalibrationPeakInsignificantEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


CalibrationPeakInsignificantEventArgs Methods

The CalibrationPeakInsignificantEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CalibrationPeakInsignificantEventArgs Class
OINA.Extender.Acquisition.Quant Namespace


EnergyWindowRange Class

A Class that defines the scope of an energy window.
Inheritance Hierarchy
SystemObject
OINA.Extender.Acquisition.QuantEnergyWindowRange

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class EnergyWindowRange
Public Class EnergyWindowRange
public ref class EnergyWindowRange
type EnergyWindowRange =  class end

The EnergyWindowRange type exposes the following members.

Constructors
 | Name | Description
Public method | EnergyWindowRange | Initializes a new instance of the EnergyWindowRange class.
Top
Properties
 | Name | Description
Public property | LowerEnergy | Gets the lower bound of the energy window.
Public property | UpperEnergy | Gets the upper bound of the energy window.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Acquisition.Quant Namespace


EnergyWindowRange Constructor

Initializes a new instance of the EnergyWindowRange class.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public EnergyWindowRange(
    double lowerEnergy,
    double upperEnergy
)
Public Sub New (
    lowerEnergy As Double,
    upperEnergy As Double
)
public:
EnergyWindowRange(
    double lowerEnergy,
    double upperEnergy
)
new :
        lowerEnergy : float *
        upperEnergy : float -> EnergyWindowRange

Parameters

lowerEnergy
Type: SystemDouble
The lower bound of the energy window
upperEnergy
Type: SystemDouble
The upper bound of the energy window
See Also

Reference

EnergyWindowRange Class
OINA.Extender.Acquisition.Quant Namespace


EnergyWindowRange Properties

The EnergyWindowRange type exposes the following members.

Properties
 | Name | Description
Public property | LowerEnergy | Gets the lower bound of the energy window.
Public property | UpperEnergy | Gets the upper bound of the energy window.
Top
See Also

Reference

EnergyWindowRange Class
OINA.Extender.Acquisition.Quant Namespace


EnergyWindowRange.LowerEnergy Property

Gets the lower bound of the energy window.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double LowerEnergy { get; }
Public ReadOnly Property LowerEnergy As Double
    Get
public:
property double LowerEnergy {
    double get ();
}
member LowerEnergy : float with get

Property Value

Type: Double
See Also

Reference

EnergyWindowRange Class
OINA.Extender.Acquisition.Quant Namespace


EnergyWindowRange.UpperEnergy Property

Gets the upper bound of the energy window.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double UpperEnergy { get; }
Public ReadOnly Property UpperEnergy As Double
    Get
public:
property double UpperEnergy {
    double get ();
}
member UpperEnergy : float with get

Property Value

Type: Double
See Also

Reference

EnergyWindowRange Class
OINA.Extender.Acquisition.Quant Namespace


EnergyWindowRange Methods

The EnergyWindowRange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EnergyWindowRange Class
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationCapabilities Interface

An Interface that defines the capabilities for quant calibration.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IQuantCalibrationCapabilities : INotifyPropertyChanged
Public Interface IQuantCalibrationCapabilities
    Inherits INotifyPropertyChanged
public interface class IQuantCalibrationCapabilities : INotifyPropertyChanged
type IQuantCalibrationCapabilities =
    interface
        interface INotifyPropertyChanged
    end

The IQuantCalibrationCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AllowedCalibrationElements | Gets the allowed quant calibration elements.
Public property | AllowedCalibrationModes | Gets the allowed quant calibration modes.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationCapabilities Properties

The IQuantCalibrationCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AllowedCalibrationElements | Gets the allowed quant calibration elements.
Public property | AllowedCalibrationModes | Gets the allowed quant calibration modes.
Top
See Also

Reference

IQuantCalibrationCapabilities Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationCapabilities.AllowedCalibrationElements Property

Gets the allowed quant calibration elements.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<int> AllowedCalibrationElements { get; }
ReadOnly Property AllowedCalibrationElements As ReadOnlyCollection(Of Integer)
    Get
property ReadOnlyCollection<int>^ AllowedCalibrationElements {
    ReadOnlyCollection<int>^ get ();
}
abstract AllowedCalibrationElements : ReadOnlyCollection<int> with get

Property Value

Type: ReadOnlyCollection Int32
See Also

Reference

IQuantCalibrationCapabilities Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationCapabilities.AllowedCalibrationModes Property

Gets the allowed quant calibration modes.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<QuantCalibrationMode> AllowedCalibrationModes { get; }
ReadOnly Property AllowedCalibrationModes As ReadOnlyCollection(Of QuantCalibrationMode)
    Get
property ReadOnlyCollection<QuantCalibrationMode>^ AllowedCalibrationModes {
    ReadOnlyCollection<QuantCalibrationMode>^ get ();
}
abstract AllowedCalibrationModes : ReadOnlyCollection<QuantCalibrationMode> with get

Property Value

Type: ReadOnlyCollection QuantCalibrationMode
See Also

Reference

IQuantCalibrationCapabilities Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationCapabilities Events

The IQuantCalibrationCapabilities type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IQuantCalibrationCapabilities Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController Interface

An Interface that can be used to perform a quant calibration.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IQuantCalibrationController : INotifyPropertyChanged,
    IDisposable
Public Interface IQuantCalibrationController
    Inherits INotifyPropertyChanged, IDisposable
public interface class IQuantCalibrationController : INotifyPropertyChanged,
    IDisposable
type IQuantCalibrationController =
    interface
        interface INotifyPropertyChanged
        interface IDisposable
    end

The IQuantCalibrationController type exposes the following members.

Properties
 | Name | Description
Public property | CurrentCalibrationSpectrum | Gets the current spectrum.
Public property | CurrentEnergyWindow | Gets the current energy window in keV.
Public property | ElapsedTime | Gets the total elapsed time.
Public property | EstimatedTimeToCompletion | Gets the estimated time remaining to complete the calibration.
Public property | IsAcquiring | Gets a value indicating whether a calibration is in progress.
Public property | IsIdle | Gets a value indicating whether a calibration is not in progress.
Public property | PercentageComplete | Gets the progress of the calibration as a percentage.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StartCalibration | Start energy calibration or beam measurement.
Public method | StopCalibration | Stop energy calibration or beam measurement.
Top
Events
 | Name | Description
Public event | BeamMeasurementAcquisitionFinished | Occurs when the beam current measurement acquisition has finished.
Public event | BeamMeasurementAcquisitionStarted | Occurs when the beam current measurement acquisition has started.
Public event | BeamMeasurementFinished | Occurs when the beam current measurement has finished.
Public event | BeamMeasurementResult | Occurs when the beam current measurement result has been calculated.
Public event | CalibrationPeakInsignificant | Occurs when the calibration peak is insignificant.
Public event | EnergyCalibrationAcquisitionFinished | Occurs when the energy calibration acquisition has finished.
Public event | EnergyCalibrationAcquisitionStarted | Occurs when the energy calibration acquisition has started.
Public event | EnergyCalibrationFinished | Occurs when the energy calibration has finished.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Examples
Copy
namespace Extender.CodeExamples.AcquisitionExamples
{
    using System;
    using System.ComponentModel;
    using System.Globalization;
    using System.Linq;
    using OINA.Extender;
    using OINA.Extender.Acquisition.Ed;
    using OINA.Extender.Acquisition.Quant;

    /// <summary>
    /// The microscope beam current may vary with time. If we want to measure absolute concentrations,
    /// we need to make a comparison of intensity of a peak with that from a known
    /// material. If we measure a known material, we can then make accurate intensity measurements
    /// on unknowns, provided the beam current doesn't alter after the optimization.
    /// <para/>
    /// Note that you do not need to perform the Beam Measurement routine if you are only interested
    /// in Qualitative Analysis or Normalized Quantitative Analysis
    /// </summary>
    public class BeamMeasurementExample
    {
        /// <summary>
        /// Flag to show if the user has been warned about insignificant calibration peak for a particular run
        /// </summary>
        private bool userWarnedOnCalibrationPeakInsignificant;

        public void Run()
        {
            Console.WriteLine();
            Console.WriteLine(@"Quant Calibration - Beam Measurement Example.");
            Console.WriteLine();

            IQuantCalibrationSettings quantCalibrationSettings = AcquireFactory.CreateQuantCalibrationSettings();
            IQuantCalibrationController quantCalibrationController = AcquireFactory.CreateQuantCalibrationController();

            // Use the same Ed settings as spectrum acquistion
            IEdSettings edSettings = AcquireFactory.CreateEdSpectrumSettings().EdSettings;

            Console.WriteLine(@"Allowed Process Times: {0}", string.Join(", ", quantCalibrationSettings.EdCapabilities.AllowedProcessTimes));
            Console.WriteLine(@"Allowed Energy Ranges: {0}", string.Join(", ", quantCalibrationSettings.EdCapabilities.AllowedEnergyRanges));
            Console.WriteLine(@"Allowed Number of Channels: {0}", string.Join(", ", quantCalibrationSettings.EdCapabilities.AllowedNumberOfChannels));

            edSettings.EnergyRange = 10;
            edSettings.NumberOfChannels = 1024;
            edSettings.ProcessTime = 4;

            quantCalibrationSettings.EdSettings.CopyFrom(edSettings);

            // Set the Calibration settings to Beam Measurement mode
            quantCalibrationSettings.CalibrationMode = QuantCalibrationMode.BeamMeasurement;

            // Select eg. Manganese as the calibration element
            ////const int CalibrationElement = 25; // Manganese - correct element when using hardware simulator
            const int CalibrationElement = 14; // Silicon - incorrect element - use to trigger the Insignificant Calibration Peak warning.

            // Set calibration element
            quantCalibrationSettings.CalibrationElementAtomicNumber = CalibrationElement;

            // Events from the IQuantCalibrationController object
            quantCalibrationController.BeamMeasurementAcquisitionStarted += this.OnBeamMeasurementAcquisitionStarted;
            quantCalibrationController.BeamMeasurementAcquisitionFinished += this.OnBeamMeasurementAcquisitionFinished;
            quantCalibrationController.BeamMeasurementResult += this.OnBeamMeasurementResult;
            quantCalibrationController.BeamMeasurementFinished += this.OnBeamMeasurementFinished;

            quantCalibrationController.PropertyChanged += this.OnControllerPropertyChanged;
            quantCalibrationController.CalibrationPeakInsignificant += this.OnCalibrationPeakInsignificant;

            try
            {
                quantCalibrationController.StartCalibration(quantCalibrationSettings);
            }
            catch (InvalidSettingsException ex)
            {
                Console.WriteLine(@"The settings are not valid: {0}", ex.Message);
                ex.ValidationResults.ValidationErrors.ToList().ForEach(Console.WriteLine);
                return;
            }

            this.userWarnedOnCalibrationPeakInsignificant = false;
        }

        /// <summary>
        /// The calibration peak is not significant.
        /// Trigger this by choosing the wrong element.
        /// </summary>
        /// <param name="sender">The sender</param>
        /// <param name="e">The event args</param>
        private void OnCalibrationPeakInsignificant(object sender, CalibrationPeakInsignificantEventArgs e)
        {
            if (this.userWarnedOnCalibrationPeakInsignificant)
            {
                return;
            }

            Console.WriteLine(@"Controller CalibrationPeakInsignificant:");

            Console.WriteLine(
                @"The calibration peak is not significantly greater than the background:Peak counts: {0}, Low energy background: {1}, High energy background: {2}",
                e.PeakCounts,
                e.LowEnergyBackgroundCounts,
                e.HighEnergyBackgroundCounts);

            Console.WriteLine(@"    ElapsedTime - {0:hh\:mm\:ss}", e.ElapsedTime);
            Console.WriteLine(@"    EstimatedTimeToCompletion - {0:hh\:mm\:ss}", e.EstimatedTimeToCompletion);
            Console.WriteLine();

            Console.WriteLine(@"The wrong calibration element may have been selected.");
            Console.WriteLine(@"Do you want to stop calibration (Y/N) ?");

            if (Console.ReadKey().Key == ConsoleKey.Y)
            {
                ((IQuantCalibrationController)sender).StopCalibration();
            }

            this.userWarnedOnCalibrationPeakInsignificant = true;
        }

        /// <summary>
        /// Called when IQuantCalibrationController PropertyChanged
        /// </summary>
        private void OnControllerPropertyChanged(object sender, PropertyChangedEventArgs e)
        {
            var controller = (IQuantCalibrationController)sender;

            var output = string.Empty;
            switch (e.PropertyName)
            {
                case "IsIdle":
                    output = string.Format(CultureInfo.InvariantCulture, @"     IsIdle - {0}", controller.IsIdle);
                    break;
                case "IsAcquiring":
                    output = string.Format(CultureInfo.InvariantCulture, @"     IsAcquiring - {0}", controller.IsAcquiring);
                    break;
                case "CurrentCalibrationSpectrum":
                    output = @"     CurrentCalibrationSpectrum";
                    if (controller.CurrentCalibrationSpectrum != null)
                    {
                        output = string.Format(CultureInfo.InvariantCulture, @"     CurrentCalibrationSpectrum - {0}", controller.CurrentCalibrationSpectrum.Label);
                    }

                    break;
                case "CurrentEnergyWindow":
                    output = @"     CurrentEnergyWindow";
                    if (controller.CurrentEnergyWindow != null)
                    {
                        output = string.Format(CultureInfo.InvariantCulture, @"     CurrentEnergyWindow Lower/Upper Energy - {0}/{1}", controller.CurrentEnergyWindow.LowerEnergy, controller.CurrentEnergyWindow.UpperEnergy);
                    }

                    break;
                case "PercentageComplete":
                    output = string.Format(CultureInfo.InvariantCulture, @"     PercentageComplete - {0:0.00}", controller.PercentageComplete);
                    break;
                case "ElapsedTime":
                    output = string.Format(CultureInfo.InvariantCulture, @"     ElapsedTime - {0:hh\:mm\:ss\.ff}", controller.ElapsedTime);
                    break;
                case "EstimatedTimeToCompletion":
                    output = string.Format(CultureInfo.InvariantCulture, @"     EstimatedTimeToCompletion - {0:hh\:mm\:ss\.ff}", controller.EstimatedTimeToCompletion);
                    break;
                default:
                    output = string.Format(CultureInfo.InvariantCulture, @"     {0}", e.PropertyName);
                    break;
            }

            Console.WriteLine(@"Controller Property Changed:{0}{1}", Environment.NewLine, output);
            Console.WriteLine();
        }

        /// <summary>
        /// The beam measurement has finished
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">CalibrationFinishedEventArgs - may contain a local exception raised by Calibration process</param>
        private void OnBeamMeasurementFinished(object sender, CalibrationFinishedEventArgs e)
        {
            string output = string.Empty;
            if (e.Error != null)
            {
                output = string.Format(CultureInfo.InvariantCulture, @":{0}     Error Occurred: - {1}", Environment.NewLine, e.Error);
            }

            Console.WriteLine(@"Controller BeamMeasurementFinished{0}", output);
            Console.WriteLine();
        }

        /// <summary>
        /// The beam measurement has been compared to the previous measurement
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">The BeamMeasurementResultEventArgs which contain the results of the beam measurement</param>
        private void OnBeamMeasurementResult(object sender, BeamMeasurementResultEventArgs e)
        {
            Console.WriteLine(@"Controller BeamMeasurementResult:");

            if (e.Status == BeamMeasurementResultStatus.MeasurementDifference)
            {
                Console.WriteLine(@"The beam current is {0:0.00}% of the last value", e.Percent);
            }
            else if (e.Status == BeamMeasurementResultStatus.MeasurementOK)
            {
                Console.WriteLine(@"Measurement OK");
            }
            else
            {
                Console.WriteLine(@"Unexpected result status");
            }

            Console.WriteLine(@"Do you want to save the beam measurement (Y/N) ?");

            if (Console.ReadKey().Key == ConsoleKey.N)
            {
                e.Cancel = true;
            }
        }

        /// <summary>
        /// Called when the beam measurement acquisition has started
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">The event args</param>
        private void OnBeamMeasurementAcquisitionStarted(object sender, EventArgs e)
        {
            Console.WriteLine(@"Controller BeamMeasurementAcquisitionStarted:");
            Console.WriteLine(@"     CurrentCalibrationSpectrum Id - {0}", ((IQuantCalibrationController)sender).CurrentCalibrationSpectrum.Id);
            Console.WriteLine();
        }

        /// <summary>
        /// The beam measurement acquisition has finished
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">The CalibrationAcquisitionFinishedEventArgs, which contain details of how the measurement finished</param>
        private void OnBeamMeasurementAcquisitionFinished(object sender, CalibrationAcquisitionFinishedEventArgs e)
        {
            Console.WriteLine(@"Controller BeamMeasurementAcquisitionFinished:");

            if (!e.Success)
            {
                Console.WriteLine(@"Beam measurement acquisition did not complete successfully.");

                // Acquisition was stopped by the user, or an error occured
                if (e.Error != null)
                {
                    Console.WriteLine(@"Error occurred: {1}", e.Error.Message);
                }
            }

            Console.WriteLine();
        }
    }
}
Examples
Copy
namespace Extender.CodeExamples.AcquisitionExamples
{
    using System;
    using System.ComponentModel;
    using System.Globalization;
    using System.Linq;
    using OINA.Extender;
    using OINA.Extender.Acquisition.Quant;

    /// <summary>
    /// Ambient temperature changes will alter the gain of the system and this will affect where
    /// peaks appear in the spectrum. The exact peak positions and the resolution of the system are
    /// needed to precisely identify individual peak components in the spectrum.
    /// If peaks overlap, the relative sizes of individual peaks can only be calculated accurately if the
    /// width and position of each peak is accurately known. By measuring the position of one
    /// known peak, the system can be optimized to determine the position of all other peaks.
    /// </summary>
    public class EnergyCalibrationExample
    {
        /// <summary>
        /// Flag to show if the use has been warned about insignificant calibration peak for a particular run
        /// </summary>
        private bool userWarnedOnCalibrationPeakInsignificant;

        public void Run()
        {
            Console.WriteLine();
            Console.WriteLine(@"Quant Calibration - Energy Calibration Example.");
            Console.WriteLine();

            IQuantCalibrationSettings quantCalibrationSettings = AcquireFactory.CreateQuantCalibrationSettings();
            IQuantCalibrationController quantCalibrationController = AcquireFactory.CreateQuantCalibrationController();

            // Set the Calibration settings to Energy Calibration mode
            quantCalibrationSettings.CalibrationMode = QuantCalibrationMode.EnergyCalibration;

            // Energy Calibration is performed at 2 process times, PT1 and another process time.
            // The other process time should be the one that is most commonly used.
            quantCalibrationSettings.EdSettings.ProcessTime = 2;

            // Select eg. Manganese as the calibration element
            const int CalibrationElement = 25; // Manganese - correct element when using simulated hardware
            ////const int CalibrationElement = 14; // Silicon - incorrect element - use to trigger the Insignificant Calibration Peak warning.

            // Set calibration element
            quantCalibrationSettings.CalibrationElementAtomicNumber = CalibrationElement;

            // Events from the IQuantCalibrationController object
            quantCalibrationController.EnergyCalibrationAcquisitionStarted += this.OnEnergyCalibrationAcquisitionStarted;
            quantCalibrationController.EnergyCalibrationAcquisitionFinished += this.OnEnergyCalibrationAcquisitionFinished;
            quantCalibrationController.EnergyCalibrationFinished += this.OnEnergyCalibrationFinished;

            quantCalibrationController.PropertyChanged += this.OnControllerPropertyChanged;
            quantCalibrationController.CalibrationPeakInsignificant += this.OnCalibrationPeakInsignificant;

            try
            {
                quantCalibrationController.StartCalibration(quantCalibrationSettings);
            }
            catch (InvalidSettingsException ex)
            {
                Console.WriteLine(@"The settings are not valid: {0}", ex.Message);
                ex.ValidationResults.ValidationErrors.ToList().ForEach(Console.WriteLine);
                return;
            }

            this.userWarnedOnCalibrationPeakInsignificant = false;
        }

        /// <summary>
        /// The calibration peak is not significant.
        /// Trigger this in this example by choosing the wrong element.
        /// </summary>
        /// <param name="sender">The sender</param>
        /// <param name="e">The event args</param>
        private void OnCalibrationPeakInsignificant(object sender, CalibrationPeakInsignificantEventArgs e)
        {
            if (this.userWarnedOnCalibrationPeakInsignificant)
            {
                return;
            }

            Console.WriteLine(@"Controller CalibrationPeakInsignificant:");

            Console.WriteLine(
                @"The calibration peak is not significantly greater than the background: Peak counts: {0}, low energy background: {1}, high energy background: {2}",
                e.PeakCounts,
                e.LowEnergyBackgroundCounts,
                e.HighEnergyBackgroundCounts);

            Console.WriteLine(@"    ElapsedTime - {0:hh\:mm\:ss}", e.ElapsedTime);
            Console.WriteLine(@"    EstimatedTimeToCompletion - {0:hh\:mm\:ss}. ", e.EstimatedTimeToCompletion);
            Console.WriteLine();

            this.userWarnedOnCalibrationPeakInsignificant = true;

            Console.WriteLine(@"The wrong calibration element may have been selected.");
            Console.WriteLine(@"Do you want to stop calibration (Y/N) ?");

            if (Console.ReadKey().Key == ConsoleKey.Y)
            {
                ((IQuantCalibrationController)sender).StopCalibration();
            }
        }

        /// <summary>
        /// Called when IQuantCalibrationController PropertyChanged
        /// </summary>
        private void OnControllerPropertyChanged(object sender, PropertyChangedEventArgs e)
        {
            var controller = (IQuantCalibrationController)sender;

            var output = string.Empty;
            switch (e.PropertyName)
            {
                case "IsIdle":
                    output = string.Format(CultureInfo.InvariantCulture, @"     IsIdle - {0}", controller.IsIdle);
                    break;
                case "IsAcquiring":
                    output = string.Format(CultureInfo.InvariantCulture, @"     IsAcquiring - {0}", controller.IsAcquiring);
                    break;
                case "CurrentCalibrationSpectrum":
                    output = @"     CurrentCalibrationSpectrum";
                    if (controller.CurrentCalibrationSpectrum != null)
                    {
                        output = string.Format(CultureInfo.InvariantCulture, @"     CurrentCalibrationSpectrum - {0}", controller.CurrentCalibrationSpectrum.Label);
                    }

                    break;
                case "CurrentEnergyWindow":
                    output = @"     CurrentEnergyWindow";
                    if (controller.CurrentEnergyWindow != null)
                    {
                        output = string.Format(CultureInfo.InvariantCulture, @"     CurrentEnergyWindow Lower/Upper Energy - {0}/{1}", controller.CurrentEnergyWindow.LowerEnergy, controller.CurrentEnergyWindow.UpperEnergy);
                    }

                    break;
                case "PercentageComplete":
                    output = string.Format(CultureInfo.InvariantCulture, @"     PercentageComplete - {0:0.00}", controller.PercentageComplete);
                    break;
                case "ElapsedTime":
                    output = string.Format(CultureInfo.InvariantCulture, @"     ElapsedTime - {0:hh\:mm\:ss\.ff}", controller.ElapsedTime);
                    break;
                case "EstimatedTimeToCompletion":
                    output = string.Format(CultureInfo.InvariantCulture, @"     EstimatedTimeToCompletion - {0:hh\:mm\:ss\.ff}", controller.EstimatedTimeToCompletion);
                    break;
                default:
                    output = string.Format(CultureInfo.InvariantCulture, @"     {0}", e.PropertyName);
                    break;
            }

            Console.WriteLine(@"Controller Property Changed:{0}{1}", Environment.NewLine, output);
            Console.WriteLine();
        }

        /// <summary>
        /// The energy calibration has finished
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">CalibrationFinishedEventArgs - may contain a local exception raised by Calibration process</param>
        private void OnEnergyCalibrationFinished(object sender, CalibrationFinishedEventArgs e)
        {
            string output = string.Empty;
            if (e.Error != null)
            {
                output = string.Format(CultureInfo.InvariantCulture, @":{0}     Error Occurred: - {1}", Environment.NewLine, e.Error);
            }

            Console.WriteLine(@"Controller EnergyCalibrationFinished{0}", output);
            Console.WriteLine();
        }

        /// <summary>
        /// Called when the energy calibration acquisition has started
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">The event args</param>
        private void OnEnergyCalibrationAcquisitionStarted(object sender, EventArgs e)
        {
            Console.WriteLine(@"Controller EnergyCalibrationAcquisitionStarted:");
            Console.WriteLine(@"     CurrentCalibrationSpectrum Id - {0}", ((IQuantCalibrationController)sender).CurrentCalibrationSpectrum.Id);
            Console.WriteLine();
        }

        /// <summary>
        /// The energy calibration acquisition has finished
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">The CalibrationAcquisitionFinishedEventArgs, which contain details of how the measurement finished</param>
        private void OnEnergyCalibrationAcquisitionFinished(object sender, CalibrationAcquisitionFinishedEventArgs e)
        {
            Console.WriteLine(@"Controller EnergyCalibrationAcquisitionFinished:");
            Console.WriteLine();

            if (e.Success)
            {
                Console.WriteLine(@"Perform Energy calibration using the acquired spectra (Y/N) ?");
                if (Console.ReadKey().Key == ConsoleKey.N)
                {
                    e.Cancel = true;
                }
            }
            else
            {
                Console.WriteLine(@"Energy calibration acquisition did not complete successfully.");

                // Acquisition was stopped by the user, or an error occured
                if (e.Error != null)
                {
                    Console.WriteLine(@"Error occurred: {1}", e.Error.Message);
                }
            }

            Console.WriteLine();
        }
    }
}
See Also

Reference

OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController Properties

The IQuantCalibrationController type exposes the following members.

Properties
 | Name | Description
Public property | CurrentCalibrationSpectrum | Gets the current spectrum.
Public property | CurrentEnergyWindow | Gets the current energy window in keV.
Public property | ElapsedTime | Gets the total elapsed time.
Public property | EstimatedTimeToCompletion | Gets the estimated time remaining to complete the calibration.
Public property | IsAcquiring | Gets a value indicating whether a calibration is in progress.
Public property | IsIdle | Gets a value indicating whether a calibration is not in progress.
Public property | PercentageComplete | Gets the progress of the calibration as a percentage.
Top
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.CurrentCalibrationSpectrum Property

Gets the current spectrum.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSpectrum CurrentCalibrationSpectrum { get; }
ReadOnly Property CurrentCalibrationSpectrum As IEdSpectrum
    Get
property IEdSpectrum^ CurrentCalibrationSpectrum {
    IEdSpectrum^ get ();
}
abstract CurrentCalibrationSpectrum : IEdSpectrum with get

Property Value

Type: IEdSpectrum
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.CurrentEnergyWindow Property

Gets the current energy window in keV.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
EnergyWindowRange CurrentEnergyWindow { get; }
ReadOnly Property CurrentEnergyWindow As EnergyWindowRange
    Get
property EnergyWindowRange^ CurrentEnergyWindow {
    EnergyWindowRange^ get ();
}
abstract CurrentEnergyWindow : EnergyWindowRange with get

Property Value

Type: EnergyWindowRange
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.ElapsedTime Property

Gets the total elapsed time.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
TimeSpan ElapsedTime { get; }
ReadOnly Property ElapsedTime As TimeSpan
    Get
property TimeSpan ElapsedTime {
    TimeSpan get ();
}
abstract ElapsedTime : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.EstimatedTimeToCompletion Property

Gets the estimated time remaining to complete the calibration.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
TimeSpan EstimatedTimeToCompletion { get; }
ReadOnly Property EstimatedTimeToCompletion As TimeSpan
    Get
property TimeSpan EstimatedTimeToCompletion {
    TimeSpan get ();
}
abstract EstimatedTimeToCompletion : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.IsAcquiring Property

Gets a value indicating whether a calibration is in progress.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsAcquiring { get; }
ReadOnly Property IsAcquiring As Boolean
    Get
property bool IsAcquiring {
    bool get ();
}
abstract IsAcquiring : bool with get

Property Value

Type: Boolean
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.IsIdle Property

Gets a value indicating whether a calibration is not in progress.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsIdle { get; }
ReadOnly Property IsIdle As Boolean
    Get
property bool IsIdle {
    bool get ();
}
abstract IsIdle : bool with get

Property Value

Type: Boolean
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.PercentageComplete Property

Gets the progress of the calibration as a percentage.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double PercentageComplete { get; }
ReadOnly Property PercentageComplete As Double
    Get
property double PercentageComplete {
    double get ();
}
abstract PercentageComplete : float with get

Property Value

Type: Double
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController Methods

The IQuantCalibrationController type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StartCalibration | Start energy calibration or beam measurement.
Public method | StopCalibration | Stop energy calibration or beam measurement.
Top
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.StartCalibration Method

Start energy calibration or beam measurement.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void StartCalibration(
    IQuantCalibrationSettings settings
)
Sub StartCalibration (
    settings As IQuantCalibrationSettings
)
void StartCalibration(
    IQuantCalibrationSettings^ settings
)
abstract StartCalibration :
        settings : IQuantCalibrationSettings -> unit

Parameters

settings
Type: OINA.Extender.Acquisition.QuantIQuantCalibrationSettings
Settings for energy calibration or beam measurement.
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.StopCalibration Method

Stop energy calibration or beam measurement.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void StopCalibration()
Sub StopCalibration
void StopCalibration()
abstract StopCalibration : unit -> unit
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController Events

The IQuantCalibrationController type exposes the following members.

Events
 | Name | Description
Public event | BeamMeasurementAcquisitionFinished | Occurs when the beam current measurement acquisition has finished.
Public event | BeamMeasurementAcquisitionStarted | Occurs when the beam current measurement acquisition has started.
Public event | BeamMeasurementFinished | Occurs when the beam current measurement has finished.
Public event | BeamMeasurementResult | Occurs when the beam current measurement result has been calculated.
Public event | CalibrationPeakInsignificant | Occurs when the calibration peak is insignificant.
Public event | EnergyCalibrationAcquisitionFinished | Occurs when the energy calibration acquisition has finished.
Public event | EnergyCalibrationAcquisitionStarted | Occurs when the energy calibration acquisition has started.
Public event | EnergyCalibrationFinished | Occurs when the energy calibration has finished.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.BeamMeasurementAcquisitionFinished Event

Occurs when the beam current measurement acquisition has finished.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<CalibrationAcquisitionFinishedEventArgs> BeamMeasurementAcquisitionFinished
Event BeamMeasurementAcquisitionFinished As EventHandler(Of CalibrationAcquisitionFinishedEventArgs)
 event EventHandler<CalibrationAcquisitionFinishedEventArgs^>^ BeamMeasurementAcquisitionFinished {
    void add (EventHandler<CalibrationAcquisitionFinishedEventArgs^>^ value);
    void remove (EventHandler<CalibrationAcquisitionFinishedEventArgs^>^ value);
}
abstract BeamMeasurementAcquisitionFinished : IEvent<EventHandler<CalibrationAcquisitionFinishedEventArgs>,
    CalibrationAcquisitionFinishedEventArgs>

Value

Type: SystemEventHandler CalibrationAcquisitionFinishedEventArgs
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.BeamMeasurementAcquisitionStarted Event

Occurs when the beam current measurement acquisition has started.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler BeamMeasurementAcquisitionStarted
Event BeamMeasurementAcquisitionStarted As EventHandler
 event EventHandler^ BeamMeasurementAcquisitionStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract BeamMeasurementAcquisitionStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.BeamMeasurementFinished Event

Occurs when the beam current measurement has finished.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<CalibrationFinishedEventArgs> BeamMeasurementFinished
Event BeamMeasurementFinished As EventHandler(Of CalibrationFinishedEventArgs)
 event EventHandler<CalibrationFinishedEventArgs^>^ BeamMeasurementFinished {
    void add (EventHandler<CalibrationFinishedEventArgs^>^ value);
    void remove (EventHandler<CalibrationFinishedEventArgs^>^ value);
}
abstract BeamMeasurementFinished : IEvent<EventHandler<CalibrationFinishedEventArgs>,
    CalibrationFinishedEventArgs>

Value

Type: SystemEventHandler CalibrationFinishedEventArgs
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.BeamMeasurementResult Event

Occurs when the beam current measurement result has been calculated.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<BeamMeasurementResultEventArgs> BeamMeasurementResult
Event BeamMeasurementResult As EventHandler(Of BeamMeasurementResultEventArgs)
 event EventHandler<BeamMeasurementResultEventArgs^>^ BeamMeasurementResult {
    void add (EventHandler<BeamMeasurementResultEventArgs^>^ value);
    void remove (EventHandler<BeamMeasurementResultEventArgs^>^ value);
}
abstract BeamMeasurementResult : IEvent<EventHandler<BeamMeasurementResultEventArgs>,
    BeamMeasurementResultEventArgs>

Value

Type: SystemEventHandler BeamMeasurementResultEventArgs
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.CalibrationPeakInsignificant Event

Occurs when the calibration peak is insignificant.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<CalibrationPeakInsignificantEventArgs> CalibrationPeakInsignificant
Event CalibrationPeakInsignificant As EventHandler(Of CalibrationPeakInsignificantEventArgs)
 event EventHandler<CalibrationPeakInsignificantEventArgs^>^ CalibrationPeakInsignificant {
    void add (EventHandler<CalibrationPeakInsignificantEventArgs^>^ value);
    void remove (EventHandler<CalibrationPeakInsignificantEventArgs^>^ value);
}
abstract CalibrationPeakInsignificant : IEvent<EventHandler<CalibrationPeakInsignificantEventArgs>,
    CalibrationPeakInsignificantEventArgs>

Value

Type: SystemEventHandler CalibrationPeakInsignificantEventArgs
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.EnergyCalibrationAcquisitionFinished Event

Occurs when the energy calibration acquisition has finished.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<CalibrationAcquisitionFinishedEventArgs> EnergyCalibrationAcquisitionFinished
Event EnergyCalibrationAcquisitionFinished As EventHandler(Of CalibrationAcquisitionFinishedEventArgs)
 event EventHandler<CalibrationAcquisitionFinishedEventArgs^>^ EnergyCalibrationAcquisitionFinished {
    void add (EventHandler<CalibrationAcquisitionFinishedEventArgs^>^ value);
    void remove (EventHandler<CalibrationAcquisitionFinishedEventArgs^>^ value);
}
abstract EnergyCalibrationAcquisitionFinished : IEvent<EventHandler<CalibrationAcquisitionFinishedEventArgs>,
    CalibrationAcquisitionFinishedEventArgs>

Value

Type: SystemEventHandler CalibrationAcquisitionFinishedEventArgs
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.EnergyCalibrationAcquisitionStarted Event

Occurs when the energy calibration acquisition has started.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler EnergyCalibrationAcquisitionStarted
Event EnergyCalibrationAcquisitionStarted As EventHandler
 event EventHandler^ EnergyCalibrationAcquisitionStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract EnergyCalibrationAcquisitionStarted : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationController.EnergyCalibrationFinished Event

Occurs when the energy calibration has finished.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<CalibrationFinishedEventArgs> EnergyCalibrationFinished
Event EnergyCalibrationFinished As EventHandler(Of CalibrationFinishedEventArgs)
 event EventHandler<CalibrationFinishedEventArgs^>^ EnergyCalibrationFinished {
    void add (EventHandler<CalibrationFinishedEventArgs^>^ value);
    void remove (EventHandler<CalibrationFinishedEventArgs^>^ value);
}
abstract EnergyCalibrationFinished : IEvent<EventHandler<CalibrationFinishedEventArgs>,
    CalibrationFinishedEventArgs>

Value

Type: SystemEventHandler CalibrationFinishedEventArgs
See Also

Reference

IQuantCalibrationController Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationSettings Interface

An Interface that defines the settings for quant calibration.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IQuantCalibrationSettings : INotifyPropertyChanged
Public Interface IQuantCalibrationSettings
    Inherits INotifyPropertyChanged
public interface class IQuantCalibrationSettings : INotifyPropertyChanged
type IQuantCalibrationSettings =
    interface
        interface INotifyPropertyChanged
    end

The IQuantCalibrationSettings type exposes the following members.

Properties
 | Name | Description
Public property | CalibrationElementAtomicNumber | Gets or sets the element used for energy calibration or beam measurement.
Public property | CalibrationMode | Gets or sets the calibration mode.
Public property | Capabilities | Gets the capabilities for quant calibration.
Public property | EdCapabilities | Gets the Ed Capabilities
Public property | EdSettings | Gets the Ed Settings
Public property | TotalCountsInSpectrum | Gets or sets the count limit at which to terminate the Beam Measurement. Not used for Energy Calibration.
Top
Methods
 | Name | Description
Public method | Validate | Validates the settings.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Examples
Copy
namespace Extender.CodeExamples.AcquisitionExamples
{
    using System;
    using System.ComponentModel;
    using System.Globalization;
    using System.Linq;
    using OINA.Extender;
    using OINA.Extender.Acquisition.Ed;
    using OINA.Extender.Acquisition.Quant;

    /// <summary>
    /// The microscope beam current may vary with time. If we want to measure absolute concentrations,
    /// we need to make a comparison of intensity of a peak with that from a known
    /// material. If we measure a known material, we can then make accurate intensity measurements
    /// on unknowns, provided the beam current doesn't alter after the optimization.
    /// <para/>
    /// Note that you do not need to perform the Beam Measurement routine if you are only interested
    /// in Qualitative Analysis or Normalized Quantitative Analysis
    /// </summary>
    public class BeamMeasurementExample
    {
        /// <summary>
        /// Flag to show if the user has been warned about insignificant calibration peak for a particular run
        /// </summary>
        private bool userWarnedOnCalibrationPeakInsignificant;

        public void Run()
        {
            Console.WriteLine();
            Console.WriteLine(@"Quant Calibration - Beam Measurement Example.");
            Console.WriteLine();

            IQuantCalibrationSettings quantCalibrationSettings = AcquireFactory.CreateQuantCalibrationSettings();
            IQuantCalibrationController quantCalibrationController = AcquireFactory.CreateQuantCalibrationController();

            // Use the same Ed settings as spectrum acquistion
            IEdSettings edSettings = AcquireFactory.CreateEdSpectrumSettings().EdSettings;

            Console.WriteLine(@"Allowed Process Times: {0}", string.Join(", ", quantCalibrationSettings.EdCapabilities.AllowedProcessTimes));
            Console.WriteLine(@"Allowed Energy Ranges: {0}", string.Join(", ", quantCalibrationSettings.EdCapabilities.AllowedEnergyRanges));
            Console.WriteLine(@"Allowed Number of Channels: {0}", string.Join(", ", quantCalibrationSettings.EdCapabilities.AllowedNumberOfChannels));

            edSettings.EnergyRange = 10;
            edSettings.NumberOfChannels = 1024;
            edSettings.ProcessTime = 4;

            quantCalibrationSettings.EdSettings.CopyFrom(edSettings);

            // Set the Calibration settings to Beam Measurement mode
            quantCalibrationSettings.CalibrationMode = QuantCalibrationMode.BeamMeasurement;

            // Select eg. Manganese as the calibration element
            ////const int CalibrationElement = 25; // Manganese - correct element when using hardware simulator
            const int CalibrationElement = 14; // Silicon - incorrect element - use to trigger the Insignificant Calibration Peak warning.

            // Set calibration element
            quantCalibrationSettings.CalibrationElementAtomicNumber = CalibrationElement;

            // Events from the IQuantCalibrationController object
            quantCalibrationController.BeamMeasurementAcquisitionStarted += this.OnBeamMeasurementAcquisitionStarted;
            quantCalibrationController.BeamMeasurementAcquisitionFinished += this.OnBeamMeasurementAcquisitionFinished;
            quantCalibrationController.BeamMeasurementResult += this.OnBeamMeasurementResult;
            quantCalibrationController.BeamMeasurementFinished += this.OnBeamMeasurementFinished;

            quantCalibrationController.PropertyChanged += this.OnControllerPropertyChanged;
            quantCalibrationController.CalibrationPeakInsignificant += this.OnCalibrationPeakInsignificant;

            try
            {
                quantCalibrationController.StartCalibration(quantCalibrationSettings);
            }
            catch (InvalidSettingsException ex)
            {
                Console.WriteLine(@"The settings are not valid: {0}", ex.Message);
                ex.ValidationResults.ValidationErrors.ToList().ForEach(Console.WriteLine);
                return;
            }

            this.userWarnedOnCalibrationPeakInsignificant = false;
        }

        /// <summary>
        /// The calibration peak is not significant.
        /// Trigger this by choosing the wrong element.
        /// </summary>
        /// <param name="sender">The sender</param>
        /// <param name="e">The event args</param>
        private void OnCalibrationPeakInsignificant(object sender, CalibrationPeakInsignificantEventArgs e)
        {
            if (this.userWarnedOnCalibrationPeakInsignificant)
            {
                return;
            }

            Console.WriteLine(@"Controller CalibrationPeakInsignificant:");

            Console.WriteLine(
                @"The calibration peak is not significantly greater than the background:Peak counts: {0}, Low energy background: {1}, High energy background: {2}",
                e.PeakCounts,
                e.LowEnergyBackgroundCounts,
                e.HighEnergyBackgroundCounts);

            Console.WriteLine(@"    ElapsedTime - {0:hh\:mm\:ss}", e.ElapsedTime);
            Console.WriteLine(@"    EstimatedTimeToCompletion - {0:hh\:mm\:ss}", e.EstimatedTimeToCompletion);
            Console.WriteLine();

            Console.WriteLine(@"The wrong calibration element may have been selected.");
            Console.WriteLine(@"Do you want to stop calibration (Y/N) ?");

            if (Console.ReadKey().Key == ConsoleKey.Y)
            {
                ((IQuantCalibrationController)sender).StopCalibration();
            }

            this.userWarnedOnCalibrationPeakInsignificant = true;
        }

        /// <summary>
        /// Called when IQuantCalibrationController PropertyChanged
        /// </summary>
        private void OnControllerPropertyChanged(object sender, PropertyChangedEventArgs e)
        {
            var controller = (IQuantCalibrationController)sender;

            var output = string.Empty;
            switch (e.PropertyName)
            {
                case "IsIdle":
                    output = string.Format(CultureInfo.InvariantCulture, @"     IsIdle - {0}", controller.IsIdle);
                    break;
                case "IsAcquiring":
                    output = string.Format(CultureInfo.InvariantCulture, @"     IsAcquiring - {0}", controller.IsAcquiring);
                    break;
                case "CurrentCalibrationSpectrum":
                    output = @"     CurrentCalibrationSpectrum";
                    if (controller.CurrentCalibrationSpectrum != null)
                    {
                        output = string.Format(CultureInfo.InvariantCulture, @"     CurrentCalibrationSpectrum - {0}", controller.CurrentCalibrationSpectrum.Label);
                    }

                    break;
                case "CurrentEnergyWindow":
                    output = @"     CurrentEnergyWindow";
                    if (controller.CurrentEnergyWindow != null)
                    {
                        output = string.Format(CultureInfo.InvariantCulture, @"     CurrentEnergyWindow Lower/Upper Energy - {0}/{1}", controller.CurrentEnergyWindow.LowerEnergy, controller.CurrentEnergyWindow.UpperEnergy);
                    }

                    break;
                case "PercentageComplete":
                    output = string.Format(CultureInfo.InvariantCulture, @"     PercentageComplete - {0:0.00}", controller.PercentageComplete);
                    break;
                case "ElapsedTime":
                    output = string.Format(CultureInfo.InvariantCulture, @"     ElapsedTime - {0:hh\:mm\:ss\.ff}", controller.ElapsedTime);
                    break;
                case "EstimatedTimeToCompletion":
                    output = string.Format(CultureInfo.InvariantCulture, @"     EstimatedTimeToCompletion - {0:hh\:mm\:ss\.ff}", controller.EstimatedTimeToCompletion);
                    break;
                default:
                    output = string.Format(CultureInfo.InvariantCulture, @"     {0}", e.PropertyName);
                    break;
            }

            Console.WriteLine(@"Controller Property Changed:{0}{1}", Environment.NewLine, output);
            Console.WriteLine();
        }

        /// <summary>
        /// The beam measurement has finished
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">CalibrationFinishedEventArgs - may contain a local exception raised by Calibration process</param>
        private void OnBeamMeasurementFinished(object sender, CalibrationFinishedEventArgs e)
        {
            string output = string.Empty;
            if (e.Error != null)
            {
                output = string.Format(CultureInfo.InvariantCulture, @":{0}     Error Occurred: - {1}", Environment.NewLine, e.Error);
            }

            Console.WriteLine(@"Controller BeamMeasurementFinished{0}", output);
            Console.WriteLine();
        }

        /// <summary>
        /// The beam measurement has been compared to the previous measurement
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">The BeamMeasurementResultEventArgs which contain the results of the beam measurement</param>
        private void OnBeamMeasurementResult(object sender, BeamMeasurementResultEventArgs e)
        {
            Console.WriteLine(@"Controller BeamMeasurementResult:");

            if (e.Status == BeamMeasurementResultStatus.MeasurementDifference)
            {
                Console.WriteLine(@"The beam current is {0:0.00}% of the last value", e.Percent);
            }
            else if (e.Status == BeamMeasurementResultStatus.MeasurementOK)
            {
                Console.WriteLine(@"Measurement OK");
            }
            else
            {
                Console.WriteLine(@"Unexpected result status");
            }

            Console.WriteLine(@"Do you want to save the beam measurement (Y/N) ?");

            if (Console.ReadKey().Key == ConsoleKey.N)
            {
                e.Cancel = true;
            }
        }

        /// <summary>
        /// Called when the beam measurement acquisition has started
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">The event args</param>
        private void OnBeamMeasurementAcquisitionStarted(object sender, EventArgs e)
        {
            Console.WriteLine(@"Controller BeamMeasurementAcquisitionStarted:");
            Console.WriteLine(@"     CurrentCalibrationSpectrum Id - {0}", ((IQuantCalibrationController)sender).CurrentCalibrationSpectrum.Id);
            Console.WriteLine();
        }

        /// <summary>
        /// The beam measurement acquisition has finished
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">The CalibrationAcquisitionFinishedEventArgs, which contain details of how the measurement finished</param>
        private void OnBeamMeasurementAcquisitionFinished(object sender, CalibrationAcquisitionFinishedEventArgs e)
        {
            Console.WriteLine(@"Controller BeamMeasurementAcquisitionFinished:");

            if (!e.Success)
            {
                Console.WriteLine(@"Beam measurement acquisition did not complete successfully.");

                // Acquisition was stopped by the user, or an error occured
                if (e.Error != null)
                {
                    Console.WriteLine(@"Error occurred: {1}", e.Error.Message);
                }
            }

            Console.WriteLine();
        }
    }
}
Examples
Copy
namespace Extender.CodeExamples.AcquisitionExamples
{
    using System;
    using System.ComponentModel;
    using System.Globalization;
    using System.Linq;
    using OINA.Extender;
    using OINA.Extender.Acquisition.Quant;

    /// <summary>
    /// Ambient temperature changes will alter the gain of the system and this will affect where
    /// peaks appear in the spectrum. The exact peak positions and the resolution of the system are
    /// needed to precisely identify individual peak components in the spectrum.
    /// If peaks overlap, the relative sizes of individual peaks can only be calculated accurately if the
    /// width and position of each peak is accurately known. By measuring the position of one
    /// known peak, the system can be optimized to determine the position of all other peaks.
    /// </summary>
    public class EnergyCalibrationExample
    {
        /// <summary>
        /// Flag to show if the use has been warned about insignificant calibration peak for a particular run
        /// </summary>
        private bool userWarnedOnCalibrationPeakInsignificant;

        public void Run()
        {
            Console.WriteLine();
            Console.WriteLine(@"Quant Calibration - Energy Calibration Example.");
            Console.WriteLine();

            IQuantCalibrationSettings quantCalibrationSettings = AcquireFactory.CreateQuantCalibrationSettings();
            IQuantCalibrationController quantCalibrationController = AcquireFactory.CreateQuantCalibrationController();

            // Set the Calibration settings to Energy Calibration mode
            quantCalibrationSettings.CalibrationMode = QuantCalibrationMode.EnergyCalibration;

            // Energy Calibration is performed at 2 process times, PT1 and another process time.
            // The other process time should be the one that is most commonly used.
            quantCalibrationSettings.EdSettings.ProcessTime = 2;

            // Select eg. Manganese as the calibration element
            const int CalibrationElement = 25; // Manganese - correct element when using simulated hardware
            ////const int CalibrationElement = 14; // Silicon - incorrect element - use to trigger the Insignificant Calibration Peak warning.

            // Set calibration element
            quantCalibrationSettings.CalibrationElementAtomicNumber = CalibrationElement;

            // Events from the IQuantCalibrationController object
            quantCalibrationController.EnergyCalibrationAcquisitionStarted += this.OnEnergyCalibrationAcquisitionStarted;
            quantCalibrationController.EnergyCalibrationAcquisitionFinished += this.OnEnergyCalibrationAcquisitionFinished;
            quantCalibrationController.EnergyCalibrationFinished += this.OnEnergyCalibrationFinished;

            quantCalibrationController.PropertyChanged += this.OnControllerPropertyChanged;
            quantCalibrationController.CalibrationPeakInsignificant += this.OnCalibrationPeakInsignificant;

            try
            {
                quantCalibrationController.StartCalibration(quantCalibrationSettings);
            }
            catch (InvalidSettingsException ex)
            {
                Console.WriteLine(@"The settings are not valid: {0}", ex.Message);
                ex.ValidationResults.ValidationErrors.ToList().ForEach(Console.WriteLine);
                return;
            }

            this.userWarnedOnCalibrationPeakInsignificant = false;
        }

        /// <summary>
        /// The calibration peak is not significant.
        /// Trigger this in this example by choosing the wrong element.
        /// </summary>
        /// <param name="sender">The sender</param>
        /// <param name="e">The event args</param>
        private void OnCalibrationPeakInsignificant(object sender, CalibrationPeakInsignificantEventArgs e)
        {
            if (this.userWarnedOnCalibrationPeakInsignificant)
            {
                return;
            }

            Console.WriteLine(@"Controller CalibrationPeakInsignificant:");

            Console.WriteLine(
                @"The calibration peak is not significantly greater than the background: Peak counts: {0}, low energy background: {1}, high energy background: {2}",
                e.PeakCounts,
                e.LowEnergyBackgroundCounts,
                e.HighEnergyBackgroundCounts);

            Console.WriteLine(@"    ElapsedTime - {0:hh\:mm\:ss}", e.ElapsedTime);
            Console.WriteLine(@"    EstimatedTimeToCompletion - {0:hh\:mm\:ss}. ", e.EstimatedTimeToCompletion);
            Console.WriteLine();

            this.userWarnedOnCalibrationPeakInsignificant = true;

            Console.WriteLine(@"The wrong calibration element may have been selected.");
            Console.WriteLine(@"Do you want to stop calibration (Y/N) ?");

            if (Console.ReadKey().Key == ConsoleKey.Y)
            {
                ((IQuantCalibrationController)sender).StopCalibration();
            }
        }

        /// <summary>
        /// Called when IQuantCalibrationController PropertyChanged
        /// </summary>
        private void OnControllerPropertyChanged(object sender, PropertyChangedEventArgs e)
        {
            var controller = (IQuantCalibrationController)sender;

            var output = string.Empty;
            switch (e.PropertyName)
            {
                case "IsIdle":
                    output = string.Format(CultureInfo.InvariantCulture, @"     IsIdle - {0}", controller.IsIdle);
                    break;
                case "IsAcquiring":
                    output = string.Format(CultureInfo.InvariantCulture, @"     IsAcquiring - {0}", controller.IsAcquiring);
                    break;
                case "CurrentCalibrationSpectrum":
                    output = @"     CurrentCalibrationSpectrum";
                    if (controller.CurrentCalibrationSpectrum != null)
                    {
                        output = string.Format(CultureInfo.InvariantCulture, @"     CurrentCalibrationSpectrum - {0}", controller.CurrentCalibrationSpectrum.Label);
                    }

                    break;
                case "CurrentEnergyWindow":
                    output = @"     CurrentEnergyWindow";
                    if (controller.CurrentEnergyWindow != null)
                    {
                        output = string.Format(CultureInfo.InvariantCulture, @"     CurrentEnergyWindow Lower/Upper Energy - {0}/{1}", controller.CurrentEnergyWindow.LowerEnergy, controller.CurrentEnergyWindow.UpperEnergy);
                    }

                    break;
                case "PercentageComplete":
                    output = string.Format(CultureInfo.InvariantCulture, @"     PercentageComplete - {0:0.00}", controller.PercentageComplete);
                    break;
                case "ElapsedTime":
                    output = string.Format(CultureInfo.InvariantCulture, @"     ElapsedTime - {0:hh\:mm\:ss\.ff}", controller.ElapsedTime);
                    break;
                case "EstimatedTimeToCompletion":
                    output = string.Format(CultureInfo.InvariantCulture, @"     EstimatedTimeToCompletion - {0:hh\:mm\:ss\.ff}", controller.EstimatedTimeToCompletion);
                    break;
                default:
                    output = string.Format(CultureInfo.InvariantCulture, @"     {0}", e.PropertyName);
                    break;
            }

            Console.WriteLine(@"Controller Property Changed:{0}{1}", Environment.NewLine, output);
            Console.WriteLine();
        }

        /// <summary>
        /// The energy calibration has finished
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">CalibrationFinishedEventArgs - may contain a local exception raised by Calibration process</param>
        private void OnEnergyCalibrationFinished(object sender, CalibrationFinishedEventArgs e)
        {
            string output = string.Empty;
            if (e.Error != null)
            {
                output = string.Format(CultureInfo.InvariantCulture, @":{0}     Error Occurred: - {1}", Environment.NewLine, e.Error);
            }

            Console.WriteLine(@"Controller EnergyCalibrationFinished{0}", output);
            Console.WriteLine();
        }

        /// <summary>
        /// Called when the energy calibration acquisition has started
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">The event args</param>
        private void OnEnergyCalibrationAcquisitionStarted(object sender, EventArgs e)
        {
            Console.WriteLine(@"Controller EnergyCalibrationAcquisitionStarted:");
            Console.WriteLine(@"     CurrentCalibrationSpectrum Id - {0}", ((IQuantCalibrationController)sender).CurrentCalibrationSpectrum.Id);
            Console.WriteLine();
        }

        /// <summary>
        /// The energy calibration acquisition has finished
        /// </summary>
        /// <param name="sender">The QuantCalibrationController</param>
        /// <param name="e">The CalibrationAcquisitionFinishedEventArgs, which contain details of how the measurement finished</param>
        private void OnEnergyCalibrationAcquisitionFinished(object sender, CalibrationAcquisitionFinishedEventArgs e)
        {
            Console.WriteLine(@"Controller EnergyCalibrationAcquisitionFinished:");
            Console.WriteLine();

            if (e.Success)
            {
                Console.WriteLine(@"Perform Energy calibration using the acquired spectra (Y/N) ?");
                if (Console.ReadKey().Key == ConsoleKey.N)
                {
                    e.Cancel = true;
                }
            }
            else
            {
                Console.WriteLine(@"Energy calibration acquisition did not complete successfully.");

                // Acquisition was stopped by the user, or an error occured
                if (e.Error != null)
                {
                    Console.WriteLine(@"Error occurred: {1}", e.Error.Message);
                }
            }

            Console.WriteLine();
        }
    }
}
See Also

Reference

OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationSettings Properties

The IQuantCalibrationSettings type exposes the following members.

Properties
 | Name | Description
Public property | CalibrationElementAtomicNumber | Gets or sets the element used for energy calibration or beam measurement.
Public property | CalibrationMode | Gets or sets the calibration mode.
Public property | Capabilities | Gets the capabilities for quant calibration.
Public property | EdCapabilities | Gets the Ed Capabilities
Public property | EdSettings | Gets the Ed Settings
Public property | TotalCountsInSpectrum | Gets or sets the count limit at which to terminate the Beam Measurement. Not used for Energy Calibration.
Top
See Also

Reference

IQuantCalibrationSettings Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationSettings.CalibrationElementAtomicNumber Property

Gets or sets the element used for energy calibration or beam measurement.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int CalibrationElementAtomicNumber { get; set; }
Property CalibrationElementAtomicNumber As Integer
    Get
    Set
property int CalibrationElementAtomicNumber {
    int get ();
    void set (int value);
}
abstract CalibrationElementAtomicNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

IQuantCalibrationSettings Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationSettings.CalibrationMode Property

Gets or sets the calibration mode.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
QuantCalibrationMode CalibrationMode { get; set; }
Property CalibrationMode As QuantCalibrationMode
    Get
    Set
property QuantCalibrationMode CalibrationMode {
    QuantCalibrationMode get ();
    void set (QuantCalibrationMode value);
}
abstract CalibrationMode : QuantCalibrationMode with get, set

Property Value

Type: QuantCalibrationMode
See Also

Reference

IQuantCalibrationSettings Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationSettings.Capabilities Property

Gets the capabilities for quant calibration.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IQuantCalibrationCapabilities Capabilities { get; }
ReadOnly Property Capabilities As IQuantCalibrationCapabilities
    Get
property IQuantCalibrationCapabilities^ Capabilities {
    IQuantCalibrationCapabilities^ get ();
}
abstract Capabilities : IQuantCalibrationCapabilities with get

Property Value

Type: IQuantCalibrationCapabilities
See Also

Reference

IQuantCalibrationSettings Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationSettings.EdCapabilities Property

Gets the Ed Capabilities

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdCapabilities EdCapabilities { get; }
ReadOnly Property EdCapabilities As IEdCapabilities
    Get
property IEdCapabilities^ EdCapabilities {
    IEdCapabilities^ get ();
}
abstract EdCapabilities : IEdCapabilities with get

Property Value

Type: IEdCapabilities
See Also

Reference

IQuantCalibrationSettings Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationSettings.EdSettings Property

Gets the Ed Settings

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSettings EdSettings { get; }
ReadOnly Property EdSettings As IEdSettings
    Get
property IEdSettings^ EdSettings {
    IEdSettings^ get ();
}
abstract EdSettings : IEdSettings with get

Property Value

Type: IEdSettings
See Also

Reference

IQuantCalibrationSettings Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationSettings.TotalCountsInSpectrum Property

Gets or sets the count limit at which to terminate the Beam Measurement. Not used for Energy Calibration.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int TotalCountsInSpectrum { get; set; }
Property TotalCountsInSpectrum As Integer
    Get
    Set
property int TotalCountsInSpectrum {
    int get ();
    void set (int value);
}
abstract TotalCountsInSpectrum : int with get, set

Property Value

Type: Int32
See Also

Reference

IQuantCalibrationSettings Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationSettings Methods

The IQuantCalibrationSettings type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Validates the settings.
Top
See Also

Reference

IQuantCalibrationSettings Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationSettings.Validate Method

Validates the settings.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IValidationResults Validate()
Function Validate As IValidationResults
IValidationResults^ Validate()
abstract Validate : unit -> IValidationResults

Return Value

Type: IValidationResults
The validation results
See Also

Reference

IQuantCalibrationSettings Interface
OINA.Extender.Acquisition.Quant Namespace


IQuantCalibrationSettings Events

The IQuantCalibrationSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IQuantCalibrationSettings Interface
OINA.Extender.Acquisition.Quant Namespace


QuantCalibrationException Class

A Class that defines an exception created when an error occurs during beam measurement, or energy calibration.
Inheritance Hierarchy
SystemObject
SystemException
OINA.Extender.Acquisition.QuantQuantCalibrationException

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class QuantCalibrationException : Exception
<SerializableAttribute>
Public Class QuantCalibrationException
    Inherits Exception
[SerializableAttribute]
public ref class QuantCalibrationException : public Exception
[<SerializableAttribute>]
type QuantCalibrationException =
    class
        inherit Exception
    end

The QuantCalibrationException type exposes the following members.

Constructors
 | Name | Description
Public method | QuantCalibrationException | Initializes a new instance of the QuantCalibrationException class
Public method | QuantCalibrationException(String) | Initializes a new instance of the QuantCalibrationException class
Protected method | QuantCalibrationException(SerializationInfo, StreamingContext) | Initializes a new instance of the QuantCalibrationException class
Public method | QuantCalibrationException(String, Exception) | Initializes a new instance of the QuantCalibrationException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OINA.Extender.Acquisition.Quant Namespace


QuantCalibrationException Constructor

Overload List
 | Name | Description
Public method | QuantCalibrationException | Initializes a new instance of the QuantCalibrationException class
Public method | QuantCalibrationException(String) | Initializes a new instance of the QuantCalibrationException class
Protected method | QuantCalibrationException(SerializationInfo, StreamingContext) | Initializes a new instance of the QuantCalibrationException class
Public method | QuantCalibrationException(String, Exception) | Initializes a new instance of the QuantCalibrationException class
Top
See Also

Reference

QuantCalibrationException Class
OINA.Extender.Acquisition.Quant Namespace


QuantCalibrationException Constructor

Initializes a new instance of the QuantCalibrationException class

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public QuantCalibrationException()
Public Sub New
public:
QuantCalibrationException()
new : unit -> QuantCalibrationException
See Also

Reference

QuantCalibrationException Class
QuantCalibrationException Overload
OINA.Extender.Acquisition.Quant Namespace


QuantCalibrationException Constructor (String)

Initializes a new instance of the QuantCalibrationException class

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public QuantCalibrationException(
    string message
)
Public Sub New (
    message As String
)
public:
QuantCalibrationException(
    String^ message
)
new :
        message : string -> QuantCalibrationException

Parameters

message
Type: SystemString
error message
See Also

Reference

QuantCalibrationException Class
QuantCalibrationException Overload
OINA.Extender.Acquisition.Quant Namespace


QuantCalibrationException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the QuantCalibrationException class

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
protected QuantCalibrationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
QuantCalibrationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> QuantCalibrationException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
serialization information
context
Type: System.Runtime.SerializationStreamingContext
streaming context
See Also

Reference

QuantCalibrationException Class
QuantCalibrationException Overload
OINA.Extender.Acquisition.Quant Namespace


QuantCalibrationException Constructor (String, Exception)

Initializes a new instance of the QuantCalibrationException class

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public QuantCalibrationException(
    string message,
    Exception inner
)
Public Sub New (
    message As String,
    inner As Exception
)
public:
QuantCalibrationException(
    String^ message,
    Exception^ inner
)
new :
        message : string *
        inner : Exception -> QuantCalibrationException

Parameters

message
Type: SystemString
error message
inner
Type: SystemException
inner exception
See Also

Reference

QuantCalibrationException Class
QuantCalibrationException Overload
OINA.Extender.Acquisition.Quant Namespace


QuantCalibrationException Properties

The QuantCalibrationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

QuantCalibrationException Class
OINA.Extender.Acquisition.Quant Namespace


QuantCalibrationException Methods

The QuantCalibrationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

QuantCalibrationException Class
OINA.Extender.Acquisition.Quant Namespace


QuantCalibrationException Events

The QuantCalibrationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

QuantCalibrationException Class
OINA.Extender.Acquisition.Quant Namespace


QuantCalibrationMode Enumeration

The type of calibration to perform.

Namespace: OINA.Extender.Acquisition.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum QuantCalibrationMode
Public Enumeration QuantCalibrationMode
public enum class QuantCalibrationMode
type QuantCalibrationMode
Members
Member name | Value | Description
Unknown | 0 | Has not been set.
EnergyCalibration | 1 | Performs an Energy Calibration.
BeamMeasurement | 2 | Performs a Beam Measurement.
See Also

Reference

OINA.Extender.Acquisition.Quant Namespace


OINA.Extender.Acquisition.XSync Namespace

Defines all Classes and Interfaces used to control the acquisition of Ed data using External Scan Synchronisation.

Classes
 | Class | Description
Public class | FrameCompletedEventArgs | Class that provides information about a completed frame
Public class | PauseScanEventArgs | Class that indicates that the scan should be paused
Public class | ResumeScanEventArgs | Class that indicates that the scan should be resumed
Interfaces
 | Interface | Description
Public interface | ICasLineSyncCapabilities | Interface that provides capabilities for CAS line sync
Public interface | ICasLineSyncSettings | Interface that provides settings for CAS line sync
Public interface | IXSyncAcquisitionRegion | An Interface that defines an acquisition region when using external scan control.
Public interface | IXSyncCapabilities | An Interface that defines capabilities for acquisition using external scan synchronization.
Public interface | IXSyncEdMapAcquisitionController | An Interface that defines Ed map acquisition using external scan synchronization.
Public interface | IXSyncEdMapSettings | An Interface that defines settings for Ed map acquisition using external scan synchronization.
Public interface | IXSyncSettings | An Interface that defines the settings for acquisition using external scan synchronization.
Enumerations
 | Enumeration | Description
Public enumeration | XSyncMode | The external scan synchronization mode.


FrameCompletedEventArgs Class

Class that provides information about a completed frame
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.Extender.Acquisition.XSyncFrameCompletedEventArgs

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class FrameCompletedEventArgs : EventArgs
Public Class FrameCompletedEventArgs
    Inherits EventArgs
public ref class FrameCompletedEventArgs : public EventArgs
type FrameCompletedEventArgs =
    class
        inherit EventArgs
    end

The FrameCompletedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FrameCompletedEventArgs | Initializes a new instance of the FrameCompletedEventArgs class.
Top
Properties
 | Name | Description
Public property | FrameNumber | Gets the completed frame number
Public property | Id | Gets the Id of the acquiring object
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Acquisition.XSync Namespace


FrameCompletedEventArgs Constructor

Initializes a new instance of the FrameCompletedEventArgs class.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public FrameCompletedEventArgs(
    Guid id,
    int frameNumber
)
Public Sub New (
    id As Guid,
    frameNumber As Integer
)
public:
FrameCompletedEventArgs(
    Guid id,
    int frameNumber
)
new :
        id : Guid *
        frameNumber : int -> FrameCompletedEventArgs

Parameters

id
Type: SystemGuid
The id of the acquiring object
frameNumber
Type: SystemInt32
The completed frame number
See Also

Reference

FrameCompletedEventArgs Class
OINA.Extender.Acquisition.XSync Namespace


FrameCompletedEventArgs Properties

The FrameCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FrameNumber | Gets the completed frame number
Public property | Id | Gets the Id of the acquiring object
Top
See Also

Reference

FrameCompletedEventArgs Class
OINA.Extender.Acquisition.XSync Namespace


FrameCompletedEventArgs.FrameNumber Property

Gets the completed frame number

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public int FrameNumber { get; }
Public ReadOnly Property FrameNumber As Integer
    Get
public:
property int FrameNumber {
    int get ();
}
member FrameNumber : int with get

Property Value

Type: Int32
See Also

Reference

FrameCompletedEventArgs Class
OINA.Extender.Acquisition.XSync Namespace


FrameCompletedEventArgs.Id Property

Gets the Id of the acquiring object

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}
member Id : Guid with get

Property Value

Type: Guid
See Also

Reference

FrameCompletedEventArgs Class
OINA.Extender.Acquisition.XSync Namespace


FrameCompletedEventArgs Methods

The FrameCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FrameCompletedEventArgs Class
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncCapabilities Interface

Interface that provides capabilities for CAS line sync

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface ICasLineSyncCapabilities : INotifyPropertyChanged
Public Interface ICasLineSyncCapabilities
    Inherits INotifyPropertyChanged
public interface class ICasLineSyncCapabilities : INotifyPropertyChanged
type ICasLineSyncCapabilities =
    interface
        interface INotifyPropertyChanged
    end

The ICasLineSyncCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | MaximumBinFactorY | Gets the maximum binning factor used to convert the number of lines scanned to data pixels
Public property | MaximumDwellTimeMicroSeconds | Gets the maximum dwell time per pixel in microseconds.
Public property | MaximumLineRunUpMicroSeconds | Gets the maximum time to wait before the first pixel in microseconds
Public property | MaximumLinesPerFrame | Gets the maximum number of lines scanned per frame
Public property | MinimumBinFactorY | Gets the minimum binning factor used to convert the number of lines scanned to data pixels
Public property | MinimumDwellTimeMicroSeconds | Gets the minimum dwell time per pixel in microseconds.
Public property | MinimumLineRunUpMicroSeconds | Gets the minimum time to wait before the first pixel in microseconds
Public property | MinimumLinesPerFrame | Gets the minimum number of lines scanned per frame
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncCapabilities Properties

The ICasLineSyncCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | MaximumBinFactorY | Gets the maximum binning factor used to convert the number of lines scanned to data pixels
Public property | MaximumDwellTimeMicroSeconds | Gets the maximum dwell time per pixel in microseconds.
Public property | MaximumLineRunUpMicroSeconds | Gets the maximum time to wait before the first pixel in microseconds
Public property | MaximumLinesPerFrame | Gets the maximum number of lines scanned per frame
Public property | MinimumBinFactorY | Gets the minimum binning factor used to convert the number of lines scanned to data pixels
Public property | MinimumDwellTimeMicroSeconds | Gets the minimum dwell time per pixel in microseconds.
Public property | MinimumLineRunUpMicroSeconds | Gets the minimum time to wait before the first pixel in microseconds
Public property | MinimumLinesPerFrame | Gets the minimum number of lines scanned per frame
Top
See Also

Reference

ICasLineSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncCapabilities.MaximumBinFactorY Property

Gets the maximum binning factor used to convert the number of lines scanned to data pixels

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MaximumBinFactorY { get; }
ReadOnly Property MaximumBinFactorY As Integer
    Get
property int MaximumBinFactorY {
    int get ();
}
abstract MaximumBinFactorY : int with get

Property Value

Type: Int32
See Also

Reference

ICasLineSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncCapabilities.MaximumDwellTimeMicroSeconds Property

Gets the maximum dwell time per pixel in microseconds.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MaximumDwellTimeMicroSeconds { get; }
ReadOnly Property MaximumDwellTimeMicroSeconds As Double
    Get
property double MaximumDwellTimeMicroSeconds {
    double get ();
}
abstract MaximumDwellTimeMicroSeconds : float with get

Property Value

Type: Double
See Also

Reference

ICasLineSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncCapabilities.MaximumLineRunUpMicroSeconds Property

Gets the maximum time to wait before the first pixel in microseconds

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MaximumLineRunUpMicroSeconds { get; }
ReadOnly Property MaximumLineRunUpMicroSeconds As Double
    Get
property double MaximumLineRunUpMicroSeconds {
    double get ();
}
abstract MaximumLineRunUpMicroSeconds : float with get

Property Value

Type: Double
See Also

Reference

ICasLineSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncCapabilities.MaximumLinesPerFrame Property

Gets the maximum number of lines scanned per frame

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MaximumLinesPerFrame { get; }
ReadOnly Property MaximumLinesPerFrame As Integer
    Get
property int MaximumLinesPerFrame {
    int get ();
}
abstract MaximumLinesPerFrame : int with get

Property Value

Type: Int32
See Also

Reference

ICasLineSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncCapabilities.MinimumBinFactorY Property

Gets the minimum binning factor used to convert the number of lines scanned to data pixels

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MinimumBinFactorY { get; }
ReadOnly Property MinimumBinFactorY As Integer
    Get
property int MinimumBinFactorY {
    int get ();
}
abstract MinimumBinFactorY : int with get

Property Value

Type: Int32
See Also

Reference

ICasLineSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncCapabilities.MinimumDwellTimeMicroSeconds Property

Gets the minimum dwell time per pixel in microseconds.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MinimumDwellTimeMicroSeconds { get; }
ReadOnly Property MinimumDwellTimeMicroSeconds As Double
    Get
property double MinimumDwellTimeMicroSeconds {
    double get ();
}
abstract MinimumDwellTimeMicroSeconds : float with get

Property Value

Type: Double
See Also

Reference

ICasLineSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncCapabilities.MinimumLineRunUpMicroSeconds Property

Gets the minimum time to wait before the first pixel in microseconds

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MinimumLineRunUpMicroSeconds { get; }
ReadOnly Property MinimumLineRunUpMicroSeconds As Double
    Get
property double MinimumLineRunUpMicroSeconds {
    double get ();
}
abstract MinimumLineRunUpMicroSeconds : float with get

Property Value

Type: Double
See Also

Reference

ICasLineSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncCapabilities.MinimumLinesPerFrame Property

Gets the minimum number of lines scanned per frame

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MinimumLinesPerFrame { get; }
ReadOnly Property MinimumLinesPerFrame As Integer
    Get
property int MinimumLinesPerFrame {
    int get ();
}
abstract MinimumLinesPerFrame : int with get

Property Value

Type: Int32
See Also

Reference

ICasLineSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncCapabilities Events

The ICasLineSyncCapabilities type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ICasLineSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncSettings Interface

Interface that provides settings for CAS line sync

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface ICasLineSyncSettings : INotifyPropertyChanged
Public Interface ICasLineSyncSettings
    Inherits INotifyPropertyChanged
public interface class ICasLineSyncSettings : INotifyPropertyChanged
type ICasLineSyncSettings =
    interface
        interface INotifyPropertyChanged
    end

The ICasLineSyncSettings type exposes the following members.

Properties
 | Name | Description
Public property | BinFactorY | Gets or sets the binning factor used to convert the number of lines scanned to data pixels
Public property | DwellTimeMicroSeconds | Gets or sets the dwell time per pixel in microseconds.
Public property | LineRunUpMicroSeconds | Gets or sets the time to wait before the first pixel in microseconds
Public property | LinesPerFrame | Gets or sets the number of lines scanned per frame
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncSettings Properties

The ICasLineSyncSettings type exposes the following members.

Properties
 | Name | Description
Public property | BinFactorY | Gets or sets the binning factor used to convert the number of lines scanned to data pixels
Public property | DwellTimeMicroSeconds | Gets or sets the dwell time per pixel in microseconds.
Public property | LineRunUpMicroSeconds | Gets or sets the time to wait before the first pixel in microseconds
Public property | LinesPerFrame | Gets or sets the number of lines scanned per frame
Top
See Also

Reference

ICasLineSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncSettings.BinFactorY Property

Gets or sets the binning factor used to convert the number of lines scanned to data pixels

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int BinFactorY { get; set; }
Property BinFactorY As Integer
    Get
    Set
property int BinFactorY {
    int get ();
    void set (int value);
}
abstract BinFactorY : int with get, set

Property Value

Type: Int32
See Also

Reference

ICasLineSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncSettings.DwellTimeMicroSeconds Property

Gets or sets the dwell time per pixel in microseconds.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double DwellTimeMicroSeconds { get; set; }
Property DwellTimeMicroSeconds As Double
    Get
    Set
property double DwellTimeMicroSeconds {
    double get ();
    void set (double value);
}
abstract DwellTimeMicroSeconds : float with get, set

Property Value

Type: Double
Remarks
In 100ns steps
See Also

Reference

ICasLineSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncSettings.LineRunUpMicroSeconds Property

Gets or sets the time to wait before the first pixel in microseconds

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double LineRunUpMicroSeconds { get; set; }
Property LineRunUpMicroSeconds As Double
    Get
    Set
property double LineRunUpMicroSeconds {
    double get ();
    void set (double value);
}
abstract LineRunUpMicroSeconds : float with get, set

Property Value

Type: Double
Remarks
In 25ns steps
See Also

Reference

ICasLineSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncSettings.LinesPerFrame Property

Gets or sets the number of lines scanned per frame

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int LinesPerFrame { get; set; }
Property LinesPerFrame As Integer
    Get
    Set
property int LinesPerFrame {
    int get ();
    void set (int value);
}
abstract LinesPerFrame : int with get, set

Property Value

Type: Int32
See Also

Reference

ICasLineSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


ICasLineSyncSettings Events

The ICasLineSyncSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ICasLineSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncAcquisitionRegion Interface

An Interface that defines an acquisition region when using external scan control.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IXSyncAcquisitionRegion : INotifyPropertyChanged
Public Interface IXSyncAcquisitionRegion
    Inherits INotifyPropertyChanged
public interface class IXSyncAcquisitionRegion : INotifyPropertyChanged
type IXSyncAcquisitionRegion =
    interface
        interface INotifyPropertyChanged
    end

The IXSyncAcquisitionRegion type exposes the following members.

Properties
 | Name | Description
Public property | CurrentAcquisitionRegion | Gets the current acquisition region. This is updated when a create region method is called.
Public property | PixelSize | Gets the size of a pixel (= 1 / resolution) This will get updated when a create region method is called
Top
Methods
 | Name | Description
Public method | CreateChordListRegion | Creates a chord list region.
Public method | CreateRectangleRegion | Creates a rectangle region
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition.XSync Namespace


IXSyncAcquisitionRegion Properties

The IXSyncAcquisitionRegion type exposes the following members.

Properties
 | Name | Description
Public property | CurrentAcquisitionRegion | Gets the current acquisition region. This is updated when a create region method is called.
Public property | PixelSize | Gets the size of a pixel (= 1 / resolution) This will get updated when a create region method is called
Top
See Also

Reference

IXSyncAcquisitionRegion Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncAcquisitionRegion.CurrentAcquisitionRegion Property

Gets the current acquisition region. This is updated when a create region method is called.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IRegion CurrentAcquisitionRegion { get; }
ReadOnly Property CurrentAcquisitionRegion As IRegion
    Get
property IRegion^ CurrentAcquisitionRegion {
    IRegion^ get ();
}
abstract CurrentAcquisitionRegion : IRegion with get

Property Value

Type: IRegion
See Also

Reference

IXSyncAcquisitionRegion Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncAcquisitionRegion.PixelSize Property

Gets the size of a pixel (= 1 / resolution) This will get updated when a create region method is called

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double PixelSize { get; }
ReadOnly Property PixelSize As Double
    Get
property double PixelSize {
    double get ();
}
abstract PixelSize : float with get

Property Value

Type: Double
See Also

Reference

IXSyncAcquisitionRegion Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncAcquisitionRegion Methods

The IXSyncAcquisitionRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateChordListRegion | Creates a chord list region.
Public method | CreateRectangleRegion | Creates a rectangle region
Top
See Also

Reference

IXSyncAcquisitionRegion Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncAcquisitionRegion.CreateChordListRegion Method

Creates a chord list region.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IChordListRegion CreateChordListRegion(
    ChordList chordList
)
Function CreateChordListRegion (
    chordList As ChordList
) As IChordListRegion
IChordListRegion^ CreateChordListRegion(
    ChordList^ chordList
)
abstract CreateChordListRegion :
        chordList : ChordList -> IChordListRegion

Parameters

chordList
Type: OINA.Extender.DataChordList
The chord list in pixel co-ordinates

Return Value

Type: IChordListRegion
The chord list region
See Also

Reference

IXSyncAcquisitionRegion Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncAcquisitionRegion.CreateRectangleRegion Method

Creates a rectangle region

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IRectangleRegion CreateRectangleRegion(
    Rect rect,
    double pixelSize
)
Function CreateRectangleRegion (
    rect As Rect,
    pixelSize As Double
) As IRectangleRegion
IRectangleRegion^ CreateRectangleRegion(
    Rect rect,
    double pixelSize
)
abstract CreateRectangleRegion :
        rect : Rect *
        pixelSize : float -> IRectangleRegion

Parameters

rect
Type: System.WindowsRect
The rectangle in normalised co-ordinates
pixelSize
Type: SystemDouble
The pixel size (= 1 / resolution)

Return Value

Type: IRectangleRegion
The rectangle region
See Also

Reference

IXSyncAcquisitionRegion Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncAcquisitionRegion Events

The IXSyncAcquisitionRegion type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IXSyncAcquisitionRegion Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities Interface

An Interface that defines capabilities for acquisition using external scan synchronization.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IXSyncCapabilities : INotifyPropertyChanged
Public Interface IXSyncCapabilities
    Inherits INotifyPropertyChanged
public interface class IXSyncCapabilities : INotifyPropertyChanged
type IXSyncCapabilities =
    interface
        interface INotifyPropertyChanged
    end

The IXSyncCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AllowedSynchronizationModes | Gets the allowed synchronization modes.
Public property | HasHardwareConnection | Gets a value indicating whether the hardware is connected.
Public property | LineSync | Gets the capabilities for Cas Line Sync mode
Public property | MaximumCalibratedFieldWidthmm | Gets the maximum calibrated field width in mm at 1x magnification
Public property | MaximumNumberOfFrames | Gets the maximum number of frames.
Public property | MaximumNumberOfPixels | Gets the maximum number of pixels.
Public property | MaximumPixelSize | Gets the maximum pixel size
Public property | MinimumCalibratedFieldWidthmm | Gets the minimum calibrated field width in mm at 1x magnification
Public property | MinimumNumberOfFrames | Gets the minimum number of frames.
Public property | MinimumNumberOfPixels | Gets the minimum number of pixels.
Public property | MinimumPixelSize | Gets the minimum pixel size
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities Properties

The IXSyncCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AllowedSynchronizationModes | Gets the allowed synchronization modes.
Public property | HasHardwareConnection | Gets a value indicating whether the hardware is connected.
Public property | LineSync | Gets the capabilities for Cas Line Sync mode
Public property | MaximumCalibratedFieldWidthmm | Gets the maximum calibrated field width in mm at 1x magnification
Public property | MaximumNumberOfFrames | Gets the maximum number of frames.
Public property | MaximumNumberOfPixels | Gets the maximum number of pixels.
Public property | MaximumPixelSize | Gets the maximum pixel size
Public property | MinimumCalibratedFieldWidthmm | Gets the minimum calibrated field width in mm at 1x magnification
Public property | MinimumNumberOfFrames | Gets the minimum number of frames.
Public property | MinimumNumberOfPixels | Gets the minimum number of pixels.
Public property | MinimumPixelSize | Gets the minimum pixel size
Top
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities.AllowedSynchronizationModes Property

Gets the allowed synchronization modes.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ReadOnlyCollection<XSyncMode> AllowedSynchronizationModes { get; }
ReadOnly Property AllowedSynchronizationModes As ReadOnlyCollection(Of XSyncMode)
    Get
property ReadOnlyCollection<XSyncMode>^ AllowedSynchronizationModes {
    ReadOnlyCollection<XSyncMode>^ get ();
}
abstract AllowedSynchronizationModes : ReadOnlyCollection<XSyncMode> with get

Property Value

Type: ReadOnlyCollection XSyncMode
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities.HasHardwareConnection Property

Gets a value indicating whether the hardware is connected.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasHardwareConnection { get; }
ReadOnly Property HasHardwareConnection As Boolean
    Get
property bool HasHardwareConnection {
    bool get ();
}
abstract HasHardwareConnection : bool with get

Property Value

Type: Boolean
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities.LineSync Property

Gets the capabilities for Cas Line Sync mode

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ICasLineSyncCapabilities LineSync { get; }
ReadOnly Property LineSync As ICasLineSyncCapabilities
    Get
property ICasLineSyncCapabilities^ LineSync {
    ICasLineSyncCapabilities^ get ();
}
abstract LineSync : ICasLineSyncCapabilities with get

Property Value

Type: ICasLineSyncCapabilities
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities.MaximumCalibratedFieldWidthmm Property

Gets the maximum calibrated field width in mm at 1x magnification

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MaximumCalibratedFieldWidthmm { get; }
ReadOnly Property MaximumCalibratedFieldWidthmm As Double
    Get
property double MaximumCalibratedFieldWidthmm {
    double get ();
}
abstract MaximumCalibratedFieldWidthmm : float with get

Property Value

Type: Double
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities.MaximumNumberOfFrames Property

Gets the maximum number of frames.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MaximumNumberOfFrames { get; }
ReadOnly Property MaximumNumberOfFrames As Integer
    Get
property int MaximumNumberOfFrames {
    int get ();
}
abstract MaximumNumberOfFrames : int with get

Property Value

Type: Int32
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities.MaximumNumberOfPixels Property

Gets the maximum number of pixels.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MaximumNumberOfPixels { get; }
ReadOnly Property MaximumNumberOfPixels As Integer
    Get
property int MaximumNumberOfPixels {
    int get ();
}
abstract MaximumNumberOfPixels : int with get

Property Value

Type: Int32
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities.MaximumPixelSize Property

Gets the maximum pixel size

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MaximumPixelSize { get; }
ReadOnly Property MaximumPixelSize As Double
    Get
property double MaximumPixelSize {
    double get ();
}
abstract MaximumPixelSize : float with get

Property Value

Type: Double
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities.MinimumCalibratedFieldWidthmm Property

Gets the minimum calibrated field width in mm at 1x magnification

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MinimumCalibratedFieldWidthmm { get; }
ReadOnly Property MinimumCalibratedFieldWidthmm As Double
    Get
property double MinimumCalibratedFieldWidthmm {
    double get ();
}
abstract MinimumCalibratedFieldWidthmm : float with get

Property Value

Type: Double
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities.MinimumNumberOfFrames Property

Gets the minimum number of frames.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MinimumNumberOfFrames { get; }
ReadOnly Property MinimumNumberOfFrames As Integer
    Get
property int MinimumNumberOfFrames {
    int get ();
}
abstract MinimumNumberOfFrames : int with get

Property Value

Type: Int32
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities.MinimumNumberOfPixels Property

Gets the minimum number of pixels.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MinimumNumberOfPixels { get; }
ReadOnly Property MinimumNumberOfPixels As Integer
    Get
property int MinimumNumberOfPixels {
    int get ();
}
abstract MinimumNumberOfPixels : int with get

Property Value

Type: Int32
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities.MinimumPixelSize Property

Gets the minimum pixel size

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MinimumPixelSize { get; }
ReadOnly Property MinimumPixelSize As Double
    Get
property double MinimumPixelSize {
    double get ();
}
abstract MinimumPixelSize : float with get

Property Value

Type: Double
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncCapabilities Events

The IXSyncCapabilities type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IXSyncCapabilities Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController Interface

An Interface that defines Ed map acquisition using external scan synchronization.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IXSyncEdMapAcquisitionController
Public Interface IXSyncEdMapAcquisitionController
public interface class IXSyncEdMapAcquisitionController
type IXSyncEdMapAcquisitionController =  interface end

The IXSyncEdMapAcquisitionController type exposes the following members.

Properties
 | Name | Description
Public property | CurrentData | Gets the current map data
Public property | IsAcquiring | Gets a value indicating whether there is an acquisition in progress.
Top
Methods
 | Name | Description
Public method | Delete | Deletes the ed map
Public method | IsEdHardwareReady | Gets a value indicating whether the Ed hardware is ready or not.
Public method | NotifyPauseResume | Notifies that the external scan hardware is paused or resumed
Public method | StartAcquisition | Start acquisition using external scan synchronization.
Public method | StopAcquisition | Stop acquisition immediately.
Top
Events
 | Name | Description
Public event | ExperimentFinished | Occurs when acquisition has finished.
Public event | ExperimentStarted | Occurs when acquisition has started.
Public event | ExperimentStarting | Occurs before acquisition starts.
Public event | FrameCompleted | Occurs when a map frame has been acquired.
Public event | PauseRequested | Occurs when the scan needs to be paused.
Public event | ResumeRequested | Occurs when the scan needs to be resumed.
Top
See Also

Reference

OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController Properties

The IXSyncEdMapAcquisitionController type exposes the following members.

Properties
 | Name | Description
Public property | CurrentData | Gets the current map data
Public property | IsAcquiring | Gets a value indicating whether there is an acquisition in progress.
Top
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.CurrentData Property

Gets the current map data

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdMapAcquisitionData CurrentData { get; }
ReadOnly Property CurrentData As IEdMapAcquisitionData
    Get
property IEdMapAcquisitionData^ CurrentData {
    IEdMapAcquisitionData^ get ();
}
abstract CurrentData : IEdMapAcquisitionData with get

Property Value

Type: IEdMapAcquisitionData
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.IsAcquiring Property

Gets a value indicating whether there is an acquisition in progress.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsAcquiring { get; }
ReadOnly Property IsAcquiring As Boolean
    Get
property bool IsAcquiring {
    bool get ();
}
abstract IsAcquiring : bool with get

Property Value

Type: Boolean
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController Methods

The IXSyncEdMapAcquisitionController type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Deletes the ed map
Public method | IsEdHardwareReady | Gets a value indicating whether the Ed hardware is ready or not.
Public method | NotifyPauseResume | Notifies that the external scan hardware is paused or resumed
Public method | StartAcquisition | Start acquisition using external scan synchronization.
Public method | StopAcquisition | Stop acquisition immediately.
Top
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.Delete Method

Deletes the ed map

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void Delete(
    IEdMap edMap
)
Sub Delete (
    edMap As IEdMap
)
void Delete(
    IEdMap^ edMap
)
abstract Delete :
        edMap : IEdMap -> unit

Parameters

edMap
Type: OINA.Extender.Data.EdIEdMap
The ed map
Remarks
Maps should be deleted when the data is no longer required
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.IsEdHardwareReady Method

Gets a value indicating whether the Ed hardware is ready or not.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsEdHardwareReady(
    IXSyncEdMapSettings settings
)
Function IsEdHardwareReady (
    settings As IXSyncEdMapSettings
) As Boolean
bool IsEdHardwareReady(
    IXSyncEdMapSettings^ settings
)
abstract IsEdHardwareReady :
        settings : IXSyncEdMapSettings -> bool

Parameters

settings
Type: OINA.Extender.Acquisition.XSyncIXSyncEdMapSettings
The XSync Ed Map settings

Return Value

Type: Boolean
true if the hardware is ready
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.NotifyPauseResume Method

Notifies that the external scan hardware is paused or resumed

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void NotifyPauseResume(
    bool isPaused
)
Sub NotifyPauseResume (
    isPaused As Boolean
)
void NotifyPauseResume(
    bool isPaused
)
abstract NotifyPauseResume :
        isPaused : bool -> unit

Parameters

isPaused
Type: SystemBoolean
Whether the scan is paused or resumed
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.StartAcquisition Method

Start acquisition using external scan synchronization.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdMapAcquisitionData StartAcquisition(
    IXSyncEdMapSettings settings
)
Function StartAcquisition (
    settings As IXSyncEdMapSettings
) As IEdMapAcquisitionData
IEdMapAcquisitionData^ StartAcquisition(
    IXSyncEdMapSettings^ settings
)
abstract StartAcquisition :
        settings : IXSyncEdMapSettings -> IEdMapAcquisitionData

Parameters

settings
Type: OINA.Extender.Acquisition.XSyncIXSyncEdMapSettings
The settings

Return Value

Type: IEdMapAcquisitionData
The Ed map data
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.StopAcquisition Method

Stop acquisition immediately.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void StopAcquisition()
Sub StopAcquisition
void StopAcquisition()
abstract StopAcquisition : unit -> unit
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController Events

The IXSyncEdMapAcquisitionController type exposes the following members.

Events
 | Name | Description
Public event | ExperimentFinished | Occurs when acquisition has finished.
Public event | ExperimentStarted | Occurs when acquisition has started.
Public event | ExperimentStarting | Occurs before acquisition starts.
Public event | FrameCompleted | Occurs when a map frame has been acquired.
Public event | PauseRequested | Occurs when the scan needs to be paused.
Public event | ResumeRequested | Occurs when the scan needs to be resumed.
Top
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.ExperimentFinished Event

Occurs when acquisition has finished.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AcquisitionFinishedEventArgs<IEdMapAcquisitionData>> ExperimentFinished
Event ExperimentFinished As EventHandler(Of AcquisitionFinishedEventArgs(Of IEdMapAcquisitionData))
 event EventHandler<AcquisitionFinishedEventArgs<IEdMapAcquisitionData^>^>^ ExperimentFinished {
    void add (EventHandler<AcquisitionFinishedEventArgs<IEdMapAcquisitionData^>^>^ value);
    void remove (EventHandler<AcquisitionFinishedEventArgs<IEdMapAcquisitionData^>^>^ value);
}
abstract ExperimentFinished : IEvent<EventHandler<AcquisitionFinishedEventArgs<IEdMapAcquisitionData>>,
    AcquisitionFinishedEventArgs<IEdMapAcquisitionData>>

Value

Type: SystemEventHandler AcquisitionFinishedEventArgs IEdMapAcquisitionData
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.ExperimentStarted Event

Occurs when acquisition has started.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AcquisitionStartedEventArgs<IEdMapAcquisitionData>> ExperimentStarted
Event ExperimentStarted As EventHandler(Of AcquisitionStartedEventArgs(Of IEdMapAcquisitionData))
 event EventHandler<AcquisitionStartedEventArgs<IEdMapAcquisitionData^>^>^ ExperimentStarted {
    void add (EventHandler<AcquisitionStartedEventArgs<IEdMapAcquisitionData^>^>^ value);
    void remove (EventHandler<AcquisitionStartedEventArgs<IEdMapAcquisitionData^>^>^ value);
}
abstract ExperimentStarted : IEvent<EventHandler<AcquisitionStartedEventArgs<IEdMapAcquisitionData>>,
    AcquisitionStartedEventArgs<IEdMapAcquisitionData>>

Value

Type: SystemEventHandler AcquisitionStartedEventArgs IEdMapAcquisitionData
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.ExperimentStarting Event

Occurs before acquisition starts.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<AcquisitionStartingEventArgs<IEdMapAcquisitionData>> ExperimentStarting
Event ExperimentStarting As EventHandler(Of AcquisitionStartingEventArgs(Of IEdMapAcquisitionData))
 event EventHandler<AcquisitionStartingEventArgs<IEdMapAcquisitionData^>^>^ ExperimentStarting {
    void add (EventHandler<AcquisitionStartingEventArgs<IEdMapAcquisitionData^>^>^ value);
    void remove (EventHandler<AcquisitionStartingEventArgs<IEdMapAcquisitionData^>^>^ value);
}
abstract ExperimentStarting : IEvent<EventHandler<AcquisitionStartingEventArgs<IEdMapAcquisitionData>>,
    AcquisitionStartingEventArgs<IEdMapAcquisitionData>>

Value

Type: SystemEventHandler AcquisitionStartingEventArgs IEdMapAcquisitionData
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.FrameCompleted Event

Occurs when a map frame has been acquired.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<FrameCompletedEventArgs> FrameCompleted
Event FrameCompleted As EventHandler(Of FrameCompletedEventArgs)
 event EventHandler<FrameCompletedEventArgs^>^ FrameCompleted {
    void add (EventHandler<FrameCompletedEventArgs^>^ value);
    void remove (EventHandler<FrameCompletedEventArgs^>^ value);
}
abstract FrameCompleted : IEvent<EventHandler<FrameCompletedEventArgs>,
    FrameCompletedEventArgs>

Value

Type: SystemEventHandler FrameCompletedEventArgs
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.PauseRequested Event

Occurs when the scan needs to be paused.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<PauseScanEventArgs> PauseRequested
Event PauseRequested As EventHandler(Of PauseScanEventArgs)
 event EventHandler<PauseScanEventArgs^>^ PauseRequested {
    void add (EventHandler<PauseScanEventArgs^>^ value);
    void remove (EventHandler<PauseScanEventArgs^>^ value);
}
abstract PauseRequested : IEvent<EventHandler<PauseScanEventArgs>,
    PauseScanEventArgs>

Value

Type: SystemEventHandler PauseScanEventArgs
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapAcquisitionController.ResumeRequested Event

Occurs when the scan needs to be resumed.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ResumeScanEventArgs> ResumeRequested
Event ResumeRequested As EventHandler(Of ResumeScanEventArgs)
 event EventHandler<ResumeScanEventArgs^>^ ResumeRequested {
    void add (EventHandler<ResumeScanEventArgs^>^ value);
    void remove (EventHandler<ResumeScanEventArgs^>^ value);
}
abstract ResumeRequested : IEvent<EventHandler<ResumeScanEventArgs>,
    ResumeScanEventArgs>

Value

Type: SystemEventHandler ResumeScanEventArgs
See Also

Reference

IXSyncEdMapAcquisitionController Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapSettings Interface

An Interface that defines settings for Ed map acquisition using external scan synchronization.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IXSyncEdMapSettings
Public Interface IXSyncEdMapSettings
public interface class IXSyncEdMapSettings
type IXSyncEdMapSettings =  interface end

The IXSyncEdMapSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcquireSpectrum | Gets or sets a value indicating whether to acquire a spectrum at the same time as the map
Public property | EdCapabilities | Gets the Ed capabilities.
Public property | EdSettings | Gets the Ed settings.
Public property | XSyncCapabilities | Gets the external scan synchronization capabilities.
Public property | XSyncSettings | Gets the external scan synchronization settings.
Top
Methods
 | Name | Description
Public method | Validate | Validates all the settings.
Top
See Also

Reference

OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapSettings Properties

The IXSyncEdMapSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcquireSpectrum | Gets or sets a value indicating whether to acquire a spectrum at the same time as the map
Public property | EdCapabilities | Gets the Ed capabilities.
Public property | EdSettings | Gets the Ed settings.
Public property | XSyncCapabilities | Gets the external scan synchronization capabilities.
Public property | XSyncSettings | Gets the external scan synchronization settings.
Top
See Also

Reference

IXSyncEdMapSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapSettings.AcquireSpectrum Property

Gets or sets a value indicating whether to acquire a spectrum at the same time as the map

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool AcquireSpectrum { get; set; }
Property AcquireSpectrum As Boolean
    Get
    Set
property bool AcquireSpectrum {
    bool get ();
    void set (bool value);
}
abstract AcquireSpectrum : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IXSyncEdMapSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapSettings.EdCapabilities Property

Gets the Ed capabilities.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdCapabilities EdCapabilities { get; }
ReadOnly Property EdCapabilities As IEdCapabilities
    Get
property IEdCapabilities^ EdCapabilities {
    IEdCapabilities^ get ();
}
abstract EdCapabilities : IEdCapabilities with get

Property Value

Type: IEdCapabilities
See Also

Reference

IXSyncEdMapSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapSettings.EdSettings Property

Gets the Ed settings.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSettings EdSettings { get; }
ReadOnly Property EdSettings As IEdSettings
    Get
property IEdSettings^ EdSettings {
    IEdSettings^ get ();
}
abstract EdSettings : IEdSettings with get

Property Value

Type: IEdSettings
See Also

Reference

IXSyncEdMapSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapSettings.XSyncCapabilities Property

Gets the external scan synchronization capabilities.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IXSyncCapabilities XSyncCapabilities { get; }
ReadOnly Property XSyncCapabilities As IXSyncCapabilities
    Get
property IXSyncCapabilities^ XSyncCapabilities {
    IXSyncCapabilities^ get ();
}
abstract XSyncCapabilities : IXSyncCapabilities with get

Property Value

Type: IXSyncCapabilities
See Also

Reference

IXSyncEdMapSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapSettings.XSyncSettings Property

Gets the external scan synchronization settings.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IXSyncSettings XSyncSettings { get; }
ReadOnly Property XSyncSettings As IXSyncSettings
    Get
property IXSyncSettings^ XSyncSettings {
    IXSyncSettings^ get ();
}
abstract XSyncSettings : IXSyncSettings with get

Property Value

Type: IXSyncSettings
See Also

Reference

IXSyncEdMapSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapSettings Methods

The IXSyncEdMapSettings type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Validates all the settings.
Top
See Also

Reference

IXSyncEdMapSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncEdMapSettings.Validate Method

Validates all the settings.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IValidationResults Validate()
Function Validate As IValidationResults
IValidationResults^ Validate()
abstract Validate : unit -> IValidationResults

Return Value

Type: IValidationResults
The validation results
See Also

Reference

IXSyncEdMapSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncSettings Interface

An Interface that defines the settings for acquisition using external scan synchronization.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IXSyncSettings : INotifyPropertyChanged
Public Interface IXSyncSettings
    Inherits INotifyPropertyChanged
public interface class IXSyncSettings : INotifyPropertyChanged
type IXSyncSettings =
    interface
        interface INotifyPropertyChanged
    end

The IXSyncSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionRegion | Gets the acquisition region.
Public property | CalibratedFieldWidthmm | Gets or sets the calibrated field width in mm at 1x magnification
Public property | FrameCount | Gets or sets the number of frames to acquire.
Public property | LineSync | Gets the settings for Cas Line Sync mode
Public property | SynchronizationMode | Gets or sets the external scan synchronization mode.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Acquisition.XSync Namespace


IXSyncSettings Properties

The IXSyncSettings type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionRegion | Gets the acquisition region.
Public property | CalibratedFieldWidthmm | Gets or sets the calibrated field width in mm at 1x magnification
Public property | FrameCount | Gets or sets the number of frames to acquire.
Public property | LineSync | Gets the settings for Cas Line Sync mode
Public property | SynchronizationMode | Gets or sets the external scan synchronization mode.
Top
See Also

Reference

IXSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncSettings.AcquisitionRegion Property

Gets the acquisition region.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IXSyncAcquisitionRegion AcquisitionRegion { get; }
ReadOnly Property AcquisitionRegion As IXSyncAcquisitionRegion
    Get
property IXSyncAcquisitionRegion^ AcquisitionRegion {
    IXSyncAcquisitionRegion^ get ();
}
abstract AcquisitionRegion : IXSyncAcquisitionRegion with get

Property Value

Type: IXSyncAcquisitionRegion
See Also

Reference

IXSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncSettings.CalibratedFieldWidthmm Property

Gets or sets the calibrated field width in mm at 1x magnification

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double CalibratedFieldWidthmm { get; set; }
Property CalibratedFieldWidthmm As Double
    Get
    Set
property double CalibratedFieldWidthmm {
    double get ();
    void set (double value);
}
abstract CalibratedFieldWidthmm : float with get, set

Property Value

Type: Double
See Also

Reference

IXSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncSettings.FrameCount Property

Gets or sets the number of frames to acquire.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int FrameCount { get; set; }
Property FrameCount As Integer
    Get
    Set
property int FrameCount {
    int get ();
    void set (int value);
}
abstract FrameCount : int with get, set

Property Value

Type: Int32
See Also

Reference

IXSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncSettings.LineSync Property

Gets the settings for Cas Line Sync mode

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ICasLineSyncSettings LineSync { get; }
ReadOnly Property LineSync As ICasLineSyncSettings
    Get
property ICasLineSyncSettings^ LineSync {
    ICasLineSyncSettings^ get ();
}
abstract LineSync : ICasLineSyncSettings with get

Property Value

Type: ICasLineSyncSettings
See Also

Reference

IXSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncSettings.SynchronizationMode Property

Gets or sets the external scan synchronization mode.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
XSyncMode SynchronizationMode { get; set; }
Property SynchronizationMode As XSyncMode
    Get
    Set
property XSyncMode SynchronizationMode {
    XSyncMode get ();
    void set (XSyncMode value);
}
abstract SynchronizationMode : XSyncMode with get, set

Property Value

Type: XSyncMode
See Also

Reference

IXSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


IXSyncSettings Events

The IXSyncSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IXSyncSettings Interface
OINA.Extender.Acquisition.XSync Namespace


PauseScanEventArgs Class

Class that indicates that the scan should be paused
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.Extender.Acquisition.XSyncPauseScanEventArgs

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class PauseScanEventArgs : EventArgs
Public Class PauseScanEventArgs
    Inherits EventArgs
public ref class PauseScanEventArgs : public EventArgs
type PauseScanEventArgs =
    class
        inherit EventArgs
    end

The PauseScanEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Acquisition.XSync Namespace


PauseScanEventArgs Methods

The PauseScanEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PauseScanEventArgs Class
OINA.Extender.Acquisition.XSync Namespace


ResumeScanEventArgs Class

Class that indicates that the scan should be resumed
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.Extender.Acquisition.XSyncResumeScanEventArgs

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class ResumeScanEventArgs : EventArgs
Public Class ResumeScanEventArgs
    Inherits EventArgs
public ref class ResumeScanEventArgs : public EventArgs
type ResumeScanEventArgs =
    class
        inherit EventArgs
    end

The ResumeScanEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Acquisition.XSync Namespace


ResumeScanEventArgs Methods

The ResumeScanEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResumeScanEventArgs Class
OINA.Extender.Acquisition.XSync Namespace


XSyncMode Enumeration

The external scan synchronization mode.

Namespace: OINA.Extender.Acquisition.XSync
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum XSyncMode
Public Enumeration XSyncMode
public enum class XSyncMode
type XSyncMode
Members
Member name | Value | Description
Unknown | 0 | Has not been set.
HardwareMoveOnly | 2 | Performs scan synchronization using unidirectional hardware control.
CASLineSync | 5 | Performs scan synchronization using CAS line sync
See Also

Reference

OINA.Extender.Acquisition.XSync Namespace


OINA.Extender.Controls Namespace

Defines all Classes and Interfaces used for the visual User Controls used by the API.

OINA Extender Controls Namespace

Classes
 | Class | Description
Public class | ElementCombo | Initializes a new instance of the ElementCombo control class.
Public class | ImageViewer | A control used for displaying images.
Public class | PeriodicTableControl | A Class representing the Periodic Table of Elements that allows the selection/exclusion of elements for identification purposes.
Public class | SpectrumViewer | A control for displaying an X-Ray spectrum.
Enumerations
 | Enumeration | Description
Public enumeration | ExportImageType | The supported image exported types.
Public enumeration | QuantResultCategory | The allowed quant result categories.
Public enumeration | QuantResultFormat | The supported quant result display modes.


ElementCombo Class

Initializes a new instance of the ElementCombo control class.
ElementCombo
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
OINA.Extender.ControlsElementCombo

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class ElementCombo : UserControl,
    INotifyPropertyChanged, IComponentConnector
Public Class ElementCombo
    Inherits UserControl
    Implements INotifyPropertyChanged, IComponentConnector
public ref class ElementCombo : public UserControl,
    INotifyPropertyChanged, IComponentConnector
type ElementCombo =
    class
        inherit UserControl
        interface INotifyPropertyChanged
        interface IComponentConnector
    end

The ElementCombo type exposes the following members.

Constructors
 | Name | Description
Public method | ElementCombo | ElementCombo constructor
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CurrentElement | Gets or sets the currently selected element.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayFormat | Gets or sets a value that specifies whether the element's name or symbol is displayed.
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Items | Gets or sets the elements displayed in the list.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Event raised when a property changes.
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ChartElementsProperty | The Dependency Property for binding to the ChartElements property. Used internally by the control.
CurrentElementProperty | The Dependency Property for binding to the CurrentElement property.
DisplayFormatProperty | The Dependency Property for binding to the DisplayFormat property.
ItemsProperty | The Dependency Property for binding to the Items property.
Top
See Also

Reference

OINA.Extender.Controls Namespace


ElementCombo Constructor

ElementCombo constructor

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ElementCombo()
Public Sub New
public:
ElementCombo()
new : unit -> ElementCombo
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo Properties

The ElementCombo type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CurrentElement | Gets or sets the currently selected element.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayFormat | Gets or sets a value that specifies whether the element's name or symbol is displayed.
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Items | Gets or sets the elements displayed in the list.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo.CurrentElement Property

Gets or sets the currently selected element.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public int CurrentElement { get; set; }
Public Property CurrentElement As Integer
    Get
    Set
public:
property int CurrentElement {
    int get ();
    void set (int value);
}
member CurrentElement : int with get, set

Property Value

Type: Int32
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo.DisplayFormat Property

Gets or sets a value that specifies whether the element's name or symbol is displayed.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ElementComboDisplayFormat DisplayFormat { get; set; }
Public Property DisplayFormat As ElementComboDisplayFormat
    Get
    Set
public:
property ElementComboDisplayFormat DisplayFormat {
    ElementComboDisplayFormat get ();
    void set (ElementComboDisplayFormat value);
}
member DisplayFormat : ElementComboDisplayFormat with get, set

Property Value

Type: ElementComboDisplayFormat
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo.Items Property

Gets or sets the elements displayed in the list.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<int> Items { get; set; }
Public Property Items As IEnumerable(Of Integer)
    Get
    Set
public:
property IEnumerable<int>^ Items {
    IEnumerable<int>^ get ();
    void set (IEnumerable<int>^ value);
}
member Items : IEnumerable<int> with get, set

Property Value

Type: IEnumerable Int32
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo Methods

The ElementCombo type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo.InitializeComponent Method

InitializeComponent

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void InitializeComponent()
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo Events

The ElementCombo type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Event raised when a property changes.
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo.PropertyChanged Event

Event raised when a property changes.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo Fields

The ElementCombo type exposes the following members.

Fields
Name | Description
ChartElementsProperty | The Dependency Property for binding to the ChartElements property. Used internally by the control.
CurrentElementProperty | The Dependency Property for binding to the CurrentElement property.
DisplayFormatProperty | The Dependency Property for binding to the DisplayFormat property.
ItemsProperty | The Dependency Property for binding to the Items property.
Top
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo.ChartElementsProperty Field

The Dependency Property for binding to the ChartElements property. Used internally by the control.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ChartElementsProperty
Public Shared ReadOnly ChartElementsProperty As DependencyProperty
public:
static initonly DependencyProperty^ ChartElementsProperty
static val ChartElementsProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo.CurrentElementProperty Field

The Dependency Property for binding to the CurrentElement property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty CurrentElementProperty
Public Shared ReadOnly CurrentElementProperty As DependencyProperty
public:
static initonly DependencyProperty^ CurrentElementProperty
static val CurrentElementProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo.DisplayFormatProperty Field

The Dependency Property for binding to the DisplayFormat property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty DisplayFormatProperty
Public Shared ReadOnly DisplayFormatProperty As DependencyProperty
public:
static initonly DependencyProperty^ DisplayFormatProperty
static val DisplayFormatProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ElementCombo.ItemsProperty Field

The Dependency Property for binding to the Items property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ItemsProperty
Public Shared ReadOnly ItemsProperty As DependencyProperty
public:
static initonly DependencyProperty^ ItemsProperty
static val ItemsProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ElementCombo Class
OINA.Extender.Controls Namespace


ExportImageType Enumeration

The supported image exported types.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum ExportImageType
Public Enumeration ExportImageType
public enum class ExportImageType
type ExportImageType
Members
Member name | Value | Description
Tiff | 0 | Represents a 32-bit colour Tagged Image File Format image.
Gray8Tiff | 1 | Represents an 8-bit greyscale Tagged Image File Format image.
Color8Tiff | 2 | Represents an 8-bit colour Tagged Image File Format image.
See Also

Reference

OINA.Extender.Controls Namespace


ImageViewer Class

A control used for displaying images.
ImageViewer
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
OINA.Extender.ControlsImageViewer

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class ImageViewer : UserControl,
    INotifyPropertyChanged, IComponentConnector
Public Class ImageViewer
    Inherits UserControl
    Implements INotifyPropertyChanged, IComponentConnector
public ref class ImageViewer : public UserControl,
    INotifyPropertyChanged, IComponentConnector
type ImageViewer =
    class
        inherit UserControl
        interface INotifyPropertyChanged
        interface IComponentConnector
    end

The ImageViewer type exposes the following members.

Constructors
 | Name | Description
Public method | ImageViewer | Initializes a new instance of the ImageViewer class.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreBrightnessContrastButtonsVisible | Gets or sets a value indicating whether the Brightness and Contrast buttons are visible or not.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayImage | Gets or sets the displayed image.
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | InteractionTool | Gets or sets the tool being used to handle mouse interaction.
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsColourBarAvailable | Gets a value indicating whether a colour bar is available for the displayed image.
Public property | IsColourBarVisible | Gets or sets a value indicating whether a colour bar is available for the displayed image.
Public property | IsColourKeyAvailable | Gets a value indicating whether a colour key is available for the displayed image.
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHeaderVisible | Gets or sets a value indicating whether the header is visible or not.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsScaleBarVisible | Gets or sets a value indicating whether the scale bar is visible or not.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | Export | Exports the displayed image to a file.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Event raised when a property changes.
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreBrightnessContrastButtonsVisibleProperty | The Dependency Property for binding to the AreBrightnessContrastButtonsVisible property.
DisplayImageProperty | The Dependency Property for binding to the DisplayImage property.
ExportImageCopyCommand | Command for copying the image to the clipboard.
ExportImageSaveAsCommand | Command for saving the image viewer as an image file.
ExportRealDataCommand | Command for saving the displayed image data as a CSV or TSV file.
InteractionToolProperty | The Dependency Property for binding to the InteractionTool property.
IsColourBarAvailableProperty | The Dependency Property for binding to the IsColourBarAvailable property.
IsColourBarVisibleProperty | The Dependency Property for binding to the IsColourBarVisible property.
IsColourKeyAvailableProperty | The Dependency Property for binding to the IsColourKeyAvailable property.
IsHeaderVisibleProperty | The Dependency Property for binding to the IsHeaderVisible property.
IsScaleBarVisibleProperty | The Dependency Property for binding to the IsScaleBarVisible property.
RescaleImageCommand | Command for re-scaling the image to fit or fill the viewer.
SaveDirectCommand | Command for saving the displayed image as a PNG file at its original resolution.
SaveRawTiffCommand | Command for saving the displayed image as a TIF file at its original resolution.
ShowBrightnessContrastDialogCommand | Command for displaying the BrightnessContrastDialog.
ShowImageDetailsCommand | Command for displaying details about the image.
Top
See Also

Reference

OINA.Extender.Controls Namespace


ImageViewer Constructor

Initializes a new instance of the ImageViewer class.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ImageViewer()
Public Sub New
public:
ImageViewer()
new : unit -> ImageViewer
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer Properties

The ImageViewer type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreBrightnessContrastButtonsVisible | Gets or sets a value indicating whether the Brightness and Contrast buttons are visible or not.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayImage | Gets or sets the displayed image.
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | InteractionTool | Gets or sets the tool being used to handle mouse interaction.
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsColourBarAvailable | Gets a value indicating whether a colour bar is available for the displayed image.
Public property | IsColourBarVisible | Gets or sets a value indicating whether a colour bar is available for the displayed image.
Public property | IsColourKeyAvailable | Gets a value indicating whether a colour key is available for the displayed image.
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHeaderVisible | Gets or sets a value indicating whether the header is visible or not.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsScaleBarVisible | Gets or sets a value indicating whether the scale bar is visible or not.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.AreBrightnessContrastButtonsVisible Property

Gets or sets a value indicating whether the Brightness and Contrast buttons are visible or not.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool AreBrightnessContrastButtonsVisible { get; set; }
Public Property AreBrightnessContrastButtonsVisible As Boolean
    Get
    Set
public:
property bool AreBrightnessContrastButtonsVisible {
    bool get ();
    void set (bool value);
}
member AreBrightnessContrastButtonsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.DisplayImage Property

Gets or sets the displayed image.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public IImageCorrection DisplayImage { get; set; }
Public Property DisplayImage As IImageCorrection
    Get
    Set
public:
property IImageCorrection^ DisplayImage {
    IImageCorrection^ get ();
    void set (IImageCorrection^ value);
}
member DisplayImage : IImageCorrection with get, set

Property Value

Type: IImageCorrection
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.InteractionTool Property

Gets or sets the tool being used to handle mouse interaction.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ImageInteractionTool InteractionTool { get; set; }
Public Property InteractionTool As ImageInteractionTool
    Get
    Set
public:
property ImageInteractionTool InteractionTool {
    ImageInteractionTool get ();
    void set (ImageInteractionTool value);
}
member InteractionTool : ImageInteractionTool with get, set

Property Value

Type: ImageInteractionTool
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.IsColourBarAvailable Property

Gets a value indicating whether a colour bar is available for the displayed image.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsColourBarAvailable { get; }
Public ReadOnly Property IsColourBarAvailable As Boolean
    Get
public:
property bool IsColourBarAvailable {
    bool get ();
}
member IsColourBarAvailable : bool with get

Property Value

Type: Boolean
true if the colour bar is available; otherwise, false.
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.IsColourBarVisible Property

Gets or sets a value indicating whether a colour bar is available for the displayed image.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsColourBarVisible { get; set; }
Public Property IsColourBarVisible As Boolean
    Get
    Set
public:
property bool IsColourBarVisible {
    bool get ();
    void set (bool value);
}
member IsColourBarVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.IsColourKeyAvailable Property

Gets a value indicating whether a colour key is available for the displayed image.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsColourKeyAvailable { get; }
Public ReadOnly Property IsColourKeyAvailable As Boolean
    Get
public:
property bool IsColourKeyAvailable {
    bool get ();
}
member IsColourKeyAvailable : bool with get

Property Value

Type: Boolean
true if the colour key is available; otherwise, false.
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.IsHeaderVisible Property

Gets or sets a value indicating whether the header is visible or not.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsHeaderVisible { get; set; }
Public Property IsHeaderVisible As Boolean
    Get
    Set
public:
property bool IsHeaderVisible {
    bool get ();
    void set (bool value);
}
member IsHeaderVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.IsScaleBarVisible Property

Gets or sets a value indicating whether the scale bar is visible or not.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsScaleBarVisible { get; set; }
Public Property IsScaleBarVisible As Boolean
    Get
    Set
public:
property bool IsScaleBarVisible {
    bool get ();
    void set (bool value);
}
member IsScaleBarVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer Methods

The ImageViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | Export | Exports the displayed image to a file.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.Export Method

Exports the displayed image to a file.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void Export(
    string fileName,
    ExportFormat exportFormat
)
Public Sub Export (
    fileName As String,
    exportFormat As ExportFormat
)
public:
void Export(
    String^ fileName,
    ExportFormat exportFormat
)
member Export :
        fileName : string *
        exportFormat : ExportFormat -> unit

Parameters

fileName
Type: SystemString
Name of file to export to.
exportFormat
Type: OINA.Extender.Controls.CommonExportFormat
File format to export in.
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.InitializeComponent Method

InitializeComponent

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void InitializeComponent()
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer Events

The ImageViewer type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Event raised when a property changes.
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.PropertyChanged Event

Event raised when a property changes.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer Fields

The ImageViewer type exposes the following members.

Fields
Name | Description
AreBrightnessContrastButtonsVisibleProperty | The Dependency Property for binding to the AreBrightnessContrastButtonsVisible property.
DisplayImageProperty | The Dependency Property for binding to the DisplayImage property.
ExportImageCopyCommand | Command for copying the image to the clipboard.
ExportImageSaveAsCommand | Command for saving the image viewer as an image file.
ExportRealDataCommand | Command for saving the displayed image data as a CSV or TSV file.
InteractionToolProperty | The Dependency Property for binding to the InteractionTool property.
IsColourBarAvailableProperty | The Dependency Property for binding to the IsColourBarAvailable property.
IsColourBarVisibleProperty | The Dependency Property for binding to the IsColourBarVisible property.
IsColourKeyAvailableProperty | The Dependency Property for binding to the IsColourKeyAvailable property.
IsHeaderVisibleProperty | The Dependency Property for binding to the IsHeaderVisible property.
IsScaleBarVisibleProperty | The Dependency Property for binding to the IsScaleBarVisible property.
RescaleImageCommand | Command for re-scaling the image to fit or fill the viewer.
SaveDirectCommand | Command for saving the displayed image as a PNG file at its original resolution.
SaveRawTiffCommand | Command for saving the displayed image as a TIF file at its original resolution.
ShowBrightnessContrastDialogCommand | Command for displaying the BrightnessContrastDialog.
ShowImageDetailsCommand | Command for displaying details about the image.
Top
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.AreBrightnessContrastButtonsVisibleProperty Field

The Dependency Property for binding to the AreBrightnessContrastButtonsVisible property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty AreBrightnessContrastButtonsVisibleProperty
Public Shared ReadOnly AreBrightnessContrastButtonsVisibleProperty As DependencyProperty
public:
static initonly DependencyProperty^ AreBrightnessContrastButtonsVisibleProperty
static val AreBrightnessContrastButtonsVisibleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.DisplayImageProperty Field

The Dependency Property for binding to the DisplayImage property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty DisplayImageProperty
Public Shared ReadOnly DisplayImageProperty As DependencyProperty
public:
static initonly DependencyProperty^ DisplayImageProperty
static val DisplayImageProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.ExportImageCopyCommand Field

Command for copying the image to the clipboard.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand ExportImageCopyCommand
Public Shared ReadOnly ExportImageCopyCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ ExportImageCopyCommand
static val ExportImageCopyCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.ExportImageSaveAsCommand Field

Command for saving the image viewer as an image file.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand ExportImageSaveAsCommand
Public Shared ReadOnly ExportImageSaveAsCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ ExportImageSaveAsCommand
static val ExportImageSaveAsCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.ExportRealDataCommand Field

Command for saving the displayed image data as a CSV or TSV file.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand ExportRealDataCommand
Public Shared ReadOnly ExportRealDataCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ ExportRealDataCommand
static val ExportRealDataCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.InteractionToolProperty Field

The Dependency Property for binding to the InteractionTool property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty InteractionToolProperty
Public Shared ReadOnly InteractionToolProperty As DependencyProperty
public:
static initonly DependencyProperty^ InteractionToolProperty
static val InteractionToolProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.IsColourBarAvailableProperty Field

The Dependency Property for binding to the IsColourBarAvailable property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsColourBarAvailableProperty
Public Shared ReadOnly IsColourBarAvailableProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsColourBarAvailableProperty
static val IsColourBarAvailableProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.IsColourBarVisibleProperty Field

The Dependency Property for binding to the IsColourBarVisible property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsColourBarVisibleProperty
Public Shared ReadOnly IsColourBarVisibleProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsColourBarVisibleProperty
static val IsColourBarVisibleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.IsColourKeyAvailableProperty Field

The Dependency Property for binding to the IsColourKeyAvailable property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsColourKeyAvailableProperty
Public Shared ReadOnly IsColourKeyAvailableProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsColourKeyAvailableProperty
static val IsColourKeyAvailableProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.IsHeaderVisibleProperty Field

The Dependency Property for binding to the IsHeaderVisible property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsHeaderVisibleProperty
Public Shared ReadOnly IsHeaderVisibleProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsHeaderVisibleProperty
static val IsHeaderVisibleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.IsScaleBarVisibleProperty Field

The Dependency Property for binding to the IsScaleBarVisible property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsScaleBarVisibleProperty
Public Shared ReadOnly IsScaleBarVisibleProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsScaleBarVisibleProperty
static val IsScaleBarVisibleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.RescaleImageCommand Field

Command for re-scaling the image to fit or fill the viewer.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand RescaleImageCommand
Public Shared ReadOnly RescaleImageCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ RescaleImageCommand
static val RescaleImageCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.SaveDirectCommand Field

Command for saving the displayed image as a PNG file at its original resolution.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand SaveDirectCommand
Public Shared ReadOnly SaveDirectCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ SaveDirectCommand
static val SaveDirectCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.SaveRawTiffCommand Field

Command for saving the displayed image as a TIF file at its original resolution.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand SaveRawTiffCommand
Public Shared ReadOnly SaveRawTiffCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ SaveRawTiffCommand
static val SaveRawTiffCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.ShowBrightnessContrastDialogCommand Field

Command for displaying the BrightnessContrastDialog.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand ShowBrightnessContrastDialogCommand
Public Shared ReadOnly ShowBrightnessContrastDialogCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ ShowBrightnessContrastDialogCommand
static val ShowBrightnessContrastDialogCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


ImageViewer.ShowImageDetailsCommand Field

Command for displaying details about the image.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand ShowImageDetailsCommand
Public Shared ReadOnly ShowImageDetailsCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ ShowImageDetailsCommand
static val ShowImageDetailsCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

ImageViewer Class
OINA.Extender.Controls Namespace


PeriodicTableControl Class

A Class representing the Periodic Table of Elements that allows the selection/exclusion of elements for identification purposes.
PeriodicTableControl
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
OINA.Extender.ControlsPeriodicTableControl

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class PeriodicTableControl : UserControl,
    IComponentConnector, IStyleConnector
Public Class PeriodicTableControl
    Inherits UserControl
    Implements IComponentConnector, IStyleConnector
public ref class PeriodicTableControl : public UserControl,
    IComponentConnector, IStyleConnector
type PeriodicTableControl =
    class
        inherit UserControl
        interface IComponentConnector
        interface IStyleConnector
    end

The PeriodicTableControl type exposes the following members.

Constructors
 | Name | Description
Public method | PeriodicTableControl | Initializes a new instance of the PeriodicTable control class.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ChartElements | Gets all the elements in the Periodic Table
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExcludedElements | Gets the elements that are always excluded when identifying peaks in the spectrum.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IncludedElements | Gets the elements that are always included when identifying peaks in the spectrum.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedElement |
Public property | SelectionMode | Gets or sets a value that defines if the user can select multiple elements from the table. In Single selection mode the user can toggle the elements between states by double-clicking an element. In multiple selection mode, the user may select multiple elements by using the shift or ctrl keys whilst clicking on elements in the table, and then selecting their states using the buttons at the bottom. Extended mode is not supported.
Public property | ShowClearAll | Gets or sets a value indicating whether to show the Clear All button.
Public property | ShowElementColors | Gets or sets a value indicating whether to show a color bar beneath the element
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UnsetElements | Gets the elements that can be included when identifying peaks in the spectrum
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | Clear | Sets element(s) to ‘unset’ in the periodic table.
Public method | ClearAll | Sets all elements to ‘unset’ in the periodic table.
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EnableElements | Enable or Disable elements in the table.
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | ExcludeElements | Sets element(s) to ‘excluded’ in the periodic table.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetElementColor | Gets the colour of the element.
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | IncludeElements | Sets element(s) to ‘included’ in the periodic table.
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LookupElementInfo | Looks up the element's information from an atomic number.
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetElementColor | Sets the color of a color bar beneath the element.
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | The Property changed event
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
SelectedElementProperty |
SelectionModeProperty | The Dependency Property for binding to the SelectionMode property.
SelectionStateChangeCommand | Command for changing the selection state of an element.
ShowClearAllProperty | The Dependency Property for binding to the ShowClearAll property.
ShowElementColorsProperty | The Dependency Property for binding to the ShowElementColors property.
Top
See Also

Reference

OINA.Extender.Controls Namespace


PeriodicTableControl Constructor

Initializes a new instance of the PeriodicTable control class.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public PeriodicTableControl()
Public Sub New
public:
PeriodicTableControl()
new : unit -> PeriodicTableControl
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl Properties

The PeriodicTableControl type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ChartElements | Gets all the elements in the Periodic Table
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExcludedElements | Gets the elements that are always excluded when identifying peaks in the spectrum.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IncludedElements | Gets the elements that are always included when identifying peaks in the spectrum.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedElement |
Public property | SelectionMode | Gets or sets a value that defines if the user can select multiple elements from the table. In Single selection mode the user can toggle the elements between states by double-clicking an element. In multiple selection mode, the user may select multiple elements by using the shift or ctrl keys whilst clicking on elements in the table, and then selecting their states using the buttons at the bottom. Extended mode is not supported.
Public property | ShowClearAll | Gets or sets a value indicating whether to show the Clear All button.
Public property | ShowElementColors | Gets or sets a value indicating whether to show a color bar beneath the element
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UnsetElements | Gets the elements that can be included when identifying peaks in the spectrum
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.ChartElements Property

Gets all the elements in the Periodic Table

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyObservableCollection<IPeriodicTableElement> ChartElements { get; }
Public ReadOnly Property ChartElements As ReadOnlyObservableCollection(Of IPeriodicTableElement)
    Get
public:
property ReadOnlyObservableCollection<IPeriodicTableElement^>^ ChartElements {
    ReadOnlyObservableCollection<IPeriodicTableElement^>^ get ();
}
member ChartElements : ReadOnlyObservableCollection<IPeriodicTableElement> with get

Property Value

Type: ReadOnlyObservableCollection IPeriodicTableElement
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.ExcludedElements Property

Gets the elements that are always excluded when identifying peaks in the spectrum.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyObservableCollection<int> ExcludedElements { get; }
Public ReadOnly Property ExcludedElements As ReadOnlyObservableCollection(Of Integer)
    Get
public:
property ReadOnlyObservableCollection<int>^ ExcludedElements {
    ReadOnlyObservableCollection<int>^ get ();
}
member ExcludedElements : ReadOnlyObservableCollection<int> with get

Property Value

Type: ReadOnlyObservableCollection Int32
The excluded elements.
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.IncludedElements Property

Gets the elements that are always included when identifying peaks in the spectrum.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyObservableCollection<int> IncludedElements { get; }
Public ReadOnly Property IncludedElements As ReadOnlyObservableCollection(Of Integer)
    Get
public:
property ReadOnlyObservableCollection<int>^ IncludedElements {
    ReadOnlyObservableCollection<int>^ get ();
}
member IncludedElements : ReadOnlyObservableCollection<int> with get

Property Value

Type: ReadOnlyObservableCollection Int32
The included elements.
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.SelectedElement Property

[Missing <summary> documentation for "P:OINA.Extender.Controls.PeriodicTableControl.SelectedElement"]

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public int SelectedElement { get; set; }
Public Property SelectedElement As Integer
    Get
    Set
public:
property int SelectedElement {
    int get ();
    void set (int value);
}
member SelectedElement : int with get, set

Property Value

Type: Int32
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.SelectionMode Property

Gets or sets a value that defines if the user can select multiple elements from the table. In Single selection mode the user can toggle the elements between states by double-clicking an element. In multiple selection mode, the user may select multiple elements by using the shift or ctrl keys whilst clicking on elements in the table, and then selecting their states using the buttons at the bottom. Extended mode is not supported.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public SelectionMode SelectionMode { get; set; }
Public Property SelectionMode As SelectionMode
    Get
    Set
public:
property SelectionMode SelectionMode {
    SelectionMode get ();
    void set (SelectionMode value);
}
member SelectionMode : SelectionMode with get, set

Property Value

Type: SelectionMode
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.ShowClearAll Property

Gets or sets a value indicating whether to show the Clear All button.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowClearAll { get; set; }
Public Property ShowClearAll As Boolean
    Get
    Set
public:
property bool ShowClearAll {
    bool get ();
    void set (bool value);
}
member ShowClearAll : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.ShowElementColors Property

Gets or sets a value indicating whether to show a color bar beneath the element

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowElementColors { get; set; }
Public Property ShowElementColors As Boolean
    Get
    Set
public:
property bool ShowElementColors {
    bool get ();
    void set (bool value);
}
member ShowElementColors : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.UnsetElements Property

Gets the elements that can be included when identifying peaks in the spectrum

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ReadOnlyObservableCollection<int> UnsetElements { get; }
Public ReadOnly Property UnsetElements As ReadOnlyObservableCollection(Of Integer)
    Get
public:
property ReadOnlyObservableCollection<int>^ UnsetElements {
    ReadOnlyObservableCollection<int>^ get ();
}
member UnsetElements : ReadOnlyObservableCollection<int> with get

Property Value

Type: ReadOnlyObservableCollection Int32
The unset elements.
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl Methods

The PeriodicTableControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | Clear | Sets element(s) to ‘unset’ in the periodic table.
Public method | ClearAll | Sets all elements to ‘unset’ in the periodic table.
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EnableElements | Enable or Disable elements in the table.
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | ExcludeElements | Sets element(s) to ‘excluded’ in the periodic table.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetElementColor | Gets the colour of the element.
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | IncludeElements | Sets element(s) to ‘included’ in the periodic table.
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LookupElementInfo | Looks up the element's information from an atomic number.
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetElementColor | Sets the color of a color bar beneath the element.
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.Clear Method

Sets element(s) to ‘unset’ in the periodic table.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void Clear(
    params int[] elements
)
Public Sub Clear (
    ParamArray elements As Integer()
)
public:
void Clear(
    ... array<int>^ elements
)
member Clear :
        elements : int[] -> unit

Parameters

elements
Type: SystemInt32
1 to n element numbers to unset
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.ClearAll Method

Sets all elements to ‘unset’ in the periodic table.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void ClearAll()
Public Sub ClearAll
public:
void ClearAll()
member ClearAll : unit -> unit
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.EnableElements Method

Enable or Disable elements in the table.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void EnableElements(
    bool enable,
    params int[] elements
)
Public Sub EnableElements (
    enable As Boolean,
    ParamArray elements As Integer()
)
public:
void EnableElements(
    bool enable,
    ... array<int>^ elements
)
member EnableElements :
        enable : bool *
        elements : int[] -> unit

Parameters

enable
Type: SystemBoolean
true to enable, false to disable
elements
Type: SystemInt32
1 to n element numbers to eneble or disable
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.ExcludeElements Method

Sets element(s) to ‘excluded’ in the periodic table.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void ExcludeElements(
    params int[] excludedElements
)
Public Sub ExcludeElements (
    ParamArray excludedElements As Integer()
)
public:
void ExcludeElements(
    ... array<int>^ excludedElements
)
member ExcludeElements :
        excludedElements : int[] -> unit

Parameters

excludedElements
Type: SystemInt32
1 to n element numbers to set to excluded
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.GetElementColor Method

Gets the colour of the element.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Nullable<Color> GetElementColor(
    int atomicNumber
)
Public Function GetElementColor (
    atomicNumber As Integer
) As Nullable(Of Color)
public:
Nullable<Color> GetElementColor(
    int atomicNumber
)
member GetElementColor :
        atomicNumber : int -> Nullable<Color>

Parameters

atomicNumber
Type: SystemInt32
The atomic number.

Return Value

Type: Nullable Color
null if element not found, otherwise the current colour of the element.
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.IncludeElements Method

Sets element(s) to ‘included’ in the periodic table.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void IncludeElements(
    params int[] includedElements
)
Public Sub IncludeElements (
    ParamArray includedElements As Integer()
)
public:
void IncludeElements(
    ... array<int>^ includedElements
)
member IncludeElements :
        includedElements : int[] -> unit

Parameters

includedElements
Type: SystemInt32
1 to n element numbers to set to included
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.InitializeComponent Method

InitializeComponent

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void InitializeComponent()
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit

Implements

IComponentConnectorInitializeComponent
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.LookupElementInfo Method

Looks up the element's information from an atomic number.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public IPeriodicTableElement LookupElementInfo(
    int atomicNumber
)
Public Function LookupElementInfo (
    atomicNumber As Integer
) As IPeriodicTableElement
public:
IPeriodicTableElement^ LookupElementInfo(
    int atomicNumber
)
member LookupElementInfo :
        atomicNumber : int -> IPeriodicTableElement

Parameters

atomicNumber
Type: SystemInt32
the atomic number of the element

Return Value

Type: IPeriodicTableElement
the element information
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.SetElementColor Method

Sets the color of a color bar beneath the element.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void SetElementColor(
    int atomicNumber,
    Color color
)
Public Sub SetElementColor (
    atomicNumber As Integer,
    color As Color
)
public:
void SetElementColor(
    int atomicNumber,
    Color color
)
member SetElementColor :
        atomicNumber : int *
        color : Color -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number.
color
Type: System.Windows.MediaColor
The color.
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl Events

The PeriodicTableControl type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | The Property changed event
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.PropertyChanged Event

The Property changed event

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
 event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
member PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl Fields

The PeriodicTableControl type exposes the following members.

Fields
Name | Description
SelectedElementProperty |
SelectionModeProperty | The Dependency Property for binding to the SelectionMode property.
SelectionStateChangeCommand | Command for changing the selection state of an element.
ShowClearAllProperty | The Dependency Property for binding to the ShowClearAll property.
ShowElementColorsProperty | The Dependency Property for binding to the ShowElementColors property.
Top
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.SelectedElementProperty Field

[Missing <summary> documentation for "F:OINA.Extender.Controls.PeriodicTableControl.SelectedElementProperty"]

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty SelectedElementProperty
Public Shared ReadOnly SelectedElementProperty As DependencyProperty
public:
static initonly DependencyProperty^ SelectedElementProperty
static val SelectedElementProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.SelectionModeProperty Field

The Dependency Property for binding to the SelectionMode property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty SelectionModeProperty
Public Shared ReadOnly SelectionModeProperty As DependencyProperty
public:
static initonly DependencyProperty^ SelectionModeProperty
static val SelectionModeProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.SelectionStateChangeCommand Field

Command for changing the selection state of an element.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedCommand SelectionStateChangeCommand
Public Shared ReadOnly SelectionStateChangeCommand As RoutedCommand
public:
static initonly RoutedCommand^ SelectionStateChangeCommand
static val SelectionStateChangeCommand: RoutedCommand

Field Value

Type: RoutedCommand
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.ShowClearAllProperty Field

The Dependency Property for binding to the ShowClearAll property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowClearAllProperty
Public Shared ReadOnly ShowClearAllProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowClearAllProperty
static val ShowClearAllProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


PeriodicTableControl.ShowElementColorsProperty Field

The Dependency Property for binding to the ShowElementColors property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowElementColorsProperty
Public Shared ReadOnly ShowElementColorsProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowElementColorsProperty
static val ShowElementColorsProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

PeriodicTableControl Class
OINA.Extender.Controls Namespace


QuantResultCategory Enumeration

The allowed quant result categories.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum QuantResultCategory
Public Enumeration QuantResultCategory
public enum class QuantResultCategory
type QuantResultCategory
Members
Member name | Value | Description
AtomicPercent | 1 |
WeightPercent | 0 |
OxidePercent | 2 |
See Also

Reference

OINA.Extender.Controls Namespace


QuantResultFormat Enumeration

The supported quant result display modes.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum QuantResultFormat
Public Enumeration QuantResultFormat
public enum class QuantResultFormat
type QuantResultFormat
Members
Member name | Value | Description
Table | 0 | Represents quant results displayed in a table.
Histogram | 1 | Represents quant results displayed in a histogram.
See Also

Reference

OINA.Extender.Controls Namespace


SpectrumViewer Class

A control for displaying an X-Ray spectrum.
SpectrumViewer
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
OINA.Extender.ControlsSpectrumViewer

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class SpectrumViewer : UserControl,
    INotifyPropertyChanged, IComponentConnector
Public Class SpectrumViewer
    Inherits UserControl
    Implements INotifyPropertyChanged, IComponentConnector
public ref class SpectrumViewer : public UserControl,
    INotifyPropertyChanged, IComponentConnector
type SpectrumViewer =
    class
        inherit UserControl
        interface INotifyPropertyChanged
        interface IComponentConnector
    end

The SpectrumViewer type exposes the following members.

Constructors
 | Name | Description
Public method | SpectrumViewer | Initializes a new instance of the SpectrumViewer control class.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DrawStyle | Gets or sets the value of the spectrum draw style.
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | EnergyWindowsSource | Gets or sets a collection of EnergyWindows displayed in the spectrum.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | InteractionTool | Gets or sets the tool being used to handle mouse interaction.
Public property | IsAltYAxisVisible | Gets or sets a value indicating whether or not to show the y-axis.
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsNormalizationEnabled | Gets or sets a value indicating whether normalization is enabled.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | IsXAxisAutoScaleEnabled | Gets or sets a value indicating whether the x-axis range auto-scales to follow the data. If set to true, the x-axis will scale to show the full width of the spectrum.
Public property | IsXAxisLocked | Gets or sets a value indicating whether the spectrum can be moved or rescaled in the x direction.
Public property | IsXAxisVisible | Gets or sets a value indicating whether or not to show the x-axis.
Public property | IsYAxisAutoScaleEnabled | Gets or sets a value indicating whether the y-axis range auto-scales to follow the data. If set to true, the y-axis will scale to show the full height of the spectrum.
Public property | IsYAxisLocked | Gets or sets a value indicating whether the spectrum can be moved or rescaled in the y direction.
Public property | IsYAxisVisible | Gets or sets a value indicating whether or not to show the y-axis.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MarkersElement | Gets or sets the atomic number of the element for which to show x-ray line markers in the spectrum.
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaximumCountsPerSecond | Gets or sets the maximum value of the y-axis.
Public property | MaximumEnergy | Gets or sets the maximum value of the x-axis in keV.
Public property | MaximumUpperLimit | Gets the upper limit of the maximum value of the y-axis.
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinimumEnergy | Gets or sets the minimum value of the x-axis in keV.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NoisePeakCutoffEnergy | Gets or sets the energy at which to perform Normalization.
Public property | NoisePeakMode | Gets or sets value indicating whether the y-axis range excludes the noise peak when auto-scaling to follow the data.
Public property | NormalizationEnergy | Gets or sets the energy at which to perform Normalization.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedQuantResultCategory | Gets or sets the selected quant result category.
Public property | SelectedQuantResultFormat | Gets or sets the selected quant result format.
Public property | ShowLegend | Gets or sets a value indicating whether to show or hide the legend.
Public property | ShowNormalizationRegion | Gets or sets a value indicating whether to show or hide the normalization region.
Public property | ShowPeakLabels | Gets or sets a value indicating whether to show or hide labels for identified peaks in the spectrum.
Public property | ShowQuantResults | Gets or sets a value indicating whether to show or hide the quant results.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Spectrum | Gets or sets the spectrum viewed in the control.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | YAxisType | Gets or sets the y-axis scale as Linear or Logarithmic.
Public property | YAxisUnits | Gets or sets the y-axis units.
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddComparisonSpectrum | Adds an additional spectrum to the viewer for comparison.
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearComparisonSpectra | Removes all spectra that have been added for comparison.
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateImage(ExportImageType) | Creates an image of the spectrum viewer control.
Public method | CreateImage(ExportImageType, Int32, Int32) | Creates an image of the spectrum viewer control.
Public method | CreateImage(ExportImageType, Int32, Int32, TiffCompressOption) | Creates an image of the spectrum viewer control.
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged(DependencyPropertyChangedEventArgs) | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnPropertyChanged(PropertyChangedEventArgs) | Handle property changed event
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveCompareSpectrum | Removes a spectrum that has been added for comparison.
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SEMQuantify | Quantifies the current spectrum using the provided SEM quant settings and displays the results if ShowQuantResults is true.
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | The property changed event.
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | SpectrumClicked | Occurs when the spectrum is clicked.
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DeletePeakLabelCommand | The DeletePeakLabelCommand command removes the peak label passed as the command parameter from its containing spectrum.
DrawStyleProperty | The Dependency Property for binding to the DrawStyle property.
EnergyWindowsSourceProperty | The Dependency Property for binding to the EnergyWindowsSource property.
ExportEMSACommand | Command for exporting the spectrum in EMSA format.
ExportImageCopyCommand | Command for copying the spectrum to the clipboard.
ExportImageSaveCommand | Command for saving the spectrum as an image.
InteractionToolProperty | The Dependency Property for binding to the InteractionTool property.
IsAltYAxisVisibleProperty | The Dependency Property for binding to the IsYAxisVisible property.
IsNormalizationEnabledProperty | The Dependency Property for binding to the IsNormalizationEnabled property.
IsXAxisAutoScaleEnabledProperty | The Dependency Property for binding to the IsXAxisAutoScaleEnabled property.
IsXAxisLockedProperty | The Dependency Property for binding to the IsXAxisLocked property.
IsXAxisVisibleProperty | The Dependency Property for binding to the IsXAxisVisible property.
IsYAxisAutoScaleEnabledProperty | The Dependency Property for binding to the IsYAxisAutoScaleEnabled property.
IsYAxisLockedProperty | The Dependency Property for binding to the IsYAxisLocked property.
IsYAxisVisibleProperty | The Dependency Property for binding to the IsYAxisVisible property.
MarkersElementProperty | The Dependency Property for binding to the MarkersElement property.
MaximumCountsPerSecondProperty | The Dependency Property for binding to the MaximumCountsPerSecond property.
MaximumEnergyProperty | The Dependency Property for binding to the MaximumEnergy property.
MaximumUpperLimitProperty | The Dependency Property for binding to the MaximumUpperLimit property.
MinimumEnergyProperty | The Dependency Property for binding to the MinimumEnergy property.
NoisePeakCutoffEnergyProperty | The Dependency Property for binding to the NoisePeakCutoffEnergy property.
NoisePeakModeProperty | The Dependency Property for binding to the NoisePeakMode property.
NormalizationEnergyProperty | The Dependency Property for binding to the NormalizationEnergy property.
NormalizationWindowWidthProperty | The Dependency Property for binding to the NormalizationWindowWidth property.
ResetPeakLabelPositionsCommand | Command for re-setting peak label positions.
ResetScalesCommand | Command for rescaling the spectrum to fit the viewer.
SelectedQuantResultCategoryProperty | The Dependency Property for binding to the SelectedQuantResultCategory property.
SelectedQuantResultFormatProperty | The Dependency Property for binding to the SelectedQuantResultFormat property.
SetDrawStyleCommand | Command for setting the draw style of the spectrum visuals.
SetYAxisTypeCommand | Command for setting the y-axis type.
SetYAxisUnitsCommand | Command for setting the y-axis units.
ShowLegendProperty | The Dependency Property for binding to the ShowLegend property.
ShowNormalizationRegionProperty | The Dependency Property for binding to the ShowNormalizationRegion property.
ShowPeakLabelsProperty | The Dependency Property for binding to the ShowPeakLabels property.
ShowQuantResultsProperty | The Dependency Property for binding to the ShowQuantResults property.
ShowSpectrumDetailsCommand | Command for showing the spectrum details window.
SpectrumClickedEvent | The Routed Event for the SpectrumClicked event.
SpectrumProperty | The Dependency Property for binding to the Spectrum property.
YAxisTypeProperty | The Dependency Property for binding to the YAxisType property.
YAxisUnitsProperty | The Dependency Property for binding to the YAxisUnits property.
Top
See Also

Reference

OINA.Extender.Controls Namespace


SpectrumViewer Constructor

Initializes a new instance of the SpectrumViewer control class.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public SpectrumViewer()
Public Sub New
public:
SpectrumViewer()
new : unit -> SpectrumViewer
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer Properties

The SpectrumViewer type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DrawStyle | Gets or sets the value of the spectrum draw style.
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | EnergyWindowsSource | Gets or sets a collection of EnergyWindows displayed in the spectrum.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | InteractionTool | Gets or sets the tool being used to handle mouse interaction.
Public property | IsAltYAxisVisible | Gets or sets a value indicating whether or not to show the y-axis.
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsNormalizationEnabled | Gets or sets a value indicating whether normalization is enabled.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | IsXAxisAutoScaleEnabled | Gets or sets a value indicating whether the x-axis range auto-scales to follow the data. If set to true, the x-axis will scale to show the full width of the spectrum.
Public property | IsXAxisLocked | Gets or sets a value indicating whether the spectrum can be moved or rescaled in the x direction.
Public property | IsXAxisVisible | Gets or sets a value indicating whether or not to show the x-axis.
Public property | IsYAxisAutoScaleEnabled | Gets or sets a value indicating whether the y-axis range auto-scales to follow the data. If set to true, the y-axis will scale to show the full height of the spectrum.
Public property | IsYAxisLocked | Gets or sets a value indicating whether the spectrum can be moved or rescaled in the y direction.
Public property | IsYAxisVisible | Gets or sets a value indicating whether or not to show the y-axis.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MarkersElement | Gets or sets the atomic number of the element for which to show x-ray line markers in the spectrum.
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaximumCountsPerSecond | Gets or sets the maximum value of the y-axis.
Public property | MaximumEnergy | Gets or sets the maximum value of the x-axis in keV.
Public property | MaximumUpperLimit | Gets the upper limit of the maximum value of the y-axis.
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinimumEnergy | Gets or sets the minimum value of the x-axis in keV.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NoisePeakCutoffEnergy | Gets or sets the energy at which to perform Normalization.
Public property | NoisePeakMode | Gets or sets value indicating whether the y-axis range excludes the noise peak when auto-scaling to follow the data.
Public property | NormalizationEnergy | Gets or sets the energy at which to perform Normalization.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedQuantResultCategory | Gets or sets the selected quant result category.
Public property | SelectedQuantResultFormat | Gets or sets the selected quant result format.
Public property | ShowLegend | Gets or sets a value indicating whether to show or hide the legend.
Public property | ShowNormalizationRegion | Gets or sets a value indicating whether to show or hide the normalization region.
Public property | ShowPeakLabels | Gets or sets a value indicating whether to show or hide labels for identified peaks in the spectrum.
Public property | ShowQuantResults | Gets or sets a value indicating whether to show or hide the quant results.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Spectrum | Gets or sets the spectrum viewed in the control.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | YAxisType | Gets or sets the y-axis scale as Linear or Logarithmic.
Public property | YAxisUnits | Gets or sets the y-axis units.
Top
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.DrawStyle Property

Gets or sets the value of the spectrum draw style.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public SpectrumDrawStyle DrawStyle { get; set; }
Public Property DrawStyle As SpectrumDrawStyle
    Get
    Set
public:
property SpectrumDrawStyle DrawStyle {
    SpectrumDrawStyle get ();
    void set (SpectrumDrawStyle value);
}
member DrawStyle : SpectrumDrawStyle with get, set

Property Value

Type: SpectrumDrawStyle
If Histogram, the spectrum data is drawn as a histogram. If Line, the spectrum data is drawn as a continuous line. If Smooth, the spectrum data is drawn as a continuous line with smoothing enabled where smoothing is the process of removing noise from the visible spectra.
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.EnergyWindowsSource Property

Gets or sets a collection of EnergyWindows displayed in the spectrum.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public IEnumerable EnergyWindowsSource { get; set; }
Public Property EnergyWindowsSource As IEnumerable
    Get
    Set
public:
property IEnumerable^ EnergyWindowsSource {
    IEnumerable^ get ();
    void set (IEnumerable^ value);
}
member EnergyWindowsSource : IEnumerable with get, set

Property Value

Type: IEnumerable
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.InteractionTool Property

Gets or sets the tool being used to handle mouse interaction.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public InteractionTool InteractionTool { get; set; }
Public Property InteractionTool As InteractionTool
    Get
    Set
public:
property InteractionTool InteractionTool {
    InteractionTool get ();
    void set (InteractionTool value);
}
member InteractionTool : InteractionTool with get, set

Property Value

Type: InteractionTool
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsAltYAxisVisible Property

Gets or sets a value indicating whether or not to show the y-axis.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsAltYAxisVisible { get; set; }
Public Property IsAltYAxisVisible As Boolean
    Get
    Set
public:
property bool IsAltYAxisVisible {
    bool get ();
    void set (bool value);
}
member IsAltYAxisVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsNormalizationEnabled Property

Gets or sets a value indicating whether normalization is enabled.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsNormalizationEnabled { get; set; }
Public Property IsNormalizationEnabled As Boolean
    Get
    Set
public:
property bool IsNormalizationEnabled {
    bool get ();
    void set (bool value);
}
member IsNormalizationEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsXAxisAutoScaleEnabled Property

Gets or sets a value indicating whether the x-axis range auto-scales to follow the data. If set to true, the x-axis will scale to show the full width of the spectrum.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsXAxisAutoScaleEnabled { get; set; }
Public Property IsXAxisAutoScaleEnabled As Boolean
    Get
    Set
public:
property bool IsXAxisAutoScaleEnabled {
    bool get ();
    void set (bool value);
}
member IsXAxisAutoScaleEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsXAxisLocked Property

Gets or sets a value indicating whether the spectrum can be moved or rescaled in the x direction.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsXAxisLocked { get; set; }
Public Property IsXAxisLocked As Boolean
    Get
    Set
public:
property bool IsXAxisLocked {
    bool get ();
    void set (bool value);
}
member IsXAxisLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsXAxisVisible Property

Gets or sets a value indicating whether or not to show the x-axis.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsXAxisVisible { get; set; }
Public Property IsXAxisVisible As Boolean
    Get
    Set
public:
property bool IsXAxisVisible {
    bool get ();
    void set (bool value);
}
member IsXAxisVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsYAxisAutoScaleEnabled Property

Gets or sets a value indicating whether the y-axis range auto-scales to follow the data. If set to true, the y-axis will scale to show the full height of the spectrum.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsYAxisAutoScaleEnabled { get; set; }
Public Property IsYAxisAutoScaleEnabled As Boolean
    Get
    Set
public:
property bool IsYAxisAutoScaleEnabled {
    bool get ();
    void set (bool value);
}
member IsYAxisAutoScaleEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsYAxisLocked Property

Gets or sets a value indicating whether the spectrum can be moved or rescaled in the y direction.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsYAxisLocked { get; set; }
Public Property IsYAxisLocked As Boolean
    Get
    Set
public:
property bool IsYAxisLocked {
    bool get ();
    void set (bool value);
}
member IsYAxisLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsYAxisVisible Property

Gets or sets a value indicating whether or not to show the y-axis.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsYAxisVisible { get; set; }
Public Property IsYAxisVisible As Boolean
    Get
    Set
public:
property bool IsYAxisVisible {
    bool get ();
    void set (bool value);
}
member IsYAxisVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.MarkersElement Property

Gets or sets the atomic number of the element for which to show x-ray line markers in the spectrum.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public int MarkersElement { get; set; }
Public Property MarkersElement As Integer
    Get
    Set
public:
property int MarkersElement {
    int get ();
    void set (int value);
}
member MarkersElement : int with get, set

Property Value

Type: Int32
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.MaximumCountsPerSecond Property

Gets or sets the maximum value of the y-axis.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double MaximumCountsPerSecond { get; set; }
Public Property MaximumCountsPerSecond As Double
    Get
    Set
public:
property double MaximumCountsPerSecond {
    double get ();
    void set (double value);
}
member MaximumCountsPerSecond : float with get, set

Property Value

Type: Double
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.MaximumEnergy Property

Gets or sets the maximum value of the x-axis in keV.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double MaximumEnergy { get; set; }
Public Property MaximumEnergy As Double
    Get
    Set
public:
property double MaximumEnergy {
    double get ();
    void set (double value);
}
member MaximumEnergy : float with get, set

Property Value

Type: Double
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.MaximumUpperLimit Property

Gets the upper limit of the maximum value of the y-axis.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double MaximumUpperLimit { get; }
Public ReadOnly Property MaximumUpperLimit As Double
    Get
public:
property double MaximumUpperLimit {
    double get ();
}
member MaximumUpperLimit : float with get

Property Value

Type: Double
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.MinimumEnergy Property

Gets or sets the minimum value of the x-axis in keV.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double MinimumEnergy { get; set; }
Public Property MinimumEnergy As Double
    Get
    Set
public:
property double MinimumEnergy {
    double get ();
    void set (double value);
}
member MinimumEnergy : float with get, set

Property Value

Type: Double
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.NoisePeakCutoffEnergy Property

Gets or sets the energy at which to perform Normalization.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double NoisePeakCutoffEnergy { get; set; }
Public Property NoisePeakCutoffEnergy As Double
    Get
    Set
public:
property double NoisePeakCutoffEnergy {
    double get ();
    void set (double value);
}
member NoisePeakCutoffEnergy : float with get, set

Property Value

Type: Double
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.NoisePeakMode Property

Gets or sets value indicating whether the y-axis range excludes the noise peak when auto-scaling to follow the data.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public SpectrumNoisePeakMode NoisePeakMode { get; set; }
Public Property NoisePeakMode As SpectrumNoisePeakMode
    Get
    Set
public:
property SpectrumNoisePeakMode NoisePeakMode {
    SpectrumNoisePeakMode get ();
    void set (SpectrumNoisePeakMode value);
}
member NoisePeakMode : SpectrumNoisePeakMode with get, set

Property Value

Type: SpectrumNoisePeakMode
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.NormalizationEnergy Property

Gets or sets the energy at which to perform Normalization.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double NormalizationEnergy { get; set; }
Public Property NormalizationEnergy As Double
    Get
    Set
public:
property double NormalizationEnergy {
    double get ();
    void set (double value);
}
member NormalizationEnergy : float with get, set

Property Value

Type: Double
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.SelectedQuantResultCategory Property

Gets or sets the selected quant result category.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public QuantResultCategory SelectedQuantResultCategory { get; set; }
Public Property SelectedQuantResultCategory As QuantResultCategory
    Get
    Set
public:
property QuantResultCategory SelectedQuantResultCategory {
    QuantResultCategory get ();
    void set (QuantResultCategory value);
}
member SelectedQuantResultCategory : QuantResultCategory with get, set

Property Value

Type: QuantResultCategory
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.SelectedQuantResultFormat Property

Gets or sets the selected quant result format.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public QuantResultFormat SelectedQuantResultFormat { get; set; }
Public Property SelectedQuantResultFormat As QuantResultFormat
    Get
    Set
public:
property QuantResultFormat SelectedQuantResultFormat {
    QuantResultFormat get ();
    void set (QuantResultFormat value);
}
member SelectedQuantResultFormat : QuantResultFormat with get, set

Property Value

Type: QuantResultFormat
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ShowLegend Property

Gets or sets a value indicating whether to show or hide the legend.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowLegend { get; set; }
Public Property ShowLegend As Boolean
    Get
    Set
public:
property bool ShowLegend {
    bool get ();
    void set (bool value);
}
member ShowLegend : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ShowNormalizationRegion Property

Gets or sets a value indicating whether to show or hide the normalization region.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowNormalizationRegion { get; set; }
Public Property ShowNormalizationRegion As Boolean
    Get
    Set
public:
property bool ShowNormalizationRegion {
    bool get ();
    void set (bool value);
}
member ShowNormalizationRegion : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ShowPeakLabels Property

Gets or sets a value indicating whether to show or hide labels for identified peaks in the spectrum.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowPeakLabels { get; set; }
Public Property ShowPeakLabels As Boolean
    Get
    Set
public:
property bool ShowPeakLabels {
    bool get ();
    void set (bool value);
}
member ShowPeakLabels : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ShowQuantResults Property

Gets or sets a value indicating whether to show or hide the quant results.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowQuantResults { get; set; }
Public Property ShowQuantResults As Boolean
    Get
    Set
public:
property bool ShowQuantResults {
    bool get ();
    void set (bool value);
}
member ShowQuantResults : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.Spectrum Property

Gets or sets the spectrum viewed in the control.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public IEdSpectrum Spectrum { get; set; }
Public Property Spectrum As IEdSpectrum
    Get
    Set
public:
property IEdSpectrum^ Spectrum {
    IEdSpectrum^ get ();
    void set (IEdSpectrum^ value);
}
member Spectrum : IEdSpectrum with get, set

Property Value

Type: IEdSpectrum
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.YAxisType Property

Gets or sets the y-axis scale as Linear or Logarithmic.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ScaleType YAxisType { get; set; }
Public Property YAxisType As ScaleType
    Get
    Set
public:
property ScaleType YAxisType {
    ScaleType get ();
    void set (ScaleType value);
}
member YAxisType : ScaleType with get, set

Property Value

Type: ScaleType
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.YAxisUnits Property

Gets or sets the y-axis units.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public SpectrumUnit YAxisUnits { get; set; }
Public Property YAxisUnits As SpectrumUnit
    Get
    Set
public:
property SpectrumUnit YAxisUnits {
    SpectrumUnit get ();
    void set (SpectrumUnit value);
}
member YAxisUnits : SpectrumUnit with get, set

Property Value

Type: SpectrumUnit
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer Methods

The SpectrumViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddComparisonSpectrum | Adds an additional spectrum to the viewer for comparison.
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearComparisonSpectra | Removes all spectra that have been added for comparison.
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateImage(ExportImageType) | Creates an image of the spectrum viewer control.
Public method | CreateImage(ExportImageType, Int32, Int32) | Creates an image of the spectrum viewer control.
Public method | CreateImage(ExportImageType, Int32, Int32, TiffCompressOption) | Creates an image of the spectrum viewer control.
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged(DependencyPropertyChangedEventArgs) | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnPropertyChanged(PropertyChangedEventArgs) | Handle property changed event
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveCompareSpectrum | Removes a spectrum that has been added for comparison.
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SEMQuantify | Quantifies the current spectrum using the provided SEM quant settings and displays the results if ShowQuantResults is true.
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.AddComparisonSpectrum Method

Adds an additional spectrum to the viewer for comparison.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void AddComparisonSpectrum(
    IEdSpectrum spectrum,
    Color spectrumColor
)
Public Sub AddComparisonSpectrum (
    spectrum As IEdSpectrum,
    spectrumColor As Color
)
public:
void AddComparisonSpectrum(
    IEdSpectrum^ spectrum,
    Color spectrumColor
)
member AddComparisonSpectrum :
        spectrum : IEdSpectrum *
        spectrumColor : Color -> unit

Parameters

spectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The spectrum.
spectrumColor
Type: System.Windows.MediaColor
Color of the spectrum.
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ClearComparisonSpectra Method

Removes all spectra that have been added for comparison.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void ClearComparisonSpectra()
Public Sub ClearComparisonSpectra
public:
void ClearComparisonSpectra()
member ClearComparisonSpectra : unit -> unit
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.CreateImage Method

Overload List
 | Name | Description
Public method | CreateImage(ExportImageType) | Creates an image of the spectrum viewer control.
Public method | CreateImage(ExportImageType, Int32, Int32) | Creates an image of the spectrum viewer control.
Public method | CreateImage(ExportImageType, Int32, Int32, TiffCompressOption) | Creates an image of the spectrum viewer control.
Top
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.CreateImage Method (ExportImageType)

Creates an image of the spectrum viewer control.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public byte[] CreateImage(
    ExportImageType imageType
)
Public Function CreateImage (
    imageType As ExportImageType
) As Byte()
public:
array<unsigned char>^ CreateImage(
    ExportImageType imageType
)
member CreateImage :
        imageType : ExportImageType -> byte[]

Parameters

imageType
Type: OINA.Extender.ControlsExportImageType
Type of the image.

Return Value

Type: Byte
The image byte array.
See Also

Reference

SpectrumViewer Class
CreateImage Overload
OINA.Extender.Controls Namespace


SpectrumViewer.CreateImage Method (ExportImageType, Int32, Int32)

Creates an image of the spectrum viewer control.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public byte[] CreateImage(
    ExportImageType imageType,
    int width,
    int height
)
Public Function CreateImage (
    imageType As ExportImageType,
    width As Integer,
    height As Integer
) As Byte()
public:
array<unsigned char>^ CreateImage(
    ExportImageType imageType,
    int width,
    int height
)
member CreateImage :
        imageType : ExportImageType *
        width : int *
        height : int -> byte[]

Parameters

imageType
Type: OINA.Extender.ControlsExportImageType
Type of the image.
width
Type: SystemInt32
The output width.
height
Type: SystemInt32
The output height.

Return Value

Type: Byte
The image byte array.
See Also

Reference

SpectrumViewer Class
CreateImage Overload
OINA.Extender.Controls Namespace


SpectrumViewer.CreateImage Method (ExportImageType, Int32, Int32, TiffCompressOption)

Creates an image of the spectrum viewer control.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public byte[] CreateImage(
    ExportImageType imageType,
    int width,
    int height,
    TiffCompressOption tiffCompressOption
)
Public Function CreateImage (
    imageType As ExportImageType,
    width As Integer,
    height As Integer,
    tiffCompressOption As TiffCompressOption
) As Byte()
public:
array<unsigned char>^ CreateImage(
    ExportImageType imageType,
    int width,
    int height,
    TiffCompressOption tiffCompressOption
)
member CreateImage :
        imageType : ExportImageType *
        width : int *
        height : int *
        tiffCompressOption : TiffCompressOption -> byte[]

Parameters

imageType
Type: OINA.Extender.ControlsExportImageType
Type of the image.
width
Type: SystemInt32
The output width.
height
Type: SystemInt32
The output height.
tiffCompressOption
Type: System.Windows.Media.ImagingTiffCompressOption
The tiff compression.

Return Value

Type: Byte
The image byte array.
See Also

Reference

SpectrumViewer Class
CreateImage Overload
OINA.Extender.Controls Namespace


SpectrumViewer.InitializeComponent Method

InitializeComponent

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void InitializeComponent()
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit

Implements

IComponentConnectorInitializeComponent
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.OnPropertyChanged Method

Overload List
 | Name | Description
Protected method | OnPropertyChanged(DependencyPropertyChangedEventArgs) | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnPropertyChanged(PropertyChangedEventArgs) | Handle property changed event
Top
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.OnPropertyChanged Method (PropertyChangedEventArgs)

Handle property changed event

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs eventArgs
)
Protected Overridable Sub OnPropertyChanged (
    eventArgs As PropertyChangedEventArgs
)
protected:
virtual void OnPropertyChanged(
    PropertyChangedEventArgs^ eventArgs
)
abstract OnPropertyChanged :
        eventArgs : PropertyChangedEventArgs -> unit
override OnPropertyChanged :
        eventArgs : PropertyChangedEventArgs -> unit

Parameters

eventArgs
Type: System.ComponentModelPropertyChangedEventArgs
The event arguments
See Also

Reference

SpectrumViewer Class
OnPropertyChanged Overload
OINA.Extender.Controls Namespace


SpectrumViewer.RemoveCompareSpectrum Method

Removes a spectrum that has been added for comparison.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void RemoveCompareSpectrum(
    Guid spectrumId
)
Public Sub RemoveCompareSpectrum (
    spectrumId As Guid
)
public:
void RemoveCompareSpectrum(
    Guid spectrumId
)
member RemoveCompareSpectrum :
        spectrumId : Guid -> unit

Parameters

spectrumId
Type: SystemGuid
The spectrum identifier.
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.SEMQuantify Method

Quantifies the current spectrum using the provided SEM quant settings and displays the results if ShowQuantResults is true.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ISEMQuantStatus SEMQuantify(
    ISEMQuantSettings settings
)
Public Function SEMQuantify (
    settings As ISEMQuantSettings
) As ISEMQuantStatus
public:
ISEMQuantStatus^ SEMQuantify(
    ISEMQuantSettings^ settings
)
member SEMQuantify :
        settings : ISEMQuantSettings -> ISEMQuantStatus

Parameters

settings
Type: OINA.Extender.Processing.QuantISEMQuantSettings
The settings.

Return Value

Type: ISEMQuantStatus
The SEM quant status.
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer Events

The SpectrumViewer type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | The property changed event.
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | SpectrumClicked | Occurs when the spectrum is clicked.
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.PropertyChanged Event

The property changed event.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.SpectrumClicked Event

Occurs when the spectrum is clicked.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<SpectrumClickedEventArgs> SpectrumClicked
Public Event SpectrumClicked As EventHandler(Of SpectrumClickedEventArgs)
public:
 event EventHandler<SpectrumClickedEventArgs^>^ SpectrumClicked {
    void add (EventHandler<SpectrumClickedEventArgs^>^ value);
    void remove (EventHandler<SpectrumClickedEventArgs^>^ value);
}
member SpectrumClicked : IEvent<EventHandler<SpectrumClickedEventArgs>,
    SpectrumClickedEventArgs>

Value

Type: SystemEventHandler SpectrumClickedEventArgs
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer Fields

The SpectrumViewer type exposes the following members.

Fields
Name | Description
DeletePeakLabelCommand | The DeletePeakLabelCommand command removes the peak label passed as the command parameter from its containing spectrum.
DrawStyleProperty | The Dependency Property for binding to the DrawStyle property.
EnergyWindowsSourceProperty | The Dependency Property for binding to the EnergyWindowsSource property.
ExportEMSACommand | Command for exporting the spectrum in EMSA format.
ExportImageCopyCommand | Command for copying the spectrum to the clipboard.
ExportImageSaveCommand | Command for saving the spectrum as an image.
InteractionToolProperty | The Dependency Property for binding to the InteractionTool property.
IsAltYAxisVisibleProperty | The Dependency Property for binding to the IsYAxisVisible property.
IsNormalizationEnabledProperty | The Dependency Property for binding to the IsNormalizationEnabled property.
IsXAxisAutoScaleEnabledProperty | The Dependency Property for binding to the IsXAxisAutoScaleEnabled property.
IsXAxisLockedProperty | The Dependency Property for binding to the IsXAxisLocked property.
IsXAxisVisibleProperty | The Dependency Property for binding to the IsXAxisVisible property.
IsYAxisAutoScaleEnabledProperty | The Dependency Property for binding to the IsYAxisAutoScaleEnabled property.
IsYAxisLockedProperty | The Dependency Property for binding to the IsYAxisLocked property.
IsYAxisVisibleProperty | The Dependency Property for binding to the IsYAxisVisible property.
MarkersElementProperty | The Dependency Property for binding to the MarkersElement property.
MaximumCountsPerSecondProperty | The Dependency Property for binding to the MaximumCountsPerSecond property.
MaximumEnergyProperty | The Dependency Property for binding to the MaximumEnergy property.
MaximumUpperLimitProperty | The Dependency Property for binding to the MaximumUpperLimit property.
MinimumEnergyProperty | The Dependency Property for binding to the MinimumEnergy property.
NoisePeakCutoffEnergyProperty | The Dependency Property for binding to the NoisePeakCutoffEnergy property.
NoisePeakModeProperty | The Dependency Property for binding to the NoisePeakMode property.
NormalizationEnergyProperty | The Dependency Property for binding to the NormalizationEnergy property.
NormalizationWindowWidthProperty | The Dependency Property for binding to the NormalizationWindowWidth property.
ResetPeakLabelPositionsCommand | Command for re-setting peak label positions.
ResetScalesCommand | Command for rescaling the spectrum to fit the viewer.
SelectedQuantResultCategoryProperty | The Dependency Property for binding to the SelectedQuantResultCategory property.
SelectedQuantResultFormatProperty | The Dependency Property for binding to the SelectedQuantResultFormat property.
SetDrawStyleCommand | Command for setting the draw style of the spectrum visuals.
SetYAxisTypeCommand | Command for setting the y-axis type.
SetYAxisUnitsCommand | Command for setting the y-axis units.
ShowLegendProperty | The Dependency Property for binding to the ShowLegend property.
ShowNormalizationRegionProperty | The Dependency Property for binding to the ShowNormalizationRegion property.
ShowPeakLabelsProperty | The Dependency Property for binding to the ShowPeakLabels property.
ShowQuantResultsProperty | The Dependency Property for binding to the ShowQuantResults property.
ShowSpectrumDetailsCommand | Command for showing the spectrum details window.
SpectrumClickedEvent | The Routed Event for the SpectrumClicked event.
SpectrumProperty | The Dependency Property for binding to the Spectrum property.
YAxisTypeProperty | The Dependency Property for binding to the YAxisType property.
YAxisUnitsProperty | The Dependency Property for binding to the YAxisUnits property.
Top
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.DeletePeakLabelCommand Field

The DeletePeakLabelCommand command removes the peak label passed as the command parameter from its containing spectrum.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand DeletePeakLabelCommand
Public Shared ReadOnly DeletePeakLabelCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ DeletePeakLabelCommand
static val DeletePeakLabelCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.DrawStyleProperty Field

The Dependency Property for binding to the DrawStyle property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty DrawStyleProperty
Public Shared ReadOnly DrawStyleProperty As DependencyProperty
public:
static initonly DependencyProperty^ DrawStyleProperty
static val DrawStyleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.EnergyWindowsSourceProperty Field

The Dependency Property for binding to the EnergyWindowsSource property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty EnergyWindowsSourceProperty
Public Shared ReadOnly EnergyWindowsSourceProperty As DependencyProperty
public:
static initonly DependencyProperty^ EnergyWindowsSourceProperty
static val EnergyWindowsSourceProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ExportEMSACommand Field

Command for exporting the spectrum in EMSA format.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand ExportEMSACommand
Public Shared ReadOnly ExportEMSACommand As RoutedUICommand
public:
static initonly RoutedUICommand^ ExportEMSACommand
static val ExportEMSACommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ExportImageCopyCommand Field

Command for copying the spectrum to the clipboard.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedCommand ExportImageCopyCommand
Public Shared ReadOnly ExportImageCopyCommand As RoutedCommand
public:
static initonly RoutedCommand^ ExportImageCopyCommand
static val ExportImageCopyCommand: RoutedCommand

Field Value

Type: RoutedCommand
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ExportImageSaveCommand Field

Command for saving the spectrum as an image.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedCommand ExportImageSaveCommand
Public Shared ReadOnly ExportImageSaveCommand As RoutedCommand
public:
static initonly RoutedCommand^ ExportImageSaveCommand
static val ExportImageSaveCommand: RoutedCommand

Field Value

Type: RoutedCommand
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.InteractionToolProperty Field

The Dependency Property for binding to the InteractionTool property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty InteractionToolProperty
Public Shared ReadOnly InteractionToolProperty As DependencyProperty
public:
static initonly DependencyProperty^ InteractionToolProperty
static val InteractionToolProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsAltYAxisVisibleProperty Field

The Dependency Property for binding to the IsYAxisVisible property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsAltYAxisVisibleProperty
Public Shared ReadOnly IsAltYAxisVisibleProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsAltYAxisVisibleProperty
static val IsAltYAxisVisibleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsNormalizationEnabledProperty Field

The Dependency Property for binding to the IsNormalizationEnabled property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsNormalizationEnabledProperty
Public Shared ReadOnly IsNormalizationEnabledProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsNormalizationEnabledProperty
static val IsNormalizationEnabledProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsXAxisAutoScaleEnabledProperty Field

The Dependency Property for binding to the IsXAxisAutoScaleEnabled property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsXAxisAutoScaleEnabledProperty
Public Shared ReadOnly IsXAxisAutoScaleEnabledProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsXAxisAutoScaleEnabledProperty
static val IsXAxisAutoScaleEnabledProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsXAxisLockedProperty Field

The Dependency Property for binding to the IsXAxisLocked property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsXAxisLockedProperty
Public Shared ReadOnly IsXAxisLockedProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsXAxisLockedProperty
static val IsXAxisLockedProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsXAxisVisibleProperty Field

The Dependency Property for binding to the IsXAxisVisible property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsXAxisVisibleProperty
Public Shared ReadOnly IsXAxisVisibleProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsXAxisVisibleProperty
static val IsXAxisVisibleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsYAxisAutoScaleEnabledProperty Field

The Dependency Property for binding to the IsYAxisAutoScaleEnabled property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsYAxisAutoScaleEnabledProperty
Public Shared ReadOnly IsYAxisAutoScaleEnabledProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsYAxisAutoScaleEnabledProperty
static val IsYAxisAutoScaleEnabledProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsYAxisLockedProperty Field

The Dependency Property for binding to the IsYAxisLocked property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsYAxisLockedProperty
Public Shared ReadOnly IsYAxisLockedProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsYAxisLockedProperty
static val IsYAxisLockedProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.IsYAxisVisibleProperty Field

The Dependency Property for binding to the IsYAxisVisible property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsYAxisVisibleProperty
Public Shared ReadOnly IsYAxisVisibleProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsYAxisVisibleProperty
static val IsYAxisVisibleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.MarkersElementProperty Field

The Dependency Property for binding to the MarkersElement property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty MarkersElementProperty
Public Shared ReadOnly MarkersElementProperty As DependencyProperty
public:
static initonly DependencyProperty^ MarkersElementProperty
static val MarkersElementProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.MaximumCountsPerSecondProperty Field

The Dependency Property for binding to the MaximumCountsPerSecond property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty MaximumCountsPerSecondProperty
Public Shared ReadOnly MaximumCountsPerSecondProperty As DependencyProperty
public:
static initonly DependencyProperty^ MaximumCountsPerSecondProperty
static val MaximumCountsPerSecondProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.MaximumEnergyProperty Field

The Dependency Property for binding to the MaximumEnergy property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty MaximumEnergyProperty
Public Shared ReadOnly MaximumEnergyProperty As DependencyProperty
public:
static initonly DependencyProperty^ MaximumEnergyProperty
static val MaximumEnergyProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.MaximumUpperLimitProperty Field

The Dependency Property for binding to the MaximumUpperLimit property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty MaximumUpperLimitProperty
Public Shared ReadOnly MaximumUpperLimitProperty As DependencyProperty
public:
static initonly DependencyProperty^ MaximumUpperLimitProperty
static val MaximumUpperLimitProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.MinimumEnergyProperty Field

The Dependency Property for binding to the MinimumEnergy property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty MinimumEnergyProperty
Public Shared ReadOnly MinimumEnergyProperty As DependencyProperty
public:
static initonly DependencyProperty^ MinimumEnergyProperty
static val MinimumEnergyProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.NoisePeakCutoffEnergyProperty Field

The Dependency Property for binding to the NoisePeakCutoffEnergy property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty NoisePeakCutoffEnergyProperty
Public Shared ReadOnly NoisePeakCutoffEnergyProperty As DependencyProperty
public:
static initonly DependencyProperty^ NoisePeakCutoffEnergyProperty
static val NoisePeakCutoffEnergyProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.NoisePeakModeProperty Field

The Dependency Property for binding to the NoisePeakMode property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty NoisePeakModeProperty
Public Shared ReadOnly NoisePeakModeProperty As DependencyProperty
public:
static initonly DependencyProperty^ NoisePeakModeProperty
static val NoisePeakModeProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.NormalizationEnergyProperty Field

The Dependency Property for binding to the NormalizationEnergy property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty NormalizationEnergyProperty
Public Shared ReadOnly NormalizationEnergyProperty As DependencyProperty
public:
static initonly DependencyProperty^ NormalizationEnergyProperty
static val NormalizationEnergyProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.NormalizationWindowWidthProperty Field

The Dependency Property for binding to the NormalizationWindowWidth property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty NormalizationWindowWidthProperty
Public Shared ReadOnly NormalizationWindowWidthProperty As DependencyProperty
public:
static initonly DependencyProperty^ NormalizationWindowWidthProperty
static val NormalizationWindowWidthProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ResetPeakLabelPositionsCommand Field

Command for re-setting peak label positions.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand ResetPeakLabelPositionsCommand
Public Shared ReadOnly ResetPeakLabelPositionsCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ ResetPeakLabelPositionsCommand
static val ResetPeakLabelPositionsCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ResetScalesCommand Field

Command for rescaling the spectrum to fit the viewer.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand ResetScalesCommand
Public Shared ReadOnly ResetScalesCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ ResetScalesCommand
static val ResetScalesCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.SelectedQuantResultCategoryProperty Field

The Dependency Property for binding to the SelectedQuantResultCategory property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty SelectedQuantResultCategoryProperty
Public Shared ReadOnly SelectedQuantResultCategoryProperty As DependencyProperty
public:
static initonly DependencyProperty^ SelectedQuantResultCategoryProperty
static val SelectedQuantResultCategoryProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.SelectedQuantResultFormatProperty Field

The Dependency Property for binding to the SelectedQuantResultFormat property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty SelectedQuantResultFormatProperty
Public Shared ReadOnly SelectedQuantResultFormatProperty As DependencyProperty
public:
static initonly DependencyProperty^ SelectedQuantResultFormatProperty
static val SelectedQuantResultFormatProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.SetDrawStyleCommand Field

Command for setting the draw style of the spectrum visuals.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedCommand SetDrawStyleCommand
Public Shared ReadOnly SetDrawStyleCommand As RoutedCommand
public:
static initonly RoutedCommand^ SetDrawStyleCommand
static val SetDrawStyleCommand: RoutedCommand

Field Value

Type: RoutedCommand
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.SetYAxisTypeCommand Field

Command for setting the y-axis type.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedCommand SetYAxisTypeCommand
Public Shared ReadOnly SetYAxisTypeCommand As RoutedCommand
public:
static initonly RoutedCommand^ SetYAxisTypeCommand
static val SetYAxisTypeCommand: RoutedCommand

Field Value

Type: RoutedCommand
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.SetYAxisUnitsCommand Field

Command for setting the y-axis units.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedCommand SetYAxisUnitsCommand
Public Shared ReadOnly SetYAxisUnitsCommand As RoutedCommand
public:
static initonly RoutedCommand^ SetYAxisUnitsCommand
static val SetYAxisUnitsCommand: RoutedCommand

Field Value

Type: RoutedCommand
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ShowLegendProperty Field

The Dependency Property for binding to the ShowLegend property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowLegendProperty
Public Shared ReadOnly ShowLegendProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowLegendProperty
static val ShowLegendProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ShowNormalizationRegionProperty Field

The Dependency Property for binding to the ShowNormalizationRegion property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowNormalizationRegionProperty
Public Shared ReadOnly ShowNormalizationRegionProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowNormalizationRegionProperty
static val ShowNormalizationRegionProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ShowPeakLabelsProperty Field

The Dependency Property for binding to the ShowPeakLabels property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowPeakLabelsProperty
Public Shared ReadOnly ShowPeakLabelsProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowPeakLabelsProperty
static val ShowPeakLabelsProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ShowQuantResultsProperty Field

The Dependency Property for binding to the ShowQuantResults property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowQuantResultsProperty
Public Shared ReadOnly ShowQuantResultsProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowQuantResultsProperty
static val ShowQuantResultsProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.ShowSpectrumDetailsCommand Field

Command for showing the spectrum details window.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedUICommand ShowSpectrumDetailsCommand
Public Shared ReadOnly ShowSpectrumDetailsCommand As RoutedUICommand
public:
static initonly RoutedUICommand^ ShowSpectrumDetailsCommand
static val ShowSpectrumDetailsCommand: RoutedUICommand

Field Value

Type: RoutedUICommand
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.SpectrumClickedEvent Field

The Routed Event for the SpectrumClicked event.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly RoutedEvent SpectrumClickedEvent
Public Shared ReadOnly SpectrumClickedEvent As RoutedEvent
public:
static initonly RoutedEvent^ SpectrumClickedEvent
static val SpectrumClickedEvent: RoutedEvent

Field Value

Type: RoutedEvent
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.SpectrumProperty Field

The Dependency Property for binding to the Spectrum property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty SpectrumProperty
Public Shared ReadOnly SpectrumProperty As DependencyProperty
public:
static initonly DependencyProperty^ SpectrumProperty
static val SpectrumProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.YAxisTypeProperty Field

The Dependency Property for binding to the YAxisType property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty YAxisTypeProperty
Public Shared ReadOnly YAxisTypeProperty As DependencyProperty
public:
static initonly DependencyProperty^ YAxisTypeProperty
static val YAxisTypeProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


SpectrumViewer.YAxisUnitsProperty Field

The Dependency Property for binding to the YAxisUnits property.

Namespace: OINA.Extender.Controls
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty YAxisUnitsProperty
Public Shared ReadOnly YAxisUnitsProperty As DependencyProperty
public:
static initonly DependencyProperty^ YAxisUnitsProperty
static val YAxisUnitsProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewer Class
OINA.Extender.Controls Namespace


OINA.Extender.Controls.Common Namespace

Defines all Classes, Interfaces and definitions common across all Extender Visual Controls.

OINA Extender Controls Common Namespace

Enumerations
 | Enumeration | Description
Public enumeration | ElementComboDisplayFormat | The format of the ElementCombo control label.
Public enumeration | ElementInclusionState | Include/exclude element from identification process.
Public enumeration | ExportFormat | The file format for the exported image.


ElementComboDisplayFormat Enumeration

The format of the ElementCombo control label.

Namespace: OINA.Extender.Controls.Common
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum ElementComboDisplayFormat
Public Enumeration ElementComboDisplayFormat
public enum class ElementComboDisplayFormat
type ElementComboDisplayFormat
Members
Member name | Value | Description
ShowName | 0 | Displays the Element name.
ShowSymbol | 1 | Displays the Element symbol.
See Also

Reference

OINA.Extender.Controls.Common Namespace


ElementInclusionState Enumeration

Include/exclude element from identification process.

Namespace: OINA.Extender.Controls.Common
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum ElementInclusionState
Public Enumeration ElementInclusionState
public enum class ElementInclusionState
type ElementInclusionState
Members
Member name | Value | Description
Unset | 0 | Element has not yet been included/excluded
Included | 1 | Include this element when identifying peaks in the spectrum.
Excluded | 2 | Exclude this element when identifying peaks in the spectrum.
See Also

Reference

OINA.Extender.Controls.Common Namespace


ExportFormat Enumeration

The file format for the exported image.

Namespace: OINA.Extender.Controls.Common
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum ExportFormat
Public Enumeration ExportFormat
public enum class ExportFormat
type ExportFormat
Members
Member name | Value | Description
None | 0 |
bmp | 1 | A bitmap image.
gif | 2 | Graphics Interchange Format. A bitmap image.
jpeg | 3 | Joint Photographic Experts Group (JPEG). A compressed image.
png | 4 | Portable Network Graphics (PNG). A raster image.
tiff | 5 | Tagged Image File Format (TIFF). A raster image.
wmp | 6 | Windows Media Player (WMP). A video file.
See Also

Reference

OINA.Extender.Controls.Common Namespace


OINA.Extender.Controls.Image Namespace

Defines all Classes, Interfaces and definitions common to the Image Viewer Control.

Classes
 | Class | Description
Public class | EdMapImageDetailsView | Interaction logic for EdMapImageDetails.xaml
Public class | ImageDetails | A Class that provides information about the image.
Public class | ImageViewerContextMenu | Used to customize the context menu for the image viewer control. Where a property to set the visibility of a menu item does not exist, its visibility will be determined by the visibility of its descendants.
Enumerations
 | Enumeration | Description
Public enumeration | ImageInteractionTool | Options for image interaction.


EdMapImageDetailsView Class

Interaction logic for EdMapImageDetails.xaml
EdMapImageDetailsView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
OINA.Extender.Controls.ImageEdMapImageDetailsView

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class EdMapImageDetailsView : Window,
    INotifyPropertyChanged, IComponentConnector
Public Class EdMapImageDetailsView
    Inherits Window
    Implements INotifyPropertyChanged, IComponentConnector
public ref class EdMapImageDetailsView : public Window,
    INotifyPropertyChanged, IComponentConnector
type EdMapImageDetailsView =
    class
        inherit Window
        interface INotifyPropertyChanged
        interface IComponentConnector
    end

The EdMapImageDetailsView type exposes the following members.

Constructors
 | Name | Description
Public method | EdMapImageDetailsView | Initializes a new instance of the EdMapImageDetailsView class.
Top
Properties
 | Name | Description
Public property | AcceleratingVoltage | Gets the accelerating voltage in kV
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BinningFactor | Gets the binning factor
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DateCreated | Gets the date the image was created
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DwellTimePerPixelMicroseconds | Gets the dwell time for each pixel in microseconds
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | EffectiveMagnificationWithZoom | Gets the effective magnification used for an image if digital zoom (for drift correction) is included.
Public property | EnergyRange | Gets the energy range in keV
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Public property | ImageHeight | Gets the image height in mm
Public property | ImageIcon | Gets the image icon
Public property | ImageWidth | Gets the image width in mm
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Label | Gets the label, a user defined string for naming the image.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | Maximum | Gets the maximum value in the image in cps
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NumberOfChannels | Gets the number of channels
Public property | NumberOfFrames | Gets the number of frames
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PrimaryDetectorSerialNumber | Gets the primary detector serial number
Public property | ProcessTime | Gets the process time
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | ResolutionHeight | Gets the height of the image in pixels
Public property | ResolutionWidth | Gets the width of the image in pixels
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | SecondaryDetectorSerialNumbers | Gets the secondary detector serial numbers
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SmoothingLevel | Gets the smoothing level
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StageRotate | Gets the stage rotate in degrees
Public property | StageTilt | Gets the stage tilt in degrees
Public property | StageX | Gets the stage X position in mm
Public property | StageY | Gets the stage Y position in mm
Public property | StageZ | Gets the stage Z position in mm
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | WorkingDistance | Gets the working distance in mm
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of this Window object is modified. (Inherited from Window.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView Constructor

Initializes a new instance of the EdMapImageDetailsView class.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public EdMapImageDetailsView(
    IEdMapImage imageData
)
Public Sub New (
    imageData As IEdMapImage
)
public:
EdMapImageDetailsView(
    IEdMapImage^ imageData
)
new :
        imageData : IEdMapImage -> EdMapImageDetailsView

Parameters

imageData
Type: OINA.Extender.Data.ImageIEdMapImage
The image shown in the ImageViewer
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView Properties

The EdMapImageDetailsView type exposes the following members.

Properties
 | Name | Description
Public property | AcceleratingVoltage | Gets the accelerating voltage in kV
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BinningFactor | Gets the binning factor
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DateCreated | Gets the date the image was created
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DwellTimePerPixelMicroseconds | Gets the dwell time for each pixel in microseconds
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | EffectiveMagnificationWithZoom | Gets the effective magnification used for an image if digital zoom (for drift correction) is included.
Public property | EnergyRange | Gets the energy range in keV
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Public property | ImageHeight | Gets the image height in mm
Public property | ImageIcon | Gets the image icon
Public property | ImageWidth | Gets the image width in mm
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Label | Gets the label, a user defined string for naming the image.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | Maximum | Gets the maximum value in the image in cps
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NumberOfChannels | Gets the number of channels
Public property | NumberOfFrames | Gets the number of frames
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PrimaryDetectorSerialNumber | Gets the primary detector serial number
Public property | ProcessTime | Gets the process time
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | ResolutionHeight | Gets the height of the image in pixels
Public property | ResolutionWidth | Gets the width of the image in pixels
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | SecondaryDetectorSerialNumbers | Gets the secondary detector serial numbers
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SmoothingLevel | Gets the smoothing level
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StageRotate | Gets the stage rotate in degrees
Public property | StageTilt | Gets the stage tilt in degrees
Public property | StageX | Gets the stage X position in mm
Public property | StageY | Gets the stage Y position in mm
Public property | StageZ | Gets the stage Z position in mm
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | WorkingDistance | Gets the working distance in mm
Top
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.AcceleratingVoltage Property

Gets the accelerating voltage in kV

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string AcceleratingVoltage { get; }
Public ReadOnly Property AcceleratingVoltage As String
    Get
public:
property String^ AcceleratingVoltage {
    String^ get ();
}
member AcceleratingVoltage : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.BinningFactor Property

Gets the binning factor

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string BinningFactor { get; }
Public ReadOnly Property BinningFactor As String
    Get
public:
property String^ BinningFactor {
    String^ get ();
}
member BinningFactor : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.DateCreated Property

Gets the date the image was created

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string DateCreated { get; }
Public ReadOnly Property DateCreated As String
    Get
public:
property String^ DateCreated {
    String^ get ();
}
member DateCreated : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.DwellTimePerPixelMicroseconds Property

Gets the dwell time for each pixel in microseconds

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string DwellTimePerPixelMicroseconds { get; }
Public ReadOnly Property DwellTimePerPixelMicroseconds As String
    Get
public:
property String^ DwellTimePerPixelMicroseconds {
    String^ get ();
}
member DwellTimePerPixelMicroseconds : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.EffectiveMagnificationWithZoom Property

Gets the effective magnification used for an image if digital zoom (for drift correction) is included.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string EffectiveMagnificationWithZoom { get; }
Public ReadOnly Property EffectiveMagnificationWithZoom As String
    Get
public:
property String^ EffectiveMagnificationWithZoom {
    String^ get ();
}
member EffectiveMagnificationWithZoom : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.EnergyRange Property

Gets the energy range in keV

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string EnergyRange { get; }
Public ReadOnly Property EnergyRange As String
    Get
public:
property String^ EnergyRange {
    String^ get ();
}
member EnergyRange : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.ImageHeight Property

Gets the image height in mm

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string ImageHeight { get; }
Public ReadOnly Property ImageHeight As String
    Get
public:
property String^ ImageHeight {
    String^ get ();
}
member ImageHeight : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.ImageIcon Property

Gets the image icon

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Uri ImageIcon { get; }
Public ReadOnly Property ImageIcon As Uri
    Get
public:
property Uri^ ImageIcon {
    Uri^ get ();
}
member ImageIcon : Uri with get

Property Value

Type: Uri
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.ImageWidth Property

Gets the image width in mm

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string ImageWidth { get; }
Public ReadOnly Property ImageWidth As String
    Get
public:
property String^ ImageWidth {
    String^ get ();
}
member ImageWidth : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.Label Property

Gets the label, a user defined string for naming the image.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string Label { get; }
Public ReadOnly Property Label As String
    Get
public:
property String^ Label {
    String^ get ();
}
member Label : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.Maximum Property

Gets the maximum value in the image in cps

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string Maximum { get; }
Public ReadOnly Property Maximum As String
    Get
public:
property String^ Maximum {
    String^ get ();
}
member Maximum : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.NumberOfChannels Property

Gets the number of channels

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string NumberOfChannels { get; }
Public ReadOnly Property NumberOfChannels As String
    Get
public:
property String^ NumberOfChannels {
    String^ get ();
}
member NumberOfChannels : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.NumberOfFrames Property

Gets the number of frames

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string NumberOfFrames { get; }
Public ReadOnly Property NumberOfFrames As String
    Get
public:
property String^ NumberOfFrames {
    String^ get ();
}
member NumberOfFrames : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.PrimaryDetectorSerialNumber Property

Gets the primary detector serial number

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string PrimaryDetectorSerialNumber { get; }
Public ReadOnly Property PrimaryDetectorSerialNumber As String
    Get
public:
property String^ PrimaryDetectorSerialNumber {
    String^ get ();
}
member PrimaryDetectorSerialNumber : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.ProcessTime Property

Gets the process time

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string ProcessTime { get; }
Public ReadOnly Property ProcessTime As String
    Get
public:
property String^ ProcessTime {
    String^ get ();
}
member ProcessTime : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.ResolutionHeight Property

Gets the height of the image in pixels

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string ResolutionHeight { get; }
Public ReadOnly Property ResolutionHeight As String
    Get
public:
property String^ ResolutionHeight {
    String^ get ();
}
member ResolutionHeight : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.ResolutionWidth Property

Gets the width of the image in pixels

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string ResolutionWidth { get; }
Public ReadOnly Property ResolutionWidth As String
    Get
public:
property String^ ResolutionWidth {
    String^ get ();
}
member ResolutionWidth : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.SecondaryDetectorSerialNumbers Property

Gets the secondary detector serial numbers

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string SecondaryDetectorSerialNumbers { get; }
Public ReadOnly Property SecondaryDetectorSerialNumbers As String
    Get
public:
property String^ SecondaryDetectorSerialNumbers {
    String^ get ();
}
member SecondaryDetectorSerialNumbers : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.SmoothingLevel Property

Gets the smoothing level

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string SmoothingLevel { get; }
Public ReadOnly Property SmoothingLevel As String
    Get
public:
property String^ SmoothingLevel {
    String^ get ();
}
member SmoothingLevel : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.StageRotate Property

Gets the stage rotate in degrees

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string StageRotate { get; }
Public ReadOnly Property StageRotate As String
    Get
public:
property String^ StageRotate {
    String^ get ();
}
member StageRotate : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.StageTilt Property

Gets the stage tilt in degrees

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string StageTilt { get; }
Public ReadOnly Property StageTilt As String
    Get
public:
property String^ StageTilt {
    String^ get ();
}
member StageTilt : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.StageX Property

Gets the stage X position in mm

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string StageX { get; }
Public ReadOnly Property StageX As String
    Get
public:
property String^ StageX {
    String^ get ();
}
member StageX : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.StageY Property

Gets the stage Y position in mm

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string StageY { get; }
Public ReadOnly Property StageY As String
    Get
public:
property String^ StageY {
    String^ get ();
}
member StageY : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.StageZ Property

Gets the stage Z position in mm

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string StageZ { get; }
Public ReadOnly Property StageZ As String
    Get
public:
property String^ StageZ {
    String^ get ();
}
member StageZ : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.WorkingDistance Property

Gets the working distance in mm

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string WorkingDistance { get; }
Public ReadOnly Property WorkingDistance As String
    Get
public:
property String^ WorkingDistance {
    String^ get ();
}
member WorkingDistance : string with get

Property Value

Type: String
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView Methods

The EdMapImageDetailsView type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of this Window object is modified. (Inherited from Window.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.InitializeComponent Method

InitializeComponent

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void InitializeComponent()
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit

Implements

IComponentConnectorInitializeComponent
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView Events

The EdMapImageDetailsView type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


EdMapImageDetailsView.PropertyChanged Event

[Missing <summary> documentation for "E:OINA.Extender.Controls.Image.EdMapImageDetailsView.PropertyChanged"]

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

EdMapImageDetailsView Class
OINA.Extender.Controls.Image Namespace


ImageDetails Class

A Class that provides information about the image.
ImageDetails
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
OINA.Extender.Controls.ImageImageDetails

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class ImageDetails : Window,
    INotifyPropertyChanged, IComponentConnector
Public Class ImageDetails
    Inherits Window
    Implements INotifyPropertyChanged, IComponentConnector
public ref class ImageDetails : public Window,
    INotifyPropertyChanged, IComponentConnector
type ImageDetails =
    class
        inherit Window
        interface INotifyPropertyChanged
        interface IComponentConnector
    end

The ImageDetails type exposes the following members.

Constructors
 | Name | Description
Public method | ImageDetails | Initializes a new instance of the ImageDetails class.
Top
Properties
 | Name | Description
Public property | AcquisitionDate | Gets the image acquisition date
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DwellTimePerPixelMicroseconds | Gets the dwell time for each pixel in microseconds
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | EffectiveMagnificationWithZoom | Gets the effective magnification used for an image if digital zoom (for drift correction) is included.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FramesAveraged | Gets the number of averaged frames
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Public property | ImageHeight | Gets the viewable-image height in mm
Public property | ImageWidth | Gets the viewable-image width in mm
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | InputSource | Gets the image input source
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Label | Gets the label, a user defined string for naming the image.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | ResolutionHeight | Gets the height of the image in pixels
Public property | ResolutionWidth | Gets the width of the image in pixels
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpecimenTilt | Gets specimen tilt
Public property | StageTilt | Gets stage tilt
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | TiltCorrection | Gets software tilt correction
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of this Window object is modified. (Inherited from Window.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | PropertyChanged event
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

OINA.Extender.Controls.Image Namespace


ImageDetails Constructor

Initializes a new instance of the ImageDetails class.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ImageDetails(
    IElectronImage imageData
)
Public Sub New (
    imageData As IElectronImage
)
public:
ImageDetails(
    IElectronImage^ imageData
)
new :
        imageData : IElectronImage -> ImageDetails

Parameters

imageData
Type: OINA.Extender.Data.ImageIElectronImage
ElectronImage shown in the ImageViewer
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails Properties

The ImageDetails type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the image acquisition date
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DwellTimePerPixelMicroseconds | Gets the dwell time for each pixel in microseconds
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | EffectiveMagnificationWithZoom | Gets the effective magnification used for an image if digital zoom (for drift correction) is included.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FramesAveraged | Gets the number of averaged frames
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Public property | ImageHeight | Gets the viewable-image height in mm
Public property | ImageWidth | Gets the viewable-image width in mm
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | InputSource | Gets the image input source
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Label | Gets the label, a user defined string for naming the image.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | ResolutionHeight | Gets the height of the image in pixels
Public property | ResolutionWidth | Gets the width of the image in pixels
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpecimenTilt | Gets specimen tilt
Public property | StageTilt | Gets stage tilt
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | TiltCorrection | Gets software tilt correction
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.AcquisitionDate Property

Gets the image acquisition date

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string AcquisitionDate { get; }
Public ReadOnly Property AcquisitionDate As String
    Get
public:
property String^ AcquisitionDate {
    String^ get ();
}
member AcquisitionDate : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.DwellTimePerPixelMicroseconds Property

Gets the dwell time for each pixel in microseconds

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string DwellTimePerPixelMicroseconds { get; }
Public ReadOnly Property DwellTimePerPixelMicroseconds As String
    Get
public:
property String^ DwellTimePerPixelMicroseconds {
    String^ get ();
}
member DwellTimePerPixelMicroseconds : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.EffectiveMagnificationWithZoom Property

Gets the effective magnification used for an image if digital zoom (for drift correction) is included.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string EffectiveMagnificationWithZoom { get; }
Public ReadOnly Property EffectiveMagnificationWithZoom As String
    Get
public:
property String^ EffectiveMagnificationWithZoom {
    String^ get ();
}
member EffectiveMagnificationWithZoom : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.FramesAveraged Property

Gets the number of averaged frames

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string FramesAveraged { get; }
Public ReadOnly Property FramesAveraged As String
    Get
public:
property String^ FramesAveraged {
    String^ get ();
}
member FramesAveraged : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.ImageHeight Property

Gets the viewable-image height in mm

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string ImageHeight { get; }
Public ReadOnly Property ImageHeight As String
    Get
public:
property String^ ImageHeight {
    String^ get ();
}
member ImageHeight : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.ImageWidth Property

Gets the viewable-image width in mm

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string ImageWidth { get; }
Public ReadOnly Property ImageWidth As String
    Get
public:
property String^ ImageWidth {
    String^ get ();
}
member ImageWidth : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.InputSource Property

Gets the image input source

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string InputSource { get; }
Public ReadOnly Property InputSource As String
    Get
public:
property String^ InputSource {
    String^ get ();
}
member InputSource : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.Label Property

Gets the label, a user defined string for naming the image.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string Label { get; }
Public ReadOnly Property Label As String
    Get
public:
property String^ Label {
    String^ get ();
}
member Label : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.ResolutionHeight Property

Gets the height of the image in pixels

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string ResolutionHeight { get; }
Public ReadOnly Property ResolutionHeight As String
    Get
public:
property String^ ResolutionHeight {
    String^ get ();
}
member ResolutionHeight : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.ResolutionWidth Property

Gets the width of the image in pixels

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string ResolutionWidth { get; }
Public ReadOnly Property ResolutionWidth As String
    Get
public:
property String^ ResolutionWidth {
    String^ get ();
}
member ResolutionWidth : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.SpecimenTilt Property

Gets specimen tilt

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string SpecimenTilt { get; }
Public ReadOnly Property SpecimenTilt As String
    Get
public:
property String^ SpecimenTilt {
    String^ get ();
}
member SpecimenTilt : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.StageTilt Property

Gets stage tilt

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string StageTilt { get; }
Public ReadOnly Property StageTilt As String
    Get
public:
property String^ StageTilt {
    String^ get ();
}
member StageTilt : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.TiltCorrection Property

Gets software tilt correction

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string TiltCorrection { get; }
Public ReadOnly Property TiltCorrection As String
    Get
public:
property String^ TiltCorrection {
    String^ get ();
}
member TiltCorrection : string with get

Property Value

Type: String
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails Methods

The ImageDetails type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of this Window object is modified. (Inherited from Window.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.InitializeComponent Method

InitializeComponent

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void InitializeComponent()
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails Events

The ImageDetails type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | PropertyChanged event
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageDetails.PropertyChanged Event

PropertyChanged event

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ImageDetails Class
OINA.Extender.Controls.Image Namespace


ImageInteractionTool Enumeration

Options for image interaction.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum ImageInteractionTool
Public Enumeration ImageInteractionTool
public enum class ImageInteractionTool
type ImageInteractionTool
Members
Member name | Value | Description
Pan | 0 | Enables panning and zooming of the image (default).
Caliper | 1 | Creates a caliper annotation.
Angle | 2 | Creates an angle annotation.
Info | 3 | Gets the pixel co-ordinates and counts at the mouse position.
See Also

Reference

OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu Class

Used to customize the context menu for the image viewer control. Where a property to set the visibility of a menu item does not exist, its visibility will be determined by the visibility of its descendants.
ImageViewerContextMenu
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesMenuBase
System.Windows.ControlsContextMenu
OINA.Extender.Controls.ImageImageViewerContextMenu

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class ImageViewerContextMenu : ContextMenu,
    IComponentConnector
Public Class ImageViewerContextMenu
    Inherits ContextMenu
    Implements IComponentConnector
public ref class ImageViewerContextMenu : public ContextMenu,
    IComponentConnector
type ImageViewerContextMenu =
    class
        inherit ContextMenu
        interface IComponentConnector
    end

The ImageViewerContextMenu type exposes the following members.

Constructors
 | Name | Description
Public method | ImageViewerContextMenu | Initializes a new instance of the ImageViewerContextMenu class.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | CustomPopupPlacementCallback | Gets or sets a callback that indicates where a ContextMenu should be placed on the screen. (Inherited from ContextMenu.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the control supports scrolling. (Inherited from ContextMenu.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasDropShadow | Gets or sets a value that indicates whether the context menu appears with a dropped shadow. (Inherited from ContextMenu.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Get or sets the horizontal distance between the target origin and the popup alignment point. (Inherited from ContextMenu.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsColorBarItemVisible | Gets a value indicating whether the ‘Color Bar’ item is visible under the ‘View’ item in the context menu. This depends on the type of image displayed and the ShowColorBarItem property.
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets a value that indicates whether the ContextMenu is visible. (Inherited from ContextMenu.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | ItemContainerTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from MenuBase.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Placement | Gets or sets the Placement property of a ContextMenu. (Inherited from ContextMenu.)
Public property | PlacementRectangle | Gets or sets the area relative to which the context menu is positioned when it opens. (Inherited from ContextMenu.)
Public property | PlacementTarget | Gets or sets the UIElement relative to which the ContextMenu is positioned when it opens. (Inherited from ContextMenu.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ShowBrightnessContrastButtonsItem | Gets or sets a value indicating whether the ‘Show Contrast/Brightness Buttons’ item is visible under the ‘View’ item in the context menu.
Public property | ShowColorBarItem | Gets or sets a value indicating whether the ‘Color Bar’ item is visible under the ‘View’ item in the context menu.
Public property | ShowCopyItem | Gets or sets a value indicating whether the ‘Copy’ item is visible under the ‘Export’ item in the context menu.
Public property | ShowDetailsItem | Gets or sets a value indicating whether the ‘Details…’ item is visible in the context menu.
Public property | ShowFillDisplayWithImageItem | Gets or sets a value indicating whether the ‘Fill Display with Image’ item is visible under the ‘Rescale Image’ item in the context menu.
Public property | ShowFitImageToDisplayItem | Gets or sets a value indicating whether the ‘Fit Image to Display’ item is visible under the ‘Rescale Image’ item in the context menu.
Public property | ShowHeaderItem | Gets or sets a value indicating whether the ‘Header’ item is visible under the ‘View’ item in the context menu.
Public property | ShowSaveAsItem | Gets or sets a value indicating whether the ‘Save As…’ item is visible under the ‘Export’ item in the context menu.
Public property | ShowSaveAsOriginalItem | Gets or sets a value indicating whether the ‘Save As (original resolution)’ item is visible under the ‘Export’ item in the context menu.
Public property | ShowSaveRawTiffItem | Gets or sets a value indicating whether the ‘.TIFF’ item is visible under the ‘Export Data Only’ item in the context menu.
Public property | ShowSaveTSVOrCSVItem | Gets or sets a value indicating whether the ‘.TSV or .CSV’ item is visible under the ‘Export Data Only’ item in the context menu.
Public property | ShowScaleBarItem | Gets or sets a value indicating whether the ‘Scale Bar’ item is visible under the ‘View’ item in the context menu.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpen | Gets or sets a value that indicates whether the ContextMenu should close automatically. (Inherited from ContextMenu.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | UsesItemContainerTemplate | Gets or sets a value that indicates whether the menu selects different item containers, depending on the type of the item in the underlying collection or some other heuristic. (Inherited from MenuBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Get or sets the vertical distance between the target origin and the popup alignment point. (Inherited from ContextMenu.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from MenuBase.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HandleMouseButton | Called when a mouse button is pressed or released. (Inherited from MenuBase.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is, or is eligible to be, its own item container. (Inherited from MenuBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Called when the Closed event occurs. (Inherited from ContextMenu.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a ContextMenuAutomationPeer object for this ContextMenu. (Inherited from ContextMenu.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ContextMenu.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called when a KeyDown event is raised by an object inside the ContextMenu. (Inherited from ContextMenu.)
Protected method | OnKeyUp | Responds to the KeyUp event. (Inherited from ContextMenu.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves the control. (Inherited from MenuBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnOpened | Called when the Opened event occurs. (Inherited from ContextMenu.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when a context menu's visual parent changes. (Inherited from ContextMenu.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ContextMenu.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when a particular instance of a ContextMenu closes. (Inherited from ContextMenu.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | Opened | Occurs when a particular instance of a context menu opens. (Inherited from ContextMenu.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsColorBarItemVisibleProperty | The Dependency Property for binding to the IsColorBarItemVisible property.
ShowBrightnessContrastButtonsItemProperty | The Dependency Property for binding to the ShowBrightnessContrastButtonsItem property.
ShowColorBarItemProperty | The Dependency Property for binding to the ShowColorBarItem property.
ShowCopyItemProperty | The Dependency Property for binding to the ShowCopyItem property.
ShowDetailsItemProperty | The Dependency Property for binding to the ShowDetailsItem property.
ShowFillDisplayWithImageItemProperty | The Dependency Property for binding to the ShowFitImageToDisplayItem property.
ShowFitImageToDisplayItemProperty | The Dependency Property for binding to the ShowFitImageToDisplayItem property.
ShowHeaderItemProperty | The Dependency Property for binding to the ShowHeaderItem property.
ShowSaveAsItemProperty | The Dependency Property for binding to the ShowSaveAsItem property.
ShowSaveAsOriginalItemProperty | The Dependency Property for binding to the ShowSaveAsOriginalItem property.
ShowSaveRawTiffItemProperty | The Dependency Property for binding to the ShowSaveRawTiffItem property.
ShowSaveTSVOrCSVItemProperty | The Dependency Property for binding to the ShowSaveTSVOrCSVItem property.
ShowScaleBarItemProperty | The Dependency Property for binding to the ShowScaleBarItem property.
Top
See Also

Reference

OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu Constructor

Initializes a new instance of the ImageViewerContextMenu class.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ImageViewerContextMenu()
Public Sub New
public:
ImageViewerContextMenu()
new : unit -> ImageViewerContextMenu
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu Properties

The ImageViewerContextMenu type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | CustomPopupPlacementCallback | Gets or sets a callback that indicates where a ContextMenu should be placed on the screen. (Inherited from ContextMenu.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the control supports scrolling. (Inherited from ContextMenu.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasDropShadow | Gets or sets a value that indicates whether the context menu appears with a dropped shadow. (Inherited from ContextMenu.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Get or sets the horizontal distance between the target origin and the popup alignment point. (Inherited from ContextMenu.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsColorBarItemVisible | Gets a value indicating whether the ‘Color Bar’ item is visible under the ‘View’ item in the context menu. This depends on the type of image displayed and the ShowColorBarItem property.
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets a value that indicates whether the ContextMenu is visible. (Inherited from ContextMenu.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | ItemContainerTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from MenuBase.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Placement | Gets or sets the Placement property of a ContextMenu. (Inherited from ContextMenu.)
Public property | PlacementRectangle | Gets or sets the area relative to which the context menu is positioned when it opens. (Inherited from ContextMenu.)
Public property | PlacementTarget | Gets or sets the UIElement relative to which the ContextMenu is positioned when it opens. (Inherited from ContextMenu.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ShowBrightnessContrastButtonsItem | Gets or sets a value indicating whether the ‘Show Contrast/Brightness Buttons’ item is visible under the ‘View’ item in the context menu.
Public property | ShowColorBarItem | Gets or sets a value indicating whether the ‘Color Bar’ item is visible under the ‘View’ item in the context menu.
Public property | ShowCopyItem | Gets or sets a value indicating whether the ‘Copy’ item is visible under the ‘Export’ item in the context menu.
Public property | ShowDetailsItem | Gets or sets a value indicating whether the ‘Details…’ item is visible in the context menu.
Public property | ShowFillDisplayWithImageItem | Gets or sets a value indicating whether the ‘Fill Display with Image’ item is visible under the ‘Rescale Image’ item in the context menu.
Public property | ShowFitImageToDisplayItem | Gets or sets a value indicating whether the ‘Fit Image to Display’ item is visible under the ‘Rescale Image’ item in the context menu.
Public property | ShowHeaderItem | Gets or sets a value indicating whether the ‘Header’ item is visible under the ‘View’ item in the context menu.
Public property | ShowSaveAsItem | Gets or sets a value indicating whether the ‘Save As…’ item is visible under the ‘Export’ item in the context menu.
Public property | ShowSaveAsOriginalItem | Gets or sets a value indicating whether the ‘Save As (original resolution)’ item is visible under the ‘Export’ item in the context menu.
Public property | ShowSaveRawTiffItem | Gets or sets a value indicating whether the ‘.TIFF’ item is visible under the ‘Export Data Only’ item in the context menu.
Public property | ShowSaveTSVOrCSVItem | Gets or sets a value indicating whether the ‘.TSV or .CSV’ item is visible under the ‘Export Data Only’ item in the context menu.
Public property | ShowScaleBarItem | Gets or sets a value indicating whether the ‘Scale Bar’ item is visible under the ‘View’ item in the context menu.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpen | Gets or sets a value that indicates whether the ContextMenu should close automatically. (Inherited from ContextMenu.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | UsesItemContainerTemplate | Gets or sets a value that indicates whether the menu selects different item containers, depending on the type of the item in the underlying collection or some other heuristic. (Inherited from MenuBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Get or sets the vertical distance between the target origin and the popup alignment point. (Inherited from ContextMenu.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.IsColorBarItemVisible Property

Gets a value indicating whether the ‘Color Bar’ item is visible under the ‘View’ item in the context menu. This depends on the type of image displayed and the ShowColorBarItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool IsColorBarItemVisible { get; }
Public ReadOnly Property IsColorBarItemVisible As Boolean
    Get
public:
property bool IsColorBarItemVisible {
    bool get ();
}
member IsColorBarItemVisible : bool with get

Property Value

Type: Boolean
true if a color bar item is visible; otherwise, false.
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowBrightnessContrastButtonsItem Property

Gets or sets a value indicating whether the ‘Show Contrast/Brightness Buttons’ item is visible under the ‘View’ item in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowBrightnessContrastButtonsItem { get; set; }
Public Property ShowBrightnessContrastButtonsItem As Boolean
    Get
    Set
public:
property bool ShowBrightnessContrastButtonsItem {
    bool get ();
    void set (bool value);
}
member ShowBrightnessContrastButtonsItem : bool with get, set

Property Value

Type: Boolean
true if [show brightness contrast buttons]; otherwise, false.
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowColorBarItem Property

Gets or sets a value indicating whether the ‘Color Bar’ item is visible under the ‘View’ item in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowColorBarItem { get; set; }
Public Property ShowColorBarItem As Boolean
    Get
    Set
public:
property bool ShowColorBarItem {
    bool get ();
    void set (bool value);
}
member ShowColorBarItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowCopyItem Property

Gets or sets a value indicating whether the ‘Copy’ item is visible under the ‘Export’ item in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowCopyItem { get; set; }
Public Property ShowCopyItem As Boolean
    Get
    Set
public:
property bool ShowCopyItem {
    bool get ();
    void set (bool value);
}
member ShowCopyItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowDetailsItem Property

Gets or sets a value indicating whether the ‘Details…’ item is visible in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowDetailsItem { get; set; }
Public Property ShowDetailsItem As Boolean
    Get
    Set
public:
property bool ShowDetailsItem {
    bool get ();
    void set (bool value);
}
member ShowDetailsItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowFillDisplayWithImageItem Property

Gets or sets a value indicating whether the ‘Fill Display with Image’ item is visible under the ‘Rescale Image’ item in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowFillDisplayWithImageItem { get; set; }
Public Property ShowFillDisplayWithImageItem As Boolean
    Get
    Set
public:
property bool ShowFillDisplayWithImageItem {
    bool get ();
    void set (bool value);
}
member ShowFillDisplayWithImageItem : bool with get, set

Property Value

Type: Boolean
true if [show fill display with image item]; otherwise, false.
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowFitImageToDisplayItem Property

Gets or sets a value indicating whether the ‘Fit Image to Display’ item is visible under the ‘Rescale Image’ item in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowFitImageToDisplayItem { get; set; }
Public Property ShowFitImageToDisplayItem As Boolean
    Get
    Set
public:
property bool ShowFitImageToDisplayItem {
    bool get ();
    void set (bool value);
}
member ShowFitImageToDisplayItem : bool with get, set

Property Value

Type: Boolean
true if [show fit image to display item]; otherwise, false.
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowHeaderItem Property

Gets or sets a value indicating whether the ‘Header’ item is visible under the ‘View’ item in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowHeaderItem { get; set; }
Public Property ShowHeaderItem As Boolean
    Get
    Set
public:
property bool ShowHeaderItem {
    bool get ();
    void set (bool value);
}
member ShowHeaderItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowSaveAsItem Property

Gets or sets a value indicating whether the ‘Save As…’ item is visible under the ‘Export’ item in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowSaveAsItem { get; set; }
Public Property ShowSaveAsItem As Boolean
    Get
    Set
public:
property bool ShowSaveAsItem {
    bool get ();
    void set (bool value);
}
member ShowSaveAsItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowSaveAsOriginalItem Property

Gets or sets a value indicating whether the ‘Save As (original resolution)’ item is visible under the ‘Export’ item in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowSaveAsOriginalItem { get; set; }
Public Property ShowSaveAsOriginalItem As Boolean
    Get
    Set
public:
property bool ShowSaveAsOriginalItem {
    bool get ();
    void set (bool value);
}
member ShowSaveAsOriginalItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowSaveRawTiffItem Property

Gets or sets a value indicating whether the ‘.TIFF’ item is visible under the ‘Export Data Only’ item in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowSaveRawTiffItem { get; set; }
Public Property ShowSaveRawTiffItem As Boolean
    Get
    Set
public:
property bool ShowSaveRawTiffItem {
    bool get ();
    void set (bool value);
}
member ShowSaveRawTiffItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowSaveTSVOrCSVItem Property

Gets or sets a value indicating whether the ‘.TSV or .CSV’ item is visible under the ‘Export Data Only’ item in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowSaveTSVOrCSVItem { get; set; }
Public Property ShowSaveTSVOrCSVItem As Boolean
    Get
    Set
public:
property bool ShowSaveTSVOrCSVItem {
    bool get ();
    void set (bool value);
}
member ShowSaveTSVOrCSVItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowScaleBarItem Property

Gets or sets a value indicating whether the ‘Scale Bar’ item is visible under the ‘View’ item in the context menu.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowScaleBarItem { get; set; }
Public Property ShowScaleBarItem As Boolean
    Get
    Set
public:
property bool ShowScaleBarItem {
    bool get ();
    void set (bool value);
}
member ShowScaleBarItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu Methods

The ImageViewerContextMenu type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from MenuBase.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HandleMouseButton | Called when a mouse button is pressed or released. (Inherited from MenuBase.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is, or is eligible to be, its own item container. (Inherited from MenuBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Called when the Closed event occurs. (Inherited from ContextMenu.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a ContextMenuAutomationPeer object for this ContextMenu. (Inherited from ContextMenu.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ContextMenu.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called when a KeyDown event is raised by an object inside the ContextMenu. (Inherited from ContextMenu.)
Protected method | OnKeyUp | Responds to the KeyUp event. (Inherited from ContextMenu.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves the control. (Inherited from MenuBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnOpened | Called when the Opened event occurs. (Inherited from ContextMenu.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when a context menu's visual parent changes. (Inherited from ContextMenu.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ContextMenu.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.InitializeComponent Method

InitializeComponent

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void InitializeComponent()
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu Events

The ImageViewerContextMenu type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when a particular instance of a ContextMenu closes. (Inherited from ContextMenu.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | Opened | Occurs when a particular instance of a context menu opens. (Inherited from ContextMenu.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu Fields

The ImageViewerContextMenu type exposes the following members.

Fields
Name | Description
IsColorBarItemVisibleProperty | The Dependency Property for binding to the IsColorBarItemVisible property.
ShowBrightnessContrastButtonsItemProperty | The Dependency Property for binding to the ShowBrightnessContrastButtonsItem property.
ShowColorBarItemProperty | The Dependency Property for binding to the ShowColorBarItem property.
ShowCopyItemProperty | The Dependency Property for binding to the ShowCopyItem property.
ShowDetailsItemProperty | The Dependency Property for binding to the ShowDetailsItem property.
ShowFillDisplayWithImageItemProperty | The Dependency Property for binding to the ShowFitImageToDisplayItem property.
ShowFitImageToDisplayItemProperty | The Dependency Property for binding to the ShowFitImageToDisplayItem property.
ShowHeaderItemProperty | The Dependency Property for binding to the ShowHeaderItem property.
ShowSaveAsItemProperty | The Dependency Property for binding to the ShowSaveAsItem property.
ShowSaveAsOriginalItemProperty | The Dependency Property for binding to the ShowSaveAsOriginalItem property.
ShowSaveRawTiffItemProperty | The Dependency Property for binding to the ShowSaveRawTiffItem property.
ShowSaveTSVOrCSVItemProperty | The Dependency Property for binding to the ShowSaveTSVOrCSVItem property.
ShowScaleBarItemProperty | The Dependency Property for binding to the ShowScaleBarItem property.
Top
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.IsColorBarItemVisibleProperty Field

The Dependency Property for binding to the IsColorBarItemVisible property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty IsColorBarItemVisibleProperty
Public Shared ReadOnly IsColorBarItemVisibleProperty As DependencyProperty
public:
static initonly DependencyProperty^ IsColorBarItemVisibleProperty
static val IsColorBarItemVisibleProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowBrightnessContrastButtonsItemProperty Field

The Dependency Property for binding to the ShowBrightnessContrastButtonsItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowBrightnessContrastButtonsItemProperty
Public Shared ReadOnly ShowBrightnessContrastButtonsItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowBrightnessContrastButtonsItemProperty
static val ShowBrightnessContrastButtonsItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowColorBarItemProperty Field

The Dependency Property for binding to the ShowColorBarItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowColorBarItemProperty
Public Shared ReadOnly ShowColorBarItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowColorBarItemProperty
static val ShowColorBarItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowCopyItemProperty Field

The Dependency Property for binding to the ShowCopyItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowCopyItemProperty
Public Shared ReadOnly ShowCopyItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowCopyItemProperty
static val ShowCopyItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowDetailsItemProperty Field

The Dependency Property for binding to the ShowDetailsItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowDetailsItemProperty
Public Shared ReadOnly ShowDetailsItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowDetailsItemProperty
static val ShowDetailsItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowFillDisplayWithImageItemProperty Field

The Dependency Property for binding to the ShowFitImageToDisplayItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowFillDisplayWithImageItemProperty
Public Shared ReadOnly ShowFillDisplayWithImageItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowFillDisplayWithImageItemProperty
static val ShowFillDisplayWithImageItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowFitImageToDisplayItemProperty Field

The Dependency Property for binding to the ShowFitImageToDisplayItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowFitImageToDisplayItemProperty
Public Shared ReadOnly ShowFitImageToDisplayItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowFitImageToDisplayItemProperty
static val ShowFitImageToDisplayItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowHeaderItemProperty Field

The Dependency Property for binding to the ShowHeaderItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowHeaderItemProperty
Public Shared ReadOnly ShowHeaderItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowHeaderItemProperty
static val ShowHeaderItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowSaveAsItemProperty Field

The Dependency Property for binding to the ShowSaveAsItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowSaveAsItemProperty
Public Shared ReadOnly ShowSaveAsItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowSaveAsItemProperty
static val ShowSaveAsItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowSaveAsOriginalItemProperty Field

The Dependency Property for binding to the ShowSaveAsOriginalItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowSaveAsOriginalItemProperty
Public Shared ReadOnly ShowSaveAsOriginalItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowSaveAsOriginalItemProperty
static val ShowSaveAsOriginalItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowSaveRawTiffItemProperty Field

The Dependency Property for binding to the ShowSaveRawTiffItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowSaveRawTiffItemProperty
Public Shared ReadOnly ShowSaveRawTiffItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowSaveRawTiffItemProperty
static val ShowSaveRawTiffItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowSaveTSVOrCSVItemProperty Field

The Dependency Property for binding to the ShowSaveTSVOrCSVItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowSaveTSVOrCSVItemProperty
Public Shared ReadOnly ShowSaveTSVOrCSVItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowSaveTSVOrCSVItemProperty
static val ShowSaveTSVOrCSVItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


ImageViewerContextMenu.ShowScaleBarItemProperty Field

The Dependency Property for binding to the ShowScaleBarItem property.

Namespace: OINA.Extender.Controls.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowScaleBarItemProperty
Public Shared ReadOnly ShowScaleBarItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowScaleBarItemProperty
static val ShowScaleBarItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageViewerContextMenu Class
OINA.Extender.Controls.Image Namespace


OINA.Extender.Controls.Spectrum Namespace

Defines a set of Classes, Interfaces and definitions that apply only to Extender Visual Controls that display, or manipulate, Spectrum information.

OINA Extender Controls Spectrum Namespace

Classes
 | Class | Description
Public class | EnergyWindow | A Class that defines an energy window for the spectrum.
Public class | SpectrumClickedEventArgs | A Class that defines/sets arguments that provide information relating to mouse-clicks on a spectrum.
Public class | SpectrumDetails | A Class that displays information about a spectrum.
Public class | SpectrumViewerContextMenu | A Class that defines a context menu for a spectrum viewer control.
Enumerations
 | Enumeration | Description
Public enumeration | InteractionTool | Options for spectrum interaction.
Public enumeration | ScaleType | The type of scale used.
Public enumeration | SpectrumDrawStyle | The spectrum draw style.
Public enumeration | SpectrumNoisePeakMode | Options for including the noise peak in the spectrum.
Public enumeration | SpectrumUnit | Options for scaling the spectrum Y-axis.


EnergyWindow Class

A Class that defines an energy window for the spectrum.
Inheritance Hierarchy
SystemObject
OINA.Extender.Controls.SpectrumEnergyWindow

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class EnergyWindow : IEquatable<EnergyWindow>
Public NotInheritable Class EnergyWindow
    Implements IEquatable(Of EnergyWindow)
public ref class EnergyWindow sealed : IEquatable<EnergyWindow^>
[<SealedAttribute>]
type EnergyWindow =
    class
        interface IEquatable<EnergyWindow>
    end

The EnergyWindow type exposes the following members.

Constructors
 | Name | Description
Public method | EnergyWindow | Initializes a new instance of the EnergyWindow class.
Top
Properties
 | Name | Description
Public property | Color | Gets the color of the energy window when displayed in the spectrum.
Public property | LowerEnergy | Gets the lower bound of the energy window (keV).
Public property | UpperEnergy | Gets the upper bound of the energy window (keV).
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether two energy windows are the same. (Overrides ObjectEquals(Object).)
Public method | Equals(EnergyWindow) | Determines whether two energy windows are the same.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Controls.Spectrum Namespace


EnergyWindow Constructor

Initializes a new instance of the EnergyWindow class.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public EnergyWindow(
    double lowerEnergy,
    double upperEnergy,
    Color color
)
Public Sub New (
    lowerEnergy As Double,
    upperEnergy As Double,
    color As Color
)
public:
EnergyWindow(
    double lowerEnergy,
    double upperEnergy,
    Color color
)
new :
        lowerEnergy : float *
        upperEnergy : float *
        color : Color -> EnergyWindow

Parameters

lowerEnergy
Type: SystemDouble
The lower energy
upperEnergy
Type: SystemDouble
The upper energy
color
Type: System.Windows.MediaColor
The color
See Also

Reference

EnergyWindow Class
OINA.Extender.Controls.Spectrum Namespace


EnergyWindow Properties

The EnergyWindow type exposes the following members.

Properties
 | Name | Description
Public property | Color | Gets the color of the energy window when displayed in the spectrum.
Public property | LowerEnergy | Gets the lower bound of the energy window (keV).
Public property | UpperEnergy | Gets the upper bound of the energy window (keV).
Top
See Also

Reference

EnergyWindow Class
OINA.Extender.Controls.Spectrum Namespace


EnergyWindow.Color Property

Gets the color of the energy window when displayed in the spectrum.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
public:
property Color Color {
    Color get ();
}
member Color : Color with get

Property Value

Type: Color
See Also

Reference

EnergyWindow Class
OINA.Extender.Controls.Spectrum Namespace


EnergyWindow.LowerEnergy Property

Gets the lower bound of the energy window (keV).

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double LowerEnergy { get; }
Public ReadOnly Property LowerEnergy As Double
    Get
public:
property double LowerEnergy {
    double get ();
}
member LowerEnergy : float with get

Property Value

Type: Double
See Also

Reference

EnergyWindow Class
OINA.Extender.Controls.Spectrum Namespace


EnergyWindow.UpperEnergy Property

Gets the upper bound of the energy window (keV).

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double UpperEnergy { get; }
Public ReadOnly Property UpperEnergy As Double
    Get
public:
property double UpperEnergy {
    double get ();
}
member UpperEnergy : float with get

Property Value

Type: Double
See Also

Reference

EnergyWindow Class
OINA.Extender.Controls.Spectrum Namespace


EnergyWindow Methods

The EnergyWindow type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether two energy windows are the same. (Overrides ObjectEquals(Object).)
Public method | Equals(EnergyWindow) | Determines whether two energy windows are the same.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EnergyWindow Class
OINA.Extender.Controls.Spectrum Namespace


EnergyWindow.Equals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether two energy windows are the same. (Overrides ObjectEquals(Object).)
Public method | Equals(EnergyWindow) | Determines whether two energy windows are the same.
Top
See Also

Reference

EnergyWindow Class
OINA.Extender.Controls.Spectrum Namespace


EnergyWindow.Equals Method (Object)

Determines whether two energy windows are the same.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified object is equal to the current object; otherwise, false.
See Also

Reference

EnergyWindow Class
Equals Overload
OINA.Extender.Controls.Spectrum Namespace


EnergyWindow.Equals Method (EnergyWindow)

Determines whether two energy windows are the same.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    EnergyWindow other
)
Public Function Equals (
    other As EnergyWindow
) As Boolean
public:
virtual bool Equals(
    EnergyWindow^ other
) sealed
abstract Equals :
        other : EnergyWindow -> bool
override Equals :
        other : EnergyWindow -> bool

Parameters

other
Type: OINA.Extender.Controls.SpectrumEnergyWindow
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified object is equal to the current object; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

EnergyWindow Class
Equals Overload
OINA.Extender.Controls.Spectrum Namespace


EnergyWindow.GetHashCode Method

Serves as a hash function for a particular type.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

EnergyWindow Class
OINA.Extender.Controls.Spectrum Namespace


InteractionTool Enumeration

Options for spectrum interaction.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum InteractionTool
Public Enumeration InteractionTool
public enum class InteractionTool
type InteractionTool
Members
Member name | Value | Description
Pointer | 0 | Enables panning and zooming of the spectrum and interaction with peak labels.
Pan | 1 | Enables panning and zooming of the spectrum (default).
Information | 2 | Gets the Energy and Counts at the mouse position.
NormalizationPoint | 3 | Normalize spectra at a point.
NormalizationArea | 4 | Normalize spectra across an area.
See Also

Reference

OINA.Extender.Controls.Spectrum Namespace


ScaleType Enumeration

The type of scale used.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum ScaleType
Public Enumeration ScaleType
public enum class ScaleType
type ScaleType
Members
Member name | Value | Description
Linear | 0 | Scales y-axis in linear fashion.
Logarithmic | 1 | Scales y-axis in logarithmic fashion.
See Also

Reference

OINA.Extender.Controls.Spectrum Namespace


SpectrumClickedEventArgs Class

A Class that defines/sets arguments that provide information relating to mouse-clicks on a spectrum.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
OINA.Extender.Controls.SpectrumSpectrumClickedEventArgs

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class SpectrumClickedEventArgs : RoutedEventArgs
Public Class SpectrumClickedEventArgs
    Inherits RoutedEventArgs
public ref class SpectrumClickedEventArgs : public RoutedEventArgs
type SpectrumClickedEventArgs =
    class
        inherit RoutedEventArgs
    end

The SpectrumClickedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SpectrumClickedEventArgs(Double) | Initializes a new instance of the SpectrumClickedEventArgs class.
Public method | SpectrumClickedEventArgs(RoutedEvent, Double) | Initializes a new instance of the SpectrumClickedEventArgs class.
Public method | SpectrumClickedEventArgs(RoutedEvent, Object, Double) | Initializes a new instance of the SpectrumClickedEventArgs class.
Top
Properties
 | Name | Description
Public property | Energy | Gets the energy value at the cursor position, in keV.
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Controls.Spectrum Namespace


SpectrumClickedEventArgs Constructor

Overload List
 | Name | Description
Public method | SpectrumClickedEventArgs(Double) | Initializes a new instance of the SpectrumClickedEventArgs class.
Public method | SpectrumClickedEventArgs(RoutedEvent, Double) | Initializes a new instance of the SpectrumClickedEventArgs class.
Public method | SpectrumClickedEventArgs(RoutedEvent, Object, Double) | Initializes a new instance of the SpectrumClickedEventArgs class.
Top
See Also

Reference

SpectrumClickedEventArgs Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumClickedEventArgs Constructor (Double)

Initializes a new instance of the SpectrumClickedEventArgs class.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public SpectrumClickedEventArgs(
    double energy
)
Public Sub New (
    energy As Double
)
public:
SpectrumClickedEventArgs(
    double energy
)
new :
        energy : float -> SpectrumClickedEventArgs

Parameters

energy
Type: SystemDouble
The energy value
See Also

Reference

SpectrumClickedEventArgs Class
SpectrumClickedEventArgs Overload
OINA.Extender.Controls.Spectrum Namespace


SpectrumClickedEventArgs Constructor (RoutedEvent, Double)

Initializes a new instance of the SpectrumClickedEventArgs class.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public SpectrumClickedEventArgs(
    RoutedEvent routedEvent,
    double energy
)
Public Sub New (
    routedEvent As RoutedEvent,
    energy As Double
)
public:
SpectrumClickedEventArgs(
    RoutedEvent^ routedEvent,
    double energy
)
new :
        routedEvent : RoutedEvent *
        energy : float -> SpectrumClickedEventArgs

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event
energy
Type: SystemDouble
The energy value
See Also

Reference

SpectrumClickedEventArgs Class
SpectrumClickedEventArgs Overload
OINA.Extender.Controls.Spectrum Namespace


SpectrumClickedEventArgs Constructor (RoutedEvent, Object, Double)

Initializes a new instance of the SpectrumClickedEventArgs class.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public SpectrumClickedEventArgs(
    RoutedEvent routedEvent,
    Object source,
    double energy
)
Public Sub New (
    routedEvent As RoutedEvent,
    source As Object,
    energy As Double
)
public:
SpectrumClickedEventArgs(
    RoutedEvent^ routedEvent,
    Object^ source,
    double energy
)
new :
        routedEvent : RoutedEvent *
        source : Object *
        energy : float -> SpectrumClickedEventArgs

Parameters

routedEvent
Type: System.WindowsRoutedEvent
The routed event.
source
Type: SystemObject
The event trigger
energy
Type: SystemDouble
The energy value
See Also

Reference

SpectrumClickedEventArgs Class
SpectrumClickedEventArgs Overload
OINA.Extender.Controls.Spectrum Namespace


SpectrumClickedEventArgs Properties

The SpectrumClickedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Energy | Gets the energy value at the cursor position, in keV.
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
See Also

Reference

SpectrumClickedEventArgs Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumClickedEventArgs.Energy Property

Gets the energy value at the cursor position, in keV.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double Energy { get; }
Public ReadOnly Property Energy As Double
    Get
public:
property double Energy {
    double get ();
}
member Energy : float with get

Property Value

Type: Double
See Also

Reference

SpectrumClickedEventArgs Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumClickedEventArgs Methods

The SpectrumClickedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SpectrumClickedEventArgs Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails Class

A Class that displays information about a spectrum.
SpectrumDetails
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
OINA.Extender.Controls.SpectrumSpectrumDetails

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class SpectrumDetails : Window,
    INotifyPropertyChanged, IComponentConnector
Public Class SpectrumDetails
    Inherits Window
    Implements INotifyPropertyChanged, IComponentConnector
public ref class SpectrumDetails : public Window,
    INotifyPropertyChanged, IComponentConnector
type SpectrumDetails =
    class
        inherit Window
        interface INotifyPropertyChanged
        interface IComponentConnector
    end

The SpectrumDetails type exposes the following members.

Constructors
 | Name | Description
Public method | SpectrumDetails | Initializes a new instance of the SpectrumDetails class.
Public method | SpectrumDetails(IEdSpectrum) | Initializes a new instance of the SpectrumDetails class.
Top
Properties
 | Name | Description
Public property | AcceleratingVoltage | Gets the accelerating voltage used in kV.
Public property | AcquisitionDate | Gets the date when the spectrum was acquired.
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AzimuthDegrees | Gets the azimuth angle in degrees. The azimuth angle is the angle in degrees between the direction of the sample tilt and a line drawn between the X-ray detector and the point where the electron beam meets the sample, normal to the electron beam.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DetectorType | Gets the detector type.
Public property | DetectorTypeId | Gets the detector type id.
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ElevationDegrees | Gets the elevation angle in degrees. The elevation angle is the angle in degrees between the plane perpendicular to the electron beam and a line drawn between the X-ray detector and the point where the electron beam meets the sample.
Public property | EnergyPerChannel | Gets the energy per channel used in eV.
Public property | EnergyRange | Gets the energy range in keV
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Label | Gets the spectrum label
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Public property | LiveTime | Gets the live time in seconds
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Magnification | Gets the magnification used.
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NumberOfChannels | Gets the number of channels.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PrimaryDetectorSerialNumber | Gets the primary detector serial number
Public property | ProcessTime | Gets the process time used.
Public property | PulsePileupStatus | Gets the status of the pulse pileup correction.
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | SecondaryDetectorSerialNumbers | Gets the secondary detector serial numbers. Used with multiple Ed detector systems.
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Source | Gets the source of the spectrum. E.g. Acquired, Acquired (Imported)
Public property | SpecimenTiltDegrees | Gets the specimen tilt angle in degrees.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | WindowType | Gets the detector window type.
Public property | WorkingDistance | Gets the working distance in mm.
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of this Window object is modified. (Inherited from Window.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | PropertyChanged event
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails Constructor

Overload List
 | Name | Description
Public method | SpectrumDetails | Initializes a new instance of the SpectrumDetails class.
Public method | SpectrumDetails(IEdSpectrum) | Initializes a new instance of the SpectrumDetails class.
Top
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails Constructor

Initializes a new instance of the SpectrumDetails class.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public SpectrumDetails()
Public Sub New
public:
SpectrumDetails()
new : unit -> SpectrumDetails
See Also

Reference

SpectrumDetails Class
SpectrumDetails Overload
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails Constructor (IEdSpectrum)

Initializes a new instance of the SpectrumDetails class.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public SpectrumDetails(
    IEdSpectrum spectrum
)
Public Sub New (
    spectrum As IEdSpectrum
)
public:
SpectrumDetails(
    IEdSpectrum^ spectrum
)
new :
        spectrum : IEdSpectrum -> SpectrumDetails

Parameters

spectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The spectrum
See Also

Reference

SpectrumDetails Class
SpectrumDetails Overload
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails Properties

The SpectrumDetails type exposes the following members.

Properties
 | Name | Description
Public property | AcceleratingVoltage | Gets the accelerating voltage used in kV.
Public property | AcquisitionDate | Gets the date when the spectrum was acquired.
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AzimuthDegrees | Gets the azimuth angle in degrees. The azimuth angle is the angle in degrees between the direction of the sample tilt and a line drawn between the X-ray detector and the point where the electron beam meets the sample, normal to the electron beam.
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DetectorType | Gets the detector type.
Public property | DetectorTypeId | Gets the detector type id.
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ElevationDegrees | Gets the elevation angle in degrees. The elevation angle is the angle in degrees between the plane perpendicular to the electron beam and a line drawn between the X-ray detector and the point where the electron beam meets the sample.
Public property | EnergyPerChannel | Gets the energy per channel used in eV.
Public property | EnergyRange | Gets the energy range in keV
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Label | Gets the spectrum label
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Public property | LiveTime | Gets the live time in seconds
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Magnification | Gets the magnification used.
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NumberOfChannels | Gets the number of channels.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PrimaryDetectorSerialNumber | Gets the primary detector serial number
Public property | ProcessTime | Gets the process time used.
Public property | PulsePileupStatus | Gets the status of the pulse pileup correction.
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | SecondaryDetectorSerialNumbers | Gets the secondary detector serial numbers. Used with multiple Ed detector systems.
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Source | Gets the source of the spectrum. E.g. Acquired, Acquired (Imported)
Public property | SpecimenTiltDegrees | Gets the specimen tilt angle in degrees.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | WindowType | Gets the detector window type.
Public property | WorkingDistance | Gets the working distance in mm.
Top
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.AcceleratingVoltage Property

Gets the accelerating voltage used in kV.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string AcceleratingVoltage { get; }
Public ReadOnly Property AcceleratingVoltage As String
    Get
public:
property String^ AcceleratingVoltage {
    String^ get ();
}
member AcceleratingVoltage : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.AcquisitionDate Property

Gets the date when the spectrum was acquired.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string AcquisitionDate { get; }
Public ReadOnly Property AcquisitionDate As String
    Get
public:
property String^ AcquisitionDate {
    String^ get ();
}
member AcquisitionDate : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.AzimuthDegrees Property

Gets the azimuth angle in degrees. The azimuth angle is the angle in degrees between the direction of the sample tilt and a line drawn between the X-ray detector and the point where the electron beam meets the sample, normal to the electron beam.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string AzimuthDegrees { get; }
Public ReadOnly Property AzimuthDegrees As String
    Get
public:
property String^ AzimuthDegrees {
    String^ get ();
}
member AzimuthDegrees : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.DetectorType Property

Gets the detector type.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string DetectorType { get; }
Public ReadOnly Property DetectorType As String
    Get
public:
property String^ DetectorType {
    String^ get ();
}
member DetectorType : string with get

Return Value

Type: String
The detector type as string
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.DetectorTypeId Property

Gets the detector type id.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string DetectorTypeId { get; }
Public ReadOnly Property DetectorTypeId As String
    Get
public:
property String^ DetectorTypeId {
    String^ get ();
}
member DetectorTypeId : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.ElevationDegrees Property

Gets the elevation angle in degrees. The elevation angle is the angle in degrees between the plane perpendicular to the electron beam and a line drawn between the X-ray detector and the point where the electron beam meets the sample.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string ElevationDegrees { get; }
Public ReadOnly Property ElevationDegrees As String
    Get
public:
property String^ ElevationDegrees {
    String^ get ();
}
member ElevationDegrees : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.EnergyPerChannel Property

Gets the energy per channel used in eV.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string EnergyPerChannel { get; }
Public ReadOnly Property EnergyPerChannel As String
    Get
public:
property String^ EnergyPerChannel {
    String^ get ();
}
member EnergyPerChannel : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.EnergyRange Property

Gets the energy range in keV

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string EnergyRange { get; }
Public ReadOnly Property EnergyRange As String
    Get
public:
property String^ EnergyRange {
    String^ get ();
}
member EnergyRange : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.Label Property

Gets the spectrum label

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string Label { get; }
Public ReadOnly Property Label As String
    Get
public:
property String^ Label {
    String^ get ();
}
member Label : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.LiveTime Property

Gets the live time in seconds

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string LiveTime { get; }
Public ReadOnly Property LiveTime As String
    Get
public:
property String^ LiveTime {
    String^ get ();
}
member LiveTime : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.Magnification Property

Gets the magnification used.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string Magnification { get; }
Public ReadOnly Property Magnification As String
    Get
public:
property String^ Magnification {
    String^ get ();
}
member Magnification : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.NumberOfChannels Property

Gets the number of channels.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string NumberOfChannels { get; }
Public ReadOnly Property NumberOfChannels As String
    Get
public:
property String^ NumberOfChannels {
    String^ get ();
}
member NumberOfChannels : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.PrimaryDetectorSerialNumber Property

Gets the primary detector serial number

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string PrimaryDetectorSerialNumber { get; }
Public ReadOnly Property PrimaryDetectorSerialNumber As String
    Get
public:
property String^ PrimaryDetectorSerialNumber {
    String^ get ();
}
member PrimaryDetectorSerialNumber : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.ProcessTime Property

Gets the process time used.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string ProcessTime { get; }
Public ReadOnly Property ProcessTime As String
    Get
public:
property String^ ProcessTime {
    String^ get ();
}
member ProcessTime : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.PulsePileupStatus Property

Gets the status of the pulse pileup correction.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string PulsePileupStatus { get; }
Public ReadOnly Property PulsePileupStatus As String
    Get
public:
property String^ PulsePileupStatus {
    String^ get ();
}
member PulsePileupStatus : string with get

Return Value

Type: String
The pulse pile up status as string
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.SecondaryDetectorSerialNumbers Property

Gets the secondary detector serial numbers. Used with multiple Ed detector systems.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string SecondaryDetectorSerialNumbers { get; }
Public ReadOnly Property SecondaryDetectorSerialNumbers As String
    Get
public:
property String^ SecondaryDetectorSerialNumbers {
    String^ get ();
}
member SecondaryDetectorSerialNumbers : string with get

Return Value

Type: String
All detector serial number in one string
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.Source Property

Gets the source of the spectrum. E.g. Acquired, Acquired (Imported)

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string Source { get; }
Public ReadOnly Property Source As String
    Get
public:
property String^ Source {
    String^ get ();
}
member Source : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.SpecimenTiltDegrees Property

Gets the specimen tilt angle in degrees.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string SpecimenTiltDegrees { get; }
Public ReadOnly Property SpecimenTiltDegrees As String
    Get
public:
property String^ SpecimenTiltDegrees {
    String^ get ();
}
member SpecimenTiltDegrees : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.WindowType Property

Gets the detector window type.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string WindowType { get; }
Public ReadOnly Property WindowType As String
    Get
public:
property String^ WindowType {
    String^ get ();
}
member WindowType : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.WorkingDistance Property

Gets the working distance in mm.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string WorkingDistance { get; }
Public ReadOnly Property WorkingDistance As String
    Get
public:
property String^ WorkingDistance {
    String^ get ();
}
member WorkingDistance : string with get

Property Value

Type: String
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails Methods

The SpectrumDetails type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of this Window object is modified. (Inherited from Window.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.InitializeComponent Method

InitializeComponent

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void InitializeComponent()
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit

Implements

IComponentConnectorInitializeComponent
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails Events

The SpectrumDetails type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | PropertyChanged event
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDetails.PropertyChanged Event

PropertyChanged event

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

SpectrumDetails Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumDrawStyle Enumeration

The spectrum draw style.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum SpectrumDrawStyle
Public Enumeration SpectrumDrawStyle
public enum class SpectrumDrawStyle
type SpectrumDrawStyle
Members
Member name | Value | Description
Histogram | 0 | Draw the spectrum data as a histogram.
Line | 1 | Draw the spectrum data as a continuous line.
Smooth | 2 | Draw the spectrum data as a smoothed continuous line.
See Also

Reference

OINA.Extender.Controls.Spectrum Namespace


SpectrumNoisePeakMode Enumeration

Options for including the noise peak in the spectrum.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum SpectrumNoisePeakMode
Public Enumeration SpectrumNoisePeakMode
public enum class SpectrumNoisePeakMode
type SpectrumNoisePeakMode
Members
Member name | Value | Description
ShowInclude | 0 | Shows noise peak and includes it in scaling.
ShowExclude | 1 | Shows noise peak and excludes it from scaling.
Hide | 2 | Hides noise peak.
See Also

Reference

OINA.Extender.Controls.Spectrum Namespace


SpectrumUnit Enumeration

Options for scaling the spectrum Y-axis.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum SpectrumUnit
Public Enumeration SpectrumUnit
public enum class SpectrumUnit
type SpectrumUnit
Members
Member name | Value | Description
CountsPerSecondPerEv | 0 | Y-axis units expressed as counts per second, per eV.
Counts | 1 | Y-axis units expressed as counts.
See Also

Reference

OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu Class

A Class that defines a context menu for a spectrum viewer control.
SpectrumViewerContextMenu
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesMenuBase
System.Windows.ControlsContextMenu
OINA.Extender.Controls.SpectrumSpectrumViewerContextMenu

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class SpectrumViewerContextMenu : ContextMenu,
    IComponentConnector
Public Class SpectrumViewerContextMenu
    Inherits ContextMenu
    Implements IComponentConnector
public ref class SpectrumViewerContextMenu : public ContextMenu,
    IComponentConnector
type SpectrumViewerContextMenu =
    class
        inherit ContextMenu
        interface IComponentConnector
    end

The SpectrumViewerContextMenu type exposes the following members.

Constructors
 | Name | Description
Public method | SpectrumViewerContextMenu | Construct spectrum viewer context menu.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | CustomPopupPlacementCallback | Gets or sets a callback that indicates where a ContextMenu should be placed on the screen. (Inherited from ContextMenu.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the control supports scrolling. (Inherited from ContextMenu.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasDropShadow | Gets or sets a value that indicates whether the context menu appears with a dropped shadow. (Inherited from ContextMenu.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Get or sets the horizontal distance between the target origin and the popup alignment point. (Inherited from ContextMenu.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets a value that indicates whether the ContextMenu is visible. (Inherited from ContextMenu.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | ItemContainerTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from MenuBase.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Placement | Gets or sets the Placement property of a ContextMenu. (Inherited from ContextMenu.)
Public property | PlacementRectangle | Gets or sets the area relative to which the context menu is positioned when it opens. (Inherited from ContextMenu.)
Public property | PlacementTarget | Gets or sets the UIElement relative to which the ContextMenu is positioned when it opens. (Inherited from ContextMenu.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ShowDetailsItem | Gets or sets a value indicating whether or not to show peak labels.
Public property | ShowDrawStyleItems | Gets or sets a value indicating whether or not to show the Draw Style menu item.
Public property | ShowExportCopyItem | Gets or sets a value indicating whether or not to show the Copy Sub menu item.
Public property | ShowExportEMSAItem | Gets or sets a value indicating whether or not to show the Export to EMSA menu item.
Public property | ShowExportSaveAsItem | Gets or sets a value indicating whether or not to show the Save As sub menu item.
Public property | ShowHideNoisePeakItem | Gets or sets a value indicating whether or not to show the Noise Peak menu item.
Public property | ShowNoisePeakExcludeItem | Gets or sets a value indicating whether or not to show the Exclude from Scaling sub menu item.
Public property | ShowNoisePeakIncludeItem | Gets or sets a value indicating whether or not to show the Include Scaling sub menu item.
Public property | ShowNormalizeItem | Gets or sets a value indicating whether or not to show the Normalize menu item.
Public property | ShowPeakLabelItem | Gets or sets a value indicating whether or not to show the Show Peak Label sub menu item.
Public property | ShowPeakLabelResetPositionItem | Gets or sets a value indicating whether or not to show the Reset Positions sub menu item.
Public property | ShowResetScalesItem | Gets or sets a value indicating whether or not to show the Reset Scales menu item.
Public property | ShowXAxisItem | Gets or sets a value indicating whether or not to show the Show X-Axis sub menu item.
Public property | ShowXAxisLockedItem | Gets or sets a value indicating whether or not to show the Locked sub menu item.
Public property | ShowYAxisItem | Gets or sets a value indicating whether or not to show the Y-Axis menu item.
Public property | ShowYAxisLockedItem | Gets or sets a value indicating whether or not to show the Locked sub menu item.
Public property | ShowYAxisScaleItems | Gets or sets a value indicating whether or not to show the Scale sub menu item.
Public property | ShowYAxisUnitsItems | Gets or sets a value indicating whether or not to show Y-Axis units menu item.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpen | Gets or sets a value that indicates whether the ContextMenu should close automatically. (Inherited from ContextMenu.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | UsesItemContainerTemplate | Gets or sets a value that indicates whether the menu selects different item containers, depending on the type of the item in the underlying collection or some other heuristic. (Inherited from MenuBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Get or sets the vertical distance between the target origin and the popup alignment point. (Inherited from ContextMenu.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from MenuBase.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HandleMouseButton | Called when a mouse button is pressed or released. (Inherited from MenuBase.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is, or is eligible to be, its own item container. (Inherited from MenuBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Called when the Closed event occurs. (Inherited from ContextMenu.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a ContextMenuAutomationPeer object for this ContextMenu. (Inherited from ContextMenu.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ContextMenu.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called when a KeyDown event is raised by an object inside the ContextMenu. (Inherited from ContextMenu.)
Protected method | OnKeyUp | Responds to the KeyUp event. (Inherited from ContextMenu.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves the control. (Inherited from MenuBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnOpened | Called when the Opened event occurs. (Inherited from ContextMenu.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when a context menu's visual parent changes. (Inherited from ContextMenu.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ContextMenu.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when a particular instance of a ContextMenu closes. (Inherited from ContextMenu.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | Opened | Occurs when a particular instance of a context menu opens. (Inherited from ContextMenu.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ShowDetailsItemProperty | The Dependency Property for binding to the ShowDetailsItem property.
ShowDrawStyleItemsProperty | The Dependency Property for binding to the ShowDrawStyleItems property.
ShowExportCopyItemProperty | The Dependency Property for binding to the ShowExportCopyItem property.
ShowExportEMSAItemProperty | The Dependency Property for binding to the ShowExportItems property.
ShowExportSaveAsItemProperty | The Dependency Property for binding to the ShowExportSaveAsItem property.
ShowHideNoisePeakItemProperty | The Dependency Property for binding to the ShowNoisePeakItems property.
ShowNoisePeakExcludeItemProperty | The Dependency Property for binding to the ShowNoisePeakExcludeItem property.
ShowNoisePeakIncludeItemProperty | The Dependency Property for binding to the ShowNoisePeakIncludeItem property.
ShowNormalizeItemProperty | The Dependency Property for binding to the ShowNormalizeItem property.
ShowPeakLabelItemProperty | The Dependency Property for binding to the ShowPeakLabelItem property.
ShowPeakLabelResetPositionItemProperty | The Dependency Property for binding to the ShowPeakLabelResetPositionItem property.
ShowResetScalesItemProperty | The Dependency Property for binding to the ShowResetScalesItem property.
ShowXAxisItemProperty | The Dependency Property for binding to the ShowXAxisItem property.
ShowXAxisLockedItemProperty | The Dependency Property for binding to the ShowXAxisLockedItem property.
ShowYAxisItemProperty | The Dependency Property for binding to the ShowYAxisItem property.
ShowYAxisLockedItemProperty | The Dependency Property for binding to the ShowYAxisLockedItem property.
ShowYAxisScaleItemsProperty | The Dependency Property for binding to the ShowYAxisScaleItems property.
ShowYAxisUnitsItemsProperty | The Dependency Property for binding to the ShowYAxisUnitsItem property.
Top
See Also

Reference

OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu Constructor

Construct spectrum viewer context menu.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public SpectrumViewerContextMenu()
Public Sub New
public:
SpectrumViewerContextMenu()
new : unit -> SpectrumViewerContextMenu
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu Properties

The SpectrumViewerContextMenu type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | CustomPopupPlacementCallback | Gets or sets a callback that indicates where a ContextMenu should be placed on the screen. (Inherited from ContextMenu.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the control supports scrolling. (Inherited from ContextMenu.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasDropShadow | Gets or sets a value that indicates whether the context menu appears with a dropped shadow. (Inherited from ContextMenu.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Get or sets the horizontal distance between the target origin and the popup alignment point. (Inherited from ContextMenu.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets a value that indicates whether the ContextMenu is visible. (Inherited from ContextMenu.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | ItemContainerTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from MenuBase.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Placement | Gets or sets the Placement property of a ContextMenu. (Inherited from ContextMenu.)
Public property | PlacementRectangle | Gets or sets the area relative to which the context menu is positioned when it opens. (Inherited from ContextMenu.)
Public property | PlacementTarget | Gets or sets the UIElement relative to which the ContextMenu is positioned when it opens. (Inherited from ContextMenu.)
Public property | RenderSize | Gets (or sets) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ShowDetailsItem | Gets or sets a value indicating whether or not to show peak labels.
Public property | ShowDrawStyleItems | Gets or sets a value indicating whether or not to show the Draw Style menu item.
Public property | ShowExportCopyItem | Gets or sets a value indicating whether or not to show the Copy Sub menu item.
Public property | ShowExportEMSAItem | Gets or sets a value indicating whether or not to show the Export to EMSA menu item.
Public property | ShowExportSaveAsItem | Gets or sets a value indicating whether or not to show the Save As sub menu item.
Public property | ShowHideNoisePeakItem | Gets or sets a value indicating whether or not to show the Noise Peak menu item.
Public property | ShowNoisePeakExcludeItem | Gets or sets a value indicating whether or not to show the Exclude from Scaling sub menu item.
Public property | ShowNoisePeakIncludeItem | Gets or sets a value indicating whether or not to show the Include Scaling sub menu item.
Public property | ShowNormalizeItem | Gets or sets a value indicating whether or not to show the Normalize menu item.
Public property | ShowPeakLabelItem | Gets or sets a value indicating whether or not to show the Show Peak Label sub menu item.
Public property | ShowPeakLabelResetPositionItem | Gets or sets a value indicating whether or not to show the Reset Positions sub menu item.
Public property | ShowResetScalesItem | Gets or sets a value indicating whether or not to show the Reset Scales menu item.
Public property | ShowXAxisItem | Gets or sets a value indicating whether or not to show the Show X-Axis sub menu item.
Public property | ShowXAxisLockedItem | Gets or sets a value indicating whether or not to show the Locked sub menu item.
Public property | ShowYAxisItem | Gets or sets a value indicating whether or not to show the Y-Axis menu item.
Public property | ShowYAxisLockedItem | Gets or sets a value indicating whether or not to show the Locked sub menu item.
Public property | ShowYAxisScaleItems | Gets or sets a value indicating whether or not to show the Scale sub menu item.
Public property | ShowYAxisUnitsItems | Gets or sets a value indicating whether or not to show Y-Axis units menu item.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpen | Gets or sets a value that indicates whether the ContextMenu should close automatically. (Inherited from ContextMenu.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | UsesItemContainerTemplate | Gets or sets a value that indicates whether the menu selects different item containers, depending on the type of the item in the underlying collection or some other heuristic. (Inherited from MenuBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Get or sets the vertical distance between the target origin and the popup alignment point. (Inherited from ContextMenu.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Top
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowDetailsItem Property

Gets or sets a value indicating whether or not to show peak labels.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowDetailsItem { get; set; }
Public Property ShowDetailsItem As Boolean
    Get
    Set
public:
property bool ShowDetailsItem {
    bool get ();
    void set (bool value);
}
member ShowDetailsItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowDrawStyleItems Property

Gets or sets a value indicating whether or not to show the Draw Style menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowDrawStyleItems { get; set; }
Public Property ShowDrawStyleItems As Boolean
    Get
    Set
public:
property bool ShowDrawStyleItems {
    bool get ();
    void set (bool value);
}
member ShowDrawStyleItems : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowExportCopyItem Property

Gets or sets a value indicating whether or not to show the Copy Sub menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowExportCopyItem { get; set; }
Public Property ShowExportCopyItem As Boolean
    Get
    Set
public:
property bool ShowExportCopyItem {
    bool get ();
    void set (bool value);
}
member ShowExportCopyItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowExportEMSAItem Property

Gets or sets a value indicating whether or not to show the Export to EMSA menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowExportEMSAItem { get; set; }
Public Property ShowExportEMSAItem As Boolean
    Get
    Set
public:
property bool ShowExportEMSAItem {
    bool get ();
    void set (bool value);
}
member ShowExportEMSAItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowExportSaveAsItem Property

Gets or sets a value indicating whether or not to show the Save As sub menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowExportSaveAsItem { get; set; }
Public Property ShowExportSaveAsItem As Boolean
    Get
    Set
public:
property bool ShowExportSaveAsItem {
    bool get ();
    void set (bool value);
}
member ShowExportSaveAsItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowHideNoisePeakItem Property

Gets or sets a value indicating whether or not to show the Noise Peak menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowHideNoisePeakItem { get; set; }
Public Property ShowHideNoisePeakItem As Boolean
    Get
    Set
public:
property bool ShowHideNoisePeakItem {
    bool get ();
    void set (bool value);
}
member ShowHideNoisePeakItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowNoisePeakExcludeItem Property

Gets or sets a value indicating whether or not to show the Exclude from Scaling sub menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowNoisePeakExcludeItem { get; set; }
Public Property ShowNoisePeakExcludeItem As Boolean
    Get
    Set
public:
property bool ShowNoisePeakExcludeItem {
    bool get ();
    void set (bool value);
}
member ShowNoisePeakExcludeItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowNoisePeakIncludeItem Property

Gets or sets a value indicating whether or not to show the Include Scaling sub menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowNoisePeakIncludeItem { get; set; }
Public Property ShowNoisePeakIncludeItem As Boolean
    Get
    Set
public:
property bool ShowNoisePeakIncludeItem {
    bool get ();
    void set (bool value);
}
member ShowNoisePeakIncludeItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowNormalizeItem Property

Gets or sets a value indicating whether or not to show the Normalize menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowNormalizeItem { get; set; }
Public Property ShowNormalizeItem As Boolean
    Get
    Set
public:
property bool ShowNormalizeItem {
    bool get ();
    void set (bool value);
}
member ShowNormalizeItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowPeakLabelItem Property

Gets or sets a value indicating whether or not to show the Show Peak Label sub menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowPeakLabelItem { get; set; }
Public Property ShowPeakLabelItem As Boolean
    Get
    Set
public:
property bool ShowPeakLabelItem {
    bool get ();
    void set (bool value);
}
member ShowPeakLabelItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowPeakLabelResetPositionItem Property

Gets or sets a value indicating whether or not to show the Reset Positions sub menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowPeakLabelResetPositionItem { get; set; }
Public Property ShowPeakLabelResetPositionItem As Boolean
    Get
    Set
public:
property bool ShowPeakLabelResetPositionItem {
    bool get ();
    void set (bool value);
}
member ShowPeakLabelResetPositionItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowResetScalesItem Property

Gets or sets a value indicating whether or not to show the Reset Scales menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowResetScalesItem { get; set; }
Public Property ShowResetScalesItem As Boolean
    Get
    Set
public:
property bool ShowResetScalesItem {
    bool get ();
    void set (bool value);
}
member ShowResetScalesItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowXAxisItem Property

Gets or sets a value indicating whether or not to show the Show X-Axis sub menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowXAxisItem { get; set; }
Public Property ShowXAxisItem As Boolean
    Get
    Set
public:
property bool ShowXAxisItem {
    bool get ();
    void set (bool value);
}
member ShowXAxisItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowXAxisLockedItem Property

Gets or sets a value indicating whether or not to show the Locked sub menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowXAxisLockedItem { get; set; }
Public Property ShowXAxisLockedItem As Boolean
    Get
    Set
public:
property bool ShowXAxisLockedItem {
    bool get ();
    void set (bool value);
}
member ShowXAxisLockedItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowYAxisItem Property

Gets or sets a value indicating whether or not to show the Y-Axis menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowYAxisItem { get; set; }
Public Property ShowYAxisItem As Boolean
    Get
    Set
public:
property bool ShowYAxisItem {
    bool get ();
    void set (bool value);
}
member ShowYAxisItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowYAxisLockedItem Property

Gets or sets a value indicating whether or not to show the Locked sub menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowYAxisLockedItem { get; set; }
Public Property ShowYAxisLockedItem As Boolean
    Get
    Set
public:
property bool ShowYAxisLockedItem {
    bool get ();
    void set (bool value);
}
member ShowYAxisLockedItem : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowYAxisScaleItems Property

Gets or sets a value indicating whether or not to show the Scale sub menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowYAxisScaleItems { get; set; }
Public Property ShowYAxisScaleItems As Boolean
    Get
    Set
public:
property bool ShowYAxisScaleItems {
    bool get ();
    void set (bool value);
}
member ShowYAxisScaleItems : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowYAxisUnitsItems Property

Gets or sets a value indicating whether or not to show Y-Axis units menu item.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool ShowYAxisUnitsItems { get; set; }
Public Property ShowYAxisUnitsItems As Boolean
    Get
    Set
public:
property bool ShowYAxisUnitsItems {
    bool get ();
    void set (bool value);
}
member ShowYAxisUnitsItems : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu Methods

The SpectrumViewerContextMenu type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from MenuBase.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HandleMouseButton | Called when a mouse button is pressed or released. (Inherited from MenuBase.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is, or is eligible to be, its own item container. (Inherited from MenuBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Called when the Closed event occurs. (Inherited from ContextMenu.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a ContextMenuAutomationPeer object for this ContextMenu. (Inherited from ContextMenu.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ContextMenu.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called when a KeyDown event is raised by an object inside the ContextMenu. (Inherited from ContextMenu.)
Protected method | OnKeyUp | Responds to the KeyUp event. (Inherited from ContextMenu.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves the control. (Inherited from MenuBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnOpened | Called when the Opened event occurs. (Inherited from ContextMenu.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when a context menu's visual parent changes. (Inherited from ContextMenu.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ContextMenu.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Top
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.InitializeComponent Method

InitializeComponent

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public void InitializeComponent()
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit

Implements

IComponentConnectorInitializeComponent
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu Events

The SpectrumViewerContextMenu type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when a particular instance of a ContextMenu closes. (Inherited from ContextMenu.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | Opened | Occurs when a particular instance of a context menu opens. (Inherited from ContextMenu.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu Fields

The SpectrumViewerContextMenu type exposes the following members.

Fields
Name | Description
ShowDetailsItemProperty | The Dependency Property for binding to the ShowDetailsItem property.
ShowDrawStyleItemsProperty | The Dependency Property for binding to the ShowDrawStyleItems property.
ShowExportCopyItemProperty | The Dependency Property for binding to the ShowExportCopyItem property.
ShowExportEMSAItemProperty | The Dependency Property for binding to the ShowExportItems property.
ShowExportSaveAsItemProperty | The Dependency Property for binding to the ShowExportSaveAsItem property.
ShowHideNoisePeakItemProperty | The Dependency Property for binding to the ShowNoisePeakItems property.
ShowNoisePeakExcludeItemProperty | The Dependency Property for binding to the ShowNoisePeakExcludeItem property.
ShowNoisePeakIncludeItemProperty | The Dependency Property for binding to the ShowNoisePeakIncludeItem property.
ShowNormalizeItemProperty | The Dependency Property for binding to the ShowNormalizeItem property.
ShowPeakLabelItemProperty | The Dependency Property for binding to the ShowPeakLabelItem property.
ShowPeakLabelResetPositionItemProperty | The Dependency Property for binding to the ShowPeakLabelResetPositionItem property.
ShowResetScalesItemProperty | The Dependency Property for binding to the ShowResetScalesItem property.
ShowXAxisItemProperty | The Dependency Property for binding to the ShowXAxisItem property.
ShowXAxisLockedItemProperty | The Dependency Property for binding to the ShowXAxisLockedItem property.
ShowYAxisItemProperty | The Dependency Property for binding to the ShowYAxisItem property.
ShowYAxisLockedItemProperty | The Dependency Property for binding to the ShowYAxisLockedItem property.
ShowYAxisScaleItemsProperty | The Dependency Property for binding to the ShowYAxisScaleItems property.
ShowYAxisUnitsItemsProperty | The Dependency Property for binding to the ShowYAxisUnitsItem property.
Top
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowDetailsItemProperty Field

The Dependency Property for binding to the ShowDetailsItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowDetailsItemProperty
Public Shared ReadOnly ShowDetailsItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowDetailsItemProperty
static val ShowDetailsItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowDrawStyleItemsProperty Field

The Dependency Property for binding to the ShowDrawStyleItems property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowDrawStyleItemsProperty
Public Shared ReadOnly ShowDrawStyleItemsProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowDrawStyleItemsProperty
static val ShowDrawStyleItemsProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowExportCopyItemProperty Field

The Dependency Property for binding to the ShowExportCopyItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowExportCopyItemProperty
Public Shared ReadOnly ShowExportCopyItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowExportCopyItemProperty
static val ShowExportCopyItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowExportEMSAItemProperty Field

The Dependency Property for binding to the ShowExportItems property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowExportEMSAItemProperty
Public Shared ReadOnly ShowExportEMSAItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowExportEMSAItemProperty
static val ShowExportEMSAItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowExportSaveAsItemProperty Field

The Dependency Property for binding to the ShowExportSaveAsItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowExportSaveAsItemProperty
Public Shared ReadOnly ShowExportSaveAsItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowExportSaveAsItemProperty
static val ShowExportSaveAsItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowHideNoisePeakItemProperty Field

The Dependency Property for binding to the ShowNoisePeakItems property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowHideNoisePeakItemProperty
Public Shared ReadOnly ShowHideNoisePeakItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowHideNoisePeakItemProperty
static val ShowHideNoisePeakItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowNoisePeakExcludeItemProperty Field

The Dependency Property for binding to the ShowNoisePeakExcludeItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowNoisePeakExcludeItemProperty
Public Shared ReadOnly ShowNoisePeakExcludeItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowNoisePeakExcludeItemProperty
static val ShowNoisePeakExcludeItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowNoisePeakIncludeItemProperty Field

The Dependency Property for binding to the ShowNoisePeakIncludeItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowNoisePeakIncludeItemProperty
Public Shared ReadOnly ShowNoisePeakIncludeItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowNoisePeakIncludeItemProperty
static val ShowNoisePeakIncludeItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowNormalizeItemProperty Field

The Dependency Property for binding to the ShowNormalizeItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowNormalizeItemProperty
Public Shared ReadOnly ShowNormalizeItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowNormalizeItemProperty
static val ShowNormalizeItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowPeakLabelItemProperty Field

The Dependency Property for binding to the ShowPeakLabelItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowPeakLabelItemProperty
Public Shared ReadOnly ShowPeakLabelItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowPeakLabelItemProperty
static val ShowPeakLabelItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowPeakLabelResetPositionItemProperty Field

The Dependency Property for binding to the ShowPeakLabelResetPositionItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowPeakLabelResetPositionItemProperty
Public Shared ReadOnly ShowPeakLabelResetPositionItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowPeakLabelResetPositionItemProperty
static val ShowPeakLabelResetPositionItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowResetScalesItemProperty Field

The Dependency Property for binding to the ShowResetScalesItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowResetScalesItemProperty
Public Shared ReadOnly ShowResetScalesItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowResetScalesItemProperty
static val ShowResetScalesItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowXAxisItemProperty Field

The Dependency Property for binding to the ShowXAxisItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowXAxisItemProperty
Public Shared ReadOnly ShowXAxisItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowXAxisItemProperty
static val ShowXAxisItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowXAxisLockedItemProperty Field

The Dependency Property for binding to the ShowXAxisLockedItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowXAxisLockedItemProperty
Public Shared ReadOnly ShowXAxisLockedItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowXAxisLockedItemProperty
static val ShowXAxisLockedItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowYAxisItemProperty Field

The Dependency Property for binding to the ShowYAxisItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowYAxisItemProperty
Public Shared ReadOnly ShowYAxisItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowYAxisItemProperty
static val ShowYAxisItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowYAxisLockedItemProperty Field

The Dependency Property for binding to the ShowYAxisLockedItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowYAxisLockedItemProperty
Public Shared ReadOnly ShowYAxisLockedItemProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowYAxisLockedItemProperty
static val ShowYAxisLockedItemProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowYAxisScaleItemsProperty Field

The Dependency Property for binding to the ShowYAxisScaleItems property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowYAxisScaleItemsProperty
Public Shared ReadOnly ShowYAxisScaleItemsProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowYAxisScaleItemsProperty
static val ShowYAxisScaleItemsProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


SpectrumViewerContextMenu.ShowYAxisUnitsItemsProperty Field

The Dependency Property for binding to the ShowYAxisUnitsItem property.

Namespace: OINA.Extender.Controls.Spectrum
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static readonly DependencyProperty ShowYAxisUnitsItemsProperty
Public Shared ReadOnly ShowYAxisUnitsItemsProperty As DependencyProperty
public:
static initonly DependencyProperty^ ShowYAxisUnitsItemsProperty
static val ShowYAxisUnitsItemsProperty: DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SpectrumViewerContextMenu Class
OINA.Extender.Controls.Spectrum Namespace


OINA.Extender.Controls.Styles Namespace

Defines Classes used to modify the visual style of Extender Controls. Each control available within the Extender Library has its own default visual theme. A Static Class exists for each Control for which the visual style can be modified.

Classes
 | Class | Description
Public class | BrightnessContrastDialogStyle | Allows for changes in style to be applied to the brightness contrast dialog.
Public class | DetailsDialogStyle | Settings for styling the detail dialogs.
Public class | ElementComboStyle | A Class used for defining the appearance of the ElementCombo Control.
Public class | ImageViewerStyle | A Class used for defining the appearance of the Image Viewer Control.
Public class | PeriodicTableStyle | A Class used to configure the appearance of the Periodic Table Control.
Public class | SpectrumViewerStyle | A Class used for defining the appearance of the SpectrumViewer control.


BrightnessContrastDialogStyle Class

Allows for changes in style to be applied to the brightness contrast dialog.
Inheritance Hierarchy
SystemObject
OINA.Extender.Controls.StylesBrightnessContrastDialogStyle

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class BrightnessContrastDialogStyle
Public NotInheritable Class BrightnessContrastDialogStyle
public ref class BrightnessContrastDialogStyle abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BrightnessContrastDialogStyle =  class end

The BrightnessContrastDialogStyle type exposes the following members.

Properties
Name | Description
AxisMarkersColor | Gets or sets the axis markers color
AxisTicksColor | Gets or sets the plotter axis ticks color
BrightnessContrastDialogBackgroundColor | Gets or sets the brightness contrast dialog background color
ComboLineColor | Gets or sets the combo line color
GenericControlBackgroundColor | Gets or sets the generic control background color
HeaderFontColor | Gets or sets the colour of the header
HeaderFontFamily | Gets or sets the header font family
HeaderFontSize | Gets or sets the font size of header
HeaderFontStyle | Gets or sets the header font style
PlotterBackgroundColor | Gets or sets the combo and plotter background color
PlotterLineColor | Gets or sets the plotter line color
Top
Methods
Name | Description
ResetStyles | Resets the styles.
Top
See Also

Reference

OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle Properties

The BrightnessContrastDialogStyle type exposes the following members.

Properties
Name | Description
AxisMarkersColor | Gets or sets the axis markers color
AxisTicksColor | Gets or sets the plotter axis ticks color
BrightnessContrastDialogBackgroundColor | Gets or sets the brightness contrast dialog background color
ComboLineColor | Gets or sets the combo line color
GenericControlBackgroundColor | Gets or sets the generic control background color
HeaderFontColor | Gets or sets the colour of the header
HeaderFontFamily | Gets or sets the header font family
HeaderFontSize | Gets or sets the font size of header
HeaderFontStyle | Gets or sets the header font style
PlotterBackgroundColor | Gets or sets the combo and plotter background color
PlotterLineColor | Gets or sets the plotter line color
Top
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.AxisMarkersColor Property

Gets or sets the axis markers color

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color AxisMarkersColor { get; set; }
Public Shared Property AxisMarkersColor As Color
    Get
    Set
public:
static property Color AxisMarkersColor {
    Color get ();
    void set (Color value);
}
static member AxisMarkersColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.AxisTicksColor Property

Gets or sets the plotter axis ticks color

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color AxisTicksColor { get; set; }
Public Shared Property AxisTicksColor As Color
    Get
    Set
public:
static property Color AxisTicksColor {
    Color get ();
    void set (Color value);
}
static member AxisTicksColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.BrightnessContrastDialogBackgroundColor Property

Gets or sets the brightness contrast dialog background color

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color BrightnessContrastDialogBackgroundColor { get; set; }
Public Shared Property BrightnessContrastDialogBackgroundColor As Color
    Get
    Set
public:
static property Color BrightnessContrastDialogBackgroundColor {
    Color get ();
    void set (Color value);
}
static member BrightnessContrastDialogBackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.ComboLineColor Property

Gets or sets the combo line color

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color ComboLineColor { get; set; }
Public Shared Property ComboLineColor As Color
    Get
    Set
public:
static property Color ComboLineColor {
    Color get ();
    void set (Color value);
}
static member ComboLineColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.GenericControlBackgroundColor Property

Gets or sets the generic control background color

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color GenericControlBackgroundColor { get; set; }
Public Shared Property GenericControlBackgroundColor As Color
    Get
    Set
public:
static property Color GenericControlBackgroundColor {
    Color get ();
    void set (Color value);
}
static member GenericControlBackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.HeaderFontColor Property

Gets or sets the colour of the header

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color HeaderFontColor { get; set; }
Public Shared Property HeaderFontColor As Color
    Get
    Set
public:
static property Color HeaderFontColor {
    Color get ();
    void set (Color value);
}
static member HeaderFontColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.HeaderFontFamily Property

Gets or sets the header font family

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static FontFamily HeaderFontFamily { get; set; }
Public Shared Property HeaderFontFamily As FontFamily
    Get
    Set
public:
static property FontFamily^ HeaderFontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}
static member HeaderFontFamily : FontFamily with get, set

Property Value

Type: FontFamily
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.HeaderFontSize Property

Gets or sets the font size of header

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double HeaderFontSize { get; set; }
Public Shared Property HeaderFontSize As Double
    Get
    Set
public:
static property double HeaderFontSize {
    double get ();
    void set (double value);
}
static member HeaderFontSize : float with get, set

Property Value

Type: Double
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.HeaderFontStyle Property

Gets or sets the header font style

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static FontStyle HeaderFontStyle { get; set; }
Public Shared Property HeaderFontStyle As FontStyle
    Get
    Set
public:
static property FontStyle HeaderFontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
static member HeaderFontStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.PlotterBackgroundColor Property

Gets or sets the combo and plotter background color

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color PlotterBackgroundColor { get; set; }
Public Shared Property PlotterBackgroundColor As Color
    Get
    Set
public:
static property Color PlotterBackgroundColor {
    Color get ();
    void set (Color value);
}
static member PlotterBackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.PlotterLineColor Property

Gets or sets the plotter line color

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color PlotterLineColor { get; set; }
Public Shared Property PlotterLineColor As Color
    Get
    Set
public:
static property Color PlotterLineColor {
    Color get ();
    void set (Color value);
}
static member PlotterLineColor : Color with get, set

Property Value

Type: Color
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle Methods

The BrightnessContrastDialogStyle type exposes the following members.

Methods
Name | Description
ResetStyles | Resets the styles.
Top
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


BrightnessContrastDialogStyle.ResetStyles Method

Resets the styles.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static void ResetStyles()
Public Shared Sub ResetStyles
public:
static void ResetStyles()
static member ResetStyles : unit -> unit
See Also

Reference

BrightnessContrastDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle Class

Settings for styling the detail dialogs.
Inheritance Hierarchy
SystemObject
OINA.Extender.Controls.StylesDetailsDialogStyle

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class DetailsDialogStyle
Public NotInheritable Class DetailsDialogStyle
public ref class DetailsDialogStyle abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DetailsDialogStyle =  class end

The DetailsDialogStyle type exposes the following members.

Properties
Name | Description
DetailsTextColor | Gets or sets the color of the details text.
DetailsTextFontFamily | Gets or sets the details text font family.
DetailsTextFontStyle | Gets or sets the details text font style.
DetailsTextSize | Gets or sets the size of the details text.
DialogBackgroundColor | Gets or sets the color of the dialog background.
HeaderTextColor | Gets or sets the color of the header text.
HeaderTextFontFamily | Gets or sets the header text font family.
HeaderTextFontStyle | Gets or sets the header text font style.
HeaderTextSize | Gets or sets the size of the header text.
Top
Methods
Name | Description
ResetStyles | Resets the styles.
Top
See Also

Reference

OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle Properties

The DetailsDialogStyle type exposes the following members.

Properties
Name | Description
DetailsTextColor | Gets or sets the color of the details text.
DetailsTextFontFamily | Gets or sets the details text font family.
DetailsTextFontStyle | Gets or sets the details text font style.
DetailsTextSize | Gets or sets the size of the details text.
DialogBackgroundColor | Gets or sets the color of the dialog background.
HeaderTextColor | Gets or sets the color of the header text.
HeaderTextFontFamily | Gets or sets the header text font family.
HeaderTextFontStyle | Gets or sets the header text font style.
HeaderTextSize | Gets or sets the size of the header text.
Top
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle.DetailsTextColor Property

Gets or sets the color of the details text.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color DetailsTextColor { get; set; }
Public Shared Property DetailsTextColor As Color
    Get
    Set
public:
static property Color DetailsTextColor {
    Color get ();
    void set (Color value);
}
static member DetailsTextColor : Color with get, set

Property Value

Type: Color
The color of the details text.
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle.DetailsTextFontFamily Property

Gets or sets the details text font family.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static FontFamily DetailsTextFontFamily { get; set; }
Public Shared Property DetailsTextFontFamily As FontFamily
    Get
    Set
public:
static property FontFamily^ DetailsTextFontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}
static member DetailsTextFontFamily : FontFamily with get, set

Property Value

Type: FontFamily
The details text font family.
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle.DetailsTextFontStyle Property

Gets or sets the details text font style.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static FontStyle DetailsTextFontStyle { get; set; }
Public Shared Property DetailsTextFontStyle As FontStyle
    Get
    Set
public:
static property FontStyle DetailsTextFontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
static member DetailsTextFontStyle : FontStyle with get, set

Property Value

Type: FontStyle
The details text font style.
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle.DetailsTextSize Property

Gets or sets the size of the details text.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double DetailsTextSize { get; set; }
Public Shared Property DetailsTextSize As Double
    Get
    Set
public:
static property double DetailsTextSize {
    double get ();
    void set (double value);
}
static member DetailsTextSize : float with get, set

Property Value

Type: Double
The size of the details text.
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle.DialogBackgroundColor Property

Gets or sets the color of the dialog background.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color DialogBackgroundColor { get; set; }
Public Shared Property DialogBackgroundColor As Color
    Get
    Set
public:
static property Color DialogBackgroundColor {
    Color get ();
    void set (Color value);
}
static member DialogBackgroundColor : Color with get, set

Property Value

Type: Color
The color of the dialog background.
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle.HeaderTextColor Property

Gets or sets the color of the header text.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color HeaderTextColor { get; set; }
Public Shared Property HeaderTextColor As Color
    Get
    Set
public:
static property Color HeaderTextColor {
    Color get ();
    void set (Color value);
}
static member HeaderTextColor : Color with get, set

Property Value

Type: Color
The color of the header text.
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle.HeaderTextFontFamily Property

Gets or sets the header text font family.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static FontFamily HeaderTextFontFamily { get; set; }
Public Shared Property HeaderTextFontFamily As FontFamily
    Get
    Set
public:
static property FontFamily^ HeaderTextFontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}
static member HeaderTextFontFamily : FontFamily with get, set

Property Value

Type: FontFamily
The header text font family.
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle.HeaderTextFontStyle Property

Gets or sets the header text font style.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static FontStyle HeaderTextFontStyle { get; set; }
Public Shared Property HeaderTextFontStyle As FontStyle
    Get
    Set
public:
static property FontStyle HeaderTextFontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
static member HeaderTextFontStyle : FontStyle with get, set

Property Value

Type: FontStyle
The header text font style.
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle.HeaderTextSize Property

Gets or sets the size of the header text.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double HeaderTextSize { get; set; }
Public Shared Property HeaderTextSize As Double
    Get
    Set
public:
static property double HeaderTextSize {
    double get ();
    void set (double value);
}
static member HeaderTextSize : float with get, set

Property Value

Type: Double
The size of the header text.
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle Methods

The DetailsDialogStyle type exposes the following members.

Methods
Name | Description
ResetStyles | Resets the styles.
Top
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


DetailsDialogStyle.ResetStyles Method

Resets the styles.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static void ResetStyles()
Public Shared Sub ResetStyles
public:
static void ResetStyles()
static member ResetStyles : unit -> unit
See Also

Reference

DetailsDialogStyle Class
OINA.Extender.Controls.Styles Namespace


ElementComboStyle Class

A Class used for defining the appearance of the ElementCombo Control.
Inheritance Hierarchy
SystemObject
OINA.Extender.Controls.StylesElementComboStyle

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class ElementComboStyle
Public NotInheritable Class ElementComboStyle
public ref class ElementComboStyle abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElementComboStyle =  class end

The ElementComboStyle type exposes the following members.

Properties
Name | Description
Background | Gets or sets background colour for spectrum viewer.
ComboFontSize | Gets or sets font size for spectrum viewer text
Foreground | Gets or sets foreground colour for spectrum viewer.
Top
Methods
Name | Description
ResetStyles | Restores the default style.
Top
See Also

Reference

OINA.Extender.Controls.Styles Namespace


ElementComboStyle Properties

The ElementComboStyle type exposes the following members.

Properties
Name | Description
Background | Gets or sets background colour for spectrum viewer.
ComboFontSize | Gets or sets font size for spectrum viewer text
Foreground | Gets or sets foreground colour for spectrum viewer.
Top
See Also

Reference

ElementComboStyle Class
OINA.Extender.Controls.Styles Namespace


ElementComboStyle.Background Property

Gets or sets background colour for spectrum viewer.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color Background { get; set; }
Public Shared Property Background As Color
    Get
    Set
public:
static property Color Background {
    Color get ();
    void set (Color value);
}
static member Background : Color with get, set

Property Value

Type: Color
See Also

Reference

ElementComboStyle Class
OINA.Extender.Controls.Styles Namespace


ElementComboStyle.ComboFontSize Property

Gets or sets font size for spectrum viewer text

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double ComboFontSize { get; set; }
Public Shared Property ComboFontSize As Double
    Get
    Set
public:
static property double ComboFontSize {
    double get ();
    void set (double value);
}
static member ComboFontSize : float with get, set

Property Value

Type: Double
See Also

Reference

ElementComboStyle Class
OINA.Extender.Controls.Styles Namespace


ElementComboStyle.Foreground Property

Gets or sets foreground colour for spectrum viewer.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color Foreground { get; set; }
Public Shared Property Foreground As Color
    Get
    Set
public:
static property Color Foreground {
    Color get ();
    void set (Color value);
}
static member Foreground : Color with get, set

Property Value

Type: Color
See Also

Reference

ElementComboStyle Class
OINA.Extender.Controls.Styles Namespace


ElementComboStyle Methods

The ElementComboStyle type exposes the following members.

Methods
Name | Description
ResetStyles | Restores the default style.
Top
See Also

Reference

ElementComboStyle Class
OINA.Extender.Controls.Styles Namespace


ElementComboStyle.ResetStyles Method

Restores the default style.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static void ResetStyles()
Public Shared Sub ResetStyles
public:
static void ResetStyles()
static member ResetStyles : unit -> unit
See Also

Reference

ElementComboStyle Class
OINA.Extender.Controls.Styles Namespace


ImageViewerStyle Class

A Class used for defining the appearance of the Image Viewer Control.
Inheritance Hierarchy
SystemObject
OINA.Extender.Controls.StylesImageViewerStyle

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class ImageViewerStyle
Public NotInheritable Class ImageViewerStyle
public ref class ImageViewerStyle abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ImageViewerStyle =  class end

The ImageViewerStyle type exposes the following members.

Properties
Name | Description
BackgroundColor | Gets or sets the background colour.
ForegroundColor | Gets or sets the foreground colour.
HeaderFontFamily | Gets or sets the header font family.
HeaderFontSize | Gets or sets the header font size.
ScaleBarFontSize | Gets or sets the scale bar font size.
Top
Methods
Name | Description
ResetStyles | Reset the default style.
Top
See Also

Reference

OINA.Extender.Controls.Styles Namespace


ImageViewerStyle Properties

The ImageViewerStyle type exposes the following members.

Properties
Name | Description
BackgroundColor | Gets or sets the background colour.
ForegroundColor | Gets or sets the foreground colour.
HeaderFontFamily | Gets or sets the header font family.
HeaderFontSize | Gets or sets the header font size.
ScaleBarFontSize | Gets or sets the scale bar font size.
Top
See Also

Reference

ImageViewerStyle Class
OINA.Extender.Controls.Styles Namespace


ImageViewerStyle.BackgroundColor Property

Gets or sets the background colour.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color BackgroundColor { get; set; }
Public Shared Property BackgroundColor As Color
    Get
    Set
public:
static property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
static member BackgroundColor : Color with get, set

Property Value

Type: Color
The color of the imageviewer background.
See Also

Reference

ImageViewerStyle Class
OINA.Extender.Controls.Styles Namespace


ImageViewerStyle.ForegroundColor Property

Gets or sets the foreground colour.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color ForegroundColor { get; set; }
Public Shared Property ForegroundColor As Color
    Get
    Set
public:
static property Color ForegroundColor {
    Color get ();
    void set (Color value);
}
static member ForegroundColor : Color with get, set

Property Value

Type: Color
The color of the imageviewer background.
See Also

Reference

ImageViewerStyle Class
OINA.Extender.Controls.Styles Namespace


ImageViewerStyle.HeaderFontFamily Property

Gets or sets the header font family.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static FontFamily HeaderFontFamily { get; set; }
Public Shared Property HeaderFontFamily As FontFamily
    Get
    Set
public:
static property FontFamily^ HeaderFontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}
static member HeaderFontFamily : FontFamily with get, set

Property Value

Type: FontFamily
See Also

Reference

ImageViewerStyle Class
OINA.Extender.Controls.Styles Namespace


ImageViewerStyle.HeaderFontSize Property

Gets or sets the header font size.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double HeaderFontSize { get; set; }
Public Shared Property HeaderFontSize As Double
    Get
    Set
public:
static property double HeaderFontSize {
    double get ();
    void set (double value);
}
static member HeaderFontSize : float with get, set

Property Value

Type: Double
See Also

Reference

ImageViewerStyle Class
OINA.Extender.Controls.Styles Namespace


ImageViewerStyle.ScaleBarFontSize Property

Gets or sets the scale bar font size.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double ScaleBarFontSize { get; set; }
Public Shared Property ScaleBarFontSize As Double
    Get
    Set
public:
static property double ScaleBarFontSize {
    double get ();
    void set (double value);
}
static member ScaleBarFontSize : float with get, set

Property Value

Type: Double
See Also

Reference

ImageViewerStyle Class
OINA.Extender.Controls.Styles Namespace


ImageViewerStyle Methods

The ImageViewerStyle type exposes the following members.

Methods
Name | Description
ResetStyles | Reset the default style.
Top
See Also

Reference

ImageViewerStyle Class
OINA.Extender.Controls.Styles Namespace


ImageViewerStyle.ResetStyles Method

Reset the default style.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static void ResetStyles()
Public Shared Sub ResetStyles
public:
static void ResetStyles()
static member ResetStyles : unit -> unit
See Also

Reference

ImageViewerStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle Class

A Class used to configure the appearance of the Periodic Table Control.
Inheritance Hierarchy
SystemObject
OINA.Extender.Controls.StylesPeriodicTableStyle

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class PeriodicTableStyle
Public NotInheritable Class PeriodicTableStyle
public ref class PeriodicTableStyle abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PeriodicTableStyle =  class end

The PeriodicTableStyle type exposes the following members.

Properties
Name | Description
BackgroundColor | Gets or sets the color of the periodic table background.
ElementBorderColor | Gets or sets element border colour for periodic table display.
ElementExcludeBackgroundColor | Gets or sets colour used for each element button representing an excluded element.
ElementFontColor | Gets or sets the font colour used for each element button.
ElementHighlightColor | Gets or sets the highlighting colour used for each element button.
ElementIdleBackgroundColor | Gets or sets the color of the element idle background.
ElementIncludeBackgroundColor | Gets or sets the element background colour.
PeriodicTableFontFamily | Gets or sets the font family used for periodic table display text.
PeriodicTableFontSize | Gets or sets the size of the periodic table font.
PeriodicTableFontStyle | Gets or sets the font style for the periodic table display.
Top
Methods
Name | Description
ResetStyles | Reset the default style.
Top
See Also

Reference

OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle Properties

The PeriodicTableStyle type exposes the following members.

Properties
Name | Description
BackgroundColor | Gets or sets the color of the periodic table background.
ElementBorderColor | Gets or sets element border colour for periodic table display.
ElementExcludeBackgroundColor | Gets or sets colour used for each element button representing an excluded element.
ElementFontColor | Gets or sets the font colour used for each element button.
ElementHighlightColor | Gets or sets the highlighting colour used for each element button.
ElementIdleBackgroundColor | Gets or sets the color of the element idle background.
ElementIncludeBackgroundColor | Gets or sets the element background colour.
PeriodicTableFontFamily | Gets or sets the font family used for periodic table display text.
PeriodicTableFontSize | Gets or sets the size of the periodic table font.
PeriodicTableFontStyle | Gets or sets the font style for the periodic table display.
Top
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle.BackgroundColor Property

Gets or sets the color of the periodic table background.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color BackgroundColor { get; set; }
Public Shared Property BackgroundColor As Color
    Get
    Set
public:
static property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
static member BackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle.ElementBorderColor Property

Gets or sets element border colour for periodic table display.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color ElementBorderColor { get; set; }
Public Shared Property ElementBorderColor As Color
    Get
    Set
public:
static property Color ElementBorderColor {
    Color get ();
    void set (Color value);
}
static member ElementBorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle.ElementExcludeBackgroundColor Property

Gets or sets colour used for each element button representing an excluded element.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color ElementExcludeBackgroundColor { get; set; }
Public Shared Property ElementExcludeBackgroundColor As Color
    Get
    Set
public:
static property Color ElementExcludeBackgroundColor {
    Color get ();
    void set (Color value);
}
static member ElementExcludeBackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle.ElementFontColor Property

Gets or sets the font colour used for each element button.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color ElementFontColor { get; set; }
Public Shared Property ElementFontColor As Color
    Get
    Set
public:
static property Color ElementFontColor {
    Color get ();
    void set (Color value);
}
static member ElementFontColor : Color with get, set

Property Value

Type: Color
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle.ElementHighlightColor Property

Gets or sets the highlighting colour used for each element button.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color ElementHighlightColor { get; set; }
Public Shared Property ElementHighlightColor As Color
    Get
    Set
public:
static property Color ElementHighlightColor {
    Color get ();
    void set (Color value);
}
static member ElementHighlightColor : Color with get, set

Property Value

Type: Color
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle.ElementIdleBackgroundColor Property

Gets or sets the color of the element idle background.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color ElementIdleBackgroundColor { get; set; }
Public Shared Property ElementIdleBackgroundColor As Color
    Get
    Set
public:
static property Color ElementIdleBackgroundColor {
    Color get ();
    void set (Color value);
}
static member ElementIdleBackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle.ElementIncludeBackgroundColor Property

Gets or sets the element background colour.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color ElementIncludeBackgroundColor { get; set; }
Public Shared Property ElementIncludeBackgroundColor As Color
    Get
    Set
public:
static property Color ElementIncludeBackgroundColor {
    Color get ();
    void set (Color value);
}
static member ElementIncludeBackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle.PeriodicTableFontFamily Property

Gets or sets the font family used for periodic table display text.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static FontFamily PeriodicTableFontFamily { get; set; }
Public Shared Property PeriodicTableFontFamily As FontFamily
    Get
    Set
public:
static property FontFamily^ PeriodicTableFontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}
static member PeriodicTableFontFamily : FontFamily with get, set

Property Value

Type: FontFamily
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle.PeriodicTableFontSize Property

Gets or sets the size of the periodic table font.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double PeriodicTableFontSize { get; set; }
Public Shared Property PeriodicTableFontSize As Double
    Get
    Set
public:
static property double PeriodicTableFontSize {
    double get ();
    void set (double value);
}
static member PeriodicTableFontSize : float with get, set

Property Value

Type: Double
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle.PeriodicTableFontStyle Property

Gets or sets the font style for the periodic table display.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static FontStyle PeriodicTableFontStyle { get; set; }
Public Shared Property PeriodicTableFontStyle As FontStyle
    Get
    Set
public:
static property FontStyle PeriodicTableFontStyle {
    FontStyle get ();
    void set (FontStyle value);
}
static member PeriodicTableFontStyle : FontStyle with get, set

Property Value

Type: FontStyle
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle Methods

The PeriodicTableStyle type exposes the following members.

Methods
Name | Description
ResetStyles | Reset the default style.
Top
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


PeriodicTableStyle.ResetStyles Method

Reset the default style.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static void ResetStyles()
Public Shared Sub ResetStyles
public:
static void ResetStyles()
static member ResetStyles : unit -> unit
See Also

Reference

PeriodicTableStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle Class

A Class used for defining the appearance of the SpectrumViewer control.
Inheritance Hierarchy
SystemObject
OINA.Extender.Controls.StylesSpectrumViewerStyle

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class SpectrumViewerStyle
Public NotInheritable Class SpectrumViewerStyle
public ref class SpectrumViewerStyle abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SpectrumViewerStyle =  class end

The SpectrumViewerStyle type exposes the following members.

Properties
Name | Description
AlternatePeakLabelBackground | Gets or sets the alternative peak label background colour.
AlternatePeakLabelTextColor | Gets or sets the alternative peak label text colour.
AxisColor | Gets or sets the axis colour.
AxisFontSize | Gets or sets the axis font size.
AxisLabelMargin | Gets or sets the axis label margin.
AxisLineThickness | Gets or sets the axis line thickness.
AxisMajorTickLength | Gets or sets the axis major tick length.
AxisMinorTickLength | Gets or sets the axis minor tick length.
AxisSubMinorTickLength | Gets or sets the axis sub minor tick length.
AxisTextColor | Gets or sets the axis text colour.
IsAxisLineVisible | Gets or sets a value indicating whether axis lines are visible.
QuantResultsBackgroundColor | Gets or sets the color of the quant results background.
QuantResultsBackgroundOpacity | Gets or sets the quant results background opacity.
QuantResultsCategory | Gets or sets the quant results category.
QuantResultsFormat | Gets or sets the quant results format.
ShowQuantResults | Gets or sets a value indicating whether to show the quant results.
SpectrumBackgroundColor | Gets or sets the colour of the background.
SpectrumLabelTextColor | Gets or sets the colour of the Label.
SpectrumPeakLabelBackgroundColor | Gets or sets the peak label background colour.
SpectrumPeakLabelBorderColor | Gets or sets the peak label border colour.
SpectrumPeakLabelTextColor | Gets or sets the peak label text colour.
SpectrumVisualFillColor | Gets or sets the colour of the spectrum.
Top
Methods
Name | Description
ResetStyles | Reset the default style.
Top
See Also

Reference

OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle Properties

The SpectrumViewerStyle type exposes the following members.

Properties
Name | Description
AlternatePeakLabelBackground | Gets or sets the alternative peak label background colour.
AlternatePeakLabelTextColor | Gets or sets the alternative peak label text colour.
AxisColor | Gets or sets the axis colour.
AxisFontSize | Gets or sets the axis font size.
AxisLabelMargin | Gets or sets the axis label margin.
AxisLineThickness | Gets or sets the axis line thickness.
AxisMajorTickLength | Gets or sets the axis major tick length.
AxisMinorTickLength | Gets or sets the axis minor tick length.
AxisSubMinorTickLength | Gets or sets the axis sub minor tick length.
AxisTextColor | Gets or sets the axis text colour.
IsAxisLineVisible | Gets or sets a value indicating whether axis lines are visible.
QuantResultsBackgroundColor | Gets or sets the color of the quant results background.
QuantResultsBackgroundOpacity | Gets or sets the quant results background opacity.
QuantResultsCategory | Gets or sets the quant results category.
QuantResultsFormat | Gets or sets the quant results format.
ShowQuantResults | Gets or sets a value indicating whether to show the quant results.
SpectrumBackgroundColor | Gets or sets the colour of the background.
SpectrumLabelTextColor | Gets or sets the colour of the Label.
SpectrumPeakLabelBackgroundColor | Gets or sets the peak label background colour.
SpectrumPeakLabelBorderColor | Gets or sets the peak label border colour.
SpectrumPeakLabelTextColor | Gets or sets the peak label text colour.
SpectrumVisualFillColor | Gets or sets the colour of the spectrum.
Top
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.AlternatePeakLabelBackground Property

Gets or sets the alternative peak label background colour.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color AlternatePeakLabelBackground { get; set; }
Public Shared Property AlternatePeakLabelBackground As Color
    Get
    Set
public:
static property Color AlternatePeakLabelBackground {
    Color get ();
    void set (Color value);
}
static member AlternatePeakLabelBackground : Color with get, set

Property Value

Type: Color
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.AlternatePeakLabelTextColor Property

Gets or sets the alternative peak label text colour.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color AlternatePeakLabelTextColor { get; set; }
Public Shared Property AlternatePeakLabelTextColor As Color
    Get
    Set
public:
static property Color AlternatePeakLabelTextColor {
    Color get ();
    void set (Color value);
}
static member AlternatePeakLabelTextColor : Color with get, set

Property Value

Type: Color
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.AxisColor Property

Gets or sets the axis colour.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color AxisColor { get; set; }
Public Shared Property AxisColor As Color
    Get
    Set
public:
static property Color AxisColor {
    Color get ();
    void set (Color value);
}
static member AxisColor : Color with get, set

Property Value

Type: Color
The color of the axis tick color.
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.AxisFontSize Property

Gets or sets the axis font size.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double AxisFontSize { get; set; }
Public Shared Property AxisFontSize As Double
    Get
    Set
public:
static property double AxisFontSize {
    double get ();
    void set (double value);
}
static member AxisFontSize : float with get, set

Property Value

Type: Double
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.AxisLabelMargin Property

Gets or sets the axis label margin.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Thickness AxisLabelMargin { get; set; }
Public Shared Property AxisLabelMargin As Thickness
    Get
    Set
public:
static property Thickness AxisLabelMargin {
    Thickness get ();
    void set (Thickness value);
}
static member AxisLabelMargin : Thickness with get, set

Property Value

Type: Thickness
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.AxisLineThickness Property

Gets or sets the axis line thickness.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double AxisLineThickness { get; set; }
Public Shared Property AxisLineThickness As Double
    Get
    Set
public:
static property double AxisLineThickness {
    double get ();
    void set (double value);
}
static member AxisLineThickness : float with get, set

Property Value

Type: Double
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.AxisMajorTickLength Property

Gets or sets the axis major tick length.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double AxisMajorTickLength { get; set; }
Public Shared Property AxisMajorTickLength As Double
    Get
    Set
public:
static property double AxisMajorTickLength {
    double get ();
    void set (double value);
}
static member AxisMajorTickLength : float with get, set

Property Value

Type: Double
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.AxisMinorTickLength Property

Gets or sets the axis minor tick length.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double AxisMinorTickLength { get; set; }
Public Shared Property AxisMinorTickLength As Double
    Get
    Set
public:
static property double AxisMinorTickLength {
    double get ();
    void set (double value);
}
static member AxisMinorTickLength : float with get, set

Property Value

Type: Double
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.AxisSubMinorTickLength Property

Gets or sets the axis sub minor tick length.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double AxisSubMinorTickLength { get; set; }
Public Shared Property AxisSubMinorTickLength As Double
    Get
    Set
public:
static property double AxisSubMinorTickLength {
    double get ();
    void set (double value);
}
static member AxisSubMinorTickLength : float with get, set

Property Value

Type: Double
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.AxisTextColor Property

Gets or sets the axis text colour.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color AxisTextColor { get; set; }
Public Shared Property AxisTextColor As Color
    Get
    Set
public:
static property Color AxisTextColor {
    Color get ();
    void set (Color value);
}
static member AxisTextColor : Color with get, set

Property Value

Type: Color
The color of the axis foreground.
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.IsAxisLineVisible Property

Gets or sets a value indicating whether axis lines are visible.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static bool IsAxisLineVisible { get; set; }
Public Shared Property IsAxisLineVisible As Boolean
    Get
    Set
public:
static property bool IsAxisLineVisible {
    bool get ();
    void set (bool value);
}
static member IsAxisLineVisible : bool with get, set

Property Value

Type: Boolean
true if the axis visible; otherwise, false.
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.QuantResultsBackgroundColor Property

Gets or sets the color of the quant results background.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color QuantResultsBackgroundColor { get; set; }
Public Shared Property QuantResultsBackgroundColor As Color
    Get
    Set
public:
static property Color QuantResultsBackgroundColor {
    Color get ();
    void set (Color value);
}
static member QuantResultsBackgroundColor : Color with get, set

Property Value

Type: Color
The color of the quant results background.
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.QuantResultsBackgroundOpacity Property

Gets or sets the quant results background opacity.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static double QuantResultsBackgroundOpacity { get; set; }
Public Shared Property QuantResultsBackgroundOpacity As Double
    Get
    Set
public:
static property double QuantResultsBackgroundOpacity {
    double get ();
    void set (double value);
}
static member QuantResultsBackgroundOpacity : float with get, set

Property Value

Type: Double
The quant results background opacity.
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.QuantResultsCategory Property

Gets or sets the quant results category.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static QuantResultCategory QuantResultsCategory { get; set; }
Public Shared Property QuantResultsCategory As QuantResultCategory
    Get
    Set
public:
static property QuantResultCategory QuantResultsCategory {
    QuantResultCategory get ();
    void set (QuantResultCategory value);
}
static member QuantResultsCategory : QuantResultCategory with get, set

Property Value

Type: QuantResultCategory
The quant results category.
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.QuantResultsFormat Property

Gets or sets the quant results format.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static QuantResultFormat QuantResultsFormat { get; set; }
Public Shared Property QuantResultsFormat As QuantResultFormat
    Get
    Set
public:
static property QuantResultFormat QuantResultsFormat {
    QuantResultFormat get ();
    void set (QuantResultFormat value);
}
static member QuantResultsFormat : QuantResultFormat with get, set

Property Value

Type: QuantResultFormat
The quant results format.
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.ShowQuantResults Property

Gets or sets a value indicating whether to show the quant results.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static bool ShowQuantResults { get; set; }
Public Shared Property ShowQuantResults As Boolean
    Get
    Set
public:
static property bool ShowQuantResults {
    bool get ();
    void set (bool value);
}
static member ShowQuantResults : bool with get, set

Property Value

Type: Boolean
true if showing the quant results; otherwise, false.
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.SpectrumBackgroundColor Property

Gets or sets the colour of the background.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color SpectrumBackgroundColor { get; set; }
Public Shared Property SpectrumBackgroundColor As Color
    Get
    Set
public:
static property Color SpectrumBackgroundColor {
    Color get ();
    void set (Color value);
}
static member SpectrumBackgroundColor : Color with get, set

Property Value

Type: Color
The color of the spectrumviewer background.
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.SpectrumLabelTextColor Property

Gets or sets the colour of the Label.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color SpectrumLabelTextColor { get; set; }
Public Shared Property SpectrumLabelTextColor As Color
    Get
    Set
public:
static property Color SpectrumLabelTextColor {
    Color get ();
    void set (Color value);
}
static member SpectrumLabelTextColor : Color with get, set

Property Value

Type: Color
The color of the spectrumviewer foreground.
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.SpectrumPeakLabelBackgroundColor Property

Gets or sets the peak label background colour.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color SpectrumPeakLabelBackgroundColor { get; set; }
Public Shared Property SpectrumPeakLabelBackgroundColor As Color
    Get
    Set
public:
static property Color SpectrumPeakLabelBackgroundColor {
    Color get ();
    void set (Color value);
}
static member SpectrumPeakLabelBackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.SpectrumPeakLabelBorderColor Property

Gets or sets the peak label border colour.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color SpectrumPeakLabelBorderColor { get; set; }
Public Shared Property SpectrumPeakLabelBorderColor As Color
    Get
    Set
public:
static property Color SpectrumPeakLabelBorderColor {
    Color get ();
    void set (Color value);
}
static member SpectrumPeakLabelBorderColor : Color with get, set

Property Value

Type: Color
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.SpectrumPeakLabelTextColor Property

Gets or sets the peak label text colour.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color SpectrumPeakLabelTextColor { get; set; }
Public Shared Property SpectrumPeakLabelTextColor As Color
    Get
    Set
public:
static property Color SpectrumPeakLabelTextColor {
    Color get ();
    void set (Color value);
}
static member SpectrumPeakLabelTextColor : Color with get, set

Property Value

Type: Color
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.SpectrumVisualFillColor Property

Gets or sets the colour of the spectrum.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static Color SpectrumVisualFillColor { get; set; }
Public Shared Property SpectrumVisualFillColor As Color
    Get
    Set
public:
static property Color SpectrumVisualFillColor {
    Color get ();
    void set (Color value);
}
static member SpectrumVisualFillColor : Color with get, set

Property Value

Type: Color
The color of the Spectrum Visual Fill.
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle Methods

The SpectrumViewerStyle type exposes the following members.

Methods
Name | Description
ResetStyles | Reset the default style.
Top
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


SpectrumViewerStyle.ResetStyles Method

Reset the default style.

Namespace: OINA.Extender.Controls.Styles
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static void ResetStyles()
Public Shared Sub ResetStyles
public:
static void ResetStyles()
static member ResetStyles : unit -> unit
See Also

Reference

SpectrumViewerStyle Class
OINA.Extender.Controls.Styles Namespace


OINA.Extender.Data Namespace

Top level Class (for Ed, Image and Region) that describes Data Types available within Extender.

OINA Extender Data Namespace

Classes
 | Class | Description
Public class | Chord | A Class representing a line of pixels in the X direction, starting at X, Y.
Public class | ChordList | A Class representing a list of chords.
Public class | SpatialDataChangedEventArgs | A Class that provides information about a changed region of an image, or map.
Interfaces
 | Interface | Description
Public interface | IPeakLabels | An Interface that defines spectrum peak labels.
Public interface | IPeakParameters | IPeakParameters interface
Public interface | IPeriodicTableElement | An Interface that defines information about an element.


Chord Class

A Class representing a line of pixels in the X direction, starting at X, Y.
Inheritance Hierarchy
SystemObject
OINA.Extender.DataChord

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class Chord
Public Class Chord
public ref class Chord
type Chord =  class end

The Chord type exposes the following members.

Constructors
 | Name | Description
Public method | Chord | Initializes a new instance of the Chord class.
Top
Properties
 | Name | Description
Public property | Length | Gets the Chord length.
Public property | X | Gets Chord X position.
Public property | Y | Gets Chord Y position.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Data Namespace


Chord Constructor

Initializes a new instance of the Chord class.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Chord(
    int x,
    int y,
    int length
)
Public Sub New (
    x As Integer,
    y As Integer,
    length As Integer
)
public:
Chord(
    int x,
    int y,
    int length
)
new :
        x : int *
        y : int *
        length : int -> Chord

Parameters

x
Type: SystemInt32
The x position
y
Type: SystemInt32
The y position
length
Type: SystemInt32
The length
See Also

Reference

Chord Class
OINA.Extender.Data Namespace


Chord Properties

The Chord type exposes the following members.

Properties
 | Name | Description
Public property | Length | Gets the Chord length.
Public property | X | Gets Chord X position.
Public property | Y | Gets Chord Y position.
Top
See Also

Reference

Chord Class
OINA.Extender.Data Namespace


Chord.Length Property

Gets the Chord length.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
member Length : int with get

Property Value

Type: Int32
See Also

Reference

Chord Class
OINA.Extender.Data Namespace


Chord.X Property

Gets Chord X position.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public int X { get; }
Public ReadOnly Property X As Integer
    Get
public:
property int X {
    int get ();
}
member X : int with get

Property Value

Type: Int32
See Also

Reference

Chord Class
OINA.Extender.Data Namespace


Chord.Y Property

Gets Chord Y position.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public int Y { get; }
Public ReadOnly Property Y As Integer
    Get
public:
property int Y {
    int get ();
}
member Y : int with get

Property Value

Type: Int32
See Also

Reference

Chord Class
OINA.Extender.Data Namespace


Chord Methods

The Chord type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Chord Class
OINA.Extender.Data Namespace


ChordList Class

A Class representing a list of chords.
Inheritance Hierarchy
SystemObject
OINA.Extender.DataChordList

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class ChordList : IEnumerable<Chord>,
    IReadOnlyCollection<Chord>, IEnumerable
Public Class ChordList
    Implements IEnumerable(Of Chord), IReadOnlyCollection(Of Chord),
    IEnumerable
public ref class ChordList : IEnumerable<Chord^>,
    IReadOnlyCollection<Chord^>, IEnumerable
type ChordList =
    class
        interface IEnumerable<Chord>
        interface IReadOnlyCollection<Chord>
        interface IEnumerable
    end

The ChordList type exposes the following members.

Constructors
 | Name | Description
Public method | ChordList | Initializes a new instance of the ChordList class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of chords in the list.
Public property | Id | Gets the unique ID for this chordlist.
Public property | Item | Gets Chord at the specified index in the list.
Public property | PixelSize | Gets pixel size of the Chord List (1/ (the resolution in pixels)).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets the enumerator
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Data Namespace


ChordList Constructor

Initializes a new instance of the ChordList class.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ChordList(
    IEnumerable<Chord> chords,
    double pixelSize
)
Public Sub New (
    chords As IEnumerable(Of Chord),
    pixelSize As Double
)
public:
ChordList(
    IEnumerable<Chord^>^ chords,
    double pixelSize
)
new :
        chords : IEnumerable<Chord> *
        pixelSize : float -> ChordList

Parameters

chords
Type: System.Collections.GenericIEnumerable Chord
Chords that define the acquisition area
pixelSize
Type: SystemDouble
The size of a pixel (= 1 / resolution in pixels).
See Also

Reference

ChordList Class
OINA.Extender.Data Namespace


ChordList Properties

The ChordList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of chords in the list.
Public property | Id | Gets the unique ID for this chordlist.
Public property | Item | Gets Chord at the specified index in the list.
Public property | PixelSize | Gets pixel size of the Chord List (1/ (the resolution in pixels)).
Top
See Also

Reference

ChordList Class
OINA.Extender.Data Namespace


ChordList.Count Property

Gets the number of chords in the list.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Property Value

Type: Int32
The number of chords.

Implements

IReadOnlyCollectionTCount
See Also

Reference

ChordList Class
OINA.Extender.Data Namespace


ChordList.Id Property

Gets the unique ID for this chordlist.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}
member Id : Guid with get

Property Value

Type: Guid
The ID.
See Also

Reference

ChordList Class
OINA.Extender.Data Namespace


ChordList.Item Property

Gets Chord at the specified index in the list.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Chord this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Chord
    Get
public:
property Chord^ default[int index] {
    Chord^ get (int index);
}
member Item : Chord with get

Parameters

index
Type: SystemInt32
The index

Return Value

Type: Chord
The chord at the specified index
See Also

Reference

ChordList Class
OINA.Extender.Data Namespace


ChordList.PixelSize Property

Gets pixel size of the Chord List (1/ (the resolution in pixels)).

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double PixelSize { get; }
Public ReadOnly Property PixelSize As Double
    Get
public:
property double PixelSize {
    double get ();
}
member PixelSize : float with get

Property Value

Type: Double
See Also

Reference

ChordList Class
OINA.Extender.Data Namespace


ChordList Methods

The ChordList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets the enumerator
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChordList Class
OINA.Extender.Data Namespace


ChordList.GetEnumerator Method

Gets the enumerator

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<Chord> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Chord)
public:
virtual IEnumerator<Chord^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<Chord>
override GetEnumerator : unit -> IEnumerator<Chord>

Return Value

Type: IEnumerator Chord
The enumerator

Implements

IEnumerableTGetEnumerator
See Also

Reference

ChordList Class
OINA.Extender.Data Namespace


IPeakLabels Interface

An Interface that defines spectrum peak labels.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IPeakLabels
Public Interface IPeakLabels
public interface class IPeakLabels
type IPeakLabels =  interface end

The IPeakLabels type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of peak labels defined.
Top
Methods
 | Name | Description
Public method | Add | Adds a peak label with a particular energy and label.
Public method | Clear | Removes all peak labels.
Public method | GetAtomicNumber | Gets the atomic number of a peak label at a specified index.
Public method | GetLabel | Gets the label of a peak label at a specified index.
Public method | Remove | Removes the peak label for an element at the specified energy.
Public method | SetLabel | Sets the label of a peak label at a specified index.
Top
See Also

Reference

OINA.Extender.Data Namespace


IPeakLabels Properties

The IPeakLabels type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of peak labels defined.
Top
See Also

Reference

IPeakLabels Interface
OINA.Extender.Data Namespace


IPeakLabels.Count Property

Gets the number of peak labels defined.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Property Value

Type: Int32
See Also

Reference

IPeakLabels Interface
OINA.Extender.Data Namespace


IPeakLabels Methods

The IPeakLabels type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a peak label with a particular energy and label.
Public method | Clear | Removes all peak labels.
Public method | GetAtomicNumber | Gets the atomic number of a peak label at a specified index.
Public method | GetLabel | Gets the label of a peak label at a specified index.
Public method | Remove | Removes the peak label for an element at the specified energy.
Public method | SetLabel | Sets the label of a peak label at a specified index.
Top
See Also

Reference

IPeakLabels Interface
OINA.Extender.Data Namespace


IPeakLabels.Add Method

Adds a peak label with a particular energy and label.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void Add(
    int atomicNumber,
    string label
)
Sub Add (
    atomicNumber As Integer,
    label As String
)
void Add(
    int atomicNumber,
    String^ label
)
abstract Add :
        atomicNumber : int *
        label : string -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number
label
Type: SystemString
The label
See Also

Reference

IPeakLabels Interface
OINA.Extender.Data Namespace


IPeakLabels.Clear Method

Removes all peak labels.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void Clear()
Sub Clear
void Clear()
abstract Clear : unit -> unit
See Also

Reference

IPeakLabels Interface
OINA.Extender.Data Namespace


IPeakLabels.GetAtomicNumber Method

Gets the atomic number of a peak label at a specified index.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int GetAtomicNumber(
    int index
)
Function GetAtomicNumber (
    index As Integer
) As Integer
int GetAtomicNumber(
    int index
)
abstract GetAtomicNumber :
        index : int -> int

Parameters

index
Type: SystemInt32
The index (zero-based)

Return Value

Type: Int32
The atomic number
See Also

Reference

IPeakLabels Interface
OINA.Extender.Data Namespace


IPeakLabels.GetLabel Method

Gets the label of a peak label at a specified index.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string GetLabel(
    int index
)
Function GetLabel (
    index As Integer
) As String
String^ GetLabel(
    int index
)
abstract GetLabel :
        index : int -> string

Parameters

index
Type: SystemInt32
The index (zero-based)

Return Value

Type: String
The Label
See Also

Reference

IPeakLabels Interface
OINA.Extender.Data Namespace


IPeakLabels.Remove Method

Removes the peak label for an element at the specified energy.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void Remove(
    int atomicNumber
)
Sub Remove (
    atomicNumber As Integer
)
void Remove(
    int atomicNumber
)
abstract Remove :
        atomicNumber : int -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number
See Also

Reference

IPeakLabels Interface
OINA.Extender.Data Namespace


IPeakLabels.SetLabel Method

Sets the label of a peak label at a specified index.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetLabel(
    int index,
    string label
)
Sub SetLabel (
    index As Integer,
    label As String
)
void SetLabel(
    int index,
    String^ label
)
abstract SetLabel :
        index : int *
        label : string -> unit

Parameters

index
Type: SystemInt32
The index (zero-based)
label
Type: SystemString
The new label
See Also

Reference

IPeakLabels Interface
OINA.Extender.Data Namespace


IPeakParameters Interface

IPeakParameters interface

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IPeakParameters
Public Interface IPeakParameters
public interface class IPeakParameters
type IPeakParameters =  interface end

The IPeakParameters type exposes the following members.

Properties
 | Name | Description
Public property | Centre | Gets the centre channel of the gaussian.
Public property | FWHM | Gets the FWHM in eV of the peak.
Top
See Also

Reference

OINA.Extender.Data Namespace


IPeakParameters Properties

The IPeakParameters type exposes the following members.

Properties
 | Name | Description
Public property | Centre | Gets the centre channel of the gaussian.
Public property | FWHM | Gets the FWHM in eV of the peak.
Top
See Also

Reference

IPeakParameters Interface
OINA.Extender.Data Namespace


IPeakParameters.Centre Property

Gets the centre channel of the gaussian.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Centre { get; }
ReadOnly Property Centre As Double
    Get
property double Centre {
    double get ();
}
abstract Centre : float with get

Property Value

Type: Double
See Also

Reference

IPeakParameters Interface
OINA.Extender.Data Namespace


IPeakParameters.FWHM Property

Gets the FWHM in eV of the peak.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double FWHM { get; }
ReadOnly Property FWHM As Double
    Get
property double FWHM {
    double get ();
}
abstract FWHM : float with get

Property Value

Type: Double
See Also

Reference

IPeakParameters Interface
OINA.Extender.Data Namespace


IPeriodicTableElement Interface

An Interface that defines information about an element.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IPeriodicTableElement
Public Interface IPeriodicTableElement
public interface class IPeriodicTableElement
type IPeriodicTableElement =  interface end

The IPeriodicTableElement type exposes the following members.

Properties
 | Name | Description
Public property | AtomicNumber | Gets the element’s atomic number.
Public property | ElementDensity | Gets the element’s density.
Public property | ElementName | Gets the element’s name.
Public property | ElementValency | Gets the element’s valency.
Public property | Symbol | Gets the element’s periodic table symbol.
Top
See Also

Reference

OINA.Extender.Data Namespace


IPeriodicTableElement Properties

The IPeriodicTableElement type exposes the following members.

Properties
 | Name | Description
Public property | AtomicNumber | Gets the element’s atomic number.
Public property | ElementDensity | Gets the element’s density.
Public property | ElementName | Gets the element’s name.
Public property | ElementValency | Gets the element’s valency.
Public property | Symbol | Gets the element’s periodic table symbol.
Top
See Also

Reference

IPeriodicTableElement Interface
OINA.Extender.Data Namespace


IPeriodicTableElement.AtomicNumber Property

Gets the element’s atomic number.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int AtomicNumber { get; }
ReadOnly Property AtomicNumber As Integer
    Get
property int AtomicNumber {
    int get ();
}
abstract AtomicNumber : int with get

Property Value

Type: Int32
See Also

Reference

IPeriodicTableElement Interface
OINA.Extender.Data Namespace


IPeriodicTableElement.ElementDensity Property

Gets the element’s density.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
float ElementDensity { get; }
ReadOnly Property ElementDensity As Single
    Get
property float ElementDensity {
    float get ();
}
abstract ElementDensity : float32 with get

Property Value

Type: Single
See Also

Reference

IPeriodicTableElement Interface
OINA.Extender.Data Namespace


IPeriodicTableElement.ElementName Property

Gets the element’s name.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string ElementName { get; }
ReadOnly Property ElementName As String
    Get
property String^ ElementName {
    String^ get ();
}
abstract ElementName : string with get

Property Value

Type: String
See Also

Reference

IPeriodicTableElement Interface
OINA.Extender.Data Namespace


IPeriodicTableElement.ElementValency Property

Gets the element’s valency.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int ElementValency { get; }
ReadOnly Property ElementValency As Integer
    Get
property int ElementValency {
    int get ();
}
abstract ElementValency : int with get

Property Value

Type: Int32
See Also

Reference

IPeriodicTableElement Interface
OINA.Extender.Data Namespace


IPeriodicTableElement.Symbol Property

Gets the element’s periodic table symbol.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string Symbol { get; }
ReadOnly Property Symbol As String
    Get
property String^ Symbol {
    String^ get ();
}
abstract Symbol : string with get

Property Value

Type: String
See Also

Reference

IPeriodicTableElement Interface
OINA.Extender.Data Namespace


SpatialDataChangedEventArgs Class

A Class that provides information about a changed region of an image, or map.
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.Extender.DataSpatialDataChangedEventArgs

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class SpatialDataChangedEventArgs : EventArgs
Public Class SpatialDataChangedEventArgs
    Inherits EventArgs
public ref class SpatialDataChangedEventArgs : public EventArgs
type SpatialDataChangedEventArgs =
    class
        inherit EventArgs
    end

The SpatialDataChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChangedPixels | Gets a value indicating the changed region in pixel co-ordinates.
Public property | Ids | Gets the identities of the hardware responsible for the change.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Data Namespace


SpatialDataChangedEventArgs Properties

The SpatialDataChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChangedPixels | Gets a value indicating the changed region in pixel co-ordinates.
Public property | Ids | Gets the identities of the hardware responsible for the change.
Top
See Also

Reference

SpatialDataChangedEventArgs Class
OINA.Extender.Data Namespace


SpatialDataChangedEventArgs.ChangedPixels Property

Gets a value indicating the changed region in pixel co-ordinates.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Rectangle ChangedPixels { get; }
Public ReadOnly Property ChangedPixels As Rectangle
    Get
public:
property Rectangle ChangedPixels {
    Rectangle get ();
}
member ChangedPixels : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

SpatialDataChangedEventArgs Class
OINA.Extender.Data Namespace


SpatialDataChangedEventArgs.Ids Property

Gets the identities of the hardware responsible for the change.

Namespace: OINA.Extender.Data
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public IReadOnlyList<string> Ids { get; }
Public ReadOnly Property Ids As IReadOnlyList(Of String)
    Get
public:
property IReadOnlyList<String^>^ Ids {
    IReadOnlyList<String^>^ get ();
}
member Ids : IReadOnlyList<string> with get

Property Value

Type: IReadOnlyList String
See Also

Reference

SpatialDataChangedEventArgs Class
OINA.Extender.Data Namespace


SpatialDataChangedEventArgs Methods

The SpatialDataChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SpatialDataChangedEventArgs Class
OINA.Extender.Data Namespace


OINA.Extender.Data.Ed Namespace

Defines Classes and Interfaces that describe Ed Data Types available within Extender.

Classes
 | Class | Description
Public class | EdHardwareId | A class used to identify the hardware used for acquisition.
Interfaces
 | Interface | Description
Public interface | IEdEnergyWindow | An interface that defines information about an energy window for an element
Public interface | IEdMap | An Interface that defines an Ed Map.
Public interface | IEdMapAcquisitionData | Ed map acquisition data interface
Public interface | IEdMapDetails | An interface that defines the details of an Ed Map.
 | IEdSpectrum | An Interface that defines an Ed spectrum.
Public interface | IEdSpectrumDetails | An interface that defines the details of an Ed spectrum.
Enumerations
 | Enumeration | Description
Public enumeration | EdEnergyWindowSource | Identifies the source of the map window - i.e. how the window was generated


EdEnergyWindowSource Enumeration

Identifies the source of the map window - i.e. how the window was generated

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum EdEnergyWindowSource
Public Enumeration EdEnergyWindowSource
public enum class EdEnergyWindowSource
type EdEnergyWindowSource
Members
Member name | Value | Description
Automatic | 0 |
ManualLineSelection | 1 |
ManualEnergySelection | 2 |
See Also

Reference

OINA.Extender.Data.Ed Namespace


EdHardwareId Class

A class used to identify the hardware used for acquisition.
Inheritance Hierarchy
SystemObject
OINA.Extender.Data.EdEdHardwareId

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class EdHardwareId : IEquatable<EdHardwareId>
Public Class EdHardwareId
    Implements IEquatable(Of EdHardwareId)
public ref class EdHardwareId : IEquatable<EdHardwareId^>
type EdHardwareId =
    class
        interface IEquatable<EdHardwareId>
    end

The EdHardwareId type exposes the following members.

Properties
 | Name | Description
Public property | DetectorDeviceId | Gets the detector device identifier.
Public property | DetectorSerialNumber | Gets the detector serial number.
Public property | DisplayName | Gets the display name. Name used to identify detector in the UI.
Public property | EdDeviceId | Gets the Ed device identifier.
Public property | XSyncDeviceId | Gets the xsync device identifier.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether two hardware ids are the same. (Overrides ObjectEquals(Object).)
Public method | Equals(EdHardwareId) | Determines whether two hardware ids are the same.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.
Top
See Also

Reference

OINA.Extender.Data.Ed Namespace


EdHardwareId Properties

The EdHardwareId type exposes the following members.

Properties
 | Name | Description
Public property | DetectorDeviceId | Gets the detector device identifier.
Public property | DetectorSerialNumber | Gets the detector serial number.
Public property | DisplayName | Gets the display name. Name used to identify detector in the UI.
Public property | EdDeviceId | Gets the Ed device identifier.
Public property | XSyncDeviceId | Gets the xsync device identifier.
Top
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


EdHardwareId.DetectorDeviceId Property

Gets the detector device identifier.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string DetectorDeviceId { get; }
Public ReadOnly Property DetectorDeviceId As String
    Get
public:
property String^ DetectorDeviceId {
    String^ get ();
}
member DetectorDeviceId : string with get

Property Value

Type: String
The detector device identifier.
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


EdHardwareId.DetectorSerialNumber Property

Gets the detector serial number.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string DetectorSerialNumber { get; }
Public ReadOnly Property DetectorSerialNumber As String
    Get
public:
property String^ DetectorSerialNumber {
    String^ get ();
}
member DetectorSerialNumber : string with get

Property Value

Type: String
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


EdHardwareId.DisplayName Property

Gets the display name. Name used to identify detector in the UI.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}
member DisplayName : string with get

Property Value

Type: String
The display name.
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


EdHardwareId.EdDeviceId Property

Gets the Ed device identifier.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string EdDeviceId { get; }
Public ReadOnly Property EdDeviceId As String
    Get
public:
property String^ EdDeviceId {
    String^ get ();
}
member EdDeviceId : string with get

Property Value

Type: String
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


EdHardwareId.XSyncDeviceId Property

Gets the xsync device identifier.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public string XSyncDeviceId { get; }
Public ReadOnly Property XSyncDeviceId As String
    Get
public:
property String^ XSyncDeviceId {
    String^ get ();
}
member XSyncDeviceId : string with get

Property Value

Type: String
The xsync device identifier.
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


EdHardwareId Methods

The EdHardwareId type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether two hardware ids are the same. (Overrides ObjectEquals(Object).)
Public method | Equals(EdHardwareId) | Determines whether two hardware ids are the same.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


EdHardwareId.Equals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether two hardware ids are the same. (Overrides ObjectEquals(Object).)
Public method | Equals(EdHardwareId) | Determines whether two hardware ids are the same.
Top
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


EdHardwareId.Equals Method (Object)

Determines whether two hardware ids are the same.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

EdHardwareId Class
Equals Overload
OINA.Extender.Data.Ed Namespace


EdHardwareId.Equals Method (EdHardwareId)

Determines whether two hardware ids are the same.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    EdHardwareId other
)
Public Function Equals (
    other As EdHardwareId
) As Boolean
public:
virtual bool Equals(
    EdHardwareId^ other
) sealed
abstract Equals :
        other : EdHardwareId -> bool
override Equals :
        other : EdHardwareId -> bool

Parameters

other
Type: OINA.Extender.Data.EdEdHardwareId
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

EdHardwareId Class
Equals Overload
OINA.Extender.Data.Ed Namespace


EdHardwareId.GetHashCode Method

Returns a hash code for this instance.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


EdHardwareId Operators

The EdHardwareId type exposes the following members.

Operators
Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.
Top
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


EdHardwareId.Equality Operator

Implements the operator ==.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    EdHardwareId leftHand,
    EdHardwareId rightHand
)
Public Shared Operator = (
    leftHand As EdHardwareId,
    rightHand As EdHardwareId
) As Boolean
public:
static bool operator ==(
    EdHardwareId^ leftHand,
    EdHardwareId^ rightHand
)
static let inline (=)
        leftHand : EdHardwareId *
        rightHand : EdHardwareId  : bool

Parameters

leftHand
Type: OINA.Extender.Data.EdEdHardwareId
A.
rightHand
Type: OINA.Extender.Data.EdEdHardwareId
The b.

Return Value

Type: Boolean
The result of the operator.
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


EdHardwareId.Inequality Operator

Implements the operator !=.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    EdHardwareId leftHand,
    EdHardwareId rightHand
)
Public Shared Operator <> (
    leftHand As EdHardwareId,
    rightHand As EdHardwareId
) As Boolean
public:
static bool operator !=(
    EdHardwareId^ leftHand,
    EdHardwareId^ rightHand
)
static let inline (<>)
        leftHand : EdHardwareId *
        rightHand : EdHardwareId  : bool

Parameters

leftHand
Type: OINA.Extender.Data.EdEdHardwareId
A.
rightHand
Type: OINA.Extender.Data.EdEdHardwareId
The b.

Return Value

Type: Boolean
The result of the operator.
See Also

Reference

EdHardwareId Class
OINA.Extender.Data.Ed Namespace


IEdEnergyWindow Interface

An interface that defines information about an energy window for an element

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdEnergyWindow
Public Interface IEdEnergyWindow
public interface class IEdEnergyWindow
type IEdEnergyWindow =  interface end

The IEdEnergyWindow type exposes the following members.

Properties
 | Name | Description
Public property | AtomicNumber | Gets the atomic number of the element
Public property | LineCode | Gets the line code for the element line being mapped
Public property | LowerEnergy | Gets the lower energy of the window in keV
Public property | Source | Gets the origin of the map energy window. Has it been manually defined or automatically generated.
Public property | UpperEnergy | Gets the upper energy of the window in keV
Top
See Also

Reference

OINA.Extender.Data.Ed Namespace


IEdEnergyWindow Properties

The IEdEnergyWindow type exposes the following members.

Properties
 | Name | Description
Public property | AtomicNumber | Gets the atomic number of the element
Public property | LineCode | Gets the line code for the element line being mapped
Public property | LowerEnergy | Gets the lower energy of the window in keV
Public property | Source | Gets the origin of the map energy window. Has it been manually defined or automatically generated.
Public property | UpperEnergy | Gets the upper energy of the window in keV
Top
See Also

Reference

IEdEnergyWindow Interface
OINA.Extender.Data.Ed Namespace


IEdEnergyWindow.AtomicNumber Property

Gets the atomic number of the element

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int AtomicNumber { get; }
ReadOnly Property AtomicNumber As Integer
    Get
property int AtomicNumber {
    int get ();
}
abstract AtomicNumber : int with get

Property Value

Type: Int32
See Also

Reference

IEdEnergyWindow Interface
OINA.Extender.Data.Ed Namespace


IEdEnergyWindow.LineCode Property

Gets the line code for the element line being mapped

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string LineCode { get; }
ReadOnly Property LineCode As String
    Get
property String^ LineCode {
    String^ get ();
}
abstract LineCode : string with get

Property Value

Type: String
See Also

Reference

IEdEnergyWindow Interface
OINA.Extender.Data.Ed Namespace


IEdEnergyWindow.LowerEnergy Property

Gets the lower energy of the window in keV

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double LowerEnergy { get; }
ReadOnly Property LowerEnergy As Double
    Get
property double LowerEnergy {
    double get ();
}
abstract LowerEnergy : float with get

Property Value

Type: Double
See Also

Reference

IEdEnergyWindow Interface
OINA.Extender.Data.Ed Namespace


IEdEnergyWindow.Source Property

Gets the origin of the map energy window. Has it been manually defined or automatically generated.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
EdEnergyWindowSource Source { get; }
ReadOnly Property Source As EdEnergyWindowSource
    Get
property EdEnergyWindowSource Source {
    EdEnergyWindowSource get ();
}
abstract Source : EdEnergyWindowSource with get

Property Value

Type: EdEnergyWindowSource
See Also

Reference

IEdEnergyWindow Interface
OINA.Extender.Data.Ed Namespace


IEdEnergyWindow.UpperEnergy Property

Gets the upper energy of the window in keV

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double UpperEnergy { get; }
ReadOnly Property UpperEnergy As Double
    Get
property double UpperEnergy {
    double get ();
}
abstract UpperEnergy : float with get

Property Value

Type: Double
See Also

Reference

IEdEnergyWindow Interface
OINA.Extender.Data.Ed Namespace


IEdMap Interface

An Interface that defines an Ed Map.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdMap : INotifyPropertyChanged, IDisposable
Public Interface IEdMap
    Inherits INotifyPropertyChanged, IDisposable
public interface class IEdMap : INotifyPropertyChanged,
    IDisposable
type IEdMap =
    interface
        interface INotifyPropertyChanged
        interface IDisposable
    end

The IEdMap type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date.
Public property | ColumnConditions | Gets the microscope column conditions.
Public property | Details | Gets a snapshot of the map details
Public property | EnergyRange | Gets energy range in keV.
Public property | ExcludedElements | Gets the excluded elements within the map.
Public property | HardwareIds | Gets identifiers for all devices used to acquire the data.
Public property | Height | Gets the height of the map in pixels.
Public property | Id | Gets a unique identifier for the map.
Public property | IdentifiedElements | Gets the identified elements within the map.
Public property | Label | Gets or sets the label, where the label is a user defined string for naming the map.
Public property | LiveTimeSeconds | Gets the live time in seconds.
Public property | NumberOfChannels | Gets the number of channels.
Public property | PixelSize | Gets the pixel size.
Public property | PrimaryHardwareId | Gets the identifier of the primary device used to acquire the data.
Public property | ProcessTime | Gets the process time.
Public property | RealTimeSeconds | Gets the real time in seconds.
Public property | Region | Gets the acquisition region.
Public property | StageConditions | Gets the microscope stage conditions.
Public property | StrobeWidth | Gets the FWHM of the strobe in eV.
Public property | Width | Gets the width of the map in pixels.
Top
Methods
 | Name | Description
Public method | ClearExcludedElements | Clears the excluded elements.
Public method | ClearIdentifiedElements | Clears the identified elements.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetLiveTimes | Copies the live times into the supplied buffer. Buffer length should be at least (Width x Height) / binFactor.
Public method | SetExcludedElement | Excludes an element from the auto Id process.
Public method | SetExcludedElements | Excludes a range of elements from the auto Id process.
Public method | SetIdentifiedElement | Sets an identified element.
Public method | SetIdentifiedElements | Sets a range of identified elements.
Top
Events
 | Name | Description
Public event | DataChanged | Occurs when the data changes.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Data.Ed Namespace


IEdMap Properties

The IEdMap type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date.
Public property | ColumnConditions | Gets the microscope column conditions.
Public property | Details | Gets a snapshot of the map details
Public property | EnergyRange | Gets energy range in keV.
Public property | ExcludedElements | Gets the excluded elements within the map.
Public property | HardwareIds | Gets identifiers for all devices used to acquire the data.
Public property | Height | Gets the height of the map in pixels.
Public property | Id | Gets a unique identifier for the map.
Public property | IdentifiedElements | Gets the identified elements within the map.
Public property | Label | Gets or sets the label, where the label is a user defined string for naming the map.
Public property | LiveTimeSeconds | Gets the live time in seconds.
Public property | NumberOfChannels | Gets the number of channels.
Public property | PixelSize | Gets the pixel size.
Public property | PrimaryHardwareId | Gets the identifier of the primary device used to acquire the data.
Public property | ProcessTime | Gets the process time.
Public property | RealTimeSeconds | Gets the real time in seconds.
Public property | Region | Gets the acquisition region.
Public property | StageConditions | Gets the microscope stage conditions.
Public property | StrobeWidth | Gets the FWHM of the strobe in eV.
Public property | Width | Gets the width of the map in pixels.
Top
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.AcquisitionDate Property

Gets the acquisition date.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DateTime AcquisitionDate { get; }
ReadOnly Property AcquisitionDate As DateTime
    Get
property DateTime AcquisitionDate {
    DateTime get ();
}
abstract AcquisitionDate : DateTime with get

Property Value

Type: DateTime
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.ColumnConditions Property

Gets the microscope column conditions.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IColumnConditions ColumnConditions { get; }
ReadOnly Property ColumnConditions As IColumnConditions
    Get
property IColumnConditions^ ColumnConditions {
    IColumnConditions^ get ();
}
abstract ColumnConditions : IColumnConditions with get

Property Value

Type: IColumnConditions
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.Details Property

Gets a snapshot of the map details

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdMapDetails Details { get; }
ReadOnly Property Details As IEdMapDetails
    Get
property IEdMapDetails^ Details {
    IEdMapDetails^ get ();
}
abstract Details : IEdMapDetails with get

Property Value

Type: IEdMapDetails
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.EnergyRange Property

Gets energy range in keV.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int EnergyRange { get; }
ReadOnly Property EnergyRange As Integer
    Get
property int EnergyRange {
    int get ();
}
abstract EnergyRange : int with get

Property Value

Type: Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.ExcludedElements Property

Gets the excluded elements within the map.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEnumerable<int> ExcludedElements { get; }
ReadOnly Property ExcludedElements As IEnumerable(Of Integer)
    Get
property IEnumerable<int>^ ExcludedElements {
    IEnumerable<int>^ get ();
}
abstract ExcludedElements : IEnumerable<int> with get

Property Value

Type: IEnumerable Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.HardwareIds Property

Gets identifiers for all devices used to acquire the data.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEnumerable<EdHardwareId> HardwareIds { get; }
ReadOnly Property HardwareIds As IEnumerable(Of EdHardwareId)
    Get
property IEnumerable<EdHardwareId^>^ HardwareIds {
    IEnumerable<EdHardwareId^>^ get ();
}
abstract HardwareIds : IEnumerable<EdHardwareId> with get

Property Value

Type: IEnumerable EdHardwareId
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.Height Property

Gets the height of the map in pixels.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int Height { get; }
ReadOnly Property Height As Integer
    Get
property int Height {
    int get ();
}
abstract Height : int with get

Property Value

Type: Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.Id Property

Gets a unique identifier for the map.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Guid Id { get; }
ReadOnly Property Id As Guid
    Get
property Guid Id {
    Guid get ();
}
abstract Id : Guid with get

Property Value

Type: Guid
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.IdentifiedElements Property

Gets the identified elements within the map.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEnumerable<int> IdentifiedElements { get; }
ReadOnly Property IdentifiedElements As IEnumerable(Of Integer)
    Get
property IEnumerable<int>^ IdentifiedElements {
    IEnumerable<int>^ get ();
}
abstract IdentifiedElements : IEnumerable<int> with get

Property Value

Type: IEnumerable Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.Label Property

Gets or sets the label, where the label is a user defined string for naming the map.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string Label { get; set; }
Property Label As String
    Get
    Set
property String^ Label {
    String^ get ();
    void set (String^ value);
}
abstract Label : string with get, set

Property Value

Type: String
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.LiveTimeSeconds Property

Gets the live time in seconds.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double LiveTimeSeconds { get; }
ReadOnly Property LiveTimeSeconds As Double
    Get
property double LiveTimeSeconds {
    double get ();
}
abstract LiveTimeSeconds : float with get

Property Value

Type: Double
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.NumberOfChannels Property

Gets the number of channels.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int NumberOfChannels { get; }
ReadOnly Property NumberOfChannels As Integer
    Get
property int NumberOfChannels {
    int get ();
}
abstract NumberOfChannels : int with get

Property Value

Type: Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.PixelSize Property

Gets the pixel size.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double PixelSize { get; }
ReadOnly Property PixelSize As Double
    Get
property double PixelSize {
    double get ();
}
abstract PixelSize : float with get

Property Value

Type: Double
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.PrimaryHardwareId Property

Gets the identifier of the primary device used to acquire the data.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
EdHardwareId PrimaryHardwareId { get; }
ReadOnly Property PrimaryHardwareId As EdHardwareId
    Get
property EdHardwareId^ PrimaryHardwareId {
    EdHardwareId^ get ();
}
abstract PrimaryHardwareId : EdHardwareId with get

Property Value

Type: EdHardwareId
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.ProcessTime Property

Gets the process time.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int ProcessTime { get; }
ReadOnly Property ProcessTime As Integer
    Get
property int ProcessTime {
    int get ();
}
abstract ProcessTime : int with get

Property Value

Type: Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.RealTimeSeconds Property

Gets the real time in seconds.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double RealTimeSeconds { get; }
ReadOnly Property RealTimeSeconds As Double
    Get
property double RealTimeSeconds {
    double get ();
}
abstract RealTimeSeconds : float with get

Property Value

Type: Double
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.Region Property

Gets the acquisition region.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IRegion Region { get; }
ReadOnly Property Region As IRegion
    Get
property IRegion^ Region {
    IRegion^ get ();
}
abstract Region : IRegion with get

Property Value

Type: IRegion
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.StageConditions Property

Gets the microscope stage conditions.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IStageConditions StageConditions { get; }
ReadOnly Property StageConditions As IStageConditions
    Get
property IStageConditions^ StageConditions {
    IStageConditions^ get ();
}
abstract StageConditions : IStageConditions with get

Property Value

Type: IStageConditions
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.StrobeWidth Property

Gets the FWHM of the strobe in eV.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StrobeWidth { get; }
ReadOnly Property StrobeWidth As Double
    Get
property double StrobeWidth {
    double get ();
}
abstract StrobeWidth : float with get

Property Value

Type: Double
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.Width Property

Gets the width of the map in pixels.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int Width { get; }
ReadOnly Property Width As Integer
    Get
property int Width {
    int get ();
}
abstract Width : int with get

Property Value

Type: Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap Methods

The IEdMap type exposes the following members.

Methods
 | Name | Description
Public method | ClearExcludedElements | Clears the excluded elements.
Public method | ClearIdentifiedElements | Clears the identified elements.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetLiveTimes | Copies the live times into the supplied buffer. Buffer length should be at least (Width x Height) / binFactor.
Public method | SetExcludedElement | Excludes an element from the auto Id process.
Public method | SetExcludedElements | Excludes a range of elements from the auto Id process.
Public method | SetIdentifiedElement | Sets an identified element.
Public method | SetIdentifiedElements | Sets a range of identified elements.
Top
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.ClearExcludedElements Method

Clears the excluded elements.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void ClearExcludedElements()
Sub ClearExcludedElements
void ClearExcludedElements()
abstract ClearExcludedElements : unit -> unit
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.ClearIdentifiedElements Method

Clears the identified elements.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void ClearIdentifiedElements()
Sub ClearIdentifiedElements
void ClearIdentifiedElements()
abstract ClearIdentifiedElements : unit -> unit
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.GetLiveTimes Method

Copies the live times into the supplied buffer. Buffer length should be at least (Width x Height) / binFactor.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void GetLiveTimes(
    int binFactor,
    float[] buffer
)
Sub GetLiveTimes (
    binFactor As Integer,
    buffer As Single()
)
void GetLiveTimes(
    int binFactor,
    array<float>^ buffer
)
abstract GetLiveTimes :
        binFactor : int *
        buffer : float32[] -> unit

Parameters

binFactor
Type: SystemInt32
The bin factor.
buffer
Type: SystemSingle
The buffer.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
ArgumentNullException | Thrown if buffer is null.
ArgumentOutOfRangeException | Thrown if buffer is too small.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.SetExcludedElement Method

Excludes an element from the auto Id process.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetExcludedElement(
    int atomicNumber,
    bool excluded
)
Sub SetExcludedElement (
    atomicNumber As Integer,
    excluded As Boolean
)
void SetExcludedElement(
    int atomicNumber,
    bool excluded
)
abstract SetExcludedElement :
        atomicNumber : int *
        excluded : bool -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number.
excluded
Type: SystemBoolean
True to exclude the element, otherwise false.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.SetExcludedElements Method

Excludes a range of elements from the auto Id process.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetExcludedElements(
    IEnumerable<int> atomicNumbers,
    bool excluded
)
Sub SetExcludedElements (
    atomicNumbers As IEnumerable(Of Integer),
    excluded As Boolean
)
void SetExcludedElements(
    IEnumerable<int>^ atomicNumbers,
    bool excluded
)
abstract SetExcludedElements :
        atomicNumbers : IEnumerable<int> *
        excluded : bool -> unit

Parameters

atomicNumbers
Type: System.Collections.GenericIEnumerable Int32
The atomic numbers.
excluded
Type: SystemBoolean
True to exclude the elements, otherwise false.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.SetIdentifiedElement Method

Sets an identified element.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetIdentifiedElement(
    int atomicNumber,
    bool identified
)
Sub SetIdentifiedElement (
    atomicNumber As Integer,
    identified As Boolean
)
void SetIdentifiedElement(
    int atomicNumber,
    bool identified
)
abstract SetIdentifiedElement :
        atomicNumber : int *
        identified : bool -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number.
identified
Type: SystemBoolean
True to identify the element, otherwise false.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.SetIdentifiedElements Method

Sets a range of identified elements.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetIdentifiedElements(
    IEnumerable<int> atomicNumbers,
    bool identified
)
Sub SetIdentifiedElements (
    atomicNumbers As IEnumerable(Of Integer),
    identified As Boolean
)
void SetIdentifiedElements(
    IEnumerable<int>^ atomicNumbers,
    bool identified
)
abstract SetIdentifiedElements :
        atomicNumbers : IEnumerable<int> *
        identified : bool -> unit

Parameters

atomicNumbers
Type: System.Collections.GenericIEnumerable Int32
The atomic numbers.
identified
Type: SystemBoolean
True to identify the elements, otherwise false.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the map is disposed.
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap Events

The IEdMap type exposes the following members.

Events
 | Name | Description
Public event | DataChanged | Occurs when the data changes.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMap.DataChanged Event

Occurs when the data changes.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<SpatialDataChangedEventArgs> DataChanged
Event DataChanged As EventHandler(Of SpatialDataChangedEventArgs)
 event EventHandler<SpatialDataChangedEventArgs^>^ DataChanged {
    void add (EventHandler<SpatialDataChangedEventArgs^>^ value);
    void remove (EventHandler<SpatialDataChangedEventArgs^>^ value);
}
abstract DataChanged : IEvent<EventHandler<SpatialDataChangedEventArgs>,
    SpatialDataChangedEventArgs>

Value

Type: SystemEventHandler SpatialDataChangedEventArgs
See Also

Reference

IEdMap Interface
OINA.Extender.Data.Ed Namespace


IEdMapAcquisitionData Interface

Ed map acquisition data interface

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdMapAcquisitionData
Public Interface IEdMapAcquisitionData
public interface class IEdMapAcquisitionData
type IEdMapAcquisitionData =  interface end

The IEdMapAcquisitionData type exposes the following members.

Properties
 | Name | Description
Public property | EdMap | Gets the Ed map.
Public property | EdSpectrum | Gets the Ed sum spectrum.
Top
See Also

Reference

OINA.Extender.Data.Ed Namespace


IEdMapAcquisitionData Properties

The IEdMapAcquisitionData type exposes the following members.

Properties
 | Name | Description
Public property | EdMap | Gets the Ed map.
Public property | EdSpectrum | Gets the Ed sum spectrum.
Top
See Also

Reference

IEdMapAcquisitionData Interface
OINA.Extender.Data.Ed Namespace


IEdMapAcquisitionData.EdMap Property

Gets the Ed map.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdMap EdMap { get; }
ReadOnly Property EdMap As IEdMap
    Get
property IEdMap^ EdMap {
    IEdMap^ get ();
}
abstract EdMap : IEdMap with get

Property Value

Type: IEdMap
See Also

Reference

IEdMapAcquisitionData Interface
OINA.Extender.Data.Ed Namespace


IEdMapAcquisitionData.EdSpectrum Property

Gets the Ed sum spectrum.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSpectrum EdSpectrum { get; }
ReadOnly Property EdSpectrum As IEdSpectrum
    Get
property IEdSpectrum^ EdSpectrum {
    IEdSpectrum^ get ();
}
abstract EdSpectrum : IEdSpectrum with get

Property Value

Type: IEdSpectrum
See Also

Reference

IEdMapAcquisitionData Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails Interface

An interface that defines the details of an Ed Map.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdMapDetails
Public Interface IEdMapDetails
public interface class IEdMapDetails
type IEdMapDetails =  interface end

The IEdMapDetails type exposes the following members.

Properties
 | Name | Description
Public property | AcceleratingVoltage | Gets the microscope accelerating voltage in kV.
Public property | AcquisitionDate | Gets acquisition date.
Public property | EffectiveMagnificationWithZoom | Gets the effective magnification used for an image if digital zoom (for drift correction) is included.
Public property | EnergyRange | Gets the energy range in keV.
Public property | Height | Gets the height of map in pixels
Public property | ImageHeight | Gets the map height in mm
Public property | ImageWidth | Gets the map width in mm
Public property | Label | Gets the label, a user defined string for naming the map.
Public property | LiveTimeSeconds | Gets the live time in seconds.
Public property | NumberOfChannels | Gets the number of channels.
Public property | NumberOfFrames | Gets the number of frames
Public property | PrimaryDetectorSerialNumber | Gets the identifier for the primary detector used to acquire the data.
Public property | ProcessTime | Gets the process time.
Public property | SecondaryDetectorSerialNumbers | Gets identifiers for the secondary detectors used to acquire the data.
Public property | TotalCounts | Gets the total counts in the map
Public property | Width | Gets the width of the map in pixels
Public property | WorkingDistance | Gets the microscope working distance in mm.
Top
See Also

Reference

OINA.Extender.Data.Ed Namespace


IEdMapDetails Properties

The IEdMapDetails type exposes the following members.

Properties
 | Name | Description
Public property | AcceleratingVoltage | Gets the microscope accelerating voltage in kV.
Public property | AcquisitionDate | Gets acquisition date.
Public property | EffectiveMagnificationWithZoom | Gets the effective magnification used for an image if digital zoom (for drift correction) is included.
Public property | EnergyRange | Gets the energy range in keV.
Public property | Height | Gets the height of map in pixels
Public property | ImageHeight | Gets the map height in mm
Public property | ImageWidth | Gets the map width in mm
Public property | Label | Gets the label, a user defined string for naming the map.
Public property | LiveTimeSeconds | Gets the live time in seconds.
Public property | NumberOfChannels | Gets the number of channels.
Public property | NumberOfFrames | Gets the number of frames
Public property | PrimaryDetectorSerialNumber | Gets the identifier for the primary detector used to acquire the data.
Public property | ProcessTime | Gets the process time.
Public property | SecondaryDetectorSerialNumbers | Gets identifiers for the secondary detectors used to acquire the data.
Public property | TotalCounts | Gets the total counts in the map
Public property | Width | Gets the width of the map in pixels
Public property | WorkingDistance | Gets the microscope working distance in mm.
Top
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.AcceleratingVoltage Property

Gets the microscope accelerating voltage in kV.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double AcceleratingVoltage { get; }
ReadOnly Property AcceleratingVoltage As Double
    Get
property double AcceleratingVoltage {
    double get ();
}
abstract AcceleratingVoltage : float with get

Property Value

Type: Double
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.AcquisitionDate Property

Gets acquisition date.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DateTime AcquisitionDate { get; }
ReadOnly Property AcquisitionDate As DateTime
    Get
property DateTime AcquisitionDate {
    DateTime get ();
}
abstract AcquisitionDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.EffectiveMagnificationWithZoom Property

Gets the effective magnification used for an image if digital zoom (for drift correction) is included.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double EffectiveMagnificationWithZoom { get; }
ReadOnly Property EffectiveMagnificationWithZoom As Double
    Get
property double EffectiveMagnificationWithZoom {
    double get ();
}
abstract EffectiveMagnificationWithZoom : float with get

Property Value

Type: Double
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.EnergyRange Property

Gets the energy range in keV.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int EnergyRange { get; }
ReadOnly Property EnergyRange As Integer
    Get
property int EnergyRange {
    int get ();
}
abstract EnergyRange : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.Height Property

Gets the height of map in pixels

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Height { get; }
ReadOnly Property Height As Double
    Get
property double Height {
    double get ();
}
abstract Height : float with get

Property Value

Type: Double
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.ImageHeight Property

Gets the map height in mm

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double ImageHeight { get; }
ReadOnly Property ImageHeight As Double
    Get
property double ImageHeight {
    double get ();
}
abstract ImageHeight : float with get

Property Value

Type: Double
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.ImageWidth Property

Gets the map width in mm

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double ImageWidth { get; }
ReadOnly Property ImageWidth As Double
    Get
property double ImageWidth {
    double get ();
}
abstract ImageWidth : float with get

Property Value

Type: Double
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.Label Property

Gets the label, a user defined string for naming the map.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string Label { get; }
ReadOnly Property Label As String
    Get
property String^ Label {
    String^ get ();
}
abstract Label : string with get

Property Value

Type: String
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.LiveTimeSeconds Property

Gets the live time in seconds.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double LiveTimeSeconds { get; }
ReadOnly Property LiveTimeSeconds As Double
    Get
property double LiveTimeSeconds {
    double get ();
}
abstract LiveTimeSeconds : float with get

Property Value

Type: Double
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.NumberOfChannels Property

Gets the number of channels.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int NumberOfChannels { get; }
ReadOnly Property NumberOfChannels As Integer
    Get
property int NumberOfChannels {
    int get ();
}
abstract NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.NumberOfFrames Property

Gets the number of frames

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int NumberOfFrames { get; }
ReadOnly Property NumberOfFrames As Integer
    Get
property int NumberOfFrames {
    int get ();
}
abstract NumberOfFrames : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.PrimaryDetectorSerialNumber Property

Gets the identifier for the primary detector used to acquire the data.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string PrimaryDetectorSerialNumber { get; }
ReadOnly Property PrimaryDetectorSerialNumber As String
    Get
property String^ PrimaryDetectorSerialNumber {
    String^ get ();
}
abstract PrimaryDetectorSerialNumber : string with get

Property Value

Type: String
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.ProcessTime Property

Gets the process time.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int ProcessTime { get; }
ReadOnly Property ProcessTime As Integer
    Get
property int ProcessTime {
    int get ();
}
abstract ProcessTime : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.SecondaryDetectorSerialNumbers Property

Gets identifiers for the secondary detectors used to acquire the data.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string SecondaryDetectorSerialNumbers { get; }
ReadOnly Property SecondaryDetectorSerialNumbers As String
    Get
property String^ SecondaryDetectorSerialNumbers {
    String^ get ();
}
abstract SecondaryDetectorSerialNumbers : string with get

Property Value

Type: String
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.TotalCounts Property

Gets the total counts in the map

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
long TotalCounts { get; }
ReadOnly Property TotalCounts As Long
    Get
property long long TotalCounts {
    long long get ();
}
abstract TotalCounts : int64 with get

Property Value

Type: Int64
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.Width Property

Gets the width of the map in pixels

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Width { get; }
ReadOnly Property Width As Double
    Get
property double Width {
    double get ();
}
abstract Width : float with get

Property Value

Type: Double
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdMapDetails.WorkingDistance Property

Gets the microscope working distance in mm.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double WorkingDistance { get; }
ReadOnly Property WorkingDistance As Double
    Get
property double WorkingDistance {
    double get ();
}
abstract WorkingDistance : float with get

Property Value

Type: Double
See Also

Reference

IEdMapDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum Interface

An Interface that defines an Ed spectrum.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdSpectrum : INotifyPropertyChanged,
    IDisposable
Public Interface IEdSpectrum
    Inherits INotifyPropertyChanged, IDisposable
public interface class IEdSpectrum : INotifyPropertyChanged,
    IDisposable
type IEdSpectrum =
    interface
        interface INotifyPropertyChanged
        interface IDisposable
    end

The IEdSpectrum type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets acquisition date.
Public property | ChannelWidth | Gets the width of channel in ev
Public property | ColumnConditions | Gets the microscope column conditions.
Public property | Details | Gets a snapshot of the spectrum details
Public property | EnergyRange | Gets energy range in keV.
Public property | ExcludedElements | Gets the excluded elements within the spectrum.
Public property | HardwareIds | Gets ids used to identify the detectors used for acquisition.
Public property | Id | Gets unique identifier for the spectrum.
Public property | IdentifiedElements | Gets the identified elements within the spectrum.
Public property | IsPulsePileupCorrected | Gets a value indicating whether pulse pile-up correction has been applied.
Public property | Label | Gets or sets the label, where the label is a user defined string for naming the spectrum.
Public property | LiveTimeSeconds | Gets the live time in seconds.
Public property | NumberOfChannels | Gets the number of channels.
Public property | PeakLabels | Gets the peak labels.
Public property | PrimaryHardwareId | Gets the identifier of the primary detector used to acquire the data.
Public property | ProcessTime | Gets the process time.
Public property | PulsePileup | Gets or sets a value indicating whether the pulse pile up correction is enabled.
Public property | RealTimeSeconds | Gets the real time in seconds.
Public property | Region | Gets the acquisition region.
Public property | StageConditions | Gets the microscope stage conditions.
Public property | StrobeWidth | Gets the FWHM of the strobe in eV
Public property | ZeroChannelValue | Gets the value of channel zero in ev
Top
Methods
 | Name | Description
Public method | ClearExcludedElements | Clears the excluded elements.
Public method | ClearIdentifiedElements | Clears the identified elements.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetChannelData | Get corrected spectrum channel data The spectrum data is corrected for interpolation, escape peak stripping and pulse pile up (optional).
Public method | Save | Saves the spectrum to a byte array/
Public method | SetExcludedElement | Excludes an element from the auto Id process.
Public method | SetExcludedElements | Excludes a range of elements from the auto Id process.
Public method | SetIdentifiedElement | Sets an identified element.
Public method | SetIdentifiedElements | Sets a range of identified elements.
Top
Events
 | Name | Description
Public event | DataChanged | Event to notify when spectrum data changed
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Examples
Copy
public void Run()
{
    Console.WriteLine();
    Console.WriteLine(@"Spectrum Acquisition Example.");
    Console.WriteLine();

    Console.WriteLine();
    Console.WriteLine(@"Quantification Processing Option:");

    // Get choice of processing option from user
    var processingOptions = new Dictionary<int, string>
    {
        { 1, "All Elements" },
        { 2, "Element by Difference" },
        { 3, "Element by Stoichiometry" }
    };

    this.userProcessingOption = Program.MakeChoice(processingOptions);

    IEdSpectrumSettings edSpectrumSettings = AcquireFactory.CreateEdSpectrumSettings();

    edSpectrumSettings.EdSettings.AcquisitionMode = EdAcquireMode.LiveTime; // RealTime or LiveTime
    edSpectrumSettings.EdSettings.AcquisitionTime = TimeSpan.FromSeconds(2);

    Console.WriteLine(@"Allowed Process Times: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedProcessTimes));
    Console.WriteLine(@"Allowed Energy Ranges: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedEnergyRanges));
    Console.WriteLine(@"Allowed Number of Channels: {0}", string.Join(", ", edSpectrumSettings.EdCapabilities.AllowedNumberOfChannels));

    edSpectrumSettings.EdSettings.ProcessTime = 1;
    edSpectrumSettings.EdSettings.EnergyRange = 10;
    edSpectrumSettings.EdSettings.NumberOfChannels = 1024;

    edSpectrumSettings.ScanSettings.AcquisitionRegion.CreateFullFieldRegion(1.0 / 1024.0);

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = AcquireFactory.CreateEdSpectrumServer();

    // Event handlers for spectrum acquisition controller events
    edSpectrumAcquisitionController.ExperimentStarting += this.OnEdSpectrumExperimentStarting;
    edSpectrumAcquisitionController.ExperimentFinished += this.OnEdSpectrumExperimentFinished;

    // IEdSpectrumSettings.EdCapabilities will validate settings and hardware availability.
    if (edSpectrumAcquisitionController.IsEdHardwareReady(edSpectrumSettings))
    {
        // This only used for multiple acquisition:
        //      if this is the first acquisition, call BeginMultipleAcquisition
        //      on the IEdSpectrumAcquisitionController to suppress external scan switching
        edSpectrumAcquisitionController.BeginMultipleAcquisition();

        // Start spectrum acquisition
        try
        {
            IEdSpectrum edSpectrum = edSpectrumAcquisitionController.StartAcquisition(edSpectrumSettings);

            edSpectrum.Label = @"Code Example Spectrum";
        }
        catch (InvalidSettingsException invalidSettingsException)
        {
            Console.WriteLine(@"Invalid Settings Exception:");
            Console.WriteLine(
                @"{0} {1}",
                invalidSettingsException.Message,
                string.Join(",", invalidSettingsException.ValidationResults.ValidationErrors));
        }
        catch (AcquisitionStartException acquisitionStartException)
        {
            Console.WriteLine(@"Acquisition Start Exception:");
            Console.WriteLine(acquisitionStartException.Message);
        }
    }
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Starting.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The <see cref="AcquisitionFinishedEventArgs{IEdSpectrum}"/> instance containing the event data.</param>
private void OnEdSpectrumExperimentStarting(object sender, AcquisitionStartingEventArgs<IEdSpectrum> e)
{
    IEdSpectrum edSpectrum = e.Value;

    Console.WriteLine(@"Spectrum Acquisition starting: {0}", edSpectrum.Label);
    Console.WriteLine();

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        edSpectrumAcquisitionController.ExperimentStarting -= this.OnEdSpectrumExperimentStarting;
        edSpectrumAcquisitionController.ExperimentStarted += this.OnEdSpectrumExperimentStarted;
    }

    edSpectrum.PropertyChanged += this.OnPropertyChanged;
    edSpectrum.DataChanged += this.OnDataChanged;
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Started.
/// </summary>
/// <param name="sender">The sender.</param>
/// <param name="e">The <see cref="AcquisitionFinishedEventArgs{IEdSpectrum}"/> instance containing the event data.</param>
private void OnEdSpectrumExperimentStarted(object sender, AcquisitionStartedEventArgs<IEdSpectrum> e)
{
    IEdSpectrum edSpectrum = e.Value;

    Console.WriteLine(@"Spectrum Acquisition started: {0}", edSpectrum.Label);
    Console.WriteLine();

    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        edSpectrumAcquisitionController.ExperimentStarted -= this.OnEdSpectrumExperimentStarted;
    }
}

/// <summary>
/// Called when IEdSpectrumAcquisitionController Experiment Finished
/// </summary>
/// <param name="sender">sender object</param>
/// <param name="e">The instance containing the event data.</param>
private void OnEdSpectrumExperimentFinished(object sender, AcquisitionFinishedEventArgs<IEdSpectrum> e)
{
    IEdSpectrumAcquisitionController edSpectrumAcquisitionController = sender as IEdSpectrumAcquisitionController;

    if (edSpectrumAcquisitionController != null)
    {
        // This only used for multiple acquisition:
        //      If this is the last experiment, call EndMultipleAcquisition on the Acquisition
        //      controller, to re-enable external scan switching
        edSpectrumAcquisitionController.EndMultipleAcquisition();

        edSpectrumAcquisitionController.ExperimentFinished -= this.OnEdSpectrumExperimentFinished;
    }

    IEdSpectrum edSpectrum = e.Value;

    edSpectrum.PropertyChanged -= this.OnPropertyChanged;
    edSpectrum.DataChanged -= this.OnDataChanged;

    Console.WriteLine();
    Console.WriteLine(@"Spectrum Acquisition finished: {0}", edSpectrum.Label);
    Console.WriteLine(@"    AcquisitionDate: {0}", edSpectrum.AcquisitionDate);
    Console.WriteLine(@"    LiveTime: {0:0.00}, RealTime: {1:0.00}", edSpectrum.LiveTimeSeconds, edSpectrum.RealTimeSeconds);
    Console.WriteLine();

    this.edSpectrum = edSpectrum;

    this.DoAutoID();
    this.DoQuant();

    Console.WriteLine();
    Console.WriteLine();
    Console.WriteLine(@"Code Example finished.");
}

/// <summary>
/// Called when IEdSpectrum PropertyChanged
/// </summary>
/// <param name="sender">Event source</param>
/// <param name="e">Event arguments</param>
private void OnPropertyChanged(object sender, PropertyChangedEventArgs e)
{
    var edSpectrum = (IEdSpectrum)sender;

    var output = string.Empty;

    switch (e.PropertyName)
    {
        case "ColumnConditions":
            output = string.Format(CultureInfo.InvariantCulture, @"     Column Conditions: eg WorkingDistance - {0:0.00}", edSpectrum.ColumnConditions.WorkingDistance);
            break;
        case "StageConditions":
            output = string.Format(CultureInfo.InvariantCulture, @"     Stage Conditions: eg StageR - {0:0.00}", edSpectrum.StageConditions.StageR);
            break;
        case "AcquisitionDate":
            output = string.Format(CultureInfo.InvariantCulture, @"     Acquisition Date: {0:dd-MMM-yy HH:mm:ss}", edSpectrum.AcquisitionDate);
            break;
        case "HardwareIds":
            output = string.Format(CultureInfo.InvariantCulture, @"     HardwareIds: eg DetectorDeviceId - {0}", string.Join(",", edSpectrum.HardwareIds.Select(h => h.DetectorDeviceId).ToArray()));
            break;
        case "PrimaryHardwareId":
            output = string.Format(CultureInfo.InvariantCulture, @"     PrimaryHardwareId: eg DetectorDeviceId - {0}", string.Join(",", edSpectrum.PrimaryHardwareId.DetectorDeviceId));
            break;
        case "RealTimeSeconds":
            output = string.Format(CultureInfo.InvariantCulture, @"     Real Time - {0:0.00}", edSpectrum.RealTimeSeconds);
            break;
        case "LiveTimeSeconds":
            output = string.Format(CultureInfo.InvariantCulture, @"     Live Time - {0:0.00}", edSpectrum.LiveTimeSeconds);
            break;
        default:
            output = string.Format(CultureInfo.InvariantCulture, @"     {0}", e.PropertyName);
            break;
    }

    Console.WriteLine(@"Property Changed:{0}{1}", Environment.NewLine, output);
    Console.WriteLine();
}

/// <summary>
/// Called when IEdSpectrum DataChanged
/// </summary>
/// <param name="sender">Event source</param>
/// <param name="e">Event arguments</param>
private void OnDataChanged(object sender, EventArgs e)
{
    var edSpectrum = (IEdSpectrum)sender;

    var buffer = new int[edSpectrum.NumberOfChannels];

    edSpectrum.GetChannelData(buffer);

    Console.WriteLine(@"Data Changed - ChannelData: {0}{1}", Environment.NewLine, string.Join(",", buffer));
    Console.WriteLine();
}
See Also

Reference

OINA.Extender.Data.Ed Namespace


IEdSpectrum Properties

The IEdSpectrum type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets acquisition date.
Public property | ChannelWidth | Gets the width of channel in ev
Public property | ColumnConditions | Gets the microscope column conditions.
Public property | Details | Gets a snapshot of the spectrum details
Public property | EnergyRange | Gets energy range in keV.
Public property | ExcludedElements | Gets the excluded elements within the spectrum.
Public property | HardwareIds | Gets ids used to identify the detectors used for acquisition.
Public property | Id | Gets unique identifier for the spectrum.
Public property | IdentifiedElements | Gets the identified elements within the spectrum.
Public property | IsPulsePileupCorrected | Gets a value indicating whether pulse pile-up correction has been applied.
Public property | Label | Gets or sets the label, where the label is a user defined string for naming the spectrum.
Public property | LiveTimeSeconds | Gets the live time in seconds.
Public property | NumberOfChannels | Gets the number of channels.
Public property | PeakLabels | Gets the peak labels.
Public property | PrimaryHardwareId | Gets the identifier of the primary detector used to acquire the data.
Public property | ProcessTime | Gets the process time.
Public property | PulsePileup | Gets or sets a value indicating whether the pulse pile up correction is enabled.
Public property | RealTimeSeconds | Gets the real time in seconds.
Public property | Region | Gets the acquisition region.
Public property | StageConditions | Gets the microscope stage conditions.
Public property | StrobeWidth | Gets the FWHM of the strobe in eV
Public property | ZeroChannelValue | Gets the value of channel zero in ev
Top
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.AcquisitionDate Property

Gets acquisition date.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DateTime AcquisitionDate { get; }
ReadOnly Property AcquisitionDate As DateTime
    Get
property DateTime AcquisitionDate {
    DateTime get ();
}
abstract AcquisitionDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.ChannelWidth Property

Gets the width of channel in ev

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double ChannelWidth { get; }
ReadOnly Property ChannelWidth As Double
    Get
property double ChannelWidth {
    double get ();
}
abstract ChannelWidth : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.ColumnConditions Property

Gets the microscope column conditions.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IColumnConditions ColumnConditions { get; }
ReadOnly Property ColumnConditions As IColumnConditions
    Get
property IColumnConditions^ ColumnConditions {
    IColumnConditions^ get ();
}
abstract ColumnConditions : IColumnConditions with get

Property Value

Type: IColumnConditions
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.Details Property

Gets a snapshot of the spectrum details

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSpectrumDetails Details { get; }
ReadOnly Property Details As IEdSpectrumDetails
    Get
property IEdSpectrumDetails^ Details {
    IEdSpectrumDetails^ get ();
}
abstract Details : IEdSpectrumDetails with get

Property Value

Type: IEdSpectrumDetails
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.EnergyRange Property

Gets energy range in keV.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int EnergyRange { get; }
ReadOnly Property EnergyRange As Integer
    Get
property int EnergyRange {
    int get ();
}
abstract EnergyRange : int with get

Property Value

Type: Int32
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.ExcludedElements Property

Gets the excluded elements within the spectrum.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEnumerable<int> ExcludedElements { get; }
ReadOnly Property ExcludedElements As IEnumerable(Of Integer)
    Get
property IEnumerable<int>^ ExcludedElements {
    IEnumerable<int>^ get ();
}
abstract ExcludedElements : IEnumerable<int> with get

Property Value

Type: IEnumerable Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the spectrum is disposed.
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.HardwareIds Property

Gets ids used to identify the detectors used for acquisition.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEnumerable<EdHardwareId> HardwareIds { get; }
ReadOnly Property HardwareIds As IEnumerable(Of EdHardwareId)
    Get
property IEnumerable<EdHardwareId^>^ HardwareIds {
    IEnumerable<EdHardwareId^>^ get ();
}
abstract HardwareIds : IEnumerable<EdHardwareId> with get

Property Value

Type: IEnumerable EdHardwareId
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.Id Property

Gets unique identifier for the spectrum.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Guid Id { get; }
ReadOnly Property Id As Guid
    Get
property Guid Id {
    Guid get ();
}
abstract Id : Guid with get

Property Value

Type: Guid
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.IdentifiedElements Property

Gets the identified elements within the spectrum.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEnumerable<int> IdentifiedElements { get; }
ReadOnly Property IdentifiedElements As IEnumerable(Of Integer)
    Get
property IEnumerable<int>^ IdentifiedElements {
    IEnumerable<int>^ get ();
}
abstract IdentifiedElements : IEnumerable<int> with get

Property Value

Type: IEnumerable Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the spectrum is disposed.
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.IsPulsePileupCorrected Property

Gets a value indicating whether pulse pile-up correction has been applied.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsPulsePileupCorrected { get; }
ReadOnly Property IsPulsePileupCorrected As Boolean
    Get
property bool IsPulsePileupCorrected {
    bool get ();
}
abstract IsPulsePileupCorrected : bool with get

Property Value

Type: Boolean
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.Label Property

Gets or sets the label, where the label is a user defined string for naming the spectrum.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string Label { get; set; }
Property Label As String
    Get
    Set
property String^ Label {
    String^ get ();
    void set (String^ value);
}
abstract Label : string with get, set

Property Value

Type: String
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.LiveTimeSeconds Property

Gets the live time in seconds.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double LiveTimeSeconds { get; }
ReadOnly Property LiveTimeSeconds As Double
    Get
property double LiveTimeSeconds {
    double get ();
}
abstract LiveTimeSeconds : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.NumberOfChannels Property

Gets the number of channels.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int NumberOfChannels { get; }
ReadOnly Property NumberOfChannels As Integer
    Get
property int NumberOfChannels {
    int get ();
}
abstract NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.PeakLabels Property

Gets the peak labels.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IPeakLabels PeakLabels { get; }
ReadOnly Property PeakLabels As IPeakLabels
    Get
property IPeakLabels^ PeakLabels {
    IPeakLabels^ get ();
}
abstract PeakLabels : IPeakLabels with get

Property Value

Type: IPeakLabels
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.PrimaryHardwareId Property

Gets the identifier of the primary detector used to acquire the data.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
EdHardwareId PrimaryHardwareId { get; }
ReadOnly Property PrimaryHardwareId As EdHardwareId
    Get
property EdHardwareId^ PrimaryHardwareId {
    EdHardwareId^ get ();
}
abstract PrimaryHardwareId : EdHardwareId with get

Property Value

Type: EdHardwareId
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.ProcessTime Property

Gets the process time.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int ProcessTime { get; }
ReadOnly Property ProcessTime As Integer
    Get
property int ProcessTime {
    int get ();
}
abstract ProcessTime : int with get

Property Value

Type: Int32
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.PulsePileup Property

Gets or sets a value indicating whether the pulse pile up correction is enabled.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool PulsePileup { get; set; }
Property PulsePileup As Boolean
    Get
    Set
property bool PulsePileup {
    bool get ();
    void set (bool value);
}
abstract PulsePileup : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.RealTimeSeconds Property

Gets the real time in seconds.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double RealTimeSeconds { get; }
ReadOnly Property RealTimeSeconds As Double
    Get
property double RealTimeSeconds {
    double get ();
}
abstract RealTimeSeconds : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.Region Property

Gets the acquisition region.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IRegion Region { get; }
ReadOnly Property Region As IRegion
    Get
property IRegion^ Region {
    IRegion^ get ();
}
abstract Region : IRegion with get

Property Value

Type: IRegion
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.StageConditions Property

Gets the microscope stage conditions.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IStageConditions StageConditions { get; }
ReadOnly Property StageConditions As IStageConditions
    Get
property IStageConditions^ StageConditions {
    IStageConditions^ get ();
}
abstract StageConditions : IStageConditions with get

Property Value

Type: IStageConditions
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.StrobeWidth Property

Gets the FWHM of the strobe in eV

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StrobeWidth { get; }
ReadOnly Property StrobeWidth As Double
    Get
property double StrobeWidth {
    double get ();
}
abstract StrobeWidth : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.ZeroChannelValue Property

Gets the value of channel zero in ev

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double ZeroChannelValue { get; }
ReadOnly Property ZeroChannelValue As Double
    Get
property double ZeroChannelValue {
    double get ();
}
abstract ZeroChannelValue : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum Methods

The IEdSpectrum type exposes the following members.

Methods
 | Name | Description
Public method | ClearExcludedElements | Clears the excluded elements.
Public method | ClearIdentifiedElements | Clears the identified elements.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetChannelData | Get corrected spectrum channel data The spectrum data is corrected for interpolation, escape peak stripping and pulse pile up (optional).
Public method | Save | Saves the spectrum to a byte array/
Public method | SetExcludedElement | Excludes an element from the auto Id process.
Public method | SetExcludedElements | Excludes a range of elements from the auto Id process.
Public method | SetIdentifiedElement | Sets an identified element.
Public method | SetIdentifiedElements | Sets a range of identified elements.
Top
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.ClearExcludedElements Method

Clears the excluded elements.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void ClearExcludedElements()
Sub ClearExcludedElements
void ClearExcludedElements()
abstract ClearExcludedElements : unit -> unit
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the spectrum is disposed.
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.ClearIdentifiedElements Method

Clears the identified elements.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void ClearIdentifiedElements()
Sub ClearIdentifiedElements
void ClearIdentifiedElements()
abstract ClearIdentifiedElements : unit -> unit
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the spectrum is disposed.
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.GetChannelData Method

Get corrected spectrum channel data The spectrum data is corrected for interpolation, escape peak stripping and pulse pile up (optional).

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void GetChannelData(
    int[] output
)
Sub GetChannelData (
    output As Integer()
)
void GetChannelData(
    array<int>^ output
)
abstract GetChannelData :
        output : int[] -> unit

Parameters

output
Type: SystemInt32
output array
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.Save Method

Saves the spectrum to a byte array/

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
byte[] Save()
Function Save As Byte()
array<unsigned char>^ Save()
abstract Save : unit -> byte[]

Return Value

Type: Byte
The byte array
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.SetExcludedElement Method

Excludes an element from the auto Id process.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetExcludedElement(
    int atomicNumber,
    bool excluded
)
Sub SetExcludedElement (
    atomicNumber As Integer,
    excluded As Boolean
)
void SetExcludedElement(
    int atomicNumber,
    bool excluded
)
abstract SetExcludedElement :
        atomicNumber : int *
        excluded : bool -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number.
excluded
Type: SystemBoolean
True to exclude the element, otherwise false.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the spectrum is disposed.
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.SetExcludedElements Method

Excludes a range of elements from the auto Id process.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetExcludedElements(
    IEnumerable<int> atomicNumbers,
    bool excluded
)
Sub SetExcludedElements (
    atomicNumbers As IEnumerable(Of Integer),
    excluded As Boolean
)
void SetExcludedElements(
    IEnumerable<int>^ atomicNumbers,
    bool excluded
)
abstract SetExcludedElements :
        atomicNumbers : IEnumerable<int> *
        excluded : bool -> unit

Parameters

atomicNumbers
Type: System.Collections.GenericIEnumerable Int32
The atomic numbers.
excluded
Type: SystemBoolean
True to exclude the elements, otherwise false.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the spectrum is disposed.
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.SetIdentifiedElement Method

Sets an identified element.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetIdentifiedElement(
    int atomicNumber,
    bool identified
)
Sub SetIdentifiedElement (
    atomicNumber As Integer,
    identified As Boolean
)
void SetIdentifiedElement(
    int atomicNumber,
    bool identified
)
abstract SetIdentifiedElement :
        atomicNumber : int *
        identified : bool -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number.
identified
Type: SystemBoolean
True to identify the element, otherwise false.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the spectrum is disposed.
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.SetIdentifiedElements Method

Sets a range of identified elements.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetIdentifiedElements(
    IEnumerable<int> atomicNumbers,
    bool identified
)
Sub SetIdentifiedElements (
    atomicNumbers As IEnumerable(Of Integer),
    identified As Boolean
)
void SetIdentifiedElements(
    IEnumerable<int>^ atomicNumbers,
    bool identified
)
abstract SetIdentifiedElements :
        atomicNumbers : IEnumerable<int> *
        identified : bool -> unit

Parameters

atomicNumbers
Type: System.Collections.GenericIEnumerable Int32
The atomic numbers.
identified
Type: SystemBoolean
True to identify the elements, otherwise false.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the spectrum is disposed.
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum Events

The IEdSpectrum type exposes the following members.

Events
 | Name | Description
Public event | DataChanged | Event to notify when spectrum data changed
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrum.DataChanged Event

Event to notify when spectrum data changed

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler DataChanged
Event DataChanged As EventHandler
 event EventHandler^ DataChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract DataChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IEdSpectrum Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails Interface

An interface that defines the details of an Ed spectrum.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdSpectrumDetails
Public Interface IEdSpectrumDetails
public interface class IEdSpectrumDetails
type IEdSpectrumDetails =  interface end

The IEdSpectrumDetails type exposes the following members.

Properties
 | Name | Description
Public property | AcceleratingVoltage | Gets the microscope accelerating voltage in kV.
Public property | AcquisitionDate | Gets acquisition date.
Public property | AzimuthAngle | Gets the azimuth angle in degrees.
Public property | DetectorElevation | Gets the detector elevation in degrees.
Public property | DetectorType | Gets the detector type.
Public property | DetectorTypeId | Gets an identifier for the detector type
Public property | EdXraySource | Gets the source that generated the spectrum.
Public property | EnergyPerChannel | Gets the energy per channel in electronvolts.
Public property | EnergyRange | Gets the energy range in keV.
Public property | Label | Gets the label, a user defined string for naming the spectrum.
Public property | LiveTimeSeconds | Gets the live time in seconds.
Public property | Magnification | Gets the microscope Magnification.
Public property | NumberOfChannels | Gets the number of channels.
Public property | PrimaryDetectorSerialNumber | Gets the identifier for the primary detector used to acquire the data.
Public property | ProcessTime | Gets the process time.
Public property | PulsePileupStatus | Gets the status of the pulse pileup correction
Public property | SecondaryDetectorSerialNumbers | Gets identifiers for the secondary detectors used to acquire the data.
Public property | SpecimenTilt | Gets the microscope specimen tilt in degrees.
Public property | WindowType | Gets the detector window type.
Public property | WorkingDistance | Gets the microscope working distance in mm.
Top
See Also

Reference

OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails Properties

The IEdSpectrumDetails type exposes the following members.

Properties
 | Name | Description
Public property | AcceleratingVoltage | Gets the microscope accelerating voltage in kV.
Public property | AcquisitionDate | Gets acquisition date.
Public property | AzimuthAngle | Gets the azimuth angle in degrees.
Public property | DetectorElevation | Gets the detector elevation in degrees.
Public property | DetectorType | Gets the detector type.
Public property | DetectorTypeId | Gets an identifier for the detector type
Public property | EdXraySource | Gets the source that generated the spectrum.
Public property | EnergyPerChannel | Gets the energy per channel in electronvolts.
Public property | EnergyRange | Gets the energy range in keV.
Public property | Label | Gets the label, a user defined string for naming the spectrum.
Public property | LiveTimeSeconds | Gets the live time in seconds.
Public property | Magnification | Gets the microscope Magnification.
Public property | NumberOfChannels | Gets the number of channels.
Public property | PrimaryDetectorSerialNumber | Gets the identifier for the primary detector used to acquire the data.
Public property | ProcessTime | Gets the process time.
Public property | PulsePileupStatus | Gets the status of the pulse pileup correction
Public property | SecondaryDetectorSerialNumbers | Gets identifiers for the secondary detectors used to acquire the data.
Public property | SpecimenTilt | Gets the microscope specimen tilt in degrees.
Public property | WindowType | Gets the detector window type.
Public property | WorkingDistance | Gets the microscope working distance in mm.
Top
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.AcceleratingVoltage Property

Gets the microscope accelerating voltage in kV.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double AcceleratingVoltage { get; }
ReadOnly Property AcceleratingVoltage As Double
    Get
property double AcceleratingVoltage {
    double get ();
}
abstract AcceleratingVoltage : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.AcquisitionDate Property

Gets acquisition date.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DateTime AcquisitionDate { get; }
ReadOnly Property AcquisitionDate As DateTime
    Get
property DateTime AcquisitionDate {
    DateTime get ();
}
abstract AcquisitionDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.AzimuthAngle Property

Gets the azimuth angle in degrees.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double AzimuthAngle { get; }
ReadOnly Property AzimuthAngle As Double
    Get
property double AzimuthAngle {
    double get ();
}
abstract AzimuthAngle : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.DetectorElevation Property

Gets the detector elevation in degrees.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double DetectorElevation { get; }
ReadOnly Property DetectorElevation As Double
    Get
property double DetectorElevation {
    double get ();
}
abstract DetectorElevation : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.DetectorType Property

Gets the detector type.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string DetectorType { get; }
ReadOnly Property DetectorType As String
    Get
property String^ DetectorType {
    String^ get ();
}
abstract DetectorType : string with get

Property Value

Type: String
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.DetectorTypeId Property

Gets an identifier for the detector type

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int DetectorTypeId { get; }
ReadOnly Property DetectorTypeId As Integer
    Get
property int DetectorTypeId {
    int get ();
}
abstract DetectorTypeId : int with get

Property Value

Type: Int32
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.EdXraySource Property

Gets the source that generated the spectrum.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string EdXraySource { get; }
ReadOnly Property EdXraySource As String
    Get
property String^ EdXraySource {
    String^ get ();
}
abstract EdXraySource : string with get

Property Value

Type: String
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.EnergyPerChannel Property

Gets the energy per channel in electronvolts.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double EnergyPerChannel { get; }
ReadOnly Property EnergyPerChannel As Double
    Get
property double EnergyPerChannel {
    double get ();
}
abstract EnergyPerChannel : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.EnergyRange Property

Gets the energy range in keV.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int EnergyRange { get; }
ReadOnly Property EnergyRange As Integer
    Get
property int EnergyRange {
    int get ();
}
abstract EnergyRange : int with get

Property Value

Type: Int32
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.Label Property

Gets the label, a user defined string for naming the spectrum.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string Label { get; }
ReadOnly Property Label As String
    Get
property String^ Label {
    String^ get ();
}
abstract Label : string with get

Property Value

Type: String
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.LiveTimeSeconds Property

Gets the live time in seconds.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double LiveTimeSeconds { get; }
ReadOnly Property LiveTimeSeconds As Double
    Get
property double LiveTimeSeconds {
    double get ();
}
abstract LiveTimeSeconds : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.Magnification Property

Gets the microscope Magnification.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Magnification { get; }
ReadOnly Property Magnification As Double
    Get
property double Magnification {
    double get ();
}
abstract Magnification : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.NumberOfChannels Property

Gets the number of channels.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int NumberOfChannels { get; }
ReadOnly Property NumberOfChannels As Integer
    Get
property int NumberOfChannels {
    int get ();
}
abstract NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.PrimaryDetectorSerialNumber Property

Gets the identifier for the primary detector used to acquire the data.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string PrimaryDetectorSerialNumber { get; }
ReadOnly Property PrimaryDetectorSerialNumber As String
    Get
property String^ PrimaryDetectorSerialNumber {
    String^ get ();
}
abstract PrimaryDetectorSerialNumber : string with get

Property Value

Type: String
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.ProcessTime Property

Gets the process time.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int ProcessTime { get; }
ReadOnly Property ProcessTime As Integer
    Get
property int ProcessTime {
    int get ();
}
abstract ProcessTime : int with get

Property Value

Type: Int32
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.PulsePileupStatus Property

Gets the status of the pulse pileup correction

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string PulsePileupStatus { get; }
ReadOnly Property PulsePileupStatus As String
    Get
property String^ PulsePileupStatus {
    String^ get ();
}
abstract PulsePileupStatus : string with get

Property Value

Type: String
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.SecondaryDetectorSerialNumbers Property

Gets identifiers for the secondary detectors used to acquire the data.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string SecondaryDetectorSerialNumbers { get; }
ReadOnly Property SecondaryDetectorSerialNumbers As String
    Get
property String^ SecondaryDetectorSerialNumbers {
    String^ get ();
}
abstract SecondaryDetectorSerialNumbers : string with get

Property Value

Type: String
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.SpecimenTilt Property

Gets the microscope specimen tilt in degrees.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double SpecimenTilt { get; }
ReadOnly Property SpecimenTilt As Double
    Get
property double SpecimenTilt {
    double get ();
}
abstract SpecimenTilt : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.WindowType Property

Gets the detector window type.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string WindowType { get; }
ReadOnly Property WindowType As String
    Get
property String^ WindowType {
    String^ get ();
}
abstract WindowType : string with get

Property Value

Type: String
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


IEdSpectrumDetails.WorkingDistance Property

Gets the microscope working distance in mm.

Namespace: OINA.Extender.Data.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double WorkingDistance { get; }
ReadOnly Property WorkingDistance As Double
    Get
property double WorkingDistance {
    double get ();
}
abstract WorkingDistance : float with get

Property Value

Type: Double
See Also

Reference

IEdSpectrumDetails Interface
OINA.Extender.Data.Ed Namespace


OINA.Extender.Data.Image Namespace

Defines Classes and Interfaces that describe image Data Types available within Extender.

Interfaces
 | Interface | Description
Public interface | IEdMapImage | Interface that defines properties and methods for Ed Map Images.
Public interface | IEdMapImageDetails | Interface that defines the details of an Ed map image.
 | IElectronImage | An Interface that defines an Electron image.
Public interface | IElectronImageDetails | An interface that defines the details of the eletron image
Public interface | IFLSMapImage | Interface that defines properties and methods for FLS Map Images.
Public interface | IImageCorrection | An Interface that defines common properties and methods for images.
Public interface | IWindowIntegralMapImage | Interface that defines properties and methods for Window integral Map Images.
Enumerations
 | Enumeration | Description
Public enumeration | ImageInputSources | Input sources used for image acquisition.


IEdMapImage Interface

Interface that defines properties and methods for Ed Map Images.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdMapImage : INotifyPropertyChanged,
    IDisposable, IImageCorrection
Public Interface IEdMapImage
    Inherits INotifyPropertyChanged, IDisposable, IImageCorrection
public interface class IEdMapImage : INotifyPropertyChanged,
    IDisposable, IImageCorrection
type IEdMapImage =
    interface
        interface INotifyPropertyChanged
        interface IDisposable
        interface IImageCorrection
    end

The IEdMapImage type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date. (Inherited from IImageCorrection.)
Public property | AtomicNumber | Gets the atomic number.
Public property | BinFactor | Gets the bin factor
Public property | BytesPerPixel | Gets the number of bytes used to store the data at each pixel. (Inherited from IImageCorrection.)
Public property | ColumnConditions | Gets the microscope column conditions.
Public property | DateCreated | Gets the date the image was created
Public property | Details | Gets a snapshot of the image details.
Public property | DwellTimePerPixelMicroseconds | Gets the time spent acquiring each pixel in microseconds.
Public property | Height | Gets the height of the image in pixels. (Inherited from IImageCorrection.)
Public property | Id | Gets a unique identifier for the image. (Inherited from IImageCorrection.)
Public property | IsFrozen | Gets a value indicating whether the image data has finished updating.
Public property | Label | Gets or sets a label to identify the image. (Inherited from IImageCorrection.)
Public property | LowColor | Gets or sets the lower colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Maximum | Gets the maximum value in the image.
Public property | Minimum | Gets the minimum value in the image.
Public property | PixelSize | Gets the pixel size. (Inherited from IImageCorrection.)
Public property | Region | Gets the acquisition region.
Public property | StageConditions | Gets the microscope stage conditions.
Public property | UpperColor | Gets or sets the upper colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Width | Gets the width of the image in pixels. (Inherited from IImageCorrection.)
Top
Methods
 | Name | Description
Public method | AutoBrightness | Performs automatic brightness correction. (Inherited from IImageCorrection.)
Public method | AutoGamma | Performs automatic gamma correction. (Inherited from IImageCorrection.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetData(Point) | Gets the data at a pixel.
Public method | GetData(Single) | Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height).
Public method | GetData(IEnumerableChord, Single) | Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels.
Public method | Save | Saves the image as a byte array. (Inherited from IImageCorrection.)
Top
Events
 | Name | Description
Public event | DataChanged | Event that is fired when the image data changes.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Data.Image Namespace


IEdMapImage Properties

The IEdMapImage type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date. (Inherited from IImageCorrection.)
Public property | AtomicNumber | Gets the atomic number.
Public property | BinFactor | Gets the bin factor
Public property | BytesPerPixel | Gets the number of bytes used to store the data at each pixel. (Inherited from IImageCorrection.)
Public property | ColumnConditions | Gets the microscope column conditions.
Public property | DateCreated | Gets the date the image was created
Public property | Details | Gets a snapshot of the image details.
Public property | DwellTimePerPixelMicroseconds | Gets the time spent acquiring each pixel in microseconds.
Public property | Height | Gets the height of the image in pixels. (Inherited from IImageCorrection.)
Public property | Id | Gets a unique identifier for the image. (Inherited from IImageCorrection.)
Public property | IsFrozen | Gets a value indicating whether the image data has finished updating.
Public property | Label | Gets or sets a label to identify the image. (Inherited from IImageCorrection.)
Public property | LowColor | Gets or sets the lower colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Maximum | Gets the maximum value in the image.
Public property | Minimum | Gets the minimum value in the image.
Public property | PixelSize | Gets the pixel size. (Inherited from IImageCorrection.)
Public property | Region | Gets the acquisition region.
Public property | StageConditions | Gets the microscope stage conditions.
Public property | UpperColor | Gets or sets the upper colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Width | Gets the width of the image in pixels. (Inherited from IImageCorrection.)
Top
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.AtomicNumber Property

Gets the atomic number.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int AtomicNumber { get; }
ReadOnly Property AtomicNumber As Integer
    Get
property int AtomicNumber {
    int get ();
}
abstract AtomicNumber : int with get

Property Value

Type: Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.BinFactor Property

Gets the bin factor

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int BinFactor { get; }
ReadOnly Property BinFactor As Integer
    Get
property int BinFactor {
    int get ();
}
abstract BinFactor : int with get

Property Value

Type: Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.ColumnConditions Property

Gets the microscope column conditions.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IColumnConditions ColumnConditions { get; }
ReadOnly Property ColumnConditions As IColumnConditions
    Get
property IColumnConditions^ ColumnConditions {
    IColumnConditions^ get ();
}
abstract ColumnConditions : IColumnConditions with get

Property Value

Type: IColumnConditions
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.DateCreated Property

Gets the date the image was created

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DateTime DateCreated { get; }
ReadOnly Property DateCreated As DateTime
    Get
property DateTime DateCreated {
    DateTime get ();
}
abstract DateCreated : DateTime with get

Property Value

Type: DateTime
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.Details Property

Gets a snapshot of the image details.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdMapImageDetails Details { get; }
ReadOnly Property Details As IEdMapImageDetails
    Get
property IEdMapImageDetails^ Details {
    IEdMapImageDetails^ get ();
}
abstract Details : IEdMapImageDetails with get

Property Value

Type: IEdMapImageDetails
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.DwellTimePerPixelMicroseconds Property

Gets the time spent acquiring each pixel in microseconds.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double DwellTimePerPixelMicroseconds { get; }
ReadOnly Property DwellTimePerPixelMicroseconds As Double
    Get
property double DwellTimePerPixelMicroseconds {
    double get ();
}
abstract DwellTimePerPixelMicroseconds : float with get

Property Value

Type: Double
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.IsFrozen Property

Gets a value indicating whether the image data has finished updating.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsFrozen { get; }
ReadOnly Property IsFrozen As Boolean
    Get
property bool IsFrozen {
    bool get ();
}
abstract IsFrozen : bool with get

Property Value

Type: Boolean
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.Maximum Property

Gets the maximum value in the image.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Maximum { get; }
ReadOnly Property Maximum As Double
    Get
property double Maximum {
    double get ();
}
abstract Maximum : float with get

Property Value

Type: Double
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.Minimum Property

Gets the minimum value in the image.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Minimum { get; }
ReadOnly Property Minimum As Double
    Get
property double Minimum {
    double get ();
}
abstract Minimum : float with get

Property Value

Type: Double
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.Region Property

Gets the acquisition region.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IRegion Region { get; }
ReadOnly Property Region As IRegion
    Get
property IRegion^ Region {
    IRegion^ get ();
}
abstract Region : IRegion with get

Property Value

Type: IRegion
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.StageConditions Property

Gets the microscope stage conditions.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IStageConditions StageConditions { get; }
ReadOnly Property StageConditions As IStageConditions
    Get
property IStageConditions^ StageConditions {
    IStageConditions^ get ();
}
abstract StageConditions : IStageConditions with get

Property Value

Type: IStageConditions
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage Methods

The IEdMapImage type exposes the following members.

Methods
 | Name | Description
Public method | AutoBrightness | Performs automatic brightness correction. (Inherited from IImageCorrection.)
Public method | AutoGamma | Performs automatic gamma correction. (Inherited from IImageCorrection.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetData(Point) | Gets the data at a pixel.
Public method | GetData(Single) | Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height).
Public method | GetData(IEnumerableChord, Single) | Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels.
Public method | Save | Saves the image as a byte array. (Inherited from IImageCorrection.)
Top
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.GetData Method

Overload List
 | Name | Description
Public method | GetData(Point) | Gets the data at a pixel.
Public method | GetData(Single) | Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height).
Public method | GetData(IEnumerableChord, Single) | Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels.
Top
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.GetData Method (Point)

Gets the data at a pixel.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
float GetData(
    Point position
)
Function GetData (
    position As Point
) As Single
float GetData(
    Point position
)
abstract GetData :
        position : Point -> float32

Parameters

position
Type: System.DrawingPoint
The pixel position.

Return Value

Type: Single
The value of the data at the position.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
ArgumentOutOfRangeException | Thrown if position is not within the image.
See Also

Reference

IEdMapImage Interface
GetData Overload
OINA.Extender.Data.Image Namespace


IEdMapImage.GetData Method (Single[])

Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height).

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void GetData(
    float[] buffer
)
Sub GetData (
    buffer As Single()
)
void GetData(
    array<float>^ buffer
)
abstract GetData :
        buffer : float32[] -> unit

Parameters

buffer
Type: SystemSingle
The buffer.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
ArgumentNullException | Thrown if buffer is null.
ArgumentOutOfRangeException | Thrown if buffer is too small.
See Also

Reference

IEdMapImage Interface
GetData Overload
OINA.Extender.Data.Image Namespace


IEdMapImage.GetData Method (IEnumerable(Chord), Single[])

Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void GetData(
    IEnumerable<Chord> chords,
    float[] buffer
)
Sub GetData (
    chords As IEnumerable(Of Chord),
    buffer As Single()
)
void GetData(
    IEnumerable<Chord^>^ chords,
    array<float>^ buffer
)
abstract GetData :
        chords : IEnumerable<Chord> *
        buffer : float32[] -> unit

Parameters

chords
Type: System.Collections.GenericIEnumerable Chord
The region of the image.
buffer
Type: SystemSingle
The data buffer for image data.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
ArgumentNullException | Thrown if chords or buffer is null.
ArgumentException | Thrown if chords is empty or contains a null chord.
ArgumentOutOfRangeException | Thrown if buffer is too small.
See Also

Reference

IEdMapImage Interface
GetData Overload
OINA.Extender.Data.Image Namespace


IEdMapImage Events

The IEdMapImage type exposes the following members.

Events
 | Name | Description
Public event | DataChanged | Event that is fired when the image data changes.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImage.DataChanged Event

Event that is fired when the image data changes.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<SpatialDataChangedEventArgs> DataChanged
Event DataChanged As EventHandler(Of SpatialDataChangedEventArgs)
 event EventHandler<SpatialDataChangedEventArgs^>^ DataChanged {
    void add (EventHandler<SpatialDataChangedEventArgs^>^ value);
    void remove (EventHandler<SpatialDataChangedEventArgs^>^ value);
}
abstract DataChanged : IEvent<EventHandler<SpatialDataChangedEventArgs>,
    SpatialDataChangedEventArgs>

Value

Type: SystemEventHandler SpatialDataChangedEventArgs
See Also

Reference

IEdMapImage Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails Interface

Interface that defines the details of an Ed map image.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdMapImageDetails
Public Interface IEdMapImageDetails
public interface class IEdMapImageDetails
type IEdMapImageDetails =  interface end

The IEdMapImageDetails type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets acquisition date.
Public property | BinFactor | Gets the binning factor
Public property | DateCreated | Gets the date the image was created
Public property | DwellTimePerPixelMicroseconds | Gets dwell time for each pixel in microseconds
Public property | EffectiveMagnificationWithZoom | Gets the effective magnification used for an image if digital zoom (for drift correction) is included.
Public property | EnergyRange | Gets the energy range in keV.
Public property | Height | Gets the height of the image in pixels
Public property | HighVoltage | Gets the high voltage in kV
Public property | ImageHeight | Gets the image height in mm
Public property | ImageWidth | Gets the image width in mm
Public property | Label | Gets the label, a user defined string for naming the image.
Public property | Maximum | Gets the maximum value in the image
Public property | NumberOfChannels | Gets the number of channels.
Public property | NumberOfFrames | Gets the number of frames
Public property | PrimaryDetectorSerialNumber | Gets the identifier of the primary detector used to acquire the data.
Public property | ProcessTime | Gets the process time.
Public property | SecondaryDetectorSerialNumbers | Gets identifiers for the secondary detectors used to acquire the data.
Public property | SmoothingLevel | Gets the smoothing level
Public property | StageRotate | Gets the rotate axis position in degrees
Public property | StageTilt | Gets the tilt axis position in degrees
Public property | StageX | Gets the X axis position in mm
Public property | StageY | Gets the Y axis position in mm
Public property | StageZ | Gets the Z axis position in mm
Public property | Width | Gets the width of the image in pixels
Public property | WorkingDistance | Gets the working distance in mm
Top
See Also

Reference

OINA.Extender.Data.Image Namespace


IEdMapImageDetails Properties

The IEdMapImageDetails type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets acquisition date.
Public property | BinFactor | Gets the binning factor
Public property | DateCreated | Gets the date the image was created
Public property | DwellTimePerPixelMicroseconds | Gets dwell time for each pixel in microseconds
Public property | EffectiveMagnificationWithZoom | Gets the effective magnification used for an image if digital zoom (for drift correction) is included.
Public property | EnergyRange | Gets the energy range in keV.
Public property | Height | Gets the height of the image in pixels
Public property | HighVoltage | Gets the high voltage in kV
Public property | ImageHeight | Gets the image height in mm
Public property | ImageWidth | Gets the image width in mm
Public property | Label | Gets the label, a user defined string for naming the image.
Public property | Maximum | Gets the maximum value in the image
Public property | NumberOfChannels | Gets the number of channels.
Public property | NumberOfFrames | Gets the number of frames
Public property | PrimaryDetectorSerialNumber | Gets the identifier of the primary detector used to acquire the data.
Public property | ProcessTime | Gets the process time.
Public property | SecondaryDetectorSerialNumbers | Gets identifiers for the secondary detectors used to acquire the data.
Public property | SmoothingLevel | Gets the smoothing level
Public property | StageRotate | Gets the rotate axis position in degrees
Public property | StageTilt | Gets the tilt axis position in degrees
Public property | StageX | Gets the X axis position in mm
Public property | StageY | Gets the Y axis position in mm
Public property | StageZ | Gets the Z axis position in mm
Public property | Width | Gets the width of the image in pixels
Public property | WorkingDistance | Gets the working distance in mm
Top
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.AcquisitionDate Property

Gets acquisition date.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DateTime AcquisitionDate { get; }
ReadOnly Property AcquisitionDate As DateTime
    Get
property DateTime AcquisitionDate {
    DateTime get ();
}
abstract AcquisitionDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.BinFactor Property

Gets the binning factor

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int BinFactor { get; }
ReadOnly Property BinFactor As Integer
    Get
property int BinFactor {
    int get ();
}
abstract BinFactor : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.DateCreated Property

Gets the date the image was created

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DateTime DateCreated { get; }
ReadOnly Property DateCreated As DateTime
    Get
property DateTime DateCreated {
    DateTime get ();
}
abstract DateCreated : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.DwellTimePerPixelMicroseconds Property

Gets dwell time for each pixel in microseconds

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double DwellTimePerPixelMicroseconds { get; }
ReadOnly Property DwellTimePerPixelMicroseconds As Double
    Get
property double DwellTimePerPixelMicroseconds {
    double get ();
}
abstract DwellTimePerPixelMicroseconds : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.EffectiveMagnificationWithZoom Property

Gets the effective magnification used for an image if digital zoom (for drift correction) is included.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double EffectiveMagnificationWithZoom { get; }
ReadOnly Property EffectiveMagnificationWithZoom As Double
    Get
property double EffectiveMagnificationWithZoom {
    double get ();
}
abstract EffectiveMagnificationWithZoom : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.EnergyRange Property

Gets the energy range in keV.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int EnergyRange { get; }
ReadOnly Property EnergyRange As Integer
    Get
property int EnergyRange {
    int get ();
}
abstract EnergyRange : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.Height Property

Gets the height of the image in pixels

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int Height { get; }
ReadOnly Property Height As Integer
    Get
property int Height {
    int get ();
}
abstract Height : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.HighVoltage Property

Gets the high voltage in kV

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double HighVoltage { get; }
ReadOnly Property HighVoltage As Double
    Get
property double HighVoltage {
    double get ();
}
abstract HighVoltage : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.ImageHeight Property

Gets the image height in mm

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double ImageHeight { get; }
ReadOnly Property ImageHeight As Double
    Get
property double ImageHeight {
    double get ();
}
abstract ImageHeight : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.ImageWidth Property

Gets the image width in mm

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double ImageWidth { get; }
ReadOnly Property ImageWidth As Double
    Get
property double ImageWidth {
    double get ();
}
abstract ImageWidth : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.Label Property

Gets the label, a user defined string for naming the image.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string Label { get; }
ReadOnly Property Label As String
    Get
property String^ Label {
    String^ get ();
}
abstract Label : string with get

Property Value

Type: String
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.Maximum Property

Gets the maximum value in the image

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Maximum { get; }
ReadOnly Property Maximum As Double
    Get
property double Maximum {
    double get ();
}
abstract Maximum : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.NumberOfChannels Property

Gets the number of channels.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int NumberOfChannels { get; }
ReadOnly Property NumberOfChannels As Integer
    Get
property int NumberOfChannels {
    int get ();
}
abstract NumberOfChannels : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.NumberOfFrames Property

Gets the number of frames

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int NumberOfFrames { get; }
ReadOnly Property NumberOfFrames As Integer
    Get
property int NumberOfFrames {
    int get ();
}
abstract NumberOfFrames : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.PrimaryDetectorSerialNumber Property

Gets the identifier of the primary detector used to acquire the data.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string PrimaryDetectorSerialNumber { get; }
ReadOnly Property PrimaryDetectorSerialNumber As String
    Get
property String^ PrimaryDetectorSerialNumber {
    String^ get ();
}
abstract PrimaryDetectorSerialNumber : string with get

Property Value

Type: String
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.ProcessTime Property

Gets the process time.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int ProcessTime { get; }
ReadOnly Property ProcessTime As Integer
    Get
property int ProcessTime {
    int get ();
}
abstract ProcessTime : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.SecondaryDetectorSerialNumbers Property

Gets identifiers for the secondary detectors used to acquire the data.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string SecondaryDetectorSerialNumbers { get; }
ReadOnly Property SecondaryDetectorSerialNumbers As String
    Get
property String^ SecondaryDetectorSerialNumbers {
    String^ get ();
}
abstract SecondaryDetectorSerialNumbers : string with get

Property Value

Type: String
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.SmoothingLevel Property

Gets the smoothing level

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int SmoothingLevel { get; }
ReadOnly Property SmoothingLevel As Integer
    Get
property int SmoothingLevel {
    int get ();
}
abstract SmoothingLevel : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.StageRotate Property

Gets the rotate axis position in degrees

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StageRotate { get; }
ReadOnly Property StageRotate As Double
    Get
property double StageRotate {
    double get ();
}
abstract StageRotate : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.StageTilt Property

Gets the tilt axis position in degrees

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StageTilt { get; }
ReadOnly Property StageTilt As Double
    Get
property double StageTilt {
    double get ();
}
abstract StageTilt : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.StageX Property

Gets the X axis position in mm

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StageX { get; }
ReadOnly Property StageX As Double
    Get
property double StageX {
    double get ();
}
abstract StageX : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.StageY Property

Gets the Y axis position in mm

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StageY { get; }
ReadOnly Property StageY As Double
    Get
property double StageY {
    double get ();
}
abstract StageY : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.StageZ Property

Gets the Z axis position in mm

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StageZ { get; }
ReadOnly Property StageZ As Double
    Get
property double StageZ {
    double get ();
}
abstract StageZ : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.Width Property

Gets the width of the image in pixels

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int Width { get; }
ReadOnly Property Width As Integer
    Get
property int Width {
    int get ();
}
abstract Width : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IEdMapImageDetails.WorkingDistance Property

Gets the working distance in mm

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double WorkingDistance { get; }
ReadOnly Property WorkingDistance As Double
    Get
property double WorkingDistance {
    double get ();
}
abstract WorkingDistance : float with get

Property Value

Type: Double
See Also

Reference

IEdMapImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImage Interface

An Interface that defines an Electron image.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IElectronImage : INotifyPropertyChanged,
    IDisposable, IImageCorrection
Public Interface IElectronImage
    Inherits INotifyPropertyChanged, IDisposable, IImageCorrection
public interface class IElectronImage : INotifyPropertyChanged,
    IDisposable, IImageCorrection
type IElectronImage =
    interface
        interface INotifyPropertyChanged
        interface IDisposable
        interface IImageCorrection
    end

The IElectronImage type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date. (Inherited from IImageCorrection.)
Public property | BytesPerPixel | Gets the number of bytes used to store the data at each pixel. (Inherited from IImageCorrection.)
Public property | ColumnConditions | Gets the microscope column conditions used.
Public property | Details | Gets a snapshot of the electron image details.
Public property | DwellTimePerPixelMicroseconds | Gets the time spent acquiring each pixel in microseconds.
Public property | FramesAveraged | Gets the number of frames acquired.
Public property | Height | Gets the height of the image in pixels. (Inherited from IImageCorrection.)
Public property | Id | Gets a unique identifier for the image. (Inherited from IImageCorrection.)
Public property | InputSource | Gets the image input source (BSE, SE).
Public property | IsFrozen | Gets a value indicating whether the image data has finished updating.
Public property | Label | Gets or sets a label to identify the image. (Inherited from IImageCorrection.)
Public property | LowColor | Gets or sets the lower colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | PixelSize | Gets the pixel size. (Inherited from IImageCorrection.)
Public property | Region | Gets the acquisition region.
Public property | StageConditions | Gets the microscope stage conditions used.
Public property | UpperColor | Gets or sets the upper colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Width | Gets the width of the image in pixels. (Inherited from IImageCorrection.)
Top
Methods
 | Name | Description
Public method | AutoBrightness | Performs automatic brightness correction. (Inherited from IImageCorrection.)
Public method | AutoGamma | Performs automatic gamma correction. (Inherited from IImageCorrection.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetData(Byte) | Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height x BytesPerPixel).
Public method | GetData(Point) | Gets the data at a pixel.
Public method | GetData(IEnumerableChord, Byte) | Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels * BytesPerPixel.
Public method | Save | Saves the image as a byte array. (Inherited from IImageCorrection.)
Top
Events
 | Name | Description
Public event | DataChanged | Event that is fired when the image data changes.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Examples
Copy
namespace Extender.CodeExamples.AcquisitionExamples
{
    using System;
    using System.Collections.Generic;
    using System.ComponentModel;
    using System.Linq;
    using System.Text;
    using OINA.Extender;
    using OINA.Extender.Acquisition;
    using OINA.Extender.Acquisition.Image;
    using OINA.Extender.Data;
    using OINA.Extender.Data.Image;

    /// <summary>
    /// AcquireImageExample
    /// </summary>
    public class AcquireImageExample
    {
        /// <summary>
        /// Run
        /// </summary>
        public void Run()
        {
            Console.WriteLine();
            Console.WriteLine(@"Image Acquisition Example.");
            Console.WriteLine();

            IImageAcquisitionSettings acquisitionSettings = AcquireFactory.CreateImageSettings();

            IImageSettings imageSettings = acquisitionSettings.ImageSettings;
            IImageCapabilities imageCapabilities = acquisitionSettings.ImageCapabilities;
            IImageScanSettings scanSettings = acquisitionSettings.ScanSettings;

            IImageAcquisitionController imageAcquisitionController = AcquireFactory.CreateImageServer();

            imageAcquisitionController.ExperimentStarting += this.OnImageExperimentStarting;
            imageAcquisitionController.ExperimentStarted += this.OnImageExperimentStarted;
            imageAcquisitionController.ExperimentFinished += this.OnImageExperimentFinished;

            imageSettings.DwellTimeMicroSeconds = 40;

            // Multiple input sources can be used.
            imageSettings.InputSources.ToList().ForEach(i => imageSettings.EnableInputSource(i.Key, true));

            scanSettings.FrameCount = 1;

            // Pixel size is 1/Resolution
            var pixelSize = 1d / 1024;

            scanSettings.AcquisitionRegion.CreateFullFieldRegion(pixelSize);

            // Check valid Dwell Time
            if (imageSettings.DwellTimeMicroSeconds > imageCapabilities.MaximumImageDwellMicroseconds ||
                imageSettings.DwellTimeMicroSeconds < imageCapabilities.MinimumImageDwellMicroseconds)
            {
                Console.WriteLine(
                    @"Invalid Dwell Time setting ({0}): Value must be between {1} and {2}",
                    imageSettings.DwellTimeMicroSeconds,
                    imageCapabilities.MinimumImageDwellMicroseconds,
                    imageCapabilities.MaximumImageDwellMicroseconds);
            }

            try
            {
                IEnumerable<IElectronImage> images = imageAcquisitionController.StartAcquisition(acquisitionSettings);
                images.ToList().ForEach(i =>
                {
                    i.Label = string.Format(@"Code example image - {0:HH:mm:ss} - {1}", DateTime.Now, i.InputSource.ToString());
                });
            }
            catch (InvalidSettingsException settingsException)
            {
                var sb = new StringBuilder(@"Invalid settings have been supplied: ");
                sb.AppendLine();
                settingsException.ValidationResults.ValidationErrors.ToList().ForEach(ve => sb.AppendFormat("{0}{1}", Environment.NewLine, ve));

                Console.WriteLine(sb.ToString());
            }
            catch (AcquisitionStartException startException)
            {
                Console.WriteLine(@"AcquisitionStartException: {0}", startException.Message);
            }
        }

        /// <summary>
        /// OnImageExperimentStarting
        /// </summary>
        private void OnImageExperimentStarting(object sender, AcquisitionStartingEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarting:");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                image.PropertyChanged += this.OnImagePropertyChanged;
                image.DataChanged += this.OnImageDataChanged;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentStarted
        /// </summary>
        private void OnImageExperimentStarted(object sender, AcquisitionStartedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentStarted");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarting -= this.OnImageExperimentStarting;
            }

            Console.WriteLine();
        }

        /// <summary>
        /// OnImageExperimentFinished
        /// </summary>
        private void OnImageExperimentFinished(object sender, AcquisitionFinishedEventArgs<IElectronImage[]> e)
        {
            Console.WriteLine();
            Console.WriteLine(@"IImageAcquisitionController.ExperimentFinished");

            foreach (IElectronImage image in e.Value)
            {
                Console.WriteLine(@"    Image: ""{0}""", image.Label);
                Console.WriteLine(@"    AcquisitionDate: {0:dd-MMM-yy HH:mm:ss}", image.AcquisitionDate);
                Console.WriteLine(@"    FramesAveraged: {0}", image.FramesAveraged);

                image.PropertyChanged -= this.OnImagePropertyChanged;
                image.DataChanged -= this.OnImageDataChanged;
            }

            var imageAcquisitionController = sender as IImageAcquisitionController;

            if (imageAcquisitionController != null)
            {
                imageAcquisitionController.ExperimentStarted -= this.OnImageExperimentStarted;
                imageAcquisitionController.ExperimentFinished -= this.OnImageExperimentFinished;
            }

            Console.WriteLine();
            Console.WriteLine();
            Console.WriteLine(@"Code Example finished.");
        }

        /// <summary>
        /// OnImagePropertyChanged
        /// </summary>
        private void OnImagePropertyChanged(object sender, PropertyChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image != null)
            {
                Console.WriteLine(@"IElectronImage.PropertyChanged:{0}      ""{1}"" - {2}", Environment.NewLine, image.Label, e.PropertyName);
                Console.WriteLine();
            }
        }

        /// <summary>
        /// OnImageDataChanged
        /// </summary>
        private void OnImageDataChanged(object sender, SpatialDataChangedEventArgs e)
        {
            var image = sender as IElectronImage;

            if (image == null)
            {
                return;
            }

            Console.WriteLine(@"IElectronImage.DataChanged: {0}", image.Label);
            Console.WriteLine(@"        ChangedPixels Height/Width: {0}/{1}", e.ChangedPixels.Height, e.ChangedPixels.Width);

            var chordArray = new[] { new Chord(e.ChangedPixels.X, e.ChangedPixels.Y, e.ChangedPixels.Width) };

            var buffer = new byte[chordArray[0].Length * image.BytesPerPixel];

            // Get the data for the changed pixels
            image.GetData(chordArray, buffer);

            Console.WriteLine(@"        Image Height/Width: {0}/{1}", image.Height, image.Width);
            Console.WriteLine(@"        Image BytesPerPixel: {0}", image.BytesPerPixel);
            Console.WriteLine(@"        Data Buffer length: {0:0,000}", buffer.Length);
            Console.WriteLine();
        }
    }
}
See Also

Reference

OINA.Extender.Data.Image Namespace


IElectronImage Properties

The IElectronImage type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date. (Inherited from IImageCorrection.)
Public property | BytesPerPixel | Gets the number of bytes used to store the data at each pixel. (Inherited from IImageCorrection.)
Public property | ColumnConditions | Gets the microscope column conditions used.
Public property | Details | Gets a snapshot of the electron image details.
Public property | DwellTimePerPixelMicroseconds | Gets the time spent acquiring each pixel in microseconds.
Public property | FramesAveraged | Gets the number of frames acquired.
Public property | Height | Gets the height of the image in pixels. (Inherited from IImageCorrection.)
Public property | Id | Gets a unique identifier for the image. (Inherited from IImageCorrection.)
Public property | InputSource | Gets the image input source (BSE, SE).
Public property | IsFrozen | Gets a value indicating whether the image data has finished updating.
Public property | Label | Gets or sets a label to identify the image. (Inherited from IImageCorrection.)
Public property | LowColor | Gets or sets the lower colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | PixelSize | Gets the pixel size. (Inherited from IImageCorrection.)
Public property | Region | Gets the acquisition region.
Public property | StageConditions | Gets the microscope stage conditions used.
Public property | UpperColor | Gets or sets the upper colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Width | Gets the width of the image in pixels. (Inherited from IImageCorrection.)
Top
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage.ColumnConditions Property

Gets the microscope column conditions used.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IColumnConditions ColumnConditions { get; }
ReadOnly Property ColumnConditions As IColumnConditions
    Get
property IColumnConditions^ ColumnConditions {
    IColumnConditions^ get ();
}
abstract ColumnConditions : IColumnConditions with get

Property Value

Type: IColumnConditions
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage.Details Property

Gets a snapshot of the electron image details.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IElectronImageDetails Details { get; }
ReadOnly Property Details As IElectronImageDetails
    Get
property IElectronImageDetails^ Details {
    IElectronImageDetails^ get ();
}
abstract Details : IElectronImageDetails with get

Property Value

Type: IElectronImageDetails
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage.DwellTimePerPixelMicroseconds Property

Gets the time spent acquiring each pixel in microseconds.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double DwellTimePerPixelMicroseconds { get; }
ReadOnly Property DwellTimePerPixelMicroseconds As Double
    Get
property double DwellTimePerPixelMicroseconds {
    double get ();
}
abstract DwellTimePerPixelMicroseconds : float with get

Property Value

Type: Double
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage.FramesAveraged Property

Gets the number of frames acquired.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int FramesAveraged { get; }
ReadOnly Property FramesAveraged As Integer
    Get
property int FramesAveraged {
    int get ();
}
abstract FramesAveraged : int with get

Property Value

Type: Int32
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage.InputSource Property

Gets the image input source (BSE, SE).

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ImageInputSources InputSource { get; }
ReadOnly Property InputSource As ImageInputSources
    Get
property ImageInputSources InputSource {
    ImageInputSources get ();
}
abstract InputSource : ImageInputSources with get

Property Value

Type: ImageInputSources
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage.IsFrozen Property

Gets a value indicating whether the image data has finished updating.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsFrozen { get; }
ReadOnly Property IsFrozen As Boolean
    Get
property bool IsFrozen {
    bool get ();
}
abstract IsFrozen : bool with get

Property Value

Type: Boolean
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage.Region Property

Gets the acquisition region.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IRegion Region { get; }
ReadOnly Property Region As IRegion
    Get
property IRegion^ Region {
    IRegion^ get ();
}
abstract Region : IRegion with get

Property Value

Type: IRegion
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage.StageConditions Property

Gets the microscope stage conditions used.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IStageConditions StageConditions { get; }
ReadOnly Property StageConditions As IStageConditions
    Get
property IStageConditions^ StageConditions {
    IStageConditions^ get ();
}
abstract StageConditions : IStageConditions with get

Property Value

Type: IStageConditions
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage Methods

The IElectronImage type exposes the following members.

Methods
 | Name | Description
Public method | AutoBrightness | Performs automatic brightness correction. (Inherited from IImageCorrection.)
Public method | AutoGamma | Performs automatic gamma correction. (Inherited from IImageCorrection.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetData(Byte) | Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height x BytesPerPixel).
Public method | GetData(Point) | Gets the data at a pixel.
Public method | GetData(IEnumerableChord, Byte) | Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels * BytesPerPixel.
Public method | Save | Saves the image as a byte array. (Inherited from IImageCorrection.)
Top
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage.GetData Method

Overload List
 | Name | Description
Public method | GetData(Byte) | Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height x BytesPerPixel).
Public method | GetData(Point) | Gets the data at a pixel.
Public method | GetData(IEnumerableChord, Byte) | Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels * BytesPerPixel.
Top
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage.GetData Method (Byte[])

Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height x BytesPerPixel).

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void GetData(
    byte[] buffer
)
Sub GetData (
    buffer As Byte()
)
void GetData(
    array<unsigned char>^ buffer
)
abstract GetData :
        buffer : byte[] -> unit

Parameters

buffer
Type: SystemByte
The buffer.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
ArgumentNullException | Thrown if buffer is null.
ArgumentOutOfRangeException | Thrown if buffer is too small.
See Also

Reference

IElectronImage Interface
GetData Overload
OINA.Extender.Data.Image Namespace


IElectronImage.GetData Method (Point)

Gets the data at a pixel.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
short GetData(
    Point position
)
Function GetData (
    position As Point
) As Short
short GetData(
    Point position
)
abstract GetData :
        position : Point -> int16

Parameters

position
Type: System.DrawingPoint
The position of the interested pixel.

Return Value

Type: Int16
The value of the data at the position.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
ArgumentOutOfRangeException | Thrown if position is not within the image.
See Also

Reference

IElectronImage Interface
GetData Overload
OINA.Extender.Data.Image Namespace


IElectronImage.GetData Method (IEnumerable(Chord), Byte[])

Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels * BytesPerPixel.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void GetData(
    IEnumerable<Chord> chords,
    byte[] buffer
)
Sub GetData (
    chords As IEnumerable(Of Chord),
    buffer As Byte()
)
void GetData(
    IEnumerable<Chord^>^ chords,
    array<unsigned char>^ buffer
)
abstract GetData :
        chords : IEnumerable<Chord> *
        buffer : byte[] -> unit

Parameters

chords
Type: System.Collections.GenericIEnumerable Chord
The region of the image.
buffer
Type: SystemByte
The data buffer for image data.
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
ArgumentNullException | Thrown if chords or buffer is null.
ArgumentException | Thrown if chords is empty or contains a null chord.
ArgumentOutOfRangeException | Thrown if buffer is too small.
See Also

Reference

IElectronImage Interface
GetData Overload
OINA.Extender.Data.Image Namespace


IElectronImage Events

The IElectronImage type exposes the following members.

Events
 | Name | Description
Public event | DataChanged | Event that is fired when the image data changes.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImage.DataChanged Event

Event that is fired when the image data changes.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<SpatialDataChangedEventArgs> DataChanged
Event DataChanged As EventHandler(Of SpatialDataChangedEventArgs)
 event EventHandler<SpatialDataChangedEventArgs^>^ DataChanged {
    void add (EventHandler<SpatialDataChangedEventArgs^>^ value);
    void remove (EventHandler<SpatialDataChangedEventArgs^>^ value);
}
abstract DataChanged : IEvent<EventHandler<SpatialDataChangedEventArgs>,
    SpatialDataChangedEventArgs>

Value

Type: SystemEventHandler SpatialDataChangedEventArgs
See Also

Reference

IElectronImage Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails Interface

An interface that defines the details of the eletron image

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IElectronImageDetails
Public Interface IElectronImageDetails
public interface class IElectronImageDetails
type IElectronImageDetails =  interface end

The IElectronImageDetails type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets acquisiton date
Public property | DwellTimePerPixelMicroseconds | Gets dwell time for each pixel in microseconds
Public property | EffectiveMagnificationWithZoom | Gets the effective magnification used for an image if digital zoom (for drift correction) is included.
Public property | FramesAveraged | Gets the number of averaged frames
Public property | Height | Gets the height of image(pixels)
Public property | ImageHeight | Gets the viewable-image height in mm
Public property | ImageWidth | Gets the viewable-image width in mm
Public property | InputSource | Gets the image input source
Public property | Label | Gets the label, a user defined string for naming the image.
Public property | SpecimenTilt | Gets specimen tilt in degrees
Public property | StageTilt | Gets stage tilt in degrees
Public property | TiltCorrection | Gets software tilt correction state
Public property | Width | Gets the width of image(pixels)
Top
See Also

Reference

OINA.Extender.Data.Image Namespace


IElectronImageDetails Properties

The IElectronImageDetails type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets acquisiton date
Public property | DwellTimePerPixelMicroseconds | Gets dwell time for each pixel in microseconds
Public property | EffectiveMagnificationWithZoom | Gets the effective magnification used for an image if digital zoom (for drift correction) is included.
Public property | FramesAveraged | Gets the number of averaged frames
Public property | Height | Gets the height of image(pixels)
Public property | ImageHeight | Gets the viewable-image height in mm
Public property | ImageWidth | Gets the viewable-image width in mm
Public property | InputSource | Gets the image input source
Public property | Label | Gets the label, a user defined string for naming the image.
Public property | SpecimenTilt | Gets specimen tilt in degrees
Public property | StageTilt | Gets stage tilt in degrees
Public property | TiltCorrection | Gets software tilt correction state
Public property | Width | Gets the width of image(pixels)
Top
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.AcquisitionDate Property

Gets acquisiton date

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DateTime AcquisitionDate { get; }
ReadOnly Property AcquisitionDate As DateTime
    Get
property DateTime AcquisitionDate {
    DateTime get ();
}
abstract AcquisitionDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.DwellTimePerPixelMicroseconds Property

Gets dwell time for each pixel in microseconds

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double DwellTimePerPixelMicroseconds { get; }
ReadOnly Property DwellTimePerPixelMicroseconds As Double
    Get
property double DwellTimePerPixelMicroseconds {
    double get ();
}
abstract DwellTimePerPixelMicroseconds : float with get

Property Value

Type: Double
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.EffectiveMagnificationWithZoom Property

Gets the effective magnification used for an image if digital zoom (for drift correction) is included.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double EffectiveMagnificationWithZoom { get; }
ReadOnly Property EffectiveMagnificationWithZoom As Double
    Get
property double EffectiveMagnificationWithZoom {
    double get ();
}
abstract EffectiveMagnificationWithZoom : float with get

Property Value

Type: Double
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.FramesAveraged Property

Gets the number of averaged frames

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int FramesAveraged { get; }
ReadOnly Property FramesAveraged As Integer
    Get
property int FramesAveraged {
    int get ();
}
abstract FramesAveraged : int with get

Property Value

Type: Int32
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.Height Property

Gets the height of image(pixels)

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Height { get; }
ReadOnly Property Height As Double
    Get
property double Height {
    double get ();
}
abstract Height : float with get

Property Value

Type: Double
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.ImageHeight Property

Gets the viewable-image height in mm

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double ImageHeight { get; }
ReadOnly Property ImageHeight As Double
    Get
property double ImageHeight {
    double get ();
}
abstract ImageHeight : float with get

Property Value

Type: Double
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.ImageWidth Property

Gets the viewable-image width in mm

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double ImageWidth { get; }
ReadOnly Property ImageWidth As Double
    Get
property double ImageWidth {
    double get ();
}
abstract ImageWidth : float with get

Property Value

Type: Double
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.InputSource Property

Gets the image input source

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ImageInputSources InputSource { get; }
ReadOnly Property InputSource As ImageInputSources
    Get
property ImageInputSources InputSource {
    ImageInputSources get ();
}
abstract InputSource : ImageInputSources with get

Property Value

Type: ImageInputSources
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.Label Property

Gets the label, a user defined string for naming the image.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string Label { get; }
ReadOnly Property Label As String
    Get
property String^ Label {
    String^ get ();
}
abstract Label : string with get

Property Value

Type: String
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.SpecimenTilt Property

Gets specimen tilt in degrees

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double SpecimenTilt { get; }
ReadOnly Property SpecimenTilt As Double
    Get
property double SpecimenTilt {
    double get ();
}
abstract SpecimenTilt : float with get

Property Value

Type: Double
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.StageTilt Property

Gets stage tilt in degrees

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StageTilt { get; }
ReadOnly Property StageTilt As Double
    Get
property double StageTilt {
    double get ();
}
abstract StageTilt : float with get

Property Value

Type: Double
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.TiltCorrection Property

Gets software tilt correction state

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string TiltCorrection { get; }
ReadOnly Property TiltCorrection As String
    Get
property String^ TiltCorrection {
    String^ get ();
}
abstract TiltCorrection : string with get

Property Value

Type: String
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IElectronImageDetails.Width Property

Gets the width of image(pixels)

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Width { get; }
ReadOnly Property Width As Double
    Get
property double Width {
    double get ();
}
abstract Width : float with get

Property Value

Type: Double
See Also

Reference

IElectronImageDetails Interface
OINA.Extender.Data.Image Namespace


IFLSMapImage Interface

Interface that defines properties and methods for FLS Map Images.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IFLSMapImage : INotifyPropertyChanged,
    IDisposable, IEdMapImage, IImageCorrection
Public Interface IFLSMapImage
    Inherits INotifyPropertyChanged, IDisposable, IEdMapImage, IImageCorrection
public interface class IFLSMapImage : INotifyPropertyChanged,
    IDisposable, IEdMapImage, IImageCorrection
type IFLSMapImage =
    interface
        interface INotifyPropertyChanged
        interface IDisposable
        interface IEdMapImage
        interface IImageCorrection
    end

The IFLSMapImage type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date. (Inherited from IImageCorrection.)
Public property | AtomicNumber | Gets the atomic number. (Inherited from IEdMapImage.)
Public property | BinFactor | Gets the bin factor (Inherited from IEdMapImage.)
Public property | BytesPerPixel | Gets the number of bytes used to store the data at each pixel. (Inherited from IImageCorrection.)
Public property | ColumnConditions | Gets the microscope column conditions. (Inherited from IEdMapImage.)
Public property | DateCreated | Gets the date the image was created (Inherited from IEdMapImage.)
Public property | Details | Gets a snapshot of the image details. (Inherited from IEdMapImage.)
Public property | DwellTimePerPixelMicroseconds | Gets the time spent acquiring each pixel in microseconds. (Inherited from IEdMapImage.)
Public property | FlsThresholdApplied | Gets a value indicating whether thresholding has been applied
Public property | FlsThresholdSigmaLevel | Gets the sigma value used for thresholding
Public property | Height | Gets the height of the image in pixels. (Inherited from IImageCorrection.)
Public property | Id | Gets a unique identifier for the image. (Inherited from IImageCorrection.)
Public property | IsFrozen | Gets a value indicating whether the image data has finished updating. (Inherited from IEdMapImage.)
Public property | Label | Gets or sets a label to identify the image. (Inherited from IImageCorrection.)
Public property | LineType | Gets the line type
Public property | LowColor | Gets or sets the lower colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Maximum | Gets the maximum value in the image. (Inherited from IEdMapImage.)
Public property | Minimum | Gets the minimum value in the image. (Inherited from IEdMapImage.)
Public property | PixelSize | Gets the pixel size. (Inherited from IImageCorrection.)
Public property | Region | Gets the acquisition region. (Inherited from IEdMapImage.)
Public property | StageConditions | Gets the microscope stage conditions. (Inherited from IEdMapImage.)
Public property | UpperColor | Gets or sets the upper colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Width | Gets the width of the image in pixels. (Inherited from IImageCorrection.)
Top
Methods
 | Name | Description
Public method | AutoBrightness | Performs automatic brightness correction. (Inherited from IImageCorrection.)
Public method | AutoGamma | Performs automatic gamma correction. (Inherited from IImageCorrection.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetData(Point) | Gets the data at a pixel. (Inherited from IEdMapImage.)
Public method | GetData(Single) | Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height). (Inherited from IEdMapImage.)
Public method | GetData(IEnumerableChord, Single) | Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels. (Inherited from IEdMapImage.)
Public method | Save | Saves the image as a byte array. (Inherited from IImageCorrection.)
Top
Events
 | Name | Description
Public event | DataChanged | Event that is fired when the image data changes. (Inherited from IEdMapImage.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Data.Image Namespace


IFLSMapImage Properties

The IFLSMapImage type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date. (Inherited from IImageCorrection.)
Public property | AtomicNumber | Gets the atomic number. (Inherited from IEdMapImage.)
Public property | BinFactor | Gets the bin factor (Inherited from IEdMapImage.)
Public property | BytesPerPixel | Gets the number of bytes used to store the data at each pixel. (Inherited from IImageCorrection.)
Public property | ColumnConditions | Gets the microscope column conditions. (Inherited from IEdMapImage.)
Public property | DateCreated | Gets the date the image was created (Inherited from IEdMapImage.)
Public property | Details | Gets a snapshot of the image details. (Inherited from IEdMapImage.)
Public property | DwellTimePerPixelMicroseconds | Gets the time spent acquiring each pixel in microseconds. (Inherited from IEdMapImage.)
Public property | FlsThresholdApplied | Gets a value indicating whether thresholding has been applied
Public property | FlsThresholdSigmaLevel | Gets the sigma value used for thresholding
Public property | Height | Gets the height of the image in pixels. (Inherited from IImageCorrection.)
Public property | Id | Gets a unique identifier for the image. (Inherited from IImageCorrection.)
Public property | IsFrozen | Gets a value indicating whether the image data has finished updating. (Inherited from IEdMapImage.)
Public property | Label | Gets or sets a label to identify the image. (Inherited from IImageCorrection.)
Public property | LineType | Gets the line type
Public property | LowColor | Gets or sets the lower colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Maximum | Gets the maximum value in the image. (Inherited from IEdMapImage.)
Public property | Minimum | Gets the minimum value in the image. (Inherited from IEdMapImage.)
Public property | PixelSize | Gets the pixel size. (Inherited from IImageCorrection.)
Public property | Region | Gets the acquisition region. (Inherited from IEdMapImage.)
Public property | StageConditions | Gets the microscope stage conditions. (Inherited from IEdMapImage.)
Public property | UpperColor | Gets or sets the upper colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Width | Gets the width of the image in pixels. (Inherited from IImageCorrection.)
Top
See Also

Reference

IFLSMapImage Interface
OINA.Extender.Data.Image Namespace


IFLSMapImage.FlsThresholdApplied Property

Gets a value indicating whether thresholding has been applied

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool FlsThresholdApplied { get; }
ReadOnly Property FlsThresholdApplied As Boolean
    Get
property bool FlsThresholdApplied {
    bool get ();
}
abstract FlsThresholdApplied : bool with get

Property Value

Type: Boolean
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IFLSMapImage Interface
OINA.Extender.Data.Image Namespace


IFLSMapImage.FlsThresholdSigmaLevel Property

Gets the sigma value used for thresholding

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double FlsThresholdSigmaLevel { get; }
ReadOnly Property FlsThresholdSigmaLevel As Double
    Get
property double FlsThresholdSigmaLevel {
    double get ();
}
abstract FlsThresholdSigmaLevel : float with get

Property Value

Type: Double
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IFLSMapImage Interface
OINA.Extender.Data.Image Namespace


IFLSMapImage.LineType Property

Gets the line type

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
QuantLineCode LineType { get; }
ReadOnly Property LineType As QuantLineCode
    Get
property QuantLineCode LineType {
    QuantLineCode get ();
}
abstract LineType : QuantLineCode with get

Property Value

Type: QuantLineCode
Exceptions
Exception | Condition
ObjectDisposedException | Thrown if the image is disposed.
See Also

Reference

IFLSMapImage Interface
OINA.Extender.Data.Image Namespace


IFLSMapImage Methods

The IFLSMapImage type exposes the following members.

Methods
 | Name | Description
Public method | AutoBrightness | Performs automatic brightness correction. (Inherited from IImageCorrection.)
Public method | AutoGamma | Performs automatic gamma correction. (Inherited from IImageCorrection.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetData(Point) | Gets the data at a pixel. (Inherited from IEdMapImage.)
Public method | GetData(Single) | Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height). (Inherited from IEdMapImage.)
Public method | GetData(IEnumerableChord, Single) | Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels. (Inherited from IEdMapImage.)
Public method | Save | Saves the image as a byte array. (Inherited from IImageCorrection.)
Top
See Also

Reference

IFLSMapImage Interface
OINA.Extender.Data.Image Namespace


IFLSMapImage Events

The IFLSMapImage type exposes the following members.

Events
 | Name | Description
Public event | DataChanged | Event that is fired when the image data changes. (Inherited from IEdMapImage.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IFLSMapImage Interface
OINA.Extender.Data.Image Namespace


IImageCorrection Interface

An Interface that defines common properties and methods for images.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IImageCorrection : INotifyPropertyChanged,
    IDisposable
Public Interface IImageCorrection
    Inherits INotifyPropertyChanged, IDisposable
public interface class IImageCorrection : INotifyPropertyChanged,
    IDisposable
type IImageCorrection =
    interface
        interface INotifyPropertyChanged
        interface IDisposable
    end

The IImageCorrection type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date.
Public property | BytesPerPixel | Gets the number of bytes used to store the data at each pixel.
Public property | Height | Gets the height of the image in pixels.
Public property | Id | Gets a unique identifier for the image.
Public property | Label | Gets or sets a label to identify the image.
Public property | LowColor | Gets or sets the lower colour value for interpolating the pixel values.
Public property | PixelSize | Gets the pixel size.
Public property | UpperColor | Gets or sets the upper colour value for interpolating the pixel values.
Public property | Width | Gets the width of the image in pixels.
Top
Methods
 | Name | Description
Public method | AutoBrightness | Performs automatic brightness correction.
Public method | AutoGamma | Performs automatic gamma correction.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Save | Saves the image as a byte array.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Data.Image Namespace


IImageCorrection Properties

The IImageCorrection type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date.
Public property | BytesPerPixel | Gets the number of bytes used to store the data at each pixel.
Public property | Height | Gets the height of the image in pixels.
Public property | Id | Gets a unique identifier for the image.
Public property | Label | Gets or sets a label to identify the image.
Public property | LowColor | Gets or sets the lower colour value for interpolating the pixel values.
Public property | PixelSize | Gets the pixel size.
Public property | UpperColor | Gets or sets the upper colour value for interpolating the pixel values.
Public property | Width | Gets the width of the image in pixels.
Top
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.AcquisitionDate Property

Gets the acquisition date.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DateTime AcquisitionDate { get; }
ReadOnly Property AcquisitionDate As DateTime
    Get
property DateTime AcquisitionDate {
    DateTime get ();
}
abstract AcquisitionDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.BytesPerPixel Property

Gets the number of bytes used to store the data at each pixel.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int BytesPerPixel { get; }
ReadOnly Property BytesPerPixel As Integer
    Get
property int BytesPerPixel {
    int get ();
}
abstract BytesPerPixel : int with get

Property Value

Type: Int32
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.Height Property

Gets the height of the image in pixels.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int Height { get; }
ReadOnly Property Height As Integer
    Get
property int Height {
    int get ();
}
abstract Height : int with get

Property Value

Type: Int32
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.Id Property

Gets a unique identifier for the image.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Guid Id { get; }
ReadOnly Property Id As Guid
    Get
property Guid Id {
    Guid get ();
}
abstract Id : Guid with get

Property Value

Type: Guid
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.Label Property

Gets or sets a label to identify the image.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string Label { get; set; }
Property Label As String
    Get
    Set
property String^ Label {
    String^ get ();
    void set (String^ value);
}
abstract Label : string with get, set

Property Value

Type: String
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.LowColor Property

Gets or sets the lower colour value for interpolating the pixel values.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Color LowColor { get; set; }
Property LowColor As Color
    Get
    Set
property Color LowColor {
    Color get ();
    void set (Color value);
}
abstract LowColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.PixelSize Property

Gets the pixel size.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double PixelSize { get; }
ReadOnly Property PixelSize As Double
    Get
property double PixelSize {
    double get ();
}
abstract PixelSize : float with get

Property Value

Type: Double
The field width in pixels.
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.UpperColor Property

Gets or sets the upper colour value for interpolating the pixel values.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Color UpperColor { get; set; }
Property UpperColor As Color
    Get
    Set
property Color UpperColor {
    Color get ();
    void set (Color value);
}
abstract UpperColor : Color with get, set

Property Value

Type: Color
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.Width Property

Gets the width of the image in pixels.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int Width { get; }
ReadOnly Property Width As Integer
    Get
property int Width {
    int get ();
}
abstract Width : int with get

Property Value

Type: Int32
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection Methods

The IImageCorrection type exposes the following members.

Methods
 | Name | Description
Public method | AutoBrightness | Performs automatic brightness correction.
Public method | AutoGamma | Performs automatic gamma correction.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Save | Saves the image as a byte array.
Top
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.AutoBrightness Method

Performs automatic brightness correction.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void AutoBrightness()
Sub AutoBrightness
void AutoBrightness()
abstract AutoBrightness : unit -> unit
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.AutoGamma Method

Performs automatic gamma correction.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void AutoGamma()
Sub AutoGamma
void AutoGamma()
abstract AutoGamma : unit -> unit
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection.Save Method

Saves the image as a byte array.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
byte[] Save()
Function Save As Byte()
array<unsigned char>^ Save()
abstract Save : unit -> byte[]

Return Value

Type: Byte
The byte array
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


IImageCorrection Events

The IImageCorrection type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IImageCorrection Interface
OINA.Extender.Data.Image Namespace


ImageInputSources Enumeration

Input sources used for image acquisition.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum ImageInputSources
Public Enumeration ImageInputSources
public enum class ImageInputSources
type ImageInputSources
Members
Member name | Value | Description
None | 0 | No imaging
SE | 1 | Secondary electron imaging
Bse | 2 | Backscattered electron image
See Also

Reference

OINA.Extender.Data.Image Namespace


IWindowIntegralMapImage Interface

Interface that defines properties and methods for Window integral Map Images.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IWindowIntegralMapImage : INotifyPropertyChanged,
    IDisposable, IEdMapImage, IImageCorrection
Public Interface IWindowIntegralMapImage
    Inherits INotifyPropertyChanged, IDisposable, IEdMapImage, IImageCorrection
public interface class IWindowIntegralMapImage : INotifyPropertyChanged,
    IDisposable, IEdMapImage, IImageCorrection
type IWindowIntegralMapImage =
    interface
        interface INotifyPropertyChanged
        interface IDisposable
        interface IEdMapImage
        interface IImageCorrection
    end

The IWindowIntegralMapImage type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date. (Inherited from IImageCorrection.)
Public property | AtomicNumber | Gets the atomic number. (Inherited from IEdMapImage.)
Public property | BinFactor | Gets the bin factor (Inherited from IEdMapImage.)
Public property | BytesPerPixel | Gets the number of bytes used to store the data at each pixel. (Inherited from IImageCorrection.)
Public property | ColumnConditions | Gets the microscope column conditions. (Inherited from IEdMapImage.)
Public property | DateCreated | Gets the date the image was created (Inherited from IEdMapImage.)
Public property | Details | Gets a snapshot of the image details. (Inherited from IEdMapImage.)
Public property | DwellTimePerPixelMicroseconds | Gets the time spent acquiring each pixel in microseconds. (Inherited from IEdMapImage.)
Public property | Height | Gets the height of the image in pixels. (Inherited from IImageCorrection.)
Public property | Id | Gets a unique identifier for the image. (Inherited from IImageCorrection.)
Public property | IsFrozen | Gets a value indicating whether the image data has finished updating. (Inherited from IEdMapImage.)
Public property | Label | Gets or sets a label to identify the image. (Inherited from IImageCorrection.)
Public property | LowColor | Gets or sets the lower colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Maximum | Gets the maximum value in the image. (Inherited from IEdMapImage.)
Public property | Minimum | Gets the minimum value in the image. (Inherited from IEdMapImage.)
Public property | PixelSize | Gets the pixel size. (Inherited from IImageCorrection.)
Public property | Region | Gets the acquisition region. (Inherited from IEdMapImage.)
Public property | StageConditions | Gets the microscope stage conditions. (Inherited from IEdMapImage.)
Public property | UpperColor | Gets or sets the upper colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Width | Gets the width of the image in pixels. (Inherited from IImageCorrection.)
Public property | Window | Gets the energy window used to extract the data from the map.
Top
Methods
 | Name | Description
Public method | AutoBrightness | Performs automatic brightness correction. (Inherited from IImageCorrection.)
Public method | AutoGamma | Performs automatic gamma correction. (Inherited from IImageCorrection.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetData(Point) | Gets the data at a pixel. (Inherited from IEdMapImage.)
Public method | GetData(Single) | Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height). (Inherited from IEdMapImage.)
Public method | GetData(IEnumerableChord, Single) | Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels. (Inherited from IEdMapImage.)
Public method | Save | Saves the image as a byte array. (Inherited from IImageCorrection.)
Top
Events
 | Name | Description
Public event | DataChanged | Event that is fired when the image data changes. (Inherited from IEdMapImage.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Data.Image Namespace


IWindowIntegralMapImage Properties

The IWindowIntegralMapImage type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionDate | Gets the acquisition date. (Inherited from IImageCorrection.)
Public property | AtomicNumber | Gets the atomic number. (Inherited from IEdMapImage.)
Public property | BinFactor | Gets the bin factor (Inherited from IEdMapImage.)
Public property | BytesPerPixel | Gets the number of bytes used to store the data at each pixel. (Inherited from IImageCorrection.)
Public property | ColumnConditions | Gets the microscope column conditions. (Inherited from IEdMapImage.)
Public property | DateCreated | Gets the date the image was created (Inherited from IEdMapImage.)
Public property | Details | Gets a snapshot of the image details. (Inherited from IEdMapImage.)
Public property | DwellTimePerPixelMicroseconds | Gets the time spent acquiring each pixel in microseconds. (Inherited from IEdMapImage.)
Public property | Height | Gets the height of the image in pixels. (Inherited from IImageCorrection.)
Public property | Id | Gets a unique identifier for the image. (Inherited from IImageCorrection.)
Public property | IsFrozen | Gets a value indicating whether the image data has finished updating. (Inherited from IEdMapImage.)
Public property | Label | Gets or sets a label to identify the image. (Inherited from IImageCorrection.)
Public property | LowColor | Gets or sets the lower colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Maximum | Gets the maximum value in the image. (Inherited from IEdMapImage.)
Public property | Minimum | Gets the minimum value in the image. (Inherited from IEdMapImage.)
Public property | PixelSize | Gets the pixel size. (Inherited from IImageCorrection.)
Public property | Region | Gets the acquisition region. (Inherited from IEdMapImage.)
Public property | StageConditions | Gets the microscope stage conditions. (Inherited from IEdMapImage.)
Public property | UpperColor | Gets or sets the upper colour value for interpolating the pixel values. (Inherited from IImageCorrection.)
Public property | Width | Gets the width of the image in pixels. (Inherited from IImageCorrection.)
Public property | Window | Gets the energy window used to extract the data from the map.
Top
See Also

Reference

IWindowIntegralMapImage Interface
OINA.Extender.Data.Image Namespace


IWindowIntegralMapImage.Window Property

Gets the energy window used to extract the data from the map.

Namespace: OINA.Extender.Data.Image
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdEnergyWindow Window { get; }
ReadOnly Property Window As IEdEnergyWindow
    Get
property IEdEnergyWindow^ Window {
    IEdEnergyWindow^ get ();
}
abstract Window : IEdEnergyWindow with get

Property Value

Type: IEdEnergyWindow
See Also

Reference

IWindowIntegralMapImage Interface
OINA.Extender.Data.Image Namespace


IWindowIntegralMapImage Methods

The IWindowIntegralMapImage type exposes the following members.

Methods
 | Name | Description
Public method | AutoBrightness | Performs automatic brightness correction. (Inherited from IImageCorrection.)
Public method | AutoGamma | Performs automatic gamma correction. (Inherited from IImageCorrection.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetData(Point) | Gets the data at a pixel. (Inherited from IEdMapImage.)
Public method | GetData(Single) | Copies the image data into the supplied buffer. Buffer length should be at least (Width x Height). (Inherited from IEdMapImage.)
Public method | GetData(IEnumerableChord, Single) | Copies the image data into the supplied buffer for the region specified by the chords. Buffer length should be at least number of pixels. (Inherited from IEdMapImage.)
Public method | Save | Saves the image as a byte array. (Inherited from IImageCorrection.)
Top
See Also

Reference

IWindowIntegralMapImage Interface
OINA.Extender.Data.Image Namespace


IWindowIntegralMapImage Events

The IWindowIntegralMapImage type exposes the following members.

Events
 | Name | Description
Public event | DataChanged | Event that is fired when the image data changes. (Inherited from IEdMapImage.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IWindowIntegralMapImage Interface
OINA.Extender.Data.Image Namespace


OINA.Extender.Data.Region Namespace

Defines Classes and Interfaces that describe acquisition regions.

Interfaces
 | Interface | Description
Public interface | IChordListRegion | An Interface that defines a region as a chord list in pixel co-ordinates.
Public interface | IFullFieldRegion | The full area scanned
Public interface | IMicroscopeRegion | An Interface that defines a region where Oxford Instruments hardware does not control the scan.
Public interface | IPointRegion | An Interface that defines acquisition from a single point.
Public interface | IRectangleRegion | An Interface that defines acquisition from a rectangle.
Public interface | IRegion | An Interface that defines an acquisition region.


IChordListRegion Interface

An Interface that defines a region as a chord list in pixel co-ordinates.

Namespace: OINA.Extender.Data.Region
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IChordListRegion : ICloneable,
    IRegion
Public Interface IChordListRegion
    Inherits ICloneable, IRegion
public interface class IChordListRegion : ICloneable,
    IRegion
type IChordListRegion =
    interface
        interface ICloneable
        interface IRegion
    end

The IChordListRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates. (Inherited from IRegion.)
Public property | ChordList | Gets the chord list, in pixel co-ordinates.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

OINA.Extender.Data.Region Namespace


IChordListRegion Properties

The IChordListRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates. (Inherited from IRegion.)
Public property | ChordList | Gets the chord list, in pixel co-ordinates.
Top
See Also

Reference

IChordListRegion Interface
OINA.Extender.Data.Region Namespace


IChordListRegion.ChordList Property

Gets the chord list, in pixel co-ordinates.

Namespace: OINA.Extender.Data.Region
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ChordList ChordList { get; }
ReadOnly Property ChordList As ChordList
    Get
property ChordList^ ChordList {
    ChordList^ get ();
}
abstract ChordList : ChordList with get

Property Value

Type: ChordList
See Also

Reference

IChordListRegion Interface
OINA.Extender.Data.Region Namespace


IChordListRegion Methods

The IChordListRegion type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

IChordListRegion Interface
OINA.Extender.Data.Region Namespace


IFullFieldRegion Interface

The full area scanned

Namespace: OINA.Extender.Data.Region
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IFullFieldRegion : ICloneable,
    IRegion
Public Interface IFullFieldRegion
    Inherits ICloneable, IRegion
public interface class IFullFieldRegion : ICloneable,
    IRegion
type IFullFieldRegion =
    interface
        interface ICloneable
        interface IRegion
    end

The IFullFieldRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates. (Inherited from IRegion.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

OINA.Extender.Data.Region Namespace


IFullFieldRegion Properties

The IFullFieldRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates. (Inherited from IRegion.)
Top
See Also

Reference

IFullFieldRegion Interface
OINA.Extender.Data.Region Namespace


IFullFieldRegion Methods

The IFullFieldRegion type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

IFullFieldRegion Interface
OINA.Extender.Data.Region Namespace


IMicroscopeRegion Interface

An Interface that defines a region where Oxford Instruments hardware does not control the scan.

Namespace: OINA.Extender.Data.Region
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IMicroscopeRegion : ICloneable,
    IRegion
Public Interface IMicroscopeRegion
    Inherits ICloneable, IRegion
public interface class IMicroscopeRegion : ICloneable,
    IRegion
type IMicroscopeRegion =
    interface
        interface ICloneable
        interface IRegion
    end

The IMicroscopeRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates. (Inherited from IRegion.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

OINA.Extender.Data.Region Namespace


IMicroscopeRegion Properties

The IMicroscopeRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates. (Inherited from IRegion.)
Top
See Also

Reference

IMicroscopeRegion Interface
OINA.Extender.Data.Region Namespace


IMicroscopeRegion Methods

The IMicroscopeRegion type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

IMicroscopeRegion Interface
OINA.Extender.Data.Region Namespace


IPointRegion Interface

An Interface that defines acquisition from a single point.

Namespace: OINA.Extender.Data.Region
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IPointRegion : ICloneable,
    IRegion
Public Interface IPointRegion
    Inherits ICloneable, IRegion
public interface class IPointRegion : ICloneable,
    IRegion
type IPointRegion =
    interface
        interface ICloneable
        interface IRegion
    end

The IPointRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates. (Inherited from IRegion.)
Public property | Position | Gets the position in normalised co-ordinates.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

OINA.Extender.Data.Region Namespace


IPointRegion Properties

The IPointRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates. (Inherited from IRegion.)
Public property | Position | Gets the position in normalised co-ordinates.
Top
See Also

Reference

IPointRegion Interface
OINA.Extender.Data.Region Namespace


IPointRegion.Position Property

Gets the position in normalised co-ordinates.

Namespace: OINA.Extender.Data.Region
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Point Position { get; }
ReadOnly Property Position As Point
    Get
property Point Position {
    Point get ();
}
abstract Position : Point with get

Property Value

Type: Point
See Also

Reference

IPointRegion Interface
OINA.Extender.Data.Region Namespace


IPointRegion Methods

The IPointRegion type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

IPointRegion Interface
OINA.Extender.Data.Region Namespace


IRectangleRegion Interface

An Interface that defines acquisition from a rectangle.

Namespace: OINA.Extender.Data.Region
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IRectangleRegion : ICloneable,
    IRegion
Public Interface IRectangleRegion
    Inherits ICloneable, IRegion
public interface class IRectangleRegion : ICloneable,
    IRegion
type IRectangleRegion =
    interface
        interface ICloneable
        interface IRegion
    end

The IRectangleRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates. (Inherited from IRegion.)
Public property | Rectangle | Gets the scanned area in normalised co-ordinates.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

OINA.Extender.Data.Region Namespace


IRectangleRegion Properties

The IRectangleRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates. (Inherited from IRegion.)
Public property | Rectangle | Gets the scanned area in normalised co-ordinates.
Top
See Also

Reference

IRectangleRegion Interface
OINA.Extender.Data.Region Namespace


IRectangleRegion.Rectangle Property

Gets the scanned area in normalised co-ordinates.

Namespace: OINA.Extender.Data.Region
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Rect Rectangle { get; }
ReadOnly Property Rectangle As Rect
    Get
property Rect Rectangle {
    Rect get ();
}
abstract Rectangle : Rect with get

Property Value

Type: Rect
See Also

Reference

IRectangleRegion Interface
OINA.Extender.Data.Region Namespace


IRectangleRegion Methods

The IRectangleRegion type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

IRectangleRegion Interface
OINA.Extender.Data.Region Namespace


IRegion Interface

An Interface that defines an acquisition region.

Namespace: OINA.Extender.Data.Region
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IRegion : ICloneable
Public Interface IRegion
    Inherits ICloneable
public interface class IRegion : ICloneable
type IRegion =
    interface
        interface ICloneable
    end

The IRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

OINA.Extender.Data.Region Namespace


IRegion Properties

The IRegion type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | Gets the bounding box for the region in normalised co-ordinates.
Top
See Also

Reference

IRegion Interface
OINA.Extender.Data.Region Namespace


IRegion.BoundingBox Property

Gets the bounding box for the region in normalised co-ordinates.

Namespace: OINA.Extender.Data.Region
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Rect BoundingBox { get; }
ReadOnly Property BoundingBox As Rect
    Get
property Rect BoundingBox {
    Rect get ();
}
abstract BoundingBox : Rect with get

Property Value

Type: Rect
See Also

Reference

IRegion Interface
OINA.Extender.Data.Region Namespace


IRegion Methods

The IRegion type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
Top
See Also

Reference

IRegion Interface
OINA.Extender.Data.Region Namespace


OINA.Extender.DetectorControl Namespace

Defines Classes used to interact with Detectors making up a system; and a Detector's associated functionality.

An array of Detector Control Objects can be obtained using OINA.Extender.AcquireFactory.CreateEdDetectorControl. Each function for a Detector can be controlled using a Control Interface Object, obtained from the Detector's IEdDetectorControl Interface Object, such as Thermal Control, Shutter Control, Slide Control, and Overload Control.

An array of detector control objects can be obtained using [AcquireFactory.CreateEdDetectorControl()]. Each function for a detector can be controlled using a control interface object obtained from the detector's [IEdDetectorControl] interface object, such as Thermal Control, Shutter Control, Slide Control, and Overload Control.

OINA Extender DetectorControl Namespace

Classes
 | Class | Description
Public class | DetectorControlException | A Class that generates an exception when there is a detector control error.
Interfaces
 | Interface | Description
Public interface | IControlBase | A common detector control interface.
 | IDetectorStatus | An Interface that defines the status of the detector.
 | IEdDetectorControl | An Interface that facilitates control of an Ed detector. CreateEdDetectorControl
 | IOverloadCapabilities | An Interface that defines the overload capabilities of a detector. Capabilities
 | IOverloadControl | An Interface that defines overload control for a detector.
 | IOverloadStatus | An Interface that defines the overload status of a detector.
 | IShutterCapabilities | An Interface that defines the shutter capabilities of a detector. Capabilities
 | IShutterControl | An Interface that defines shutter control for a detector.
 | IShutterStatus | An Interface that defines the shutter status of an Ed detector.
 | ISlideCapabilities | An Interface that defines the slide capabilities of a detector. Capabilities
 | ISlideControl | An Interface that defines slide control of an Ed detector.
 | ISlideStatus | An Interface that defines the slide status of an Ed detector.
 | IThermalCapabilities | An Interface that defines the thermal control capabilities of a detector.
 | IThermalControl | An Interface that defines the thermal control for a detector.
 | IThermalStatus | An Interface that defines the thermal control status.
Enumerations
 | Enumeration | Description
Public enumeration | DetectorOperatingMode | Options for operating the detector.
Public enumeration | DetectorOperatingState | Detector operating states.
Public enumeration | DetectorShutterState | Detector shutter states.
Public enumeration | DetectorSlideActivity | Slide activity options.
Public enumeration | DetectorSlidePositionState | Detector slide position states.
Public enumeration | DetectorVacuumState | Detector vacuum states.
Public enumeration | LN2State | LN2 states.
Public enumeration | LowMagInterlock | The status of Low Mag Interlock.


DetectorControlException Class

A Class that generates an exception when there is a detector control error.
Inheritance Hierarchy
SystemObject
SystemException
OINA.Extender.DetectorControlDetectorControlException

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DetectorControlException : Exception
<SerializableAttribute>
Public Class DetectorControlException
    Inherits Exception
[SerializableAttribute]
public ref class DetectorControlException : public Exception
[<SerializableAttribute>]
type DetectorControlException =
    class
        inherit Exception
    end

The DetectorControlException type exposes the following members.

Constructors
 | Name | Description
Public method | DetectorControlException | Initializes a new instance of the DetectorControlException class.
Public method | DetectorControlException(String) | Initializes a new instance of the DetectorControlException class.
Protected method | DetectorControlException(SerializationInfo, StreamingContext) | Needed to comply with correct inheritance for Exception
Public method | DetectorControlException(String, Exception) | Initializes a new instance of the DetectorControlException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Needed to comply with correct inheritance for Exception (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OINA.Extender.DetectorControl Namespace


DetectorControlException Constructor

Overload List
 | Name | Description
Public method | DetectorControlException | Initializes a new instance of the DetectorControlException class.
Public method | DetectorControlException(String) | Initializes a new instance of the DetectorControlException class.
Protected method | DetectorControlException(SerializationInfo, StreamingContext) | Needed to comply with correct inheritance for Exception
Public method | DetectorControlException(String, Exception) | Initializes a new instance of the DetectorControlException class.
Top
See Also

Reference

DetectorControlException Class
OINA.Extender.DetectorControl Namespace


DetectorControlException Constructor

Initializes a new instance of the DetectorControlException class.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DetectorControlException()
Public Sub New
public:
DetectorControlException()
new : unit -> DetectorControlException
See Also

Reference

DetectorControlException Class
DetectorControlException Overload
OINA.Extender.DetectorControl Namespace


DetectorControlException Constructor (String)

Initializes a new instance of the DetectorControlException class.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DetectorControlException(
    string message
)
Public Sub New (
    message As String
)
public:
DetectorControlException(
    String^ message
)
new :
        message : string -> DetectorControlException

Parameters

message
Type: SystemString
The message
See Also

Reference

DetectorControlException Class
DetectorControlException Overload
OINA.Extender.DetectorControl Namespace


DetectorControlException Constructor (SerializationInfo, StreamingContext)

Needed to comply with correct inheritance for Exception

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
protected DetectorControlException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
DetectorControlException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DetectorControlException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The info
context
Type: System.Runtime.SerializationStreamingContext
The context
See Also

Reference

DetectorControlException Class
DetectorControlException Overload
OINA.Extender.DetectorControl Namespace


DetectorControlException Constructor (String, Exception)

Initializes a new instance of the DetectorControlException class.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public DetectorControlException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
public:
DetectorControlException(
    String^ message,
    Exception^ innerException
)
new :
        message : string *
        innerException : Exception -> DetectorControlException

Parameters

message
Type: SystemString
The message
innerException
Type: SystemException
The inner exception
See Also

Reference

DetectorControlException Class
DetectorControlException Overload
OINA.Extender.DetectorControl Namespace


DetectorControlException Properties

The DetectorControlException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

DetectorControlException Class
OINA.Extender.DetectorControl Namespace


DetectorControlException Methods

The DetectorControlException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Needed to comply with correct inheritance for Exception (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

DetectorControlException Class
OINA.Extender.DetectorControl Namespace


DetectorControlException.GetObjectData Method

Needed to comply with correct inheritance for Exception

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The info
context
Type: System.Runtime.SerializationStreamingContext
The Context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DetectorControlException Class
OINA.Extender.DetectorControl Namespace


DetectorControlException Events

The DetectorControlException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DetectorControlException Class
OINA.Extender.DetectorControl Namespace


DetectorOperatingMode Enumeration

Options for operating the detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum DetectorOperatingMode
Public Enumeration DetectorOperatingMode
public enum class DetectorOperatingMode
type DetectorOperatingMode
Members
Member name | Value | Description
Unknown | 0 | The system was unable to determine how the detector is being cooled.
Manual | 1 | The detector is being cooled manually.
Automatic | 2 | The detector is being cooled automatically.
Standby | 3 | The detector is in standby mode.
See Also

Reference

OINA.Extender.DetectorControl Namespace


DetectorOperatingState Enumeration

Detector operating states.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum DetectorOperatingState
Public Enumeration DetectorOperatingState
public enum class DetectorOperatingState
type DetectorOperatingState
Members
Member name | Value | Description
Unknown | 0 | The system was unable to determine the state of the detector cooling.
Initialising | 1 | The detector cooling is initialising.
ManualControl | 2 | The detector cooling is under manual control
Standby | 3 | The detector cooling is in standby.
Warming | 4 | The detector is warming.
Warm | 5 | The detector is warm.
Cooling | 6 | The detector is cooling.
Cold | 7 | The detector is cold.
Fault | 8 | There is a fault with the detector cooling.
See Also

Reference

OINA.Extender.DetectorControl Namespace


DetectorShutterState Enumeration

Detector shutter states.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum DetectorShutterState
Public Enumeration DetectorShutterState
public enum class DetectorShutterState
type DetectorShutterState
Members
Member name | Value | Description
Unknown | 0 | The shutter state is unknown
Fault | 1 | The shutter is in a fault state
Open | 2 | The shutter is open
Closed | 3 | The shutter is closed
ClosedDueToOverload | 4 | The shutter has been closed due to an overload
See Also

Reference

OINA.Extender.DetectorControl Namespace


DetectorSlideActivity Enumeration

Slide activity options.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum DetectorSlideActivity
Public Enumeration DetectorSlideActivity
public enum class DetectorSlideActivity
type DetectorSlideActivity
Members
Member name | Value | Description
Unknown | 0 | The Slide activity is unknown
NotMoving | 1 | The Slide is not moving
MovingIn | 2 | The Slide is moving in
MovingOut | 3 | The Slide is moving out
AutoRetracting | 4 | The Slide is auto retracting
Homing | 5 | The Slide is moving to the Home position
See Also

Reference

OINA.Extender.DetectorControl Namespace


DetectorSlidePositionState Enumeration

Detector slide position states.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum DetectorSlidePositionState
Public Enumeration DetectorSlidePositionState
public enum class DetectorSlidePositionState
type DetectorSlidePositionState
Members
Member name | Value | Description
Unknown | 0 | The Slide position is Unknown
In | 1 | The Slide is fully inserted
Out | 2 | The Slide is fully retracted
Indeterminate | 3 | The Slide position can't be determined
Fault | 4 | There is a fault with the Slide
AutoRetracted | 5 | The Slide has been auto-retracted
ReferencePosition | 6 | The Slide is in a reference position
Intermediate | 7 | The Slide is in an intermediate state
See Also

Reference

OINA.Extender.DetectorControl Namespace


DetectorVacuumState Enumeration

Detector vacuum states.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum DetectorVacuumState
Public Enumeration DetectorVacuumState
public enum class DetectorVacuumState
type DetectorVacuumState
Members
Member name | Value | Description
Unknown | 0 | The system was unable to ascertain the state of the sensor.
Vented | 1 | The sensor is at atmosphere.
UnderVacuum | 2 | The sensor is under vacuum.
See Also

Reference

OINA.Extender.DetectorControl Namespace


IControlBase Interface

A common detector control interface.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IControlBase : IDisposable
Public Interface IControlBase
    Inherits IDisposable
public interface class IControlBase : IDisposable
type IControlBase =
    interface
        interface IDisposable
    end

The IControlBase type exposes the following members.

Properties
 | Name | Description
Public property | HardwareId | Gets a value identifying the detector being controlled.
Public property | IsConnected | Gets a value indicating whether or not the detector is connected.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
Events
 | Name | Description
Public event | DetectorConnected | Occurs when a connection to the detector is made or lost. Use this event to get capabilities and status.
Public event | StatusChanged | Occurs when the detector status changes.
Top
See Also

Reference

OINA.Extender.DetectorControl Namespace


IControlBase Properties

The IControlBase type exposes the following members.

Properties
 | Name | Description
Public property | HardwareId | Gets a value identifying the detector being controlled.
Public property | IsConnected | Gets a value indicating whether or not the detector is connected.
Top
See Also

Reference

IControlBase Interface
OINA.Extender.DetectorControl Namespace


IControlBase.HardwareId Property

Gets a value identifying the detector being controlled.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
EdHardwareId HardwareId { get; }
ReadOnly Property HardwareId As EdHardwareId
    Get
property EdHardwareId^ HardwareId {
    EdHardwareId^ get ();
}
abstract HardwareId : EdHardwareId with get

Property Value

Type: EdHardwareId
See Also

Reference

IControlBase Interface
OINA.Extender.DetectorControl Namespace


IControlBase.IsConnected Property

Gets a value indicating whether or not the detector is connected.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsConnected { get; }
ReadOnly Property IsConnected As Boolean
    Get
property bool IsConnected {
    bool get ();
}
abstract IsConnected : bool with get

Property Value

Type: Boolean
true if this instance has a hardware connection; otherwise, false.
See Also

Reference

IControlBase Interface
OINA.Extender.DetectorControl Namespace


IControlBase Methods

The IControlBase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

IControlBase Interface
OINA.Extender.DetectorControl Namespace


IControlBase Events

The IControlBase type exposes the following members.

Events
 | Name | Description
Public event | DetectorConnected | Occurs when a connection to the detector is made or lost. Use this event to get capabilities and status.
Public event | StatusChanged | Occurs when the detector status changes.
Top
See Also

Reference

IControlBase Interface
OINA.Extender.DetectorControl Namespace


IControlBase.DetectorConnected Event

Occurs when a connection to the detector is made or lost. Use this event to get capabilities and status.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<bool>> DetectorConnected
Event DetectorConnected As EventHandler(Of EventArgs(Of Boolean))
 event EventHandler<EventArgs<bool>^>^ DetectorConnected {
    void add (EventHandler<EventArgs<bool>^>^ value);
    void remove (EventHandler<EventArgs<bool>^>^ value);
}
abstract DetectorConnected : IEvent<EventHandler<EventArgs<bool>>,
    EventArgs<bool>>

Value

Type: SystemEventHandler EventArgs Boolean
See Also

Reference

IControlBase Interface
OINA.Extender.DetectorControl Namespace


IControlBase.StatusChanged Event

Occurs when the detector status changes.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler StatusChanged
Event StatusChanged As EventHandler
 event EventHandler^ StatusChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
abstract StatusChanged : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

IControlBase Interface
OINA.Extender.DetectorControl Namespace


IDetectorStatus Interface

An Interface that defines the status of the detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IDetectorStatus : INotifyPropertyChanged
Public Interface IDetectorStatus
    Inherits INotifyPropertyChanged
public interface class IDetectorStatus : INotifyPropertyChanged
type IDetectorStatus =
    interface
        interface INotifyPropertyChanged
    end

The IDetectorStatus type exposes the following members.

Properties
 | Name | Description
Public property | IsDetectorReady | Gets a value indicating whether or not the detector is ready to use.
Public property | StatusDescription | Gets a message describing why the detector cannot be used.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Examples
Copy
namespace Extender.CodeExamples.DetectorExamples
{
    using System;
    using OINA.Extender;
    using OINA.Extender.DetectorControl;

    public class DetectorStatusExample
    {
        public static void Main(string[] args)
        {
            // Get the first detector control from the AcquireFactory
            IEdDetectorControl currentDetector = AcquireFactory.CreateEdDetectorControl()[0];

            Console.WriteLine("Current Detector is ready? {0}", currentDetector.DetectorStatus.IsDetectorReady);
            Console.WriteLine("Current Detector Status description : ");
            Console.WriteLine(currentDetector.DetectorStatus.StatusDescription);
        }
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace


IDetectorStatus Properties

The IDetectorStatus type exposes the following members.

Properties
 | Name | Description
Public property | IsDetectorReady | Gets a value indicating whether or not the detector is ready to use.
Public property | StatusDescription | Gets a message describing why the detector cannot be used.
Top
See Also

Reference

IDetectorStatus Interface
OINA.Extender.DetectorControl Namespace


IDetectorStatus.IsDetectorReady Property

Gets a value indicating whether or not the detector is ready to use.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsDetectorReady { get; }
ReadOnly Property IsDetectorReady As Boolean
    Get
property bool IsDetectorReady {
    bool get ();
}
abstract IsDetectorReady : bool with get

Property Value

Type: Boolean
See Also

Reference

IDetectorStatus Interface
OINA.Extender.DetectorControl Namespace


IDetectorStatus.StatusDescription Property

Gets a message describing why the detector cannot be used.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string StatusDescription { get; }
ReadOnly Property StatusDescription As String
    Get
property String^ StatusDescription {
    String^ get ();
}
abstract StatusDescription : string with get

Property Value

Type: String
See Also

Reference

IDetectorStatus Interface
OINA.Extender.DetectorControl Namespace


IDetectorStatus Events

The IDetectorStatus type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IDetectorStatus Interface
OINA.Extender.DetectorControl Namespace


IEdDetectorControl Interface

An Interface that facilitates control of an Ed detector. CreateEdDetectorControl

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdDetectorControl
Public Interface IEdDetectorControl
public interface class IEdDetectorControl
type IEdDetectorControl =  interface end

The IEdDetectorControl type exposes the following members.

Properties
 | Name | Description
Public property | DetectorStatus | Gets the current status of detector.
Public property | OverloadControl | Gets the overload control.
Public property | ShutterControl | Gets the shutter control.
Public property | SlideControl | Gets the slide control.
Public property | ThermalControl | Gets the thermal control.
Top
Examples
Copy
namespace Extender.CodeExamples.DetectorExamples
{
    using OINA.Extender;
    using OINA.Extender.DetectorControl;

    /// <summary>
    /// In this example we get the first detector from the AquireFactory.
    /// </summary>
    public class EdDetectorControlExample
    {
        public static void Main(string[] args)
        {
            // Get the first detector control from the AcquireFactory
            IEdDetectorControl currentDetector = AcquireFactory.CreateEdDetectorControl()[0];
        }
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace


IEdDetectorControl Properties

The IEdDetectorControl type exposes the following members.

Properties
 | Name | Description
Public property | DetectorStatus | Gets the current status of detector.
Public property | OverloadControl | Gets the overload control.
Public property | ShutterControl | Gets the shutter control.
Public property | SlideControl | Gets the slide control.
Public property | ThermalControl | Gets the thermal control.
Top
See Also

Reference

IEdDetectorControl Interface
OINA.Extender.DetectorControl Namespace


IEdDetectorControl.DetectorStatus Property

Gets the current status of detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IDetectorStatus DetectorStatus { get; }
ReadOnly Property DetectorStatus As IDetectorStatus
    Get
property IDetectorStatus^ DetectorStatus {
    IDetectorStatus^ get ();
}
abstract DetectorStatus : IDetectorStatus with get

Property Value

Type: IDetectorStatus
See Also

Reference

IEdDetectorControl Interface
OINA.Extender.DetectorControl Namespace


IEdDetectorControl.OverloadControl Property

Gets the overload control.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IOverloadControl OverloadControl { get; }
ReadOnly Property OverloadControl As IOverloadControl
    Get
property IOverloadControl^ OverloadControl {
    IOverloadControl^ get ();
}
abstract OverloadControl : IOverloadControl with get

Property Value

Type: IOverloadControl
See Also

Reference

IEdDetectorControl Interface
OINA.Extender.DetectorControl Namespace


IEdDetectorControl.ShutterControl Property

Gets the shutter control.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IShutterControl ShutterControl { get; }
ReadOnly Property ShutterControl As IShutterControl
    Get
property IShutterControl^ ShutterControl {
    IShutterControl^ get ();
}
abstract ShutterControl : IShutterControl with get

Property Value

Type: IShutterControl
See Also

Reference

IEdDetectorControl Interface
OINA.Extender.DetectorControl Namespace


IEdDetectorControl.SlideControl Property

Gets the slide control.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ISlideControl SlideControl { get; }
ReadOnly Property SlideControl As ISlideControl
    Get
property ISlideControl^ SlideControl {
    ISlideControl^ get ();
}
abstract SlideControl : ISlideControl with get

Property Value

Type: ISlideControl
See Also

Reference

IEdDetectorControl Interface
OINA.Extender.DetectorControl Namespace


IEdDetectorControl.ThermalControl Property

Gets the thermal control.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IThermalControl ThermalControl { get; }
ReadOnly Property ThermalControl As IThermalControl
    Get
property IThermalControl^ ThermalControl {
    IThermalControl^ get ();
}
abstract ThermalControl : IThermalControl with get

Property Value

Type: IThermalControl
See Also

Reference

IEdDetectorControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadCapabilities Interface

An Interface that defines the overload capabilities of a detector. Capabilities

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IOverloadCapabilities
Public Interface IOverloadCapabilities
public interface class IOverloadCapabilities
type IOverloadCapabilities =  interface end

The IOverloadCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | HasLowMagInterlock | Gets a value indicating whether or not there is a low mag interlock.
Public property | HasOverloadDelay | Gets a value indicating whether or not the detector supports overload delay.
Public property | HasOverloadDetection | Gets a value indicating whether or not the detector supports overload detection.
Public property | HasOverloadThreshold | Gets a value indicating whether or not the detector supports overload threshold.
Public property | MaximumOverloadDelay | Gets the maximum overload delay.
Public property | MaximumOverloadThreshold | Gets the maximum overload threshold.
Public property | MinimumOverloadDelay | Gets the minimum overload delay.
Public property | MinimumOverloadThreshold | Gets the minimum overload threshold.
Top
Examples
Copy
/// <summary>
/// Prints the detectors overload capabilities to console output.
/// </summary>
public void PrintOverloadCapabilities(IEdDetectorControl currentDetector)
{
    if (currentDetector.OverloadControl.Capabilities.HasOverloadDetection)
    {
        Console.WriteLine("Detector Overload control has overload detection.");
    }
    else
    {
        Console.WriteLine("Detector Overload control does not have overload detection!");
    }

    if (currentDetector.OverloadControl.Capabilities.HasLowMagInterlock)
    {
        Console.WriteLine("Detector Overload control has low mag interlock.");
    }

    if (currentDetector.OverloadControl.Capabilities.HasOverloadDelay)
    {
        Console.WriteLine("Min Overload delay = {0}", currentDetector.OverloadControl.Capabilities.MinimumOverloadDelay);
        Console.WriteLine("Max Overload delay = {0}", currentDetector.OverloadControl.Capabilities.MaximumOverloadDelay);
    }

    if (currentDetector.OverloadControl.Capabilities.HasOverloadThreshold)
    {
        Console.WriteLine("Min Overload Threshold = {0}", currentDetector.OverloadControl.Capabilities.MinimumOverloadThreshold);
        Console.WriteLine("Max Overload Threshold = {0}", currentDetector.OverloadControl.Capabilities.MaximumOverloadThreshold);
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace
IEdDetectorControlOverloadControl


IOverloadCapabilities Properties

The IOverloadCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | HasLowMagInterlock | Gets a value indicating whether or not there is a low mag interlock.
Public property | HasOverloadDelay | Gets a value indicating whether or not the detector supports overload delay.
Public property | HasOverloadDetection | Gets a value indicating whether or not the detector supports overload detection.
Public property | HasOverloadThreshold | Gets a value indicating whether or not the detector supports overload threshold.
Public property | MaximumOverloadDelay | Gets the maximum overload delay.
Public property | MaximumOverloadThreshold | Gets the maximum overload threshold.
Public property | MinimumOverloadDelay | Gets the minimum overload delay.
Public property | MinimumOverloadThreshold | Gets the minimum overload threshold.
Top
See Also

Reference

IOverloadCapabilities Interface
OINA.Extender.DetectorControl Namespace


IOverloadCapabilities.HasLowMagInterlock Property

Gets a value indicating whether or not there is a low mag interlock.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasLowMagInterlock { get; }
ReadOnly Property HasLowMagInterlock As Boolean
    Get
property bool HasLowMagInterlock {
    bool get ();
}
abstract HasLowMagInterlock : bool with get

Property Value

Type: Boolean
true if there is a low mag interlock; otherwise, false.
See Also

Reference

IOverloadCapabilities Interface
OINA.Extender.DetectorControl Namespace


IOverloadCapabilities.HasOverloadDelay Property

Gets a value indicating whether or not the detector supports overload delay.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasOverloadDelay { get; }
ReadOnly Property HasOverloadDelay As Boolean
    Get
property bool HasOverloadDelay {
    bool get ();
}
abstract HasOverloadDelay : bool with get

Property Value

Type: Boolean
true if the detector supports overload delay; otherwise, false.
See Also

Reference

IOverloadCapabilities Interface
OINA.Extender.DetectorControl Namespace


IOverloadCapabilities.HasOverloadDetection Property

Gets a value indicating whether or not the detector supports overload detection.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasOverloadDetection { get; }
ReadOnly Property HasOverloadDetection As Boolean
    Get
property bool HasOverloadDetection {
    bool get ();
}
abstract HasOverloadDetection : bool with get

Property Value

Type: Boolean
true if the detector supports overload detection; otherwise, false.
See Also

Reference

IOverloadCapabilities Interface
OINA.Extender.DetectorControl Namespace


IOverloadCapabilities.HasOverloadThreshold Property

Gets a value indicating whether or not the detector supports overload threshold.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasOverloadThreshold { get; }
ReadOnly Property HasOverloadThreshold As Boolean
    Get
property bool HasOverloadThreshold {
    bool get ();
}
abstract HasOverloadThreshold : bool with get

Property Value

Type: Boolean
true if the detector supports overload threshold; otherwise, false.
See Also

Reference

IOverloadCapabilities Interface
OINA.Extender.DetectorControl Namespace


IOverloadCapabilities.MaximumOverloadDelay Property

Gets the maximum overload delay.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
float MaximumOverloadDelay { get; }
ReadOnly Property MaximumOverloadDelay As Single
    Get
property float MaximumOverloadDelay {
    float get ();
}
abstract MaximumOverloadDelay : float32 with get

Property Value

Type: Single
The maximum overload delay.
See Also

Reference

IOverloadCapabilities Interface
OINA.Extender.DetectorControl Namespace


IOverloadCapabilities.MaximumOverloadThreshold Property

Gets the maximum overload threshold.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
float MaximumOverloadThreshold { get; }
ReadOnly Property MaximumOverloadThreshold As Single
    Get
property float MaximumOverloadThreshold {
    float get ();
}
abstract MaximumOverloadThreshold : float32 with get

Property Value

Type: Single
The maximum overload threshold.
See Also

Reference

IOverloadCapabilities Interface
OINA.Extender.DetectorControl Namespace


IOverloadCapabilities.MinimumOverloadDelay Property

Gets the minimum overload delay.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
float MinimumOverloadDelay { get; }
ReadOnly Property MinimumOverloadDelay As Single
    Get
property float MinimumOverloadDelay {
    float get ();
}
abstract MinimumOverloadDelay : float32 with get

Property Value

Type: Single
The minimum overload delay.
See Also

Reference

IOverloadCapabilities Interface
OINA.Extender.DetectorControl Namespace


IOverloadCapabilities.MinimumOverloadThreshold Property

Gets the minimum overload threshold.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
float MinimumOverloadThreshold { get; }
ReadOnly Property MinimumOverloadThreshold As Single
    Get
property float MinimumOverloadThreshold {
    float get ();
}
abstract MinimumOverloadThreshold : float32 with get

Property Value

Type: Single
The minimum overload threshold.
See Also

Reference

IOverloadCapabilities Interface
OINA.Extender.DetectorControl Namespace


IOverloadControl Interface

An Interface that defines overload control for a detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IOverloadControl : IDisposable,
    IControlBase
Public Interface IOverloadControl
    Inherits IDisposable, IControlBase
public interface class IOverloadControl : IDisposable,
    IControlBase
type IOverloadControl =
    interface
        interface IDisposable
        interface IControlBase
    end

The IOverloadControl type exposes the following members.

Properties
 | Name | Description
 | Capabilities | Gets the overload capabilities of the detector. IOverloadCapabilities
Public property | HardwareId | Gets a value identifying the detector being controlled. (Inherited from IControlBase.)
Public property | IsConnected | Gets a value indicating whether or not the detector is connected. (Inherited from IControlBase.)
 | Status | Gets the overload status of the detector. IOverloadStatus
Top
Methods
 | Name | Description
 | CanSetOverloadDelay | Determines if the specified overload detection delay can be set.
 | CanSetOverloadThreshold | Determines whether the specified overload detection threshold can be set.
 | CanToggleOverloadDetection | Determines whether overload detection can be toggled between enabled and disabled.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | SetOverloadDelay | Sets the overload detection delay.
 | SetOverloadThreshold | Sets the overload detection threshold.
 | ToggleOverloadDetection | Toggle overload detection between enabled and disabled.
Top
Events
 | Name | Description
Public event | DetectorConnected | Occurs when a connection to the detector is made or lost. Use this event to get capabilities and status. (Inherited from IControlBase.)
Public event | StatusChanged | Occurs when the detector status changes. (Inherited from IControlBase.)
Top
Examples
Copy
namespace Extender.CodeExamples.DetectorExamples
{
    using System;
    using System.Threading;
    using OINA.Extender;
    using OINA.Extender.DetectorControl;

    public class OverloadControlExample
    {
        public static void Main(string[] args)
        {
            OverloadControlExample overloadcontrol = new OverloadControlExample();

            if (args.Length < 2)
            {
                // Get the first detector control from the AcquireFactory
                IEdDetectorControl currentDetector = AcquireFactory.CreateEdDetectorControl()[0];

                // Get the delay and threshold values passed in.
                float delay = float.Parse(args[0]);
                float threshold = float.Parse(args[1]);

                // Output the detectors overload capabilities to the console window.
                overloadcontrol.PrintOverloadCapabilities(currentDetector);

                // Output the detectors overload status to the console window.
                overloadcontrol.PrintOverloadStatus(currentDetector);

                // Try and set the overload delay...
                if (!overloadcontrol.SetOverloadDelay(currentDetector, delay))
                {
                    Console.WriteLine("Failed to set Detector Overload delay : {0}", delay);
                }

                // Try and set the overload threshold...
                if (!overloadcontrol.SetOverloadThreshold(currentDetector, threshold))
                {
                    Console.WriteLine("Failed to set Detector Overload threshold : {0}", threshold);
                }

                // Try to Toggle the overload detection every 5 seconds until a key is pressed...
                while (Console.KeyAvailable == false)
                {
                    if (!overloadcontrol.ToggleOverloadDetection(currentDetector))
                    {
                        Console.WriteLine("Unable to Toggle overload detection!");
                    }

                    // Output the detectors overload status to the console window.
                    overloadcontrol.PrintOverloadStatus(currentDetector);

                    Thread.Sleep(5000);
                }
            }
        }

        #region Overload Capabilities
        /// <summary>
        /// Prints the detectors overload capabilities to console output.
        /// </summary>
        public void PrintOverloadCapabilities(IEdDetectorControl currentDetector)
        {
            if (currentDetector.OverloadControl.Capabilities.HasOverloadDetection)
            {
                Console.WriteLine("Detector Overload control has overload detection.");
            }
            else
            {
                Console.WriteLine("Detector Overload control does not have overload detection!");
            }

            if (currentDetector.OverloadControl.Capabilities.HasLowMagInterlock)
            {
                Console.WriteLine("Detector Overload control has low mag interlock.");
            }

            if (currentDetector.OverloadControl.Capabilities.HasOverloadDelay)
            {
                Console.WriteLine("Min Overload delay = {0}", currentDetector.OverloadControl.Capabilities.MinimumOverloadDelay);
                Console.WriteLine("Max Overload delay = {0}", currentDetector.OverloadControl.Capabilities.MaximumOverloadDelay);
            }

            if (currentDetector.OverloadControl.Capabilities.HasOverloadThreshold)
            {
                Console.WriteLine("Min Overload Threshold = {0}", currentDetector.OverloadControl.Capabilities.MinimumOverloadThreshold);
                Console.WriteLine("Max Overload Threshold = {0}", currentDetector.OverloadControl.Capabilities.MaximumOverloadThreshold);
            }
        }
        #endregion

        #region Overload Status
        /// <summary>
        /// Prints the detectors status to the console output.
        /// </summary>
        public void PrintOverloadStatus(IEdDetectorControl currentDetector)
        {
            switch (currentDetector.OverloadControl.Status.LowMagInterlock)
            {
                case LowMagInterlock.Enabled:
                    Console.WriteLine("LowMagInterlock is enabled");
                    break;
                case LowMagInterlock.Disabled:
                    Console.WriteLine("LowMagInterlock is disabled");
                    break;
                case LowMagInterlock.Unknown:
                default:
                    Console.WriteLine("LowMagInterlock state can't be determined");
                    break;
            }

            Console.Write("Detector Overload is ");
            if (currentDetector.OverloadControl.Status.OverloadDetectionEnabled)
            {
                Console.WriteLine("Enabled");
            }
            else
            {
                Console.WriteLine("Disabled");
            }

            Console.WriteLine(
                "The Detectors current overload delay is {0}",
                currentDetector.OverloadControl.Status.OverloadDelay);

            Console.WriteLine(
                "The Detectors current overload threshold is {0}",
                currentDetector.OverloadControl.Status.OverloadThreshold);
        }
        #endregion

        #region Overload Delay
        /// <summary>
        /// Trys to set the detectors overload delay.
        /// </summary>
        public bool SetOverloadDelay(IEdDetectorControl currentDetector, float val)
        {
            bool isSet = false;

            if (currentDetector != null && currentDetector.OverloadControl.CanSetOverloadDelay(val))
            {
                try
                {
                    currentDetector.OverloadControl.SetOverloadDelay(val);
                    isSet = true;
                }
                catch (DetectorControlException ex)
                {
                    Console.WriteLine(ex.Message);
                }
            }

            return isSet;
        }
        #endregion

        #region Overload Threshold

        /// <summary>
        /// Trys to set the detectors overload threshold.
        /// </summary>
        public bool SetOverloadThreshold(IEdDetectorControl currentDetector, float val)
        {
            bool isSet = false;

            if (currentDetector != null && currentDetector.OverloadControl.CanSetOverloadDelay(val))
            {
                try
                {
                    currentDetector.OverloadControl.SetOverloadThreshold(val);
                    isSet = true;
                }
                catch (DetectorControlException ex)
                {
                    Console.WriteLine(ex.Message);
                }
            }

            return isSet;
        }
        #endregion

        #region Overload Toggle detection

        /// <summary>
        /// Trys to toggle the overload detection for the detector.
        /// </summary>
        public bool ToggleOverloadDetection(IEdDetectorControl currentDetector)
        {
            bool canToggle = false;

            if (currentDetector != null && currentDetector.OverloadControl.CanToggleOverloadDetection())
            {
                try
                {
                    bool toggleValue = !currentDetector.OverloadControl.Status.OverloadDetectionEnabled;
                    currentDetector.OverloadControl.ToggleOverloadDetection(toggleValue);
                    canToggle = true;
                }
                catch (DetectorControlException ex)
                {
                    Console.WriteLine(ex.Message);
                }
            }

            return canToggle;
        }
        #endregion
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace


IOverloadControl Properties

The IOverloadControl type exposes the following members.

Properties
 | Name | Description
 | Capabilities | Gets the overload capabilities of the detector. IOverloadCapabilities
Public property | HardwareId | Gets a value identifying the detector being controlled. (Inherited from IControlBase.)
Public property | IsConnected | Gets a value indicating whether or not the detector is connected. (Inherited from IControlBase.)
 | Status | Gets the overload status of the detector. IOverloadStatus
Top
See Also

Reference

IOverloadControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadControl.Capabilities Property

Gets the overload capabilities of the detector. IOverloadCapabilities

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IOverloadCapabilities Capabilities { get; }
ReadOnly Property Capabilities As IOverloadCapabilities
    Get
property IOverloadCapabilities^ Capabilities {
    IOverloadCapabilities^ get ();
}
abstract Capabilities : IOverloadCapabilities with get

Property Value

Type: IOverloadCapabilities
The overload capabilities.
Examples
Copy
/// <summary>
/// Prints the detectors overload capabilities to console output.
/// </summary>
public void PrintOverloadCapabilities(IEdDetectorControl currentDetector)
{
    if (currentDetector.OverloadControl.Capabilities.HasOverloadDetection)
    {
        Console.WriteLine("Detector Overload control has overload detection.");
    }
    else
    {
        Console.WriteLine("Detector Overload control does not have overload detection!");
    }

    if (currentDetector.OverloadControl.Capabilities.HasLowMagInterlock)
    {
        Console.WriteLine("Detector Overload control has low mag interlock.");
    }

    if (currentDetector.OverloadControl.Capabilities.HasOverloadDelay)
    {
        Console.WriteLine("Min Overload delay = {0}", currentDetector.OverloadControl.Capabilities.MinimumOverloadDelay);
        Console.WriteLine("Max Overload delay = {0}", currentDetector.OverloadControl.Capabilities.MaximumOverloadDelay);
    }

    if (currentDetector.OverloadControl.Capabilities.HasOverloadThreshold)
    {
        Console.WriteLine("Min Overload Threshold = {0}", currentDetector.OverloadControl.Capabilities.MinimumOverloadThreshold);
        Console.WriteLine("Max Overload Threshold = {0}", currentDetector.OverloadControl.Capabilities.MaximumOverloadThreshold);
    }
}
See Also

Reference

IOverloadControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadControl.Status Property

Gets the overload status of the detector. IOverloadStatus

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IOverloadStatus Status { get; }
ReadOnly Property Status As IOverloadStatus
    Get
property IOverloadStatus^ Status {
    IOverloadStatus^ get ();
}
abstract Status : IOverloadStatus with get

Property Value

Type: IOverloadStatus
The status.
Examples
Copy
/// <summary>
/// Prints the detectors status to the console output.
/// </summary>
public void PrintOverloadStatus(IEdDetectorControl currentDetector)
{
    switch (currentDetector.OverloadControl.Status.LowMagInterlock)
    {
        case LowMagInterlock.Enabled:
            Console.WriteLine("LowMagInterlock is enabled");
            break;
        case LowMagInterlock.Disabled:
            Console.WriteLine("LowMagInterlock is disabled");
            break;
        case LowMagInterlock.Unknown:
        default:
            Console.WriteLine("LowMagInterlock state can't be determined");
            break;
    }

    Console.Write("Detector Overload is ");
    if (currentDetector.OverloadControl.Status.OverloadDetectionEnabled)
    {
        Console.WriteLine("Enabled");
    }
    else
    {
        Console.WriteLine("Disabled");
    }

    Console.WriteLine(
        "The Detectors current overload delay is {0}",
        currentDetector.OverloadControl.Status.OverloadDelay);

    Console.WriteLine(
        "The Detectors current overload threshold is {0}",
        currentDetector.OverloadControl.Status.OverloadThreshold);
}
See Also

Reference

IOverloadControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadControl Methods

The IOverloadControl type exposes the following members.

Methods
 | Name | Description
 | CanSetOverloadDelay | Determines if the specified overload detection delay can be set.
 | CanSetOverloadThreshold | Determines whether the specified overload detection threshold can be set.
 | CanToggleOverloadDetection | Determines whether overload detection can be toggled between enabled and disabled.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | SetOverloadDelay | Sets the overload detection delay.
 | SetOverloadThreshold | Sets the overload detection threshold.
 | ToggleOverloadDetection | Toggle overload detection between enabled and disabled.
Top
See Also

Reference

IOverloadControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadControl.CanSetOverloadDelay Method

Determines if the specified overload detection delay can be set.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanSetOverloadDelay(
    float delay
)
Function CanSetOverloadDelay (
    delay As Single
) As Boolean
bool CanSetOverloadDelay(
    float delay
)
abstract CanSetOverloadDelay :
        delay : float32 -> bool

Parameters

delay
Type: SystemSingle
delay in seconds

Return Value

Type: Boolean
true if the specified delay can be set; otherwise, false.
Examples
Copy
/// <summary>
/// Trys to set the detectors overload delay.
/// </summary>
public bool SetOverloadDelay(IEdDetectorControl currentDetector, float val)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.OverloadControl.CanSetOverloadDelay(val))
    {
        try
        {
            currentDetector.OverloadControl.SetOverloadDelay(val);
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IOverloadControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadControl.CanSetOverloadThreshold Method

Determines whether the specified overload detection threshold can be set.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanSetOverloadThreshold(
    float threshold
)
Function CanSetOverloadThreshold (
    threshold As Single
) As Boolean
bool CanSetOverloadThreshold(
    float threshold
)
abstract CanSetOverloadThreshold :
        threshold : float32 -> bool

Parameters

threshold
Type: SystemSingle
The threshold in Mev/s.

Return Value

Type: Boolean
true if the specified threshold can be set; otherwise, false.
Examples
Copy
/// <summary>
/// Trys to set the detectors overload threshold.
/// </summary>
public bool SetOverloadThreshold(IEdDetectorControl currentDetector, float val)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.OverloadControl.CanSetOverloadDelay(val))
    {
        try
        {
            currentDetector.OverloadControl.SetOverloadThreshold(val);
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IOverloadControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadControl.CanToggleOverloadDetection Method

Determines whether overload detection can be toggled between enabled and disabled.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanToggleOverloadDetection()
Function CanToggleOverloadDetection As Boolean
bool CanToggleOverloadDetection()
abstract CanToggleOverloadDetection : unit -> bool

Return Value

Type: Boolean
true if overload detection can be toggled; otherwise, false.
Examples
Copy
/// <summary>
/// Trys to toggle the overload detection for the detector.
/// </summary>
public bool ToggleOverloadDetection(IEdDetectorControl currentDetector)
{
    bool canToggle = false;

    if (currentDetector != null && currentDetector.OverloadControl.CanToggleOverloadDetection())
    {
        try
        {
            bool toggleValue = !currentDetector.OverloadControl.Status.OverloadDetectionEnabled;
            currentDetector.OverloadControl.ToggleOverloadDetection(toggleValue);
            canToggle = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return canToggle;
}
See Also

Reference

IOverloadControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadControl.SetOverloadDelay Method

Sets the overload detection delay.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetOverloadDelay(
    float delay
)
Sub SetOverloadDelay (
    delay As Single
)
void SetOverloadDelay(
    float delay
)
abstract SetOverloadDelay :
        delay : float32 -> unit

Parameters

delay
Type: SystemSingle
The overload Delay
Exceptions
Exception | Condition
DetectorControlException | Throws a DetectorControlException exception when fails.
Examples
Copy
/// <summary>
/// Trys to set the detectors overload delay.
/// </summary>
public bool SetOverloadDelay(IEdDetectorControl currentDetector, float val)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.OverloadControl.CanSetOverloadDelay(val))
    {
        try
        {
            currentDetector.OverloadControl.SetOverloadDelay(val);
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IOverloadControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadControl.SetOverloadThreshold Method

Sets the overload detection threshold.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetOverloadThreshold(
    float threshold
)
Sub SetOverloadThreshold (
    threshold As Single
)
void SetOverloadThreshold(
    float threshold
)
abstract SetOverloadThreshold :
        threshold : float32 -> unit

Parameters

threshold
Type: SystemSingle
The threshold in Mev/s.
Exceptions
Exception | Condition
DetectorControlException | Throws a DetectorControlException exception when fails.
Examples
Copy
/// <summary>
/// Trys to set the detectors overload threshold.
/// </summary>
public bool SetOverloadThreshold(IEdDetectorControl currentDetector, float val)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.OverloadControl.CanSetOverloadDelay(val))
    {
        try
        {
            currentDetector.OverloadControl.SetOverloadThreshold(val);
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IOverloadControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadControl.ToggleOverloadDetection Method

Toggle overload detection between enabled and disabled.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void ToggleOverloadDetection(
    bool enabled
)
Sub ToggleOverloadDetection (
    enabled As Boolean
)
void ToggleOverloadDetection(
    bool enabled
)
abstract ToggleOverloadDetection :
        enabled : bool -> unit

Parameters

enabled
Type: SystemBoolean
true Enable Overload Protection; false Disable Overload protection.
Exceptions
Exception | Condition
DetectorControlException | Throws a DetectorControlException exception when fails.
Examples
Copy
/// <summary>
/// Trys to toggle the overload detection for the detector.
/// </summary>
public bool ToggleOverloadDetection(IEdDetectorControl currentDetector)
{
    bool canToggle = false;

    if (currentDetector != null && currentDetector.OverloadControl.CanToggleOverloadDetection())
    {
        try
        {
            bool toggleValue = !currentDetector.OverloadControl.Status.OverloadDetectionEnabled;
            currentDetector.OverloadControl.ToggleOverloadDetection(toggleValue);
            canToggle = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return canToggle;
}
See Also

Reference

IOverloadControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadControl Events

The IOverloadControl type exposes the following members.

Events
 | Name | Description
Public event | DetectorConnected | Occurs when a connection to the detector is made or lost. Use this event to get capabilities and status. (Inherited from IControlBase.)
Public event | StatusChanged | Occurs when the detector status changes. (Inherited from IControlBase.)
Top
See Also

Reference

IOverloadControl Interface
OINA.Extender.DetectorControl Namespace


IOverloadStatus Interface

An Interface that defines the overload status of a detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IOverloadStatus
Public Interface IOverloadStatus
public interface class IOverloadStatus
type IOverloadStatus =  interface end

The IOverloadStatus type exposes the following members.

Properties
 | Name | Description
Public property | LowMagInterlock | Gets a value indicating the status of Low Mag Interlock.
Public property | OverloadDelay | Gets the overload delay in seconds.
Public property | OverloadDetectionEnabled | Gets a value indicating whether or not overload protection is enabled.
Public property | OverloadThreshold | Gets the overload threshold in MeV/s.
Top
Examples
Copy
/// <summary>
/// Prints the detectors status to the console output.
/// </summary>
public void PrintOverloadStatus(IEdDetectorControl currentDetector)
{
    switch (currentDetector.OverloadControl.Status.LowMagInterlock)
    {
        case LowMagInterlock.Enabled:
            Console.WriteLine("LowMagInterlock is enabled");
            break;
        case LowMagInterlock.Disabled:
            Console.WriteLine("LowMagInterlock is disabled");
            break;
        case LowMagInterlock.Unknown:
        default:
            Console.WriteLine("LowMagInterlock state can't be determined");
            break;
    }

    Console.Write("Detector Overload is ");
    if (currentDetector.OverloadControl.Status.OverloadDetectionEnabled)
    {
        Console.WriteLine("Enabled");
    }
    else
    {
        Console.WriteLine("Disabled");
    }

    Console.WriteLine(
        "The Detectors current overload delay is {0}",
        currentDetector.OverloadControl.Status.OverloadDelay);

    Console.WriteLine(
        "The Detectors current overload threshold is {0}",
        currentDetector.OverloadControl.Status.OverloadThreshold);
}
See Also

Reference

OINA.Extender.DetectorControl Namespace


IOverloadStatus Properties

The IOverloadStatus type exposes the following members.

Properties
 | Name | Description
Public property | LowMagInterlock | Gets a value indicating the status of Low Mag Interlock.
Public property | OverloadDelay | Gets the overload delay in seconds.
Public property | OverloadDetectionEnabled | Gets a value indicating whether or not overload protection is enabled.
Public property | OverloadThreshold | Gets the overload threshold in MeV/s.
Top
See Also

Reference

IOverloadStatus Interface
OINA.Extender.DetectorControl Namespace


IOverloadStatus.LowMagInterlock Property

Gets a value indicating the status of Low Mag Interlock.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
LowMagInterlock LowMagInterlock { get; }
ReadOnly Property LowMagInterlock As LowMagInterlock
    Get
property LowMagInterlock LowMagInterlock {
    LowMagInterlock get ();
}
abstract LowMagInterlock : LowMagInterlock with get

Property Value

Type: LowMagInterlock
See Also

Reference

IOverloadStatus Interface
OINA.Extender.DetectorControl Namespace


IOverloadStatus.OverloadDelay Property

Gets the overload delay in seconds.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
float OverloadDelay { get; }
ReadOnly Property OverloadDelay As Single
    Get
property float OverloadDelay {
    float get ();
}
abstract OverloadDelay : float32 with get

Property Value

Type: Single
The auto retract delay.
See Also

Reference

IOverloadStatus Interface
OINA.Extender.DetectorControl Namespace


IOverloadStatus.OverloadDetectionEnabled Property

Gets a value indicating whether or not overload protection is enabled.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool OverloadDetectionEnabled { get; }
ReadOnly Property OverloadDetectionEnabled As Boolean
    Get
property bool OverloadDetectionEnabled {
    bool get ();
}
abstract OverloadDetectionEnabled : bool with get

Property Value

Type: Boolean
true if overload protection is enabled; otherwise, false.
See Also

Reference

IOverloadStatus Interface
OINA.Extender.DetectorControl Namespace


IOverloadStatus.OverloadThreshold Property

Gets the overload threshold in MeV/s.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
float OverloadThreshold { get; }
ReadOnly Property OverloadThreshold As Single
    Get
property float OverloadThreshold {
    float get ();
}
abstract OverloadThreshold : float32 with get

Property Value

Type: Single
The auto retract threshold.
See Also

Reference

IOverloadStatus Interface
OINA.Extender.DetectorControl Namespace


IShutterCapabilities Interface

An Interface that defines the shutter capabilities of a detector. Capabilities

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IShutterCapabilities
Public Interface IShutterCapabilities
public interface class IShutterCapabilities
type IShutterCapabilities =  interface end

The IShutterCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | HasPneumaticControl | Gets a value indicating whether the shutter has pneumatic control.
Top
Examples
Copy
/// <summary>
/// Prints the detectors shutter control capabilities to console output.
/// </summary>
public void PrintShutterCapabilities(IEdDetectorControl currentDetector)
{
    if (currentDetector.ShutterControl.Capabilities.HasPneumaticControl)
    {
        Console.WriteLine("Detector Shutter control has pneumatic control.");
    }
    else
    {
        Console.WriteLine("Detector Shutter control does not have pneumatic control!");
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace
IEdDetectorControlShutterControl


IShutterCapabilities Properties

The IShutterCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | HasPneumaticControl | Gets a value indicating whether the shutter has pneumatic control.
Top
See Also

Reference

IShutterCapabilities Interface
OINA.Extender.DetectorControl Namespace


IShutterCapabilities.HasPneumaticControl Property

Gets a value indicating whether the shutter has pneumatic control.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasPneumaticControl { get; }
ReadOnly Property HasPneumaticControl As Boolean
    Get
property bool HasPneumaticControl {
    bool get ();
}
abstract HasPneumaticControl : bool with get

Property Value

Type: Boolean
true if the shutter has pneumatic control; otherwise, false.
See Also

Reference

IShutterCapabilities Interface
OINA.Extender.DetectorControl Namespace


IShutterControl Interface

An Interface that defines shutter control for a detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IShutterControl : IDisposable,
    IControlBase
Public Interface IShutterControl
    Inherits IDisposable, IControlBase
public interface class IShutterControl : IDisposable,
    IControlBase
type IShutterControl =
    interface
        interface IDisposable
        interface IControlBase
    end

The IShutterControl type exposes the following members.

Properties
 | Name | Description
 | Capabilities | Gets the capabilities of the shutter. IShutterCapabilities
Public property | HardwareId | Gets a value identifying the detector being controlled. (Inherited from IControlBase.)
Public property | IsConnected | Gets a value indicating whether or not the detector is connected. (Inherited from IControlBase.)
 | Status | Gets the status of the shutter. IShutterStatus
Top
Methods
 | Name | Description
 | CanCloseShutter | Determines whether or not the shutter can be closed.
 | CanOpenShutter | Determines whether or not the shutter can be opened.
 | CloseShutter | Closes the shutter.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | OpenShutter | Opens the shutter.
Top
Events
 | Name | Description
Public event | DetectorConnected | Occurs when a connection to the detector is made or lost. Use this event to get capabilities and status. (Inherited from IControlBase.)
Public event | StatusChanged | Occurs when the detector status changes. (Inherited from IControlBase.)
Top
Examples
Copy
namespace Extender.CodeExamples.DetectorExamples
{
    using System;
    using System.Threading;
    using OINA.Extender;
    using OINA.Extender.DetectorControl;

    public class ShutterControlExample
    {
        public static void Main(string[] args)
        {
            ShutterControlExample shuttercontrol = new ShutterControlExample();

            IEdDetectorControl currentDetector = AcquireFactory.CreateEdDetectorControl()[0];

            // Output the detectors shutter control capabilities to the console window.
            shuttercontrol.PrintShutterCapabilities(currentDetector);

            // Output the detectors shutter status to the console window.
            shuttercontrol.PrintShutterStatus(currentDetector);

            // Try to Toggle the shutter state every 5 seconds until a key is pressed...
            while (Console.KeyAvailable == false)
            {
                switch (currentDetector.ShutterControl.Status.State)
                {
                    case DetectorShutterState.Open:
                        if (!shuttercontrol.CloseShutter(currentDetector))
                        {
                            Console.WriteLine("Failed to close the shutter!}");
                        }

                        break;
                    case DetectorShutterState.Closed:
                        if (!shuttercontrol.OpenShutter(currentDetector))
                        {
                            Console.WriteLine("Failed to open the shutter!}");
                        }

                        break;
                    case DetectorShutterState.ClosedDueToOverload:
                    case DetectorShutterState.Fault:
                    case DetectorShutterState.Unknown:
                    default:
                        break;
                }

                // Output the detectors shutter status to the console window.
                shuttercontrol.PrintShutterStatus(currentDetector);

                Thread.Sleep(5000);
            }
        }

        #region Shutter Capabilities
        /// <summary>
        /// Prints the detectors shutter control capabilities to console output.
        /// </summary>
        public void PrintShutterCapabilities(IEdDetectorControl currentDetector)
        {
            if (currentDetector.ShutterControl.Capabilities.HasPneumaticControl)
            {
                Console.WriteLine("Detector Shutter control has pneumatic control.");
            }
            else
            {
                Console.WriteLine("Detector Shutter control does not have pneumatic control!");
            }
        }
        #endregion

        #region Shutter Status
        /// <summary>
        /// Prints the shutter control status to the console output.
        /// </summary>
        public void PrintShutterStatus(IEdDetectorControl currentDetector)
        {
            switch (currentDetector.ShutterControl.Status.State)
            {
                case DetectorShutterState.Open:
                    Console.WriteLine("The Shutter is Open");
                    break;
                case DetectorShutterState.Closed:
                    Console.WriteLine("The Shutter is Closed");
                    break;
                case DetectorShutterState.ClosedDueToOverload:
                    Console.WriteLine("The Shutter is Closed due to an overload");
                    break;
                case DetectorShutterState.Fault:
                    Console.WriteLine("The shutter has a fault");
                    break;
                case DetectorShutterState.Unknown:
                default:
                    Console.WriteLine("Shutter state can't be determined");
                    break;
            }

            Console.Write("Shutter is ");
            if (currentDetector.ShutterControl.Status.Enabled)
            {
                Console.WriteLine("Enabled");
            }
            else
            {
                Console.WriteLine("Disabled");
            }
        }
        #endregion

        #region Open Shutter

        /// <summary>
        /// Trys to open the shutter.
        /// </summary>
        public bool OpenShutter(IEdDetectorControl currentDetector)
        {
            bool isSet = false;

            if (currentDetector != null && currentDetector.ShutterControl.CanOpenShutter())
            {
                try
                {
                    currentDetector.ShutterControl.OpenShutter();
                    isSet = true;
                }
                catch (DetectorControlException ex)
                {
                    Console.WriteLine(ex.Message);
                }
            }

            return isSet;
        }
        #endregion

        #region Close Shutter

        /// <summary>
        /// Trys to close the shutter.
        /// </summary>
        public bool CloseShutter(IEdDetectorControl currentDetector)
        {
            bool isSet = false;

            if (currentDetector != null && currentDetector.ShutterControl.CanCloseShutter())
            {
                try
                {
                    currentDetector.ShutterControl.CloseShutter();
                    isSet = true;
                }
                catch (DetectorControlException ex)
                {
                    Console.WriteLine(ex.Message);
                }
            }

            return isSet;
        }
        #endregion
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace


IShutterControl Properties

The IShutterControl type exposes the following members.

Properties
 | Name | Description
 | Capabilities | Gets the capabilities of the shutter. IShutterCapabilities
Public property | HardwareId | Gets a value identifying the detector being controlled. (Inherited from IControlBase.)
Public property | IsConnected | Gets a value indicating whether or not the detector is connected. (Inherited from IControlBase.)
 | Status | Gets the status of the shutter. IShutterStatus
Top
See Also

Reference

IShutterControl Interface
OINA.Extender.DetectorControl Namespace


IShutterControl.Capabilities Property

Gets the capabilities of the shutter. IShutterCapabilities

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IShutterCapabilities Capabilities { get; }
ReadOnly Property Capabilities As IShutterCapabilities
    Get
property IShutterCapabilities^ Capabilities {
    IShutterCapabilities^ get ();
}
abstract Capabilities : IShutterCapabilities with get

Property Value

Type: IShutterCapabilities
The capabilities.
Examples
Copy
/// <summary>
/// Prints the detectors shutter control capabilities to console output.
/// </summary>
public void PrintShutterCapabilities(IEdDetectorControl currentDetector)
{
    if (currentDetector.ShutterControl.Capabilities.HasPneumaticControl)
    {
        Console.WriteLine("Detector Shutter control has pneumatic control.");
    }
    else
    {
        Console.WriteLine("Detector Shutter control does not have pneumatic control!");
    }
}
See Also

Reference

IShutterControl Interface
OINA.Extender.DetectorControl Namespace


IShutterControl.Status Property

Gets the status of the shutter. IShutterStatus

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IShutterStatus Status { get; }
ReadOnly Property Status As IShutterStatus
    Get
property IShutterStatus^ Status {
    IShutterStatus^ get ();
}
abstract Status : IShutterStatus with get

Property Value

Type: IShutterStatus
The status.
Examples
Copy
/// <summary>
/// Prints the shutter control status to the console output.
/// </summary>
public void PrintShutterStatus(IEdDetectorControl currentDetector)
{
    switch (currentDetector.ShutterControl.Status.State)
    {
        case DetectorShutterState.Open:
            Console.WriteLine("The Shutter is Open");
            break;
        case DetectorShutterState.Closed:
            Console.WriteLine("The Shutter is Closed");
            break;
        case DetectorShutterState.ClosedDueToOverload:
            Console.WriteLine("The Shutter is Closed due to an overload");
            break;
        case DetectorShutterState.Fault:
            Console.WriteLine("The shutter has a fault");
            break;
        case DetectorShutterState.Unknown:
        default:
            Console.WriteLine("Shutter state can't be determined");
            break;
    }

    Console.Write("Shutter is ");
    if (currentDetector.ShutterControl.Status.Enabled)
    {
        Console.WriteLine("Enabled");
    }
    else
    {
        Console.WriteLine("Disabled");
    }
}
See Also

Reference

IShutterControl Interface
OINA.Extender.DetectorControl Namespace


IShutterControl Methods

The IShutterControl type exposes the following members.

Methods
 | Name | Description
 | CanCloseShutter | Determines whether or not the shutter can be closed.
 | CanOpenShutter | Determines whether or not the shutter can be opened.
 | CloseShutter | Closes the shutter.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | OpenShutter | Opens the shutter.
Top
See Also

Reference

IShutterControl Interface
OINA.Extender.DetectorControl Namespace


IShutterControl.CanCloseShutter Method

Determines whether or not the shutter can be closed.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanCloseShutter()
Function CanCloseShutter As Boolean
bool CanCloseShutter()
abstract CanCloseShutter : unit -> bool

Return Value

Type: Boolean
true if the shutter can be closed; otherwise, false.
Examples
Copy
/// <summary>
/// Trys to close the shutter.
/// </summary>
public bool CloseShutter(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.ShutterControl.CanCloseShutter())
    {
        try
        {
            currentDetector.ShutterControl.CloseShutter();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IShutterControl Interface
OINA.Extender.DetectorControl Namespace


IShutterControl.CanOpenShutter Method

Determines whether or not the shutter can be opened.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanOpenShutter()
Function CanOpenShutter As Boolean
bool CanOpenShutter()
abstract CanOpenShutter : unit -> bool

Return Value

Type: Boolean
true if the shutter can be opened; otherwise, false.
Examples
Copy
/// <summary>
/// Trys to open the shutter.
/// </summary>
public bool OpenShutter(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.ShutterControl.CanOpenShutter())
    {
        try
        {
            currentDetector.ShutterControl.OpenShutter();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IShutterControl Interface
OINA.Extender.DetectorControl Namespace


IShutterControl.CloseShutter Method

Closes the shutter.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void CloseShutter()
Sub CloseShutter
void CloseShutter()
abstract CloseShutter : unit -> unit
Exceptions
Exception | Condition
DetectorControlException | Throws a DetectorControlException exception when fails.
Examples
Copy
/// <summary>
/// Trys to close the shutter.
/// </summary>
public bool CloseShutter(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.ShutterControl.CanCloseShutter())
    {
        try
        {
            currentDetector.ShutterControl.CloseShutter();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IShutterControl Interface
OINA.Extender.DetectorControl Namespace


IShutterControl.OpenShutter Method

Opens the shutter.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void OpenShutter()
Sub OpenShutter
void OpenShutter()
abstract OpenShutter : unit -> unit
Exceptions
Exception | Condition
DetectorControlException | Throws a DetectorControlException exception when fails.
Examples
Copy
/// <summary>
/// Trys to open the shutter.
/// </summary>
public bool OpenShutter(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.ShutterControl.CanOpenShutter())
    {
        try
        {
            currentDetector.ShutterControl.OpenShutter();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IShutterControl Interface
OINA.Extender.DetectorControl Namespace


IShutterControl Events

The IShutterControl type exposes the following members.

Events
 | Name | Description
Public event | DetectorConnected | Occurs when a connection to the detector is made or lost. Use this event to get capabilities and status. (Inherited from IControlBase.)
Public event | StatusChanged | Occurs when the detector status changes. (Inherited from IControlBase.)
Top
See Also

Reference

IShutterControl Interface
OINA.Extender.DetectorControl Namespace


IShutterStatus Interface

An Interface that defines the shutter status of an Ed detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IShutterStatus
Public Interface IShutterStatus
public interface class IShutterStatus
type IShutterStatus =  interface end

The IShutterStatus type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets a value indicating whether or not the shutter has been enabled.
Public property | State | Gets the state of the shutter.
Top
Examples
Copy
/// <summary>
/// Prints the shutter control status to the console output.
/// </summary>
public void PrintShutterStatus(IEdDetectorControl currentDetector)
{
    switch (currentDetector.ShutterControl.Status.State)
    {
        case DetectorShutterState.Open:
            Console.WriteLine("The Shutter is Open");
            break;
        case DetectorShutterState.Closed:
            Console.WriteLine("The Shutter is Closed");
            break;
        case DetectorShutterState.ClosedDueToOverload:
            Console.WriteLine("The Shutter is Closed due to an overload");
            break;
        case DetectorShutterState.Fault:
            Console.WriteLine("The shutter has a fault");
            break;
        case DetectorShutterState.Unknown:
        default:
            Console.WriteLine("Shutter state can't be determined");
            break;
    }

    Console.Write("Shutter is ");
    if (currentDetector.ShutterControl.Status.Enabled)
    {
        Console.WriteLine("Enabled");
    }
    else
    {
        Console.WriteLine("Disabled");
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace


IShutterStatus Properties

The IShutterStatus type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets a value indicating whether or not the shutter has been enabled.
Public property | State | Gets the state of the shutter.
Top
See Also

Reference

IShutterStatus Interface
OINA.Extender.DetectorControl Namespace


IShutterStatus.Enabled Property

Gets a value indicating whether or not the shutter has been enabled.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get

Property Value

Type: Boolean
true if enabled; otherwise, false.
See Also

Reference

IShutterStatus Interface
OINA.Extender.DetectorControl Namespace


IShutterStatus.State Property

Gets the state of the shutter.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DetectorShutterState State { get; }
ReadOnly Property State As DetectorShutterState
    Get
property DetectorShutterState State {
    DetectorShutterState get ();
}
abstract State : DetectorShutterState with get

Property Value

Type: DetectorShutterState
See Also

Reference

IShutterStatus Interface
OINA.Extender.DetectorControl Namespace


ISlideCapabilities Interface

An Interface that defines the slide capabilities of a detector. Capabilities

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface ISlideCapabilities
Public Interface ISlideCapabilities
public interface class ISlideCapabilities
type ISlideCapabilities =  interface end

The ISlideCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | HasMotorControl | Gets a value indicating whether the slide has motor control.
Top
Examples
Copy
/// <summary>
/// Prints the detectors Slide control capabilities to console output.
/// </summary>
public void PrintSlideCapabilities(IEdDetectorControl currentDetector)
{
    if (currentDetector.SlideControl.Capabilities.HasMotorControl)
    {
        Console.WriteLine("Detector Slide has motor control.");
    }
    else
    {
        Console.WriteLine("Detector Slide  does not have motor control!");
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace
IEdDetectorControlSlideControl


ISlideCapabilities Properties

The ISlideCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | HasMotorControl | Gets a value indicating whether the slide has motor control.
Top
See Also

Reference

ISlideCapabilities Interface
OINA.Extender.DetectorControl Namespace


ISlideCapabilities.HasMotorControl Property

Gets a value indicating whether the slide has motor control.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasMotorControl { get; }
ReadOnly Property HasMotorControl As Boolean
    Get
property bool HasMotorControl {
    bool get ();
}
abstract HasMotorControl : bool with get

Property Value

Type: Boolean
true if the slide has motor control; otherwise, false.
See Also

Reference

ISlideCapabilities Interface
OINA.Extender.DetectorControl Namespace


ISlideControl Interface

An Interface that defines slide control of an Ed detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface ISlideControl : IDisposable,
    IControlBase
Public Interface ISlideControl
    Inherits IDisposable, IControlBase
public interface class ISlideControl : IDisposable,
    IControlBase
type ISlideControl =
    interface
        interface IDisposable
        interface IControlBase
    end

The ISlideControl type exposes the following members.

Properties
 | Name | Description
 | Capabilities | Gets the capabilities of the slide. ISlideCapabilities
Public property | HardwareId | Gets a value identifying the detector being controlled. (Inherited from IControlBase.)
Public property | IsConnected | Gets a value indicating whether or not the detector is connected. (Inherited from IControlBase.)
 | Status | Gets the status of the slide. ISlideStatus
Top
Methods
 | Name | Description
 | CanDriveIn | Determines whether or not the slide can drive in.
 | CanDriveOut | Determines whether or not the slide can drive out.
 | CanStop | Determines whether or not the slide can be stopped.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | DriveIn | Drives the slide in.
 | DriveOut | Drives the slide out.
 | Stop | Stops the slide at the current position.
Top
Events
 | Name | Description
Public event | DetectorConnected | Occurs when a connection to the detector is made or lost. Use this event to get capabilities and status. (Inherited from IControlBase.)
Public event | StatusChanged | Occurs when the detector status changes. (Inherited from IControlBase.)
Top
Examples
Copy
namespace Extender.CodeExamples.DetectorExamples
{
    using System;
    using System.Threading;
    using OINA.Extender;
    using OINA.Extender.DetectorControl;

    public class SlideControlExample
    {
        public static void Main(string[] args)
        {
            SlideControlExample slidecontrol = new SlideControlExample();

            IEdDetectorControl currentDetector = AcquireFactory.CreateEdDetectorControl()[0];

            // Output the detectors Slide control capabilities to the console window.
            slidecontrol.PrintSlideCapabilities(currentDetector);

            // Output the detectors Slide status to the console window.
            slidecontrol.PrintSlideStatus(currentDetector);

            ConsoleKeyInfo keyInfo;

            do
            {
                slidecontrol.PrintInfo();

                // Try to Toggle the Slide state every 5 seconds until a key is pressed...
                while (Console.KeyAvailable == false)
                {
                    // Output the detectors Slide status to the console window.
                    slidecontrol.PrintSlideStatus(currentDetector);
                    Thread.Sleep(1000);
                }

                // Read and process the user command
                keyInfo = Console.ReadKey(true);

                switch (keyInfo.Key)
                {
                    case ConsoleKey.I:
                        if (!slidecontrol.DriveSlideIn(currentDetector))
                        {
                            Console.WriteLine("Can't command the slide to drive in!");
                        }

                        break;
                    case ConsoleKey.O:
                        if (!slidecontrol.DriveSlideOut(currentDetector))
                        {
                            Console.WriteLine("Can't command the slide to drive out!");
                        }

                        break;
                    case ConsoleKey.S:
                        if (!slidecontrol.StopSlide(currentDetector))
                        {
                            Console.WriteLine("Can't command the slide to stop!");
                        }

                        break;
                    default:
                        break;
                }
            }
            while (keyInfo.Key != ConsoleKey.Escape);
        }

        public void PrintInfo()
        {
            Console.WriteLine("Press I to drive the slide in..");
            Console.WriteLine("Press O to drive the slide Out..");
            Console.WriteLine("Press S to stop the slide..");
            Console.WriteLine("Press Esc to Exit.");
        }

        #region Slide Capabilities
        /// <summary>
        /// Prints the detectors Slide control capabilities to console output.
        /// </summary>
        public void PrintSlideCapabilities(IEdDetectorControl currentDetector)
        {
            if (currentDetector.SlideControl.Capabilities.HasMotorControl)
            {
                Console.WriteLine("Detector Slide has motor control.");
            }
            else
            {
                Console.WriteLine("Detector Slide  does not have motor control!");
            }
        }
        #endregion

        #region Slide Status
        /// <summary>
        /// Prints the Slide control status to the console output.
        /// </summary>
        public void PrintSlideStatus(IEdDetectorControl currentDetector)
        {
            switch (currentDetector.SlideControl.Status.PositionState)
            {
                case DetectorSlidePositionState.In:
                    Console.WriteLine("The Slide position is In");
                    break;
                case DetectorSlidePositionState.Out:
                    Console.WriteLine("The Slide position is Out");
                    break;
                case DetectorSlidePositionState.Intermediate:
                    Console.WriteLine("The Slide position is intermediate");
                    break;
                case DetectorSlidePositionState.Fault:
                    Console.WriteLine("The Slide position has a fault");
                    break;
                case DetectorSlidePositionState.AutoRetracted:
                    Console.WriteLine("The Slide position has been automatically retracted");
                    break;
                case DetectorSlidePositionState.ReferencePosition:
                    Console.WriteLine("The Slide position has a fault");
                    break;
                case DetectorSlidePositionState.Indeterminate:
                    Console.WriteLine("Indeterminate : Slide position can't be determined");
                    break;
                case DetectorSlidePositionState.Unknown:
                    Console.WriteLine("Unknown : Slide position can't be determined");
                    break;
                default:
                    Console.WriteLine("Slide position can't be determined");
                    break;
            }

            switch (currentDetector.SlideControl.Status.Activity)
            {
                case DetectorSlideActivity.AutoRetracting:
                    Console.WriteLine("Slide is currently AutoRetracting");
                    break;
                case DetectorSlideActivity.Homing:
                    Console.WriteLine("Slide is currently Homing");
                    break;
                case DetectorSlideActivity.MovingIn:
                    Console.WriteLine("Slide is currently MovingIn");
                    break;
                case DetectorSlideActivity.MovingOut:
                    Console.WriteLine("Slide is currently MovingOut");
                    break;
                case DetectorSlideActivity.NotMoving:
                    Console.WriteLine("Slide is currently Not Moving");
                    break;
                case DetectorSlideActivity.Unknown:
                default:
                    Console.WriteLine("Slide activity is currently Unknown");
                    break;
            }
        }
        #endregion

        #region Drive Slide In

        /// <summary>
        /// Trys to drive the Slide In.
        /// </summary>
        public bool DriveSlideIn(IEdDetectorControl currentDetector)
        {
            bool isSet = false;

            if (currentDetector != null && currentDetector.SlideControl.CanDriveIn())
            {
                try
                {
                    currentDetector.SlideControl.DriveIn();
                    isSet = true;
                }
                catch (DetectorControlException ex)
                {
                    Console.WriteLine(ex.Message);
                }
            }

            return isSet;
        }
        #endregion

        #region Drive Slide Out

        /// <summary>
        /// Trys to drive the Slide Out.
        /// </summary>
        public bool DriveSlideOut(IEdDetectorControl currentDetector)
        {
            bool isSet = false;

            if (currentDetector != null && currentDetector.SlideControl.CanDriveOut())
            {
                try
                {
                    currentDetector.SlideControl.DriveOut();
                    isSet = true;
                }
                catch (DetectorControlException ex)
                {
                    Console.WriteLine(ex.Message);
                }
            }

            return isSet;
        }
        #endregion

        #region Stop Slide

        /// <summary>
        /// Trys to stop the Slide.
        /// </summary>
        public bool StopSlide(IEdDetectorControl currentDetector)
        {
            bool isSet = false;

            if (currentDetector != null && currentDetector.SlideControl.CanStop())
            {
                try
                {
                    currentDetector.SlideControl.Stop();
                    isSet = true;
                }
                catch (DetectorControlException ex)
                {
                    Console.WriteLine(ex.Message);
                }
            }

            return isSet;
        }
        #endregion
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace


ISlideControl Properties

The ISlideControl type exposes the following members.

Properties
 | Name | Description
 | Capabilities | Gets the capabilities of the slide. ISlideCapabilities
Public property | HardwareId | Gets a value identifying the detector being controlled. (Inherited from IControlBase.)
Public property | IsConnected | Gets a value indicating whether or not the detector is connected. (Inherited from IControlBase.)
 | Status | Gets the status of the slide. ISlideStatus
Top
See Also

Reference

ISlideControl Interface
OINA.Extender.DetectorControl Namespace


ISlideControl.Capabilities Property

Gets the capabilities of the slide. ISlideCapabilities

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ISlideCapabilities Capabilities { get; }
ReadOnly Property Capabilities As ISlideCapabilities
    Get
property ISlideCapabilities^ Capabilities {
    ISlideCapabilities^ get ();
}
abstract Capabilities : ISlideCapabilities with get

Property Value

Type: ISlideCapabilities
The capabilities.
Examples
Copy
/// <summary>
/// Prints the detectors Slide control capabilities to console output.
/// </summary>
public void PrintSlideCapabilities(IEdDetectorControl currentDetector)
{
    if (currentDetector.SlideControl.Capabilities.HasMotorControl)
    {
        Console.WriteLine("Detector Slide has motor control.");
    }
    else
    {
        Console.WriteLine("Detector Slide  does not have motor control!");
    }
}
See Also

Reference

ISlideControl Interface
OINA.Extender.DetectorControl Namespace


ISlideControl.Status Property

Gets the status of the slide. ISlideStatus

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ISlideStatus Status { get; }
ReadOnly Property Status As ISlideStatus
    Get
property ISlideStatus^ Status {
    ISlideStatus^ get ();
}
abstract Status : ISlideStatus with get

Property Value

Type: ISlideStatus
The status.
Examples
Copy
/// <summary>
/// Prints the Slide control status to the console output.
/// </summary>
public void PrintSlideStatus(IEdDetectorControl currentDetector)
{
    switch (currentDetector.SlideControl.Status.PositionState)
    {
        case DetectorSlidePositionState.In:
            Console.WriteLine("The Slide position is In");
            break;
        case DetectorSlidePositionState.Out:
            Console.WriteLine("The Slide position is Out");
            break;
        case DetectorSlidePositionState.Intermediate:
            Console.WriteLine("The Slide position is intermediate");
            break;
        case DetectorSlidePositionState.Fault:
            Console.WriteLine("The Slide position has a fault");
            break;
        case DetectorSlidePositionState.AutoRetracted:
            Console.WriteLine("The Slide position has been automatically retracted");
            break;
        case DetectorSlidePositionState.ReferencePosition:
            Console.WriteLine("The Slide position has a fault");
            break;
        case DetectorSlidePositionState.Indeterminate:
            Console.WriteLine("Indeterminate : Slide position can't be determined");
            break;
        case DetectorSlidePositionState.Unknown:
            Console.WriteLine("Unknown : Slide position can't be determined");
            break;
        default:
            Console.WriteLine("Slide position can't be determined");
            break;
    }

    switch (currentDetector.SlideControl.Status.Activity)
    {
        case DetectorSlideActivity.AutoRetracting:
            Console.WriteLine("Slide is currently AutoRetracting");
            break;
        case DetectorSlideActivity.Homing:
            Console.WriteLine("Slide is currently Homing");
            break;
        case DetectorSlideActivity.MovingIn:
            Console.WriteLine("Slide is currently MovingIn");
            break;
        case DetectorSlideActivity.MovingOut:
            Console.WriteLine("Slide is currently MovingOut");
            break;
        case DetectorSlideActivity.NotMoving:
            Console.WriteLine("Slide is currently Not Moving");
            break;
        case DetectorSlideActivity.Unknown:
        default:
            Console.WriteLine("Slide activity is currently Unknown");
            break;
    }
}
See Also

Reference

ISlideControl Interface
OINA.Extender.DetectorControl Namespace


ISlideControl Methods

The ISlideControl type exposes the following members.

Methods
 | Name | Description
 | CanDriveIn | Determines whether or not the slide can drive in.
 | CanDriveOut | Determines whether or not the slide can drive out.
 | CanStop | Determines whether or not the slide can be stopped.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | DriveIn | Drives the slide in.
 | DriveOut | Drives the slide out.
 | Stop | Stops the slide at the current position.
Top
See Also

Reference

ISlideControl Interface
OINA.Extender.DetectorControl Namespace


ISlideControl.CanDriveIn Method

Determines whether or not the slide can drive in.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanDriveIn()
Function CanDriveIn As Boolean
bool CanDriveIn()
abstract CanDriveIn : unit -> bool

Return Value

Type: Boolean
true if the slide can drive in; otherwise, false.
Examples
Copy
/// <summary>
/// Trys to drive the Slide In.
/// </summary>
public bool DriveSlideIn(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.SlideControl.CanDriveIn())
    {
        try
        {
            currentDetector.SlideControl.DriveIn();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

ISlideControl Interface
OINA.Extender.DetectorControl Namespace


ISlideControl.CanDriveOut Method

Determines whether or not the slide can drive out.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanDriveOut()
Function CanDriveOut As Boolean
bool CanDriveOut()
abstract CanDriveOut : unit -> bool

Return Value

Type: Boolean
true if the slide can drive out; otherwise, false.
Examples
Copy
/// <summary>
/// Trys to drive the Slide Out.
/// </summary>
public bool DriveSlideOut(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.SlideControl.CanDriveOut())
    {
        try
        {
            currentDetector.SlideControl.DriveOut();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

ISlideControl Interface
OINA.Extender.DetectorControl Namespace


ISlideControl.CanStop Method

Determines whether or not the slide can be stopped.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanStop()
Function CanStop As Boolean
bool CanStop()
abstract CanStop : unit -> bool

Return Value

Type: Boolean
true if the slide can be stopped; otherwise, false.
Examples
Copy
/// <summary>
/// Trys to stop the Slide.
/// </summary>
public bool StopSlide(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.SlideControl.CanStop())
    {
        try
        {
            currentDetector.SlideControl.Stop();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

ISlideControl Interface
OINA.Extender.DetectorControl Namespace


ISlideControl.DriveIn Method

Drives the slide in.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void DriveIn()
Sub DriveIn
void DriveIn()
abstract DriveIn : unit -> unit
Exceptions
Exception | Condition
DetectorControlException | Throws a DetectorControlException exception when fails.
Examples
Copy
/// <summary>
/// Trys to drive the Slide In.
/// </summary>
public bool DriveSlideIn(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.SlideControl.CanDriveIn())
    {
        try
        {
            currentDetector.SlideControl.DriveIn();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

ISlideControl Interface
OINA.Extender.DetectorControl Namespace


ISlideControl.DriveOut Method

Drives the slide out.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void DriveOut()
Sub DriveOut
void DriveOut()
abstract DriveOut : unit -> unit
Exceptions
Exception | Condition
DetectorControlException | Throws a DetectorControlException exception when fails.
Examples
Copy
/// <summary>
/// Trys to drive the Slide Out.
/// </summary>
public bool DriveSlideOut(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.SlideControl.CanDriveOut())
    {
        try
        {
            currentDetector.SlideControl.DriveOut();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

ISlideControl Interface
OINA.Extender.DetectorControl Namespace


ISlideControl.Stop Method

Stops the slide at the current position.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void Stop()
Sub Stop
void Stop()
abstract Stop : unit -> unit
Exceptions
Exception | Condition
DetectorControlException | Throws a DetectorControlException exception when fails.
Examples
Copy
/// <summary>
/// Trys to stop the Slide.
/// </summary>
public bool StopSlide(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.SlideControl.CanStop())
    {
        try
        {
            currentDetector.SlideControl.Stop();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

ISlideControl Interface
OINA.Extender.DetectorControl Namespace


ISlideControl Events

The ISlideControl type exposes the following members.

Events
 | Name | Description
Public event | DetectorConnected | Occurs when a connection to the detector is made or lost. Use this event to get capabilities and status. (Inherited from IControlBase.)
Public event | StatusChanged | Occurs when the detector status changes. (Inherited from IControlBase.)
Top
See Also

Reference

ISlideControl Interface
OINA.Extender.DetectorControl Namespace


ISlideStatus Interface

An Interface that defines the slide status of an Ed detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface ISlideStatus
Public Interface ISlideStatus
public interface class ISlideStatus
type ISlideStatus =  interface end

The ISlideStatus type exposes the following members.

Properties
 | Name | Description
Public property | Activity | Gets the slide activity.
Public property | PositionState | Gets the slide position state.
Top
Examples
Copy
/// <summary>
/// Prints the Slide control status to the console output.
/// </summary>
public void PrintSlideStatus(IEdDetectorControl currentDetector)
{
    switch (currentDetector.SlideControl.Status.PositionState)
    {
        case DetectorSlidePositionState.In:
            Console.WriteLine("The Slide position is In");
            break;
        case DetectorSlidePositionState.Out:
            Console.WriteLine("The Slide position is Out");
            break;
        case DetectorSlidePositionState.Intermediate:
            Console.WriteLine("The Slide position is intermediate");
            break;
        case DetectorSlidePositionState.Fault:
            Console.WriteLine("The Slide position has a fault");
            break;
        case DetectorSlidePositionState.AutoRetracted:
            Console.WriteLine("The Slide position has been automatically retracted");
            break;
        case DetectorSlidePositionState.ReferencePosition:
            Console.WriteLine("The Slide position has a fault");
            break;
        case DetectorSlidePositionState.Indeterminate:
            Console.WriteLine("Indeterminate : Slide position can't be determined");
            break;
        case DetectorSlidePositionState.Unknown:
            Console.WriteLine("Unknown : Slide position can't be determined");
            break;
        default:
            Console.WriteLine("Slide position can't be determined");
            break;
    }

    switch (currentDetector.SlideControl.Status.Activity)
    {
        case DetectorSlideActivity.AutoRetracting:
            Console.WriteLine("Slide is currently AutoRetracting");
            break;
        case DetectorSlideActivity.Homing:
            Console.WriteLine("Slide is currently Homing");
            break;
        case DetectorSlideActivity.MovingIn:
            Console.WriteLine("Slide is currently MovingIn");
            break;
        case DetectorSlideActivity.MovingOut:
            Console.WriteLine("Slide is currently MovingOut");
            break;
        case DetectorSlideActivity.NotMoving:
            Console.WriteLine("Slide is currently Not Moving");
            break;
        case DetectorSlideActivity.Unknown:
        default:
            Console.WriteLine("Slide activity is currently Unknown");
            break;
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace


ISlideStatus Properties

The ISlideStatus type exposes the following members.

Properties
 | Name | Description
Public property | Activity | Gets the slide activity.
Public property | PositionState | Gets the slide position state.
Top
See Also

Reference

ISlideStatus Interface
OINA.Extender.DetectorControl Namespace


ISlideStatus.Activity Property

Gets the slide activity.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DetectorSlideActivity Activity { get; }
ReadOnly Property Activity As DetectorSlideActivity
    Get
property DetectorSlideActivity Activity {
    DetectorSlideActivity get ();
}
abstract Activity : DetectorSlideActivity with get

Property Value

Type: DetectorSlideActivity
The Slides activity.
See Also

Reference

ISlideStatus Interface
OINA.Extender.DetectorControl Namespace


ISlideStatus.PositionState Property

Gets the slide position state.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DetectorSlidePositionState PositionState { get; }
ReadOnly Property PositionState As DetectorSlidePositionState
    Get
property DetectorSlidePositionState PositionState {
    DetectorSlidePositionState get ();
}
abstract PositionState : DetectorSlidePositionState with get

Property Value

Type: DetectorSlidePositionState
The Slides position state.
See Also

Reference

ISlideStatus Interface
OINA.Extender.DetectorControl Namespace


IThermalCapabilities Interface

An Interface that defines the thermal control capabilities of a detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IThermalCapabilities
Public Interface IThermalCapabilities
public interface class IThermalCapabilities
type IThermalCapabilities =  interface end

The IThermalCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | HasExtendedMode | Gets a value indicating whether or not the detector supports extended operation mode.
Public property | HasLN2Alarm | Gets a value indicating whether or not the detector has an LN2 alarm.
Public property | HasLN2Sensor | Gets a value indicating whether or not the detector has an LN2 sensor.
Public property | HasOperatingMode | Gets a value indicating whether or not the detector supports operating mode.
Public property | HasOperatingStatus | Gets a value indicating whether or not the detector supports operating status.
Public property | HasVacuumSensor | Gets a value indicating whether or not the detector has a vacuum sensor.
Public property | HasWindow | Gets a value indicating whether or not the detector has a window.
Top
Examples
Copy
/// <summary>
/// Prints the detectors Thermal control capabilities to console output.
/// </summary>
public void PrintThermalCapabilities(IEdDetectorControl currentDetector)
{
    if (currentDetector.ThermalControl.Capabilities.HasExtendedMode)
    {
        Console.WriteLine("Thermal Control supports Extended Mode.");
    }

    if (currentDetector.ThermalControl.Capabilities.HasLN2Sensor)
    {
        Console.WriteLine("Thermal Control Has a LN2 Sensor.");
    }

    if (currentDetector.ThermalControl.Capabilities.HasLN2Alarm)
    {
        Console.WriteLine("Thermal Control Has a LN2 Alarm.");
    }

    if (currentDetector.ThermalControl.Capabilities.HasOperatingMode)
    {
        Console.WriteLine("Thermal Control supports Operating mode.");
    }

    if (currentDetector.ThermalControl.Capabilities.HasOperatingStatus)
    {
        Console.WriteLine("Thermal Control reports operating Status");
    }

    if (currentDetector.ThermalControl.Capabilities.HasVacuumSensor)
    {
        Console.WriteLine("Thermal Control Has Vacuum Sensor.");
    }

    if (currentDetector.ThermalControl.Capabilities.HasWindow)
    {
        Console.WriteLine("Thermal Control Has a Window");
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace


IThermalCapabilities Properties

The IThermalCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | HasExtendedMode | Gets a value indicating whether or not the detector supports extended operation mode.
Public property | HasLN2Alarm | Gets a value indicating whether or not the detector has an LN2 alarm.
Public property | HasLN2Sensor | Gets a value indicating whether or not the detector has an LN2 sensor.
Public property | HasOperatingMode | Gets a value indicating whether or not the detector supports operating mode.
Public property | HasOperatingStatus | Gets a value indicating whether or not the detector supports operating status.
Public property | HasVacuumSensor | Gets a value indicating whether or not the detector has a vacuum sensor.
Public property | HasWindow | Gets a value indicating whether or not the detector has a window.
Top
See Also

Reference

IThermalCapabilities Interface
OINA.Extender.DetectorControl Namespace


IThermalCapabilities.HasExtendedMode Property

Gets a value indicating whether or not the detector supports extended operation mode.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasExtendedMode { get; }
ReadOnly Property HasExtendedMode As Boolean
    Get
property bool HasExtendedMode {
    bool get ();
}
abstract HasExtendedMode : bool with get

Property Value

Type: Boolean
true if the detector supports extended mode; otherwise, false.
See Also

Reference

IThermalCapabilities Interface
OINA.Extender.DetectorControl Namespace


IThermalCapabilities.HasLN2Alarm Property

Gets a value indicating whether or not the detector has an LN2 alarm.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasLN2Alarm { get; }
ReadOnly Property HasLN2Alarm As Boolean
    Get
property bool HasLN2Alarm {
    bool get ();
}
abstract HasLN2Alarm : bool with get

Property Value

Type: Boolean
true if the detector has an LN2 alarm; otherwise, false.
See Also

Reference

IThermalCapabilities Interface
OINA.Extender.DetectorControl Namespace


IThermalCapabilities.HasLN2Sensor Property

Gets a value indicating whether or not the detector has an LN2 sensor.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasLN2Sensor { get; }
ReadOnly Property HasLN2Sensor As Boolean
    Get
property bool HasLN2Sensor {
    bool get ();
}
abstract HasLN2Sensor : bool with get

Property Value

Type: Boolean
true if the detector has an LN2 sensor; otherwise, false.
See Also

Reference

IThermalCapabilities Interface
OINA.Extender.DetectorControl Namespace


IThermalCapabilities.HasOperatingMode Property

Gets a value indicating whether or not the detector supports operating mode.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasOperatingMode { get; }
ReadOnly Property HasOperatingMode As Boolean
    Get
property bool HasOperatingMode {
    bool get ();
}
abstract HasOperatingMode : bool with get

Property Value

Type: Boolean
true if the detector supports operating mode; otherwise, false.
See Also

Reference

IThermalCapabilities Interface
OINA.Extender.DetectorControl Namespace


IThermalCapabilities.HasOperatingStatus Property

Gets a value indicating whether or not the detector supports operating status.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasOperatingStatus { get; }
ReadOnly Property HasOperatingStatus As Boolean
    Get
property bool HasOperatingStatus {
    bool get ();
}
abstract HasOperatingStatus : bool with get

Property Value

Type: Boolean
true if the detector reports operating status; otherwise, false.
See Also

Reference

IThermalCapabilities Interface
OINA.Extender.DetectorControl Namespace


IThermalCapabilities.HasVacuumSensor Property

Gets a value indicating whether or not the detector has a vacuum sensor.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasVacuumSensor { get; }
ReadOnly Property HasVacuumSensor As Boolean
    Get
property bool HasVacuumSensor {
    bool get ();
}
abstract HasVacuumSensor : bool with get

Property Value

Type: Boolean
true if the detector has a vacuum sensor.; otherwise, false.
See Also

Reference

IThermalCapabilities Interface
OINA.Extender.DetectorControl Namespace


IThermalCapabilities.HasWindow Property

Gets a value indicating whether or not the detector has a window.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool HasWindow { get; }
ReadOnly Property HasWindow As Boolean
    Get
property bool HasWindow {
    bool get ();
}
abstract HasWindow : bool with get

Property Value

Type: Boolean
true if the detector has a window; otherwise, false.
See Also

Reference

IThermalCapabilities Interface
OINA.Extender.DetectorControl Namespace


IThermalControl Interface

An Interface that defines the thermal control for a detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IThermalControl : IDisposable,
    IControlBase
Public Interface IThermalControl
    Inherits IDisposable, IControlBase
public interface class IThermalControl : IDisposable,
    IControlBase
type IThermalControl =
    interface
        interface IDisposable
        interface IControlBase
    end

The IThermalControl type exposes the following members.

Properties
 | Name | Description
 | Capabilities | Gets the capabilities of the detector.
Public property | HardwareId | Gets a value identifying the detector being controlled. (Inherited from IControlBase.)
Public property | IsConnected | Gets a value indicating whether or not the detector is connected. (Inherited from IControlBase.)
 | Status | Gets the status of the detector.
Top
Methods
 | Name | Description
 | CanEnterAutomaticMode | Determines whether or not the detector can be switched into automatic mode.
 | CanEnterStandbyMode | Determines whether or not the detector can be switched into standby mode.
 | CanMuteLN2Alarm | Determines whether or not the LN2 alarm can be muted.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | EnterAutomaticMode | Switch the detector into automatic mode.
 | EnterStandbyMode | Switch the detector into standby mode.
 | MuteLN2Alarm | Mutes the LN2 alarm.
Top
Events
 | Name | Description
Public event | DetectorConnected | Occurs when a connection to the detector is made or lost. Use this event to get capabilities and status. (Inherited from IControlBase.)
Public event | StatusChanged | Occurs when the detector status changes. (Inherited from IControlBase.)
Top
Examples
Copy
namespace Extender.CodeExamples.DetectorExamples
{
    using System;
    using System.Threading;
    using OINA.Extender;
    using OINA.Extender.DetectorControl;

    public class ThermalControlExample
    {
        public static void Main(string[] args)
        {
            ThermalControlExample thermalcontrol = new ThermalControlExample();

            if (args.Length < 2)
            {
                PrintInfo();

                // Get the first detector control from the AcquireFactory
                IEdDetectorControl currentDetector = AcquireFactory.CreateEdDetectorControl()[0];

                // Output the detectors overload capabilities to the console window.
                thermalcontrol.PrintThermalCapabilities(currentDetector);

                ConsoleKeyInfo keyInfo;

                do
                {
                    // Try to Toggle the overload detection every 5 seconds until a key is pressed...
                    while (Console.KeyAvailable == false)
                    {
                        // Output the detectors thermal control status to the console window.
                        thermalcontrol.PrintThermalStatus(currentDetector);

                        Thread.Sleep(5000);
                    }

                    keyInfo = Console.ReadKey(true);

                    switch (keyInfo.Key)
                    {
                        case ConsoleKey.A:
                            if (thermalcontrol.EnterAutomaticMode(currentDetector))
                            {
                                Console.WriteLine("Automatic mode command success.");
                            }
                            else
                            {
                                Console.WriteLine("Automatic mode command failed.");
                            }

                            break;
                        case ConsoleKey.M:
                            if (thermalcontrol.MuteLN2Alarm(currentDetector))
                            {
                                Console.WriteLine("Mute Alarm command success.");
                            }
                            else
                            {
                                Console.WriteLine("Mute Alarm command failed.");
                            }

                            break;
                        case ConsoleKey.S:
                            if (thermalcontrol.EnterStandByMode(currentDetector))
                            {
                                Console.WriteLine("Stand-by mode command success.");
                            }
                            else
                            {
                                Console.WriteLine("Stand-by mode command failed.");
                            }

                            break;
                        case ConsoleKey.Escape:
                            break;
                        default:
                            Console.WriteLine("Key not recognised, Commands are...");
                            PrintInfo();
                            break;
                    }
                }
                while (keyInfo.Key != ConsoleKey.Escape);
            }
        }

        public static void PrintInfo()
        {
            Console.WriteLine("Press A to enter automatic thermal control...");
            Console.WriteLine("Press M to mute thermal control LN2 Alarm...");
            Console.WriteLine("Press S to enter stand-by thermal control...");
            Console.WriteLine("Press Esc to Quit...");
        }

        #region Thermal Capabilities
        /// <summary>
        /// Prints the detectors Thermal control capabilities to console output.
        /// </summary>
        public void PrintThermalCapabilities(IEdDetectorControl currentDetector)
        {
            if (currentDetector.ThermalControl.Capabilities.HasExtendedMode)
            {
                Console.WriteLine("Thermal Control supports Extended Mode.");
            }

            if (currentDetector.ThermalControl.Capabilities.HasLN2Sensor)
            {
                Console.WriteLine("Thermal Control Has a LN2 Sensor.");
            }

            if (currentDetector.ThermalControl.Capabilities.HasLN2Alarm)
            {
                Console.WriteLine("Thermal Control Has a LN2 Alarm.");
            }

            if (currentDetector.ThermalControl.Capabilities.HasOperatingMode)
            {
                Console.WriteLine("Thermal Control supports Operating mode.");
            }

            if (currentDetector.ThermalControl.Capabilities.HasOperatingStatus)
            {
                Console.WriteLine("Thermal Control reports operating Status");
            }

            if (currentDetector.ThermalControl.Capabilities.HasVacuumSensor)
            {
                Console.WriteLine("Thermal Control Has Vacuum Sensor.");
            }

            if (currentDetector.ThermalControl.Capabilities.HasWindow)
            {
                Console.WriteLine("Thermal Control Has a Window");
            }
        }
        #endregion

        #region Thermal Status
        /// <summary>
        /// Prints the detectors status to the console output.
        /// </summary>
        public void PrintThermalStatus(IEdDetectorControl currentDetector)
        {
            if (currentDetector.ThermalControl.Status.ExtendedModeEnabled)
            {
                Console.WriteLine("Thermal Control Extended mode enabled.");
            }

            switch (currentDetector.ThermalControl.Status.LN2State)
            {
                case LN2State.OK:
                    Console.WriteLine("LN2 Level is OK");
                    break;
                case LN2State.Low:
                    Console.WriteLine("LN2 Level is Low!");
                    break;
                case LN2State.InAir:
                    Console.WriteLine("LN2 sensor in Air!");
                    break;
                case LN2State.SensorMissing:
                    Console.WriteLine("LN2 sensor is missing!");
                    break;
                case LN2State.Unknown:
                default:
                    Console.WriteLine("LN2 State can't be determined");
                    break;
            }

            switch (currentDetector.ThermalControl.Status.OperatingMode)
            {
                case DetectorOperatingMode.Manual:
                    Console.WriteLine("Thermal Control is manual.");
                    break;
                case DetectorOperatingMode.Automatic:
                    Console.WriteLine("Thermal Control is automatic.");
                    break;
                case DetectorOperatingMode.Standby:
                    Console.WriteLine("Thermal Control is in stand-by.");
                    break;
                case DetectorOperatingMode.Unknown:
                default:
                    Console.WriteLine("Thermal Control mode is unknown!");
                    break;
            }

            switch (currentDetector.ThermalControl.Status.OperatingState)
            {
                case DetectorOperatingState.Cold:
                    Console.WriteLine("Thermal Control operating state is Cold");
                    break;
                case DetectorOperatingState.Cooling:
                    Console.WriteLine("Thermal Control operating state is Cooling");
                    break;
                case DetectorOperatingState.Initialising:
                    Console.WriteLine("Thermal Control operating state is Initialising");
                    break;
                case DetectorOperatingState.ManualControl:
                    Console.WriteLine("Thermal Control operating state is manual control");
                    break;
                case DetectorOperatingState.Standby:
                    Console.WriteLine("Thermal Control operating state is stand-by");
                    break;
                case DetectorOperatingState.Warming:
                    Console.WriteLine("Thermal Control operating state is Warming");
                    break;
                case DetectorOperatingState.Warm:
                    Console.WriteLine("Thermal Control operating state is Warm");
                    break;
                case DetectorOperatingState.Fault:
                    Console.WriteLine("Thermal Control operating state has a Fault");
                    break;
                case DetectorOperatingState.Unknown:
                default:
                    Console.WriteLine("Thermal Control operating state is Unknown!");
                    break;
            }

            switch (currentDetector.ThermalControl.Status.VacuumState)
            {
                case DetectorVacuumState.UnderVacuum:
                    Console.WriteLine("Thermal Control is under vacuum.");
                    break;
                case DetectorVacuumState.Vented:
                    Console.WriteLine("Thermal Control vacuum is vented.");
                    break;
                case DetectorVacuumState.Unknown:
                default:
                    Console.WriteLine("Thermal Control vacuum status is unknown.");
                    break;
            }
        }
        #endregion

        #region Thermal Control AutoMode
        /// <summary>
        /// Trys to enter automatic thermal control.
        /// </summary>
        public bool EnterAutomaticMode(IEdDetectorControl currentDetector)
        {
            bool isSet = false;

            if (currentDetector != null && currentDetector.ThermalControl.CanEnterAutomaticMode())
            {
                try
                {
                    currentDetector.ThermalControl.EnterAutomaticMode();
                    isSet = true;
                }
                catch (DetectorControlException ex)
                {
                    Console.WriteLine(ex.Message);
                }
            }

            return isSet;
        }
        #endregion

        #region Thermal Control Stand-by

        /// <summary>
        /// Trys to enter standby mode for the thermal control
        /// </summary>
        public bool EnterStandByMode(IEdDetectorControl currentDetector)
        {
            bool isSet = false;

            if (currentDetector != null && currentDetector.ThermalControl.CanEnterStandbyMode())
            {
                try
                {
                    currentDetector.ThermalControl.EnterStandbyMode();
                    isSet = true;
                }
                catch (DetectorControlException ex)
                {
                    Console.WriteLine(ex.Message);
                }
            }

            return isSet;
        }
        #endregion

        #region Mute LN2 Alarm

        /// <summary>
        /// Trys to mute the thermal controls LN2 Alarm
        /// </summary>
        public bool MuteLN2Alarm(IEdDetectorControl currentDetector)
        {
            bool isSet = false;

            if (currentDetector != null && currentDetector.ThermalControl.CanMuteLN2Alarm())
            {
                try
                {
                    currentDetector.ThermalControl.MuteLN2Alarm();
                    isSet = true;
                }
                catch (DetectorControlException ex)
                {
                    Console.WriteLine(ex.Message);
                }
            }

            return isSet;
        }
        #endregion
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace


IThermalControl Properties

The IThermalControl type exposes the following members.

Properties
 | Name | Description
 | Capabilities | Gets the capabilities of the detector.
Public property | HardwareId | Gets a value identifying the detector being controlled. (Inherited from IControlBase.)
Public property | IsConnected | Gets a value indicating whether or not the detector is connected. (Inherited from IControlBase.)
 | Status | Gets the status of the detector.
Top
See Also

Reference

IThermalControl Interface
OINA.Extender.DetectorControl Namespace


IThermalControl.Capabilities Property

Gets the capabilities of the detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IThermalCapabilities Capabilities { get; }
ReadOnly Property Capabilities As IThermalCapabilities
    Get
property IThermalCapabilities^ Capabilities {
    IThermalCapabilities^ get ();
}
abstract Capabilities : IThermalCapabilities with get

Property Value

Type: IThermalCapabilities
The capabilities. IThermalCapabilities
Examples
Copy
/// <summary>
/// Prints the detectors Thermal control capabilities to console output.
/// </summary>
public void PrintThermalCapabilities(IEdDetectorControl currentDetector)
{
    if (currentDetector.ThermalControl.Capabilities.HasExtendedMode)
    {
        Console.WriteLine("Thermal Control supports Extended Mode.");
    }

    if (currentDetector.ThermalControl.Capabilities.HasLN2Sensor)
    {
        Console.WriteLine("Thermal Control Has a LN2 Sensor.");
    }

    if (currentDetector.ThermalControl.Capabilities.HasLN2Alarm)
    {
        Console.WriteLine("Thermal Control Has a LN2 Alarm.");
    }

    if (currentDetector.ThermalControl.Capabilities.HasOperatingMode)
    {
        Console.WriteLine("Thermal Control supports Operating mode.");
    }

    if (currentDetector.ThermalControl.Capabilities.HasOperatingStatus)
    {
        Console.WriteLine("Thermal Control reports operating Status");
    }

    if (currentDetector.ThermalControl.Capabilities.HasVacuumSensor)
    {
        Console.WriteLine("Thermal Control Has Vacuum Sensor.");
    }

    if (currentDetector.ThermalControl.Capabilities.HasWindow)
    {
        Console.WriteLine("Thermal Control Has a Window");
    }
}
See Also

Reference

IThermalControl Interface
OINA.Extender.DetectorControl Namespace


IThermalControl.Status Property

Gets the status of the detector.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IThermalStatus Status { get; }
ReadOnly Property Status As IThermalStatus
    Get
property IThermalStatus^ Status {
    IThermalStatus^ get ();
}
abstract Status : IThermalStatus with get

Property Value

Type: IThermalStatus
The status. IThermalStatus
Examples
Copy
/// <summary>
/// Prints the detectors status to the console output.
/// </summary>
public void PrintThermalStatus(IEdDetectorControl currentDetector)
{
    if (currentDetector.ThermalControl.Status.ExtendedModeEnabled)
    {
        Console.WriteLine("Thermal Control Extended mode enabled.");
    }

    switch (currentDetector.ThermalControl.Status.LN2State)
    {
        case LN2State.OK:
            Console.WriteLine("LN2 Level is OK");
            break;
        case LN2State.Low:
            Console.WriteLine("LN2 Level is Low!");
            break;
        case LN2State.InAir:
            Console.WriteLine("LN2 sensor in Air!");
            break;
        case LN2State.SensorMissing:
            Console.WriteLine("LN2 sensor is missing!");
            break;
        case LN2State.Unknown:
        default:
            Console.WriteLine("LN2 State can't be determined");
            break;
    }

    switch (currentDetector.ThermalControl.Status.OperatingMode)
    {
        case DetectorOperatingMode.Manual:
            Console.WriteLine("Thermal Control is manual.");
            break;
        case DetectorOperatingMode.Automatic:
            Console.WriteLine("Thermal Control is automatic.");
            break;
        case DetectorOperatingMode.Standby:
            Console.WriteLine("Thermal Control is in stand-by.");
            break;
        case DetectorOperatingMode.Unknown:
        default:
            Console.WriteLine("Thermal Control mode is unknown!");
            break;
    }

    switch (currentDetector.ThermalControl.Status.OperatingState)
    {
        case DetectorOperatingState.Cold:
            Console.WriteLine("Thermal Control operating state is Cold");
            break;
        case DetectorOperatingState.Cooling:
            Console.WriteLine("Thermal Control operating state is Cooling");
            break;
        case DetectorOperatingState.Initialising:
            Console.WriteLine("Thermal Control operating state is Initialising");
            break;
        case DetectorOperatingState.ManualControl:
            Console.WriteLine("Thermal Control operating state is manual control");
            break;
        case DetectorOperatingState.Standby:
            Console.WriteLine("Thermal Control operating state is stand-by");
            break;
        case DetectorOperatingState.Warming:
            Console.WriteLine("Thermal Control operating state is Warming");
            break;
        case DetectorOperatingState.Warm:
            Console.WriteLine("Thermal Control operating state is Warm");
            break;
        case DetectorOperatingState.Fault:
            Console.WriteLine("Thermal Control operating state has a Fault");
            break;
        case DetectorOperatingState.Unknown:
        default:
            Console.WriteLine("Thermal Control operating state is Unknown!");
            break;
    }

    switch (currentDetector.ThermalControl.Status.VacuumState)
    {
        case DetectorVacuumState.UnderVacuum:
            Console.WriteLine("Thermal Control is under vacuum.");
            break;
        case DetectorVacuumState.Vented:
            Console.WriteLine("Thermal Control vacuum is vented.");
            break;
        case DetectorVacuumState.Unknown:
        default:
            Console.WriteLine("Thermal Control vacuum status is unknown.");
            break;
    }
}
See Also

Reference

IThermalControl Interface
OINA.Extender.DetectorControl Namespace


IThermalControl Methods

The IThermalControl type exposes the following members.

Methods
 | Name | Description
 | CanEnterAutomaticMode | Determines whether or not the detector can be switched into automatic mode.
 | CanEnterStandbyMode | Determines whether or not the detector can be switched into standby mode.
 | CanMuteLN2Alarm | Determines whether or not the LN2 alarm can be muted.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
 | EnterAutomaticMode | Switch the detector into automatic mode.
 | EnterStandbyMode | Switch the detector into standby mode.
 | MuteLN2Alarm | Mutes the LN2 alarm.
Top
See Also

Reference

IThermalControl Interface
OINA.Extender.DetectorControl Namespace


IThermalControl.CanEnterAutomaticMode Method

Determines whether or not the detector can be switched into automatic mode.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanEnterAutomaticMode()
Function CanEnterAutomaticMode As Boolean
bool CanEnterAutomaticMode()
abstract CanEnterAutomaticMode : unit -> bool

Return Value

Type: Boolean
true if the detector can be switched into automatic mode; otherwise, false.
Examples
Copy
/// <summary>
/// Trys to enter automatic thermal control.
/// </summary>
public bool EnterAutomaticMode(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.ThermalControl.CanEnterAutomaticMode())
    {
        try
        {
            currentDetector.ThermalControl.EnterAutomaticMode();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IThermalControl Interface
OINA.Extender.DetectorControl Namespace


IThermalControl.CanEnterStandbyMode Method

Determines whether or not the detector can be switched into standby mode.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanEnterStandbyMode()
Function CanEnterStandbyMode As Boolean
bool CanEnterStandbyMode()
abstract CanEnterStandbyMode : unit -> bool

Return Value

Type: Boolean
true if the detector can be switched into standby mode; otherwise, false.
Examples
Copy
/// <summary>
/// Trys to enter standby mode for the thermal control
/// </summary>
public bool EnterStandByMode(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.ThermalControl.CanEnterStandbyMode())
    {
        try
        {
            currentDetector.ThermalControl.EnterStandbyMode();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IThermalControl Interface
OINA.Extender.DetectorControl Namespace


IThermalControl.CanMuteLN2Alarm Method

Determines whether or not the LN2 alarm can be muted.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanMuteLN2Alarm()
Function CanMuteLN2Alarm As Boolean
bool CanMuteLN2Alarm()
abstract CanMuteLN2Alarm : unit -> bool

Return Value

Type: Boolean
true if the LN2 alarm can be muted; otherwise, false.
Examples
Copy
/// <summary>
/// Trys to mute the thermal controls LN2 Alarm
/// </summary>
public bool MuteLN2Alarm(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.ThermalControl.CanMuteLN2Alarm())
    {
        try
        {
            currentDetector.ThermalControl.MuteLN2Alarm();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IThermalControl Interface
OINA.Extender.DetectorControl Namespace


IThermalControl.EnterAutomaticMode Method

Switch the detector into automatic mode.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void EnterAutomaticMode()
Sub EnterAutomaticMode
void EnterAutomaticMode()
abstract EnterAutomaticMode : unit -> unit
Exceptions
Exception | Condition
DetectorControlException | Throws a DetectorControlException exception when fails.
Examples
Copy
/// <summary>
/// Trys to enter automatic thermal control.
/// </summary>
public bool EnterAutomaticMode(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.ThermalControl.CanEnterAutomaticMode())
    {
        try
        {
            currentDetector.ThermalControl.EnterAutomaticMode();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IThermalControl Interface
OINA.Extender.DetectorControl Namespace


IThermalControl.EnterStandbyMode Method

Switch the detector into standby mode.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void EnterStandbyMode()
Sub EnterStandbyMode
void EnterStandbyMode()
abstract EnterStandbyMode : unit -> unit
Exceptions
Exception | Condition
DetectorControlException | Throws a DetectorControlException exception when fails.
Examples
Copy
/// <summary>
/// Trys to enter standby mode for the thermal control
/// </summary>
public bool EnterStandByMode(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.ThermalControl.CanEnterStandbyMode())
    {
        try
        {
            currentDetector.ThermalControl.EnterStandbyMode();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IThermalControl Interface
OINA.Extender.DetectorControl Namespace


IThermalControl.MuteLN2Alarm Method

Mutes the LN2 alarm.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void MuteLN2Alarm()
Sub MuteLN2Alarm
void MuteLN2Alarm()
abstract MuteLN2Alarm : unit -> unit
Exceptions
Exception | Condition
DetectorControlException | Throws a DetectorControlException exception when fails.
Examples
Copy
/// <summary>
/// Trys to mute the thermal controls LN2 Alarm
/// </summary>
public bool MuteLN2Alarm(IEdDetectorControl currentDetector)
{
    bool isSet = false;

    if (currentDetector != null && currentDetector.ThermalControl.CanMuteLN2Alarm())
    {
        try
        {
            currentDetector.ThermalControl.MuteLN2Alarm();
            isSet = true;
        }
        catch (DetectorControlException ex)
        {
            Console.WriteLine(ex.Message);
        }
    }

    return isSet;
}
See Also

Reference

IThermalControl Interface
OINA.Extender.DetectorControl Namespace


IThermalControl Events

The IThermalControl type exposes the following members.

Events
 | Name | Description
Public event | DetectorConnected | Occurs when a connection to the detector is made or lost. Use this event to get capabilities and status. (Inherited from IControlBase.)
Public event | StatusChanged | Occurs when the detector status changes. (Inherited from IControlBase.)
Top
See Also

Reference

IThermalControl Interface
OINA.Extender.DetectorControl Namespace


IThermalStatus Interface

An Interface that defines the thermal control status.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IThermalStatus
Public Interface IThermalStatus
public interface class IThermalStatus
type IThermalStatus =  interface end

The IThermalStatus type exposes the following members.

Properties
 | Name | Description
Public property | ExtendedModeEnabled | Gets a value indicating whether or not extended mode is enabled.
Public property | LN2State | Gets the state of the LN2 sensor. LN2State
Public property | OperatingMode | Gets the operating mode of the detector. DetectorOperatingMode
Public property | OperatingState | Gets the operating state of the detector. DetectorOperatingState
Public property | VacuumState | Gets the state of the vacuum sensor. DetectorVacuumState
Top
Examples
Copy
/// <summary>
/// Prints the detectors status to the console output.
/// </summary>
public void PrintThermalStatus(IEdDetectorControl currentDetector)
{
    if (currentDetector.ThermalControl.Status.ExtendedModeEnabled)
    {
        Console.WriteLine("Thermal Control Extended mode enabled.");
    }

    switch (currentDetector.ThermalControl.Status.LN2State)
    {
        case LN2State.OK:
            Console.WriteLine("LN2 Level is OK");
            break;
        case LN2State.Low:
            Console.WriteLine("LN2 Level is Low!");
            break;
        case LN2State.InAir:
            Console.WriteLine("LN2 sensor in Air!");
            break;
        case LN2State.SensorMissing:
            Console.WriteLine("LN2 sensor is missing!");
            break;
        case LN2State.Unknown:
        default:
            Console.WriteLine("LN2 State can't be determined");
            break;
    }

    switch (currentDetector.ThermalControl.Status.OperatingMode)
    {
        case DetectorOperatingMode.Manual:
            Console.WriteLine("Thermal Control is manual.");
            break;
        case DetectorOperatingMode.Automatic:
            Console.WriteLine("Thermal Control is automatic.");
            break;
        case DetectorOperatingMode.Standby:
            Console.WriteLine("Thermal Control is in stand-by.");
            break;
        case DetectorOperatingMode.Unknown:
        default:
            Console.WriteLine("Thermal Control mode is unknown!");
            break;
    }

    switch (currentDetector.ThermalControl.Status.OperatingState)
    {
        case DetectorOperatingState.Cold:
            Console.WriteLine("Thermal Control operating state is Cold");
            break;
        case DetectorOperatingState.Cooling:
            Console.WriteLine("Thermal Control operating state is Cooling");
            break;
        case DetectorOperatingState.Initialising:
            Console.WriteLine("Thermal Control operating state is Initialising");
            break;
        case DetectorOperatingState.ManualControl:
            Console.WriteLine("Thermal Control operating state is manual control");
            break;
        case DetectorOperatingState.Standby:
            Console.WriteLine("Thermal Control operating state is stand-by");
            break;
        case DetectorOperatingState.Warming:
            Console.WriteLine("Thermal Control operating state is Warming");
            break;
        case DetectorOperatingState.Warm:
            Console.WriteLine("Thermal Control operating state is Warm");
            break;
        case DetectorOperatingState.Fault:
            Console.WriteLine("Thermal Control operating state has a Fault");
            break;
        case DetectorOperatingState.Unknown:
        default:
            Console.WriteLine("Thermal Control operating state is Unknown!");
            break;
    }

    switch (currentDetector.ThermalControl.Status.VacuumState)
    {
        case DetectorVacuumState.UnderVacuum:
            Console.WriteLine("Thermal Control is under vacuum.");
            break;
        case DetectorVacuumState.Vented:
            Console.WriteLine("Thermal Control vacuum is vented.");
            break;
        case DetectorVacuumState.Unknown:
        default:
            Console.WriteLine("Thermal Control vacuum status is unknown.");
            break;
    }
}
See Also

Reference

OINA.Extender.DetectorControl Namespace


IThermalStatus Properties

The IThermalStatus type exposes the following members.

Properties
 | Name | Description
Public property | ExtendedModeEnabled | Gets a value indicating whether or not extended mode is enabled.
Public property | LN2State | Gets the state of the LN2 sensor. LN2State
Public property | OperatingMode | Gets the operating mode of the detector. DetectorOperatingMode
Public property | OperatingState | Gets the operating state of the detector. DetectorOperatingState
Public property | VacuumState | Gets the state of the vacuum sensor. DetectorVacuumState
Top
See Also

Reference

IThermalStatus Interface
OINA.Extender.DetectorControl Namespace


IThermalStatus.ExtendedModeEnabled Property

Gets a value indicating whether or not extended mode is enabled.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool ExtendedModeEnabled { get; }
ReadOnly Property ExtendedModeEnabled As Boolean
    Get
property bool ExtendedModeEnabled {
    bool get ();
}
abstract ExtendedModeEnabled : bool with get

Property Value

Type: Boolean
true if extended mode is enabled; otherwise, false.
See Also

Reference

IThermalStatus Interface
OINA.Extender.DetectorControl Namespace


IThermalStatus.LN2State Property

Gets the state of the LN2 sensor. LN2State

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
LN2State LN2State { get; }
ReadOnly Property LN2State As LN2State
    Get
property LN2State LN2State {
    LN2State get ();
}
abstract LN2State : LN2State with get

Property Value

Type: LN2State
The state of the LN2 sensor.
See Also

Reference

IThermalStatus Interface
OINA.Extender.DetectorControl Namespace


IThermalStatus.OperatingMode Property

Gets the operating mode of the detector. DetectorOperatingMode

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DetectorOperatingMode OperatingMode { get; }
ReadOnly Property OperatingMode As DetectorOperatingMode
    Get
property DetectorOperatingMode OperatingMode {
    DetectorOperatingMode get ();
}
abstract OperatingMode : DetectorOperatingMode with get

Property Value

Type: DetectorOperatingMode
The operating state.
See Also

Reference

IThermalStatus Interface
OINA.Extender.DetectorControl Namespace


IThermalStatus.OperatingState Property

Gets the operating state of the detector. DetectorOperatingState

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DetectorOperatingState OperatingState { get; }
ReadOnly Property OperatingState As DetectorOperatingState
    Get
property DetectorOperatingState OperatingState {
    DetectorOperatingState get ();
}
abstract OperatingState : DetectorOperatingState with get

Property Value

Type: DetectorOperatingState
The operating state.
See Also

Reference

IThermalStatus Interface
OINA.Extender.DetectorControl Namespace


IThermalStatus.VacuumState Property

Gets the state of the vacuum sensor. DetectorVacuumState

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
DetectorVacuumState VacuumState { get; }
ReadOnly Property VacuumState As DetectorVacuumState
    Get
property DetectorVacuumState VacuumState {
    DetectorVacuumState get ();
}
abstract VacuumState : DetectorVacuumState with get

Property Value

Type: DetectorVacuumState
The state of the vacuum sensor.
See Also

Reference

IThermalStatus Interface
OINA.Extender.DetectorControl Namespace


LN2State Enumeration

LN2 states.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum LN2State
Public Enumeration LN2State
public enum class LN2State
type LN2State
Members
Member name | Value | Description
Unknown | 0 | The system was unable to ascertain the state of the sensor.
OK | 1 | The LN2 level is OK.
Low | 2 | The LN2 Level is Low.
InAir | 3 | The LN2 sensor is in air.
SensorMissing | 4 | The LN2 sensor has not been detected.
See Also

Reference

OINA.Extender.DetectorControl Namespace


LowMagInterlock Enumeration

The status of Low Mag Interlock.

Namespace: OINA.Extender.DetectorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum LowMagInterlock
Public Enumeration LowMagInterlock
public enum class LowMagInterlock
type LowMagInterlock
Members
Member name | Value | Description
Unknown | 0 | Indicates that the interlock state can't be determined
Enabled | 1 | Indicates that the interlock is enabled
Disabled | 2 | Indicates that the interlock is disabled
See Also

Reference

OINA.Extender.DetectorControl Namespace


OINA.Extender.MicroscopeControl Namespace

Defines Classes and Interfaces that allow for the control of the Microscope.

OINA Extender Microscope Namespace

Classes
 | Class | Description
Public class | ColumnEventArgs | A Class that provides information about microscope column parameters.
Public class | CompletedEventArgs | A Class that provides information about microscope parameter changes.
Public class | StageEventArgs | A Class that provides information about microscope stage parameters.
Interfaces
 | Interface | Description
Public interface | IColumnCapabilities | An Interface that defines column parameter capabilities.
Public interface | IColumnConditions | An Interface that defines microscope column conditions.
Public interface | IConnectionStatus | An Interface that defines the connection status for Column or Stage control.
Public interface | IMicroscopeController | Interface that defines column, stage and external scan control.
Public interface | IMicroscopeParameterCapability | An Interface that defines the capabilities of column and stage parameters.
Public interface | IStageCapabilities | An Interface that defines the stage capabilities for the microscope.
Public interface | IStageConditions | An Interface that defines the stage conditions.
Enumerations
 | Enumeration | Description
Public enumeration | Column | Column parameters.
Public enumeration | MicroscopeControlType | Types of microscope control.
Public enumeration | Stage | Stage parameters.


Column Enumeration

Column parameters.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum Column
Public Enumeration Column
public enum class Column
type Column
Members
Member name | Value | Description
Unknown | 0 | The Column Parameter is unknown (not set).
HighVoltage | 1 | The High Voltage Parameter.
WorkingDistance | 2 | The Working Distance Parameter.
Magnification | 3 | The Magnification Parameter.
BeamOn | 4 | The BeamOn Parameter.
FilamentOn | 5 | The FilamentOn Parameter.
Brightness | 6 | The Brightness parameter.
Contrast | 7 | The Contrast parameter.
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


ColumnEventArgs Class

A Class that provides information about microscope column parameters.
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.ExtenderEventArgs Column, Double
OINA.Extender.MicroscopeControlColumnEventArgs

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class ColumnEventArgs : EventArgs<Column, double>
Public Class ColumnEventArgs
    Inherits EventArgs(Of Column, Double)
public ref class ColumnEventArgs : public EventArgs<Column, double>
type ColumnEventArgs =
    class
        inherit EventArgs<Column, float>
    end

The ColumnEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the key (Inherited from EventArgsTKey, TValue.)
Public property | Value | Gets the value (Inherited from EventArgsTKey, TValue.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


ColumnEventArgs Properties

The ColumnEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the key (Inherited from EventArgsTKey, TValue.)
Public property | Value | Gets the value (Inherited from EventArgsTKey, TValue.)
Top
See Also

Reference

ColumnEventArgs Class
OINA.Extender.MicroscopeControl Namespace


ColumnEventArgs Methods

The ColumnEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColumnEventArgs Class
OINA.Extender.MicroscopeControl Namespace


CompletedEventArgs Class

A Class that provides information about microscope parameter changes.
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.Extender.MicroscopeControlCompletedEventArgs

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class CompletedEventArgs : EventArgs
Public Class CompletedEventArgs
    Inherits EventArgs
public ref class CompletedEventArgs : public EventArgs
type CompletedEventArgs =
    class
        inherit EventArgs
    end

The CompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets a value indicating the microscope control type. Unknown, Column, Stage, External Scan.
Public property | Error | Gets the exception if the change was not successful.
Public property | Success | Gets a value indicating whether the change was successful.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


CompletedEventArgs Properties

The CompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Control | Gets a value indicating the microscope control type. Unknown, Column, Stage, External Scan.
Public property | Error | Gets the exception if the change was not successful.
Public property | Success | Gets a value indicating whether the change was successful.
Top
See Also

Reference

CompletedEventArgs Class
OINA.Extender.MicroscopeControl Namespace


CompletedEventArgs.Control Property

Gets a value indicating the microscope control type. Unknown, Column, Stage, External Scan.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public MicroscopeControlType Control { get; }
Public ReadOnly Property Control As MicroscopeControlType
    Get
public:
property MicroscopeControlType Control {
    MicroscopeControlType get ();
}
member Control : MicroscopeControlType with get

Property Value

Type: MicroscopeControlType
See Also

Reference

CompletedEventArgs Class
OINA.Extender.MicroscopeControl Namespace


CompletedEventArgs.Error Property

Gets the exception if the change was not successful.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Exception Error { get; }
Public ReadOnly Property Error As Exception
    Get
public:
property Exception^ Error {
    Exception^ get ();
}
member Error : Exception with get

Property Value

Type: Exception
See Also

Reference

CompletedEventArgs Class
OINA.Extender.MicroscopeControl Namespace


CompletedEventArgs.Success Property

Gets a value indicating whether the change was successful.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public bool Success { get; }
Public ReadOnly Property Success As Boolean
    Get
public:
property bool Success {
    bool get ();
}
member Success : bool with get

Property Value

Type: Boolean
See Also

Reference

CompletedEventArgs Class
OINA.Extender.MicroscopeControl Namespace


CompletedEventArgs Methods

The CompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompletedEventArgs Class
OINA.Extender.MicroscopeControl Namespace


IColumnCapabilities Interface

An Interface that defines column parameter capabilities.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IColumnCapabilities
Public Interface IColumnCapabilities
public interface class IColumnCapabilities
type IColumnCapabilities =  interface end

The IColumnCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | BeamOn | Gets the capabilities for the BeamOn
Public property | Brightness | Gets the capabilities for the Brightness
Public property | Contrast | Gets the capabilities for the Contrast
Public property | FilamentOn | Gets the capabilities for the FilamentOn
Public property | HighVoltage | Gets the capabilities for the HighVoltage
Public property | Magnification | Gets the capabilities for the Magnification
Public property | WorkingDistance | Gets the capabilities for the WorkingDistance
Top
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


IColumnCapabilities Properties

The IColumnCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | BeamOn | Gets the capabilities for the BeamOn
Public property | Brightness | Gets the capabilities for the Brightness
Public property | Contrast | Gets the capabilities for the Contrast
Public property | FilamentOn | Gets the capabilities for the FilamentOn
Public property | HighVoltage | Gets the capabilities for the HighVoltage
Public property | Magnification | Gets the capabilities for the Magnification
Public property | WorkingDistance | Gets the capabilities for the WorkingDistance
Top
See Also

Reference

IColumnCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IColumnCapabilities.BeamOn Property

Gets the capabilities for the BeamOn

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability BeamOn { get; }
ReadOnly Property BeamOn As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ BeamOn {
    IMicroscopeParameterCapability^ get ();
}
abstract BeamOn : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IColumnCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IColumnCapabilities.Brightness Property

Gets the capabilities for the Brightness

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability Brightness { get; }
ReadOnly Property Brightness As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ Brightness {
    IMicroscopeParameterCapability^ get ();
}
abstract Brightness : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IColumnCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IColumnCapabilities.Contrast Property

Gets the capabilities for the Contrast

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability Contrast { get; }
ReadOnly Property Contrast As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ Contrast {
    IMicroscopeParameterCapability^ get ();
}
abstract Contrast : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IColumnCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IColumnCapabilities.FilamentOn Property

Gets the capabilities for the FilamentOn

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability FilamentOn { get; }
ReadOnly Property FilamentOn As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ FilamentOn {
    IMicroscopeParameterCapability^ get ();
}
abstract FilamentOn : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IColumnCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IColumnCapabilities.HighVoltage Property

Gets the capabilities for the HighVoltage

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability HighVoltage { get; }
ReadOnly Property HighVoltage As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ HighVoltage {
    IMicroscopeParameterCapability^ get ();
}
abstract HighVoltage : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IColumnCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IColumnCapabilities.Magnification Property

Gets the capabilities for the Magnification

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability Magnification { get; }
ReadOnly Property Magnification As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ Magnification {
    IMicroscopeParameterCapability^ get ();
}
abstract Magnification : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IColumnCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IColumnCapabilities.WorkingDistance Property

Gets the capabilities for the WorkingDistance

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability WorkingDistance { get; }
ReadOnly Property WorkingDistance As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ WorkingDistance {
    IMicroscopeParameterCapability^ get ();
}
abstract WorkingDistance : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IColumnCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IColumnConditions Interface

An Interface that defines microscope column conditions.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IColumnConditions
Public Interface IColumnConditions
public interface class IColumnConditions
type IColumnConditions =  interface end

The IColumnConditions type exposes the following members.

Properties
 | Name | Description
Public property | BeamOn | Gets the value indicating the state of BeamOn. 1 = on, 0 = off.
Public property | Brightness | Gets a value of the Brightness
Public property | Contrast | Gets the value of the Contrast
Public property | FilamentOn | Gets the value indicating the state of FilamentOn. 1 = on, 0 = off.
Public property | HighVoltage | Gets the value of HighVoltage (kV).
Public property | Magnification | Gets a value of the Magnification
Public property | WorkingDistance | Gets a value of the WorkingDistance (mm)
Top
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


IColumnConditions Properties

The IColumnConditions type exposes the following members.

Properties
 | Name | Description
Public property | BeamOn | Gets the value indicating the state of BeamOn. 1 = on, 0 = off.
Public property | Brightness | Gets a value of the Brightness
Public property | Contrast | Gets the value of the Contrast
Public property | FilamentOn | Gets the value indicating the state of FilamentOn. 1 = on, 0 = off.
Public property | HighVoltage | Gets the value of HighVoltage (kV).
Public property | Magnification | Gets a value of the Magnification
Public property | WorkingDistance | Gets a value of the WorkingDistance (mm)
Top
See Also

Reference

IColumnConditions Interface
OINA.Extender.MicroscopeControl Namespace


IColumnConditions.BeamOn Property

Gets the value indicating the state of BeamOn. 1 = on, 0 = off.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double BeamOn { get; }
ReadOnly Property BeamOn As Double
    Get
property double BeamOn {
    double get ();
}
abstract BeamOn : float with get

Property Value

Type: Double
See Also

Reference

IColumnConditions Interface
OINA.Extender.MicroscopeControl Namespace


IColumnConditions.Brightness Property

Gets a value of the Brightness

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Brightness { get; }
ReadOnly Property Brightness As Double
    Get
property double Brightness {
    double get ();
}
abstract Brightness : float with get

Property Value

Type: Double
See Also

Reference

IColumnConditions Interface
OINA.Extender.MicroscopeControl Namespace


IColumnConditions.Contrast Property

Gets the value of the Contrast

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Contrast { get; }
ReadOnly Property Contrast As Double
    Get
property double Contrast {
    double get ();
}
abstract Contrast : float with get

Property Value

Type: Double
See Also

Reference

IColumnConditions Interface
OINA.Extender.MicroscopeControl Namespace


IColumnConditions.FilamentOn Property

Gets the value indicating the state of FilamentOn. 1 = on, 0 = off.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double FilamentOn { get; }
ReadOnly Property FilamentOn As Double
    Get
property double FilamentOn {
    double get ();
}
abstract FilamentOn : float with get

Property Value

Type: Double
See Also

Reference

IColumnConditions Interface
OINA.Extender.MicroscopeControl Namespace


IColumnConditions.HighVoltage Property

Gets the value of HighVoltage (kV).

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double HighVoltage { get; }
ReadOnly Property HighVoltage As Double
    Get
property double HighVoltage {
    double get ();
}
abstract HighVoltage : float with get

Property Value

Type: Double
See Also

Reference

IColumnConditions Interface
OINA.Extender.MicroscopeControl Namespace


IColumnConditions.Magnification Property

Gets a value of the Magnification

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Magnification { get; }
ReadOnly Property Magnification As Double
    Get
property double Magnification {
    double get ();
}
abstract Magnification : float with get

Property Value

Type: Double
See Also

Reference

IColumnConditions Interface
OINA.Extender.MicroscopeControl Namespace


IColumnConditions.WorkingDistance Property

Gets a value of the WorkingDistance (mm)

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double WorkingDistance { get; }
ReadOnly Property WorkingDistance As Double
    Get
property double WorkingDistance {
    double get ();
}
abstract WorkingDistance : float with get

Property Value

Type: Double
See Also

Reference

IColumnConditions Interface
OINA.Extender.MicroscopeControl Namespace


IConnectionStatus Interface

An Interface that defines the connection status for Column or Stage control.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IConnectionStatus
Public Interface IConnectionStatus
public interface class IConnectionStatus
type IConnectionStatus =  interface end

The IConnectionStatus type exposes the following members.

Properties
 | Name | Description
Public property | IsConnected | Gets a value indicating whether or not the Stage, or Column control, is connected.
Public property | IsDefaultControl | Gets a value indicating whether or not the built-in (default) control is used.
Public property | Name | Gets the name of the Column or Stage control. A particular driver has a particular name. For example, microscope model.
Top
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


IConnectionStatus Properties

The IConnectionStatus type exposes the following members.

Properties
 | Name | Description
Public property | IsConnected | Gets a value indicating whether or not the Stage, or Column control, is connected.
Public property | IsDefaultControl | Gets a value indicating whether or not the built-in (default) control is used.
Public property | Name | Gets the name of the Column or Stage control. A particular driver has a particular name. For example, microscope model.
Top
See Also

Reference

IConnectionStatus Interface
OINA.Extender.MicroscopeControl Namespace


IConnectionStatus.IsConnected Property

Gets a value indicating whether or not the Stage, or Column control, is connected.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsConnected { get; }
ReadOnly Property IsConnected As Boolean
    Get
property bool IsConnected {
    bool get ();
}
abstract IsConnected : bool with get

Property Value

Type: Boolean
See Also

Reference

IConnectionStatus Interface
OINA.Extender.MicroscopeControl Namespace


IConnectionStatus.IsDefaultControl Property

Gets a value indicating whether or not the built-in (default) control is used.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsDefaultControl { get; }
ReadOnly Property IsDefaultControl As Boolean
    Get
property bool IsDefaultControl {
    bool get ();
}
abstract IsDefaultControl : bool with get

Property Value

Type: Boolean
See Also

Reference

IConnectionStatus Interface
OINA.Extender.MicroscopeControl Namespace


IConnectionStatus.Name Property

Gets the name of the Column or Stage control. A particular driver has a particular name. For example, microscope model.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IConnectionStatus Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController Interface

Interface that defines column, stage and external scan control.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IMicroscopeController
Public Interface IMicroscopeController
public interface class IMicroscopeController
type IMicroscopeController =  interface end

The IMicroscopeController type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCapabilities | Gets the column capabilities
Public property | ColumnConditions | Gets the column conditions
Public property | ColumnConnectionStatus | Gets the column control connection status
Public property | IsInExternalScan | Gets a value indicating whether the microscope is in external scan mode.
Public property | StageCapabilities | Gets the stage capabilities
Public property | StageConditions | Gets the stage conditions
Public property | StageConnectionStatus | Gets the stage control connection status
Top
Methods
 | Name | Description
Public method | SetColumnConditions | Set the column parameters. Only the parameters included in the dictionary will be changed.
Public method | SetExternalScan | Sets the external scan control state
Public method | SetStageConditions | Set the stage position. Only the parameters included in the dictionary will be changed.
Top
Events
 | Name | Description
Public event | ChangeCompleted | Occurs when a column, stage or external scan change has completed
Public event | ColumnChange | Occurs when a column parameter changes
Public event | ColumnConnected | Occurs when column control is connected or disconnected
Public event | StageChange | Occurs when a stage parameter changes
Public event | StageConnected | Occurs when stage control is connected or disconnected
Top
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


IMicroscopeController Properties

The IMicroscopeController type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCapabilities | Gets the column capabilities
Public property | ColumnConditions | Gets the column conditions
Public property | ColumnConnectionStatus | Gets the column control connection status
Public property | IsInExternalScan | Gets a value indicating whether the microscope is in external scan mode.
Public property | StageCapabilities | Gets the stage capabilities
Public property | StageConditions | Gets the stage conditions
Public property | StageConnectionStatus | Gets the stage control connection status
Top
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.ColumnCapabilities Property

Gets the column capabilities

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IColumnCapabilities ColumnCapabilities { get; }
ReadOnly Property ColumnCapabilities As IColumnCapabilities
    Get
property IColumnCapabilities^ ColumnCapabilities {
    IColumnCapabilities^ get ();
}
abstract ColumnCapabilities : IColumnCapabilities with get

Property Value

Type: IColumnCapabilities
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.ColumnConditions Property

Gets the column conditions

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IColumnConditions ColumnConditions { get; }
ReadOnly Property ColumnConditions As IColumnConditions
    Get
property IColumnConditions^ ColumnConditions {
    IColumnConditions^ get ();
}
abstract ColumnConditions : IColumnConditions with get

Property Value

Type: IColumnConditions
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.ColumnConnectionStatus Property

Gets the column control connection status

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IConnectionStatus ColumnConnectionStatus { get; }
ReadOnly Property ColumnConnectionStatus As IConnectionStatus
    Get
property IConnectionStatus^ ColumnConnectionStatus {
    IConnectionStatus^ get ();
}
abstract ColumnConnectionStatus : IConnectionStatus with get

Return Value

Type: IConnectionStatus
The status
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.IsInExternalScan Property

Gets a value indicating whether the microscope is in external scan mode.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsInExternalScan { get; }
ReadOnly Property IsInExternalScan As Boolean
    Get
property bool IsInExternalScan {
    bool get ();
}
abstract IsInExternalScan : bool with get

Property Value

Type: Boolean
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.StageCapabilities Property

Gets the stage capabilities

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IStageCapabilities StageCapabilities { get; }
ReadOnly Property StageCapabilities As IStageCapabilities
    Get
property IStageCapabilities^ StageCapabilities {
    IStageCapabilities^ get ();
}
abstract StageCapabilities : IStageCapabilities with get

Property Value

Type: IStageCapabilities
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.StageConditions Property

Gets the stage conditions

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IStageConditions StageConditions { get; }
ReadOnly Property StageConditions As IStageConditions
    Get
property IStageConditions^ StageConditions {
    IStageConditions^ get ();
}
abstract StageConditions : IStageConditions with get

Property Value

Type: IStageConditions
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.StageConnectionStatus Property

Gets the stage control connection status

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IConnectionStatus StageConnectionStatus { get; }
ReadOnly Property StageConnectionStatus As IConnectionStatus
    Get
property IConnectionStatus^ StageConnectionStatus {
    IConnectionStatus^ get ();
}
abstract StageConnectionStatus : IConnectionStatus with get

Return Value

Type: IConnectionStatus
The status
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController Methods

The IMicroscopeController type exposes the following members.

Methods
 | Name | Description
Public method | SetColumnConditions | Set the column parameters. Only the parameters included in the dictionary will be changed.
Public method | SetExternalScan | Sets the external scan control state
Public method | SetStageConditions | Set the stage position. Only the parameters included in the dictionary will be changed.
Top
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.SetColumnConditions Method

Set the column parameters. Only the parameters included in the dictionary will be changed.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetColumnConditions(
    IDictionary<Column, double> newValues
)
Sub SetColumnConditions (
    newValues As IDictionary(Of Column, Double)
)
void SetColumnConditions(
    IDictionary<Column, double>^ newValues
)
abstract SetColumnConditions :
        newValues : IDictionary<Column, float> -> unit

Parameters

newValues
Type: System.Collections.GenericIDictionary Column, Double
The parameters to set
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.SetExternalScan Method

Sets the external scan control state

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetExternalScan(
    bool value
)
Sub SetExternalScan (
    value As Boolean
)
void SetExternalScan(
    bool value
)
abstract SetExternalScan :
        value : bool -> unit

Parameters

value
Type: SystemBoolean
true to switch into external scan
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.SetStageConditions Method

Set the stage position. Only the parameters included in the dictionary will be changed.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetStageConditions(
    IDictionary<Stage, double> newValues
)
Sub SetStageConditions (
    newValues As IDictionary(Of Stage, Double)
)
void SetStageConditions(
    IDictionary<Stage, double>^ newValues
)
abstract SetStageConditions :
        newValues : IDictionary<Stage, float> -> unit

Parameters

newValues
Type: System.Collections.GenericIDictionary Stage, Double
The parameters to set
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController Events

The IMicroscopeController type exposes the following members.

Events
 | Name | Description
Public event | ChangeCompleted | Occurs when a column, stage or external scan change has completed
Public event | ColumnChange | Occurs when a column parameter changes
Public event | ColumnConnected | Occurs when column control is connected or disconnected
Public event | StageChange | Occurs when a stage parameter changes
Public event | StageConnected | Occurs when stage control is connected or disconnected
Top
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.ChangeCompleted Event

Occurs when a column, stage or external scan change has completed

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<CompletedEventArgs> ChangeCompleted
Event ChangeCompleted As EventHandler(Of CompletedEventArgs)
 event EventHandler<CompletedEventArgs^>^ ChangeCompleted {
    void add (EventHandler<CompletedEventArgs^>^ value);
    void remove (EventHandler<CompletedEventArgs^>^ value);
}
abstract ChangeCompleted : IEvent<EventHandler<CompletedEventArgs>,
    CompletedEventArgs>

Value

Type: SystemEventHandler CompletedEventArgs
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.ColumnChange Event

Occurs when a column parameter changes

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ColumnEventArgs> ColumnChange
Event ColumnChange As EventHandler(Of ColumnEventArgs)
 event EventHandler<ColumnEventArgs^>^ ColumnChange {
    void add (EventHandler<ColumnEventArgs^>^ value);
    void remove (EventHandler<ColumnEventArgs^>^ value);
}
abstract ColumnChange : IEvent<EventHandler<ColumnEventArgs>,
    ColumnEventArgs>

Value

Type: SystemEventHandler ColumnEventArgs
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.ColumnConnected Event

Occurs when column control is connected or disconnected

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<bool>> ColumnConnected
Event ColumnConnected As EventHandler(Of EventArgs(Of Boolean))
 event EventHandler<EventArgs<bool>^>^ ColumnConnected {
    void add (EventHandler<EventArgs<bool>^>^ value);
    void remove (EventHandler<EventArgs<bool>^>^ value);
}
abstract ColumnConnected : IEvent<EventHandler<EventArgs<bool>>,
    EventArgs<bool>>

Value

Type: SystemEventHandler EventArgs Boolean
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.StageChange Event

Occurs when a stage parameter changes

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<StageEventArgs> StageChange
Event StageChange As EventHandler(Of StageEventArgs)
 event EventHandler<StageEventArgs^>^ StageChange {
    void add (EventHandler<StageEventArgs^>^ value);
    void remove (EventHandler<StageEventArgs^>^ value);
}
abstract StageChange : IEvent<EventHandler<StageEventArgs>,
    StageEventArgs>

Value

Type: SystemEventHandler StageEventArgs
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeController.StageConnected Event

Occurs when stage control is connected or disconnected

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<EventArgs<bool>> StageConnected
Event StageConnected As EventHandler(Of EventArgs(Of Boolean))
 event EventHandler<EventArgs<bool>^>^ StageConnected {
    void add (EventHandler<EventArgs<bool>^>^ value);
    void remove (EventHandler<EventArgs<bool>^>^ value);
}
abstract StageConnected : IEvent<EventHandler<EventArgs<bool>>,
    EventArgs<bool>>

Value

Type: SystemEventHandler EventArgs Boolean
See Also

Reference

IMicroscopeController Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeParameterCapability Interface

An Interface that defines the capabilities of column and stage parameters.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IMicroscopeParameterCapability
Public Interface IMicroscopeParameterCapability
public interface class IMicroscopeParameterCapability
type IMicroscopeParameterCapability =  interface end

The IMicroscopeParameterCapability type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether or not the parameter can be read.
Public property | CanWrite | Gets a value indicating whether or not the parameter can be written.
Public property | Max | Gets the maximum value of the parameter.
Public property | Min | Gets the minimum value of the parameter.
Top
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


IMicroscopeParameterCapability Properties

The IMicroscopeParameterCapability type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether or not the parameter can be read.
Public property | CanWrite | Gets a value indicating whether or not the parameter can be written.
Public property | Max | Gets the maximum value of the parameter.
Public property | Min | Gets the minimum value of the parameter.
Top
See Also

Reference

IMicroscopeParameterCapability Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeParameterCapability.CanRead Property

Gets a value indicating whether or not the parameter can be read.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanRead { get; }
ReadOnly Property CanRead As Boolean
    Get
property bool CanRead {
    bool get ();
}
abstract CanRead : bool with get

Property Value

Type: Boolean
See Also

Reference

IMicroscopeParameterCapability Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeParameterCapability.CanWrite Property

Gets a value indicating whether or not the parameter can be written.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool CanWrite { get; }
ReadOnly Property CanWrite As Boolean
    Get
property bool CanWrite {
    bool get ();
}
abstract CanWrite : bool with get

Property Value

Type: Boolean
See Also

Reference

IMicroscopeParameterCapability Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeParameterCapability.Max Property

Gets the maximum value of the parameter.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Max { get; }
ReadOnly Property Max As Double
    Get
property double Max {
    double get ();
}
abstract Max : float with get

Property Value

Type: Double
See Also

Reference

IMicroscopeParameterCapability Interface
OINA.Extender.MicroscopeControl Namespace


IMicroscopeParameterCapability.Min Property

Gets the minimum value of the parameter.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Min { get; }
ReadOnly Property Min As Double
    Get
property double Min {
    double get ();
}
abstract Min : float with get

Property Value

Type: Double
See Also

Reference

IMicroscopeParameterCapability Interface
OINA.Extender.MicroscopeControl Namespace


IStageCapabilities Interface

An Interface that defines the stage capabilities for the microscope.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IStageCapabilities
Public Interface IStageCapabilities
public interface class IStageCapabilities
type IStageCapabilities =  interface end

The IStageCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | StageR | Gets the capabilities for the rotate-axis
Public property | StageT | Gets the capabilities for the tilt-axis
Public property | StageX | Gets the capabilities for the x-axis
Public property | StageY | Gets the capabilities for the y-axis
Public property | StageZ | Gets the capabilities for the z-axis
Top
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


IStageCapabilities Properties

The IStageCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | StageR | Gets the capabilities for the rotate-axis
Public property | StageT | Gets the capabilities for the tilt-axis
Public property | StageX | Gets the capabilities for the x-axis
Public property | StageY | Gets the capabilities for the y-axis
Public property | StageZ | Gets the capabilities for the z-axis
Top
See Also

Reference

IStageCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IStageCapabilities.StageR Property

Gets the capabilities for the rotate-axis

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability StageR { get; }
ReadOnly Property StageR As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ StageR {
    IMicroscopeParameterCapability^ get ();
}
abstract StageR : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IStageCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IStageCapabilities.StageT Property

Gets the capabilities for the tilt-axis

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability StageT { get; }
ReadOnly Property StageT As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ StageT {
    IMicroscopeParameterCapability^ get ();
}
abstract StageT : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IStageCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IStageCapabilities.StageX Property

Gets the capabilities for the x-axis

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability StageX { get; }
ReadOnly Property StageX As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ StageX {
    IMicroscopeParameterCapability^ get ();
}
abstract StageX : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IStageCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IStageCapabilities.StageY Property

Gets the capabilities for the y-axis

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability StageY { get; }
ReadOnly Property StageY As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ StageY {
    IMicroscopeParameterCapability^ get ();
}
abstract StageY : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IStageCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IStageCapabilities.StageZ Property

Gets the capabilities for the z-axis

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IMicroscopeParameterCapability StageZ { get; }
ReadOnly Property StageZ As IMicroscopeParameterCapability
    Get
property IMicroscopeParameterCapability^ StageZ {
    IMicroscopeParameterCapability^ get ();
}
abstract StageZ : IMicroscopeParameterCapability with get

Property Value

Type: IMicroscopeParameterCapability
See Also

Reference

IStageCapabilities Interface
OINA.Extender.MicroscopeControl Namespace


IStageConditions Interface

An Interface that defines the stage conditions.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IStageConditions
Public Interface IStageConditions
public interface class IStageConditions
type IStageConditions =  interface end

The IStageConditions type exposes the following members.

Properties
 | Name | Description
Public property | BacklashOn | Gets a value indicating whether backlash correction is enabled
Public property | StageR | Gets the Rotate axis position (degrees)
Public property | StageT | Gets the Tilt axis position (degrees)
Public property | StageX | Gets the x axis position (mm)
Public property | StageY | Gets the y axis position (mm)
Public property | StageZ | Gets the z axis position (mm)
Top
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


IStageConditions Properties

The IStageConditions type exposes the following members.

Properties
 | Name | Description
Public property | BacklashOn | Gets a value indicating whether backlash correction is enabled
Public property | StageR | Gets the Rotate axis position (degrees)
Public property | StageT | Gets the Tilt axis position (degrees)
Public property | StageX | Gets the x axis position (mm)
Public property | StageY | Gets the y axis position (mm)
Public property | StageZ | Gets the z axis position (mm)
Top
See Also

Reference

IStageConditions Interface
OINA.Extender.MicroscopeControl Namespace


IStageConditions.BacklashOn Property

Gets a value indicating whether backlash correction is enabled

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double BacklashOn { get; }
ReadOnly Property BacklashOn As Double
    Get
property double BacklashOn {
    double get ();
}
abstract BacklashOn : float with get

Property Value

Type: Double
See Also

Reference

IStageConditions Interface
OINA.Extender.MicroscopeControl Namespace


IStageConditions.StageR Property

Gets the Rotate axis position (degrees)

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StageR { get; }
ReadOnly Property StageR As Double
    Get
property double StageR {
    double get ();
}
abstract StageR : float with get

Property Value

Type: Double
See Also

Reference

IStageConditions Interface
OINA.Extender.MicroscopeControl Namespace


IStageConditions.StageT Property

Gets the Tilt axis position (degrees)

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StageT { get; }
ReadOnly Property StageT As Double
    Get
property double StageT {
    double get ();
}
abstract StageT : float with get

Property Value

Type: Double
See Also

Reference

IStageConditions Interface
OINA.Extender.MicroscopeControl Namespace


IStageConditions.StageX Property

Gets the x axis position (mm)

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StageX { get; }
ReadOnly Property StageX As Double
    Get
property double StageX {
    double get ();
}
abstract StageX : float with get

Property Value

Type: Double
See Also

Reference

IStageConditions Interface
OINA.Extender.MicroscopeControl Namespace


IStageConditions.StageY Property

Gets the y axis position (mm)

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StageY { get; }
ReadOnly Property StageY As Double
    Get
property double StageY {
    double get ();
}
abstract StageY : float with get

Property Value

Type: Double
See Also

Reference

IStageConditions Interface
OINA.Extender.MicroscopeControl Namespace


IStageConditions.StageZ Property

Gets the z axis position (mm)

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double StageZ { get; }
ReadOnly Property StageZ As Double
    Get
property double StageZ {
    double get ();
}
abstract StageZ : float with get

Property Value

Type: Double
See Also

Reference

IStageConditions Interface
OINA.Extender.MicroscopeControl Namespace


MicroscopeControlType Enumeration

Types of microscope control.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum MicroscopeControlType
Public Enumeration MicroscopeControlType
public enum class MicroscopeControlType
type MicroscopeControlType
Members
Member name | Value | Description
Unknown | 0 | Type of Microscope Control is unknown (not set).
Column | 1 | Microscope Column Control.
Stage | 2 | Microscope Stage Control.
ExternalScan | 3 | Microscope External Scan Control.
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


Stage Enumeration

Stage parameters.

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum Stage
Public Enumeration Stage
public enum class Stage
type Stage
Members
Member name | Value | Description
Unknown | 0 | The Stage Parameter is unknown (not set).
StageX | 1 | The StageX Parameter.
StageY | 2 | The StageY Parameter.
StageZ | 3 | The StageZ Parameter.
StageT | 4 | The StageT Parameter.
StageR | 5 | The StageR Parameter.
BacklashOn | 6 | Is Backlash correction switched on?
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


StageEventArgs Class

A Class that provides information about microscope stage parameters.
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.ExtenderEventArgs Stage, Double
OINA.Extender.MicroscopeControlStageEventArgs

Namespace: OINA.Extender.MicroscopeControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class StageEventArgs : EventArgs<Stage, double>
Public Class StageEventArgs
    Inherits EventArgs(Of Stage, Double)
public ref class StageEventArgs : public EventArgs<Stage, double>
type StageEventArgs =
    class
        inherit EventArgs<Stage, float>
    end

The StageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the key (Inherited from EventArgsTKey, TValue.)
Public property | Value | Gets the value (Inherited from EventArgsTKey, TValue.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.MicroscopeControl Namespace


StageEventArgs Properties

The StageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the key (Inherited from EventArgsTKey, TValue.)
Public property | Value | Gets the value (Inherited from EventArgsTKey, TValue.)
Top
See Also

Reference

StageEventArgs Class
OINA.Extender.MicroscopeControl Namespace


StageEventArgs Methods

The StageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StageEventArgs Class
OINA.Extender.MicroscopeControl Namespace


OINA.Extender.MonitorControl Namespace

Defines Classes and Interfaces used to monitor hardware.

Interfaces
 | Interface | Description
Public interface | IEdDeviceStatus | An Interface that defines the status of an Ed device.
Public interface | IMonitoringController | An Interface that monitors the hardware status.


IEdDeviceStatus Interface

An Interface that defines the status of an Ed device.

Namespace: OINA.Extender.MonitorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdDeviceStatus : INotifyPropertyChanged
Public Interface IEdDeviceStatus
    Inherits INotifyPropertyChanged
public interface class IEdDeviceStatus : INotifyPropertyChanged
type IEdDeviceStatus =
    interface
        interface INotifyPropertyChanged
    end

The IEdDeviceStatus type exposes the following members.

Properties
 | Name | Description
Public property | DeadTime | Gets the dead time (percent).
Public property | HardwareId | Gets the id of the hardware.
Public property | InputRate | Gets the input count rate (counts per second).
Public property | OutputRate | Gets the output count rate (counts per second).
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.MonitorControl Namespace


IEdDeviceStatus Properties

The IEdDeviceStatus type exposes the following members.

Properties
 | Name | Description
Public property | DeadTime | Gets the dead time (percent).
Public property | HardwareId | Gets the id of the hardware.
Public property | InputRate | Gets the input count rate (counts per second).
Public property | OutputRate | Gets the output count rate (counts per second).
Top
See Also

Reference

IEdDeviceStatus Interface
OINA.Extender.MonitorControl Namespace


IEdDeviceStatus.DeadTime Property

Gets the dead time (percent).

Namespace: OINA.Extender.MonitorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double DeadTime { get; }
ReadOnly Property DeadTime As Double
    Get
property double DeadTime {
    double get ();
}
abstract DeadTime : float with get

Property Value

Type: Double
See Also

Reference

IEdDeviceStatus Interface
OINA.Extender.MonitorControl Namespace


IEdDeviceStatus.HardwareId Property

Gets the id of the hardware.

Namespace: OINA.Extender.MonitorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
EdHardwareId HardwareId { get; }
ReadOnly Property HardwareId As EdHardwareId
    Get
property EdHardwareId^ HardwareId {
    EdHardwareId^ get ();
}
abstract HardwareId : EdHardwareId with get

Property Value

Type: EdHardwareId
See Also

Reference

IEdDeviceStatus Interface
OINA.Extender.MonitorControl Namespace


IEdDeviceStatus.InputRate Property

Gets the input count rate (counts per second).

Namespace: OINA.Extender.MonitorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int InputRate { get; }
ReadOnly Property InputRate As Integer
    Get
property int InputRate {
    int get ();
}
abstract InputRate : int with get

Property Value

Type: Int32
See Also

Reference

IEdDeviceStatus Interface
OINA.Extender.MonitorControl Namespace


IEdDeviceStatus.OutputRate Property

Gets the output count rate (counts per second).

Namespace: OINA.Extender.MonitorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int OutputRate { get; }
ReadOnly Property OutputRate As Integer
    Get
property int OutputRate {
    int get ();
}
abstract OutputRate : int with get

Property Value

Type: Int32
See Also

Reference

IEdDeviceStatus Interface
OINA.Extender.MonitorControl Namespace


IEdDeviceStatus Events

The IEdDeviceStatus type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IEdDeviceStatus Interface
OINA.Extender.MonitorControl Namespace


IMonitoringController Interface

An Interface that monitors the hardware status.

Namespace: OINA.Extender.MonitorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IMonitoringController
Public Interface IMonitoringController
public interface class IMonitoringController
type IMonitoringController =  interface end

The IMonitoringController type exposes the following members.

Properties
 | Name | Description
Public property | EdStatus | Gets the acquisition status of each Ed detector.
Top
See Also

Reference

OINA.Extender.MonitorControl Namespace


IMonitoringController Properties

The IMonitoringController type exposes the following members.

Properties
 | Name | Description
Public property | EdStatus | Gets the acquisition status of each Ed detector.
Top
See Also

Reference

IMonitoringController Interface
OINA.Extender.MonitorControl Namespace


IMonitoringController.EdStatus Property

Gets the acquisition status of each Ed detector.

Namespace: OINA.Extender.MonitorControl
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ReadOnlyDictionary<string, IEdDeviceStatus> EdStatus { get; }
ReadOnly Property EdStatus As ReadOnlyDictionary(Of String, IEdDeviceStatus)
    Get
property ReadOnlyDictionary<String^, IEdDeviceStatus^>^ EdStatus {
    ReadOnlyDictionary<String^, IEdDeviceStatus^>^ get ();
}
abstract EdStatus : ReadOnlyDictionary<string, IEdDeviceStatus> with get

Property Value

Type: ReadOnlyDictionary String, IEdDeviceStatus
See Also

Reference

IMonitoringController Interface
OINA.Extender.MonitorControl Namespace


OINA.Extender.Processing Namespace

Top level Class (for Ed and Quant) used to process data.

OINA Extender Processing Namespace

Classes
 | Class | Description
Public class | ElementProperties | A helper Class for converting between atomic number and element name/symbol.
Interfaces
 | Interface | Description
Public interface | IAutoIdSettings | An Interface that provides the settings for AutoId.
Public interface | ISampleCoating | An Interface that defines the coating on a sample.


ElementProperties Class

A helper Class for converting between atomic number and element name/symbol.
Inheritance Hierarchy
SystemObject
OINA.Extender.ProcessingElementProperties

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class ElementProperties
Public NotInheritable Class ElementProperties
public ref class ElementProperties abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElementProperties =  class end

The ElementProperties type exposes the following members.

Methods
Name | Description
GetAtomicNumberByElementName | Gets the atomic number for a given element name.
GetAtomicNumberByElementSymbol | Gets the atomic number for a given element symbol.
GetElementName | Gets the element name for a given atomic number.
GetElementSymbol | Gets the element symbol for a given atomic number.
Top
See Also

Reference

OINA.Extender.Processing Namespace


ElementProperties Methods

The ElementProperties type exposes the following members.

Methods
Name | Description
GetAtomicNumberByElementName | Gets the atomic number for a given element name.
GetAtomicNumberByElementSymbol | Gets the atomic number for a given element symbol.
GetElementName | Gets the element name for a given atomic number.
GetElementSymbol | Gets the element symbol for a given atomic number.
Top
See Also

Reference

ElementProperties Class
OINA.Extender.Processing Namespace


ElementProperties.GetAtomicNumberByElementName Method

Gets the atomic number for a given element name.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static int GetAtomicNumberByElementName(
    string elementName
)
Public Shared Function GetAtomicNumberByElementName (
    elementName As String
) As Integer
public:
static int GetAtomicNumberByElementName(
    String^ elementName
)
static member GetAtomicNumberByElementName :
        elementName : string -> int

Parameters

elementName
Type: SystemString
Element name

Return Value

Type: Int32
Return atomic number of element if match, otherwise zero is returned.
See Also

Reference

ElementProperties Class
OINA.Extender.Processing Namespace


ElementProperties.GetAtomicNumberByElementSymbol Method

Gets the atomic number for a given element symbol.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static int GetAtomicNumberByElementSymbol(
    string elementSymbol
)
Public Shared Function GetAtomicNumberByElementSymbol (
    elementSymbol As String
) As Integer
public:
static int GetAtomicNumberByElementSymbol(
    String^ elementSymbol
)
static member GetAtomicNumberByElementSymbol :
        elementSymbol : string -> int

Parameters

elementSymbol
Type: SystemString
Element symbol

Return Value

Type: Int32
Return atomic number of element if match, otherwise zero is returned.
See Also

Reference

ElementProperties Class
OINA.Extender.Processing Namespace


ElementProperties.GetElementName Method

Gets the element name for a given atomic number.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static string GetElementName(
    int atomicNumber
)
Public Shared Function GetElementName (
    atomicNumber As Integer
) As String
public:
static String^ GetElementName(
    int atomicNumber
)
static member GetElementName :
        atomicNumber : int -> string

Parameters

atomicNumber
Type: SystemInt32
Element atomic number

Return Value

Type: String
Return the element symbol if the atomic number is between 1 and 103.
See Also

Reference

ElementProperties Class
OINA.Extender.Processing Namespace


ElementProperties.GetElementSymbol Method

Gets the element symbol for a given atomic number.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static string GetElementSymbol(
    int atomicNumber
)
Public Shared Function GetElementSymbol (
    atomicNumber As Integer
) As String
public:
static String^ GetElementSymbol(
    int atomicNumber
)
static member GetElementSymbol :
        atomicNumber : int -> string

Parameters

atomicNumber
Type: SystemInt32
Element atomic number

Return Value

Type: String
Return the element symbol if the atomic number is between 1 and 103.
See Also

Reference

ElementProperties Class
OINA.Extender.Processing Namespace


IAutoIdSettings Interface

An Interface that provides the settings for AutoId.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IAutoIdSettings
Public Interface IAutoIdSettings
public interface class IAutoIdSettings
type IAutoIdSettings =  interface end

The IAutoIdSettings type exposes the following members.

Properties
 | Name | Description
Public property | ConfidenceFactor | Gets or sets a confidence factor, which determines the likelihood of identifying a peak.
Public property | DisabledElements | Gets the atomic numbers of elements that cannot be identified.
Public property | ExcludedElements | Gets the atomic numbers of elements that will not be identified. Allows elements to be excluded from the AutoId process.
Public property | KnownElements | Gets the atomic numbers of elements that are already known.
Top
Methods
 | Name | Description
Public method | ClearExcludedElements | Clears the elements excluded from the AutoId process.
Public method | ClearKnownElements | Clears the known elements.
Public method | CopyFrom | Copies the settings from specified source.
Public method | SetExcludedElement | Excludes an element from the AutoId process.
Public method | SetKnownElement | Includes a known element.
Top
See Also

Reference

OINA.Extender.Processing Namespace


IAutoIdSettings Properties

The IAutoIdSettings type exposes the following members.

Properties
 | Name | Description
Public property | ConfidenceFactor | Gets or sets a confidence factor, which determines the likelihood of identifying a peak.
Public property | DisabledElements | Gets the atomic numbers of elements that cannot be identified.
Public property | ExcludedElements | Gets the atomic numbers of elements that will not be identified. Allows elements to be excluded from the AutoId process.
Public property | KnownElements | Gets the atomic numbers of elements that are already known.
Top
See Also

Reference

IAutoIdSettings Interface
OINA.Extender.Processing Namespace


IAutoIdSettings.ConfidenceFactor Property

Gets or sets a confidence factor, which determines the likelihood of identifying a peak.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
float ConfidenceFactor { get; set; }
Property ConfidenceFactor As Single
    Get
    Set
property float ConfidenceFactor {
    float get ();
    void set (float value);
}
abstract ConfidenceFactor : float32 with get, set

Property Value

Type: Single
See Also

Reference

IAutoIdSettings Interface
OINA.Extender.Processing Namespace


IAutoIdSettings.DisabledElements Property

Gets the atomic numbers of elements that cannot be identified.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IReadOnlyList<int> DisabledElements { get; }
ReadOnly Property DisabledElements As IReadOnlyList(Of Integer)
    Get
property IReadOnlyList<int>^ DisabledElements {
    IReadOnlyList<int>^ get ();
}
abstract DisabledElements : IReadOnlyList<int> with get

Property Value

Type: IReadOnlyList Int32
See Also

Reference

IAutoIdSettings Interface
OINA.Extender.Processing Namespace


IAutoIdSettings.ExcludedElements Property

Gets the atomic numbers of elements that will not be identified. Allows elements to be excluded from the AutoId process.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IReadOnlyList<int> ExcludedElements { get; }
ReadOnly Property ExcludedElements As IReadOnlyList(Of Integer)
    Get
property IReadOnlyList<int>^ ExcludedElements {
    IReadOnlyList<int>^ get ();
}
abstract ExcludedElements : IReadOnlyList<int> with get

Property Value

Type: IReadOnlyList Int32
See Also

Reference

IAutoIdSettings Interface
OINA.Extender.Processing Namespace


IAutoIdSettings.KnownElements Property

Gets the atomic numbers of elements that are already known.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IReadOnlyList<int> KnownElements { get; }
ReadOnly Property KnownElements As IReadOnlyList(Of Integer)
    Get
property IReadOnlyList<int>^ KnownElements {
    IReadOnlyList<int>^ get ();
}
abstract KnownElements : IReadOnlyList<int> with get

Property Value

Type: IReadOnlyList Int32
See Also

Reference

IAutoIdSettings Interface
OINA.Extender.Processing Namespace


IAutoIdSettings Methods

The IAutoIdSettings type exposes the following members.

Methods
 | Name | Description
Public method | ClearExcludedElements | Clears the elements excluded from the AutoId process.
Public method | ClearKnownElements | Clears the known elements.
Public method | CopyFrom | Copies the settings from specified source.
Public method | SetExcludedElement | Excludes an element from the AutoId process.
Public method | SetKnownElement | Includes a known element.
Top
See Also

Reference

IAutoIdSettings Interface
OINA.Extender.Processing Namespace


IAutoIdSettings.ClearExcludedElements Method

Clears the elements excluded from the AutoId process.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void ClearExcludedElements()
Sub ClearExcludedElements
void ClearExcludedElements()
abstract ClearExcludedElements : unit -> unit
See Also

Reference

IAutoIdSettings Interface
OINA.Extender.Processing Namespace


IAutoIdSettings.ClearKnownElements Method

Clears the known elements.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void ClearKnownElements()
Sub ClearKnownElements
void ClearKnownElements()
abstract ClearKnownElements : unit -> unit
See Also

Reference

IAutoIdSettings Interface
OINA.Extender.Processing Namespace


IAutoIdSettings.CopyFrom Method

Copies the settings from specified source.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void CopyFrom(
    IAutoIdSettings source
)
Sub CopyFrom (
    source As IAutoIdSettings
)
void CopyFrom(
    IAutoIdSettings^ source
)
abstract CopyFrom :
        source : IAutoIdSettings -> unit

Parameters

source
Type: OINA.Extender.ProcessingIAutoIdSettings
The source settings.
See Also

Reference

IAutoIdSettings Interface
OINA.Extender.Processing Namespace


IAutoIdSettings.SetExcludedElement Method

Excludes an element from the AutoId process.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetExcludedElement(
    int atomicNumber,
    bool excluded
)
Sub SetExcludedElement (
    atomicNumber As Integer,
    excluded As Boolean
)
void SetExcludedElement(
    int atomicNumber,
    bool excluded
)
abstract SetExcludedElement :
        atomicNumber : int *
        excluded : bool -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number
excluded
Type: SystemBoolean
true if it was excluded
See Also

Reference

IAutoIdSettings Interface
OINA.Extender.Processing Namespace


IAutoIdSettings.SetKnownElement Method

Includes a known element.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetKnownElement(
    int atomicNumber,
    bool known
)
Sub SetKnownElement (
    atomicNumber As Integer,
    known As Boolean
)
void SetKnownElement(
    int atomicNumber,
    bool known
)
abstract SetKnownElement :
        atomicNumber : int *
        known : bool -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number
known
Type: SystemBoolean
true if it was known
See Also

Reference

IAutoIdSettings Interface
OINA.Extender.Processing Namespace


ISampleCoating Interface

An Interface that defines the coating on a sample.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface ISampleCoating : INotifyPropertyChanged
Public Interface ISampleCoating
    Inherits INotifyPropertyChanged
public interface class ISampleCoating : INotifyPropertyChanged
type ISampleCoating =
    interface
        interface INotifyPropertyChanged
    end

The ISampleCoating type exposes the following members.

Properties
 | Name | Description
Public property | CoatingElement | Gets or sets the atomic number of the coating element.
Public property | Density | Gets or sets the density of the coating element in g/cm^3.
Public property | IsCoated | Gets or sets a value indicating whether the sample is coated.
Public property | Thickness | Gets or sets the thickness of the coating element in nm.
Top
Methods
 | Name | Description
Public method | CopyFrom | Copies the values from specified source.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Processing Namespace


ISampleCoating Properties

The ISampleCoating type exposes the following members.

Properties
 | Name | Description
Public property | CoatingElement | Gets or sets the atomic number of the coating element.
Public property | Density | Gets or sets the density of the coating element in g/cm^3.
Public property | IsCoated | Gets or sets a value indicating whether the sample is coated.
Public property | Thickness | Gets or sets the thickness of the coating element in nm.
Top
See Also

Reference

ISampleCoating Interface
OINA.Extender.Processing Namespace


ISampleCoating.CoatingElement Property

Gets or sets the atomic number of the coating element.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int CoatingElement { get; set; }
Property CoatingElement As Integer
    Get
    Set
property int CoatingElement {
    int get ();
    void set (int value);
}
abstract CoatingElement : int with get, set

Property Value

Type: Int32
See Also

Reference

ISampleCoating Interface
OINA.Extender.Processing Namespace


ISampleCoating.Density Property

Gets or sets the density of the coating element in g/cm^3.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Density { get; set; }
Property Density As Double
    Get
    Set
property double Density {
    double get ();
    void set (double value);
}
abstract Density : float with get, set

Property Value

Type: Double
See Also

Reference

ISampleCoating Interface
OINA.Extender.Processing Namespace


ISampleCoating.IsCoated Property

Gets or sets a value indicating whether the sample is coated.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsCoated { get; set; }
Property IsCoated As Boolean
    Get
    Set
property bool IsCoated {
    bool get ();
    void set (bool value);
}
abstract IsCoated : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISampleCoating Interface
OINA.Extender.Processing Namespace


ISampleCoating.Thickness Property

Gets or sets the thickness of the coating element in nm.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double Thickness { get; set; }
Property Thickness As Double
    Get
    Set
property double Thickness {
    double get ();
    void set (double value);
}
abstract Thickness : float with get, set

Property Value

Type: Double
See Also

Reference

ISampleCoating Interface
OINA.Extender.Processing Namespace


ISampleCoating Methods

The ISampleCoating type exposes the following members.

Methods
 | Name | Description
Public method | CopyFrom | Copies the values from specified source.
Top
See Also

Reference

ISampleCoating Interface
OINA.Extender.Processing Namespace


ISampleCoating.CopyFrom Method

Copies the values from specified source.

Namespace: OINA.Extender.Processing
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void CopyFrom(
    ISampleCoating source
)
Sub CopyFrom (
    source As ISampleCoating
)
void CopyFrom(
    ISampleCoating^ source
)
abstract CopyFrom :
        source : ISampleCoating -> unit

Parameters

source
Type: OINA.Extender.ProcessingISampleCoating
The source coating.
See Also

Reference

ISampleCoating Interface
OINA.Extender.Processing Namespace


ISampleCoating Events

The ISampleCoating type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ISampleCoating Interface
OINA.Extender.Processing Namespace


OINA.Extender.Processing.Ed Namespace

Defines Classes and Interfaces used to process Ed data.

Classes
 | Class | Description
Public class | ProcessingProgressEventArgs | Class that provides progress for the processing map
Interfaces
 | Interface | Description
Public interface | IEdMapFLSCapabilities | Interface that provides capabilities for the FLS processing of Ed Maps
Public interface | IEdMapFLSProcessor | Interface for the FLS processing of acquired Ed maps
Public interface | IEdMapFLSSettings | Interface that provides settings for the FLS processing of Ed Maps
Public interface | IEdMapProcessing | Ed map processing interface.
 | IEdSpectrumProcessing | An Interface that extracts information from a spectrum.
Enumerations
 | Enumeration | Description
Public enumeration | FLSProcessingCode | Identifies X-Ray lines used for FLS processing.
Public enumeration | PeakLabelFormat |
Public enumeration | ProcessingProgressState | Identifies the processing progress state


FLSProcessingCode Enumeration

Identifies X-Ray lines used for FLS processing.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum FLSProcessingCode
Public Enumeration FLSProcessingCode
public enum class FLSProcessingCode
type FLSProcessingCode
Members
Member name | Value | Description
NullLine | 0 | X-Ray Line is unknown (unset).
K_Series | 1 | K-Series X-Ray Line.
L_Series | 2 | L-Series X-Ray Line.
M_Series | 3 | M-Series X-Ray Line.
See Also

Reference

OINA.Extender.Processing.Ed Namespace


IEdMapFLSCapabilities Interface

Interface that provides capabilities for the FLS processing of Ed Maps

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdMapFLSCapabilities
Public Interface IEdMapFLSCapabilities
public interface class IEdMapFLSCapabilities
type IEdMapFLSCapabilities =  interface end

The IEdMapFLSCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AllowedBinningFactors | Gets the allowed binning factors
Public property | MaximumAtomicNumber | Gets the maximum atomic number for FLS processing
Public property | MinimumAtomicNumber | Gets the minimum atomic number for FLS processing
Top
See Also

Reference

OINA.Extender.Processing.Ed Namespace


IEdMapFLSCapabilities Properties

The IEdMapFLSCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | AllowedBinningFactors | Gets the allowed binning factors
Public property | MaximumAtomicNumber | Gets the maximum atomic number for FLS processing
Public property | MinimumAtomicNumber | Gets the minimum atomic number for FLS processing
Top
See Also

Reference

IEdMapFLSCapabilities Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSCapabilities.AllowedBinningFactors Property

Gets the allowed binning factors

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IReadOnlyList<int> AllowedBinningFactors { get; }
ReadOnly Property AllowedBinningFactors As IReadOnlyList(Of Integer)
    Get
property IReadOnlyList<int>^ AllowedBinningFactors {
    IReadOnlyList<int>^ get ();
}
abstract AllowedBinningFactors : IReadOnlyList<int> with get

Property Value

Type: IReadOnlyList Int32
See Also

Reference

IEdMapFLSCapabilities Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSCapabilities.MaximumAtomicNumber Property

Gets the maximum atomic number for FLS processing

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MaximumAtomicNumber { get; }
ReadOnly Property MaximumAtomicNumber As Integer
    Get
property int MaximumAtomicNumber {
    int get ();
}
abstract MaximumAtomicNumber : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapFLSCapabilities Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSCapabilities.MinimumAtomicNumber Property

Gets the minimum atomic number for FLS processing

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MinimumAtomicNumber { get; }
ReadOnly Property MinimumAtomicNumber As Integer
    Get
property int MinimumAtomicNumber {
    int get ();
}
abstract MinimumAtomicNumber : int with get

Property Value

Type: Int32
See Also

Reference

IEdMapFLSCapabilities Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSProcessor Interface

Interface for the FLS processing of acquired Ed maps

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdMapFLSProcessor : IDisposable
Public Interface IEdMapFLSProcessor
    Inherits IDisposable
public interface class IEdMapFLSProcessor : IDisposable
type IEdMapFLSProcessor =
    interface
        interface IDisposable
    end

The IEdMapFLSProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CancelProcessing | Cancels FLS map processing
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StartProcessing | Starts FLS processing of the Ed map using the provided settings
Top
Events
 | Name | Description
Public event | ProgressChanged | Event that notifies that the processing progress has changed
Top
See Also

Reference

OINA.Extender.Processing.Ed Namespace


IEdMapFLSProcessor Methods

The IEdMapFLSProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CancelProcessing | Cancels FLS map processing
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StartProcessing | Starts FLS processing of the Ed map using the provided settings
Top
See Also

Reference

IEdMapFLSProcessor Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSProcessor.CancelProcessing Method

Cancels FLS map processing

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void CancelProcessing()
Sub CancelProcessing
void CancelProcessing()
abstract CancelProcessing : unit -> unit
See Also

Reference

IEdMapFLSProcessor Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSProcessor.StartProcessing Method

Starts FLS processing of the Ed map using the provided settings

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IReadOnlyList<IFLSMapImage> StartProcessing(
    IEdMapAcquisitionData mapData,
    IEdMapFLSSettings settings
)
Function StartProcessing (
    mapData As IEdMapAcquisitionData,
    settings As IEdMapFLSSettings
) As IReadOnlyList(Of IFLSMapImage)
IReadOnlyList<IFLSMapImage^>^ StartProcessing(
    IEdMapAcquisitionData^ mapData,
    IEdMapFLSSettings^ settings
)
abstract StartProcessing :
        mapData : IEdMapAcquisitionData *
        settings : IEdMapFLSSettings -> IReadOnlyList<IFLSMapImage>

Parameters

mapData
Type: OINA.Extender.Data.EdIEdMapAcquisitionData
The map data
settings
Type: OINA.Extender.Processing.EdIEdMapFLSSettings
The FLS processing settings

Return Value

Type: IReadOnlyList IFLSMapImage
The FLS map images
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the map data does not have an EdMap, when acquisition or processing are already in progress or if no IdentifiedElements are specified.
InvalidSettingsException | Thrown when the settings are invalid.
See Also

Reference

IEdMapFLSProcessor Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSProcessor Events

The IEdMapFLSProcessor type exposes the following members.

Events
 | Name | Description
Public event | ProgressChanged | Event that notifies that the processing progress has changed
Top
See Also

Reference

IEdMapFLSProcessor Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSProcessor.ProgressChanged Event

Event that notifies that the processing progress has changed

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
event EventHandler<ProcessingProgressEventArgs> ProgressChanged
Event ProgressChanged As EventHandler(Of ProcessingProgressEventArgs)
 event EventHandler<ProcessingProgressEventArgs^>^ ProgressChanged {
    void add (EventHandler<ProcessingProgressEventArgs^>^ value);
    void remove (EventHandler<ProcessingProgressEventArgs^>^ value);
}
abstract ProgressChanged : IEvent<EventHandler<ProcessingProgressEventArgs>,
    ProcessingProgressEventArgs>

Value

Type: SystemEventHandler ProcessingProgressEventArgs
See Also

Reference

IEdMapFLSProcessor Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSSettings Interface

Interface that provides settings for the FLS processing of Ed Maps

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdMapFLSSettings
Public Interface IEdMapFLSSettings
public interface class IEdMapFLSSettings
type IEdMapFLSSettings =  interface end

The IEdMapFLSSettings type exposes the following members.

Properties
 | Name | Description
Public property | ApplyFlsThreshold | Gets or sets a value indicating whether a FLS threshold is applied
Public property | BinningFactor | Gets or sets the binning factor
Public property | Capabilities | Gets the capabilities
Public property | ElementColors | Gets the element color for the atomic number
Public property | FlsLineOverrides | Gets the FLS line overrides for the atomic number
Public property | FlsSigmaThreshold | Gets or sets the FLS threshold
Top
Methods
 | Name | Description
Public method | Validate | Validates all the settings
Top
See Also

Reference

OINA.Extender.Processing.Ed Namespace


IEdMapFLSSettings Properties

The IEdMapFLSSettings type exposes the following members.

Properties
 | Name | Description
Public property | ApplyFlsThreshold | Gets or sets a value indicating whether a FLS threshold is applied
Public property | BinningFactor | Gets or sets the binning factor
Public property | Capabilities | Gets the capabilities
Public property | ElementColors | Gets the element color for the atomic number
Public property | FlsLineOverrides | Gets the FLS line overrides for the atomic number
Public property | FlsSigmaThreshold | Gets or sets the FLS threshold
Top
See Also

Reference

IEdMapFLSSettings Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSSettings.ApplyFlsThreshold Property

Gets or sets a value indicating whether a FLS threshold is applied

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool ApplyFlsThreshold { get; set; }
Property ApplyFlsThreshold As Boolean
    Get
    Set
property bool ApplyFlsThreshold {
    bool get ();
    void set (bool value);
}
abstract ApplyFlsThreshold : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEdMapFLSSettings Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSSettings.BinningFactor Property

Gets or sets the binning factor

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int BinningFactor { get; set; }
Property BinningFactor As Integer
    Get
    Set
property int BinningFactor {
    int get ();
    void set (int value);
}
abstract BinningFactor : int with get, set

Property Value

Type: Int32
See Also

Reference

IEdMapFLSSettings Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSSettings.Capabilities Property

Gets the capabilities

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdMapFLSCapabilities Capabilities { get; }
ReadOnly Property Capabilities As IEdMapFLSCapabilities
    Get
property IEdMapFLSCapabilities^ Capabilities {
    IEdMapFLSCapabilities^ get ();
}
abstract Capabilities : IEdMapFLSCapabilities with get

Property Value

Type: IEdMapFLSCapabilities
See Also

Reference

IEdMapFLSSettings Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSSettings.ElementColors Property

Gets the element color for the atomic number

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Dictionary<int, Color> ElementColors { get; }
ReadOnly Property ElementColors As Dictionary(Of Integer, Color)
    Get
property Dictionary<int, Color>^ ElementColors {
    Dictionary<int, Color>^ get ();
}
abstract ElementColors : Dictionary<int, Color> with get

Property Value

Type: Dictionary Int32, Color
See Also

Reference

IEdMapFLSSettings Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSSettings.FlsLineOverrides Property

Gets the FLS line overrides for the atomic number

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Dictionary<int, FLSProcessingCode> FlsLineOverrides { get; }
ReadOnly Property FlsLineOverrides As Dictionary(Of Integer, FLSProcessingCode)
    Get
property Dictionary<int, FLSProcessingCode>^ FlsLineOverrides {
    Dictionary<int, FLSProcessingCode>^ get ();
}
abstract FlsLineOverrides : Dictionary<int, FLSProcessingCode> with get

Property Value

Type: Dictionary Int32, FLSProcessingCode
See Also

Reference

IEdMapFLSSettings Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSSettings.FlsSigmaThreshold Property

Gets or sets the FLS threshold

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double FlsSigmaThreshold { get; set; }
Property FlsSigmaThreshold As Double
    Get
    Set
property double FlsSigmaThreshold {
    double get ();
    void set (double value);
}
abstract FlsSigmaThreshold : float with get, set

Property Value

Type: Double
See Also

Reference

IEdMapFLSSettings Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSSettings Methods

The IEdMapFLSSettings type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Validates all the settings
Top
See Also

Reference

IEdMapFLSSettings Interface
OINA.Extender.Processing.Ed Namespace


IEdMapFLSSettings.Validate Method

Validates all the settings

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IValidationResults Validate()
Function Validate As IValidationResults
IValidationResults^ Validate()
abstract Validate : unit -> IValidationResults

Return Value

Type: IValidationResults
The validation results
See Also

Reference

IEdMapFLSSettings Interface
OINA.Extender.Processing.Ed Namespace


IEdMapProcessing Interface

Ed map processing interface.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdMapProcessing
Public Interface IEdMapProcessing
public interface class IEdMapProcessing
type IEdMapProcessing =  interface end

The IEdMapProcessing type exposes the following members.

Methods
 | Name | Description
Public method | ReconstructSpectrum | Reconstructs an Ed spectrum from an Ed map
Top
See Also

Reference

OINA.Extender.Processing.Ed Namespace


IEdMapProcessing Methods

The IEdMapProcessing type exposes the following members.

Methods
 | Name | Description
Public method | ReconstructSpectrum | Reconstructs an Ed spectrum from an Ed map
Top
See Also

Reference

IEdMapProcessing Interface
OINA.Extender.Processing.Ed Namespace


IEdMapProcessing.ReconstructSpectrum Method

Reconstructs an Ed spectrum from an Ed map

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEdSpectrum ReconstructSpectrum(
    IEdMapAcquisitionData edMapData
)
Function ReconstructSpectrum (
    edMapData As IEdMapAcquisitionData
) As IEdSpectrum
IEdSpectrum^ ReconstructSpectrum(
    IEdMapAcquisitionData^ edMapData
)
abstract ReconstructSpectrum :
        edMapData : IEdMapAcquisitionData -> IEdSpectrum

Parameters

edMapData
Type: OINA.Extender.Data.EdIEdMapAcquisitionData
The Ed map

Return Value

Type: IEdSpectrum
The reconstructed spectrum
See Also

Reference

IEdMapProcessing Interface
OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing Interface

An Interface that extracts information from a spectrum.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IEdSpectrumProcessing
Public Interface IEdSpectrumProcessing
public interface class IEdSpectrumProcessing
type IEdSpectrumProcessing =  interface end

The IEdSpectrumProcessing type exposes the following members.

Methods
 | Name | Description
Public method | CalculatePeakParameters | Calculate X-Ray peak parameters.
Public method | CreateBitmap | Export the spectrum as a bitmap.
Public method | CreateEMSAOutput | Create EMSA output of a spectrum.
Public method | CreateIexSpectrum | Saves a spectrum as an INCA (.iex) file. Note: Information may be lost for this conversion.
Public method | IdentifyElements | Identify elements in a spectrum.
Public method | SEMQuantifySpectrum | Quantify spectra acquired on SEMs.
Public method | UpdateKnownElements | Update known elements in a spectrum.
Public method | UpdatePeakLabels(IEdSpectrum, IEnumerableInt32) | Update the spectrum peak labels, peak labels are default to element symbol.
Public method | UpdatePeakLabels(IEdSpectrum, IEnumerableInt32, PeakLabelFormat) | Update the spectrum peak labels.
Top
Examples
Copy
/// <summary>
/// Do AutoID
/// </summary>
private void DoAutoID()
{
    Console.WriteLine(@"AutoId - Identify elements.");

    IEdSpectrumProcessing edSpectrumProcessing = ProcessingFactory.CreateSpectrumProcessing();

    // Use the autoIdSettings to define elements that are known or elements that you want to exclude. They also list elements that cannot be identified
    IAutoIdSettings autoIdSettings = ProcessingFactory.CreateAutoIdSettings();

    IEnumerable<int> elementList = edSpectrumProcessing.IdentifyElements(this.edSpectrum, autoIdSettings);

    foreach (int i in elementList)
    {
        Console.WriteLine(@"    Identified Element: {0} - {1}", i, ElementProperties.GetElementSymbol(i));
    }
}

/// <summary>
/// Do quantitative processing
/// </summary>
private void DoQuant()
{
    ISEMQuantSettings semQuantSettings = ProcessingFactory.CreateSEMQuantSettings();

    // Processing Options:
    // AllElements - all elements yield X-rays that can be readily detected and are included.
    // ElementByDifference - The concentration of the CombinedElement is the difference between the analysed total and 100%
    // ElementByStoichiometry - The concentration of the CombinedElement is determined by its stoichiometry.
    switch (this.userProcessingOption)
    {
        case 1:
            semQuantSettings.ProcessingOption = ProcessingOption.AllElements;
            break;
        case 2:
            semQuantSettings.ProcessingOption = ProcessingOption.ElementByDifference;
            break;
        case 3:
            semQuantSettings.ProcessingOption = ProcessingOption.ElementByStoichiometry;
            break;
    }

    // Use chosen processing option
    switch (semQuantSettings.ProcessingOption)
    {
        case ProcessingOption.ElementByDifference:
            semQuantSettings.CombinedElement = 8; // Oxygen
            break;
        case ProcessingOption.ElementByStoichiometry:
            semQuantSettings.CombinedElement = 8; // Oxygen
            semQuantSettings.TypeOfIon = IonType.Anion;

            // Set the number of [CombinedElement] ions that are combined stoichiometrically to the other elements.
            // The calculations are based on the number of [CombinedElement] ions and how many atoms there are in each unit cell.
            semQuantSettings.NumberOfIons = 3;
            break;
        case ProcessingOption.AllElements:
        default:
            break;
    }

    // Specimens are sometimes coated with a thin conductive layer prior to observation in the SEM
    // to ensure that there is a good electrical path to ground. This prevents non-conducting specimens,
    // as well as the oxides which are present on the surface of many samples, from charging under the electron beam.
    bool isCoated = false;
    if (isCoated)
    {
        semQuantSettings.SampleCoating.IsCoated = true;
        semQuantSettings.SampleCoating.CoatingElement = 6; // Carbon
        semQuantSettings.SampleCoating.Thickness = 10;
        semQuantSettings.SampleCoating.Density = 2.25;
    }
    else
    {
        semQuantSettings.SampleCoating.IsCoated = false;
    }

    // Quantitative results are displayed with +/- value which is one sigma (standard deviation)
    // based on counting statistics. Typically, results which are less than 3 sigma have reduced significance
    // and so it may be desirable to set them to zero. Thresholding may be applied so
    // that results below the selected sigmas are set to zero. Thresholding will also ensure that
    // negative insignificant values, which sometimes result from trace element analysis, are set to zero.
    bool thresholding = false;
    if (thresholding)
    {
        semQuantSettings.Thresholding = true;
        semQuantSettings.SigmaLevel = 3.0;
    }
    else
    {
        semQuantSettings.Thresholding = false;
    }

    // When the spectrum is normalized the analytical total of an analysis is forced to 100%.
    // Use of this needs care in interpreting the final result since if, for example, the element list is
    // incomplete, there will be serious errors in the result, even though the total is 100%.
    semQuantSettings.Normalised = true;

    // Deconvolution elements may be used to select elements present in the spectrum that
    // should not be quantified, but whose influence needs to be accounted for when processing
    // the spectral data. For example elements present in an oxidation layer, or in a substrate
    // layer.
    bool deconvolution = false;
    if (deconvolution)
    {
        semQuantSettings.SetDeconvolutionElement(25, true); // Manganese
    }

    try
    {
        // Get the status of the quantification analysis
        ISEMQuantStatus quantStatus = ProcessingFactory.CreateSpectrumProcessing().SEMQuantifySpectrum(this.edSpectrum, semQuantSettings);

        Console.WriteLine();
        Console.WriteLine(@"Quantification status:");
        Console.WriteLine(@"{0} - {1}", quantStatus.Status, quantStatus.StatusMessage);

        Console.WriteLine();
        Console.WriteLine(@"Quantification Results:");

        double totalWeightPercent = 0;
        double totalAtomicPercent = 0;
        foreach (ISEMQuantResult result in quantStatus.Results)
        {
            Console.WriteLine(
                @"    Element: {0}, Line: {1}, Weight Percent: {2:0.00}, Weight Percent Sigma: {3:0.000000}, AtomicPercent: {4:0.00}",
                result.AtomicNumber == 0 ? @"-" : ElementProperties.GetElementSymbol(result.AtomicNumber),
                result.LineType,
                result.WeightPercent,
                result.WeightPercentSigma,
                result.AtomicPercent);

            totalWeightPercent += result.WeightPercent;
            totalAtomicPercent += result.AtomicPercent;
        }

        // If element by difference, output the element details
        if (semQuantSettings.ProcessingOption == ProcessingOption.ElementByDifference)
        {
            Console.WriteLine();
            Console.WriteLine(@"Element by Difference/Stoichiometry:");
            Console.WriteLine(
                @"    Element: {0}, Weight Percent: {1:0.00}, Atomic Percent: {2:0.00}",
                ElementProperties.GetElementSymbol(semQuantSettings.CombinedElement),
                100 - totalWeightPercent,
                100 - totalAtomicPercent);

            totalWeightPercent = 100.0;
            totalAtomicPercent = 100.0;
        }

        Console.WriteLine();
        Console.WriteLine(@"Element Totals:");
        Console.WriteLine(
            @"  Weight Percent: {0:00}, Atomic Percent: {1:0.00}",
            totalWeightPercent,
            totalAtomicPercent);
    }
    catch (QuantificationException ex)
    {
        Console.WriteLine();
        Console.WriteLine(@"Quantification Error: {0}", ex.Message);
    }
    catch (ArgumentNullException ex)
    {
        Console.WriteLine();
        Console.WriteLine(@"ArgumentNullException: {0}", ex.Message);
    }
}
See Also

Reference

OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing Methods

The IEdSpectrumProcessing type exposes the following members.

Methods
 | Name | Description
Public method | CalculatePeakParameters | Calculate X-Ray peak parameters.
Public method | CreateBitmap | Export the spectrum as a bitmap.
Public method | CreateEMSAOutput | Create EMSA output of a spectrum.
Public method | CreateIexSpectrum | Saves a spectrum as an INCA (.iex) file. Note: Information may be lost for this conversion.
Public method | IdentifyElements | Identify elements in a spectrum.
Public method | SEMQuantifySpectrum | Quantify spectra acquired on SEMs.
Public method | UpdateKnownElements | Update known elements in a spectrum.
Public method | UpdatePeakLabels(IEdSpectrum, IEnumerableInt32) | Update the spectrum peak labels, peak labels are default to element symbol.
Public method | UpdatePeakLabels(IEdSpectrum, IEnumerableInt32, PeakLabelFormat) | Update the spectrum peak labels.
Top
See Also

Reference

IEdSpectrumProcessing Interface
OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing.CalculatePeakParameters Method

Calculate X-Ray peak parameters.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IPeakParameters CalculatePeakParameters(
    IEdSpectrum edSpectrum,
    int atomicNumber
)
Function CalculatePeakParameters (
    edSpectrum As IEdSpectrum,
    atomicNumber As Integer
) As IPeakParameters
IPeakParameters^ CalculatePeakParameters(
    IEdSpectrum^ edSpectrum,
    int atomicNumber
)
abstract CalculatePeakParameters :
        edSpectrum : IEdSpectrum *
        atomicNumber : int -> IPeakParameters

Parameters

edSpectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The spectrum
atomicNumber
Type: SystemInt32
The atomic number

Return Value

Type: IPeakParameters
The peak parameters
See Also

Reference

IEdSpectrumProcessing Interface
OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing.CreateBitmap Method

Export the spectrum as a bitmap.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Bitmap CreateBitmap(
    IEdSpectrum spectrum,
    short width,
    short height
)
Function CreateBitmap (
    spectrum As IEdSpectrum,
    width As Short,
    height As Short
) As Bitmap
Bitmap^ CreateBitmap(
    IEdSpectrum^ spectrum,
    short width,
    short height
)
abstract CreateBitmap :
        spectrum : IEdSpectrum *
        width : int16 *
        height : int16 -> Bitmap

Parameters

spectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The spectrum
width
Type: SystemInt16
The width of image
height
Type: SystemInt16
The height of image

Return Value

Type: Bitmap
The exported spectrum bitmap
See Also

Reference

IEdSpectrumProcessing Interface
OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing.CreateEMSAOutput Method

Create EMSA output of a spectrum.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string CreateEMSAOutput(
    IEdSpectrum edSpectrum
)
Function CreateEMSAOutput (
    edSpectrum As IEdSpectrum
) As String
String^ CreateEMSAOutput(
    IEdSpectrum^ edSpectrum
)
abstract CreateEMSAOutput :
        edSpectrum : IEdSpectrum -> string

Parameters

edSpectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The spectrum

Return Value

Type: String
A string contains EMSA information
See Also

Reference

IEdSpectrumProcessing Interface
OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing.CreateIexSpectrum Method

Saves a spectrum as an INCA (.iex) file. Note: Information may be lost for this conversion.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void CreateIexSpectrum(
    string fileName,
    IEdSpectrum edSpectrum
)
Sub CreateIexSpectrum (
    fileName As String,
    edSpectrum As IEdSpectrum
)
void CreateIexSpectrum(
    String^ fileName,
    IEdSpectrum^ edSpectrum
)
abstract CreateIexSpectrum :
        fileName : string *
        edSpectrum : IEdSpectrum -> unit

Parameters

fileName
Type: SystemString
The path and file name of the iex file
edSpectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The spectrum
See Also

Reference

IEdSpectrumProcessing Interface
OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing.IdentifyElements Method

Identify elements in a spectrum.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEnumerable<int> IdentifyElements(
    IEdSpectrum edSpectrum,
    IAutoIdSettings autoIdSettings
)
Function IdentifyElements (
    edSpectrum As IEdSpectrum,
    autoIdSettings As IAutoIdSettings
) As IEnumerable(Of Integer)
IEnumerable<int>^ IdentifyElements(
    IEdSpectrum^ edSpectrum,
    IAutoIdSettings^ autoIdSettings
)
abstract IdentifyElements :
        edSpectrum : IEdSpectrum *
        autoIdSettings : IAutoIdSettings -> IEnumerable<int>

Parameters

edSpectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The spectrum
autoIdSettings
Type: OINA.Extender.ProcessingIAutoIdSettings
The AutoId settings

Return Value

Type: IEnumerable Int32
Returns atomic number of identified elements, or an empty list if the quant information is invalid
See Also

Reference

IEdSpectrumProcessing Interface
OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing.SEMQuantifySpectrum Method

Quantify spectra acquired on SEMs.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ISEMQuantStatus SEMQuantifySpectrum(
    IEdSpectrum edSpectrum,
    ISEMQuantSettings settings
)
Function SEMQuantifySpectrum (
    edSpectrum As IEdSpectrum,
    settings As ISEMQuantSettings
) As ISEMQuantStatus
ISEMQuantStatus^ SEMQuantifySpectrum(
    IEdSpectrum^ edSpectrum,
    ISEMQuantSettings^ settings
)
abstract SEMQuantifySpectrum :
        edSpectrum : IEdSpectrum *
        settings : ISEMQuantSettings -> ISEMQuantStatus

Parameters

edSpectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The spectrum
settings
Type: OINA.Extender.Processing.QuantISEMQuantSettings
The quant settings

Return Value

Type: ISEMQuantStatus
The SEM Quant results
Exceptions
Exception | Condition
ArgumentNullException | @edSpectrum;@Spectrum can not be null or @settings;@Settings can not be null
QuantificationException |
See Also

Reference

IEdSpectrumProcessing Interface
OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing.UpdateKnownElements Method

Update known elements in a spectrum.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void UpdateKnownElements(
    IEdSpectrum edSpectrum,
    IAutoIdSettings autoIdSettings
)
Sub UpdateKnownElements (
    edSpectrum As IEdSpectrum,
    autoIdSettings As IAutoIdSettings
)
void UpdateKnownElements(
    IEdSpectrum^ edSpectrum,
    IAutoIdSettings^ autoIdSettings
)
abstract UpdateKnownElements :
        edSpectrum : IEdSpectrum *
        autoIdSettings : IAutoIdSettings -> unit

Parameters

edSpectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The spectrum
autoIdSettings
Type: OINA.Extender.ProcessingIAutoIdSettings
the AutoId settings
See Also

Reference

IEdSpectrumProcessing Interface
OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing.UpdatePeakLabels Method

Overload List
 | Name | Description
Public method | UpdatePeakLabels(IEdSpectrum, IEnumerableInt32) | Update the spectrum peak labels, peak labels are default to element symbol.
Public method | UpdatePeakLabels(IEdSpectrum, IEnumerableInt32, PeakLabelFormat) | Update the spectrum peak labels.
Top
See Also

Reference

IEdSpectrumProcessing Interface
OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing.UpdatePeakLabels Method (IEdSpectrum, IEnumerable(Int32))

Update the spectrum peak labels, peak labels are default to element symbol.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void UpdatePeakLabels(
    IEdSpectrum edSpectrum,
    IEnumerable<int> atomicNumbersToIgnore
)
Sub UpdatePeakLabels (
    edSpectrum As IEdSpectrum,
    atomicNumbersToIgnore As IEnumerable(Of Integer)
)
void UpdatePeakLabels(
    IEdSpectrum^ edSpectrum,
    IEnumerable<int>^ atomicNumbersToIgnore
)
abstract UpdatePeakLabels :
        edSpectrum : IEdSpectrum *
        atomicNumbersToIgnore : IEnumerable<int> -> unit

Parameters

edSpectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The spectrum
atomicNumbersToIgnore
Type: System.Collections.GenericIEnumerable Int32
List of elements not to be labelled.
See Also

Reference

IEdSpectrumProcessing Interface
UpdatePeakLabels Overload
OINA.Extender.Processing.Ed Namespace


IEdSpectrumProcessing.UpdatePeakLabels Method (IEdSpectrum, IEnumerable(Int32), PeakLabelFormat)

Update the spectrum peak labels.

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void UpdatePeakLabels(
    IEdSpectrum edSpectrum,
    IEnumerable<int> atomicNumbersToIgnore,
    PeakLabelFormat peakLabelFormat
)
Sub UpdatePeakLabels (
    edSpectrum As IEdSpectrum,
    atomicNumbersToIgnore As IEnumerable(Of Integer),
    peakLabelFormat As PeakLabelFormat
)
void UpdatePeakLabels(
    IEdSpectrum^ edSpectrum,
    IEnumerable<int>^ atomicNumbersToIgnore,
    PeakLabelFormat peakLabelFormat
)
abstract UpdatePeakLabels :
        edSpectrum : IEdSpectrum *
        atomicNumbersToIgnore : IEnumerable<int> *
        peakLabelFormat : PeakLabelFormat -> unit

Parameters

edSpectrum
Type: OINA.Extender.Data.EdIEdSpectrum
The spectrum
atomicNumbersToIgnore
Type: System.Collections.GenericIEnumerable Int32
List of elements not to be labelled.
peakLabelFormat
Type: OINA.Extender.Processing.EdPeakLabelFormat
The peak label format.
See Also

Reference

IEdSpectrumProcessing Interface
UpdatePeakLabels Overload
OINA.Extender.Processing.Ed Namespace


PeakLabelFormat Enumeration

[Missing <summary> documentation for "T:OINA.Extender.Processing.Ed.PeakLabelFormat"]

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum PeakLabelFormat
Public Enumeration PeakLabelFormat
public enum class PeakLabelFormat
type PeakLabelFormat
Members
Member name | Value | Description
Symbol | 0 | Displays element Symbol.
ElementName | 1 | Displays the element name.
SymbolAndLineCode | 2 | Displays the element symbol and line code
See Also

Reference

OINA.Extender.Processing.Ed Namespace


ProcessingProgressEventArgs Class

Class that provides progress for the processing map
Inheritance Hierarchy
SystemObject
SystemEventArgs
OINA.Extender.Processing.EdProcessingProgressEventArgs

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public class ProcessingProgressEventArgs : EventArgs
Public Class ProcessingProgressEventArgs
    Inherits EventArgs
public ref class ProcessingProgressEventArgs : public EventArgs
type ProcessingProgressEventArgs =
    class
        inherit EventArgs
    end

The ProcessingProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessingProgressEventArgs | Initializes a new instance of the ProcessingProgressEventArgs class
Top
Properties
 | Name | Description
Public property | Id | Gets the id of the processing map
Public property | ProgressPercentage | Gets the progress percentage (0 - 100);
Public property | State | Gets the progress state
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OINA.Extender.Processing.Ed Namespace


ProcessingProgressEventArgs Constructor

Initializes a new instance of the ProcessingProgressEventArgs class

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ProcessingProgressEventArgs(
    Guid id,
    double progressPercentage,
    ProcessingProgressState state
)
Public Sub New (
    id As Guid,
    progressPercentage As Double,
    state As ProcessingProgressState
)
public:
ProcessingProgressEventArgs(
    Guid id,
    double progressPercentage,
    ProcessingProgressState state
)
new :
        id : Guid *
        progressPercentage : float *
        state : ProcessingProgressState -> ProcessingProgressEventArgs

Parameters

id
Type: SystemGuid
The id of the processing map
progressPercentage
Type: SystemDouble
The progress percentage (0 - 100)
state
Type: OINA.Extender.Processing.EdProcessingProgressState
The progress state
See Also

Reference

ProcessingProgressEventArgs Class
OINA.Extender.Processing.Ed Namespace


ProcessingProgressEventArgs Properties

The ProcessingProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the id of the processing map
Public property | ProgressPercentage | Gets the progress percentage (0 - 100);
Public property | State | Gets the progress state
Top
See Also

Reference

ProcessingProgressEventArgs Class
OINA.Extender.Processing.Ed Namespace


ProcessingProgressEventArgs.Id Property

Gets the id of the processing map

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}
member Id : Guid with get

Property Value

Type: Guid
See Also

Reference

ProcessingProgressEventArgs Class
OINA.Extender.Processing.Ed Namespace


ProcessingProgressEventArgs.ProgressPercentage Property

Gets the progress percentage (0 - 100);

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public double ProgressPercentage { get; }
Public ReadOnly Property ProgressPercentage As Double
    Get
public:
property double ProgressPercentage {
    double get ();
}
member ProgressPercentage : float with get

Property Value

Type: Double
See Also

Reference

ProcessingProgressEventArgs Class
OINA.Extender.Processing.Ed Namespace


ProcessingProgressEventArgs.State Property

Gets the progress state

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public ProcessingProgressState State { get; }
Public ReadOnly Property State As ProcessingProgressState
    Get
public:
property ProcessingProgressState State {
    ProcessingProgressState get ();
}
member State : ProcessingProgressState with get

Property Value

Type: ProcessingProgressState
See Also

Reference

ProcessingProgressEventArgs Class
OINA.Extender.Processing.Ed Namespace


ProcessingProgressEventArgs Methods

The ProcessingProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProcessingProgressEventArgs Class
OINA.Extender.Processing.Ed Namespace


ProcessingProgressState Enumeration

Identifies the processing progress state

Namespace: OINA.Extender.Processing.Ed
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum ProcessingProgressState
Public Enumeration ProcessingProgressState
public enum class ProcessingProgressState
type ProcessingProgressState
Members
Member name | Value | Description
Unknown | 0 | Processing state is unknown
Processing | 1 | Processing is in progress
Completed | 2 | Processing is completed
See Also

Reference

OINA.Extender.Processing.Ed Namespace


OINA.Extender.Processing.Quant Namespace

Defines Classes and Interfaces used to process Ed data for quantification.

Classes
 | Class | Description
Public class | QuantificationException | Represents a Quantification Exception
Interfaces
 | Interface | Description
Public interface | IPixelSEMQuantStatus | An Interface that defines the status of a per-pixel Quant measurement on a SEM.
Public interface | ISEMQuantCapabilities | An Interface that defines the capabilities for performing Quant on a SEM.
Public interface | ISEMQuantResult | An Interface that defines the result of Quant performed on a SEM.
 | ISEMQuantSettings | An Interface that defines the settings for performing Quant on a SEM.
 | ISEMQuantStatus | An Interface that defines the status of a Quant measurement on a SEM.
Enumerations
 | Enumeration | Description
Public enumeration | ElementListType | Quantification element list option.
Public enumeration | IonType | Types of ion.
Public enumeration | ProcessingOption | Quantification processing option.
Public enumeration | QuantAnalysisStatus | Status of quantification analysis.
Public enumeration | QuantLineCode | Identifies X-Ray lines used for quantification.


ElementListType Enumeration

Quantification element list option.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum ElementListType
Public Enumeration ElementListType
public enum class ElementListType
type ElementListType
Members
Member name | Value | Description
CurrentSpectrum | 0 | Quant processing uses the IdentifiedElements from the IEdSpectrum
Fixed | 1 | Quant processing uses the elements set in the ISEMQuantSettings
FixedAndCurrentSpectrum | 2 | Quant processing uses the IdentifiedElements from the IEdSpectrum and the elements set in the ISEMQuantSettings
See Also

Reference

OINA.Extender.Processing.Quant Namespace


IonType Enumeration

Types of ion.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum IonType
Public Enumeration IonType
public enum class IonType
type IonType
Members
Member name | Value | Description
Null | 0 | Ion Type is not set.
Anion | 1 | Anion (negative).
Cation | 2 | Cation (positive).
See Also

Reference

OINA.Extender.Processing.Quant Namespace


IPixelSEMQuantStatus Interface

An Interface that defines the status of a per-pixel Quant measurement on a SEM.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface IPixelSEMQuantStatus
Public Interface IPixelSEMQuantStatus
public interface class IPixelSEMQuantStatus
type IPixelSEMQuantStatus =  interface end

The IPixelSEMQuantStatus type exposes the following members.

Properties
 | Name | Description
Public property | ChordListId | Gets the ID of the associated chordlist.
Public property | PixelX | Gets the pixel X position.
Public property | PixelY | Gets the pixel Y position.
Public property | QuantStatus | Gets the quantification status.
Public property | TotalNumberOfCounts | Gets the total number of counts in the spectrum.
Top
See Also

Reference

OINA.Extender.Processing.Quant Namespace


IPixelSEMQuantStatus Properties

The IPixelSEMQuantStatus type exposes the following members.

Properties
 | Name | Description
Public property | ChordListId | Gets the ID of the associated chordlist.
Public property | PixelX | Gets the pixel X position.
Public property | PixelY | Gets the pixel Y position.
Public property | QuantStatus | Gets the quantification status.
Public property | TotalNumberOfCounts | Gets the total number of counts in the spectrum.
Top
See Also

Reference

IPixelSEMQuantStatus Interface
OINA.Extender.Processing.Quant Namespace


IPixelSEMQuantStatus.ChordListId Property

Gets the ID of the associated chordlist.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
Guid ChordListId { get; }
ReadOnly Property ChordListId As Guid
    Get
property Guid ChordListId {
    Guid get ();
}
abstract ChordListId : Guid with get

Property Value

Type: Guid
The chordlist ID.
See Also

Reference

IPixelSEMQuantStatus Interface
OINA.Extender.Processing.Quant Namespace


IPixelSEMQuantStatus.PixelX Property

Gets the pixel X position.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int PixelX { get; }
ReadOnly Property PixelX As Integer
    Get
property int PixelX {
    int get ();
}
abstract PixelX : int with get

Property Value

Type: Int32
The pixel Y position.
See Also

Reference

IPixelSEMQuantStatus Interface
OINA.Extender.Processing.Quant Namespace


IPixelSEMQuantStatus.PixelY Property

Gets the pixel Y position.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int PixelY { get; }
ReadOnly Property PixelY As Integer
    Get
property int PixelY {
    int get ();
}
abstract PixelY : int with get

Property Value

Type: Int32
The pixel Y position.
See Also

Reference

IPixelSEMQuantStatus Interface
OINA.Extender.Processing.Quant Namespace


IPixelSEMQuantStatus.QuantStatus Property

Gets the quantification status.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ISEMQuantStatus QuantStatus { get; }
ReadOnly Property QuantStatus As ISEMQuantStatus
    Get
property ISEMQuantStatus^ QuantStatus {
    ISEMQuantStatus^ get ();
}
abstract QuantStatus : ISEMQuantStatus with get

Property Value

Type: ISEMQuantStatus
The quantification status.
See Also

Reference

IPixelSEMQuantStatus Interface
OINA.Extender.Processing.Quant Namespace


IPixelSEMQuantStatus.TotalNumberOfCounts Property

Gets the total number of counts in the spectrum.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int TotalNumberOfCounts { get; }
ReadOnly Property TotalNumberOfCounts As Integer
    Get
property int TotalNumberOfCounts {
    int get ();
}
abstract TotalNumberOfCounts : int with get

Property Value

Type: Int32
The total number of counts.
See Also

Reference

IPixelSEMQuantStatus Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantCapabilities Interface

An Interface that defines the capabilities for performing Quant on a SEM.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface ISEMQuantCapabilities : INotifyPropertyChanged
Public Interface ISEMQuantCapabilities
    Inherits INotifyPropertyChanged
public interface class ISEMQuantCapabilities : INotifyPropertyChanged
type ISEMQuantCapabilities =
    interface
        interface INotifyPropertyChanged
    end

The ISEMQuantCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | DefaultStandardizationFiles | Gets the available default standardization files.
Public property | MaximumCombinedElementAtomicNumber | Gets the maximum combined element atomic number.
Public property | MaximumNumberOfDeconvolvedElements | Gets the maximum number of deconvolved elements.
Public property | MaximumSigma | Gets the maximum sigma.
Public property | MinimumCombinedElementAtomicNumber | Gets the minimum combined element atomic number.
Public property | MinimumSigma | Gets the minimum sigma.
Public property | UserStandardizationFiles | Gets the available user standardization files.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

OINA.Extender.Processing.Quant Namespace


ISEMQuantCapabilities Properties

The ISEMQuantCapabilities type exposes the following members.

Properties
 | Name | Description
Public property | DefaultStandardizationFiles | Gets the available default standardization files.
Public property | MaximumCombinedElementAtomicNumber | Gets the maximum combined element atomic number.
Public property | MaximumNumberOfDeconvolvedElements | Gets the maximum number of deconvolved elements.
Public property | MaximumSigma | Gets the maximum sigma.
Public property | MinimumCombinedElementAtomicNumber | Gets the minimum combined element atomic number.
Public property | MinimumSigma | Gets the minimum sigma.
Public property | UserStandardizationFiles | Gets the available user standardization files.
Top
See Also

Reference

ISEMQuantCapabilities Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantCapabilities.DefaultStandardizationFiles Property

Gets the available default standardization files.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IReadOnlyList<string> DefaultStandardizationFiles { get; }
ReadOnly Property DefaultStandardizationFiles As IReadOnlyList(Of String)
    Get
property IReadOnlyList<String^>^ DefaultStandardizationFiles {
    IReadOnlyList<String^>^ get ();
}
abstract DefaultStandardizationFiles : IReadOnlyList<string> with get

Property Value

Type: IReadOnlyList String
See Also

Reference

ISEMQuantCapabilities Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantCapabilities.MaximumCombinedElementAtomicNumber Property

Gets the maximum combined element atomic number.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MaximumCombinedElementAtomicNumber { get; }
ReadOnly Property MaximumCombinedElementAtomicNumber As Integer
    Get
property int MaximumCombinedElementAtomicNumber {
    int get ();
}
abstract MaximumCombinedElementAtomicNumber : int with get

Property Value

Type: Int32
See Also

Reference

ISEMQuantCapabilities Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantCapabilities.MaximumNumberOfDeconvolvedElements Property

Gets the maximum number of deconvolved elements.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MaximumNumberOfDeconvolvedElements { get; }
ReadOnly Property MaximumNumberOfDeconvolvedElements As Integer
    Get
property int MaximumNumberOfDeconvolvedElements {
    int get ();
}
abstract MaximumNumberOfDeconvolvedElements : int with get

Property Value

Type: Int32
See Also

Reference

ISEMQuantCapabilities Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantCapabilities.MaximumSigma Property

Gets the maximum sigma.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MaximumSigma { get; }
ReadOnly Property MaximumSigma As Double
    Get
property double MaximumSigma {
    double get ();
}
abstract MaximumSigma : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantCapabilities Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantCapabilities.MinimumCombinedElementAtomicNumber Property

Gets the minimum combined element atomic number.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int MinimumCombinedElementAtomicNumber { get; }
ReadOnly Property MinimumCombinedElementAtomicNumber As Integer
    Get
property int MinimumCombinedElementAtomicNumber {
    int get ();
}
abstract MinimumCombinedElementAtomicNumber : int with get

Property Value

Type: Int32
See Also

Reference

ISEMQuantCapabilities Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantCapabilities.MinimumSigma Property

Gets the minimum sigma.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double MinimumSigma { get; }
ReadOnly Property MinimumSigma As Double
    Get
property double MinimumSigma {
    double get ();
}
abstract MinimumSigma : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantCapabilities Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantCapabilities.UserStandardizationFiles Property

Gets the available user standardization files.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IReadOnlyList<string> UserStandardizationFiles { get; }
ReadOnly Property UserStandardizationFiles As IReadOnlyList(Of String)
    Get
property IReadOnlyList<String^>^ UserStandardizationFiles {
    IReadOnlyList<String^>^ get ();
}
abstract UserStandardizationFiles : IReadOnlyList<string> with get

Property Value

Type: IReadOnlyList String
See Also

Reference

ISEMQuantCapabilities Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantCapabilities Events

The ISEMQuantCapabilities type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ISEMQuantCapabilities Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult Interface

An Interface that defines the result of Quant performed on a SEM.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface ISEMQuantResult
Public Interface ISEMQuantResult
public interface class ISEMQuantResult
type ISEMQuantResult =  interface end

The ISEMQuantResult type exposes the following members.

Properties
 | Name | Description
Public property | ApparentConcentration | Gets the approximate weight percent of an element uncorrected for matrix effects.
Public property | ApparentConcentrationSigma | Gets the sigma value for the apparent concentration.
Public property | AtomicNumber | Gets the atomic number.
Public property | AtomicPercent | Gets the fractional concentration of an element in a sample by number of atoms as a percentage.
Public property | ChemicalFormula | Gets the chemical formula for the elements identified.
Public property | CompoundPercent | Gets the fractional concentration of a compound defined by a stoichiometric relationship in a sample as a percentage.
Public property | CompoundPercentSigma | Gets the sigma value for the compound percent.
Public property | IsCombinedElement | Gets a value indicating whether this element was used as the combined element in the Quant calculation.
Public property | IsQuantLine | Gets a value indicating whether this line was used in the Quant calculation.
Public property | KRatio | Gets the ratio of the intensity of an X-ray peak in a sample to that in a pure element.
Public property | LineEnergy | Gets the energy of the most intense line in keV
Public property | LineType | Gets the type of X-Ray line used to identify the element.
Public property | NumberOfIons | Gets the number of ions.
Public property | PeakArea | Gets the peak area.
Public property | PeakAreaSigma | Gets the sigma value for the peak area.
Public property | WeightPercent | Gets the fractional concentration of an element in a sample by weight as a percentage.
Public property | WeightPercentSigma | Gets the sigma value for the weight percent.
Top
See Also

Reference

OINA.Extender.Processing.Quant Namespace


ISEMQuantResult Properties

The ISEMQuantResult type exposes the following members.

Properties
 | Name | Description
Public property | ApparentConcentration | Gets the approximate weight percent of an element uncorrected for matrix effects.
Public property | ApparentConcentrationSigma | Gets the sigma value for the apparent concentration.
Public property | AtomicNumber | Gets the atomic number.
Public property | AtomicPercent | Gets the fractional concentration of an element in a sample by number of atoms as a percentage.
Public property | ChemicalFormula | Gets the chemical formula for the elements identified.
Public property | CompoundPercent | Gets the fractional concentration of a compound defined by a stoichiometric relationship in a sample as a percentage.
Public property | CompoundPercentSigma | Gets the sigma value for the compound percent.
Public property | IsCombinedElement | Gets a value indicating whether this element was used as the combined element in the Quant calculation.
Public property | IsQuantLine | Gets a value indicating whether this line was used in the Quant calculation.
Public property | KRatio | Gets the ratio of the intensity of an X-ray peak in a sample to that in a pure element.
Public property | LineEnergy | Gets the energy of the most intense line in keV
Public property | LineType | Gets the type of X-Ray line used to identify the element.
Public property | NumberOfIons | Gets the number of ions.
Public property | PeakArea | Gets the peak area.
Public property | PeakAreaSigma | Gets the sigma value for the peak area.
Public property | WeightPercent | Gets the fractional concentration of an element in a sample by weight as a percentage.
Public property | WeightPercentSigma | Gets the sigma value for the weight percent.
Top
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.ApparentConcentration Property

Gets the approximate weight percent of an element uncorrected for matrix effects.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double ApparentConcentration { get; }
ReadOnly Property ApparentConcentration As Double
    Get
property double ApparentConcentration {
    double get ();
}
abstract ApparentConcentration : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.ApparentConcentrationSigma Property

Gets the sigma value for the apparent concentration.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double ApparentConcentrationSigma { get; }
ReadOnly Property ApparentConcentrationSigma As Double
    Get
property double ApparentConcentrationSigma {
    double get ();
}
abstract ApparentConcentrationSigma : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.AtomicNumber Property

Gets the atomic number.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int AtomicNumber { get; }
ReadOnly Property AtomicNumber As Integer
    Get
property int AtomicNumber {
    int get ();
}
abstract AtomicNumber : int with get

Property Value

Type: Int32
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.AtomicPercent Property

Gets the fractional concentration of an element in a sample by number of atoms as a percentage.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double AtomicPercent { get; }
ReadOnly Property AtomicPercent As Double
    Get
property double AtomicPercent {
    double get ();
}
abstract AtomicPercent : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.ChemicalFormula Property

Gets the chemical formula for the elements identified.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string ChemicalFormula { get; }
ReadOnly Property ChemicalFormula As String
    Get
property String^ ChemicalFormula {
    String^ get ();
}
abstract ChemicalFormula : string with get

Property Value

Type: String
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.CompoundPercent Property

Gets the fractional concentration of a compound defined by a stoichiometric relationship in a sample as a percentage.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double CompoundPercent { get; }
ReadOnly Property CompoundPercent As Double
    Get
property double CompoundPercent {
    double get ();
}
abstract CompoundPercent : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.CompoundPercentSigma Property

Gets the sigma value for the compound percent.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double CompoundPercentSigma { get; }
ReadOnly Property CompoundPercentSigma As Double
    Get
property double CompoundPercentSigma {
    double get ();
}
abstract CompoundPercentSigma : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.IsCombinedElement Property

Gets a value indicating whether this element was used as the combined element in the Quant calculation.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsCombinedElement { get; }
ReadOnly Property IsCombinedElement As Boolean
    Get
property bool IsCombinedElement {
    bool get ();
}
abstract IsCombinedElement : bool with get

Property Value

Type: Boolean
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.IsQuantLine Property

Gets a value indicating whether this line was used in the Quant calculation.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool IsQuantLine { get; }
ReadOnly Property IsQuantLine As Boolean
    Get
property bool IsQuantLine {
    bool get ();
}
abstract IsQuantLine : bool with get

Property Value

Type: Boolean
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.KRatio Property

Gets the ratio of the intensity of an X-ray peak in a sample to that in a pure element.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double KRatio { get; }
ReadOnly Property KRatio As Double
    Get
property double KRatio {
    double get ();
}
abstract KRatio : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.LineEnergy Property

Gets the energy of the most intense line in keV

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double LineEnergy { get; }
ReadOnly Property LineEnergy As Double
    Get
property double LineEnergy {
    double get ();
}
abstract LineEnergy : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.LineType Property

Gets the type of X-Ray line used to identify the element.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
QuantLineCode LineType { get; }
ReadOnly Property LineType As QuantLineCode
    Get
property QuantLineCode LineType {
    QuantLineCode get ();
}
abstract LineType : QuantLineCode with get

Property Value

Type: QuantLineCode
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.NumberOfIons Property

Gets the number of ions.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double NumberOfIons { get; }
ReadOnly Property NumberOfIons As Double
    Get
property double NumberOfIons {
    double get ();
}
abstract NumberOfIons : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.PeakArea Property

Gets the peak area.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double PeakArea { get; }
ReadOnly Property PeakArea As Double
    Get
property double PeakArea {
    double get ();
}
abstract PeakArea : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.PeakAreaSigma Property

Gets the sigma value for the peak area.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double PeakAreaSigma { get; }
ReadOnly Property PeakAreaSigma As Double
    Get
property double PeakAreaSigma {
    double get ();
}
abstract PeakAreaSigma : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.WeightPercent Property

Gets the fractional concentration of an element in a sample by weight as a percentage.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double WeightPercent { get; }
ReadOnly Property WeightPercent As Double
    Get
property double WeightPercent {
    double get ();
}
abstract WeightPercent : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantResult.WeightPercentSigma Property

Gets the sigma value for the weight percent.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double WeightPercentSigma { get; }
ReadOnly Property WeightPercentSigma As Double
    Get
property double WeightPercentSigma {
    double get ();
}
abstract WeightPercentSigma : float with get

Property Value

Type: Double
See Also

Reference

ISEMQuantResult Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings Interface

An Interface that defines the settings for performing Quant on a SEM.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface ISEMQuantSettings : INotifyPropertyChanged
Public Interface ISEMQuantSettings
    Inherits INotifyPropertyChanged
public interface class ISEMQuantSettings : INotifyPropertyChanged
type ISEMQuantSettings =
    interface
        interface INotifyPropertyChanged
    end

The ISEMQuantSettings type exposes the following members.

Properties
 | Name | Description
Public property | Capabilities | Gets the capabilities.
Public property | CombinedElement | Gets or sets the combined element for ElementByDifference and ElementByStoichiometry calculations.
Public property | DeconvolutionElements | Gets the atomic numbers of deconvolution elements. Deconvolution elements are elements present in the spectrum that should not be quantified, but whose influence needs to be accounted for when processing the spectrum.
Public property | DefaultStandardizationsFile | Gets or sets the selected default standardizations file.
Public property | Elements | Gets the atomic numbers of elements included in a fixed list.
Public property | Normalised | Gets or sets a value indicating whether results are normalised.
Public property | NumberOfIons | Gets or sets the number of ions used with ElementByStoichiometry calculations.
Public property | ProcessingOption | Gets or sets the type of Quant calculation.
Public property | SampleCoating | Gets the sample coating.
Public property | SigmaLevel | Gets or sets the sigma level (number of standard deviations).
Public property | Thresholding | Gets or sets a value indicating whether quant lines below the sigma level are included in the calculation.
Public property | TypeOfElementList | Gets or sets the Element list type used in the quant calculations.
Public property | TypeOfIon | Gets or sets the Ion type for use with ElementByStoichiometry calculations.
Public property | UserStandardizationsFile | Gets or sets the selected user standardizations file (if any).
Top
Methods
 | Name | Description
Public method | ClearDeconvolutionElements | Clears the deconvolution elements.
Public method | ClearElements | Clears the fixed list of elements.
Public method | CopyFrom | Copies the settings from specified source.
Public method | GetValency | Gets the valency of the element for use with ElementByStoichiometry calculations.
Public method | SetDeconvolutionElement | Adds or removes an element from the list of deconvolution elements.
Public method | SetElement | Adds or removes an element from the fixed list of elements.
Public method | SetValency | Sets the valency of the element for use with ElementByStoichiometry calculations.
Public method | Validate | Validates the quant settings.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Examples
Copy
/// <summary>
/// Do AutoID
/// </summary>
private void DoAutoID()
{
    Console.WriteLine(@"AutoId - Identify elements.");

    IEdSpectrumProcessing edSpectrumProcessing = ProcessingFactory.CreateSpectrumProcessing();

    // Use the autoIdSettings to define elements that are known or elements that you want to exclude. They also list elements that cannot be identified
    IAutoIdSettings autoIdSettings = ProcessingFactory.CreateAutoIdSettings();

    IEnumerable<int> elementList = edSpectrumProcessing.IdentifyElements(this.edSpectrum, autoIdSettings);

    foreach (int i in elementList)
    {
        Console.WriteLine(@"    Identified Element: {0} - {1}", i, ElementProperties.GetElementSymbol(i));
    }
}

/// <summary>
/// Do quantitative processing
/// </summary>
private void DoQuant()
{
    ISEMQuantSettings semQuantSettings = ProcessingFactory.CreateSEMQuantSettings();

    // Processing Options:
    // AllElements - all elements yield X-rays that can be readily detected and are included.
    // ElementByDifference - The concentration of the CombinedElement is the difference between the analysed total and 100%
    // ElementByStoichiometry - The concentration of the CombinedElement is determined by its stoichiometry.
    switch (this.userProcessingOption)
    {
        case 1:
            semQuantSettings.ProcessingOption = ProcessingOption.AllElements;
            break;
        case 2:
            semQuantSettings.ProcessingOption = ProcessingOption.ElementByDifference;
            break;
        case 3:
            semQuantSettings.ProcessingOption = ProcessingOption.ElementByStoichiometry;
            break;
    }

    // Use chosen processing option
    switch (semQuantSettings.ProcessingOption)
    {
        case ProcessingOption.ElementByDifference:
            semQuantSettings.CombinedElement = 8; // Oxygen
            break;
        case ProcessingOption.ElementByStoichiometry:
            semQuantSettings.CombinedElement = 8; // Oxygen
            semQuantSettings.TypeOfIon = IonType.Anion;

            // Set the number of [CombinedElement] ions that are combined stoichiometrically to the other elements.
            // The calculations are based on the number of [CombinedElement] ions and how many atoms there are in each unit cell.
            semQuantSettings.NumberOfIons = 3;
            break;
        case ProcessingOption.AllElements:
        default:
            break;
    }

    // Specimens are sometimes coated with a thin conductive layer prior to observation in the SEM
    // to ensure that there is a good electrical path to ground. This prevents non-conducting specimens,
    // as well as the oxides which are present on the surface of many samples, from charging under the electron beam.
    bool isCoated = false;
    if (isCoated)
    {
        semQuantSettings.SampleCoating.IsCoated = true;
        semQuantSettings.SampleCoating.CoatingElement = 6; // Carbon
        semQuantSettings.SampleCoating.Thickness = 10;
        semQuantSettings.SampleCoating.Density = 2.25;
    }
    else
    {
        semQuantSettings.SampleCoating.IsCoated = false;
    }

    // Quantitative results are displayed with +/- value which is one sigma (standard deviation)
    // based on counting statistics. Typically, results which are less than 3 sigma have reduced significance
    // and so it may be desirable to set them to zero. Thresholding may be applied so
    // that results below the selected sigmas are set to zero. Thresholding will also ensure that
    // negative insignificant values, which sometimes result from trace element analysis, are set to zero.
    bool thresholding = false;
    if (thresholding)
    {
        semQuantSettings.Thresholding = true;
        semQuantSettings.SigmaLevel = 3.0;
    }
    else
    {
        semQuantSettings.Thresholding = false;
    }

    // When the spectrum is normalized the analytical total of an analysis is forced to 100%.
    // Use of this needs care in interpreting the final result since if, for example, the element list is
    // incomplete, there will be serious errors in the result, even though the total is 100%.
    semQuantSettings.Normalised = true;

    // Deconvolution elements may be used to select elements present in the spectrum that
    // should not be quantified, but whose influence needs to be accounted for when processing
    // the spectral data. For example elements present in an oxidation layer, or in a substrate
    // layer.
    bool deconvolution = false;
    if (deconvolution)
    {
        semQuantSettings.SetDeconvolutionElement(25, true); // Manganese
    }

    try
    {
        // Get the status of the quantification analysis
        ISEMQuantStatus quantStatus = ProcessingFactory.CreateSpectrumProcessing().SEMQuantifySpectrum(this.edSpectrum, semQuantSettings);

        Console.WriteLine();
        Console.WriteLine(@"Quantification status:");
        Console.WriteLine(@"{0} - {1}", quantStatus.Status, quantStatus.StatusMessage);

        Console.WriteLine();
        Console.WriteLine(@"Quantification Results:");

        double totalWeightPercent = 0;
        double totalAtomicPercent = 0;
        foreach (ISEMQuantResult result in quantStatus.Results)
        {
            Console.WriteLine(
                @"    Element: {0}, Line: {1}, Weight Percent: {2:0.00}, Weight Percent Sigma: {3:0.000000}, AtomicPercent: {4:0.00}",
                result.AtomicNumber == 0 ? @"-" : ElementProperties.GetElementSymbol(result.AtomicNumber),
                result.LineType,
                result.WeightPercent,
                result.WeightPercentSigma,
                result.AtomicPercent);

            totalWeightPercent += result.WeightPercent;
            totalAtomicPercent += result.AtomicPercent;
        }

        // If element by difference, output the element details
        if (semQuantSettings.ProcessingOption == ProcessingOption.ElementByDifference)
        {
            Console.WriteLine();
            Console.WriteLine(@"Element by Difference/Stoichiometry:");
            Console.WriteLine(
                @"    Element: {0}, Weight Percent: {1:0.00}, Atomic Percent: {2:0.00}",
                ElementProperties.GetElementSymbol(semQuantSettings.CombinedElement),
                100 - totalWeightPercent,
                100 - totalAtomicPercent);

            totalWeightPercent = 100.0;
            totalAtomicPercent = 100.0;
        }

        Console.WriteLine();
        Console.WriteLine(@"Element Totals:");
        Console.WriteLine(
            @"  Weight Percent: {0:00}, Atomic Percent: {1:0.00}",
            totalWeightPercent,
            totalAtomicPercent);
    }
    catch (QuantificationException ex)
    {
        Console.WriteLine();
        Console.WriteLine(@"Quantification Error: {0}", ex.Message);
    }
    catch (ArgumentNullException ex)
    {
        Console.WriteLine();
        Console.WriteLine(@"ArgumentNullException: {0}", ex.Message);
    }
}
See Also

Reference

OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings Properties

The ISEMQuantSettings type exposes the following members.

Properties
 | Name | Description
Public property | Capabilities | Gets the capabilities.
Public property | CombinedElement | Gets or sets the combined element for ElementByDifference and ElementByStoichiometry calculations.
Public property | DeconvolutionElements | Gets the atomic numbers of deconvolution elements. Deconvolution elements are elements present in the spectrum that should not be quantified, but whose influence needs to be accounted for when processing the spectrum.
Public property | DefaultStandardizationsFile | Gets or sets the selected default standardizations file.
Public property | Elements | Gets the atomic numbers of elements included in a fixed list.
Public property | Normalised | Gets or sets a value indicating whether results are normalised.
Public property | NumberOfIons | Gets or sets the number of ions used with ElementByStoichiometry calculations.
Public property | ProcessingOption | Gets or sets the type of Quant calculation.
Public property | SampleCoating | Gets the sample coating.
Public property | SigmaLevel | Gets or sets the sigma level (number of standard deviations).
Public property | Thresholding | Gets or sets a value indicating whether quant lines below the sigma level are included in the calculation.
Public property | TypeOfElementList | Gets or sets the Element list type used in the quant calculations.
Public property | TypeOfIon | Gets or sets the Ion type for use with ElementByStoichiometry calculations.
Public property | UserStandardizationsFile | Gets or sets the selected user standardizations file (if any).
Top
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.Capabilities Property

Gets the capabilities.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ISEMQuantCapabilities Capabilities { get; }
ReadOnly Property Capabilities As ISEMQuantCapabilities
    Get
property ISEMQuantCapabilities^ Capabilities {
    ISEMQuantCapabilities^ get ();
}
abstract Capabilities : ISEMQuantCapabilities with get

Property Value

Type: ISEMQuantCapabilities
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.CombinedElement Property

Gets or sets the combined element for ElementByDifference and ElementByStoichiometry calculations.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
int CombinedElement { get; set; }
Property CombinedElement As Integer
    Get
    Set
property int CombinedElement {
    int get ();
    void set (int value);
}
abstract CombinedElement : int with get, set

Property Value

Type: Int32
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.DeconvolutionElements Property

Gets the atomic numbers of deconvolution elements. Deconvolution elements are elements present in the spectrum that should not be quantified, but whose influence needs to be accounted for when processing the spectrum.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IReadOnlyList<int> DeconvolutionElements { get; }
ReadOnly Property DeconvolutionElements As IReadOnlyList(Of Integer)
    Get
property IReadOnlyList<int>^ DeconvolutionElements {
    IReadOnlyList<int>^ get ();
}
abstract DeconvolutionElements : IReadOnlyList<int> with get

Property Value

Type: IReadOnlyList Int32
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.DefaultStandardizationsFile Property

Gets or sets the selected default standardizations file.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string DefaultStandardizationsFile { get; set; }
Property DefaultStandardizationsFile As String
    Get
    Set
property String^ DefaultStandardizationsFile {
    String^ get ();
    void set (String^ value);
}
abstract DefaultStandardizationsFile : string with get, set

Property Value

Type: String
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.Elements Property

Gets the atomic numbers of elements included in a fixed list.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IReadOnlyList<int> Elements { get; }
ReadOnly Property Elements As IReadOnlyList(Of Integer)
    Get
property IReadOnlyList<int>^ Elements {
    IReadOnlyList<int>^ get ();
}
abstract Elements : IReadOnlyList<int> with get

Property Value

Type: IReadOnlyList Int32
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.Normalised Property

Gets or sets a value indicating whether results are normalised.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool Normalised { get; set; }
Property Normalised As Boolean
    Get
    Set
property bool Normalised {
    bool get ();
    void set (bool value);
}
abstract Normalised : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.NumberOfIons Property

Gets or sets the number of ions used with ElementByStoichiometry calculations.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double NumberOfIons { get; set; }
Property NumberOfIons As Double
    Get
    Set
property double NumberOfIons {
    double get ();
    void set (double value);
}
abstract NumberOfIons : float with get, set

Property Value

Type: Double
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.ProcessingOption Property

Gets or sets the type of Quant calculation.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ProcessingOption ProcessingOption { get; set; }
Property ProcessingOption As ProcessingOption
    Get
    Set
property ProcessingOption ProcessingOption {
    ProcessingOption get ();
    void set (ProcessingOption value);
}
abstract ProcessingOption : ProcessingOption with get, set

Property Value

Type: ProcessingOption
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.SampleCoating Property

Gets the sample coating.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ISampleCoating SampleCoating { get; }
ReadOnly Property SampleCoating As ISampleCoating
    Get
property ISampleCoating^ SampleCoating {
    ISampleCoating^ get ();
}
abstract SampleCoating : ISampleCoating with get

Property Value

Type: ISampleCoating
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.SigmaLevel Property

Gets or sets the sigma level (number of standard deviations).

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double SigmaLevel { get; set; }
Property SigmaLevel As Double
    Get
    Set
property double SigmaLevel {
    double get ();
    void set (double value);
}
abstract SigmaLevel : float with get, set

Property Value

Type: Double
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.Thresholding Property

Gets or sets a value indicating whether quant lines below the sigma level are included in the calculation.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
bool Thresholding { get; set; }
Property Thresholding As Boolean
    Get
    Set
property bool Thresholding {
    bool get ();
    void set (bool value);
}
abstract Thresholding : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.TypeOfElementList Property

Gets or sets the Element list type used in the quant calculations.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
ElementListType TypeOfElementList { get; set; }
Property TypeOfElementList As ElementListType
    Get
    Set
property ElementListType TypeOfElementList {
    ElementListType get ();
    void set (ElementListType value);
}
abstract TypeOfElementList : ElementListType with get, set

Property Value

Type: ElementListType
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.TypeOfIon Property

Gets or sets the Ion type for use with ElementByStoichiometry calculations.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IonType TypeOfIon { get; set; }
Property TypeOfIon As IonType
    Get
    Set
property IonType TypeOfIon {
    IonType get ();
    void set (IonType value);
}
abstract TypeOfIon : IonType with get, set

Property Value

Type: IonType
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.UserStandardizationsFile Property

Gets or sets the selected user standardizations file (if any).

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string UserStandardizationsFile { get; set; }
Property UserStandardizationsFile As String
    Get
    Set
property String^ UserStandardizationsFile {
    String^ get ();
    void set (String^ value);
}
abstract UserStandardizationsFile : string with get, set

Property Value

Type: String
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings Methods

The ISEMQuantSettings type exposes the following members.

Methods
 | Name | Description
Public method | ClearDeconvolutionElements | Clears the deconvolution elements.
Public method | ClearElements | Clears the fixed list of elements.
Public method | CopyFrom | Copies the settings from specified source.
Public method | GetValency | Gets the valency of the element for use with ElementByStoichiometry calculations.
Public method | SetDeconvolutionElement | Adds or removes an element from the list of deconvolution elements.
Public method | SetElement | Adds or removes an element from the fixed list of elements.
Public method | SetValency | Sets the valency of the element for use with ElementByStoichiometry calculations.
Public method | Validate | Validates the quant settings.
Top
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.ClearDeconvolutionElements Method

Clears the deconvolution elements.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void ClearDeconvolutionElements()
Sub ClearDeconvolutionElements
void ClearDeconvolutionElements()
abstract ClearDeconvolutionElements : unit -> unit
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.ClearElements Method

Clears the fixed list of elements.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void ClearElements()
Sub ClearElements
void ClearElements()
abstract ClearElements : unit -> unit
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.CopyFrom Method

Copies the settings from specified source.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void CopyFrom(
    ISEMQuantSettings source
)
Sub CopyFrom (
    source As ISEMQuantSettings
)
void CopyFrom(
    ISEMQuantSettings^ source
)
abstract CopyFrom :
        source : ISEMQuantSettings -> unit

Parameters

source
Type: OINA.Extender.Processing.QuantISEMQuantSettings
The source settings.
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.GetValency Method

Gets the valency of the element for use with ElementByStoichiometry calculations.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
double GetValency(
    int atomicNumber
)
Function GetValency (
    atomicNumber As Integer
) As Double
double GetValency(
    int atomicNumber
)
abstract GetValency :
        atomicNumber : int -> float

Parameters

atomicNumber
Type: SystemInt32
The atomic number

Return Value

Type: Double
The valency
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.SetDeconvolutionElement Method

Adds or removes an element from the list of deconvolution elements.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetDeconvolutionElement(
    int atomicNumber,
    bool include
)
Sub SetDeconvolutionElement (
    atomicNumber As Integer,
    include As Boolean
)
void SetDeconvolutionElement(
    int atomicNumber,
    bool include
)
abstract SetDeconvolutionElement :
        atomicNumber : int *
        include : bool -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number
include
Type: SystemBoolean
True to include
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.SetElement Method

Adds or removes an element from the fixed list of elements.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetElement(
    int atomicNumber,
    bool include
)
Sub SetElement (
    atomicNumber As Integer,
    include As Boolean
)
void SetElement(
    int atomicNumber,
    bool include
)
abstract SetElement :
        atomicNumber : int *
        include : bool -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number
include
Type: SystemBoolean
True to include
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.SetValency Method

Sets the valency of the element for use with ElementByStoichiometry calculations.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
void SetValency(
    int atomicNumber,
    double valency
)
Sub SetValency (
    atomicNumber As Integer,
    valency As Double
)
void SetValency(
    int atomicNumber,
    double valency
)
abstract SetValency :
        atomicNumber : int *
        valency : float -> unit

Parameters

atomicNumber
Type: SystemInt32
The atomic number
valency
Type: SystemDouble
The valency
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings.Validate Method

Validates the quant settings.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IValidationResults Validate()
Function Validate As IValidationResults
IValidationResults^ Validate()
abstract Validate : unit -> IValidationResults

Return Value

Type: IValidationResults
The validation results
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantSettings Events

The ISEMQuantSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ISEMQuantSettings Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantStatus Interface

An Interface that defines the status of a Quant measurement on a SEM.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public interface ISEMQuantStatus
Public Interface ISEMQuantStatus
public interface class ISEMQuantStatus
type ISEMQuantStatus =  interface end

The ISEMQuantStatus type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the Quantification results.
Public property | Status | Gets the Quantification status.
Public property | StatusMessage | Gets the Quantification status message.
Top
Examples
Copy
/// <summary>
/// Do AutoID
/// </summary>
private void DoAutoID()
{
    Console.WriteLine(@"AutoId - Identify elements.");

    IEdSpectrumProcessing edSpectrumProcessing = ProcessingFactory.CreateSpectrumProcessing();

    // Use the autoIdSettings to define elements that are known or elements that you want to exclude. They also list elements that cannot be identified
    IAutoIdSettings autoIdSettings = ProcessingFactory.CreateAutoIdSettings();

    IEnumerable<int> elementList = edSpectrumProcessing.IdentifyElements(this.edSpectrum, autoIdSettings);

    foreach (int i in elementList)
    {
        Console.WriteLine(@"    Identified Element: {0} - {1}", i, ElementProperties.GetElementSymbol(i));
    }
}

/// <summary>
/// Do quantitative processing
/// </summary>
private void DoQuant()
{
    ISEMQuantSettings semQuantSettings = ProcessingFactory.CreateSEMQuantSettings();

    // Processing Options:
    // AllElements - all elements yield X-rays that can be readily detected and are included.
    // ElementByDifference - The concentration of the CombinedElement is the difference between the analysed total and 100%
    // ElementByStoichiometry - The concentration of the CombinedElement is determined by its stoichiometry.
    switch (this.userProcessingOption)
    {
        case 1:
            semQuantSettings.ProcessingOption = ProcessingOption.AllElements;
            break;
        case 2:
            semQuantSettings.ProcessingOption = ProcessingOption.ElementByDifference;
            break;
        case 3:
            semQuantSettings.ProcessingOption = ProcessingOption.ElementByStoichiometry;
            break;
    }

    // Use chosen processing option
    switch (semQuantSettings.ProcessingOption)
    {
        case ProcessingOption.ElementByDifference:
            semQuantSettings.CombinedElement = 8; // Oxygen
            break;
        case ProcessingOption.ElementByStoichiometry:
            semQuantSettings.CombinedElement = 8; // Oxygen
            semQuantSettings.TypeOfIon = IonType.Anion;

            // Set the number of [CombinedElement] ions that are combined stoichiometrically to the other elements.
            // The calculations are based on the number of [CombinedElement] ions and how many atoms there are in each unit cell.
            semQuantSettings.NumberOfIons = 3;
            break;
        case ProcessingOption.AllElements:
        default:
            break;
    }

    // Specimens are sometimes coated with a thin conductive layer prior to observation in the SEM
    // to ensure that there is a good electrical path to ground. This prevents non-conducting specimens,
    // as well as the oxides which are present on the surface of many samples, from charging under the electron beam.
    bool isCoated = false;
    if (isCoated)
    {
        semQuantSettings.SampleCoating.IsCoated = true;
        semQuantSettings.SampleCoating.CoatingElement = 6; // Carbon
        semQuantSettings.SampleCoating.Thickness = 10;
        semQuantSettings.SampleCoating.Density = 2.25;
    }
    else
    {
        semQuantSettings.SampleCoating.IsCoated = false;
    }

    // Quantitative results are displayed with +/- value which is one sigma (standard deviation)
    // based on counting statistics. Typically, results which are less than 3 sigma have reduced significance
    // and so it may be desirable to set them to zero. Thresholding may be applied so
    // that results below the selected sigmas are set to zero. Thresholding will also ensure that
    // negative insignificant values, which sometimes result from trace element analysis, are set to zero.
    bool thresholding = false;
    if (thresholding)
    {
        semQuantSettings.Thresholding = true;
        semQuantSettings.SigmaLevel = 3.0;
    }
    else
    {
        semQuantSettings.Thresholding = false;
    }

    // When the spectrum is normalized the analytical total of an analysis is forced to 100%.
    // Use of this needs care in interpreting the final result since if, for example, the element list is
    // incomplete, there will be serious errors in the result, even though the total is 100%.
    semQuantSettings.Normalised = true;

    // Deconvolution elements may be used to select elements present in the spectrum that
    // should not be quantified, but whose influence needs to be accounted for when processing
    // the spectral data. For example elements present in an oxidation layer, or in a substrate
    // layer.
    bool deconvolution = false;
    if (deconvolution)
    {
        semQuantSettings.SetDeconvolutionElement(25, true); // Manganese
    }

    try
    {
        // Get the status of the quantification analysis
        ISEMQuantStatus quantStatus = ProcessingFactory.CreateSpectrumProcessing().SEMQuantifySpectrum(this.edSpectrum, semQuantSettings);

        Console.WriteLine();
        Console.WriteLine(@"Quantification status:");
        Console.WriteLine(@"{0} - {1}", quantStatus.Status, quantStatus.StatusMessage);

        Console.WriteLine();
        Console.WriteLine(@"Quantification Results:");

        double totalWeightPercent = 0;
        double totalAtomicPercent = 0;
        foreach (ISEMQuantResult result in quantStatus.Results)
        {
            Console.WriteLine(
                @"    Element: {0}, Line: {1}, Weight Percent: {2:0.00}, Weight Percent Sigma: {3:0.000000}, AtomicPercent: {4:0.00}",
                result.AtomicNumber == 0 ? @"-" : ElementProperties.GetElementSymbol(result.AtomicNumber),
                result.LineType,
                result.WeightPercent,
                result.WeightPercentSigma,
                result.AtomicPercent);

            totalWeightPercent += result.WeightPercent;
            totalAtomicPercent += result.AtomicPercent;
        }

        // If element by difference, output the element details
        if (semQuantSettings.ProcessingOption == ProcessingOption.ElementByDifference)
        {
            Console.WriteLine();
            Console.WriteLine(@"Element by Difference/Stoichiometry:");
            Console.WriteLine(
                @"    Element: {0}, Weight Percent: {1:0.00}, Atomic Percent: {2:0.00}",
                ElementProperties.GetElementSymbol(semQuantSettings.CombinedElement),
                100 - totalWeightPercent,
                100 - totalAtomicPercent);

            totalWeightPercent = 100.0;
            totalAtomicPercent = 100.0;
        }

        Console.WriteLine();
        Console.WriteLine(@"Element Totals:");
        Console.WriteLine(
            @"  Weight Percent: {0:00}, Atomic Percent: {1:0.00}",
            totalWeightPercent,
            totalAtomicPercent);
    }
    catch (QuantificationException ex)
    {
        Console.WriteLine();
        Console.WriteLine(@"Quantification Error: {0}", ex.Message);
    }
    catch (ArgumentNullException ex)
    {
        Console.WriteLine();
        Console.WriteLine(@"ArgumentNullException: {0}", ex.Message);
    }
}
See Also

Reference

OINA.Extender.Processing.Quant Namespace


ISEMQuantStatus Properties

The ISEMQuantStatus type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the Quantification results.
Public property | Status | Gets the Quantification status.
Public property | StatusMessage | Gets the Quantification status message.
Top
See Also

Reference

ISEMQuantStatus Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantStatus.Results Property

Gets the Quantification results.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
IEnumerable<ISEMQuantResult> Results { get; }
ReadOnly Property Results As IEnumerable(Of ISEMQuantResult)
    Get
property IEnumerable<ISEMQuantResult^>^ Results {
    IEnumerable<ISEMQuantResult^>^ get ();
}
abstract Results : IEnumerable<ISEMQuantResult> with get

Property Value

Type: IEnumerable ISEMQuantResult
The results.
See Also

Reference

ISEMQuantStatus Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantStatus.Status Property

Gets the Quantification status.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
QuantAnalysisStatus Status { get; }
ReadOnly Property Status As QuantAnalysisStatus
    Get
property QuantAnalysisStatus Status {
    QuantAnalysisStatus get ();
}
abstract Status : QuantAnalysisStatus with get

Property Value

Type: QuantAnalysisStatus
The status.
See Also

Reference

ISEMQuantStatus Interface
OINA.Extender.Processing.Quant Namespace


ISEMQuantStatus.StatusMessage Property

Gets the Quantification status message.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
string StatusMessage { get; }
ReadOnly Property StatusMessage As String
    Get
property String^ StatusMessage {
    String^ get ();
}
abstract StatusMessage : string with get

Property Value

Type: String
The status message.
See Also

Reference

ISEMQuantStatus Interface
OINA.Extender.Processing.Quant Namespace


ProcessingOption Enumeration

Quantification processing option.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum ProcessingOption
Public Enumeration ProcessingOption
public enum class ProcessingOption
type ProcessingOption
Members
Member name | Value | Description
AllElements | 0 | All elements yield X-rays that can be readily detected and are included.
ElementByStoichiometry | 1 | The concentration of the CombinedElement is determined by its stoichiometry.
ElementByDifference | 2 | The concentration of the CombinedElement is the difference between the analysed total and 100%
See Also

Reference

OINA.Extender.Processing.Quant Namespace


QuantAnalysisStatus Enumeration

Status of quantification analysis.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum QuantAnalysisStatus
Public Enumeration QuantAnalysisStatus
public enum class QuantAnalysisStatus
type QuantAnalysisStatus
Members
Member name | Value | Description
AnalysisOK | 0 | The analysis is OK.
InputValidationFailed | 1 | The settings are not valid.
SpectrumNotOptimized | 2 | Energy calibration has not been done and results are not normalised.
NoQuantLinesSet | 3 | X-ray lines could not be found for an element.
NoQuantStandards | 4 | No standards have been defined for an element.
ElementsOutOfRange | 5 | Element is not detectable.
OptimizationConditionsMismatch | 6 | Optimization conditions do not match analysis conditions.
UserkFactorConditionsMismatch | 7 | User k factor(s) do not match analysis conditions.
See Also

Reference

OINA.Extender.Processing.Quant Namespace


QuantificationException Class

Represents a Quantification Exception
Inheritance Hierarchy
SystemObject
SystemException
OINA.Extender.Processing.QuantQuantificationException

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class QuantificationException : Exception
<SerializableAttribute>
Public Class QuantificationException
    Inherits Exception
[SerializableAttribute]
public ref class QuantificationException : public Exception
[<SerializableAttribute>]
type QuantificationException =
    class
        inherit Exception
    end

The QuantificationException type exposes the following members.

Constructors
 | Name | Description
Public method | QuantificationException | DO NOT USE. Required for correct Exception behaviour
Public method | QuantificationException(String) | DO NOT USE. Required for correct Exception behaviour
Protected method | QuantificationException(SerializationInfo, StreamingContext) | Needed to comply with correct inheritance for Exception
Public method | QuantificationException(String, Exception) | DO NOT USE. Required for correct Exception behaviour
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Needed to comply with correct inheritance for Exception (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

OINA.Extender.Processing.Quant Namespace


QuantificationException Constructor

Overload List
 | Name | Description
Public method | QuantificationException | DO NOT USE. Required for correct Exception behaviour
Public method | QuantificationException(String) | DO NOT USE. Required for correct Exception behaviour
Protected method | QuantificationException(SerializationInfo, StreamingContext) | Needed to comply with correct inheritance for Exception
Public method | QuantificationException(String, Exception) | DO NOT USE. Required for correct Exception behaviour
Top
See Also

Reference

QuantificationException Class
OINA.Extender.Processing.Quant Namespace


QuantificationException Constructor

DO NOT USE. Required for correct Exception behaviour

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public QuantificationException()
Public Sub New
public:
QuantificationException()
new : unit -> QuantificationException
See Also

Reference

QuantificationException Class
QuantificationException Overload
OINA.Extender.Processing.Quant Namespace


QuantificationException Constructor (String)

DO NOT USE. Required for correct Exception behaviour

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public QuantificationException(
    string message
)
Public Sub New (
    message As String
)
public:
QuantificationException(
    String^ message
)
new :
        message : string -> QuantificationException

Parameters

message
Type: SystemString
The message
See Also

Reference

QuantificationException Class
QuantificationException Overload
OINA.Extender.Processing.Quant Namespace


QuantificationException Constructor (SerializationInfo, StreamingContext)

Needed to comply with correct inheritance for Exception

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
protected QuantificationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
QuantificationException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> QuantificationException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The info
context
Type: System.Runtime.SerializationStreamingContext
The context
See Also

Reference

QuantificationException Class
QuantificationException Overload
OINA.Extender.Processing.Quant Namespace


QuantificationException Constructor (String, Exception)

DO NOT USE. Required for correct Exception behaviour

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public QuantificationException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
public:
QuantificationException(
    String^ message,
    Exception^ innerException
)
new :
        message : string *
        innerException : Exception -> QuantificationException

Parameters

message
Type: SystemString
The message
innerException
Type: SystemException
The inner exception
See Also

Reference

QuantificationException Class
QuantificationException Overload
OINA.Extender.Processing.Quant Namespace


QuantificationException Properties

The QuantificationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

QuantificationException Class
OINA.Extender.Processing.Quant Namespace


QuantificationException Methods

The QuantificationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Needed to comply with correct inheritance for Exception (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

QuantificationException Class
OINA.Extender.Processing.Quant Namespace


QuantificationException.GetObjectData Method

Needed to comply with correct inheritance for Exception

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The info
context
Type: System.Runtime.SerializationStreamingContext
The Context

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

QuantificationException Class
OINA.Extender.Processing.Quant Namespace


QuantificationException Events

The QuantificationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

QuantificationException Class
OINA.Extender.Processing.Quant Namespace


QuantLineCode Enumeration

Identifies X-Ray lines used for quantification.

Namespace: OINA.Extender.Processing.Quant
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public enum QuantLineCode
Public Enumeration QuantLineCode
public enum class QuantLineCode
type QuantLineCode
Members
Member name | Value | Description
NullLine | 0 | X-Ray Line is unknown (unset).
K_Series | 1 | K-Series X-Ray Line.
L_Series | 2 | L-Series X-Ray Line.
M_Series | 3 | M-Series X-Ray Line.
K_alpha | 4 | k-alpha X-Ray Line.
L_alpha | 5 | L-alpha X-Ray Line.
M_alpha | 6 | M-alpha X-Ray Line.
K_beta | 7 | K-beta X-Ray Line.
L_beta | 8 | L-beta X-Ray Line.
M_beta | 9 | M-beta X-Ray Line.
L_gamma | 10 | L-gamma X-Ray Line.
L_l | 11 | L-l X-Ray Line.
M_zeta | 12 | M-zeta X-Ray Line.
Noise | 1500 | Noise
Noise1 | 1501 | Noise1
Noise2 | 1502 | Noise2
Noise3 | 1503 | Noise3
See Also

Reference

OINA.Extender.Processing.Quant Namespace


SmartAssembly.Attributes Namespace

[Missing <summary> documentation for "N:SmartAssembly.Attributes"]

Classes
 | Class | Description
Public class | PoweredByAttribute |


PoweredByAttribute Class

[Missing <summary> documentation for "T:SmartAssembly.Attributes.PoweredByAttribute"]

Inheritance Hierarchy
SystemObject
SystemAttribute
SmartAssembly.AttributesPoweredByAttribute

Namespace: SmartAssembly.Attributes
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public sealed class PoweredByAttribute : Attribute
Public NotInheritable Class PoweredByAttribute
    Inherits Attribute
public ref class PoweredByAttribute sealed : public Attribute
[<SealedAttribute>]
type PoweredByAttribute =
    class
        inherit Attribute
    end

The PoweredByAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PoweredByAttribute | Initializes a new instance of the PoweredByAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmartAssembly.Attributes Namespace


PoweredByAttribute Constructor

Initializes a new instance of the PoweredByAttribute class

Namespace: SmartAssembly.Attributes
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public PoweredByAttribute(
    string param0
)
Public Sub New (
    param0 As String
)
public:
PoweredByAttribute(
    String^ param0
)
new :
        param0 : string -> PoweredByAttribute

Parameters

param0
Type: SystemString

[Missing <param name="param0"/> documentation for "M:SmartAssembly.Attributes.PoweredByAttribute.#ctor(System.String)"]

See Also

Reference

PoweredByAttribute Class
SmartAssembly.Attributes Namespace


PoweredByAttribute Properties

The PoweredByAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

PoweredByAttribute Class
SmartAssembly.Attributes Namespace


PoweredByAttribute Methods

The PoweredByAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PoweredByAttribute Class
SmartAssembly.Attributes Namespace


SmartAssembly.Delegates Namespace

[Missing <summary> documentation for "N:SmartAssembly.Delegates"]

Delegates
 | Delegate | Description
Public delegate | GetString |


GetString Delegate

[Missing <summary> documentation for "T:SmartAssembly.Delegates.GetString"]

Namespace: SmartAssembly.Delegates
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public delegate string GetString(
    int i
)
Public Delegate Function GetString (
    i As Integer
) As String
public delegate String^ GetString(
    int i
)
type GetString =
    delegate of
        i : int -> string

Parameters

i
Type: SystemInt32

Return Value

Type: String
See Also

Reference

SmartAssembly.Delegates Namespace


SmartAssembly.HouseOfCards Namespace

[Missing <summary> documentation for "N:SmartAssembly.HouseOfCards"]

Classes
 | Class | Description
Public class | MemberRefsProxy |
Public class | Strings |


MemberRefsProxy Class

[Missing <summary> documentation for "T:SmartAssembly.HouseOfCards.MemberRefsProxy"]

Inheritance Hierarchy
SystemObject
SmartAssembly.HouseOfCardsMemberRefsProxy

Namespace: SmartAssembly.HouseOfCards
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class MemberRefsProxy
Public NotInheritable Class MemberRefsProxy
public ref class MemberRefsProxy abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MemberRefsProxy =  class end

The MemberRefsProxy type exposes the following members.

Methods
Name | Description
CreateMemberRefsDelegates |
Top
See Also

Reference

SmartAssembly.HouseOfCards Namespace


MemberRefsProxy Methods

The MemberRefsProxy type exposes the following members.

Methods
Name | Description
CreateMemberRefsDelegates |
Top
See Also

Reference

MemberRefsProxy Class
SmartAssembly.HouseOfCards Namespace


MemberRefsProxy.CreateMemberRefsDelegates Method

[Missing <summary> documentation for "M:SmartAssembly.HouseOfCards.MemberRefsProxy.CreateMemberRefsDelegates(System.Int32)"]

Namespace: SmartAssembly.HouseOfCards
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static void CreateMemberRefsDelegates(
    int typeID
)
Public Shared Sub CreateMemberRefsDelegates (
    typeID As Integer
)
public:
static void CreateMemberRefsDelegates(
    int typeID
)
static member CreateMemberRefsDelegates :
        typeID : int -> unit

Parameters

typeID
Type: SystemInt32

[Missing <param name="typeID"/> documentation for "M:SmartAssembly.HouseOfCards.MemberRefsProxy.CreateMemberRefsDelegates(System.Int32)"]

See Also

Reference

MemberRefsProxy Class
SmartAssembly.HouseOfCards Namespace


Strings Class

[Missing <summary> documentation for "T:SmartAssembly.HouseOfCards.Strings"]

Inheritance Hierarchy
SystemObject
SmartAssembly.HouseOfCardsStrings

Namespace: SmartAssembly.HouseOfCards
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static class Strings
Public NotInheritable Class Strings
public ref class Strings abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Strings =  class end

The Strings type exposes the following members.

Methods
Name | Description
CreateGetStringDelegate |
Top
See Also

Reference

SmartAssembly.HouseOfCards Namespace


Strings Methods

The Strings type exposes the following members.

Methods
Name | Description
CreateGetStringDelegate |
Top
See Also

Reference

Strings Class
SmartAssembly.HouseOfCards Namespace


Strings.CreateGetStringDelegate Method

[Missing <summary> documentation for "M:SmartAssembly.HouseOfCards.Strings.CreateGetStringDelegate(System.Type)"]

Namespace: SmartAssembly.HouseOfCards
Assembly: OINA.Extender (in OINA.Extender.dll) Version: 8.0.3.4821
Syntax
C#
VB
C++
F#
Copy
public static void CreateGetStringDelegate(
    Type ownerType
)
Public Shared Sub CreateGetStringDelegate (
    ownerType As Type
)
public:
static void CreateGetStringDelegate(
    Type^ ownerType
)
static member CreateGetStringDelegate :
        ownerType : Type -> unit

Parameters

ownerType
Type: SystemType

[Missing <param name="ownerType"/> documentation for "M:SmartAssembly.HouseOfCards.Strings.CreateGetStringDelegate(System.Type)"]

See Also

Reference

Strings Class
SmartAssembly.HouseOfCards Namespace


User Interface Controls

Spectrum Viewer

The Spectrum Viewer Control presents a view of an acquired spectrum. It shows (and aids in the identification of) elements detected within the spectrum.

Periodic Table

The Periodic Table Control provides three lists of elements representing a set of element states, each intended for use in spectrum processing. Elements are represented within the lists by their Atomic number.

Image Viewer

The Image Viewer Control shows an image acquired using Extender's Acquisition Service. Images are supplied to the Control by the DisplayImage Property.

Element Combo Box

The Element Combo Box Control allows you to select an element, either by its atomic number, or by its name from a drop-down-list. It words like a standard ComboBox, although the data displayed is specific to this control.


Spectrum Viewer

The Spectrum Viewer Control

The Spectrum Viewer Control presents a view of an acquired spectrum. It shows (and aids in the identification of) elements detected within the spectrum.

See Also

  • Zooming & Panning

  • Context Menu

  • Changing Visual Styles in the Spectrum Viewer Control

  • Adding the Spectrum Viewer Control to WPF

  • Adding the Spectrum Viewer Control to WinForms


Zooming & Panning

Zooming in on the Spectrum

Zooming can only be performed on the X-Axis. Click on the spectrum and use mouse scroll wheel to zoom in/out.

Panning the Spectrum

This operation allows you to pan or change the scale of the spectrum being viewed. With the “grab” mouse pointer showing, hold down the left mouse button whilst moving the mouse. This operation is usually performed when the spectrum has been "zoomed" and you wish to view other peaks within the spectrum.

See Also

  • Zooming & Panning

  • Context Menu

  • Changing Visual Styles in the Spectrum Viewer Control

  • Adding the Spectrum Viewer Control to WPF

  • Adding the Spectrum Viewer Control to WinForms


Context Menu

Context Menu

The following menu is displayed when you perform a right mouse-click on the displayed Spectrum:

Reset Scales

The Reset Scales menu item allows you to view the entire Spectrum after zooming or panning the Control.

Export Options

The Export Options allow you to export/save the Spectrum in a number of formats:

  • Save As: Allows you to save the current Spectrum as an image in a number of formats.
  • EMSA: Allows you to save the current Spectrum as an EMSA file, which can be imported into INCA.
  • Copy: Allows you to place an image onto the Windows Clipboard for pasting into a document.

Peak Label Options

The Peak Label Options allow you to hide/show Peak Labels.

Annotation Options

The Annotation Options allow you to hide/show Spectrum Annotations.

X-Axis Options
  • Show: Shows/ hides the X-Axis.
  • Locked: Locks the X-Axis such that the zoom operation is disabled and panning can only be performed on the Y-Axis.
Y-Axis Options
  • Show: Shows/ hides the X-Axis.
  • Locked: Locks the X-Axis such that the zoom operation is disabled and panning can only be performed on the Y-Axis, but does not prevent zooming on the X-Axis.
  • Units: This allows you to select units which the Y-Axis uses to scale the Spectrum. These are either Counts per second per electron volt (Cps/eV), or Counts.
  • Scale: This allows you switch the Y-Axis scale between a linear representation and a logarithmic representation.
Normalize

This allows you to switch between the raw Spectrum view and a normalized version of the Spectrum.

Smooth

This allows you to switch between the raw Spectrum view and a smoothed representation of the Spectrum.

Noise Peak Options
  • Include in Scaling: Scales the Spectrum Peak, including the Noise Peak.
  • Exclude from Scaling: Scales the Sperctrum, ignoring any Noise Peak.
  • Hide: Hides Noise Peak.
Details

Presents you with Spectrum detail in a separate window.

See Also

  • Zooming & Panning

  • Context Menu

  • Changing Visual Styles in the Spectrum Viewer Control

  • Adding the Spectrum Viewer Control to WPF

  • Adding the Spectrum Viewer Control to WinForms


Changing Visual Styles in the Spectrum Viewer Control

The Spectrum Viewer has an underlying visual theme, such that each instance of the viewer added to your project will appear identical. Access to the theme can be gained through the use of the OINA.Extender.Control.Styles.SpectrumViewerStyle class, but has been limited to allow only certain colours and Font styles to be changed.

The background colour of the viewer is not defined by the theme, so can be changed at design time using the control’s Background Colour property.

Colours

Using the OINA.Extender.Control.Styles.SpectrumViewerStyle class to change the colour of certain aspects of the SpectrumViewer’s theme will change the item’s colour for all Spectrum Viewer Controls within you project.

The colours available for modification are:

For Peak labels:

  • SpectrumPeakLabelBorderColor – the outline of the label.

  • SpectrumPeakBorderColor – the background color of the label.

  • SpectrumPeakLabelTextColor – the color of the text in the label.

  • MainSpectrumLabelForegroundColor.

  • MainSpectrumLabelBackgroundColor.

  • AlternateSpectrumLabelBrushColor.

For the Spectrum:

  • SpectrumLabelTextColor – the color used by the spectrum label.

  • SpectrumVisualFillColor – the color that fills the area under the main spectrum.

For the Spectrum View Axis:

  • AxisColor – the color used to draw the axis.

  • AxisTextColor – the color used to label the axis.

Fonts

The OINA.Extender.Control.Styles.SpectrumViewerStyle class can also be used to modify the font style used in the control. This class exposes the following static properties:

  • AxisFontSize – used to specify the size of the text used to label the axis.

Additional Style Settings

In addition to font an colors there are a few other properties that can be changed to modify the look of the Spectrum Viewer, these are :-

  • AxisMajorTickLength – sets the line length of the major axis tick marks.

  • AxisMinorTickLength – sets the line length of the minor axis tick marks.

  • IsAxisLineVisible – shows or hides the axis lines.

Reset

The visual styles of the Spectrum Viewer can be reset to its default settings using the OINA.Extender.Control.Styles.SpectrumViewerStyle using the ResetStyles static method.

See Also

  • Zooming & Panning

  • Context Menu

  • Changing Visual Styles in the Spectrum Viewer Control

  • Adding the Spectrum Viewer Control to WPF

  • Adding the Spectrum Viewer Control to WinForms


Adding the Spectrum Viewer Control to WPF

Visual Studio and WPF

Occasionally, the Control will not appear in the Visual Studio Toolbox. If this happens you should first check that Extender has been added to the references in your project.

If it still does not appear, then Extender may be added directly to the Toolbox by selecting the “Choose Items…” menu item in the Toolbox and adding Extender. This shows the Controls available from Extender in the Toolbox, which will be available for dragging onto your WPF Window.

If this still fails, add the following items to your WPF window.

Firstly, add the namespaces at the top of your windows xaml file:

Second, within the parent control (e.g. grid) add the Spectrum Viewer Control:

The table will then appear in your Windows Designer View.

See Also

  • Zooming & Panning

  • Context Menu

  • Changing Visual Styles in the Spectrum Viewer Control

  • Adding the Spectrum Viewer Control to WPF

  • Adding the Spectrum Viewer Control to WinForms


Adding the Spectrum Viewer Control to WinForms

Visual Studio and WinForms

Occasionally, the control will not appear in the Visual Studio Toolbox. In this situation you should first check that Extender has been added to the references in your project. If it still does not appear, then Extender may be added directly to the Toolbox by selecting the “Choose Items…” menu item in the Toolbox and adding Extender.

This should then show the controls available from Extender in the Toolbox, which will be available to be placed in your WinForm. Note, however, that dragging the control onto your WinForm is not permitted by current licensing.

The first step to adding the Spectrum Viewer Control to a WinForm is to add a System.Windows.Forms.Integration.ElementHost Control to the form (or User Control) where you wish the Table to be positioned.

The second step is to add the required namespaces to the forms implementation file. For example:

Once the namespace has been added you will need to create a field so that interactions with the Control can take place.

Next, create the Control and add it to our ElementHost Control by setting it as a child. For example:

Now, when the application is executed, the Spectrum Viewer Control will be visible at the location specified for the Element Host Control. The background colour of the spectrum viewer can now be changed by changing the background colour of the Element Host Control.

See Also

  • Zooming & Panning

  • Context Menu

  • Changing Visual Styles in the Spectrum Viewer Control

  • Adding the Spectrum Viewer Control to WPF

  • Adding the Spectrum Viewer Control to WinForms


Periodic Table

The Periodic Table Control

The Periodic Table Control has been designed to provide three lists of elements representing a set of element states, each intended for use in spectrum processing. Elements are represented within the lists by their Atomic number. These three states are:

  1. Included: Elements that the user ‘knows’ are in the spectrum.

  2. Excluded: Elements that the user ‘knows’ are not in the spectrum (and should be ignored).

  3. Unset (or Idle): Elements that may or may not be in a spectrum.

Elements within the Periodic Table can also be enabled or disabled. If an element has been disabled, the user will be prevented from selecting it. Furthermore, if an element has been disabled, it will not appear in any list provided by the Control. If the element is subsequently re-enabled it will be added to the unset list.

Element Lists

Element lists are read only, and cannot be modified externally. However, three methods are provided to allow for changes. If an element state is set using one of these methods, and the elements state changes, it will be removed from the list that indicates its old state and appear in the list that indicates its new state (unless the element has been disabled).

Change Notification

Each Element list can provide a change notification event, although this will not be immediately apparent. To provide an event handler for the change notification, the list must first be cast to a System.Collections.Specialized.INotifyCollectionChanged object. This will then provide a CollectionChanged event, to which your event handler can be attached. For example:

Obtaining Element Information

The Periodic Table Control also provides a method to obtain information about an element, such as the elements symbol, name, density, etc. See OINA.Extender.Data. IPeriodicElement. To obtain an element’s detail, a method is provided. See OINA.Extender.Controls.PeriodicTableControl.LookupElementInfo (int AtomicNumber).

See Also

  • Periodic Table

  • Changing Visual Styles in the Periodic Table Control

  • How the Periodic Table Control works

  • Adding the Periodic Table Control to WPF

  • Adding the Periodic Table Control to WinForms


How the Periodic Table Control works

Modes of Operation

The Periodic Table Control offers two modes of operation:

  1. Single Selection Mode: This allows for an element to be toggled between its states (NOT enabled/disabled). This is achieved by double-clicking the element.

  2. Multiple Selection Mode: When the Control is in this mode, three extra buttons are displayed. The user may select a number of elements and apply a state to all by clicking the appropriate button.

The selection of multiple elements can be achieved in two ways.

  1. Hold down the Shift key and select (click) your first element. Then select (click) the last element you wish to be selected. This has the effect of selecting all elements between these two points, either on the row or column.

  2. Hold down the Ctrl key and left mouse-click as many elements as required.

Single Selection Mode:

Multiple Selection Mode:

Key:

pt-selected-element | Selected Element
pt-unset-element | Unset Element
pt-included-element | Included Element
pt-excluded-element | Excluded Element
pt-dis-element | Disabled Element
Disable Element Selection

Elements can only be enabled or disabled by coding, and when disabled are unavailable for either selection mode.

See Also

  • Periodic Table

  • Changing Visual Styles in the Periodic Table Control

  • How the Periodic Table Control works

  • Adding the Periodic Table Control to WPF

  • Adding the Periodic Table Control to WinForms


Changing Visual Styles in the Periodic Table Control

The Periodic Table has an underlying visual theme. You can access this using the OINA.Extender.Control.Styles.PeriodicTableStyle Class.

Colours

The OINA.Extender.Control.Styles.PeriodicTableStyle is used to change colours within your Periodic Table display. Colours available for modification are:

  • ElementIncludeBackgroundColor: This is the colour that the Periodic Table Control will use as a background for an element that will be Included.

  • ElementExcludeBackgroundColor: This is the colour that the Periodic Table Control will use as a background for an element that will be Excluded.

  • ElementIdleBackgroundColor: This is the colour that the Periodic Table Control will use as a background for an element that is to all elements that is Unset. Not that if an element is disabled the background will appear as Unset, although it will not appear in the Unset Elements list.

  • ElementBorderColor: This is the border colour for all squares containing element symbols in the Periodic Table.

  • ElementHighlightColor: This is the colour used to indicate that an element has been selected within the Periodic Table.

  • ElementFontColor: This is the colour of the text used for all squares containing element symbols in the Periodic Table.

Note: The background colour of the Periodic Table as a whole is not defined by the theme, and may be changed at design time using the control’s Background Colour property.

Fonts

The OINA.Extender.Control.Styles.PeriodicTableStyle Class can also be used to modify Fonts. It exposes the following static properties:

  • PeriodicTableFontFamily:Uses a System.Windows.Media.FontFamily object to change the Font used for all text in the Periodic Table.

  • PeriodicTableFontStyle: Uses a System.Windows.FontStyle object to set the Font Style of text within the Periodic Table Control.

NOTE: Font size cannot be changed. This is a dynamic property which will be appropriately sized by the Periodic Table Control.

Resetting the visual style

The visual styles of the Periodic Table can be returned to their default settings using the the ResetStyles static method within OINA.Extender.Control.Styles.PeriodicTableStyle.

See Also

  • Periodic Table

  • Changing Visual Styles in the Periodic Table Control

  • How the Periodic Table Control works

  • Adding the Periodic Table Control to WPF

  • Adding the Periodic Table Control to WinForms


Adding the Periodic Table Control to WPF

Visual Studio and WPF

Occasionally, the Control will not appear in the Visual Studio Toolbox. If this happens you should first check that Extender has been added to the references in your project.

If it still does not appear, then Extender may be added directly to the Toolbox by selecting the “Choose Items…” menu item in the Toolbox and adding Extender. This shows the Controls available from Extender in the Toolbox, which will be available for dragging onto your WPF Window.

If this still fails, add the following items to your WPF window.

Firstly, add the namespaces at the top of your windows xaml file:

Second, within the parent control (e.g. grid) add the Periodic Table Control:

The table will then appear in your Windows Designer View.

See Also

  • Periodic Table

  • Changing Visual Styles in the Periodic Table Control

  • How the Periodic Table Control works

  • Adding the Periodic Table Control to WPF

  • Adding the Periodic Table Control to WinForms


Adding the Periodic Table Control to WinForms

Visual Studio and WinForms

Occasionally, the control will not appear in the Visual Studio Toolbox. In this situation you should first check that Extender has been added to the references in your project. If it still does not appear, then Extender may be added directly to the Toolbox by selecting the “Choose Items…” menu item in the Toolbox and adding Extender.

This should then show the controls available from Extender in the Toolbox, which will be available to be placed in your WinForm. Note, however, that dragging the control onto your WinForm is not permitted by current licensing.

The first step to adding the Periodic Table Control to a WinForm is to add a System.Windows.Forms.Integration.ElementHost Control to the form (or User Control) where you wish the Table to be positioned.

The second step is to add the required namespaces to the forms implementation file. For example:

Once the namespace has been added you will need to create a field so that interactions with the Control can take place.

Next, create the Control and add it to our ElementHost Control by setting it as a child. For example:

Now, when the application is executed, the Periodic Table Control will be visible at the location specified for the Element Host Control. The background colour of the Periodic Table can now be changed by changing the background colour of the Element Host Control.

See Also

  • Periodic Table

  • Changing Visual Styles in the Periodic Table Control

  • How the Periodic Table Control works

  • Adding the Periodic Table Control to WPF

  • Adding the Periodic Table Control to WinForms


Image Viewer

The Image Viewer Control

The Image Viewer Control shows an image acquired using Extender's Acquisition Service. Images are supplied to the Control by the DisplayImage Property.

See Also

  • Image Viewer

  • Context Menu

  • Changing Visual Styles in the Image Viewer Control

  • Adding the Image Viewer Control to WPF

  • Adding the Image Viewer Control to WinForms


Context Menu

Context Menu

The following menu is displayed when you perform a right mouse-click on the displayed image:

Rescale Image Options

The Rescale Image options allow you to:

  • Fit Image to Display: The entire image is displayed within the Control.
  • Fit Display with Image: The image is scaled to fit the display. Note, this may mean some parts of the image will not be shown.
View Options

The View options allow you to select/deselect the following for display, alongside the image:

Header: Allows you to select/deselect the Image Header. For example:

Scale Bar: Allows you to select/deselect the image Scale Bar. For example:

Color Bar: Allows you to select/deselect the image Color Bar. For example:

The Color Bar allows you to adjust the colors you see in the image.

Show Contrast/Brightness Buttons: Allows you select/deselect the image Brightness/Contrast Button and the Image Gamma Button, which automatically balances the gamma of the image if clicked. For example:

Export Options

The Export options allow you to save/copy the image to a specified location.

  • Save As (original resolution): Allows you to export the image, at full resolution, in PNG format.

  • Save As: Allows you to export the image in a number of different formats.

  • Copy: Allows you to copy the image to the Windows Clipboard.

Export Data Only Options

The Export Data Only options allow you to save just the underlying image data, as:

  • A .TIFF file.

  • A .TSV, or. .CSV file.

Details

Presents you with Image detail in a separate window.

See Also

  • Image Viewer

  • Context Menu

  • Changing Visual Styles in the Image Viewer Control

  • Adding the Image Viewer Control to WPF

  • Adding the Image Viewer Control to WinForms


Changing Visual Styles in the Image Viewer Control

The Image Viewer has an underlying visual theme, such that each instance of the viewer added to your project will appear identical. Access to the theme can be gained through the use of the OINA.Extender.Control.Styles.ImageViewerStyle class, but has been limited to allow only certain colours and Font styles to be changed.

The background colour of the viewer is not defined by the theme, so can be changed at design time using the control’s Background Colour property.

Colours

Using the OINA.Extender.Control.Styles.ImageViewerStyle class to change the colour of certain aspects of the control’s theme will change the item’s colour for all Image Viewer Controls within you project.

The colours available for modification are:

  • ImageViewerBackgroundColor – the background color for all ImageViewer controls in the project.

  • ImageViewHeadersAndScaleBarsFgColor – the color used by the Image Viewer for textual display and the Scale Bar.

Fonts

The OINA.Extender.Control.Styles.ImageViewerStyle class can also be used to modify the font style used in the control. This class exposes the following static properties:

  • ImageViewerHeaderFontSize – allows the header text size to be modified to best fit your application.

  • ImageViewerHeaderFontFamily – changes the font used for header text.

  • ImageViewerScaleBarFontSize – allows the font size of the Scale Bar to be changed.

Reset

The visual styles of the Spectrum Viewer can be reset to its default settings using the OINA.Extender.Control.Styles.ImageViewerStyle using the ResetStyles static method.

See Also

  • Image Viewer

  • Context Menu

  • Changing Visual Styles in the Image Viewer Control

  • Adding the Image Viewer Control to WPF

  • Adding the Image Viewer Control to WinForms


Adding the Image Viewer Control to WPF

Visual Studio and WPF

Occasionally, the Control will not appear in the Visual Studio Toolbox. If this happens you should first check that Extender has been added to the references in your project.

If it still does not appear, then Extender may be added directly to the Toolbox by selecting the “Choose Items…” menu item in the Toolbox and adding Extender. This shows the Controls available from Extender in the Toolbox, which will be available for dragging onto your WPF Window.

If this still fails, add the following items to your WPF window.

Firstly, add the namespaces at the top of your windows xaml file:

Second, within the parent control (e.g. grid) add the Image Viewer Control:

The table will then appear in your Windows Designer View.

See Also

  • Image Viewer

  • Context Menu

  • Changing Visual Styles in the Image Viewer Control

  • Adding the Image Viewer Control to WPF

  • Adding the Image Viewer Control to WinForms


Adding the Image Viewer Control to WinForms

Visual Studio and WinForms

Occasionally, the control will not appear in the Visual Studio Toolbox. In this situation you should first check that Extender has been added to the references in your project. If it still does not appear, then Extender may be added directly to the Toolbox by selecting the “Choose Items…” menu item in the Toolbox and adding Extender.

This should then show the controls available from Extender in the Toolbox, which will be available to be placed in your WinForm. Note, however, that dragging the control onto your WinForm is not permitted by current licensing.

The first step to adding the Image Viewer Control to a WinForm is to add a System.Windows.Forms.Integration.ElementHost Control to the form (or User Control) where you wish the Table to be positioned.

The second step is to add the required namespaces to the forms implementation file. For example:

Once the namespace has been added you will need to create a field so that interactions with the Control can take place.

Next, create the Control and add it to our ElementHost Control by setting it as a child. For example:

Now, when the application is executed, the Image Viewer Control will be visible at the location specified for the Element Host Control. The background colour of the spectrum viewer can now be changed by changing the background colour of the Element Host Control.

See Also

  • Image Viewer

  • Context Menu

  • Changing Visual Styles in the Image Viewer Control

  • Adding the Image Viewer Control to WPF

  • Adding the Image Viewer Control to WinForms


Element Combo Box

The Element Combo Control

The Element Combo Control allows you to select an element, either by its atomic number, or by its name from a drop-down-list. It words like a standard ComboBox, although the data displayed is specific to this control.

See Also

  • Element Combo Box

  • How the Element Combo Control works

  • Changing Visual Styles in the Element Combo Control

  • Adding the Element Combo Control to WPF

  • Adding the Element Combo Control to WinForms


How the Element Combo Control works

Mode of Operation

The ElementCombo Control allows elements to be displayed in a drop-down list, either as atomic numbers, or by name. The element list is provided to the control programatically.

See Also

  • Element Combo Box

  • How the Element Combo Control works

  • Changing Visual Styles in the Element Combo Control

  • Adding the Element Combo Control to WPF

  • Adding the Element Combo Control to WinForms


Changing Visual Styles in the Element Combo Control

The ElementCombo Control has an underlying visual theme, such that each instance of the viewer added to your project will appear identical. Access to the theme can be gained through the use of the OINA.Extender.Control.Styles.ElementComboStyle class, but has been limited to allow only certain colours and Font styles to be changed.

The background colour of the control can be defined by the theme, and can also be changed at design time using the control’s Background Colour property.

Colours

Using the OINA.Extender.Control.Styles.ElementComboStyle class to change the colour of certain aspects of the control’s theme will change the item’s colour for all ElementCombo Controls within you project.

The colours available for modification are:

  • MainColor – the background color for ElementCombo controls in the project.

  • Foreground – the color used on the element to display text.

Fonts

The OINA.Extender.Control.Styles.ElementComboStyle class can also be used to modify the font style used in the control. This class exposes the following static properties:

  • FontSize – allows text size to be modified to best fit your application.

Reset

The visual styles of the control can be reset to its default settings using the OINA.Extender.Control.Styles.ElementComboStyle using the ResetStyles static method.

See Also

  • Element Combo Box

  • How the Element Combo Control works

  • Changing Visual Styles in the Element Combo Control

  • Adding the Element Combo Control to WPF

  • Adding the Element Combo Control to WinForms


Adding the Element Combo Control to WPF

Visual Studio and WPF

Occasionally, the Control will not appear in the Visual Studio Toolbox. If this happens you should first check that Extender has been added to the references in your project.

If it still does not appear, then Extender may be added directly to the Toolbox by selecting the “Choose Items…” menu item in the Toolbox and adding Extender. This shows the Controls available from Extender in the Toolbox, which will be available for dragging onto your WPF Window.

If this still fails, add the following items to your WPF window.

Firstly, add the namespaces at the top of your windows xaml file:

Second, within the parent control (e.g. grid) add the ElementCombo Control:

The table will then appear in your Windows Designer View.

See Also

  • Element Combo Box

  • How the Element Combo Control works

  • Changing Visual Styles in the Element Combo Control

  • Adding the Element Combo Control to WPF

  • Adding the Element Combo Control to WinForms


Adding the Element Combo Control to WinForms

Visual Studio and WinForms

Occasionally, the control will not appear in the Visual Studio Toolbox. In this situation you should first check that Extender has been added to the references in your project. If it still does not appear, then Extender may be added directly to the Toolbox by selecting the “Choose Items…” menu item in the Toolbox and adding Extender.

This should then show the controls available from Extender in the Toolbox, which will be available to be placed in your WinForm. Note, however, that dragging the control onto your WinForm is not permitted by current licensing.

The first step to adding the ElementCombo Control to a WinForm is to add a System.Windows.Forms.Integration.ElementHost Control to the form (or User Control) where you wish the Table to be positioned.

The second step is to add the required namespaces to the forms implementation file. For example:

Once the namespace has been added you will need to create a field so that interactions with the Control can take place.

Next, create the Control and add it to our ElementHost Control by setting it as a child. For example:

Now, when the application is executed, the ElementCombo Control will be visible at the location specified for the Element Host Control. The background colour of the ElementCombo can now be changed by changing the background colour of the Element Host Control.

See Also

  • Element Combo Box

  • How the Element Combo Control works

  • Changing Visual Styles in the Element Combo Control

  • Adding the Element Combo Control to WPF

  • Adding the Element Combo Control to WinForms


Published, October 2014

About this release

This release supports:

  • Ed Spectrum Acquisition.

  • Electron Image Acquisition.

  • Energy Calibration for Ed.

This release DOES NOT support:

  • Map Acquisition.

  • Line Acquisition.

  • EBSD.

  • Wd.


T

Back to Glossary

TEM

Transmission Electron Microscope, or Transmission Electron Microscopy. An electron beam is passed through a series of lenses to form a magnified image of a specimen in the area of the objective lens. TEM operates under vacuum because electrons are easily scattered at atmospheric pressure. The lenses are electromagnetic as opposed to glass, which is opaque to electrons.

Termination

Stopping an experiment.

Thermal Capability

Thermal Control

Thermal Cycle

Thermal Status

Thickness (coating)

Thickness Property (Coating)

Thresholding

Transform

Type of Ion

Back to Glossary


F

Back to Glossary

Facade

A facade is an Object that provides a simplified interface to a larger body of code, such as a Class Library.

FEG

Field Emission Gun. A FEG pulls heated electrons out of a very-fine tungsten tip using an extremely high electric field. With a FEG, users gain electron densities up to 1,000 times those of tungsten emitters without a FEG.

FIB

Focused Ion Beam. A beam of ions replaces the beam of electrons on an electron microscope. DualBeam™ instruments may also have an ion beam column.

FIB-SEM

Focused Ion Beam Scanning Electron Microscope.

Field

The data encapsulated within a Class or Object. Fields hold information important for the operation of the Class. Fields can only be modified through Properties or Methods.

Filament

Metal wire, usually in the form of a hairpin, which, when heated in a vacuum, releases free electrons and so provides a source of electrons for an Electron Microscope.

Filament On

Fit Gausian Results

Flourescent Screen

Large plate coated with a material (phospher) which gives off light (flouresces) when bombarded by electrons. A TEM may project its electron image onto a flourescent screen to make it visible in real time.

Focal Length (of a Lens)

The distance (measured from the centre of the lens in the direction of the beam) at which a parallel incident beam is brought to a focus.

Focusing

The act of making the image as sharp as possible by adjusting the power of the objective lens.

Font Size

Foreground

Frame Count

Free Electrons

Any electron that is not attached to an ion, atom, or molecule and is free to move under the influence of an applied electric or magnetic field.

FSD

Forescatter Detector.

Back to Glossary


C

Back to Glossary

Can Read

Can Write

Capability

Something that something is able to do. For example: An Ed capability may be retrieving the maximum acquisition time.

Cathodoluminescence

The emission of light photons by a material under electron bombardment.

Centre (Gausian)

CFED

Cold Field Emission Source.

Chart Element

Chemical Formula

Channel

A range of energy.

Chord

Chord List

Chord List Region

Class

A template used for creating Objects. Extender defines Classes for Factories, Controls and Exceptions.

Coated Property

Coating

Coating of samples is required to enable or improve imaging. Creating a conductive layer of metal on the sample inhibits charging, reduces thermal damage and improves the secondary electron signal required for topographic examination in the SEM. Fine carbon layers, being transparent to the electron beam but conductive, are needed for X-Ray microanalysis, to support films on grids and back up replicas to be imaged in the TEM.

Coating Element

Column

The physical structure of an Electron Microscope that accomodates the evacuated electron beam path, the electromagnetic lenses and the specimen and aperture mechanisms.

Column Capability

Column Condition

Column Connection Status

Combined Element

Comparison Spectra Source

Composition

The elements that a specimen is composed of and their relative ratios.

Compound Percent

Compound Percent Sigma

Condenser Lens

Part of the illumination system between the gun and the specimen designed to form the electron beam, usually into a parallel configuration as it transits the sample (TEM) or enters the objective lens (SEM). It may also be used to form a finely focussed spot on the specimen (STEM).

Confidence Factor

Constructor

A special method of a Class that initiates an Object of that type.

Control

A user interface component providing a Method to present data to an end-user. Controls may also allow an end user to pass information back into Extender for data manipulation and generation. Extender uses two types of Controls:

  • User Controls: to display information and allow users to interact with code.

  • Controls for hardware: for instances where code interacts with hardware.

Control Base

Connection Status

Count Rate

The measurement of ionizing radiation.

Crystal

A material in which the atoms are ordered into rows and columns.

Crystal Structure

The order in which atoms are arranged in a material. These arrangements have a direct effect on the physical properties of the material. These arrangements commonly take the form of cubes, rectangular solids, hexagonal solids.

Current Acquisition Region

Current Element

Current Spectrum

Back to Glossary


Z

Back to Glossary

No current entries for this letter.

Back to Glossary


V

Back to Glossary

Vacuum

A region of lower than ambient gas pressure.

Vacuum Sensor

Vacuum State

Valency

Validation - results of experiment?

Back to Glossary


A

Back to Glossary

Aberration

The deviation from perfect imaging in an optical system, caused by imperfection in the lens, or by non-uniformity of the electron beam.

Accelerating Voltage

The voltage (kV) applied to the electron gun that causes electrons to accelerate down the electron optic column. The higher the accelerating voltage, the greater the energy and the shorter the wavelength of the electrons striking the specimen.

Acquisition

The gathering of data from the hardware (microscope) e.g. electron image, spectra, point data, etc.

Acquisition Date

Acquisition Mode

Acquisition Region

Acquisition Time

Active Area

Airlock

A specimen chamber within the electron microscope that can be isolated from the outside and from the rest of the system. The airlock is pumped out and the specimen is moved into the column vacuum, which reduces the amount of air and other contaminants brought into the column.

Allowed Energy Range

Allowed Number of Channels

Allowed Process Time

Amplitude

The maximum value attainable by a periodically changing physical magnitude. For electromagnetic waves, the intensity of the change is proportional to the square of their amplitude.

Amplitude Contrast

Image contrast caused when the specimen absorbs electrons from the electron beam.

Animation Clock

Anode

In an electron gun, the negatively charged electrons are accelerated towards the anode, which has a positive charge relative to the filament (cathode) from which they emerge.

Apparent Concentration

Apparent Concentration Sigma

Aperture

A small hole in a metal disc used to stop those electrons that are not required for image formation (e.g. scattered electrons).

Area (Gausian)

Assembly

The assembled (compiled) instance of a software project. Effectively, the Dynamic Link Library (the dll). For Extender, OINA.Core.dll contains a number of Class and Interface definitions.

Aspect Ratio

ATEM

Analytical TEM.

Atom

The smallest unit of physical matter that retians its elemental identity. Consists of a postively charged nucleus surrounded by negatively charged electrons in discrete orbits.

Atomic Number

The number of protons in the atomic nucleus. This number determines the chemical nature of the atom.

Atomic Percent

The percentage of one kind of atom relative to the total number of atoms.

Auto Id

Azimuth Degree

Back to Glossary


E

Back to Glossary

EBSD

Electron Backscatter Diffraction.

ED

Energy Dispersive.

EDS

Energy Dispersive Spectroscopy. An analytical technique used for the elemental analysis or chemical characterization of a sample.

Ed Capability

Ed Detector Control

Ed Device Id

Ed Hardware Id

Ed Setting

Ed Spectrum

Ed Spectrum Processing

Ed Spectrum Scan Capability

Ed Spectrum Scan Setting

Ed Spectrum Setting

EDS

Energy Dispersive X-Ray Spectroscopy.

EDX

Energy Dispersive X-Ray Analysis (sometimes EDS).

EELS

Electon Energy Loss Spectroscopy.

Electron

Fundamental sub-atomic particle carrying a negative charge and conveniently described as orbiting the nucleus of the atom. Free electrons can easily flow in a conductor and can be extracted into a vacuum by an electric field.

Electron Gun

A device intended to produce a stream of electrons.

Electron Microscope

A Microscope in which a beam of electrons is used to form a magnified image of the specimen. More precisely, a complex analytical tool that provides information about the structure, crystalography and chemistry of materials.

Electron Trap

Elecrostatic Lens

A device used to focus charged particles into a beam.

Element Border Color

Element Combo

Element Combo Style

Element Density

Element Exclude Background Color

Element Font Color

Element Highlight Color

Element Idle Backgorund Color

Element Include Background Color

Element NameElement RTS Density

Element Valency

Elevation Degrees

EMSA

Energy Per Channel

Energy Range

Energy Window

Energy Window Source

ESEM

Environmental Scanning Electron Microscope. A SEM that can accomodate a wide range of pressures in the sample chamber; up to that required to sustain water in its liquid phase.

ETEM

Environmental Transmission Electron Microscope. A TEM that can accomodate a wider range of environmental conditions and apparatus in the sample space to enable in-situ examination of materials and processes.

Event

An Event enables a Class or Object to notify other Classes or Objects when something of interest occurs.

Event Args

Exception

An error.

Excitation

The input of energy to matter leading to the emission of radiation.

Excluded Element

Experiment

The act of acquiring, viewing and analysing a spectrum.

Export

Export Copy

Export EMSA

Export Image Command

Export Save As

Extender

The OINA AZtec Extender is an API used by third-party applications that require Ed, EBSD and FSD data from OINA AZtec. More accurately, the OINA AZtec Extender is a facade on top of Mustang that encapsulates aspects of common functionality contained in the Mustang Core and simplifies it.

Extender Data

Raw data types used in Extender.

Extended Mode

Back to Glossary


B

Back to Glossary

Backlash

Clearance or lost motion in a microscope caused by gaps between moving parts.

Backlash On

Backscattered Electrons

Primary (beam) electrons that have been deflected by the specimen through an angle generally greater than ninety degrees, so that they exit the sample with little or no loss of energy.

Backscattered Electron Imaging

The production of backscattered electrons varies directly with the specimen's atomic number. This differing production rates causes higher atomic number elements to appear brighter than lower atomic number elements. This interaction is utilized to differentiate parts of the specimen that have different average atomic number.

Detection of Backscattered Electrons is achieved by using a "donut" shaped solid state semiconductor device mounted on the bottom of the objective lens. When Backscattered Electrons strike the detector electron-hole pairs are created which are then counted. This quantity is translated into a pixel intensity and displayed, forming the image.

Beam On

Bounding Box

A bounding box is a cuboid, or in 2-D a rectangle, containing an object, or objects.

BSD

Backscattered Electrons.

Back to Glossary


X

Back to Glossary

X-Axis

X-Axis Auto Scale

X-Axis Locked

X-Axis Visible

X-Rays

Electromagnetic radiation. In the Electron Microscope characteristic X-Rays are used to analyse elemental composition with high spacial resolution.

Back to Glossary


M

Back to Glossary

Main Color

Magnification

The ratio of the length of one line of the electron beam on the monitor to the width of the area scanned on the specimen.

MAM

Microscopy and Microanalysis.

Marker Element

Maximum Acquisition Time

Maximum Combined Element Atomic Number

Maximum Counts Per Second

Maximum Energy

Maximum Number of Deconvolved Elements

Maximum Overload Delay

Maximum Overload Threshold

Maximum Output Count

Maximum Output Rate

Maximum Pixel Size

Maximum Sigma

Maximum Upper Limit

Member

Content for a Class.

Method

A Subroutine associated with an Object.

Micrometre

A millionth of a metre.

Microscope

Microscope Controller

Microscope Control Type

Microscope Parameter Capability

Microscope Region

Minimum Acquisition Time

Minimum Energy

Minimum Overload Delay

Minimum Overload Threshold

Minimum Pixel Size

Monitoring Controller

Mustang

Mustang is a set of libraries, created by Oxford Instruments, that allow services to be co-ordinated in such a way that useful information can be gathered from a detector and viewed using the OINA AZtec application.

Back to Glossary


Q

Back to Glossary

Quant

Quant Calibration

Quant Calibration Line Type

Quant Line

Quant Line Code

Quant Map

Quantum

A discrete packet of energy.

Back to Glossary


Glossary

A | B | C | D
E | F | G | H
I | J | K | L
M | N | O | P
Q | R | S | T
U | V | W | X
Y | Z
See Also
OINA.Extender.dll Developer Reference


P

Back to Glossary

Peak Area

Peak Area Sigma

Peak Label

Peak Label Outline

Peak Label Reset Position

Peltier

A cooling method (device).

Periodic Element

Periodic Table Control

Periodic Table Font Family

Periodic Table Font Style

Perodic Table Style

Phase

Relative position in a cyclical or wave motion. It is expressed as an angle, one cycle, or one wavelength corresponding to 360 degrees.

Phase Contrast

Image contrast caused by the interference among transmitted electrons with phase shifts caused by interaction with the sample.

Photons

Discrete packets of electromagnetic radiation.

Pile-up Peak

Generated in the Spectrum, the consequense of Pulse Pile-up.

Pixel Size

Point Region

Position State

Primary Electrons

Electrons in a beam.

Primary Detector Serial Number

Primary Device Id

Primary Hardware Id

Process Time

Processing

The processing of acquired data and its transformation into something useful e.g. an image, spectrum, etc.

Property

A type of Class Member. It provides a flexible mechanism to read, write, or compute the value of a Field.

Pulse

Pulse Pile Up

The consequence of two or more X-Rays being detected almost simultaneously and not being recognised as separate events. More specifically, Pulse pile-up is the consequence of the charge generated from the absorption of two or more X-Rays being detected almost simultaneously and not being recognised as separate events. The number of Pile-up events depends on the count rate.

Pulse pile-up generates a Pile-up Peak (or Sum Peak)in the spectrum.

Pulse Processor

Pulse Pile Up Status

Back to Glossary


J

Back to Glossary

No current entries for this letter.

Back to Glossary


D

Back to Glossary

Dead Time

The time after each event during which the detector(s) is not able to record another event.

Deconvolution Element

Density (Coating)

Density Property (Coating)

Detector

A device that converts the energy of X-Rays into a voltage signal of proportionate size. The voltage signal is input into the pulse processor for measurement.

Detector Activity State

What the Detector is doing now: Not Moving, Moving In, Moving Out, Homing, Auto Retracting.

Detector Connected

Is the Detectors connected to ?????????????????

Detector Control

Detector Insertion Distance

The distance, shown in mm, a Detector has moved forward, from the fully retracted position.

Detector Position

Detector Serial Number

Detector Status

The current status of the Detector: Fully Inserted, Fully Retracted, Intermediate Position, Auto Retracted.

Detector Model

The type of Detector, for example X-MAX.

Detector Operating Mode

Detector Operating State

Detector Shutter State

Detector Slide Activity

Detector Slide Position

Detector Vacuum State

Detector Type

Detector Type ID

Device Enabled

Device Id

Diffraction

Deviation of the direction of light or other wave motion when the wave front passes the edge of an obstacle.

Diffraction Contrast

Image contrast caused by the removal of electrons from the beam by scattering by a periodic (crystalline) structure in the specimen.

Disabled Element

Display Property

Draw Style

Back to Glossary


O

Back to Glossary

Object

A particular instance of a Class, where the Object can be a combination of variables, functions and data structures.

Objective Lens

In the TEM this is the first lens after the specimen whose function is to focus transmitted electrons into an image. In a SEM it is the last lens before the specimen and it produces the extremely fine electron spot with which the specimen is scanned. Its quality largely determines the performace of the Microscope.

Operating Mode

Operating State

Operating Status

Output Rate

Overload

Overload Capability

Overload Control

Overload Delay

Overload Detection

Overload Detection Enabled

Overload Status

Overload Threshold

Back to Glossary


K

Back to Glossary

K Ratio

Back to Glossary


H

Back to Glossary

Hardware Id

Has Hardware Connection

Has Pneumatic Control

Has Motor Control

Hash Function

A function used to manipulate the key of an element in a list to identify its location in the list.

Hash Table

The data structure used to store elements using hashing.

Hashing

The technique used for ordering and accessing elements in a list.

High Voltage

Hole Count

Determines the amount of stray X-Rays being generated by the TEM.

Back to Glossary


I

Back to Glossary

Id

Identical Elements

Included Element

Inheritance

A Class may inherit keys and values from another Class. A mechanism for code reuse. Occurs when an Object or Class is based on another Object or Class.

Instance

Can refer generally to any running process, or specifically to an object, as in an Instance of a class. Formally, "Instance" is synonymous with "Object", as they are each a particular value (realization); "Instance" emphasizes the distinct identity of the Object.

Interaction Tool

Interface

A set of Methods that an instance of a Class can respond to. Extender exposes a number of Interfaces used to describe Objects returned from Method calls into Factories; or Objects inheriting other Interfaces.

Invalid Setting

Ion

An atom or molecule that has lost or gained and electron and therefore has a net positive or negative electric charge.

Ion Type

ISEM

Is Coated

Is Connected

Is Default Control

Is Detector Ready

Is In External Scan

Is Pulse Pile up Corrected

Back to Glossary


W

Back to Glossary

Wavelength

The distance on a periodic wave between two succesive points at which the phase is the same. For example, two crests.

WD

Wavelength Dispersive.

WDS

Wavelength Dispersive Spectrometry.

WDX

Wavelength Dispersive X-Ray analysis, or spectrometry. An alternative to Energy Dispersive Specrometry for X-Ray analysis.

Wehnelt Cylinder

An electrode between the cathode (filament) and the anode (ground) in a triode electron gun, used to form the beam and control its current.

Weight Percent

Weight Percent Sigma

Window Type

Working Distance

Working distance (mm) is the distance between the point of focus of the electron beam and the lens.

Back to Glossary


S

Back to Glossary

SAED

Selected Area Diffraction.

Sample Coating

Scale Type

Scan Capability

Scan Setting

Scanned Area

The area the electron beam has scanned, or is about to scan.

Scanning

Process of investigating a specimen by moving a finely focused electron beam in systematic patterns over the surface. The technique results in an image that corresponds to the specimen.

Scintillation Detector

Electron Detector used in SEM or STEM in which electrons are accelerated towards a phosphor, which flouresces to produce light, which is amplified by means of a photomultiplier to produce an electrical signal.

SDD

Silicon Drift Detector. An EDS device that does not require liquid nitrogen for cooling.

Secondary Electrons

Electrons that originate in the specimen and are emitted under influence of the primary beam. They are scattered from sample atoms by interaction with beam electrons. They are produced by an incident electron passing "near" an atom in the specimen, near enough to impart some of its energy to a lower energy electron (usually in the K-shell). This causes a slight energy loss and path change in the incident electron and the ionization of the electron in the specimen atom. This ionized electron then leaves the atom with a very small kinetic energy (5eV) and is then termed a "secondary electron". Each incident electron can produce several secondary electrons.

SEI

Secondary Electron Images.

Secondary Detector Serial Number

Selection Mode

SEM

Scanning Electron Microscope, or Scanning Electron Microscopy. An electron beam is passed through a small number of lenses and is focussed into a fine spot (as small an one nm in diameter) on the specimen surface. The beam is then used to scan in a rectangular raster over the specimen and the intensities of various signals created by interactions between the beam of electrons and the specimen are measured and stored in computer memory.

SEM Quant

SEM Quant Capability

SEM Quant Result

SEM Quant Setting

Semiconductor Detector

Electron Detector used in SEM or TEM in which a high energy electron is detected by the current it generates as it dissipates its energy in a solid-state diode.

Sensor

Sensor Type

Show Details

Show Element Color

Show Peak Label

Show Reset Scales

Show User Annotations

Show Viewer Content

Shutter

A protective device for a Detector. When the Microscope is operated under conditions that generate high energy X-Rays and Electrons that could damage the Detector, the Shutter can be closed to protect it.

Shutter Capability

Shutter Control

Shutter Status

Sigma Level

Sigma Sq (Gausian)

Simulator

For AZtec development purposes simulators allow software to be created and tested without the need for hardware.

Slide

A mechanical device for moving a detector backwards and forwards when inserted into the column.

Slide Capability

Slide Control

Slide Status

Slide Type

Smooth

Spatial Resolution

The ability on a microscope to distinguish small details of an object, thereby making it a major determinant of image resolution.

Specimen Tilt Degrees

Spectrometer

Instrument for obtaining a spectrum.

Spectrum

A display produced by the separation of a complex radiation into its component intensity as a function of energy or wavelength. Spectroscopic data is often represented by a spectrum, a plot of the response of interest as a function of wavelength or frequency. Effectively, a spectrum is a mass of elements found at a particular point, or across a sample. Therefore, a representation of the proportions of individual elements (as in atoms) at the particular beam position, or positions by weight of element.

Spectrum Acquisition Controller

Spectrum Clicked

Spectrum Details

Spectrum Draw Style

Spectrum Noise Peak

Spectrum Smoothing

Spectrum Unit

Spectrum Viewer

Spectrum Viewer Context

Sputter Coater

Instrument for coating a non-conducting specimen with a very thin uniform layer of a conducting element to eliminate artifacts caused by accumulating charge.

Stage

A small platform on a microscope where the specimen is mounted for examination.

Stage Capability

Stage Condition

Stage Connection

Stage Tilt

Stage R

Stage T

Stage X

Stage Y

Stage Z

Status Description (Detector)

STEM

Scanning Transmission Electron Microscope. Works on a specimen that has been thinned to facilitate detection of electrons scattered through the specimen.

Struct

A Class comprised only of Fields.

System

Multiple detectors fitted to a microscope.

Back to Glossary


U

Back to Glossary

Ultramicrotome

Instrument for cutting ultra-thin sections from a specimen prior to examination in the Microscope.

Unset Element

Upper Energy

Back to Glossary


N

Back to Glossary

Namespace

Used in Extender to categorise general areas of functionality.

Nanometre

A unit of length in the metric system, equal to one billionth of a metre.

Nanoscale

Refers to structures with a length scale applicable to nanotechnology, usually cited as 1–100 nanometers.

Nanotechnology

The manipulation of matter on an atomic, molecular, and supramolecular scale.

Noise Peak

Noise Peak Cut Off Energy

Noise Peak Exclude

Noise Peak Include

Noise Peak Mode

Normalize

Normalization

Normalization Energy

Normalization Mark

Number of Channels

Number of Ions

Back to Glossary


R

Back to Glossary

Raster

The track of the beam in a SEM or STEM. It is analogous to eye movements when reading a book; left to right, word by word, down the page line by line.

Real Time Seconds

Refraction

Changes in direction of a beam of electrons as the beam passes through regions in which its propagation speed changes.

Resolution

The number of pixels in an image.

Region

Rectangle Region

REM

Reflection Electron Microscope. As TEM, but a reflected beamof scattered electrons are detected.

Back to Glossary


L

Back to Glossary

Large Area Map

Lattice

A regular three dimensional array of atoms in a crystal.

Lens

In a Light Microscope, a piece of transparent material with one or more curved surfaces, which us used to focus light. In an Electron Microscope, a similar effect is achieved on a beam of elctrons by using a magentic (or electrostatic) field.

Line Type

Live Time

Live Time Seconds

LN

Liquid nitrogen. A method of cooling a detector.

LN2 Alarm

LN2 Sensor

LN2 State

Lower Energy

Low Mag Interlock

Back to Glossary


G

Back to Glossary

Gausian

Goniometer

Specimen stage allowing linear movement of the specimen in two or more directions and rotation of the specimen in its own plane and tilting about one or more axes which remain fixed with respect to the beam.

Ground State

The lowest energy state of an atom, typically achieved when all electrons are in place and the atom possesses no charge.

Back to Glossary


Y

Back to Glossary

Y-Axis

Y-Axis Auto Scale

Y-Axis Count

Y-Axis Linear Scale

Y-Axis Locked

Y-Axis Logarithmic Scale

Y-Axis Scale

Y-Axis Unit

Y-Axis Type

Y-Axis Unit

Y-Axis Visible

Back to Glossary